/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.518
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.518 2011/12/28 15:55:30 graaff Exp $
4
5 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
6 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
7
8 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
9 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
10 keyworded, bug 332593.
11
12 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
13 Block older versions of packages that are no longer compatible. Remove
14 ancient blocks on packags long gone from the tree.
15
16 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
17 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
18 Remove old versions.
19
20*ruby-1.9.3_p0 (18 Dec 2011)
21
22 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
23 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
24 suite which need to be diagnosed first.
25
26 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
27 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
28 #332593).
29
30 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
31 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
32 #332593).
33
34 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
35 alpha/ia64/s390/sh/sparc stable wrt #386369
36
37*ruby-1.9.3_rc1 (22 Oct 2011)
38
39 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
40 Version bump.
41
42 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
43 arm stable, bug #386369
44
45 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
46 x86 stable, bug 386369
47
48 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
49 Stable for HPPA (bug #386369).
50
51 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
52 ppc/ppc64 stable wrt #386369
53
54 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
55 Stable on amd64 wrt bug #386369
56
57 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
58 Remove vulnerable version, bug 386369.
59
60*ruby-1.8.7_p352 (30 Aug 2011)
61
62 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
63 +ruby-1.8.7_p352.ebuild:
64 Patchlevel bump for ruby:1.8. Removing old version
65
66*ruby-1.9.2_p290 (30 Aug 2011)
67
68 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
69 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
70 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
71 old patchlevels.
72
73 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
74 ruby-1.8.7_p334-r2.ebuild:
75 ppc/ppc64 stable wrt #378691
76
77*ruby-1.8.7_p334-r2 (22 Jul 2011)
78
79 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
80 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
81 for chasing down upstream and us.
82
83 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
84 Added ~mips, bug 332593
85
86 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
87 ruby-1.8.7_p334-r1.ebuild:
88 ppc64 stable wrt #369141
89
90 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
91 ia64/s390/sh/sparc stable wrt #369141
92
93 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
94 Stable for HPPA (bug #369141).
95
96 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
97 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
98
99 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
100 arm/x86 stable, bug #369141
101
102 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
103 Stable on amd64 wrt bug #369141
104
105 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
106 ruby-1.8.7_p334-r1.ebuild:
107 Stable on alpha, bug #369141
108
109*ruby-1.8.7_p334-r1 (31 May 2011)
110
111 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
112 Revision bump for security bug 369141 (CVE-2011-0188)
113
114*ruby-1.9.2-r1 (16 May 2011)
115
116 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
117 Don't remove racc files since all other ruby targets ship these files
118 themselves as well. Closes bug 363419.
119
120 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
121 ruby-1.8.7_p334.ebuild:
122 Remove old version. Remove obsolete and unused old-style virtual/ruby.
123
124 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
125 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
126
127 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
128 Add append-flags -mieee on sh, bug #357559
129
130 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
131 alpha/arm/ia64/s390/sh stable wrt #355439
132
133 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
134 Marked ~ppc64 wrt #332593
135
136 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
137 ruby-1.8.7_p334.ebuild:
138 x86 stable wrt security bug #355439
139
140 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
141 ruby-1.8.7_p334.ebuild:
142 ppc/ppc64 stable wrt #355439
143
144 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
145 Stable on amd64 wrt bug #355439
146
147 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
148 Stable for HPPA (bug #355439).
149
150*ruby-1.8.7_p334 (19 Feb 2011)
151
152 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
153 Version bump 1.8.7 series, security bug 355439
154
155 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
156 ruby-1.9.2.ebuild:
157 Remove PROVIDE for old-style virtual/ruby per bug 265054.
158
159 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
160 Remove masked ruby 1.8.6 per bug 332597.
161
162 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
163 -ruby-1.9.2_rc2.ebuild:
164 Removing old and vulnerable ebuilds
165
166 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
167 Marking ruby-1.8.7_p302 ppc64 for bug 332957
168
169 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
170 alpha/ia64/s390/sh/sparc stable wrt #332957
171
172*ruby-1.9.2 (24 Aug 2010)
173
174 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
175 metadata.xml:
176 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
177 and x86-fbsd due to a new dependency on rdoc.
178
179 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
180 arm stable, bug #332957
181
182 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
183 ruby-1.8.7_p302.ebuild:
184 x86 stable wrt security bug #332957
185
186 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
187 Stable on amd64 wrt bug #332957
188
189 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
190 Stable for PPC (bug #332957).
191
192 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
193 Stable for HPPA (bug #332957).
194
195*ruby-1.8.7_p302 (21 Aug 2010)
196
197 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
198 +ruby-1.8.7_p302.ebuild:
199 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
200 installation path.
201
202*ruby-1.8.6_p399 (19 Aug 2010)
203
204 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
205 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
206 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
207 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
208 installation path (reported by the x86 team in bug 332597)
209
210*ruby-1.9.2_rc2-r1 (18 Aug 2010)
211
212 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
213 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
214 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
215 the rubygems loading code. Add USE flag for psych.
216
217 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
218 ruby-1.9.2_rc2.ebuild:
219 Remove two keepdir that will try to keep an empty path, closes bug
220 #333163.
221
222 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
223 Marked ~ppc (bug #332593).
224
225 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
226 ruby-1.9.2_rc2.ebuild:
227 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
228
229 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
230 ruby-1.8.7_p299.ebuild:
231 Bump eselect-ruby dependency
232
233 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
234 -ruby-1.9.1_p429.ebuild:
235 Remove ebuild that is not target for unmask anyway.
236
237 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
238 ruby-1.9.2_rc2.ebuild:
239 Try 2 to fix the berkdb 5 issue on 1.9.
240
241 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
242 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
243 ruby-1.9.2_rc2.ebuild:
244 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
245 support for adding new patchsets without bumping the revision for all the
246 old ebuilds as well.
247
248*ruby-1.9.2_rc2 (14 Jul 2010)
249
250 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
251 +ruby-1.9.2_rc2.ebuild:
252 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
253 might cause _further_ build failures as it changed slightly behaviour.
254 You're going to need to rebuild rubygems and then all the packages
255 previously installed after upgrading to this.
256
257 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
258 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
259 -ruby-1.9.1_p376.ebuild:
260 Cleanup old versions.
261
262*ruby-1.9.1_p429 (04 Jul 2010)
263
264 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
265 +ruby-1.9.1_p429.ebuild:
266 Version bump to new 1.9.1 release.
267
268*ruby-1.8.7_p299 (23 Jun 2010)
269
270 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 +ruby-1.8.7_p299.ebuild:
272 Version bump.
273
274 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
275 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
276 remove useless comments
277
278 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
279 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
280 ruby-1.9.1_p376.ebuild:
281 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
282 dev.gentoo.org now.
283
284 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 ruby-1.9.1_p376.ebuild:
286 Use the correct RUBYLIB.
287
288*ruby-1.8.7_p249-r2 (18 May 2010)
289*ruby-1.8.6_p388-r1 (18 May 2010)
290
291 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
292 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
293 ruby-1.9.1_p376.ebuild, metadata.xml:
294 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
295 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
296 add USE flags for ncurses, readline and libedit, and properly depend on
297 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
298 Emacs versions support ruby-mode themselves and it should be even more
299 updated.
300
301*ruby-1.8.7_p249-r1 (06 May 2010)
302
303 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
304 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
305 309789 by Sune Kloppenborg Jeppesen.
306
307 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
308 ruby-1.8.7_p249.ebuild:
309 Use $PVR instead of $PV in patchset names
310
311 06 May 2010; Alex Legler <a3li@gentoo.org>
312 -files/ruby-1.8.6-memory-leak.diff,
313 -files/ruby18-mkmf-parallel-install.patch,
314 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
315 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
316 Remove old version. Cleanup in files/
317
318*ruby-1.9.1_p376 (01 May 2010)
319
320 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
321 Version bump. Fixes security bugs 296052 and 300468. No longer installs
322 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
323 instead.
324
325 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
326 -ruby-1.8.7_p174-r1.ebuild:
327 Remove vulnerable ebuilds, 300468
328
329 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
330 ruby-1.8.7_p249.ebuild:
331 amd64 stable, security bug 300468
332
333 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
334 ruby-1.8.7_p249.ebuild:
335 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
336
337 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
338 Stable for HPPA (bug #300468).
339
340 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
341 Stable for HPPA (bug #300468).
342
343 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
344 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
345
346 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
347 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
348
349 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
350 ruby-1.8.6_p388.ebuild:
351 stable x86, security bug 300468
352
353 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
354 ruby-1.8.7_p249.ebuild:
355 stable x86, security bug 300468
356
357*ruby-1.8.6_p388 (10 Jan 2010)
358
359 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
360 +ruby-1.8.6_p388.ebuild:
361 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
362 version. The new ebuild also has the fix for bug 168939.
363
364*ruby-1.8.7_p249 (10 Jan 2010)
365
366 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
367 +ruby-1.8.7_p249.ebuild:
368 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
369 version
370
371 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
372 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
373
374*ruby-1.8.7_p248 (25 Dec 2009)
375
376 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
377 Version bump
378
379 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
380 Remove old version.
381
382 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
383 Remove old version.
384
385 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
386 ia64/s390/sh stable wrt #288699
387
388 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
389 stable sparc, bug 288699
390
391 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
392 arm stable, bug #288699
393
394 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
395 amd64/x86 stable, bug #288699
396
397 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
398 ruby-1.8.7_p174-r1.ebuild:
399 Stable on alpha, bug #288699
400
401 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
402 ppc stable #288699
403
404 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
405 Stable for HPPA (bug #288699).
406
407 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
408 Marked ~hppa too.
409
410*ruby-1.8.7_p174-r1 (06 Oct 2009)
411
412 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
413 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
414 eselect-ruby cleanup feature.
415
416*ruby-1.9.1_p243 (09 Sep 2009)
417
418 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
419 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
420 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
421 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
422 -files/ruby19-rubygems-proxy.patch,
423 -files/ruby-1.9.1_p129-parallelmake.patch,
424 -files/ruby19-mkmf-parallel-install.patch:
425 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
426 168939. Cleaning up old patches.
427
428*ruby-1.8.6_p383 (20 Aug 2009)
429
430 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
431 Patchlevel bump.
432
433 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
434 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
435 ruby-1.9.1_p129-r1.ebuild:
436 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
437
438 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
439 Removing vulnerable ebuild, bug 273213.
440
441 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
442 Marking ruby-1.8.6_p369 ppc for bug 273213
443
444 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
445 ruby-1.9.1_p129-r1.ebuild:
446 Prepend our library path instead of overwriting it during src_install.
447 Thanks to the reporter of bug #274824.
448
449*ruby-1.8.7_p174 (18 Jun 2009)
450
451 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
452 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
453 Replacing 187_p173 with _p174 because of a regression. Unifying the
454 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
455 patchsets.
456
457 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
458 Marking ruby-1.8.6_p369 ppc64 for bug 273213
459
460 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
461 arm/ia64/s390/sh/sparc stable wrt #273213
462
463 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
464 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
465 Removing old version, minor cleanup
466
467 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
468 -files/ruby-1.8.6-openssl.patch,
469 -files/ruby-1.8.6-shortname_constants.patch,
470 -files/ruby-1.8.6_p111-r13657.patch,
471 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
472 Removing vulnerable old Ruby version and stale patches, bug 274108.
473
474 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
475 ruby-1.8.6_p369.ebuild:
476 Stable on alpha, bug #273213
477
478 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
479 Stable for HPPA (bug #273213).
480
481 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
482 ruby-1.8.6_p369.ebuild:
483 stable x86, security bug 273213
484
485 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
486 amd64 stable, security bug 273213.
487
488*ruby-1.8.7_p173 (10 Jun 2009)
489*ruby-1.8.6_p369 (10 Jun 2009)
490
491 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
492 +ruby-1.8.7_p173.ebuild:
493 Version bumps for bug #273213.
494
495*ruby-1.9.1_p129-r1 (27 May 2009)
496
497 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
498 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
499 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
500 +files/ruby-1.9.1_p129-parallelmake.patch:
501 Revision bump, add patches 1) to make Ruby behave more similarly between
502 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
503 extensions (undefined symbols in them will cause abort at runtime 3) to
504 remove a concurrency issue when building the dl extension that could
505 result in a broken dl.so.
506
507 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
508 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
509 Don't block rdoc-2 or later (which may enter Portage one day as it's
510 needed by some Rakefiles).
511
512 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
513 ruby-1.9.1_p129.ebuild:
514 Add ~x86-fbsd keyword.
515
516 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
517 keyword ~sparc-fbsd, bug #252315
518
519*ruby-1.9.1_p129 (15 May 2009)
520
521 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
522 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
523 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
524 included in every release.
525
526 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
527 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
528 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
529 ruby-1.8.7_p160.ebuild:
530 Removing vulnerable versions (#268515), fixing license (#233747).
531
532 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
533 Stable for HPPA (bug #268515).
534
535 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
536 Adapting rubygems notice.
537
538 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
539 amd64 stable, bug #268515.
540
541 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
542 arm/ia64/s390/sh/sparc stable wrt #268515
543
544 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
545 ruby-1.8.6_p368.ebuild:
546 stable x86, security bug 268515
547
548 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
549 ruby-1.8.6_p368.ebuild:
550 Stable on alpha, bug #268515
551
552 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
553 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
554
555*ruby-1.8.7_p160 (07 May 2009)
556*ruby-1.8.6_p368 (07 May 2009)
557
558 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
559 +ruby-1.8.7_p160.ebuild:
560 Version bump as per secbug 268515. NB: These are the first ebuilds that
561 no longer use ruby-config.
562
563*ruby-1.9.1-r1 (03 Apr 2009)
564*ruby-1.8.7_p72-r11 (03 Apr 2009)
565*ruby-1.8.6_p287-r13 (03 Apr 2009)
566
567 03 Apr 2009; Alex Legler <a3li@gentoo.org>
568 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
569 +files/ruby18-mkmf-parallel-install.patch,
570 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
571 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
572 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
573 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
574 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
575 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
576 happy.
577
578*ruby-1.9.1 (21 Mar 2009)
579
580 21 Mar 2009; Alex Legler <a3li@gentoo.org>
581 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
582 +ruby-1.9.1.ebuild:
583 Adding Ruby 1.9.1 for preliminary testing
584
585 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
586 ruby-1.8.6_p287-r12.ebuild:
587 Marked ~ppc for bug #252315.
588
589 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
590 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
591 bug 261982.
592
593 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
594 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
595 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
596 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
597 Cleanup
598
599*ruby-1.8.7_p72-r10 (07 Mar 2009)
600
601 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
602 +ruby-1.8.7_p72-r10.ebuild:
603 Add a revision of ruby 1.8.7 using eselect ruby.
604
605 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
606 ~mips keyworded, bug #252315.
607
608 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
609 ruby-1.8.6_p287-r5.ebuild:
610 ppc stable, bug #260006
611
612 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
613 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
614
615 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
616 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
617 Fixing Tk USE flag test, bug 258893.
618
619 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
620 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
621
622 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
623 ruby-1.8.6_p287-r5.ebuild:
624 amd64 stable wrt security bug #260006
625
626 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
627 Stable for HPPA (bug #260006).
628
629 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
630 ruby-1.8.6_p287-r5.ebuild:
631 Stable on alpha, bug #260006
632
633*ruby-1.8.7_p72-r2 (23 Feb 2009)
634*ruby-1.8.6_p287-r12 (23 Feb 2009)
635*ruby-1.8.6_p287-r5 (23 Feb 2009)
636
637 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
638 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
639 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
640 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
641 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
642 now before compilation if Tk useflags don't match) and 230748 (adding
643 --enable-option-checking=no for newer versions of autoconf).
644
645 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
646 arm/ia64/s390/sh/sparc stable wrt #254307
647
648 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
649 ruby-1.8.6_p287-r4.ebuild:
650 Stable on alpha, bug #254307
651
652 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
653 ruby-1.8.6_p287-r11.ebuild:
654 keyword ~x86-fbsd, bug #252315
655
656 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
657 ppc stable #254307
658
659 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
660 amd64/x86 stable, bug #254307
661
662 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
663 stable ppc64, bug 254307
664
665 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
666 Stable for HPPA (bug #254307).
667
668 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
669 ruby-1.8.6_p287-r11.ebuild:
670 Marked ~hppa (bug #252315).
671
672*ruby-1.8.6_p287-r11 (11 Jan 2009)
673
674 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
675 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
676 +ruby-1.8.6_p287-r11.ebuild:
677 Backport conditional definition of missing openssl functions from ruby 1.8.7.
678 Fixes #254307.
679
680 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
681 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
682
683 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
684 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
685
686 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
687 ruby-1.8.6_p287-r10.ebuild:
688 Add ~sparc keyword, bug #252315
689
690*ruby-1.8.6_p287-r10 (23 Dec 2008)
691
692 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
693 +ruby-1.8.6_p287-r10.ebuild:
694 Version bump which switches from ruby-config to eselect-ruby. Dropped most
695 keywords since eselect-ruby does not yet have these keywords.
696
697 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
698 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
699 Revert the ruby-config changes. We can't remove them until we provide an
700 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
701 for breaking things as mentioned in bug #251833.
702
703 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
704 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
705 ruby-1.8.7_p72-r1.ebuild:
706 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
707 Thanks for the people noticing this in bug #251833.
708
709 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
710 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
711 ruby-1.8.7_p72-r1.ebuild:
712 Drop dependency on ruby-config, which will be removed from the tree. We
713 currently only have one major version of ruby in the tree (Ruby 1.8), so there
714 is no need for ruby-config at this moment. For newer versions of Ruby we will
715 use eselect-ruby, which can be found in the ruby overlay at the moment.
716
717 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
718 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
719 Use mirror://ruby in SRC_URI, fixes #237392.
720
721 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
722 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
723 -ruby-1.8.7_p72.ebuild:
724 Remove old versions. Leave one old stable version with cjk support.
725
726*ruby-1.8.6_p287-r3 (29 Nov 2008)
727
728 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
729 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
730 +ruby-1.8.6_p287-r3.ebuild:
731 Fix our expansion limit patch according to debian bug report
732 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
733 make sure people will pick up the fixed version. Thanks to Alex Legler for
734 mentioning the patch.
735
736*ruby-1.8.7_p72-r1 (26 Nov 2008)
737*ruby-1.8.6_p287-r2 (26 Nov 2008)
738
739 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
740 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
741 +ruby-1.8.7_p72-r1.ebuild:
742 Fix problem with shortname constants #247790, already fixed in upstream SVN.
743 Thanks to Alex Legler for providing the patch.
744
745 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
746 -ruby-1.8.6_p287.ebuild:
747 Remove versions that will not become stable
748
749 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
750 ruby-1.8.6_p287-r1.ebuild:
751 ppc stable, bug #225465
752
753 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
754 ruby-1.8.6_p287-r1.ebuild:
755 amd64 stable wrt security bug #225465
756
757 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
758 alpha/ia64/x86 stable wrt #225465
759
760 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
761 ruby-1.8.6_p287-r1.ebuild:
762 Sparc stable --- Security Bug #225465 --- good since late August.
763
764 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
765 Stable on ppc64; bug #225465
766
767 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
768 Stable for HPPA (bug #225465).
769
770*ruby-1.8.6_p287-r1 (29 Aug 2008)
771
772 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
773 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
774 +ruby-1.8.6_p287-r1.ebuild:
775 Fix REXML security issues, bug #236060.
776
777 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
778 Add GLEP 56 USE flag descriptions.
779
780*ruby-1.8.7_p72 (15 Aug 2008)
781
782 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
783 +ruby-1.8.7_p72.ebuild:
784 bump 1.8.7 to latest patch release
785
786*ruby-1.8.6_p287 (11 Aug 2008)
787
788 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
789 Version bump for brown paper bag relelease.
790
791 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
792 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
793 Remove broken version in favor of the just-added 1.8.6_p286
794
795*ruby-1.8.6_p286 (10 Aug 2008)
796
797 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
798 Version bump to latest released version of ruby 1.8.6. This version fixes the
799 security issues reported in #225465 and #234224. The cjk USE flag has been
800 dropped since no compatible patches have been released yet.
801
802 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
803 ruby-1.8.6_p230.ebuild:
804 drop cjk from SRC_URI as well
805
806 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
807 Drop cjk support since the most recent oniguruma patches no longer apply to
808 this version, #230111.
809
810 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
811 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
812 Try to fix the security issues reported in #225465 for ruby 1.8.6.
813 Unfortunately the official p230 has a change which causes segmentation faults
814 for applications like Rails and RSpec, so we are reverting that specific
815 change.
816
817*ruby-1.8.7_p22 (29 Jun 2008)
818
819 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
820 +ruby-1.8.7_p22.ebuild:
821 bump 1.8.7 for security fix
822
823 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
824 nevermind, don't bump this yet
825
826*ruby-1.8.6_p230 (20 Jun 2008)
827
828 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
829 version bump
830
831*ruby-1.8.7 (10 Jun 2008)
832
833 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
834 +ruby-1.8.7.ebuild:
835 bump 1.8.7 to final
836
837*ruby-1.8.7_pre2 (21 Apr 2008)
838
839 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
840 +ruby-1.8.7_pre2.ebuild:
841 Version Bump
842
843*ruby-1.8.7_pre1 (16 Apr 2008)
844
845 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
846 Version bump. Drop cjk until a new version of oniguruma appears.
847
848 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
849 amd64 stable, bug 212264
850
851 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
852 Stable for HPPA (bug #212264).
853
854 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
855 ruby-1.8.6_p114.ebuild:
856 ppc stable, bug #212264
857
858 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
859 alpha/ia64 stable wrt #212264
860
861 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
862 ruby-1.8.6_p114.ebuild:
863 stable x86, security bug 212264
864
865 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
866 Sparc stable, Security Bug #212264, builds and installs, initial tests run
867 as expected.
868
869 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
870 Marking ruby-1.8.6_p114 ppc64 for bug 212264
871
872*ruby-1.8.6_p114 (05 Mar 2008)
873
874 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
875 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
876 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
877 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
878 Version bump for #212264. Remove old ebuilds.
879
880 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
881 alpha/ia64 stable wrt #208916
882
883 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
884 Stable on ppc wrt bug 208916
885
886 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
887 x86 stable, bug #208916
888
889 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
890 ruby-1.8.6_p111-r1.ebuild:
891 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
892
893 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
894 -files/ruby-1.8.6-exit-status.patch,
895 -files/ruby-1.8.6_p110-net-http-p111.patch,
896 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
897 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
898 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
899 Remove old versions
900
901 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
902 Stable on ppc64
903
904 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
905 Stable on amd64; bug 199191
906
907 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
908 alpha/ia64/sparc stable wrt #199191
909
910 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
911 Remove now-obsolete warning about coreutils versions, #203156.
912
913 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
914 Stable for HPPA (bug #199191).
915
916*ruby-1.8.6_p111-r1 (23 Dec 2007)
917
918 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
919 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
920 ssl USE flags. Patch to p113.
921
922 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
923 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
924
925 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
926 x86 stable, security bug #199191
927
928*ruby-1.8.6_p111 (23 Dec 2007)
929
930 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
931 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
932 Version bump with patch for bug #199191
933
934 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
935 Move dependency on (X)Emacs modes to PDEPEND.
936
937 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
938 Add back ~hppa keyword now that XEmacs support files have been keyworded,
939 bug 196413
940
941*ruby-1.8.6_p110-r2 (21 Oct 2007)
942
943 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
944 +ruby-1.8.6_p110-r2.ebuild:
945 Add emacs and xemacs USE flags and use them to pull in the correct editing
946 mode for each. Had to drop several arch keywords as reported on bug 196413.
947
948 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
949 amd64 stable, security bug 194236
950
951 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
952 ruby-1.8.6_p110-r1.ebuild:
953 Stable on ppc64; bug #194236
954
955 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
956 amd64 stable, security bug 194236
957
958 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
959 Stable for HPPA (bug #194236).
960
961 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
962 alpha/ia64/sparc stable wrt security #194236
963
964 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
965 ruby-1.8.6_p110-r1.ebuild:
966 ppc stable, bug #194236
967
968 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
969 ruby-1.8.6_p110-r1.ebuild:
970 stable x86, security bug 194236
971
972 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
973 ruby-1.8.5_p113.ebuild:
974 stable x86, security bug 194236
975
976 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
977 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
978 -ruby-1.8.6_p110.ebuild:
979 Remove old versions
980
981*ruby-1.8.6_p110-r1 (30 Sep 2007)
982*ruby-1.8.5_p113 (30 Sep 2007)
983
984 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
985 +files/ruby-1.8.5_p113-net-http-p114.patch,
986 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
987 +ruby-1.8.6_p110-r1.ebuild:
988 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
989 using 1.8.6-p110 as base ebuild.
990
991 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
992 More fixes from gentoo-dev and graaff
993
994 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
995 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
996
997*ruby-1.8.6_p110 (24 Sep 2007)
998
999 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1000 Version bump
1001
1002*ruby-1.8.6_p36-r4 (26 Aug 2007)
1003
1004 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1005 +ruby-1.8.6_p36-r4.ebuild:
1006 Use user LDFLAGS, #181436
1007
1008 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1009 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1010 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1011 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1012
1013 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1014 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1015 -ruby-1.8.6_p36-r2.ebuild:
1016 Remove some older versions that will not be promoted to stable, keeping at
1017 least one version of each release.
1018
1019 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1020 ruby-1.8.6_p36-r3.ebuild:
1021 (QA) RESTRICT clean up.
1022
1023*ruby-1.8.6_p36-r3 (04 Jul 2007)
1024
1025 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1026 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1027 fixed memory leak loading .so bug #182946
1028
1029 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1030 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1031 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1032 ruby-1.8.6_p36-r2.ebuild:
1033 (QA) RESTRICT clean up.
1034
1035 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1036 Re-add stable keyword for alpha as per bug #181110
1037
1038 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1039 Back to ~amd64 wrt bug 181110
1040
1041 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1042 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1043
1044*ruby-1.8.6_p36-r2 (20 Jun 2007)
1045
1046 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1047 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1048
1049*ruby-1.8.6_p36-r1 (18 Jun 2007)
1050
1051 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1052 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1053 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1054 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1055 spbecker
1056
1057 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1058 Stable on amd64 wrt bug 181110
1059
1060*ruby-1.8.6_p36 (12 Jun 2007)
1061
1062 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1063 Version Bump. Bug #181379
1064
1065 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1066 Stable on mips, per #181110.
1067
1068 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1069 Stable on ppc wrt bug 181110
1070
1071 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1072 Stable for HPPA (bug #181110).
1073
1074 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1075 alpha/ia64/x86 stable wrt #181110
1076
1077 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1078 Stable on sparc wrt #181110
1079
1080 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1081 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1082
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1083 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1084 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1085 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1086 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.518

  ViewVC Help
Powered by ViewVC 1.1.20