/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.527
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.527 2012/02/05 22:06:30 maekke Exp $
4
5 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
6 add ~arm, bug #332593
7
8 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
9 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
10
11 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
12 x86 stable wrt bug #396301
13
14 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
15 Stable for HPPA (bug #396301).
16
17 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
18 Stable for ppc/ppc64; bug #396301
19
20 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
21 Marked ~hppa (bug #332593).
22
23 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
24 Add back ~alpha keyword now that rubygems is keyworded.
25
26 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
27 Stable for AMD64, wrt security bug #396301
28
29*ruby-1.8.7_p357 (28 Dec 2011)
30
31 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
32 Version bump for security bug 396301.
33
34 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
35 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
36
37 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
38 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
39 keyworded, bug 332593.
40
41 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
42 Block older versions of packages that are no longer compatible. Remove
43 ancient blocks on packags long gone from the tree.
44
45 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
46 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
47 Remove old versions.
48
49*ruby-1.9.3_p0 (18 Dec 2011)
50
51 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
52 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
53 suite which need to be diagnosed first.
54
55 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
56 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
57 #332593).
58
59 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
60 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
61 #332593).
62
63 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
64 alpha/ia64/s390/sh/sparc stable wrt #386369
65
66*ruby-1.9.3_rc1 (22 Oct 2011)
67
68 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
69 Version bump.
70
71 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
72 arm stable, bug #386369
73
74 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
75 x86 stable, bug 386369
76
77 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
78 Stable for HPPA (bug #386369).
79
80 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
81 ppc/ppc64 stable wrt #386369
82
83 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
84 Stable on amd64 wrt bug #386369
85
86 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
87 Remove vulnerable version, bug 386369.
88
89*ruby-1.8.7_p352 (30 Aug 2011)
90
91 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
92 +ruby-1.8.7_p352.ebuild:
93 Patchlevel bump for ruby:1.8. Removing old version
94
95*ruby-1.9.2_p290 (30 Aug 2011)
96
97 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
98 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
99 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
100 old patchlevels.
101
102 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
103 ruby-1.8.7_p334-r2.ebuild:
104 ppc/ppc64 stable wrt #378691
105
106*ruby-1.8.7_p334-r2 (22 Jul 2011)
107
108 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
109 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
110 for chasing down upstream and us.
111
112 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
113 Added ~mips, bug 332593
114
115 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
116 ruby-1.8.7_p334-r1.ebuild:
117 ppc64 stable wrt #369141
118
119 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
120 ia64/s390/sh/sparc stable wrt #369141
121
122 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
123 Stable for HPPA (bug #369141).
124
125 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
126 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
127
128 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
129 arm/x86 stable, bug #369141
130
131 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
132 Stable on amd64 wrt bug #369141
133
134 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
135 ruby-1.8.7_p334-r1.ebuild:
136 Stable on alpha, bug #369141
137
138*ruby-1.8.7_p334-r1 (31 May 2011)
139
140 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
141 Revision bump for security bug 369141 (CVE-2011-0188)
142
143*ruby-1.9.2-r1 (16 May 2011)
144
145 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
146 Don't remove racc files since all other ruby targets ship these files
147 themselves as well. Closes bug 363419.
148
149 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
150 ruby-1.8.7_p334.ebuild:
151 Remove old version. Remove obsolete and unused old-style virtual/ruby.
152
153 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
154 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
155
156 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
157 Add append-flags -mieee on sh, bug #357559
158
159 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
160 alpha/arm/ia64/s390/sh stable wrt #355439
161
162 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
163 Marked ~ppc64 wrt #332593
164
165 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
166 ruby-1.8.7_p334.ebuild:
167 x86 stable wrt security bug #355439
168
169 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
170 ruby-1.8.7_p334.ebuild:
171 ppc/ppc64 stable wrt #355439
172
173 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
174 Stable on amd64 wrt bug #355439
175
176 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
177 Stable for HPPA (bug #355439).
178
179*ruby-1.8.7_p334 (19 Feb 2011)
180
181 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
182 Version bump 1.8.7 series, security bug 355439
183
184 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
185 ruby-1.9.2.ebuild:
186 Remove PROVIDE for old-style virtual/ruby per bug 265054.
187
188 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
189 Remove masked ruby 1.8.6 per bug 332597.
190
191 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
192 -ruby-1.9.2_rc2.ebuild:
193 Removing old and vulnerable ebuilds
194
195 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
196 Marking ruby-1.8.7_p302 ppc64 for bug 332957
197
198 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
199 alpha/ia64/s390/sh/sparc stable wrt #332957
200
201*ruby-1.9.2 (24 Aug 2010)
202
203 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
204 metadata.xml:
205 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
206 and x86-fbsd due to a new dependency on rdoc.
207
208 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
209 arm stable, bug #332957
210
211 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
212 ruby-1.8.7_p302.ebuild:
213 x86 stable wrt security bug #332957
214
215 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
216 Stable on amd64 wrt bug #332957
217
218 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
219 Stable for PPC (bug #332957).
220
221 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
222 Stable for HPPA (bug #332957).
223
224*ruby-1.8.7_p302 (21 Aug 2010)
225
226 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
227 +ruby-1.8.7_p302.ebuild:
228 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
229 installation path.
230
231*ruby-1.8.6_p399 (19 Aug 2010)
232
233 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
234 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
235 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
236 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
237 installation path (reported by the x86 team in bug 332597)
238
239*ruby-1.9.2_rc2-r1 (18 Aug 2010)
240
241 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
242 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
243 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
244 the rubygems loading code. Add USE flag for psych.
245
246 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
247 ruby-1.9.2_rc2.ebuild:
248 Remove two keepdir that will try to keep an empty path, closes bug
249 #333163.
250
251 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
252 Marked ~ppc (bug #332593).
253
254 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
255 ruby-1.9.2_rc2.ebuild:
256 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
257
258 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
259 ruby-1.8.7_p299.ebuild:
260 Bump eselect-ruby dependency
261
262 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
263 -ruby-1.9.1_p429.ebuild:
264 Remove ebuild that is not target for unmask anyway.
265
266 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
267 ruby-1.9.2_rc2.ebuild:
268 Try 2 to fix the berkdb 5 issue on 1.9.
269
270 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
272 ruby-1.9.2_rc2.ebuild:
273 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
274 support for adding new patchsets without bumping the revision for all the
275 old ebuilds as well.
276
277*ruby-1.9.2_rc2 (14 Jul 2010)
278
279 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
280 +ruby-1.9.2_rc2.ebuild:
281 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
282 might cause _further_ build failures as it changed slightly behaviour.
283 You're going to need to rebuild rubygems and then all the packages
284 previously installed after upgrading to this.
285
286 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
287 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
288 -ruby-1.9.1_p376.ebuild:
289 Cleanup old versions.
290
291*ruby-1.9.1_p429 (04 Jul 2010)
292
293 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
294 +ruby-1.9.1_p429.ebuild:
295 Version bump to new 1.9.1 release.
296
297*ruby-1.8.7_p299 (23 Jun 2010)
298
299 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
300 +ruby-1.8.7_p299.ebuild:
301 Version bump.
302
303 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
304 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
305 remove useless comments
306
307 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
308 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
309 ruby-1.9.1_p376.ebuild:
310 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
311 dev.gentoo.org now.
312
313 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
314 ruby-1.9.1_p376.ebuild:
315 Use the correct RUBYLIB.
316
317*ruby-1.8.7_p249-r2 (18 May 2010)
318*ruby-1.8.6_p388-r1 (18 May 2010)
319
320 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
321 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
322 ruby-1.9.1_p376.ebuild, metadata.xml:
323 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
324 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
325 add USE flags for ncurses, readline and libedit, and properly depend on
326 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
327 Emacs versions support ruby-mode themselves and it should be even more
328 updated.
329
330*ruby-1.8.7_p249-r1 (06 May 2010)
331
332 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
333 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
334 309789 by Sune Kloppenborg Jeppesen.
335
336 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
337 ruby-1.8.7_p249.ebuild:
338 Use $PVR instead of $PV in patchset names
339
340 06 May 2010; Alex Legler <a3li@gentoo.org>
341 -files/ruby-1.8.6-memory-leak.diff,
342 -files/ruby18-mkmf-parallel-install.patch,
343 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
344 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
345 Remove old version. Cleanup in files/
346
347*ruby-1.9.1_p376 (01 May 2010)
348
349 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
350 Version bump. Fixes security bugs 296052 and 300468. No longer installs
351 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
352 instead.
353
354 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
355 -ruby-1.8.7_p174-r1.ebuild:
356 Remove vulnerable ebuilds, 300468
357
358 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
359 ruby-1.8.7_p249.ebuild:
360 amd64 stable, security bug 300468
361
362 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
363 ruby-1.8.7_p249.ebuild:
364 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
365
366 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
367 Stable for HPPA (bug #300468).
368
369 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
370 Stable for HPPA (bug #300468).
371
372 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
373 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
374
375 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
376 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
377
378 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
379 ruby-1.8.6_p388.ebuild:
380 stable x86, security bug 300468
381
382 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
383 ruby-1.8.7_p249.ebuild:
384 stable x86, security bug 300468
385
386*ruby-1.8.6_p388 (10 Jan 2010)
387
388 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
389 +ruby-1.8.6_p388.ebuild:
390 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
391 version. The new ebuild also has the fix for bug 168939.
392
393*ruby-1.8.7_p249 (10 Jan 2010)
394
395 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
396 +ruby-1.8.7_p249.ebuild:
397 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
398 version
399
400 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
401 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
402
403*ruby-1.8.7_p248 (25 Dec 2009)
404
405 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
406 Version bump
407
408 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
409 Remove old version.
410
411 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
412 Remove old version.
413
414 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
415 ia64/s390/sh stable wrt #288699
416
417 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
418 stable sparc, bug 288699
419
420 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
421 arm stable, bug #288699
422
423 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
424 amd64/x86 stable, bug #288699
425
426 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
427 ruby-1.8.7_p174-r1.ebuild:
428 Stable on alpha, bug #288699
429
430 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
431 ppc stable #288699
432
433 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
434 Stable for HPPA (bug #288699).
435
436 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
437 Marked ~hppa too.
438
439*ruby-1.8.7_p174-r1 (06 Oct 2009)
440
441 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
442 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
443 eselect-ruby cleanup feature.
444
445*ruby-1.9.1_p243 (09 Sep 2009)
446
447 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
448 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
449 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
450 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
451 -files/ruby19-rubygems-proxy.patch,
452 -files/ruby-1.9.1_p129-parallelmake.patch,
453 -files/ruby19-mkmf-parallel-install.patch:
454 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
455 168939. Cleaning up old patches.
456
457*ruby-1.8.6_p383 (20 Aug 2009)
458
459 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
460 Patchlevel bump.
461
462 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
463 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
464 ruby-1.9.1_p129-r1.ebuild:
465 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
466
467 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
468 Removing vulnerable ebuild, bug 273213.
469
470 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
471 Marking ruby-1.8.6_p369 ppc for bug 273213
472
473 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
474 ruby-1.9.1_p129-r1.ebuild:
475 Prepend our library path instead of overwriting it during src_install.
476 Thanks to the reporter of bug #274824.
477
478*ruby-1.8.7_p174 (18 Jun 2009)
479
480 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
481 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
482 Replacing 187_p173 with _p174 because of a regression. Unifying the
483 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
484 patchsets.
485
486 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
487 Marking ruby-1.8.6_p369 ppc64 for bug 273213
488
489 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
490 arm/ia64/s390/sh/sparc stable wrt #273213
491
492 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
493 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
494 Removing old version, minor cleanup
495
496 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
497 -files/ruby-1.8.6-openssl.patch,
498 -files/ruby-1.8.6-shortname_constants.patch,
499 -files/ruby-1.8.6_p111-r13657.patch,
500 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
501 Removing vulnerable old Ruby version and stale patches, bug 274108.
502
503 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
504 ruby-1.8.6_p369.ebuild:
505 Stable on alpha, bug #273213
506
507 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
508 Stable for HPPA (bug #273213).
509
510 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
511 ruby-1.8.6_p369.ebuild:
512 stable x86, security bug 273213
513
514 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
515 amd64 stable, security bug 273213.
516
517*ruby-1.8.7_p173 (10 Jun 2009)
518*ruby-1.8.6_p369 (10 Jun 2009)
519
520 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
521 +ruby-1.8.7_p173.ebuild:
522 Version bumps for bug #273213.
523
524*ruby-1.9.1_p129-r1 (27 May 2009)
525
526 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
527 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
528 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
529 +files/ruby-1.9.1_p129-parallelmake.patch:
530 Revision bump, add patches 1) to make Ruby behave more similarly between
531 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
532 extensions (undefined symbols in them will cause abort at runtime 3) to
533 remove a concurrency issue when building the dl extension that could
534 result in a broken dl.so.
535
536 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
537 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
538 Don't block rdoc-2 or later (which may enter Portage one day as it's
539 needed by some Rakefiles).
540
541 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
542 ruby-1.9.1_p129.ebuild:
543 Add ~x86-fbsd keyword.
544
545 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
546 keyword ~sparc-fbsd, bug #252315
547
548*ruby-1.9.1_p129 (15 May 2009)
549
550 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
551 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
552 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
553 included in every release.
554
555 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
556 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
557 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
558 ruby-1.8.7_p160.ebuild:
559 Removing vulnerable versions (#268515), fixing license (#233747).
560
561 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
562 Stable for HPPA (bug #268515).
563
564 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
565 Adapting rubygems notice.
566
567 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
568 amd64 stable, bug #268515.
569
570 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
571 arm/ia64/s390/sh/sparc stable wrt #268515
572
573 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
574 ruby-1.8.6_p368.ebuild:
575 stable x86, security bug 268515
576
577 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
578 ruby-1.8.6_p368.ebuild:
579 Stable on alpha, bug #268515
580
581 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
582 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
583
584*ruby-1.8.7_p160 (07 May 2009)
585*ruby-1.8.6_p368 (07 May 2009)
586
587 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
588 +ruby-1.8.7_p160.ebuild:
589 Version bump as per secbug 268515. NB: These are the first ebuilds that
590 no longer use ruby-config.
591
592*ruby-1.9.1-r1 (03 Apr 2009)
593*ruby-1.8.7_p72-r11 (03 Apr 2009)
594*ruby-1.8.6_p287-r13 (03 Apr 2009)
595
596 03 Apr 2009; Alex Legler <a3li@gentoo.org>
597 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
598 +files/ruby18-mkmf-parallel-install.patch,
599 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
600 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
601 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
602 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
603 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
604 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
605 happy.
606
607*ruby-1.9.1 (21 Mar 2009)
608
609 21 Mar 2009; Alex Legler <a3li@gentoo.org>
610 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
611 +ruby-1.9.1.ebuild:
612 Adding Ruby 1.9.1 for preliminary testing
613
614 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
615 ruby-1.8.6_p287-r12.ebuild:
616 Marked ~ppc for bug #252315.
617
618 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
619 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
620 bug 261982.
621
622 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
623 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
624 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
625 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
626 Cleanup
627
628*ruby-1.8.7_p72-r10 (07 Mar 2009)
629
630 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
631 +ruby-1.8.7_p72-r10.ebuild:
632 Add a revision of ruby 1.8.7 using eselect ruby.
633
634 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
635 ~mips keyworded, bug #252315.
636
637 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
638 ruby-1.8.6_p287-r5.ebuild:
639 ppc stable, bug #260006
640
641 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
642 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
643
644 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
645 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
646 Fixing Tk USE flag test, bug 258893.
647
648 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
649 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
650
651 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
652 ruby-1.8.6_p287-r5.ebuild:
653 amd64 stable wrt security bug #260006
654
655 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
656 Stable for HPPA (bug #260006).
657
658 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
659 ruby-1.8.6_p287-r5.ebuild:
660 Stable on alpha, bug #260006
661
662*ruby-1.8.7_p72-r2 (23 Feb 2009)
663*ruby-1.8.6_p287-r12 (23 Feb 2009)
664*ruby-1.8.6_p287-r5 (23 Feb 2009)
665
666 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
667 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
668 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
669 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
670 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
671 now before compilation if Tk useflags don't match) and 230748 (adding
672 --enable-option-checking=no for newer versions of autoconf).
673
674 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
675 arm/ia64/s390/sh/sparc stable wrt #254307
676
677 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
678 ruby-1.8.6_p287-r4.ebuild:
679 Stable on alpha, bug #254307
680
681 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
682 ruby-1.8.6_p287-r11.ebuild:
683 keyword ~x86-fbsd, bug #252315
684
685 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
686 ppc stable #254307
687
688 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
689 amd64/x86 stable, bug #254307
690
691 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
692 stable ppc64, bug 254307
693
694 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
695 Stable for HPPA (bug #254307).
696
697 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
698 ruby-1.8.6_p287-r11.ebuild:
699 Marked ~hppa (bug #252315).
700
701*ruby-1.8.6_p287-r11 (11 Jan 2009)
702
703 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
704 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
705 +ruby-1.8.6_p287-r11.ebuild:
706 Backport conditional definition of missing openssl functions from ruby 1.8.7.
707 Fixes #254307.
708
709 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
710 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
711
712 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
713 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
714
715 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
716 ruby-1.8.6_p287-r10.ebuild:
717 Add ~sparc keyword, bug #252315
718
719*ruby-1.8.6_p287-r10 (23 Dec 2008)
720
721 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
722 +ruby-1.8.6_p287-r10.ebuild:
723 Version bump which switches from ruby-config to eselect-ruby. Dropped most
724 keywords since eselect-ruby does not yet have these keywords.
725
726 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
727 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
728 Revert the ruby-config changes. We can't remove them until we provide an
729 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
730 for breaking things as mentioned in bug #251833.
731
732 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
733 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
734 ruby-1.8.7_p72-r1.ebuild:
735 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
736 Thanks for the people noticing this in bug #251833.
737
738 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
739 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
740 ruby-1.8.7_p72-r1.ebuild:
741 Drop dependency on ruby-config, which will be removed from the tree. We
742 currently only have one major version of ruby in the tree (Ruby 1.8), so there
743 is no need for ruby-config at this moment. For newer versions of Ruby we will
744 use eselect-ruby, which can be found in the ruby overlay at the moment.
745
746 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
747 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
748 Use mirror://ruby in SRC_URI, fixes #237392.
749
750 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
751 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
752 -ruby-1.8.7_p72.ebuild:
753 Remove old versions. Leave one old stable version with cjk support.
754
755*ruby-1.8.6_p287-r3 (29 Nov 2008)
756
757 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
758 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
759 +ruby-1.8.6_p287-r3.ebuild:
760 Fix our expansion limit patch according to debian bug report
761 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
762 make sure people will pick up the fixed version. Thanks to Alex Legler for
763 mentioning the patch.
764
765*ruby-1.8.7_p72-r1 (26 Nov 2008)
766*ruby-1.8.6_p287-r2 (26 Nov 2008)
767
768 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
769 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
770 +ruby-1.8.7_p72-r1.ebuild:
771 Fix problem with shortname constants #247790, already fixed in upstream SVN.
772 Thanks to Alex Legler for providing the patch.
773
774 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
775 -ruby-1.8.6_p287.ebuild:
776 Remove versions that will not become stable
777
778 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
779 ruby-1.8.6_p287-r1.ebuild:
780 ppc stable, bug #225465
781
782 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
783 ruby-1.8.6_p287-r1.ebuild:
784 amd64 stable wrt security bug #225465
785
786 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
787 alpha/ia64/x86 stable wrt #225465
788
789 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
790 ruby-1.8.6_p287-r1.ebuild:
791 Sparc stable --- Security Bug #225465 --- good since late August.
792
793 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
794 Stable on ppc64; bug #225465
795
796 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
797 Stable for HPPA (bug #225465).
798
799*ruby-1.8.6_p287-r1 (29 Aug 2008)
800
801 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
802 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
803 +ruby-1.8.6_p287-r1.ebuild:
804 Fix REXML security issues, bug #236060.
805
806 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
807 Add GLEP 56 USE flag descriptions.
808
809*ruby-1.8.7_p72 (15 Aug 2008)
810
811 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
812 +ruby-1.8.7_p72.ebuild:
813 bump 1.8.7 to latest patch release
814
815*ruby-1.8.6_p287 (11 Aug 2008)
816
817 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
818 Version bump for brown paper bag relelease.
819
820 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
821 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
822 Remove broken version in favor of the just-added 1.8.6_p286
823
824*ruby-1.8.6_p286 (10 Aug 2008)
825
826 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
827 Version bump to latest released version of ruby 1.8.6. This version fixes the
828 security issues reported in #225465 and #234224. The cjk USE flag has been
829 dropped since no compatible patches have been released yet.
830
831 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
832 ruby-1.8.6_p230.ebuild:
833 drop cjk from SRC_URI as well
834
835 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
836 Drop cjk support since the most recent oniguruma patches no longer apply to
837 this version, #230111.
838
839 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
840 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
841 Try to fix the security issues reported in #225465 for ruby 1.8.6.
842 Unfortunately the official p230 has a change which causes segmentation faults
843 for applications like Rails and RSpec, so we are reverting that specific
844 change.
845
846*ruby-1.8.7_p22 (29 Jun 2008)
847
848 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
849 +ruby-1.8.7_p22.ebuild:
850 bump 1.8.7 for security fix
851
852 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
853 nevermind, don't bump this yet
854
855*ruby-1.8.6_p230 (20 Jun 2008)
856
857 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
858 version bump
859
860*ruby-1.8.7 (10 Jun 2008)
861
862 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
863 +ruby-1.8.7.ebuild:
864 bump 1.8.7 to final
865
866*ruby-1.8.7_pre2 (21 Apr 2008)
867
868 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
869 +ruby-1.8.7_pre2.ebuild:
870 Version Bump
871
872*ruby-1.8.7_pre1 (16 Apr 2008)
873
874 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
875 Version bump. Drop cjk until a new version of oniguruma appears.
876
877 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
878 amd64 stable, bug 212264
879
880 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
881 Stable for HPPA (bug #212264).
882
883 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
884 ruby-1.8.6_p114.ebuild:
885 ppc stable, bug #212264
886
887 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
888 alpha/ia64 stable wrt #212264
889
890 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
891 ruby-1.8.6_p114.ebuild:
892 stable x86, security bug 212264
893
894 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
895 Sparc stable, Security Bug #212264, builds and installs, initial tests run
896 as expected.
897
898 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
899 Marking ruby-1.8.6_p114 ppc64 for bug 212264
900
901*ruby-1.8.6_p114 (05 Mar 2008)
902
903 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
904 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
905 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
906 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
907 Version bump for #212264. Remove old ebuilds.
908
909 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
910 alpha/ia64 stable wrt #208916
911
912 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
913 Stable on ppc wrt bug 208916
914
915 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
916 x86 stable, bug #208916
917
918 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
919 ruby-1.8.6_p111-r1.ebuild:
920 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
921
922 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
923 -files/ruby-1.8.6-exit-status.patch,
924 -files/ruby-1.8.6_p110-net-http-p111.patch,
925 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
926 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
927 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
928 Remove old versions
929
930 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
931 Stable on ppc64
932
933 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
934 Stable on amd64; bug 199191
935
936 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
937 alpha/ia64/sparc stable wrt #199191
938
939 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
940 Remove now-obsolete warning about coreutils versions, #203156.
941
942 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
943 Stable for HPPA (bug #199191).
944
945*ruby-1.8.6_p111-r1 (23 Dec 2007)
946
947 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
948 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
949 ssl USE flags. Patch to p113.
950
951 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
952 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
953
954 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
955 x86 stable, security bug #199191
956
957*ruby-1.8.6_p111 (23 Dec 2007)
958
959 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
960 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
961 Version bump with patch for bug #199191
962
963 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
964 Move dependency on (X)Emacs modes to PDEPEND.
965
966 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
967 Add back ~hppa keyword now that XEmacs support files have been keyworded,
968 bug 196413
969
970*ruby-1.8.6_p110-r2 (21 Oct 2007)
971
972 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
973 +ruby-1.8.6_p110-r2.ebuild:
974 Add emacs and xemacs USE flags and use them to pull in the correct editing
975 mode for each. Had to drop several arch keywords as reported on bug 196413.
976
977 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
978 amd64 stable, security bug 194236
979
980 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
981 ruby-1.8.6_p110-r1.ebuild:
982 Stable on ppc64; bug #194236
983
984 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
985 amd64 stable, security bug 194236
986
987 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
988 Stable for HPPA (bug #194236).
989
990 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
991 alpha/ia64/sparc stable wrt security #194236
992
993 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
994 ruby-1.8.6_p110-r1.ebuild:
995 ppc stable, bug #194236
996
997 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
998 ruby-1.8.6_p110-r1.ebuild:
999 stable x86, security bug 194236
1000
1001 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1002 ruby-1.8.5_p113.ebuild:
1003 stable x86, security bug 194236
1004
1005 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1006 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1007 -ruby-1.8.6_p110.ebuild:
1008 Remove old versions
1009
1010*ruby-1.8.6_p110-r1 (30 Sep 2007)
1011*ruby-1.8.5_p113 (30 Sep 2007)
1012
1013 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1014 +files/ruby-1.8.5_p113-net-http-p114.patch,
1015 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1016 +ruby-1.8.6_p110-r1.ebuild:
1017 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1018 using 1.8.6-p110 as base ebuild.
1019
1020 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1021 More fixes from gentoo-dev and graaff
1022
1023 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1024 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1025
1026*ruby-1.8.6_p110 (24 Sep 2007)
1027
1028 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1029 Version bump
1030
1031*ruby-1.8.6_p36-r4 (26 Aug 2007)
1032
1033 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1034 +ruby-1.8.6_p36-r4.ebuild:
1035 Use user LDFLAGS, #181436
1036
1037 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1038 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1039 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1040 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1041
1042 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1043 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1044 -ruby-1.8.6_p36-r2.ebuild:
1045 Remove some older versions that will not be promoted to stable, keeping at
1046 least one version of each release.
1047
1048 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1049 ruby-1.8.6_p36-r3.ebuild:
1050 (QA) RESTRICT clean up.
1051
1052*ruby-1.8.6_p36-r3 (04 Jul 2007)
1053
1054 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1055 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1056 fixed memory leak loading .so bug #182946
1057
1058 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1059 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1060 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1061 ruby-1.8.6_p36-r2.ebuild:
1062 (QA) RESTRICT clean up.
1063
1064 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1065 Re-add stable keyword for alpha as per bug #181110
1066
1067 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1068 Back to ~amd64 wrt bug 181110
1069
1070 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1071 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1072
1073*ruby-1.8.6_p36-r2 (20 Jun 2007)
1074
1075 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1076 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1077
1078*ruby-1.8.6_p36-r1 (18 Jun 2007)
1079
1080 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1081 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1082 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1083 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1084 spbecker
1085
1086 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1087 Stable on amd64 wrt bug 181110
1088
1089*ruby-1.8.6_p36 (12 Jun 2007)
1090
1091 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1092 Version Bump. Bug #181379
1093
1094 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1095 Stable on mips, per #181110.
1096
1097 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1098 Stable on ppc wrt bug 181110
1099
1100 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1101 Stable for HPPA (bug #181110).
1102
1103 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1104 alpha/ia64/x86 stable wrt #181110
1105
1106 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1107 Stable on sparc wrt #181110
1108
1109 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1110 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1111
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1112 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1113 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1114 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1115 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.527

  ViewVC Help
Powered by ViewVC 1.1.20