/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.528
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.528 2012/02/18 08:35:39 graaff Exp $
4
5*ruby-1.9.3_p125 (18 Feb 2012)
6
7 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
8 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
9
10 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
11 add ~arm, bug #332593
12
13 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
14 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
15
16 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
17 x86 stable wrt bug #396301
18
19 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
20 Stable for HPPA (bug #396301).
21
22 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
23 Stable for ppc/ppc64; bug #396301
24
25 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
26 Marked ~hppa (bug #332593).
27
28 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
29 Add back ~alpha keyword now that rubygems is keyworded.
30
31 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
32 Stable for AMD64, wrt security bug #396301
33
34*ruby-1.8.7_p357 (28 Dec 2011)
35
36 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
37 Version bump for security bug 396301.
38
39 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
40 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
41
42 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
43 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
44 keyworded, bug 332593.
45
46 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
47 Block older versions of packages that are no longer compatible. Remove
48 ancient blocks on packags long gone from the tree.
49
50 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
51 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
52 Remove old versions.
53
54*ruby-1.9.3_p0 (18 Dec 2011)
55
56 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
57 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
58 suite which need to be diagnosed first.
59
60 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
61 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
62 #332593).
63
64 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
65 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
66 #332593).
67
68 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
69 alpha/ia64/s390/sh/sparc stable wrt #386369
70
71*ruby-1.9.3_rc1 (22 Oct 2011)
72
73 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
74 Version bump.
75
76 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
77 arm stable, bug #386369
78
79 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
80 x86 stable, bug 386369
81
82 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
83 Stable for HPPA (bug #386369).
84
85 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
86 ppc/ppc64 stable wrt #386369
87
88 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
89 Stable on amd64 wrt bug #386369
90
91 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
92 Remove vulnerable version, bug 386369.
93
94*ruby-1.8.7_p352 (30 Aug 2011)
95
96 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
97 +ruby-1.8.7_p352.ebuild:
98 Patchlevel bump for ruby:1.8. Removing old version
99
100*ruby-1.9.2_p290 (30 Aug 2011)
101
102 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
103 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
104 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
105 old patchlevels.
106
107 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
108 ruby-1.8.7_p334-r2.ebuild:
109 ppc/ppc64 stable wrt #378691
110
111*ruby-1.8.7_p334-r2 (22 Jul 2011)
112
113 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
114 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
115 for chasing down upstream and us.
116
117 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
118 Added ~mips, bug 332593
119
120 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
121 ruby-1.8.7_p334-r1.ebuild:
122 ppc64 stable wrt #369141
123
124 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
125 ia64/s390/sh/sparc stable wrt #369141
126
127 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
128 Stable for HPPA (bug #369141).
129
130 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
131 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
132
133 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
134 arm/x86 stable, bug #369141
135
136 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
137 Stable on amd64 wrt bug #369141
138
139 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
140 ruby-1.8.7_p334-r1.ebuild:
141 Stable on alpha, bug #369141
142
143*ruby-1.8.7_p334-r1 (31 May 2011)
144
145 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
146 Revision bump for security bug 369141 (CVE-2011-0188)
147
148*ruby-1.9.2-r1 (16 May 2011)
149
150 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
151 Don't remove racc files since all other ruby targets ship these files
152 themselves as well. Closes bug 363419.
153
154 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
155 ruby-1.8.7_p334.ebuild:
156 Remove old version. Remove obsolete and unused old-style virtual/ruby.
157
158 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
159 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
160
161 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
162 Add append-flags -mieee on sh, bug #357559
163
164 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
165 alpha/arm/ia64/s390/sh stable wrt #355439
166
167 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
168 Marked ~ppc64 wrt #332593
169
170 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
171 ruby-1.8.7_p334.ebuild:
172 x86 stable wrt security bug #355439
173
174 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
175 ruby-1.8.7_p334.ebuild:
176 ppc/ppc64 stable wrt #355439
177
178 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
179 Stable on amd64 wrt bug #355439
180
181 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
182 Stable for HPPA (bug #355439).
183
184*ruby-1.8.7_p334 (19 Feb 2011)
185
186 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
187 Version bump 1.8.7 series, security bug 355439
188
189 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
190 ruby-1.9.2.ebuild:
191 Remove PROVIDE for old-style virtual/ruby per bug 265054.
192
193 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
194 Remove masked ruby 1.8.6 per bug 332597.
195
196 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
197 -ruby-1.9.2_rc2.ebuild:
198 Removing old and vulnerable ebuilds
199
200 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
201 Marking ruby-1.8.7_p302 ppc64 for bug 332957
202
203 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
204 alpha/ia64/s390/sh/sparc stable wrt #332957
205
206*ruby-1.9.2 (24 Aug 2010)
207
208 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
209 metadata.xml:
210 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
211 and x86-fbsd due to a new dependency on rdoc.
212
213 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
214 arm stable, bug #332957
215
216 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
217 ruby-1.8.7_p302.ebuild:
218 x86 stable wrt security bug #332957
219
220 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
221 Stable on amd64 wrt bug #332957
222
223 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
224 Stable for PPC (bug #332957).
225
226 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
227 Stable for HPPA (bug #332957).
228
229*ruby-1.8.7_p302 (21 Aug 2010)
230
231 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
232 +ruby-1.8.7_p302.ebuild:
233 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
234 installation path.
235
236*ruby-1.8.6_p399 (19 Aug 2010)
237
238 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
239 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
240 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
241 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
242 installation path (reported by the x86 team in bug 332597)
243
244*ruby-1.9.2_rc2-r1 (18 Aug 2010)
245
246 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
247 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
248 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
249 the rubygems loading code. Add USE flag for psych.
250
251 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
252 ruby-1.9.2_rc2.ebuild:
253 Remove two keepdir that will try to keep an empty path, closes bug
254 #333163.
255
256 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
257 Marked ~ppc (bug #332593).
258
259 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
260 ruby-1.9.2_rc2.ebuild:
261 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
262
263 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
264 ruby-1.8.7_p299.ebuild:
265 Bump eselect-ruby dependency
266
267 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
268 -ruby-1.9.1_p429.ebuild:
269 Remove ebuild that is not target for unmask anyway.
270
271 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
272 ruby-1.9.2_rc2.ebuild:
273 Try 2 to fix the berkdb 5 issue on 1.9.
274
275 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
276 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
277 ruby-1.9.2_rc2.ebuild:
278 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
279 support for adding new patchsets without bumping the revision for all the
280 old ebuilds as well.
281
282*ruby-1.9.2_rc2 (14 Jul 2010)
283
284 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 +ruby-1.9.2_rc2.ebuild:
286 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
287 might cause _further_ build failures as it changed slightly behaviour.
288 You're going to need to rebuild rubygems and then all the packages
289 previously installed after upgrading to this.
290
291 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
292 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
293 -ruby-1.9.1_p376.ebuild:
294 Cleanup old versions.
295
296*ruby-1.9.1_p429 (04 Jul 2010)
297
298 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
299 +ruby-1.9.1_p429.ebuild:
300 Version bump to new 1.9.1 release.
301
302*ruby-1.8.7_p299 (23 Jun 2010)
303
304 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
305 +ruby-1.8.7_p299.ebuild:
306 Version bump.
307
308 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
309 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
310 remove useless comments
311
312 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
313 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
314 ruby-1.9.1_p376.ebuild:
315 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
316 dev.gentoo.org now.
317
318 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
319 ruby-1.9.1_p376.ebuild:
320 Use the correct RUBYLIB.
321
322*ruby-1.8.7_p249-r2 (18 May 2010)
323*ruby-1.8.6_p388-r1 (18 May 2010)
324
325 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
326 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
327 ruby-1.9.1_p376.ebuild, metadata.xml:
328 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
329 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
330 add USE flags for ncurses, readline and libedit, and properly depend on
331 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
332 Emacs versions support ruby-mode themselves and it should be even more
333 updated.
334
335*ruby-1.8.7_p249-r1 (06 May 2010)
336
337 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
338 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
339 309789 by Sune Kloppenborg Jeppesen.
340
341 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
342 ruby-1.8.7_p249.ebuild:
343 Use $PVR instead of $PV in patchset names
344
345 06 May 2010; Alex Legler <a3li@gentoo.org>
346 -files/ruby-1.8.6-memory-leak.diff,
347 -files/ruby18-mkmf-parallel-install.patch,
348 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
349 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
350 Remove old version. Cleanup in files/
351
352*ruby-1.9.1_p376 (01 May 2010)
353
354 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
355 Version bump. Fixes security bugs 296052 and 300468. No longer installs
356 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
357 instead.
358
359 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
360 -ruby-1.8.7_p174-r1.ebuild:
361 Remove vulnerable ebuilds, 300468
362
363 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
364 ruby-1.8.7_p249.ebuild:
365 amd64 stable, security bug 300468
366
367 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
368 ruby-1.8.7_p249.ebuild:
369 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
370
371 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
372 Stable for HPPA (bug #300468).
373
374 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
375 Stable for HPPA (bug #300468).
376
377 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
378 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
379
380 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
381 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
382
383 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
384 ruby-1.8.6_p388.ebuild:
385 stable x86, security bug 300468
386
387 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
388 ruby-1.8.7_p249.ebuild:
389 stable x86, security bug 300468
390
391*ruby-1.8.6_p388 (10 Jan 2010)
392
393 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
394 +ruby-1.8.6_p388.ebuild:
395 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
396 version. The new ebuild also has the fix for bug 168939.
397
398*ruby-1.8.7_p249 (10 Jan 2010)
399
400 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
401 +ruby-1.8.7_p249.ebuild:
402 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
403 version
404
405 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
406 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
407
408*ruby-1.8.7_p248 (25 Dec 2009)
409
410 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
411 Version bump
412
413 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
414 Remove old version.
415
416 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
417 Remove old version.
418
419 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
420 ia64/s390/sh stable wrt #288699
421
422 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
423 stable sparc, bug 288699
424
425 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
426 arm stable, bug #288699
427
428 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
429 amd64/x86 stable, bug #288699
430
431 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
432 ruby-1.8.7_p174-r1.ebuild:
433 Stable on alpha, bug #288699
434
435 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
436 ppc stable #288699
437
438 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
439 Stable for HPPA (bug #288699).
440
441 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
442 Marked ~hppa too.
443
444*ruby-1.8.7_p174-r1 (06 Oct 2009)
445
446 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
447 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
448 eselect-ruby cleanup feature.
449
450*ruby-1.9.1_p243 (09 Sep 2009)
451
452 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
453 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
454 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
455 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
456 -files/ruby19-rubygems-proxy.patch,
457 -files/ruby-1.9.1_p129-parallelmake.patch,
458 -files/ruby19-mkmf-parallel-install.patch:
459 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
460 168939. Cleaning up old patches.
461
462*ruby-1.8.6_p383 (20 Aug 2009)
463
464 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
465 Patchlevel bump.
466
467 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
468 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
469 ruby-1.9.1_p129-r1.ebuild:
470 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
471
472 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
473 Removing vulnerable ebuild, bug 273213.
474
475 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
476 Marking ruby-1.8.6_p369 ppc for bug 273213
477
478 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
479 ruby-1.9.1_p129-r1.ebuild:
480 Prepend our library path instead of overwriting it during src_install.
481 Thanks to the reporter of bug #274824.
482
483*ruby-1.8.7_p174 (18 Jun 2009)
484
485 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
486 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
487 Replacing 187_p173 with _p174 because of a regression. Unifying the
488 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
489 patchsets.
490
491 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
492 Marking ruby-1.8.6_p369 ppc64 for bug 273213
493
494 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
495 arm/ia64/s390/sh/sparc stable wrt #273213
496
497 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
498 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
499 Removing old version, minor cleanup
500
501 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
502 -files/ruby-1.8.6-openssl.patch,
503 -files/ruby-1.8.6-shortname_constants.patch,
504 -files/ruby-1.8.6_p111-r13657.patch,
505 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
506 Removing vulnerable old Ruby version and stale patches, bug 274108.
507
508 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
509 ruby-1.8.6_p369.ebuild:
510 Stable on alpha, bug #273213
511
512 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
513 Stable for HPPA (bug #273213).
514
515 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
516 ruby-1.8.6_p369.ebuild:
517 stable x86, security bug 273213
518
519 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
520 amd64 stable, security bug 273213.
521
522*ruby-1.8.7_p173 (10 Jun 2009)
523*ruby-1.8.6_p369 (10 Jun 2009)
524
525 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
526 +ruby-1.8.7_p173.ebuild:
527 Version bumps for bug #273213.
528
529*ruby-1.9.1_p129-r1 (27 May 2009)
530
531 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
532 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
533 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
534 +files/ruby-1.9.1_p129-parallelmake.patch:
535 Revision bump, add patches 1) to make Ruby behave more similarly between
536 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
537 extensions (undefined symbols in them will cause abort at runtime 3) to
538 remove a concurrency issue when building the dl extension that could
539 result in a broken dl.so.
540
541 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
542 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
543 Don't block rdoc-2 or later (which may enter Portage one day as it's
544 needed by some Rakefiles).
545
546 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
547 ruby-1.9.1_p129.ebuild:
548 Add ~x86-fbsd keyword.
549
550 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
551 keyword ~sparc-fbsd, bug #252315
552
553*ruby-1.9.1_p129 (15 May 2009)
554
555 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
556 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
557 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
558 included in every release.
559
560 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
561 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
562 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
563 ruby-1.8.7_p160.ebuild:
564 Removing vulnerable versions (#268515), fixing license (#233747).
565
566 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
567 Stable for HPPA (bug #268515).
568
569 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
570 Adapting rubygems notice.
571
572 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
573 amd64 stable, bug #268515.
574
575 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
576 arm/ia64/s390/sh/sparc stable wrt #268515
577
578 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
579 ruby-1.8.6_p368.ebuild:
580 stable x86, security bug 268515
581
582 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
583 ruby-1.8.6_p368.ebuild:
584 Stable on alpha, bug #268515
585
586 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
587 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
588
589*ruby-1.8.7_p160 (07 May 2009)
590*ruby-1.8.6_p368 (07 May 2009)
591
592 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
593 +ruby-1.8.7_p160.ebuild:
594 Version bump as per secbug 268515. NB: These are the first ebuilds that
595 no longer use ruby-config.
596
597*ruby-1.9.1-r1 (03 Apr 2009)
598*ruby-1.8.7_p72-r11 (03 Apr 2009)
599*ruby-1.8.6_p287-r13 (03 Apr 2009)
600
601 03 Apr 2009; Alex Legler <a3li@gentoo.org>
602 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
603 +files/ruby18-mkmf-parallel-install.patch,
604 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
605 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
606 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
607 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
608 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
609 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
610 happy.
611
612*ruby-1.9.1 (21 Mar 2009)
613
614 21 Mar 2009; Alex Legler <a3li@gentoo.org>
615 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
616 +ruby-1.9.1.ebuild:
617 Adding Ruby 1.9.1 for preliminary testing
618
619 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
620 ruby-1.8.6_p287-r12.ebuild:
621 Marked ~ppc for bug #252315.
622
623 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
624 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
625 bug 261982.
626
627 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
628 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
629 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
630 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
631 Cleanup
632
633*ruby-1.8.7_p72-r10 (07 Mar 2009)
634
635 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
636 +ruby-1.8.7_p72-r10.ebuild:
637 Add a revision of ruby 1.8.7 using eselect ruby.
638
639 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
640 ~mips keyworded, bug #252315.
641
642 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
643 ruby-1.8.6_p287-r5.ebuild:
644 ppc stable, bug #260006
645
646 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
647 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
648
649 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
650 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
651 Fixing Tk USE flag test, bug 258893.
652
653 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
654 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
655
656 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
657 ruby-1.8.6_p287-r5.ebuild:
658 amd64 stable wrt security bug #260006
659
660 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
661 Stable for HPPA (bug #260006).
662
663 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
664 ruby-1.8.6_p287-r5.ebuild:
665 Stable on alpha, bug #260006
666
667*ruby-1.8.7_p72-r2 (23 Feb 2009)
668*ruby-1.8.6_p287-r12 (23 Feb 2009)
669*ruby-1.8.6_p287-r5 (23 Feb 2009)
670
671 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
672 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
673 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
674 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
675 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
676 now before compilation if Tk useflags don't match) and 230748 (adding
677 --enable-option-checking=no for newer versions of autoconf).
678
679 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
680 arm/ia64/s390/sh/sparc stable wrt #254307
681
682 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
683 ruby-1.8.6_p287-r4.ebuild:
684 Stable on alpha, bug #254307
685
686 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
687 ruby-1.8.6_p287-r11.ebuild:
688 keyword ~x86-fbsd, bug #252315
689
690 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
691 ppc stable #254307
692
693 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
694 amd64/x86 stable, bug #254307
695
696 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
697 stable ppc64, bug 254307
698
699 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
700 Stable for HPPA (bug #254307).
701
702 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
703 ruby-1.8.6_p287-r11.ebuild:
704 Marked ~hppa (bug #252315).
705
706*ruby-1.8.6_p287-r11 (11 Jan 2009)
707
708 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
709 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
710 +ruby-1.8.6_p287-r11.ebuild:
711 Backport conditional definition of missing openssl functions from ruby 1.8.7.
712 Fixes #254307.
713
714 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
715 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
716
717 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
718 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
719
720 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
721 ruby-1.8.6_p287-r10.ebuild:
722 Add ~sparc keyword, bug #252315
723
724*ruby-1.8.6_p287-r10 (23 Dec 2008)
725
726 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
727 +ruby-1.8.6_p287-r10.ebuild:
728 Version bump which switches from ruby-config to eselect-ruby. Dropped most
729 keywords since eselect-ruby does not yet have these keywords.
730
731 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
732 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
733 Revert the ruby-config changes. We can't remove them until we provide an
734 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
735 for breaking things as mentioned in bug #251833.
736
737 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
738 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
739 ruby-1.8.7_p72-r1.ebuild:
740 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
741 Thanks for the people noticing this in bug #251833.
742
743 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
744 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
745 ruby-1.8.7_p72-r1.ebuild:
746 Drop dependency on ruby-config, which will be removed from the tree. We
747 currently only have one major version of ruby in the tree (Ruby 1.8), so there
748 is no need for ruby-config at this moment. For newer versions of Ruby we will
749 use eselect-ruby, which can be found in the ruby overlay at the moment.
750
751 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
752 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
753 Use mirror://ruby in SRC_URI, fixes #237392.
754
755 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
756 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
757 -ruby-1.8.7_p72.ebuild:
758 Remove old versions. Leave one old stable version with cjk support.
759
760*ruby-1.8.6_p287-r3 (29 Nov 2008)
761
762 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
763 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
764 +ruby-1.8.6_p287-r3.ebuild:
765 Fix our expansion limit patch according to debian bug report
766 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
767 make sure people will pick up the fixed version. Thanks to Alex Legler for
768 mentioning the patch.
769
770*ruby-1.8.7_p72-r1 (26 Nov 2008)
771*ruby-1.8.6_p287-r2 (26 Nov 2008)
772
773 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
774 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
775 +ruby-1.8.7_p72-r1.ebuild:
776 Fix problem with shortname constants #247790, already fixed in upstream SVN.
777 Thanks to Alex Legler for providing the patch.
778
779 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
780 -ruby-1.8.6_p287.ebuild:
781 Remove versions that will not become stable
782
783 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
784 ruby-1.8.6_p287-r1.ebuild:
785 ppc stable, bug #225465
786
787 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
788 ruby-1.8.6_p287-r1.ebuild:
789 amd64 stable wrt security bug #225465
790
791 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
792 alpha/ia64/x86 stable wrt #225465
793
794 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
795 ruby-1.8.6_p287-r1.ebuild:
796 Sparc stable --- Security Bug #225465 --- good since late August.
797
798 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
799 Stable on ppc64; bug #225465
800
801 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
802 Stable for HPPA (bug #225465).
803
804*ruby-1.8.6_p287-r1 (29 Aug 2008)
805
806 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
807 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
808 +ruby-1.8.6_p287-r1.ebuild:
809 Fix REXML security issues, bug #236060.
810
811 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
812 Add GLEP 56 USE flag descriptions.
813
814*ruby-1.8.7_p72 (15 Aug 2008)
815
816 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
817 +ruby-1.8.7_p72.ebuild:
818 bump 1.8.7 to latest patch release
819
820*ruby-1.8.6_p287 (11 Aug 2008)
821
822 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
823 Version bump for brown paper bag relelease.
824
825 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
826 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
827 Remove broken version in favor of the just-added 1.8.6_p286
828
829*ruby-1.8.6_p286 (10 Aug 2008)
830
831 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
832 Version bump to latest released version of ruby 1.8.6. This version fixes the
833 security issues reported in #225465 and #234224. The cjk USE flag has been
834 dropped since no compatible patches have been released yet.
835
836 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
837 ruby-1.8.6_p230.ebuild:
838 drop cjk from SRC_URI as well
839
840 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
841 Drop cjk support since the most recent oniguruma patches no longer apply to
842 this version, #230111.
843
844 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
845 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
846 Try to fix the security issues reported in #225465 for ruby 1.8.6.
847 Unfortunately the official p230 has a change which causes segmentation faults
848 for applications like Rails and RSpec, so we are reverting that specific
849 change.
850
851*ruby-1.8.7_p22 (29 Jun 2008)
852
853 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
854 +ruby-1.8.7_p22.ebuild:
855 bump 1.8.7 for security fix
856
857 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
858 nevermind, don't bump this yet
859
860*ruby-1.8.6_p230 (20 Jun 2008)
861
862 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
863 version bump
864
865*ruby-1.8.7 (10 Jun 2008)
866
867 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
868 +ruby-1.8.7.ebuild:
869 bump 1.8.7 to final
870
871*ruby-1.8.7_pre2 (21 Apr 2008)
872
873 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
874 +ruby-1.8.7_pre2.ebuild:
875 Version Bump
876
877*ruby-1.8.7_pre1 (16 Apr 2008)
878
879 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
880 Version bump. Drop cjk until a new version of oniguruma appears.
881
882 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
883 amd64 stable, bug 212264
884
885 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
886 Stable for HPPA (bug #212264).
887
888 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
889 ruby-1.8.6_p114.ebuild:
890 ppc stable, bug #212264
891
892 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
893 alpha/ia64 stable wrt #212264
894
895 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
896 ruby-1.8.6_p114.ebuild:
897 stable x86, security bug 212264
898
899 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
900 Sparc stable, Security Bug #212264, builds and installs, initial tests run
901 as expected.
902
903 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
904 Marking ruby-1.8.6_p114 ppc64 for bug 212264
905
906*ruby-1.8.6_p114 (05 Mar 2008)
907
908 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
909 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
910 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
911 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
912 Version bump for #212264. Remove old ebuilds.
913
914 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
915 alpha/ia64 stable wrt #208916
916
917 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
918 Stable on ppc wrt bug 208916
919
920 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
921 x86 stable, bug #208916
922
923 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
924 ruby-1.8.6_p111-r1.ebuild:
925 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
926
927 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
928 -files/ruby-1.8.6-exit-status.patch,
929 -files/ruby-1.8.6_p110-net-http-p111.patch,
930 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
931 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
932 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
933 Remove old versions
934
935 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
936 Stable on ppc64
937
938 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
939 Stable on amd64; bug 199191
940
941 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
942 alpha/ia64/sparc stable wrt #199191
943
944 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
945 Remove now-obsolete warning about coreutils versions, #203156.
946
947 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
948 Stable for HPPA (bug #199191).
949
950*ruby-1.8.6_p111-r1 (23 Dec 2007)
951
952 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
953 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
954 ssl USE flags. Patch to p113.
955
956 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
957 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
958
959 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
960 x86 stable, security bug #199191
961
962*ruby-1.8.6_p111 (23 Dec 2007)
963
964 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
965 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
966 Version bump with patch for bug #199191
967
968 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
969 Move dependency on (X)Emacs modes to PDEPEND.
970
971 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
972 Add back ~hppa keyword now that XEmacs support files have been keyworded,
973 bug 196413
974
975*ruby-1.8.6_p110-r2 (21 Oct 2007)
976
977 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
978 +ruby-1.8.6_p110-r2.ebuild:
979 Add emacs and xemacs USE flags and use them to pull in the correct editing
980 mode for each. Had to drop several arch keywords as reported on bug 196413.
981
982 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
983 amd64 stable, security bug 194236
984
985 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
986 ruby-1.8.6_p110-r1.ebuild:
987 Stable on ppc64; bug #194236
988
989 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
990 amd64 stable, security bug 194236
991
992 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
993 Stable for HPPA (bug #194236).
994
995 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
996 alpha/ia64/sparc stable wrt security #194236
997
998 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
999 ruby-1.8.6_p110-r1.ebuild:
1000 ppc stable, bug #194236
1001
1002 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1003 ruby-1.8.6_p110-r1.ebuild:
1004 stable x86, security bug 194236
1005
1006 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1007 ruby-1.8.5_p113.ebuild:
1008 stable x86, security bug 194236
1009
1010 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1011 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1012 -ruby-1.8.6_p110.ebuild:
1013 Remove old versions
1014
1015*ruby-1.8.6_p110-r1 (30 Sep 2007)
1016*ruby-1.8.5_p113 (30 Sep 2007)
1017
1018 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1019 +files/ruby-1.8.5_p113-net-http-p114.patch,
1020 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1021 +ruby-1.8.6_p110-r1.ebuild:
1022 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1023 using 1.8.6-p110 as base ebuild.
1024
1025 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1026 More fixes from gentoo-dev and graaff
1027
1028 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1029 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1030
1031*ruby-1.8.6_p110 (24 Sep 2007)
1032
1033 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1034 Version bump
1035
1036*ruby-1.8.6_p36-r4 (26 Aug 2007)
1037
1038 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1039 +ruby-1.8.6_p36-r4.ebuild:
1040 Use user LDFLAGS, #181436
1041
1042 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1043 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1044 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1045 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1046
1047 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1048 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1049 -ruby-1.8.6_p36-r2.ebuild:
1050 Remove some older versions that will not be promoted to stable, keeping at
1051 least one version of each release.
1052
1053 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1054 ruby-1.8.6_p36-r3.ebuild:
1055 (QA) RESTRICT clean up.
1056
1057*ruby-1.8.6_p36-r3 (04 Jul 2007)
1058
1059 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1060 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1061 fixed memory leak loading .so bug #182946
1062
1063 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1064 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1065 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1066 ruby-1.8.6_p36-r2.ebuild:
1067 (QA) RESTRICT clean up.
1068
1069 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1070 Re-add stable keyword for alpha as per bug #181110
1071
1072 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1073 Back to ~amd64 wrt bug 181110
1074
1075 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1076 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1077
1078*ruby-1.8.6_p36-r2 (20 Jun 2007)
1079
1080 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1081 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1082
1083*ruby-1.8.6_p36-r1 (18 Jun 2007)
1084
1085 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1086 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1087 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1088 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1089 spbecker
1090
1091 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1092 Stable on amd64 wrt bug 181110
1093
1094*ruby-1.8.6_p36 (12 Jun 2007)
1095
1096 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1097 Version Bump. Bug #181379
1098
1099 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1100 Stable on mips, per #181110.
1101
1102 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1103 Stable on ppc wrt bug 181110
1104
1105 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1106 Stable for HPPA (bug #181110).
1107
1108 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1109 alpha/ia64/x86 stable wrt #181110
1110
1111 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1112 Stable on sparc wrt #181110
1113
1114 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1115 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1116
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1117 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1118 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1119 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1120 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.528

  ViewVC Help
Powered by ViewVC 1.1.20