/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.531
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.531 2012/04/26 16:55:14 aballier Exp $
4
5 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
6 keyword ~amd64-fbsd
7
8*ruby-1.8.7_p358 (20 Apr 2012)
9
10 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
11 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
12 Rails 3.2.
13
14 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
15 Add ~x86-fbsd, #332593
16
17*ruby-1.9.3_p125 (18 Feb 2012)
18
19 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
20 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
21
22 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
23 add ~arm, bug #332593
24
25 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
26 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
27
28 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
29 x86 stable wrt bug #396301
30
31 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
32 Stable for HPPA (bug #396301).
33
34 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
35 Stable for ppc/ppc64; bug #396301
36
37 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
38 Marked ~hppa (bug #332593).
39
40 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
41 Add back ~alpha keyword now that rubygems is keyworded.
42
43 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
44 Stable for AMD64, wrt security bug #396301
45
46*ruby-1.8.7_p357 (28 Dec 2011)
47
48 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
49 Version bump for security bug 396301.
50
51 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
52 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
53
54 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
55 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
56 keyworded, bug 332593.
57
58 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
59 Block older versions of packages that are no longer compatible. Remove
60 ancient blocks on packags long gone from the tree.
61
62 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
63 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
64 Remove old versions.
65
66*ruby-1.9.3_p0 (18 Dec 2011)
67
68 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
69 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
70 suite which need to be diagnosed first.
71
72 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
73 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
74 #332593).
75
76 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
77 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
78 #332593).
79
80 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
81 alpha/ia64/s390/sh/sparc stable wrt #386369
82
83*ruby-1.9.3_rc1 (22 Oct 2011)
84
85 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
86 Version bump.
87
88 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
89 arm stable, bug #386369
90
91 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
92 x86 stable, bug 386369
93
94 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
95 Stable for HPPA (bug #386369).
96
97 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
98 ppc/ppc64 stable wrt #386369
99
100 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
101 Stable on amd64 wrt bug #386369
102
103 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
104 Remove vulnerable version, bug 386369.
105
106*ruby-1.8.7_p352 (30 Aug 2011)
107
108 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
109 +ruby-1.8.7_p352.ebuild:
110 Patchlevel bump for ruby:1.8. Removing old version
111
112*ruby-1.9.2_p290 (30 Aug 2011)
113
114 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
115 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
116 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
117 old patchlevels.
118
119 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
120 ruby-1.8.7_p334-r2.ebuild:
121 ppc/ppc64 stable wrt #378691
122
123*ruby-1.8.7_p334-r2 (22 Jul 2011)
124
125 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
126 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
127 for chasing down upstream and us.
128
129 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
130 Added ~mips, bug 332593
131
132 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
133 ruby-1.8.7_p334-r1.ebuild:
134 ppc64 stable wrt #369141
135
136 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
137 ia64/s390/sh/sparc stable wrt #369141
138
139 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
140 Stable for HPPA (bug #369141).
141
142 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
143 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
144
145 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
146 arm/x86 stable, bug #369141
147
148 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
149 Stable on amd64 wrt bug #369141
150
151 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
152 ruby-1.8.7_p334-r1.ebuild:
153 Stable on alpha, bug #369141
154
155*ruby-1.8.7_p334-r1 (31 May 2011)
156
157 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
158 Revision bump for security bug 369141 (CVE-2011-0188)
159
160*ruby-1.9.2-r1 (16 May 2011)
161
162 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
163 Don't remove racc files since all other ruby targets ship these files
164 themselves as well. Closes bug 363419.
165
166 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
167 ruby-1.8.7_p334.ebuild:
168 Remove old version. Remove obsolete and unused old-style virtual/ruby.
169
170 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
171 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
172
173 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
174 Add append-flags -mieee on sh, bug #357559
175
176 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
177 alpha/arm/ia64/s390/sh stable wrt #355439
178
179 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
180 Marked ~ppc64 wrt #332593
181
182 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
183 ruby-1.8.7_p334.ebuild:
184 x86 stable wrt security bug #355439
185
186 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
187 ruby-1.8.7_p334.ebuild:
188 ppc/ppc64 stable wrt #355439
189
190 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
191 Stable on amd64 wrt bug #355439
192
193 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
194 Stable for HPPA (bug #355439).
195
196*ruby-1.8.7_p334 (19 Feb 2011)
197
198 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
199 Version bump 1.8.7 series, security bug 355439
200
201 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
202 ruby-1.9.2.ebuild:
203 Remove PROVIDE for old-style virtual/ruby per bug 265054.
204
205 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
206 Remove masked ruby 1.8.6 per bug 332597.
207
208 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
209 -ruby-1.9.2_rc2.ebuild:
210 Removing old and vulnerable ebuilds
211
212 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
213 Marking ruby-1.8.7_p302 ppc64 for bug 332957
214
215 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
216 alpha/ia64/s390/sh/sparc stable wrt #332957
217
218*ruby-1.9.2 (24 Aug 2010)
219
220 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
221 metadata.xml:
222 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
223 and x86-fbsd due to a new dependency on rdoc.
224
225 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
226 arm stable, bug #332957
227
228 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
229 ruby-1.8.7_p302.ebuild:
230 x86 stable wrt security bug #332957
231
232 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
233 Stable on amd64 wrt bug #332957
234
235 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
236 Stable for PPC (bug #332957).
237
238 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
239 Stable for HPPA (bug #332957).
240
241*ruby-1.8.7_p302 (21 Aug 2010)
242
243 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
244 +ruby-1.8.7_p302.ebuild:
245 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
246 installation path.
247
248*ruby-1.8.6_p399 (19 Aug 2010)
249
250 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
251 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
252 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
253 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
254 installation path (reported by the x86 team in bug 332597)
255
256*ruby-1.9.2_rc2-r1 (18 Aug 2010)
257
258 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
259 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
260 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
261 the rubygems loading code. Add USE flag for psych.
262
263 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
264 ruby-1.9.2_rc2.ebuild:
265 Remove two keepdir that will try to keep an empty path, closes bug
266 #333163.
267
268 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
269 Marked ~ppc (bug #332593).
270
271 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
272 ruby-1.9.2_rc2.ebuild:
273 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
274
275 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
276 ruby-1.8.7_p299.ebuild:
277 Bump eselect-ruby dependency
278
279 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
280 -ruby-1.9.1_p429.ebuild:
281 Remove ebuild that is not target for unmask anyway.
282
283 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
284 ruby-1.9.2_rc2.ebuild:
285 Try 2 to fix the berkdb 5 issue on 1.9.
286
287 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
288 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
289 ruby-1.9.2_rc2.ebuild:
290 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
291 support for adding new patchsets without bumping the revision for all the
292 old ebuilds as well.
293
294*ruby-1.9.2_rc2 (14 Jul 2010)
295
296 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
297 +ruby-1.9.2_rc2.ebuild:
298 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
299 might cause _further_ build failures as it changed slightly behaviour.
300 You're going to need to rebuild rubygems and then all the packages
301 previously installed after upgrading to this.
302
303 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
304 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
305 -ruby-1.9.1_p376.ebuild:
306 Cleanup old versions.
307
308*ruby-1.9.1_p429 (04 Jul 2010)
309
310 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
311 +ruby-1.9.1_p429.ebuild:
312 Version bump to new 1.9.1 release.
313
314*ruby-1.8.7_p299 (23 Jun 2010)
315
316 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
317 +ruby-1.8.7_p299.ebuild:
318 Version bump.
319
320 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
321 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
322 remove useless comments
323
324 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
325 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
326 ruby-1.9.1_p376.ebuild:
327 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
328 dev.gentoo.org now.
329
330 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
331 ruby-1.9.1_p376.ebuild:
332 Use the correct RUBYLIB.
333
334*ruby-1.8.7_p249-r2 (18 May 2010)
335*ruby-1.8.6_p388-r1 (18 May 2010)
336
337 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
338 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
339 ruby-1.9.1_p376.ebuild, metadata.xml:
340 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
341 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
342 add USE flags for ncurses, readline and libedit, and properly depend on
343 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
344 Emacs versions support ruby-mode themselves and it should be even more
345 updated.
346
347*ruby-1.8.7_p249-r1 (06 May 2010)
348
349 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
350 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
351 309789 by Sune Kloppenborg Jeppesen.
352
353 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
354 ruby-1.8.7_p249.ebuild:
355 Use $PVR instead of $PV in patchset names
356
357 06 May 2010; Alex Legler <a3li@gentoo.org>
358 -files/ruby-1.8.6-memory-leak.diff,
359 -files/ruby18-mkmf-parallel-install.patch,
360 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
361 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
362 Remove old version. Cleanup in files/
363
364*ruby-1.9.1_p376 (01 May 2010)
365
366 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
367 Version bump. Fixes security bugs 296052 and 300468. No longer installs
368 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
369 instead.
370
371 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
372 -ruby-1.8.7_p174-r1.ebuild:
373 Remove vulnerable ebuilds, 300468
374
375 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
376 ruby-1.8.7_p249.ebuild:
377 amd64 stable, security bug 300468
378
379 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
380 ruby-1.8.7_p249.ebuild:
381 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
382
383 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
384 Stable for HPPA (bug #300468).
385
386 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
387 Stable for HPPA (bug #300468).
388
389 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
390 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
391
392 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
393 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
394
395 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
396 ruby-1.8.6_p388.ebuild:
397 stable x86, security bug 300468
398
399 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
400 ruby-1.8.7_p249.ebuild:
401 stable x86, security bug 300468
402
403*ruby-1.8.6_p388 (10 Jan 2010)
404
405 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
406 +ruby-1.8.6_p388.ebuild:
407 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
408 version. The new ebuild also has the fix for bug 168939.
409
410*ruby-1.8.7_p249 (10 Jan 2010)
411
412 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
413 +ruby-1.8.7_p249.ebuild:
414 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
415 version
416
417 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
418 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
419
420*ruby-1.8.7_p248 (25 Dec 2009)
421
422 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
423 Version bump
424
425 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
426 Remove old version.
427
428 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
429 Remove old version.
430
431 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
432 ia64/s390/sh stable wrt #288699
433
434 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
435 stable sparc, bug 288699
436
437 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
438 arm stable, bug #288699
439
440 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
441 amd64/x86 stable, bug #288699
442
443 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
444 ruby-1.8.7_p174-r1.ebuild:
445 Stable on alpha, bug #288699
446
447 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
448 ppc stable #288699
449
450 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
451 Stable for HPPA (bug #288699).
452
453 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
454 Marked ~hppa too.
455
456*ruby-1.8.7_p174-r1 (06 Oct 2009)
457
458 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
459 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
460 eselect-ruby cleanup feature.
461
462*ruby-1.9.1_p243 (09 Sep 2009)
463
464 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
465 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
466 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
467 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
468 -files/ruby19-rubygems-proxy.patch,
469 -files/ruby-1.9.1_p129-parallelmake.patch,
470 -files/ruby19-mkmf-parallel-install.patch:
471 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
472 168939. Cleaning up old patches.
473
474*ruby-1.8.6_p383 (20 Aug 2009)
475
476 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
477 Patchlevel bump.
478
479 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
480 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
481 ruby-1.9.1_p129-r1.ebuild:
482 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
483
484 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
485 Removing vulnerable ebuild, bug 273213.
486
487 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
488 Marking ruby-1.8.6_p369 ppc for bug 273213
489
490 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
491 ruby-1.9.1_p129-r1.ebuild:
492 Prepend our library path instead of overwriting it during src_install.
493 Thanks to the reporter of bug #274824.
494
495*ruby-1.8.7_p174 (18 Jun 2009)
496
497 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
498 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
499 Replacing 187_p173 with _p174 because of a regression. Unifying the
500 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
501 patchsets.
502
503 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
504 Marking ruby-1.8.6_p369 ppc64 for bug 273213
505
506 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
507 arm/ia64/s390/sh/sparc stable wrt #273213
508
509 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
510 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
511 Removing old version, minor cleanup
512
513 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
514 -files/ruby-1.8.6-openssl.patch,
515 -files/ruby-1.8.6-shortname_constants.patch,
516 -files/ruby-1.8.6_p111-r13657.patch,
517 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
518 Removing vulnerable old Ruby version and stale patches, bug 274108.
519
520 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
521 ruby-1.8.6_p369.ebuild:
522 Stable on alpha, bug #273213
523
524 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
525 Stable for HPPA (bug #273213).
526
527 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
528 ruby-1.8.6_p369.ebuild:
529 stable x86, security bug 273213
530
531 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
532 amd64 stable, security bug 273213.
533
534*ruby-1.8.7_p173 (10 Jun 2009)
535*ruby-1.8.6_p369 (10 Jun 2009)
536
537 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
538 +ruby-1.8.7_p173.ebuild:
539 Version bumps for bug #273213.
540
541*ruby-1.9.1_p129-r1 (27 May 2009)
542
543 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
544 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
545 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
546 +files/ruby-1.9.1_p129-parallelmake.patch:
547 Revision bump, add patches 1) to make Ruby behave more similarly between
548 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
549 extensions (undefined symbols in them will cause abort at runtime 3) to
550 remove a concurrency issue when building the dl extension that could
551 result in a broken dl.so.
552
553 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
554 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
555 Don't block rdoc-2 or later (which may enter Portage one day as it's
556 needed by some Rakefiles).
557
558 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
559 ruby-1.9.1_p129.ebuild:
560 Add ~x86-fbsd keyword.
561
562 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
563 keyword ~sparc-fbsd, bug #252315
564
565*ruby-1.9.1_p129 (15 May 2009)
566
567 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
568 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
569 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
570 included in every release.
571
572 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
573 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
574 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
575 ruby-1.8.7_p160.ebuild:
576 Removing vulnerable versions (#268515), fixing license (#233747).
577
578 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
579 Stable for HPPA (bug #268515).
580
581 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
582 Adapting rubygems notice.
583
584 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
585 amd64 stable, bug #268515.
586
587 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
588 arm/ia64/s390/sh/sparc stable wrt #268515
589
590 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
591 ruby-1.8.6_p368.ebuild:
592 stable x86, security bug 268515
593
594 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
595 ruby-1.8.6_p368.ebuild:
596 Stable on alpha, bug #268515
597
598 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
599 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
600
601*ruby-1.8.7_p160 (07 May 2009)
602*ruby-1.8.6_p368 (07 May 2009)
603
604 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
605 +ruby-1.8.7_p160.ebuild:
606 Version bump as per secbug 268515. NB: These are the first ebuilds that
607 no longer use ruby-config.
608
609*ruby-1.9.1-r1 (03 Apr 2009)
610*ruby-1.8.7_p72-r11 (03 Apr 2009)
611*ruby-1.8.6_p287-r13 (03 Apr 2009)
612
613 03 Apr 2009; Alex Legler <a3li@gentoo.org>
614 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
615 +files/ruby18-mkmf-parallel-install.patch,
616 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
617 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
618 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
619 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
620 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
621 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
622 happy.
623
624*ruby-1.9.1 (21 Mar 2009)
625
626 21 Mar 2009; Alex Legler <a3li@gentoo.org>
627 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
628 +ruby-1.9.1.ebuild:
629 Adding Ruby 1.9.1 for preliminary testing
630
631 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
632 ruby-1.8.6_p287-r12.ebuild:
633 Marked ~ppc for bug #252315.
634
635 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
636 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
637 bug 261982.
638
639 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
640 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
641 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
642 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
643 Cleanup
644
645*ruby-1.8.7_p72-r10 (07 Mar 2009)
646
647 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
648 +ruby-1.8.7_p72-r10.ebuild:
649 Add a revision of ruby 1.8.7 using eselect ruby.
650
651 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
652 ~mips keyworded, bug #252315.
653
654 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
655 ruby-1.8.6_p287-r5.ebuild:
656 ppc stable, bug #260006
657
658 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
659 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
660
661 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
662 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
663 Fixing Tk USE flag test, bug 258893.
664
665 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
666 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
667
668 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
669 ruby-1.8.6_p287-r5.ebuild:
670 amd64 stable wrt security bug #260006
671
672 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
673 Stable for HPPA (bug #260006).
674
675 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
676 ruby-1.8.6_p287-r5.ebuild:
677 Stable on alpha, bug #260006
678
679*ruby-1.8.7_p72-r2 (23 Feb 2009)
680*ruby-1.8.6_p287-r12 (23 Feb 2009)
681*ruby-1.8.6_p287-r5 (23 Feb 2009)
682
683 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
684 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
685 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
686 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
687 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
688 now before compilation if Tk useflags don't match) and 230748 (adding
689 --enable-option-checking=no for newer versions of autoconf).
690
691 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
692 arm/ia64/s390/sh/sparc stable wrt #254307
693
694 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
695 ruby-1.8.6_p287-r4.ebuild:
696 Stable on alpha, bug #254307
697
698 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
699 ruby-1.8.6_p287-r11.ebuild:
700 keyword ~x86-fbsd, bug #252315
701
702 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
703 ppc stable #254307
704
705 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
706 amd64/x86 stable, bug #254307
707
708 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
709 stable ppc64, bug 254307
710
711 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
712 Stable for HPPA (bug #254307).
713
714 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
715 ruby-1.8.6_p287-r11.ebuild:
716 Marked ~hppa (bug #252315).
717
718*ruby-1.8.6_p287-r11 (11 Jan 2009)
719
720 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
721 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
722 +ruby-1.8.6_p287-r11.ebuild:
723 Backport conditional definition of missing openssl functions from ruby 1.8.7.
724 Fixes #254307.
725
726 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
727 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
728
729 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
730 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
731
732 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
733 ruby-1.8.6_p287-r10.ebuild:
734 Add ~sparc keyword, bug #252315
735
736*ruby-1.8.6_p287-r10 (23 Dec 2008)
737
738 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
739 +ruby-1.8.6_p287-r10.ebuild:
740 Version bump which switches from ruby-config to eselect-ruby. Dropped most
741 keywords since eselect-ruby does not yet have these keywords.
742
743 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
744 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
745 Revert the ruby-config changes. We can't remove them until we provide an
746 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
747 for breaking things as mentioned in bug #251833.
748
749 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
750 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
751 ruby-1.8.7_p72-r1.ebuild:
752 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
753 Thanks for the people noticing this in bug #251833.
754
755 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
756 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
757 ruby-1.8.7_p72-r1.ebuild:
758 Drop dependency on ruby-config, which will be removed from the tree. We
759 currently only have one major version of ruby in the tree (Ruby 1.8), so there
760 is no need for ruby-config at this moment. For newer versions of Ruby we will
761 use eselect-ruby, which can be found in the ruby overlay at the moment.
762
763 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
764 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
765 Use mirror://ruby in SRC_URI, fixes #237392.
766
767 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
768 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
769 -ruby-1.8.7_p72.ebuild:
770 Remove old versions. Leave one old stable version with cjk support.
771
772*ruby-1.8.6_p287-r3 (29 Nov 2008)
773
774 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
775 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
776 +ruby-1.8.6_p287-r3.ebuild:
777 Fix our expansion limit patch according to debian bug report
778 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
779 make sure people will pick up the fixed version. Thanks to Alex Legler for
780 mentioning the patch.
781
782*ruby-1.8.7_p72-r1 (26 Nov 2008)
783*ruby-1.8.6_p287-r2 (26 Nov 2008)
784
785 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
786 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
787 +ruby-1.8.7_p72-r1.ebuild:
788 Fix problem with shortname constants #247790, already fixed in upstream SVN.
789 Thanks to Alex Legler for providing the patch.
790
791 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
792 -ruby-1.8.6_p287.ebuild:
793 Remove versions that will not become stable
794
795 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
796 ruby-1.8.6_p287-r1.ebuild:
797 ppc stable, bug #225465
798
799 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
800 ruby-1.8.6_p287-r1.ebuild:
801 amd64 stable wrt security bug #225465
802
803 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
804 alpha/ia64/x86 stable wrt #225465
805
806 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
807 ruby-1.8.6_p287-r1.ebuild:
808 Sparc stable --- Security Bug #225465 --- good since late August.
809
810 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
811 Stable on ppc64; bug #225465
812
813 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
814 Stable for HPPA (bug #225465).
815
816*ruby-1.8.6_p287-r1 (29 Aug 2008)
817
818 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
819 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
820 +ruby-1.8.6_p287-r1.ebuild:
821 Fix REXML security issues, bug #236060.
822
823 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
824 Add GLEP 56 USE flag descriptions.
825
826*ruby-1.8.7_p72 (15 Aug 2008)
827
828 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
829 +ruby-1.8.7_p72.ebuild:
830 bump 1.8.7 to latest patch release
831
832*ruby-1.8.6_p287 (11 Aug 2008)
833
834 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
835 Version bump for brown paper bag relelease.
836
837 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
838 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
839 Remove broken version in favor of the just-added 1.8.6_p286
840
841*ruby-1.8.6_p286 (10 Aug 2008)
842
843 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
844 Version bump to latest released version of ruby 1.8.6. This version fixes the
845 security issues reported in #225465 and #234224. The cjk USE flag has been
846 dropped since no compatible patches have been released yet.
847
848 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
849 ruby-1.8.6_p230.ebuild:
850 drop cjk from SRC_URI as well
851
852 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
853 Drop cjk support since the most recent oniguruma patches no longer apply to
854 this version, #230111.
855
856 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
857 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
858 Try to fix the security issues reported in #225465 for ruby 1.8.6.
859 Unfortunately the official p230 has a change which causes segmentation faults
860 for applications like Rails and RSpec, so we are reverting that specific
861 change.
862
863*ruby-1.8.7_p22 (29 Jun 2008)
864
865 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
866 +ruby-1.8.7_p22.ebuild:
867 bump 1.8.7 for security fix
868
869 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
870 nevermind, don't bump this yet
871
872*ruby-1.8.6_p230 (20 Jun 2008)
873
874 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
875 version bump
876
877*ruby-1.8.7 (10 Jun 2008)
878
879 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
880 +ruby-1.8.7.ebuild:
881 bump 1.8.7 to final
882
883*ruby-1.8.7_pre2 (21 Apr 2008)
884
885 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
886 +ruby-1.8.7_pre2.ebuild:
887 Version Bump
888
889*ruby-1.8.7_pre1 (16 Apr 2008)
890
891 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
892 Version bump. Drop cjk until a new version of oniguruma appears.
893
894 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
895 amd64 stable, bug 212264
896
897 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
898 Stable for HPPA (bug #212264).
899
900 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
901 ruby-1.8.6_p114.ebuild:
902 ppc stable, bug #212264
903
904 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
905 alpha/ia64 stable wrt #212264
906
907 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
908 ruby-1.8.6_p114.ebuild:
909 stable x86, security bug 212264
910
911 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
912 Sparc stable, Security Bug #212264, builds and installs, initial tests run
913 as expected.
914
915 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
916 Marking ruby-1.8.6_p114 ppc64 for bug 212264
917
918*ruby-1.8.6_p114 (05 Mar 2008)
919
920 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
921 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
922 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
923 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
924 Version bump for #212264. Remove old ebuilds.
925
926 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
927 alpha/ia64 stable wrt #208916
928
929 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
930 Stable on ppc wrt bug 208916
931
932 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
933 x86 stable, bug #208916
934
935 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
936 ruby-1.8.6_p111-r1.ebuild:
937 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
938
939 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
940 -files/ruby-1.8.6-exit-status.patch,
941 -files/ruby-1.8.6_p110-net-http-p111.patch,
942 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
943 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
944 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
945 Remove old versions
946
947 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
948 Stable on ppc64
949
950 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
951 Stable on amd64; bug 199191
952
953 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
954 alpha/ia64/sparc stable wrt #199191
955
956 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
957 Remove now-obsolete warning about coreutils versions, #203156.
958
959 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
960 Stable for HPPA (bug #199191).
961
962*ruby-1.8.6_p111-r1 (23 Dec 2007)
963
964 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
965 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
966 ssl USE flags. Patch to p113.
967
968 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
969 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
970
971 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
972 x86 stable, security bug #199191
973
974*ruby-1.8.6_p111 (23 Dec 2007)
975
976 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
977 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
978 Version bump with patch for bug #199191
979
980 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
981 Move dependency on (X)Emacs modes to PDEPEND.
982
983 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
984 Add back ~hppa keyword now that XEmacs support files have been keyworded,
985 bug 196413
986
987*ruby-1.8.6_p110-r2 (21 Oct 2007)
988
989 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
990 +ruby-1.8.6_p110-r2.ebuild:
991 Add emacs and xemacs USE flags and use them to pull in the correct editing
992 mode for each. Had to drop several arch keywords as reported on bug 196413.
993
994 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
995 amd64 stable, security bug 194236
996
997 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
998 ruby-1.8.6_p110-r1.ebuild:
999 Stable on ppc64; bug #194236
1000
1001 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1002 amd64 stable, security bug 194236
1003
1004 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1005 Stable for HPPA (bug #194236).
1006
1007 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1008 alpha/ia64/sparc stable wrt security #194236
1009
1010 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1011 ruby-1.8.6_p110-r1.ebuild:
1012 ppc stable, bug #194236
1013
1014 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1015 ruby-1.8.6_p110-r1.ebuild:
1016 stable x86, security bug 194236
1017
1018 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1019 ruby-1.8.5_p113.ebuild:
1020 stable x86, security bug 194236
1021
1022 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1023 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1024 -ruby-1.8.6_p110.ebuild:
1025 Remove old versions
1026
1027*ruby-1.8.6_p110-r1 (30 Sep 2007)
1028*ruby-1.8.5_p113 (30 Sep 2007)
1029
1030 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1031 +files/ruby-1.8.5_p113-net-http-p114.patch,
1032 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1033 +ruby-1.8.6_p110-r1.ebuild:
1034 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1035 using 1.8.6-p110 as base ebuild.
1036
1037 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1038 More fixes from gentoo-dev and graaff
1039
1040 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1041 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1042
1043*ruby-1.8.6_p110 (24 Sep 2007)
1044
1045 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1046 Version bump
1047
1048*ruby-1.8.6_p36-r4 (26 Aug 2007)
1049
1050 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1051 +ruby-1.8.6_p36-r4.ebuild:
1052 Use user LDFLAGS, #181436
1053
1054 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1055 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1056 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1057 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1058
1059 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1060 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1061 -ruby-1.8.6_p36-r2.ebuild:
1062 Remove some older versions that will not be promoted to stable, keeping at
1063 least one version of each release.
1064
1065 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1066 ruby-1.8.6_p36-r3.ebuild:
1067 (QA) RESTRICT clean up.
1068
1069*ruby-1.8.6_p36-r3 (04 Jul 2007)
1070
1071 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1072 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1073 fixed memory leak loading .so bug #182946
1074
1075 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1076 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1077 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1078 ruby-1.8.6_p36-r2.ebuild:
1079 (QA) RESTRICT clean up.
1080
1081 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1082 Re-add stable keyword for alpha as per bug #181110
1083
1084 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1085 Back to ~amd64 wrt bug 181110
1086
1087 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1088 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1089
1090*ruby-1.8.6_p36-r2 (20 Jun 2007)
1091
1092 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1093 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1094
1095*ruby-1.8.6_p36-r1 (18 Jun 2007)
1096
1097 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1098 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1099 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1100 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1101 spbecker
1102
1103 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1104 Stable on amd64 wrt bug 181110
1105
1106*ruby-1.8.6_p36 (12 Jun 2007)
1107
1108 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1109 Version Bump. Bug #181379
1110
1111 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1112 Stable on mips, per #181110.
1113
1114 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1115 Stable on ppc wrt bug 181110
1116
1117 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1118 Stable for HPPA (bug #181110).
1119
1120 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1121 alpha/ia64/x86 stable wrt #181110
1122
1123 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1124 Stable on sparc wrt #181110
1125
1126 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1127 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1128
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1129 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1130 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1131 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1132 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.531

  ViewVC Help
Powered by ViewVC 1.1.20