/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.533
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.533 2012/05/12 05:47:49 flameeyes Exp $
4
5*ruby-1.9.3_p194-r1 (12 May 2012)
6
7 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
8 +ruby-1.9.3_p194-r1.ebuild:
9 Revision bump to fix mkmf for parallel build/install. Also enable verbose
10 build, so that the log makes sense if it fails.
11
12*ruby-1.9.3_p194 (30 Apr 2012)
13
14 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
15 Version bump.
16
17 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
18 keyword ~amd64-fbsd
19
20*ruby-1.8.7_p358 (20 Apr 2012)
21
22 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
23 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
24 Rails 3.2.
25
26 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
27 Add ~x86-fbsd, #332593
28
29*ruby-1.9.3_p125 (18 Feb 2012)
30
31 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
32 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
33
34 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
35 add ~arm, bug #332593
36
37 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
38 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
39
40 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
41 x86 stable wrt bug #396301
42
43 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
44 Stable for HPPA (bug #396301).
45
46 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
47 Stable for ppc/ppc64; bug #396301
48
49 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
50 Marked ~hppa (bug #332593).
51
52 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
53 Add back ~alpha keyword now that rubygems is keyworded.
54
55 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
56 Stable for AMD64, wrt security bug #396301
57
58*ruby-1.8.7_p357 (28 Dec 2011)
59
60 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
61 Version bump for security bug 396301.
62
63 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
64 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
65
66 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
67 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
68 keyworded, bug 332593.
69
70 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
71 Block older versions of packages that are no longer compatible. Remove
72 ancient blocks on packags long gone from the tree.
73
74 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
75 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
76 Remove old versions.
77
78*ruby-1.9.3_p0 (18 Dec 2011)
79
80 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
81 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
82 suite which need to be diagnosed first.
83
84 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
85 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
86 #332593).
87
88 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
89 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
90 #332593).
91
92 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
93 alpha/ia64/s390/sh/sparc stable wrt #386369
94
95*ruby-1.9.3_rc1 (22 Oct 2011)
96
97 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
98 Version bump.
99
100 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
101 arm stable, bug #386369
102
103 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
104 x86 stable, bug 386369
105
106 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
107 Stable for HPPA (bug #386369).
108
109 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
110 ppc/ppc64 stable wrt #386369
111
112 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
113 Stable on amd64 wrt bug #386369
114
115 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
116 Remove vulnerable version, bug 386369.
117
118*ruby-1.8.7_p352 (30 Aug 2011)
119
120 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
121 +ruby-1.8.7_p352.ebuild:
122 Patchlevel bump for ruby:1.8. Removing old version
123
124*ruby-1.9.2_p290 (30 Aug 2011)
125
126 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
127 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
128 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
129 old patchlevels.
130
131 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
132 ruby-1.8.7_p334-r2.ebuild:
133 ppc/ppc64 stable wrt #378691
134
135*ruby-1.8.7_p334-r2 (22 Jul 2011)
136
137 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
138 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
139 for chasing down upstream and us.
140
141 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
142 Added ~mips, bug 332593
143
144 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
145 ruby-1.8.7_p334-r1.ebuild:
146 ppc64 stable wrt #369141
147
148 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
149 ia64/s390/sh/sparc stable wrt #369141
150
151 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
152 Stable for HPPA (bug #369141).
153
154 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
155 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
156
157 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
158 arm/x86 stable, bug #369141
159
160 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
161 Stable on amd64 wrt bug #369141
162
163 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
164 ruby-1.8.7_p334-r1.ebuild:
165 Stable on alpha, bug #369141
166
167*ruby-1.8.7_p334-r1 (31 May 2011)
168
169 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
170 Revision bump for security bug 369141 (CVE-2011-0188)
171
172*ruby-1.9.2-r1 (16 May 2011)
173
174 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
175 Don't remove racc files since all other ruby targets ship these files
176 themselves as well. Closes bug 363419.
177
178 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
179 ruby-1.8.7_p334.ebuild:
180 Remove old version. Remove obsolete and unused old-style virtual/ruby.
181
182 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
183 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
184
185 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
186 Add append-flags -mieee on sh, bug #357559
187
188 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
189 alpha/arm/ia64/s390/sh stable wrt #355439
190
191 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
192 Marked ~ppc64 wrt #332593
193
194 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
195 ruby-1.8.7_p334.ebuild:
196 x86 stable wrt security bug #355439
197
198 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
199 ruby-1.8.7_p334.ebuild:
200 ppc/ppc64 stable wrt #355439
201
202 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
203 Stable on amd64 wrt bug #355439
204
205 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
206 Stable for HPPA (bug #355439).
207
208*ruby-1.8.7_p334 (19 Feb 2011)
209
210 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
211 Version bump 1.8.7 series, security bug 355439
212
213 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
214 ruby-1.9.2.ebuild:
215 Remove PROVIDE for old-style virtual/ruby per bug 265054.
216
217 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
218 Remove masked ruby 1.8.6 per bug 332597.
219
220 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
221 -ruby-1.9.2_rc2.ebuild:
222 Removing old and vulnerable ebuilds
223
224 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
225 Marking ruby-1.8.7_p302 ppc64 for bug 332957
226
227 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
228 alpha/ia64/s390/sh/sparc stable wrt #332957
229
230*ruby-1.9.2 (24 Aug 2010)
231
232 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
233 metadata.xml:
234 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
235 and x86-fbsd due to a new dependency on rdoc.
236
237 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
238 arm stable, bug #332957
239
240 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
241 ruby-1.8.7_p302.ebuild:
242 x86 stable wrt security bug #332957
243
244 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
245 Stable on amd64 wrt bug #332957
246
247 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
248 Stable for PPC (bug #332957).
249
250 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
251 Stable for HPPA (bug #332957).
252
253*ruby-1.8.7_p302 (21 Aug 2010)
254
255 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
256 +ruby-1.8.7_p302.ebuild:
257 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
258 installation path.
259
260*ruby-1.8.6_p399 (19 Aug 2010)
261
262 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
263 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
264 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
265 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
266 installation path (reported by the x86 team in bug 332597)
267
268*ruby-1.9.2_rc2-r1 (18 Aug 2010)
269
270 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
272 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
273 the rubygems loading code. Add USE flag for psych.
274
275 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
276 ruby-1.9.2_rc2.ebuild:
277 Remove two keepdir that will try to keep an empty path, closes bug
278 #333163.
279
280 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
281 Marked ~ppc (bug #332593).
282
283 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
284 ruby-1.9.2_rc2.ebuild:
285 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
286
287 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
288 ruby-1.8.7_p299.ebuild:
289 Bump eselect-ruby dependency
290
291 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
292 -ruby-1.9.1_p429.ebuild:
293 Remove ebuild that is not target for unmask anyway.
294
295 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
296 ruby-1.9.2_rc2.ebuild:
297 Try 2 to fix the berkdb 5 issue on 1.9.
298
299 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
300 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
301 ruby-1.9.2_rc2.ebuild:
302 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
303 support for adding new patchsets without bumping the revision for all the
304 old ebuilds as well.
305
306*ruby-1.9.2_rc2 (14 Jul 2010)
307
308 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
309 +ruby-1.9.2_rc2.ebuild:
310 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
311 might cause _further_ build failures as it changed slightly behaviour.
312 You're going to need to rebuild rubygems and then all the packages
313 previously installed after upgrading to this.
314
315 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
316 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
317 -ruby-1.9.1_p376.ebuild:
318 Cleanup old versions.
319
320*ruby-1.9.1_p429 (04 Jul 2010)
321
322 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
323 +ruby-1.9.1_p429.ebuild:
324 Version bump to new 1.9.1 release.
325
326*ruby-1.8.7_p299 (23 Jun 2010)
327
328 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
329 +ruby-1.8.7_p299.ebuild:
330 Version bump.
331
332 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
333 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
334 remove useless comments
335
336 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
337 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
338 ruby-1.9.1_p376.ebuild:
339 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
340 dev.gentoo.org now.
341
342 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
343 ruby-1.9.1_p376.ebuild:
344 Use the correct RUBYLIB.
345
346*ruby-1.8.7_p249-r2 (18 May 2010)
347*ruby-1.8.6_p388-r1 (18 May 2010)
348
349 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
350 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
351 ruby-1.9.1_p376.ebuild, metadata.xml:
352 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
353 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
354 add USE flags for ncurses, readline and libedit, and properly depend on
355 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
356 Emacs versions support ruby-mode themselves and it should be even more
357 updated.
358
359*ruby-1.8.7_p249-r1 (06 May 2010)
360
361 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
362 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
363 309789 by Sune Kloppenborg Jeppesen.
364
365 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
366 ruby-1.8.7_p249.ebuild:
367 Use $PVR instead of $PV in patchset names
368
369 06 May 2010; Alex Legler <a3li@gentoo.org>
370 -files/ruby-1.8.6-memory-leak.diff,
371 -files/ruby18-mkmf-parallel-install.patch,
372 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
373 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
374 Remove old version. Cleanup in files/
375
376*ruby-1.9.1_p376 (01 May 2010)
377
378 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
379 Version bump. Fixes security bugs 296052 and 300468. No longer installs
380 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
381 instead.
382
383 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
384 -ruby-1.8.7_p174-r1.ebuild:
385 Remove vulnerable ebuilds, 300468
386
387 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
388 ruby-1.8.7_p249.ebuild:
389 amd64 stable, security bug 300468
390
391 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
392 ruby-1.8.7_p249.ebuild:
393 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
394
395 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
396 Stable for HPPA (bug #300468).
397
398 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
399 Stable for HPPA (bug #300468).
400
401 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
402 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
403
404 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
405 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
406
407 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
408 ruby-1.8.6_p388.ebuild:
409 stable x86, security bug 300468
410
411 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
412 ruby-1.8.7_p249.ebuild:
413 stable x86, security bug 300468
414
415*ruby-1.8.6_p388 (10 Jan 2010)
416
417 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
418 +ruby-1.8.6_p388.ebuild:
419 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
420 version. The new ebuild also has the fix for bug 168939.
421
422*ruby-1.8.7_p249 (10 Jan 2010)
423
424 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
425 +ruby-1.8.7_p249.ebuild:
426 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
427 version
428
429 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
430 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
431
432*ruby-1.8.7_p248 (25 Dec 2009)
433
434 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
435 Version bump
436
437 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
438 Remove old version.
439
440 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
441 Remove old version.
442
443 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
444 ia64/s390/sh stable wrt #288699
445
446 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
447 stable sparc, bug 288699
448
449 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
450 arm stable, bug #288699
451
452 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
453 amd64/x86 stable, bug #288699
454
455 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
456 ruby-1.8.7_p174-r1.ebuild:
457 Stable on alpha, bug #288699
458
459 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
460 ppc stable #288699
461
462 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
463 Stable for HPPA (bug #288699).
464
465 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
466 Marked ~hppa too.
467
468*ruby-1.8.7_p174-r1 (06 Oct 2009)
469
470 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
471 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
472 eselect-ruby cleanup feature.
473
474*ruby-1.9.1_p243 (09 Sep 2009)
475
476 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
477 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
478 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
479 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
480 -files/ruby19-rubygems-proxy.patch,
481 -files/ruby-1.9.1_p129-parallelmake.patch,
482 -files/ruby19-mkmf-parallel-install.patch:
483 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
484 168939. Cleaning up old patches.
485
486*ruby-1.8.6_p383 (20 Aug 2009)
487
488 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
489 Patchlevel bump.
490
491 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
492 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
493 ruby-1.9.1_p129-r1.ebuild:
494 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
495
496 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
497 Removing vulnerable ebuild, bug 273213.
498
499 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
500 Marking ruby-1.8.6_p369 ppc for bug 273213
501
502 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
503 ruby-1.9.1_p129-r1.ebuild:
504 Prepend our library path instead of overwriting it during src_install.
505 Thanks to the reporter of bug #274824.
506
507*ruby-1.8.7_p174 (18 Jun 2009)
508
509 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
510 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
511 Replacing 187_p173 with _p174 because of a regression. Unifying the
512 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
513 patchsets.
514
515 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
516 Marking ruby-1.8.6_p369 ppc64 for bug 273213
517
518 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
519 arm/ia64/s390/sh/sparc stable wrt #273213
520
521 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
522 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
523 Removing old version, minor cleanup
524
525 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
526 -files/ruby-1.8.6-openssl.patch,
527 -files/ruby-1.8.6-shortname_constants.patch,
528 -files/ruby-1.8.6_p111-r13657.patch,
529 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
530 Removing vulnerable old Ruby version and stale patches, bug 274108.
531
532 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
533 ruby-1.8.6_p369.ebuild:
534 Stable on alpha, bug #273213
535
536 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
537 Stable for HPPA (bug #273213).
538
539 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
540 ruby-1.8.6_p369.ebuild:
541 stable x86, security bug 273213
542
543 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
544 amd64 stable, security bug 273213.
545
546*ruby-1.8.7_p173 (10 Jun 2009)
547*ruby-1.8.6_p369 (10 Jun 2009)
548
549 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
550 +ruby-1.8.7_p173.ebuild:
551 Version bumps for bug #273213.
552
553*ruby-1.9.1_p129-r1 (27 May 2009)
554
555 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
556 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
557 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
558 +files/ruby-1.9.1_p129-parallelmake.patch:
559 Revision bump, add patches 1) to make Ruby behave more similarly between
560 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
561 extensions (undefined symbols in them will cause abort at runtime 3) to
562 remove a concurrency issue when building the dl extension that could
563 result in a broken dl.so.
564
565 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
566 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
567 Don't block rdoc-2 or later (which may enter Portage one day as it's
568 needed by some Rakefiles).
569
570 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
571 ruby-1.9.1_p129.ebuild:
572 Add ~x86-fbsd keyword.
573
574 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
575 keyword ~sparc-fbsd, bug #252315
576
577*ruby-1.9.1_p129 (15 May 2009)
578
579 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
580 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
581 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
582 included in every release.
583
584 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
585 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
586 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
587 ruby-1.8.7_p160.ebuild:
588 Removing vulnerable versions (#268515), fixing license (#233747).
589
590 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
591 Stable for HPPA (bug #268515).
592
593 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
594 Adapting rubygems notice.
595
596 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
597 amd64 stable, bug #268515.
598
599 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
600 arm/ia64/s390/sh/sparc stable wrt #268515
601
602 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
603 ruby-1.8.6_p368.ebuild:
604 stable x86, security bug 268515
605
606 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
607 ruby-1.8.6_p368.ebuild:
608 Stable on alpha, bug #268515
609
610 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
611 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
612
613*ruby-1.8.7_p160 (07 May 2009)
614*ruby-1.8.6_p368 (07 May 2009)
615
616 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
617 +ruby-1.8.7_p160.ebuild:
618 Version bump as per secbug 268515. NB: These are the first ebuilds that
619 no longer use ruby-config.
620
621*ruby-1.9.1-r1 (03 Apr 2009)
622*ruby-1.8.7_p72-r11 (03 Apr 2009)
623*ruby-1.8.6_p287-r13 (03 Apr 2009)
624
625 03 Apr 2009; Alex Legler <a3li@gentoo.org>
626 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
627 +files/ruby18-mkmf-parallel-install.patch,
628 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
629 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
630 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
631 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
632 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
633 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
634 happy.
635
636*ruby-1.9.1 (21 Mar 2009)
637
638 21 Mar 2009; Alex Legler <a3li@gentoo.org>
639 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
640 +ruby-1.9.1.ebuild:
641 Adding Ruby 1.9.1 for preliminary testing
642
643 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
644 ruby-1.8.6_p287-r12.ebuild:
645 Marked ~ppc for bug #252315.
646
647 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
648 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
649 bug 261982.
650
651 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
652 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
653 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
654 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
655 Cleanup
656
657*ruby-1.8.7_p72-r10 (07 Mar 2009)
658
659 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
660 +ruby-1.8.7_p72-r10.ebuild:
661 Add a revision of ruby 1.8.7 using eselect ruby.
662
663 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
664 ~mips keyworded, bug #252315.
665
666 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
667 ruby-1.8.6_p287-r5.ebuild:
668 ppc stable, bug #260006
669
670 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
671 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
672
673 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
674 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
675 Fixing Tk USE flag test, bug 258893.
676
677 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
678 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
679
680 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
681 ruby-1.8.6_p287-r5.ebuild:
682 amd64 stable wrt security bug #260006
683
684 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
685 Stable for HPPA (bug #260006).
686
687 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
688 ruby-1.8.6_p287-r5.ebuild:
689 Stable on alpha, bug #260006
690
691*ruby-1.8.7_p72-r2 (23 Feb 2009)
692*ruby-1.8.6_p287-r12 (23 Feb 2009)
693*ruby-1.8.6_p287-r5 (23 Feb 2009)
694
695 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
696 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
697 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
698 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
699 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
700 now before compilation if Tk useflags don't match) and 230748 (adding
701 --enable-option-checking=no for newer versions of autoconf).
702
703 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
704 arm/ia64/s390/sh/sparc stable wrt #254307
705
706 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
707 ruby-1.8.6_p287-r4.ebuild:
708 Stable on alpha, bug #254307
709
710 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
711 ruby-1.8.6_p287-r11.ebuild:
712 keyword ~x86-fbsd, bug #252315
713
714 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
715 ppc stable #254307
716
717 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
718 amd64/x86 stable, bug #254307
719
720 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
721 stable ppc64, bug 254307
722
723 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
724 Stable for HPPA (bug #254307).
725
726 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
727 ruby-1.8.6_p287-r11.ebuild:
728 Marked ~hppa (bug #252315).
729
730*ruby-1.8.6_p287-r11 (11 Jan 2009)
731
732 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
733 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
734 +ruby-1.8.6_p287-r11.ebuild:
735 Backport conditional definition of missing openssl functions from ruby 1.8.7.
736 Fixes #254307.
737
738 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
739 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
740
741 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
742 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
743
744 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
745 ruby-1.8.6_p287-r10.ebuild:
746 Add ~sparc keyword, bug #252315
747
748*ruby-1.8.6_p287-r10 (23 Dec 2008)
749
750 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
751 +ruby-1.8.6_p287-r10.ebuild:
752 Version bump which switches from ruby-config to eselect-ruby. Dropped most
753 keywords since eselect-ruby does not yet have these keywords.
754
755 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
756 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
757 Revert the ruby-config changes. We can't remove them until we provide an
758 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
759 for breaking things as mentioned in bug #251833.
760
761 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
762 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
763 ruby-1.8.7_p72-r1.ebuild:
764 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
765 Thanks for the people noticing this in bug #251833.
766
767 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
768 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
769 ruby-1.8.7_p72-r1.ebuild:
770 Drop dependency on ruby-config, which will be removed from the tree. We
771 currently only have one major version of ruby in the tree (Ruby 1.8), so there
772 is no need for ruby-config at this moment. For newer versions of Ruby we will
773 use eselect-ruby, which can be found in the ruby overlay at the moment.
774
775 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
776 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
777 Use mirror://ruby in SRC_URI, fixes #237392.
778
779 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
780 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
781 -ruby-1.8.7_p72.ebuild:
782 Remove old versions. Leave one old stable version with cjk support.
783
784*ruby-1.8.6_p287-r3 (29 Nov 2008)
785
786 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
787 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
788 +ruby-1.8.6_p287-r3.ebuild:
789 Fix our expansion limit patch according to debian bug report
790 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
791 make sure people will pick up the fixed version. Thanks to Alex Legler for
792 mentioning the patch.
793
794*ruby-1.8.7_p72-r1 (26 Nov 2008)
795*ruby-1.8.6_p287-r2 (26 Nov 2008)
796
797 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
798 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
799 +ruby-1.8.7_p72-r1.ebuild:
800 Fix problem with shortname constants #247790, already fixed in upstream SVN.
801 Thanks to Alex Legler for providing the patch.
802
803 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
804 -ruby-1.8.6_p287.ebuild:
805 Remove versions that will not become stable
806
807 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
808 ruby-1.8.6_p287-r1.ebuild:
809 ppc stable, bug #225465
810
811 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
812 ruby-1.8.6_p287-r1.ebuild:
813 amd64 stable wrt security bug #225465
814
815 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
816 alpha/ia64/x86 stable wrt #225465
817
818 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
819 ruby-1.8.6_p287-r1.ebuild:
820 Sparc stable --- Security Bug #225465 --- good since late August.
821
822 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
823 Stable on ppc64; bug #225465
824
825 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
826 Stable for HPPA (bug #225465).
827
828*ruby-1.8.6_p287-r1 (29 Aug 2008)
829
830 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
831 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
832 +ruby-1.8.6_p287-r1.ebuild:
833 Fix REXML security issues, bug #236060.
834
835 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
836 Add GLEP 56 USE flag descriptions.
837
838*ruby-1.8.7_p72 (15 Aug 2008)
839
840 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
841 +ruby-1.8.7_p72.ebuild:
842 bump 1.8.7 to latest patch release
843
844*ruby-1.8.6_p287 (11 Aug 2008)
845
846 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
847 Version bump for brown paper bag relelease.
848
849 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
850 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
851 Remove broken version in favor of the just-added 1.8.6_p286
852
853*ruby-1.8.6_p286 (10 Aug 2008)
854
855 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
856 Version bump to latest released version of ruby 1.8.6. This version fixes the
857 security issues reported in #225465 and #234224. The cjk USE flag has been
858 dropped since no compatible patches have been released yet.
859
860 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
861 ruby-1.8.6_p230.ebuild:
862 drop cjk from SRC_URI as well
863
864 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
865 Drop cjk support since the most recent oniguruma patches no longer apply to
866 this version, #230111.
867
868 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
869 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
870 Try to fix the security issues reported in #225465 for ruby 1.8.6.
871 Unfortunately the official p230 has a change which causes segmentation faults
872 for applications like Rails and RSpec, so we are reverting that specific
873 change.
874
875*ruby-1.8.7_p22 (29 Jun 2008)
876
877 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
878 +ruby-1.8.7_p22.ebuild:
879 bump 1.8.7 for security fix
880
881 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
882 nevermind, don't bump this yet
883
884*ruby-1.8.6_p230 (20 Jun 2008)
885
886 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
887 version bump
888
889*ruby-1.8.7 (10 Jun 2008)
890
891 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
892 +ruby-1.8.7.ebuild:
893 bump 1.8.7 to final
894
895*ruby-1.8.7_pre2 (21 Apr 2008)
896
897 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
898 +ruby-1.8.7_pre2.ebuild:
899 Version Bump
900
901*ruby-1.8.7_pre1 (16 Apr 2008)
902
903 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
904 Version bump. Drop cjk until a new version of oniguruma appears.
905
906 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
907 amd64 stable, bug 212264
908
909 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
910 Stable for HPPA (bug #212264).
911
912 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
913 ruby-1.8.6_p114.ebuild:
914 ppc stable, bug #212264
915
916 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
917 alpha/ia64 stable wrt #212264
918
919 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
920 ruby-1.8.6_p114.ebuild:
921 stable x86, security bug 212264
922
923 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
924 Sparc stable, Security Bug #212264, builds and installs, initial tests run
925 as expected.
926
927 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
928 Marking ruby-1.8.6_p114 ppc64 for bug 212264
929
930*ruby-1.8.6_p114 (05 Mar 2008)
931
932 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
933 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
934 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
935 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
936 Version bump for #212264. Remove old ebuilds.
937
938 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
939 alpha/ia64 stable wrt #208916
940
941 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
942 Stable on ppc wrt bug 208916
943
944 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
945 x86 stable, bug #208916
946
947 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
948 ruby-1.8.6_p111-r1.ebuild:
949 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
950
951 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
952 -files/ruby-1.8.6-exit-status.patch,
953 -files/ruby-1.8.6_p110-net-http-p111.patch,
954 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
955 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
956 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
957 Remove old versions
958
959 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
960 Stable on ppc64
961
962 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
963 Stable on amd64; bug 199191
964
965 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
966 alpha/ia64/sparc stable wrt #199191
967
968 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
969 Remove now-obsolete warning about coreutils versions, #203156.
970
971 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
972 Stable for HPPA (bug #199191).
973
974*ruby-1.8.6_p111-r1 (23 Dec 2007)
975
976 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
977 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
978 ssl USE flags. Patch to p113.
979
980 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
981 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
982
983 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
984 x86 stable, security bug #199191
985
986*ruby-1.8.6_p111 (23 Dec 2007)
987
988 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
989 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
990 Version bump with patch for bug #199191
991
992 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
993 Move dependency on (X)Emacs modes to PDEPEND.
994
995 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
996 Add back ~hppa keyword now that XEmacs support files have been keyworded,
997 bug 196413
998
999*ruby-1.8.6_p110-r2 (21 Oct 2007)
1000
1001 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1002 +ruby-1.8.6_p110-r2.ebuild:
1003 Add emacs and xemacs USE flags and use them to pull in the correct editing
1004 mode for each. Had to drop several arch keywords as reported on bug 196413.
1005
1006 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1007 amd64 stable, security bug 194236
1008
1009 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1010 ruby-1.8.6_p110-r1.ebuild:
1011 Stable on ppc64; bug #194236
1012
1013 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1014 amd64 stable, security bug 194236
1015
1016 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1017 Stable for HPPA (bug #194236).
1018
1019 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1020 alpha/ia64/sparc stable wrt security #194236
1021
1022 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1023 ruby-1.8.6_p110-r1.ebuild:
1024 ppc stable, bug #194236
1025
1026 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1027 ruby-1.8.6_p110-r1.ebuild:
1028 stable x86, security bug 194236
1029
1030 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1031 ruby-1.8.5_p113.ebuild:
1032 stable x86, security bug 194236
1033
1034 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1035 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1036 -ruby-1.8.6_p110.ebuild:
1037 Remove old versions
1038
1039*ruby-1.8.6_p110-r1 (30 Sep 2007)
1040*ruby-1.8.5_p113 (30 Sep 2007)
1041
1042 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1043 +files/ruby-1.8.5_p113-net-http-p114.patch,
1044 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1045 +ruby-1.8.6_p110-r1.ebuild:
1046 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1047 using 1.8.6-p110 as base ebuild.
1048
1049 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1050 More fixes from gentoo-dev and graaff
1051
1052 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1053 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1054
1055*ruby-1.8.6_p110 (24 Sep 2007)
1056
1057 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1058 Version bump
1059
1060*ruby-1.8.6_p36-r4 (26 Aug 2007)
1061
1062 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1063 +ruby-1.8.6_p36-r4.ebuild:
1064 Use user LDFLAGS, #181436
1065
1066 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1067 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1068 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1069 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1070
1071 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1072 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1073 -ruby-1.8.6_p36-r2.ebuild:
1074 Remove some older versions that will not be promoted to stable, keeping at
1075 least one version of each release.
1076
1077 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1078 ruby-1.8.6_p36-r3.ebuild:
1079 (QA) RESTRICT clean up.
1080
1081*ruby-1.8.6_p36-r3 (04 Jul 2007)
1082
1083 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1084 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1085 fixed memory leak loading .so bug #182946
1086
1087 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1088 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1089 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1090 ruby-1.8.6_p36-r2.ebuild:
1091 (QA) RESTRICT clean up.
1092
1093 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1094 Re-add stable keyword for alpha as per bug #181110
1095
1096 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1097 Back to ~amd64 wrt bug 181110
1098
1099 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1100 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1101
1102*ruby-1.8.6_p36-r2 (20 Jun 2007)
1103
1104 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1105 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1106
1107*ruby-1.8.6_p36-r1 (18 Jun 2007)
1108
1109 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1110 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1111 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1112 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1113 spbecker
1114
1115 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1116 Stable on amd64 wrt bug 181110
1117
1118*ruby-1.8.6_p36 (12 Jun 2007)
1119
1120 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1121 Version Bump. Bug #181379
1122
1123 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1124 Stable on mips, per #181110.
1125
1126 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1127 Stable on ppc wrt bug 181110
1128
1129 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1130 Stable for HPPA (bug #181110).
1131
1132 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1133 alpha/ia64/x86 stable wrt #181110
1134
1135 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1136 Stable on sparc wrt #181110
1137
1138 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1139 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1140
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1141 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1142 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1143 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1144 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.533

  ViewVC Help
Powered by ViewVC 1.1.20