/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.541
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.541 2012/07/24 05:44:59 jdhore Exp $
4
5 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
6 marked x86 per bug 427774
7
8 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
9 -ruby-1.9.3_p194.ebuild:
10 Cleanup.
11
12 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
13 ppc stable #411507
14
15 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
16 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
17 424611.
18
19*ruby-1.8.7_p370 (07 Jul 2012)
20
21 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
22 Version bump. Fix bug 378567 thanks to slyfox.
23
24 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
25 x86 stable, see bug 411507
26
27 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
28 arm stable, bug #411507
29
30 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
31 Stable for amd64, wrt bug #411507
32
33*ruby-1.9.3_p194-r1 (12 May 2012)
34
35 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
36 +ruby-1.9.3_p194-r1.ebuild:
37 Revision bump to fix mkmf for parallel build/install. Also enable verbose
38 build, so that the log makes sense if it fails.
39
40*ruby-1.9.3_p194 (30 Apr 2012)
41
42 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
43 Version bump.
44
45 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
46 keyword ~amd64-fbsd
47
48*ruby-1.8.7_p358 (20 Apr 2012)
49
50 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
51 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
52 Rails 3.2.
53
54 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
55 Add ~x86-fbsd, #332593
56
57*ruby-1.9.3_p125 (18 Feb 2012)
58
59 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
60 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
61
62 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
63 add ~arm, bug #332593
64
65 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
66 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
67
68 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
69 x86 stable wrt bug #396301
70
71 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
72 Stable for HPPA (bug #396301).
73
74 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
75 Stable for ppc/ppc64; bug #396301
76
77 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
78 Marked ~hppa (bug #332593).
79
80 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
81 Add back ~alpha keyword now that rubygems is keyworded.
82
83 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
84 Stable for AMD64, wrt security bug #396301
85
86*ruby-1.8.7_p357 (28 Dec 2011)
87
88 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
89 Version bump for security bug 396301.
90
91 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
92 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
93
94 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
95 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
96 keyworded, bug 332593.
97
98 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
99 Block older versions of packages that are no longer compatible. Remove
100 ancient blocks on packags long gone from the tree.
101
102 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
103 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
104 Remove old versions.
105
106*ruby-1.9.3_p0 (18 Dec 2011)
107
108 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
109 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
110 suite which need to be diagnosed first.
111
112 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
113 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
114 #332593).
115
116 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
117 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
118 #332593).
119
120 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
121 alpha/ia64/s390/sh/sparc stable wrt #386369
122
123*ruby-1.9.3_rc1 (22 Oct 2011)
124
125 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
126 Version bump.
127
128 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
129 arm stable, bug #386369
130
131 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
132 x86 stable, bug 386369
133
134 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
135 Stable for HPPA (bug #386369).
136
137 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
138 ppc/ppc64 stable wrt #386369
139
140 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
141 Stable on amd64 wrt bug #386369
142
143 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
144 Remove vulnerable version, bug 386369.
145
146*ruby-1.8.7_p352 (30 Aug 2011)
147
148 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
149 +ruby-1.8.7_p352.ebuild:
150 Patchlevel bump for ruby:1.8. Removing old version
151
152*ruby-1.9.2_p290 (30 Aug 2011)
153
154 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
155 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
156 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
157 old patchlevels.
158
159 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
160 ruby-1.8.7_p334-r2.ebuild:
161 ppc/ppc64 stable wrt #378691
162
163*ruby-1.8.7_p334-r2 (22 Jul 2011)
164
165 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
166 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
167 for chasing down upstream and us.
168
169 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
170 Added ~mips, bug 332593
171
172 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
173 ruby-1.8.7_p334-r1.ebuild:
174 ppc64 stable wrt #369141
175
176 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
177 ia64/s390/sh/sparc stable wrt #369141
178
179 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
180 Stable for HPPA (bug #369141).
181
182 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
183 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
184
185 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
186 arm/x86 stable, bug #369141
187
188 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
189 Stable on amd64 wrt bug #369141
190
191 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
192 ruby-1.8.7_p334-r1.ebuild:
193 Stable on alpha, bug #369141
194
195*ruby-1.8.7_p334-r1 (31 May 2011)
196
197 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
198 Revision bump for security bug 369141 (CVE-2011-0188)
199
200*ruby-1.9.2-r1 (16 May 2011)
201
202 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
203 Don't remove racc files since all other ruby targets ship these files
204 themselves as well. Closes bug 363419.
205
206 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
207 ruby-1.8.7_p334.ebuild:
208 Remove old version. Remove obsolete and unused old-style virtual/ruby.
209
210 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
211 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
212
213 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
214 Add append-flags -mieee on sh, bug #357559
215
216 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
217 alpha/arm/ia64/s390/sh stable wrt #355439
218
219 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
220 Marked ~ppc64 wrt #332593
221
222 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
223 ruby-1.8.7_p334.ebuild:
224 x86 stable wrt security bug #355439
225
226 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
227 ruby-1.8.7_p334.ebuild:
228 ppc/ppc64 stable wrt #355439
229
230 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
231 Stable on amd64 wrt bug #355439
232
233 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
234 Stable for HPPA (bug #355439).
235
236*ruby-1.8.7_p334 (19 Feb 2011)
237
238 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
239 Version bump 1.8.7 series, security bug 355439
240
241 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
242 ruby-1.9.2.ebuild:
243 Remove PROVIDE for old-style virtual/ruby per bug 265054.
244
245 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
246 Remove masked ruby 1.8.6 per bug 332597.
247
248 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
249 -ruby-1.9.2_rc2.ebuild:
250 Removing old and vulnerable ebuilds
251
252 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
253 Marking ruby-1.8.7_p302 ppc64 for bug 332957
254
255 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
256 alpha/ia64/s390/sh/sparc stable wrt #332957
257
258*ruby-1.9.2 (24 Aug 2010)
259
260 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
261 metadata.xml:
262 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
263 and x86-fbsd due to a new dependency on rdoc.
264
265 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
266 arm stable, bug #332957
267
268 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
269 ruby-1.8.7_p302.ebuild:
270 x86 stable wrt security bug #332957
271
272 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
273 Stable on amd64 wrt bug #332957
274
275 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
276 Stable for PPC (bug #332957).
277
278 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
279 Stable for HPPA (bug #332957).
280
281*ruby-1.8.7_p302 (21 Aug 2010)
282
283 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
284 +ruby-1.8.7_p302.ebuild:
285 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
286 installation path.
287
288*ruby-1.8.6_p399 (19 Aug 2010)
289
290 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
291 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
292 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
293 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
294 installation path (reported by the x86 team in bug 332597)
295
296*ruby-1.9.2_rc2-r1 (18 Aug 2010)
297
298 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
299 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
300 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
301 the rubygems loading code. Add USE flag for psych.
302
303 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
304 ruby-1.9.2_rc2.ebuild:
305 Remove two keepdir that will try to keep an empty path, closes bug
306 #333163.
307
308 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
309 Marked ~ppc (bug #332593).
310
311 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
312 ruby-1.9.2_rc2.ebuild:
313 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
314
315 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
316 ruby-1.8.7_p299.ebuild:
317 Bump eselect-ruby dependency
318
319 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
320 -ruby-1.9.1_p429.ebuild:
321 Remove ebuild that is not target for unmask anyway.
322
323 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
324 ruby-1.9.2_rc2.ebuild:
325 Try 2 to fix the berkdb 5 issue on 1.9.
326
327 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
328 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
329 ruby-1.9.2_rc2.ebuild:
330 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
331 support for adding new patchsets without bumping the revision for all the
332 old ebuilds as well.
333
334*ruby-1.9.2_rc2 (14 Jul 2010)
335
336 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
337 +ruby-1.9.2_rc2.ebuild:
338 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
339 might cause _further_ build failures as it changed slightly behaviour.
340 You're going to need to rebuild rubygems and then all the packages
341 previously installed after upgrading to this.
342
343 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
344 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
345 -ruby-1.9.1_p376.ebuild:
346 Cleanup old versions.
347
348*ruby-1.9.1_p429 (04 Jul 2010)
349
350 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
351 +ruby-1.9.1_p429.ebuild:
352 Version bump to new 1.9.1 release.
353
354*ruby-1.8.7_p299 (23 Jun 2010)
355
356 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
357 +ruby-1.8.7_p299.ebuild:
358 Version bump.
359
360 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
361 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
362 remove useless comments
363
364 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
365 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
366 ruby-1.9.1_p376.ebuild:
367 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
368 dev.gentoo.org now.
369
370 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
371 ruby-1.9.1_p376.ebuild:
372 Use the correct RUBYLIB.
373
374*ruby-1.8.7_p249-r2 (18 May 2010)
375*ruby-1.8.6_p388-r1 (18 May 2010)
376
377 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
378 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
379 ruby-1.9.1_p376.ebuild, metadata.xml:
380 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
381 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
382 add USE flags for ncurses, readline and libedit, and properly depend on
383 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
384 Emacs versions support ruby-mode themselves and it should be even more
385 updated.
386
387*ruby-1.8.7_p249-r1 (06 May 2010)
388
389 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
390 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
391 309789 by Sune Kloppenborg Jeppesen.
392
393 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
394 ruby-1.8.7_p249.ebuild:
395 Use $PVR instead of $PV in patchset names
396
397 06 May 2010; Alex Legler <a3li@gentoo.org>
398 -files/ruby-1.8.6-memory-leak.diff,
399 -files/ruby18-mkmf-parallel-install.patch,
400 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
401 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
402 Remove old version. Cleanup in files/
403
404*ruby-1.9.1_p376 (01 May 2010)
405
406 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
407 Version bump. Fixes security bugs 296052 and 300468. No longer installs
408 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
409 instead.
410
411 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
412 -ruby-1.8.7_p174-r1.ebuild:
413 Remove vulnerable ebuilds, 300468
414
415 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
416 ruby-1.8.7_p249.ebuild:
417 amd64 stable, security bug 300468
418
419 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
420 ruby-1.8.7_p249.ebuild:
421 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
422
423 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
424 Stable for HPPA (bug #300468).
425
426 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
427 Stable for HPPA (bug #300468).
428
429 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
430 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
431
432 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
433 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
434
435 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
436 ruby-1.8.6_p388.ebuild:
437 stable x86, security bug 300468
438
439 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
440 ruby-1.8.7_p249.ebuild:
441 stable x86, security bug 300468
442
443*ruby-1.8.6_p388 (10 Jan 2010)
444
445 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
446 +ruby-1.8.6_p388.ebuild:
447 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
448 version. The new ebuild also has the fix for bug 168939.
449
450*ruby-1.8.7_p249 (10 Jan 2010)
451
452 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
453 +ruby-1.8.7_p249.ebuild:
454 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
455 version
456
457 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
458 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
459
460*ruby-1.8.7_p248 (25 Dec 2009)
461
462 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
463 Version bump
464
465 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
466 Remove old version.
467
468 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
469 Remove old version.
470
471 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
472 ia64/s390/sh stable wrt #288699
473
474 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
475 stable sparc, bug 288699
476
477 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
478 arm stable, bug #288699
479
480 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
481 amd64/x86 stable, bug #288699
482
483 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
484 ruby-1.8.7_p174-r1.ebuild:
485 Stable on alpha, bug #288699
486
487 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
488 ppc stable #288699
489
490 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
491 Stable for HPPA (bug #288699).
492
493 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
494 Marked ~hppa too.
495
496*ruby-1.8.7_p174-r1 (06 Oct 2009)
497
498 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
499 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
500 eselect-ruby cleanup feature.
501
502*ruby-1.9.1_p243 (09 Sep 2009)
503
504 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
505 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
506 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
507 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
508 -files/ruby19-rubygems-proxy.patch,
509 -files/ruby-1.9.1_p129-parallelmake.patch,
510 -files/ruby19-mkmf-parallel-install.patch:
511 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
512 168939. Cleaning up old patches.
513
514*ruby-1.8.6_p383 (20 Aug 2009)
515
516 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
517 Patchlevel bump.
518
519 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
520 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
521 ruby-1.9.1_p129-r1.ebuild:
522 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
523
524 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
525 Removing vulnerable ebuild, bug 273213.
526
527 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
528 Marking ruby-1.8.6_p369 ppc for bug 273213
529
530 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
531 ruby-1.9.1_p129-r1.ebuild:
532 Prepend our library path instead of overwriting it during src_install.
533 Thanks to the reporter of bug #274824.
534
535*ruby-1.8.7_p174 (18 Jun 2009)
536
537 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
538 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
539 Replacing 187_p173 with _p174 because of a regression. Unifying the
540 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
541 patchsets.
542
543 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
544 Marking ruby-1.8.6_p369 ppc64 for bug 273213
545
546 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
547 arm/ia64/s390/sh/sparc stable wrt #273213
548
549 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
550 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
551 Removing old version, minor cleanup
552
553 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
554 -files/ruby-1.8.6-openssl.patch,
555 -files/ruby-1.8.6-shortname_constants.patch,
556 -files/ruby-1.8.6_p111-r13657.patch,
557 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
558 Removing vulnerable old Ruby version and stale patches, bug 274108.
559
560 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
561 ruby-1.8.6_p369.ebuild:
562 Stable on alpha, bug #273213
563
564 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
565 Stable for HPPA (bug #273213).
566
567 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
568 ruby-1.8.6_p369.ebuild:
569 stable x86, security bug 273213
570
571 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
572 amd64 stable, security bug 273213.
573
574*ruby-1.8.7_p173 (10 Jun 2009)
575*ruby-1.8.6_p369 (10 Jun 2009)
576
577 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
578 +ruby-1.8.7_p173.ebuild:
579 Version bumps for bug #273213.
580
581*ruby-1.9.1_p129-r1 (27 May 2009)
582
583 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
584 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
585 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
586 +files/ruby-1.9.1_p129-parallelmake.patch:
587 Revision bump, add patches 1) to make Ruby behave more similarly between
588 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
589 extensions (undefined symbols in them will cause abort at runtime 3) to
590 remove a concurrency issue when building the dl extension that could
591 result in a broken dl.so.
592
593 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
594 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
595 Don't block rdoc-2 or later (which may enter Portage one day as it's
596 needed by some Rakefiles).
597
598 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
599 ruby-1.9.1_p129.ebuild:
600 Add ~x86-fbsd keyword.
601
602 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
603 keyword ~sparc-fbsd, bug #252315
604
605*ruby-1.9.1_p129 (15 May 2009)
606
607 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
608 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
609 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
610 included in every release.
611
612 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
613 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
614 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
615 ruby-1.8.7_p160.ebuild:
616 Removing vulnerable versions (#268515), fixing license (#233747).
617
618 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
619 Stable for HPPA (bug #268515).
620
621 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
622 Adapting rubygems notice.
623
624 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
625 amd64 stable, bug #268515.
626
627 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
628 arm/ia64/s390/sh/sparc stable wrt #268515
629
630 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
631 ruby-1.8.6_p368.ebuild:
632 stable x86, security bug 268515
633
634 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
635 ruby-1.8.6_p368.ebuild:
636 Stable on alpha, bug #268515
637
638 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
639 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
640
641*ruby-1.8.7_p160 (07 May 2009)
642*ruby-1.8.6_p368 (07 May 2009)
643
644 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
645 +ruby-1.8.7_p160.ebuild:
646 Version bump as per secbug 268515. NB: These are the first ebuilds that
647 no longer use ruby-config.
648
649*ruby-1.9.1-r1 (03 Apr 2009)
650*ruby-1.8.7_p72-r11 (03 Apr 2009)
651*ruby-1.8.6_p287-r13 (03 Apr 2009)
652
653 03 Apr 2009; Alex Legler <a3li@gentoo.org>
654 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
655 +files/ruby18-mkmf-parallel-install.patch,
656 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
657 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
658 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
659 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
660 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
661 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
662 happy.
663
664*ruby-1.9.1 (21 Mar 2009)
665
666 21 Mar 2009; Alex Legler <a3li@gentoo.org>
667 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
668 +ruby-1.9.1.ebuild:
669 Adding Ruby 1.9.1 for preliminary testing
670
671 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
672 ruby-1.8.6_p287-r12.ebuild:
673 Marked ~ppc for bug #252315.
674
675 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
676 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
677 bug 261982.
678
679 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
680 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
681 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
682 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
683 Cleanup
684
685*ruby-1.8.7_p72-r10 (07 Mar 2009)
686
687 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
688 +ruby-1.8.7_p72-r10.ebuild:
689 Add a revision of ruby 1.8.7 using eselect ruby.
690
691 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
692 ~mips keyworded, bug #252315.
693
694 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
695 ruby-1.8.6_p287-r5.ebuild:
696 ppc stable, bug #260006
697
698 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
699 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
700
701 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
702 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
703 Fixing Tk USE flag test, bug 258893.
704
705 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
706 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
707
708 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
709 ruby-1.8.6_p287-r5.ebuild:
710 amd64 stable wrt security bug #260006
711
712 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
713 Stable for HPPA (bug #260006).
714
715 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
716 ruby-1.8.6_p287-r5.ebuild:
717 Stable on alpha, bug #260006
718
719*ruby-1.8.7_p72-r2 (23 Feb 2009)
720*ruby-1.8.6_p287-r12 (23 Feb 2009)
721*ruby-1.8.6_p287-r5 (23 Feb 2009)
722
723 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
724 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
725 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
726 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
727 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
728 now before compilation if Tk useflags don't match) and 230748 (adding
729 --enable-option-checking=no for newer versions of autoconf).
730
731 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
732 arm/ia64/s390/sh/sparc stable wrt #254307
733
734 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
735 ruby-1.8.6_p287-r4.ebuild:
736 Stable on alpha, bug #254307
737
738 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
739 ruby-1.8.6_p287-r11.ebuild:
740 keyword ~x86-fbsd, bug #252315
741
742 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
743 ppc stable #254307
744
745 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
746 amd64/x86 stable, bug #254307
747
748 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
749 stable ppc64, bug 254307
750
751 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
752 Stable for HPPA (bug #254307).
753
754 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
755 ruby-1.8.6_p287-r11.ebuild:
756 Marked ~hppa (bug #252315).
757
758*ruby-1.8.6_p287-r11 (11 Jan 2009)
759
760 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
761 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
762 +ruby-1.8.6_p287-r11.ebuild:
763 Backport conditional definition of missing openssl functions from ruby 1.8.7.
764 Fixes #254307.
765
766 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
767 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
768
769 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
770 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
771
772 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
773 ruby-1.8.6_p287-r10.ebuild:
774 Add ~sparc keyword, bug #252315
775
776*ruby-1.8.6_p287-r10 (23 Dec 2008)
777
778 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
779 +ruby-1.8.6_p287-r10.ebuild:
780 Version bump which switches from ruby-config to eselect-ruby. Dropped most
781 keywords since eselect-ruby does not yet have these keywords.
782
783 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
784 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
785 Revert the ruby-config changes. We can't remove them until we provide an
786 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
787 for breaking things as mentioned in bug #251833.
788
789 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
790 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
791 ruby-1.8.7_p72-r1.ebuild:
792 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
793 Thanks for the people noticing this in bug #251833.
794
795 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
796 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
797 ruby-1.8.7_p72-r1.ebuild:
798 Drop dependency on ruby-config, which will be removed from the tree. We
799 currently only have one major version of ruby in the tree (Ruby 1.8), so there
800 is no need for ruby-config at this moment. For newer versions of Ruby we will
801 use eselect-ruby, which can be found in the ruby overlay at the moment.
802
803 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
804 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
805 Use mirror://ruby in SRC_URI, fixes #237392.
806
807 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
808 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
809 -ruby-1.8.7_p72.ebuild:
810 Remove old versions. Leave one old stable version with cjk support.
811
812*ruby-1.8.6_p287-r3 (29 Nov 2008)
813
814 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
815 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
816 +ruby-1.8.6_p287-r3.ebuild:
817 Fix our expansion limit patch according to debian bug report
818 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
819 make sure people will pick up the fixed version. Thanks to Alex Legler for
820 mentioning the patch.
821
822*ruby-1.8.7_p72-r1 (26 Nov 2008)
823*ruby-1.8.6_p287-r2 (26 Nov 2008)
824
825 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
826 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
827 +ruby-1.8.7_p72-r1.ebuild:
828 Fix problem with shortname constants #247790, already fixed in upstream SVN.
829 Thanks to Alex Legler for providing the patch.
830
831 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
832 -ruby-1.8.6_p287.ebuild:
833 Remove versions that will not become stable
834
835 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
836 ruby-1.8.6_p287-r1.ebuild:
837 ppc stable, bug #225465
838
839 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
840 ruby-1.8.6_p287-r1.ebuild:
841 amd64 stable wrt security bug #225465
842
843 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
844 alpha/ia64/x86 stable wrt #225465
845
846 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
847 ruby-1.8.6_p287-r1.ebuild:
848 Sparc stable --- Security Bug #225465 --- good since late August.
849
850 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
851 Stable on ppc64; bug #225465
852
853 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
854 Stable for HPPA (bug #225465).
855
856*ruby-1.8.6_p287-r1 (29 Aug 2008)
857
858 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
859 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
860 +ruby-1.8.6_p287-r1.ebuild:
861 Fix REXML security issues, bug #236060.
862
863 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
864 Add GLEP 56 USE flag descriptions.
865
866*ruby-1.8.7_p72 (15 Aug 2008)
867
868 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
869 +ruby-1.8.7_p72.ebuild:
870 bump 1.8.7 to latest patch release
871
872*ruby-1.8.6_p287 (11 Aug 2008)
873
874 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
875 Version bump for brown paper bag relelease.
876
877 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
878 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
879 Remove broken version in favor of the just-added 1.8.6_p286
880
881*ruby-1.8.6_p286 (10 Aug 2008)
882
883 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
884 Version bump to latest released version of ruby 1.8.6. This version fixes the
885 security issues reported in #225465 and #234224. The cjk USE flag has been
886 dropped since no compatible patches have been released yet.
887
888 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
889 ruby-1.8.6_p230.ebuild:
890 drop cjk from SRC_URI as well
891
892 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
893 Drop cjk support since the most recent oniguruma patches no longer apply to
894 this version, #230111.
895
896 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
897 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
898 Try to fix the security issues reported in #225465 for ruby 1.8.6.
899 Unfortunately the official p230 has a change which causes segmentation faults
900 for applications like Rails and RSpec, so we are reverting that specific
901 change.
902
903*ruby-1.8.7_p22 (29 Jun 2008)
904
905 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
906 +ruby-1.8.7_p22.ebuild:
907 bump 1.8.7 for security fix
908
909 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
910 nevermind, don't bump this yet
911
912*ruby-1.8.6_p230 (20 Jun 2008)
913
914 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
915 version bump
916
917*ruby-1.8.7 (10 Jun 2008)
918
919 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
920 +ruby-1.8.7.ebuild:
921 bump 1.8.7 to final
922
923*ruby-1.8.7_pre2 (21 Apr 2008)
924
925 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
926 +ruby-1.8.7_pre2.ebuild:
927 Version Bump
928
929*ruby-1.8.7_pre1 (16 Apr 2008)
930
931 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
932 Version bump. Drop cjk until a new version of oniguruma appears.
933
934 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
935 amd64 stable, bug 212264
936
937 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
938 Stable for HPPA (bug #212264).
939
940 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
941 ruby-1.8.6_p114.ebuild:
942 ppc stable, bug #212264
943
944 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
945 alpha/ia64 stable wrt #212264
946
947 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
948 ruby-1.8.6_p114.ebuild:
949 stable x86, security bug 212264
950
951 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
952 Sparc stable, Security Bug #212264, builds and installs, initial tests run
953 as expected.
954
955 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
956 Marking ruby-1.8.6_p114 ppc64 for bug 212264
957
958*ruby-1.8.6_p114 (05 Mar 2008)
959
960 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
961 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
962 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
963 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
964 Version bump for #212264. Remove old ebuilds.
965
966 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
967 alpha/ia64 stable wrt #208916
968
969 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
970 Stable on ppc wrt bug 208916
971
972 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
973 x86 stable, bug #208916
974
975 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
976 ruby-1.8.6_p111-r1.ebuild:
977 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
978
979 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
980 -files/ruby-1.8.6-exit-status.patch,
981 -files/ruby-1.8.6_p110-net-http-p111.patch,
982 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
983 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
984 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
985 Remove old versions
986
987 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
988 Stable on ppc64
989
990 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
991 Stable on amd64; bug 199191
992
993 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
994 alpha/ia64/sparc stable wrt #199191
995
996 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
997 Remove now-obsolete warning about coreutils versions, #203156.
998
999 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1000 Stable for HPPA (bug #199191).
1001
1002*ruby-1.8.6_p111-r1 (23 Dec 2007)
1003
1004 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1005 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1006 ssl USE flags. Patch to p113.
1007
1008 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1009 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1010
1011 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1012 x86 stable, security bug #199191
1013
1014*ruby-1.8.6_p111 (23 Dec 2007)
1015
1016 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1017 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1018 Version bump with patch for bug #199191
1019
1020 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1021 Move dependency on (X)Emacs modes to PDEPEND.
1022
1023 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1024 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1025 bug 196413
1026
1027*ruby-1.8.6_p110-r2 (21 Oct 2007)
1028
1029 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1030 +ruby-1.8.6_p110-r2.ebuild:
1031 Add emacs and xemacs USE flags and use them to pull in the correct editing
1032 mode for each. Had to drop several arch keywords as reported on bug 196413.
1033
1034 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1035 amd64 stable, security bug 194236
1036
1037 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1038 ruby-1.8.6_p110-r1.ebuild:
1039 Stable on ppc64; bug #194236
1040
1041 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1042 amd64 stable, security bug 194236
1043
1044 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1045 Stable for HPPA (bug #194236).
1046
1047 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1048 alpha/ia64/sparc stable wrt security #194236
1049
1050 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1051 ruby-1.8.6_p110-r1.ebuild:
1052 ppc stable, bug #194236
1053
1054 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1055 ruby-1.8.6_p110-r1.ebuild:
1056 stable x86, security bug 194236
1057
1058 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1059 ruby-1.8.5_p113.ebuild:
1060 stable x86, security bug 194236
1061
1062 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1063 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1064 -ruby-1.8.6_p110.ebuild:
1065 Remove old versions
1066
1067*ruby-1.8.6_p110-r1 (30 Sep 2007)
1068*ruby-1.8.5_p113 (30 Sep 2007)
1069
1070 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1071 +files/ruby-1.8.5_p113-net-http-p114.patch,
1072 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1073 +ruby-1.8.6_p110-r1.ebuild:
1074 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1075 using 1.8.6-p110 as base ebuild.
1076
1077 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1078 More fixes from gentoo-dev and graaff
1079
1080 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1081 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1082
1083*ruby-1.8.6_p110 (24 Sep 2007)
1084
1085 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1086 Version bump
1087
1088*ruby-1.8.6_p36-r4 (26 Aug 2007)
1089
1090 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1091 +ruby-1.8.6_p36-r4.ebuild:
1092 Use user LDFLAGS, #181436
1093
1094 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1095 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1096 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1097 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1098
1099 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1100 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1101 -ruby-1.8.6_p36-r2.ebuild:
1102 Remove some older versions that will not be promoted to stable, keeping at
1103 least one version of each release.
1104
1105 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1106 ruby-1.8.6_p36-r3.ebuild:
1107 (QA) RESTRICT clean up.
1108
1109*ruby-1.8.6_p36-r3 (04 Jul 2007)
1110
1111 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1112 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1113 fixed memory leak loading .so bug #182946
1114
1115 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1116 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1117 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1118 ruby-1.8.6_p36-r2.ebuild:
1119 (QA) RESTRICT clean up.
1120
1121 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1122 Re-add stable keyword for alpha as per bug #181110
1123
1124 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1125 Back to ~amd64 wrt bug 181110
1126
1127 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1128 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1129
1130*ruby-1.8.6_p36-r2 (20 Jun 2007)
1131
1132 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1133 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1134
1135*ruby-1.8.6_p36-r1 (18 Jun 2007)
1136
1137 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1138 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1139 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1140 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1141 spbecker
1142
1143 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1144 Stable on amd64 wrt bug 181110
1145
1146*ruby-1.8.6_p36 (12 Jun 2007)
1147
1148 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1149 Version Bump. Bug #181379
1150
1151 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1152 Stable on mips, per #181110.
1153
1154 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1155 Stable on ppc wrt bug 181110
1156
1157 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1158 Stable for HPPA (bug #181110).
1159
1160 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1161 alpha/ia64/x86 stable wrt #181110
1162
1163 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1164 Stable on sparc wrt #181110
1165
1166 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1167 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1168
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1169 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1170 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1171 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1172 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.541

  ViewVC Help
Powered by ViewVC 1.1.20