/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.542
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.542 2012/07/25 20:15:32 blueness Exp $
4
5 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
6 ruby-1.9.3_p194-r1.ebuild:
7 Stable ppc64, bug #411507
8
9 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
10 marked x86 per bug 427774
11
12 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
13 -ruby-1.9.3_p194.ebuild:
14 Cleanup.
15
16 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
17 ppc stable #411507
18
19 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
20 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
21 424611.
22
23*ruby-1.8.7_p370 (07 Jul 2012)
24
25 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
26 Version bump. Fix bug 378567 thanks to slyfox.
27
28 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
29 x86 stable, see bug 411507
30
31 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
32 arm stable, bug #411507
33
34 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
35 Stable for amd64, wrt bug #411507
36
37*ruby-1.9.3_p194-r1 (12 May 2012)
38
39 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
40 +ruby-1.9.3_p194-r1.ebuild:
41 Revision bump to fix mkmf for parallel build/install. Also enable verbose
42 build, so that the log makes sense if it fails.
43
44*ruby-1.9.3_p194 (30 Apr 2012)
45
46 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
47 Version bump.
48
49 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
50 keyword ~amd64-fbsd
51
52*ruby-1.8.7_p358 (20 Apr 2012)
53
54 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
55 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
56 Rails 3.2.
57
58 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
59 Add ~x86-fbsd, #332593
60
61*ruby-1.9.3_p125 (18 Feb 2012)
62
63 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
64 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
65
66 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
67 add ~arm, bug #332593
68
69 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
70 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
71
72 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
73 x86 stable wrt bug #396301
74
75 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
76 Stable for HPPA (bug #396301).
77
78 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
79 Stable for ppc/ppc64; bug #396301
80
81 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
82 Marked ~hppa (bug #332593).
83
84 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
85 Add back ~alpha keyword now that rubygems is keyworded.
86
87 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
88 Stable for AMD64, wrt security bug #396301
89
90*ruby-1.8.7_p357 (28 Dec 2011)
91
92 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
93 Version bump for security bug 396301.
94
95 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
96 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
97
98 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
99 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
100 keyworded, bug 332593.
101
102 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
103 Block older versions of packages that are no longer compatible. Remove
104 ancient blocks on packags long gone from the tree.
105
106 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
107 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
108 Remove old versions.
109
110*ruby-1.9.3_p0 (18 Dec 2011)
111
112 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
113 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
114 suite which need to be diagnosed first.
115
116 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
117 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
118 #332593).
119
120 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
121 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
122 #332593).
123
124 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
125 alpha/ia64/s390/sh/sparc stable wrt #386369
126
127*ruby-1.9.3_rc1 (22 Oct 2011)
128
129 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
130 Version bump.
131
132 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
133 arm stable, bug #386369
134
135 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
136 x86 stable, bug 386369
137
138 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
139 Stable for HPPA (bug #386369).
140
141 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
142 ppc/ppc64 stable wrt #386369
143
144 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
145 Stable on amd64 wrt bug #386369
146
147 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
148 Remove vulnerable version, bug 386369.
149
150*ruby-1.8.7_p352 (30 Aug 2011)
151
152 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
153 +ruby-1.8.7_p352.ebuild:
154 Patchlevel bump for ruby:1.8. Removing old version
155
156*ruby-1.9.2_p290 (30 Aug 2011)
157
158 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
159 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
160 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
161 old patchlevels.
162
163 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
164 ruby-1.8.7_p334-r2.ebuild:
165 ppc/ppc64 stable wrt #378691
166
167*ruby-1.8.7_p334-r2 (22 Jul 2011)
168
169 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
170 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
171 for chasing down upstream and us.
172
173 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
174 Added ~mips, bug 332593
175
176 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
177 ruby-1.8.7_p334-r1.ebuild:
178 ppc64 stable wrt #369141
179
180 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
181 ia64/s390/sh/sparc stable wrt #369141
182
183 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
184 Stable for HPPA (bug #369141).
185
186 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
187 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
188
189 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
190 arm/x86 stable, bug #369141
191
192 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
193 Stable on amd64 wrt bug #369141
194
195 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
196 ruby-1.8.7_p334-r1.ebuild:
197 Stable on alpha, bug #369141
198
199*ruby-1.8.7_p334-r1 (31 May 2011)
200
201 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
202 Revision bump for security bug 369141 (CVE-2011-0188)
203
204*ruby-1.9.2-r1 (16 May 2011)
205
206 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
207 Don't remove racc files since all other ruby targets ship these files
208 themselves as well. Closes bug 363419.
209
210 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
211 ruby-1.8.7_p334.ebuild:
212 Remove old version. Remove obsolete and unused old-style virtual/ruby.
213
214 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
215 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
216
217 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
218 Add append-flags -mieee on sh, bug #357559
219
220 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
221 alpha/arm/ia64/s390/sh stable wrt #355439
222
223 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
224 Marked ~ppc64 wrt #332593
225
226 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
227 ruby-1.8.7_p334.ebuild:
228 x86 stable wrt security bug #355439
229
230 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
231 ruby-1.8.7_p334.ebuild:
232 ppc/ppc64 stable wrt #355439
233
234 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
235 Stable on amd64 wrt bug #355439
236
237 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
238 Stable for HPPA (bug #355439).
239
240*ruby-1.8.7_p334 (19 Feb 2011)
241
242 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
243 Version bump 1.8.7 series, security bug 355439
244
245 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
246 ruby-1.9.2.ebuild:
247 Remove PROVIDE for old-style virtual/ruby per bug 265054.
248
249 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
250 Remove masked ruby 1.8.6 per bug 332597.
251
252 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
253 -ruby-1.9.2_rc2.ebuild:
254 Removing old and vulnerable ebuilds
255
256 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
257 Marking ruby-1.8.7_p302 ppc64 for bug 332957
258
259 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
260 alpha/ia64/s390/sh/sparc stable wrt #332957
261
262*ruby-1.9.2 (24 Aug 2010)
263
264 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
265 metadata.xml:
266 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
267 and x86-fbsd due to a new dependency on rdoc.
268
269 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
270 arm stable, bug #332957
271
272 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
273 ruby-1.8.7_p302.ebuild:
274 x86 stable wrt security bug #332957
275
276 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
277 Stable on amd64 wrt bug #332957
278
279 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
280 Stable for PPC (bug #332957).
281
282 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
283 Stable for HPPA (bug #332957).
284
285*ruby-1.8.7_p302 (21 Aug 2010)
286
287 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
288 +ruby-1.8.7_p302.ebuild:
289 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
290 installation path.
291
292*ruby-1.8.6_p399 (19 Aug 2010)
293
294 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
295 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
296 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
297 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
298 installation path (reported by the x86 team in bug 332597)
299
300*ruby-1.9.2_rc2-r1 (18 Aug 2010)
301
302 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
303 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
304 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
305 the rubygems loading code. Add USE flag for psych.
306
307 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
308 ruby-1.9.2_rc2.ebuild:
309 Remove two keepdir that will try to keep an empty path, closes bug
310 #333163.
311
312 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
313 Marked ~ppc (bug #332593).
314
315 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
316 ruby-1.9.2_rc2.ebuild:
317 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
318
319 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
320 ruby-1.8.7_p299.ebuild:
321 Bump eselect-ruby dependency
322
323 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
324 -ruby-1.9.1_p429.ebuild:
325 Remove ebuild that is not target for unmask anyway.
326
327 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
328 ruby-1.9.2_rc2.ebuild:
329 Try 2 to fix the berkdb 5 issue on 1.9.
330
331 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
332 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
333 ruby-1.9.2_rc2.ebuild:
334 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
335 support for adding new patchsets without bumping the revision for all the
336 old ebuilds as well.
337
338*ruby-1.9.2_rc2 (14 Jul 2010)
339
340 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
341 +ruby-1.9.2_rc2.ebuild:
342 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
343 might cause _further_ build failures as it changed slightly behaviour.
344 You're going to need to rebuild rubygems and then all the packages
345 previously installed after upgrading to this.
346
347 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
348 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
349 -ruby-1.9.1_p376.ebuild:
350 Cleanup old versions.
351
352*ruby-1.9.1_p429 (04 Jul 2010)
353
354 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
355 +ruby-1.9.1_p429.ebuild:
356 Version bump to new 1.9.1 release.
357
358*ruby-1.8.7_p299 (23 Jun 2010)
359
360 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
361 +ruby-1.8.7_p299.ebuild:
362 Version bump.
363
364 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
365 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
366 remove useless comments
367
368 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
369 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
370 ruby-1.9.1_p376.ebuild:
371 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
372 dev.gentoo.org now.
373
374 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
375 ruby-1.9.1_p376.ebuild:
376 Use the correct RUBYLIB.
377
378*ruby-1.8.7_p249-r2 (18 May 2010)
379*ruby-1.8.6_p388-r1 (18 May 2010)
380
381 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
382 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
383 ruby-1.9.1_p376.ebuild, metadata.xml:
384 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
385 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
386 add USE flags for ncurses, readline and libedit, and properly depend on
387 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
388 Emacs versions support ruby-mode themselves and it should be even more
389 updated.
390
391*ruby-1.8.7_p249-r1 (06 May 2010)
392
393 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
394 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
395 309789 by Sune Kloppenborg Jeppesen.
396
397 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
398 ruby-1.8.7_p249.ebuild:
399 Use $PVR instead of $PV in patchset names
400
401 06 May 2010; Alex Legler <a3li@gentoo.org>
402 -files/ruby-1.8.6-memory-leak.diff,
403 -files/ruby18-mkmf-parallel-install.patch,
404 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
405 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
406 Remove old version. Cleanup in files/
407
408*ruby-1.9.1_p376 (01 May 2010)
409
410 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
411 Version bump. Fixes security bugs 296052 and 300468. No longer installs
412 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
413 instead.
414
415 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
416 -ruby-1.8.7_p174-r1.ebuild:
417 Remove vulnerable ebuilds, 300468
418
419 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
420 ruby-1.8.7_p249.ebuild:
421 amd64 stable, security bug 300468
422
423 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
424 ruby-1.8.7_p249.ebuild:
425 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
426
427 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
428 Stable for HPPA (bug #300468).
429
430 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
431 Stable for HPPA (bug #300468).
432
433 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
434 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
435
436 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
437 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
438
439 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
440 ruby-1.8.6_p388.ebuild:
441 stable x86, security bug 300468
442
443 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
444 ruby-1.8.7_p249.ebuild:
445 stable x86, security bug 300468
446
447*ruby-1.8.6_p388 (10 Jan 2010)
448
449 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
450 +ruby-1.8.6_p388.ebuild:
451 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
452 version. The new ebuild also has the fix for bug 168939.
453
454*ruby-1.8.7_p249 (10 Jan 2010)
455
456 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
457 +ruby-1.8.7_p249.ebuild:
458 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
459 version
460
461 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
462 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
463
464*ruby-1.8.7_p248 (25 Dec 2009)
465
466 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
467 Version bump
468
469 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
470 Remove old version.
471
472 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
473 Remove old version.
474
475 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
476 ia64/s390/sh stable wrt #288699
477
478 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
479 stable sparc, bug 288699
480
481 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
482 arm stable, bug #288699
483
484 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
485 amd64/x86 stable, bug #288699
486
487 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
488 ruby-1.8.7_p174-r1.ebuild:
489 Stable on alpha, bug #288699
490
491 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
492 ppc stable #288699
493
494 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
495 Stable for HPPA (bug #288699).
496
497 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
498 Marked ~hppa too.
499
500*ruby-1.8.7_p174-r1 (06 Oct 2009)
501
502 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
503 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
504 eselect-ruby cleanup feature.
505
506*ruby-1.9.1_p243 (09 Sep 2009)
507
508 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
509 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
510 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
511 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
512 -files/ruby19-rubygems-proxy.patch,
513 -files/ruby-1.9.1_p129-parallelmake.patch,
514 -files/ruby19-mkmf-parallel-install.patch:
515 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
516 168939. Cleaning up old patches.
517
518*ruby-1.8.6_p383 (20 Aug 2009)
519
520 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
521 Patchlevel bump.
522
523 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
524 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
525 ruby-1.9.1_p129-r1.ebuild:
526 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
527
528 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
529 Removing vulnerable ebuild, bug 273213.
530
531 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
532 Marking ruby-1.8.6_p369 ppc for bug 273213
533
534 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
535 ruby-1.9.1_p129-r1.ebuild:
536 Prepend our library path instead of overwriting it during src_install.
537 Thanks to the reporter of bug #274824.
538
539*ruby-1.8.7_p174 (18 Jun 2009)
540
541 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
542 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
543 Replacing 187_p173 with _p174 because of a regression. Unifying the
544 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
545 patchsets.
546
547 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
548 Marking ruby-1.8.6_p369 ppc64 for bug 273213
549
550 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
551 arm/ia64/s390/sh/sparc stable wrt #273213
552
553 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
554 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
555 Removing old version, minor cleanup
556
557 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
558 -files/ruby-1.8.6-openssl.patch,
559 -files/ruby-1.8.6-shortname_constants.patch,
560 -files/ruby-1.8.6_p111-r13657.patch,
561 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
562 Removing vulnerable old Ruby version and stale patches, bug 274108.
563
564 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
565 ruby-1.8.6_p369.ebuild:
566 Stable on alpha, bug #273213
567
568 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
569 Stable for HPPA (bug #273213).
570
571 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
572 ruby-1.8.6_p369.ebuild:
573 stable x86, security bug 273213
574
575 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
576 amd64 stable, security bug 273213.
577
578*ruby-1.8.7_p173 (10 Jun 2009)
579*ruby-1.8.6_p369 (10 Jun 2009)
580
581 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
582 +ruby-1.8.7_p173.ebuild:
583 Version bumps for bug #273213.
584
585*ruby-1.9.1_p129-r1 (27 May 2009)
586
587 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
588 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
589 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
590 +files/ruby-1.9.1_p129-parallelmake.patch:
591 Revision bump, add patches 1) to make Ruby behave more similarly between
592 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
593 extensions (undefined symbols in them will cause abort at runtime 3) to
594 remove a concurrency issue when building the dl extension that could
595 result in a broken dl.so.
596
597 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
598 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
599 Don't block rdoc-2 or later (which may enter Portage one day as it's
600 needed by some Rakefiles).
601
602 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
603 ruby-1.9.1_p129.ebuild:
604 Add ~x86-fbsd keyword.
605
606 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
607 keyword ~sparc-fbsd, bug #252315
608
609*ruby-1.9.1_p129 (15 May 2009)
610
611 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
612 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
613 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
614 included in every release.
615
616 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
617 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
618 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
619 ruby-1.8.7_p160.ebuild:
620 Removing vulnerable versions (#268515), fixing license (#233747).
621
622 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
623 Stable for HPPA (bug #268515).
624
625 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
626 Adapting rubygems notice.
627
628 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
629 amd64 stable, bug #268515.
630
631 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
632 arm/ia64/s390/sh/sparc stable wrt #268515
633
634 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
635 ruby-1.8.6_p368.ebuild:
636 stable x86, security bug 268515
637
638 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
639 ruby-1.8.6_p368.ebuild:
640 Stable on alpha, bug #268515
641
642 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
643 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
644
645*ruby-1.8.7_p160 (07 May 2009)
646*ruby-1.8.6_p368 (07 May 2009)
647
648 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
649 +ruby-1.8.7_p160.ebuild:
650 Version bump as per secbug 268515. NB: These are the first ebuilds that
651 no longer use ruby-config.
652
653*ruby-1.9.1-r1 (03 Apr 2009)
654*ruby-1.8.7_p72-r11 (03 Apr 2009)
655*ruby-1.8.6_p287-r13 (03 Apr 2009)
656
657 03 Apr 2009; Alex Legler <a3li@gentoo.org>
658 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
659 +files/ruby18-mkmf-parallel-install.patch,
660 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
661 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
662 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
663 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
664 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
665 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
666 happy.
667
668*ruby-1.9.1 (21 Mar 2009)
669
670 21 Mar 2009; Alex Legler <a3li@gentoo.org>
671 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
672 +ruby-1.9.1.ebuild:
673 Adding Ruby 1.9.1 for preliminary testing
674
675 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
676 ruby-1.8.6_p287-r12.ebuild:
677 Marked ~ppc for bug #252315.
678
679 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
680 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
681 bug 261982.
682
683 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
684 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
685 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
686 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
687 Cleanup
688
689*ruby-1.8.7_p72-r10 (07 Mar 2009)
690
691 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
692 +ruby-1.8.7_p72-r10.ebuild:
693 Add a revision of ruby 1.8.7 using eselect ruby.
694
695 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
696 ~mips keyworded, bug #252315.
697
698 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
699 ruby-1.8.6_p287-r5.ebuild:
700 ppc stable, bug #260006
701
702 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
703 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
704
705 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
706 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
707 Fixing Tk USE flag test, bug 258893.
708
709 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
710 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
711
712 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
713 ruby-1.8.6_p287-r5.ebuild:
714 amd64 stable wrt security bug #260006
715
716 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
717 Stable for HPPA (bug #260006).
718
719 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
720 ruby-1.8.6_p287-r5.ebuild:
721 Stable on alpha, bug #260006
722
723*ruby-1.8.7_p72-r2 (23 Feb 2009)
724*ruby-1.8.6_p287-r12 (23 Feb 2009)
725*ruby-1.8.6_p287-r5 (23 Feb 2009)
726
727 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
728 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
729 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
730 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
731 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
732 now before compilation if Tk useflags don't match) and 230748 (adding
733 --enable-option-checking=no for newer versions of autoconf).
734
735 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
736 arm/ia64/s390/sh/sparc stable wrt #254307
737
738 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
739 ruby-1.8.6_p287-r4.ebuild:
740 Stable on alpha, bug #254307
741
742 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
743 ruby-1.8.6_p287-r11.ebuild:
744 keyword ~x86-fbsd, bug #252315
745
746 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
747 ppc stable #254307
748
749 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
750 amd64/x86 stable, bug #254307
751
752 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
753 stable ppc64, bug 254307
754
755 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
756 Stable for HPPA (bug #254307).
757
758 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
759 ruby-1.8.6_p287-r11.ebuild:
760 Marked ~hppa (bug #252315).
761
762*ruby-1.8.6_p287-r11 (11 Jan 2009)
763
764 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
765 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
766 +ruby-1.8.6_p287-r11.ebuild:
767 Backport conditional definition of missing openssl functions from ruby 1.8.7.
768 Fixes #254307.
769
770 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
771 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
772
773 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
774 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
775
776 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
777 ruby-1.8.6_p287-r10.ebuild:
778 Add ~sparc keyword, bug #252315
779
780*ruby-1.8.6_p287-r10 (23 Dec 2008)
781
782 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
783 +ruby-1.8.6_p287-r10.ebuild:
784 Version bump which switches from ruby-config to eselect-ruby. Dropped most
785 keywords since eselect-ruby does not yet have these keywords.
786
787 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
788 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
789 Revert the ruby-config changes. We can't remove them until we provide an
790 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
791 for breaking things as mentioned in bug #251833.
792
793 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
794 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
795 ruby-1.8.7_p72-r1.ebuild:
796 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
797 Thanks for the people noticing this in bug #251833.
798
799 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
800 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
801 ruby-1.8.7_p72-r1.ebuild:
802 Drop dependency on ruby-config, which will be removed from the tree. We
803 currently only have one major version of ruby in the tree (Ruby 1.8), so there
804 is no need for ruby-config at this moment. For newer versions of Ruby we will
805 use eselect-ruby, which can be found in the ruby overlay at the moment.
806
807 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
808 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
809 Use mirror://ruby in SRC_URI, fixes #237392.
810
811 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
812 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
813 -ruby-1.8.7_p72.ebuild:
814 Remove old versions. Leave one old stable version with cjk support.
815
816*ruby-1.8.6_p287-r3 (29 Nov 2008)
817
818 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
819 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
820 +ruby-1.8.6_p287-r3.ebuild:
821 Fix our expansion limit patch according to debian bug report
822 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
823 make sure people will pick up the fixed version. Thanks to Alex Legler for
824 mentioning the patch.
825
826*ruby-1.8.7_p72-r1 (26 Nov 2008)
827*ruby-1.8.6_p287-r2 (26 Nov 2008)
828
829 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
830 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
831 +ruby-1.8.7_p72-r1.ebuild:
832 Fix problem with shortname constants #247790, already fixed in upstream SVN.
833 Thanks to Alex Legler for providing the patch.
834
835 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
836 -ruby-1.8.6_p287.ebuild:
837 Remove versions that will not become stable
838
839 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
840 ruby-1.8.6_p287-r1.ebuild:
841 ppc stable, bug #225465
842
843 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
844 ruby-1.8.6_p287-r1.ebuild:
845 amd64 stable wrt security bug #225465
846
847 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
848 alpha/ia64/x86 stable wrt #225465
849
850 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
851 ruby-1.8.6_p287-r1.ebuild:
852 Sparc stable --- Security Bug #225465 --- good since late August.
853
854 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
855 Stable on ppc64; bug #225465
856
857 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
858 Stable for HPPA (bug #225465).
859
860*ruby-1.8.6_p287-r1 (29 Aug 2008)
861
862 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
863 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
864 +ruby-1.8.6_p287-r1.ebuild:
865 Fix REXML security issues, bug #236060.
866
867 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
868 Add GLEP 56 USE flag descriptions.
869
870*ruby-1.8.7_p72 (15 Aug 2008)
871
872 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
873 +ruby-1.8.7_p72.ebuild:
874 bump 1.8.7 to latest patch release
875
876*ruby-1.8.6_p287 (11 Aug 2008)
877
878 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
879 Version bump for brown paper bag relelease.
880
881 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
882 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
883 Remove broken version in favor of the just-added 1.8.6_p286
884
885*ruby-1.8.6_p286 (10 Aug 2008)
886
887 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
888 Version bump to latest released version of ruby 1.8.6. This version fixes the
889 security issues reported in #225465 and #234224. The cjk USE flag has been
890 dropped since no compatible patches have been released yet.
891
892 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
893 ruby-1.8.6_p230.ebuild:
894 drop cjk from SRC_URI as well
895
896 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
897 Drop cjk support since the most recent oniguruma patches no longer apply to
898 this version, #230111.
899
900 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
901 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
902 Try to fix the security issues reported in #225465 for ruby 1.8.6.
903 Unfortunately the official p230 has a change which causes segmentation faults
904 for applications like Rails and RSpec, so we are reverting that specific
905 change.
906
907*ruby-1.8.7_p22 (29 Jun 2008)
908
909 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
910 +ruby-1.8.7_p22.ebuild:
911 bump 1.8.7 for security fix
912
913 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
914 nevermind, don't bump this yet
915
916*ruby-1.8.6_p230 (20 Jun 2008)
917
918 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
919 version bump
920
921*ruby-1.8.7 (10 Jun 2008)
922
923 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
924 +ruby-1.8.7.ebuild:
925 bump 1.8.7 to final
926
927*ruby-1.8.7_pre2 (21 Apr 2008)
928
929 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
930 +ruby-1.8.7_pre2.ebuild:
931 Version Bump
932
933*ruby-1.8.7_pre1 (16 Apr 2008)
934
935 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
936 Version bump. Drop cjk until a new version of oniguruma appears.
937
938 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
939 amd64 stable, bug 212264
940
941 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
942 Stable for HPPA (bug #212264).
943
944 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
945 ruby-1.8.6_p114.ebuild:
946 ppc stable, bug #212264
947
948 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
949 alpha/ia64 stable wrt #212264
950
951 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
952 ruby-1.8.6_p114.ebuild:
953 stable x86, security bug 212264
954
955 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
956 Sparc stable, Security Bug #212264, builds and installs, initial tests run
957 as expected.
958
959 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
960 Marking ruby-1.8.6_p114 ppc64 for bug 212264
961
962*ruby-1.8.6_p114 (05 Mar 2008)
963
964 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
965 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
966 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
967 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
968 Version bump for #212264. Remove old ebuilds.
969
970 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
971 alpha/ia64 stable wrt #208916
972
973 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
974 Stable on ppc wrt bug 208916
975
976 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
977 x86 stable, bug #208916
978
979 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
980 ruby-1.8.6_p111-r1.ebuild:
981 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
982
983 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
984 -files/ruby-1.8.6-exit-status.patch,
985 -files/ruby-1.8.6_p110-net-http-p111.patch,
986 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
987 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
988 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
989 Remove old versions
990
991 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
992 Stable on ppc64
993
994 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
995 Stable on amd64; bug 199191
996
997 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
998 alpha/ia64/sparc stable wrt #199191
999
1000 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1001 Remove now-obsolete warning about coreutils versions, #203156.
1002
1003 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1004 Stable for HPPA (bug #199191).
1005
1006*ruby-1.8.6_p111-r1 (23 Dec 2007)
1007
1008 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1009 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1010 ssl USE flags. Patch to p113.
1011
1012 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1013 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1014
1015 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1016 x86 stable, security bug #199191
1017
1018*ruby-1.8.6_p111 (23 Dec 2007)
1019
1020 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1021 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1022 Version bump with patch for bug #199191
1023
1024 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1025 Move dependency on (X)Emacs modes to PDEPEND.
1026
1027 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1028 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1029 bug 196413
1030
1031*ruby-1.8.6_p110-r2 (21 Oct 2007)
1032
1033 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1034 +ruby-1.8.6_p110-r2.ebuild:
1035 Add emacs and xemacs USE flags and use them to pull in the correct editing
1036 mode for each. Had to drop several arch keywords as reported on bug 196413.
1037
1038 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1039 amd64 stable, security bug 194236
1040
1041 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1042 ruby-1.8.6_p110-r1.ebuild:
1043 Stable on ppc64; bug #194236
1044
1045 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1046 amd64 stable, security bug 194236
1047
1048 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1049 Stable for HPPA (bug #194236).
1050
1051 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1052 alpha/ia64/sparc stable wrt security #194236
1053
1054 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1055 ruby-1.8.6_p110-r1.ebuild:
1056 ppc stable, bug #194236
1057
1058 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1059 ruby-1.8.6_p110-r1.ebuild:
1060 stable x86, security bug 194236
1061
1062 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1063 ruby-1.8.5_p113.ebuild:
1064 stable x86, security bug 194236
1065
1066 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1067 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1068 -ruby-1.8.6_p110.ebuild:
1069 Remove old versions
1070
1071*ruby-1.8.6_p110-r1 (30 Sep 2007)
1072*ruby-1.8.5_p113 (30 Sep 2007)
1073
1074 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1075 +files/ruby-1.8.5_p113-net-http-p114.patch,
1076 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1077 +ruby-1.8.6_p110-r1.ebuild:
1078 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1079 using 1.8.6-p110 as base ebuild.
1080
1081 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1082 More fixes from gentoo-dev and graaff
1083
1084 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1085 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1086
1087*ruby-1.8.6_p110 (24 Sep 2007)
1088
1089 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1090 Version bump
1091
1092*ruby-1.8.6_p36-r4 (26 Aug 2007)
1093
1094 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1095 +ruby-1.8.6_p36-r4.ebuild:
1096 Use user LDFLAGS, #181436
1097
1098 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1099 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1100 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1101 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1102
1103 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1104 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1105 -ruby-1.8.6_p36-r2.ebuild:
1106 Remove some older versions that will not be promoted to stable, keeping at
1107 least one version of each release.
1108
1109 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1110 ruby-1.8.6_p36-r3.ebuild:
1111 (QA) RESTRICT clean up.
1112
1113*ruby-1.8.6_p36-r3 (04 Jul 2007)
1114
1115 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1116 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1117 fixed memory leak loading .so bug #182946
1118
1119 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1120 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1121 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1122 ruby-1.8.6_p36-r2.ebuild:
1123 (QA) RESTRICT clean up.
1124
1125 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1126 Re-add stable keyword for alpha as per bug #181110
1127
1128 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1129 Back to ~amd64 wrt bug 181110
1130
1131 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1132 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1133
1134*ruby-1.8.6_p36-r2 (20 Jun 2007)
1135
1136 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1137 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1138
1139*ruby-1.8.6_p36-r1 (18 Jun 2007)
1140
1141 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1142 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1143 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1144 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1145 spbecker
1146
1147 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1148 Stable on amd64 wrt bug 181110
1149
1150*ruby-1.8.6_p36 (12 Jun 2007)
1151
1152 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1153 Version Bump. Bug #181379
1154
1155 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1156 Stable on mips, per #181110.
1157
1158 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1159 Stable on ppc wrt bug 181110
1160
1161 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1162 Stable for HPPA (bug #181110).
1163
1164 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1165 alpha/ia64/x86 stable wrt #181110
1166
1167 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1168 Stable on sparc wrt #181110
1169
1170 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1171 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1172
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1173 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1174 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1175 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1176 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.542

  ViewVC Help
Powered by ViewVC 1.1.20