/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.543
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.543 2012/08/02 20:50:01 maekke Exp $
4
5 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
6 arm stable, bug #427774
7
8 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
9 ruby-1.9.3_p194-r1.ebuild:
10 Stable ppc64, bug #411507
11
12 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
13 marked x86 per bug 427774
14
15 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
16 -ruby-1.9.3_p194.ebuild:
17 Cleanup.
18
19 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
20 ppc stable #411507
21
22 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
23 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
24 424611.
25
26*ruby-1.8.7_p370 (07 Jul 2012)
27
28 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
29 Version bump. Fix bug 378567 thanks to slyfox.
30
31 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
32 x86 stable, see bug 411507
33
34 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
35 arm stable, bug #411507
36
37 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
38 Stable for amd64, wrt bug #411507
39
40*ruby-1.9.3_p194-r1 (12 May 2012)
41
42 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
43 +ruby-1.9.3_p194-r1.ebuild:
44 Revision bump to fix mkmf for parallel build/install. Also enable verbose
45 build, so that the log makes sense if it fails.
46
47*ruby-1.9.3_p194 (30 Apr 2012)
48
49 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
50 Version bump.
51
52 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
53 keyword ~amd64-fbsd
54
55*ruby-1.8.7_p358 (20 Apr 2012)
56
57 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
58 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
59 Rails 3.2.
60
61 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
62 Add ~x86-fbsd, #332593
63
64*ruby-1.9.3_p125 (18 Feb 2012)
65
66 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
67 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
68
69 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
70 add ~arm, bug #332593
71
72 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
73 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
74
75 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
76 x86 stable wrt bug #396301
77
78 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
79 Stable for HPPA (bug #396301).
80
81 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
82 Stable for ppc/ppc64; bug #396301
83
84 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
85 Marked ~hppa (bug #332593).
86
87 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
88 Add back ~alpha keyword now that rubygems is keyworded.
89
90 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
91 Stable for AMD64, wrt security bug #396301
92
93*ruby-1.8.7_p357 (28 Dec 2011)
94
95 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
96 Version bump for security bug 396301.
97
98 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
99 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
100
101 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
102 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
103 keyworded, bug 332593.
104
105 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
106 Block older versions of packages that are no longer compatible. Remove
107 ancient blocks on packags long gone from the tree.
108
109 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
110 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
111 Remove old versions.
112
113*ruby-1.9.3_p0 (18 Dec 2011)
114
115 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
116 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
117 suite which need to be diagnosed first.
118
119 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
120 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
121 #332593).
122
123 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
124 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
125 #332593).
126
127 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
128 alpha/ia64/s390/sh/sparc stable wrt #386369
129
130*ruby-1.9.3_rc1 (22 Oct 2011)
131
132 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
133 Version bump.
134
135 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
136 arm stable, bug #386369
137
138 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
139 x86 stable, bug 386369
140
141 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
142 Stable for HPPA (bug #386369).
143
144 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
145 ppc/ppc64 stable wrt #386369
146
147 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
148 Stable on amd64 wrt bug #386369
149
150 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
151 Remove vulnerable version, bug 386369.
152
153*ruby-1.8.7_p352 (30 Aug 2011)
154
155 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
156 +ruby-1.8.7_p352.ebuild:
157 Patchlevel bump for ruby:1.8. Removing old version
158
159*ruby-1.9.2_p290 (30 Aug 2011)
160
161 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
162 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
163 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
164 old patchlevels.
165
166 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
167 ruby-1.8.7_p334-r2.ebuild:
168 ppc/ppc64 stable wrt #378691
169
170*ruby-1.8.7_p334-r2 (22 Jul 2011)
171
172 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
173 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
174 for chasing down upstream and us.
175
176 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
177 Added ~mips, bug 332593
178
179 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
180 ruby-1.8.7_p334-r1.ebuild:
181 ppc64 stable wrt #369141
182
183 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
184 ia64/s390/sh/sparc stable wrt #369141
185
186 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
187 Stable for HPPA (bug #369141).
188
189 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
190 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
191
192 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
193 arm/x86 stable, bug #369141
194
195 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
196 Stable on amd64 wrt bug #369141
197
198 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
199 ruby-1.8.7_p334-r1.ebuild:
200 Stable on alpha, bug #369141
201
202*ruby-1.8.7_p334-r1 (31 May 2011)
203
204 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
205 Revision bump for security bug 369141 (CVE-2011-0188)
206
207*ruby-1.9.2-r1 (16 May 2011)
208
209 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
210 Don't remove racc files since all other ruby targets ship these files
211 themselves as well. Closes bug 363419.
212
213 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
214 ruby-1.8.7_p334.ebuild:
215 Remove old version. Remove obsolete and unused old-style virtual/ruby.
216
217 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
218 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
219
220 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
221 Add append-flags -mieee on sh, bug #357559
222
223 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
224 alpha/arm/ia64/s390/sh stable wrt #355439
225
226 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
227 Marked ~ppc64 wrt #332593
228
229 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
230 ruby-1.8.7_p334.ebuild:
231 x86 stable wrt security bug #355439
232
233 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
234 ruby-1.8.7_p334.ebuild:
235 ppc/ppc64 stable wrt #355439
236
237 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
238 Stable on amd64 wrt bug #355439
239
240 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
241 Stable for HPPA (bug #355439).
242
243*ruby-1.8.7_p334 (19 Feb 2011)
244
245 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
246 Version bump 1.8.7 series, security bug 355439
247
248 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
249 ruby-1.9.2.ebuild:
250 Remove PROVIDE for old-style virtual/ruby per bug 265054.
251
252 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
253 Remove masked ruby 1.8.6 per bug 332597.
254
255 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
256 -ruby-1.9.2_rc2.ebuild:
257 Removing old and vulnerable ebuilds
258
259 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
260 Marking ruby-1.8.7_p302 ppc64 for bug 332957
261
262 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
263 alpha/ia64/s390/sh/sparc stable wrt #332957
264
265*ruby-1.9.2 (24 Aug 2010)
266
267 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
268 metadata.xml:
269 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
270 and x86-fbsd due to a new dependency on rdoc.
271
272 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
273 arm stable, bug #332957
274
275 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
276 ruby-1.8.7_p302.ebuild:
277 x86 stable wrt security bug #332957
278
279 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
280 Stable on amd64 wrt bug #332957
281
282 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
283 Stable for PPC (bug #332957).
284
285 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
286 Stable for HPPA (bug #332957).
287
288*ruby-1.8.7_p302 (21 Aug 2010)
289
290 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
291 +ruby-1.8.7_p302.ebuild:
292 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
293 installation path.
294
295*ruby-1.8.6_p399 (19 Aug 2010)
296
297 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
298 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
299 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
300 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
301 installation path (reported by the x86 team in bug 332597)
302
303*ruby-1.9.2_rc2-r1 (18 Aug 2010)
304
305 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
306 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
307 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
308 the rubygems loading code. Add USE flag for psych.
309
310 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
311 ruby-1.9.2_rc2.ebuild:
312 Remove two keepdir that will try to keep an empty path, closes bug
313 #333163.
314
315 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
316 Marked ~ppc (bug #332593).
317
318 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
319 ruby-1.9.2_rc2.ebuild:
320 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
321
322 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
323 ruby-1.8.7_p299.ebuild:
324 Bump eselect-ruby dependency
325
326 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
327 -ruby-1.9.1_p429.ebuild:
328 Remove ebuild that is not target for unmask anyway.
329
330 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
331 ruby-1.9.2_rc2.ebuild:
332 Try 2 to fix the berkdb 5 issue on 1.9.
333
334 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
335 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
336 ruby-1.9.2_rc2.ebuild:
337 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
338 support for adding new patchsets without bumping the revision for all the
339 old ebuilds as well.
340
341*ruby-1.9.2_rc2 (14 Jul 2010)
342
343 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
344 +ruby-1.9.2_rc2.ebuild:
345 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
346 might cause _further_ build failures as it changed slightly behaviour.
347 You're going to need to rebuild rubygems and then all the packages
348 previously installed after upgrading to this.
349
350 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
351 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
352 -ruby-1.9.1_p376.ebuild:
353 Cleanup old versions.
354
355*ruby-1.9.1_p429 (04 Jul 2010)
356
357 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
358 +ruby-1.9.1_p429.ebuild:
359 Version bump to new 1.9.1 release.
360
361*ruby-1.8.7_p299 (23 Jun 2010)
362
363 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
364 +ruby-1.8.7_p299.ebuild:
365 Version bump.
366
367 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
368 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
369 remove useless comments
370
371 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
372 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
373 ruby-1.9.1_p376.ebuild:
374 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
375 dev.gentoo.org now.
376
377 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
378 ruby-1.9.1_p376.ebuild:
379 Use the correct RUBYLIB.
380
381*ruby-1.8.7_p249-r2 (18 May 2010)
382*ruby-1.8.6_p388-r1 (18 May 2010)
383
384 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
385 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
386 ruby-1.9.1_p376.ebuild, metadata.xml:
387 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
388 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
389 add USE flags for ncurses, readline and libedit, and properly depend on
390 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
391 Emacs versions support ruby-mode themselves and it should be even more
392 updated.
393
394*ruby-1.8.7_p249-r1 (06 May 2010)
395
396 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
397 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
398 309789 by Sune Kloppenborg Jeppesen.
399
400 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
401 ruby-1.8.7_p249.ebuild:
402 Use $PVR instead of $PV in patchset names
403
404 06 May 2010; Alex Legler <a3li@gentoo.org>
405 -files/ruby-1.8.6-memory-leak.diff,
406 -files/ruby18-mkmf-parallel-install.patch,
407 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
408 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
409 Remove old version. Cleanup in files/
410
411*ruby-1.9.1_p376 (01 May 2010)
412
413 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
414 Version bump. Fixes security bugs 296052 and 300468. No longer installs
415 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
416 instead.
417
418 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
419 -ruby-1.8.7_p174-r1.ebuild:
420 Remove vulnerable ebuilds, 300468
421
422 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
423 ruby-1.8.7_p249.ebuild:
424 amd64 stable, security bug 300468
425
426 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
427 ruby-1.8.7_p249.ebuild:
428 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
429
430 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
431 Stable for HPPA (bug #300468).
432
433 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
434 Stable for HPPA (bug #300468).
435
436 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
437 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
438
439 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
440 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
441
442 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
443 ruby-1.8.6_p388.ebuild:
444 stable x86, security bug 300468
445
446 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
447 ruby-1.8.7_p249.ebuild:
448 stable x86, security bug 300468
449
450*ruby-1.8.6_p388 (10 Jan 2010)
451
452 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
453 +ruby-1.8.6_p388.ebuild:
454 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
455 version. The new ebuild also has the fix for bug 168939.
456
457*ruby-1.8.7_p249 (10 Jan 2010)
458
459 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
460 +ruby-1.8.7_p249.ebuild:
461 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
462 version
463
464 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
465 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
466
467*ruby-1.8.7_p248 (25 Dec 2009)
468
469 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
470 Version bump
471
472 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
473 Remove old version.
474
475 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
476 Remove old version.
477
478 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
479 ia64/s390/sh stable wrt #288699
480
481 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
482 stable sparc, bug 288699
483
484 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
485 arm stable, bug #288699
486
487 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
488 amd64/x86 stable, bug #288699
489
490 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
491 ruby-1.8.7_p174-r1.ebuild:
492 Stable on alpha, bug #288699
493
494 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
495 ppc stable #288699
496
497 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
498 Stable for HPPA (bug #288699).
499
500 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
501 Marked ~hppa too.
502
503*ruby-1.8.7_p174-r1 (06 Oct 2009)
504
505 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
506 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
507 eselect-ruby cleanup feature.
508
509*ruby-1.9.1_p243 (09 Sep 2009)
510
511 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
512 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
513 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
514 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
515 -files/ruby19-rubygems-proxy.patch,
516 -files/ruby-1.9.1_p129-parallelmake.patch,
517 -files/ruby19-mkmf-parallel-install.patch:
518 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
519 168939. Cleaning up old patches.
520
521*ruby-1.8.6_p383 (20 Aug 2009)
522
523 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
524 Patchlevel bump.
525
526 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
527 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
528 ruby-1.9.1_p129-r1.ebuild:
529 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
530
531 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
532 Removing vulnerable ebuild, bug 273213.
533
534 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
535 Marking ruby-1.8.6_p369 ppc for bug 273213
536
537 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
538 ruby-1.9.1_p129-r1.ebuild:
539 Prepend our library path instead of overwriting it during src_install.
540 Thanks to the reporter of bug #274824.
541
542*ruby-1.8.7_p174 (18 Jun 2009)
543
544 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
545 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
546 Replacing 187_p173 with _p174 because of a regression. Unifying the
547 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
548 patchsets.
549
550 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
551 Marking ruby-1.8.6_p369 ppc64 for bug 273213
552
553 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
554 arm/ia64/s390/sh/sparc stable wrt #273213
555
556 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
557 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
558 Removing old version, minor cleanup
559
560 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
561 -files/ruby-1.8.6-openssl.patch,
562 -files/ruby-1.8.6-shortname_constants.patch,
563 -files/ruby-1.8.6_p111-r13657.patch,
564 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
565 Removing vulnerable old Ruby version and stale patches, bug 274108.
566
567 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
568 ruby-1.8.6_p369.ebuild:
569 Stable on alpha, bug #273213
570
571 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
572 Stable for HPPA (bug #273213).
573
574 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
575 ruby-1.8.6_p369.ebuild:
576 stable x86, security bug 273213
577
578 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
579 amd64 stable, security bug 273213.
580
581*ruby-1.8.7_p173 (10 Jun 2009)
582*ruby-1.8.6_p369 (10 Jun 2009)
583
584 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
585 +ruby-1.8.7_p173.ebuild:
586 Version bumps for bug #273213.
587
588*ruby-1.9.1_p129-r1 (27 May 2009)
589
590 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
591 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
592 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
593 +files/ruby-1.9.1_p129-parallelmake.patch:
594 Revision bump, add patches 1) to make Ruby behave more similarly between
595 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
596 extensions (undefined symbols in them will cause abort at runtime 3) to
597 remove a concurrency issue when building the dl extension that could
598 result in a broken dl.so.
599
600 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
601 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
602 Don't block rdoc-2 or later (which may enter Portage one day as it's
603 needed by some Rakefiles).
604
605 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
606 ruby-1.9.1_p129.ebuild:
607 Add ~x86-fbsd keyword.
608
609 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
610 keyword ~sparc-fbsd, bug #252315
611
612*ruby-1.9.1_p129 (15 May 2009)
613
614 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
615 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
616 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
617 included in every release.
618
619 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
620 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
621 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
622 ruby-1.8.7_p160.ebuild:
623 Removing vulnerable versions (#268515), fixing license (#233747).
624
625 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
626 Stable for HPPA (bug #268515).
627
628 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
629 Adapting rubygems notice.
630
631 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
632 amd64 stable, bug #268515.
633
634 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
635 arm/ia64/s390/sh/sparc stable wrt #268515
636
637 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
638 ruby-1.8.6_p368.ebuild:
639 stable x86, security bug 268515
640
641 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
642 ruby-1.8.6_p368.ebuild:
643 Stable on alpha, bug #268515
644
645 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
646 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
647
648*ruby-1.8.7_p160 (07 May 2009)
649*ruby-1.8.6_p368 (07 May 2009)
650
651 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
652 +ruby-1.8.7_p160.ebuild:
653 Version bump as per secbug 268515. NB: These are the first ebuilds that
654 no longer use ruby-config.
655
656*ruby-1.9.1-r1 (03 Apr 2009)
657*ruby-1.8.7_p72-r11 (03 Apr 2009)
658*ruby-1.8.6_p287-r13 (03 Apr 2009)
659
660 03 Apr 2009; Alex Legler <a3li@gentoo.org>
661 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
662 +files/ruby18-mkmf-parallel-install.patch,
663 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
664 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
665 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
666 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
667 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
668 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
669 happy.
670
671*ruby-1.9.1 (21 Mar 2009)
672
673 21 Mar 2009; Alex Legler <a3li@gentoo.org>
674 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
675 +ruby-1.9.1.ebuild:
676 Adding Ruby 1.9.1 for preliminary testing
677
678 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
679 ruby-1.8.6_p287-r12.ebuild:
680 Marked ~ppc for bug #252315.
681
682 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
683 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
684 bug 261982.
685
686 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
687 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
688 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
689 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
690 Cleanup
691
692*ruby-1.8.7_p72-r10 (07 Mar 2009)
693
694 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
695 +ruby-1.8.7_p72-r10.ebuild:
696 Add a revision of ruby 1.8.7 using eselect ruby.
697
698 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
699 ~mips keyworded, bug #252315.
700
701 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
702 ruby-1.8.6_p287-r5.ebuild:
703 ppc stable, bug #260006
704
705 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
706 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
707
708 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
709 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
710 Fixing Tk USE flag test, bug 258893.
711
712 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
713 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
714
715 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
716 ruby-1.8.6_p287-r5.ebuild:
717 amd64 stable wrt security bug #260006
718
719 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
720 Stable for HPPA (bug #260006).
721
722 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
723 ruby-1.8.6_p287-r5.ebuild:
724 Stable on alpha, bug #260006
725
726*ruby-1.8.7_p72-r2 (23 Feb 2009)
727*ruby-1.8.6_p287-r12 (23 Feb 2009)
728*ruby-1.8.6_p287-r5 (23 Feb 2009)
729
730 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
731 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
732 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
733 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
734 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
735 now before compilation if Tk useflags don't match) and 230748 (adding
736 --enable-option-checking=no for newer versions of autoconf).
737
738 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
739 arm/ia64/s390/sh/sparc stable wrt #254307
740
741 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
742 ruby-1.8.6_p287-r4.ebuild:
743 Stable on alpha, bug #254307
744
745 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
746 ruby-1.8.6_p287-r11.ebuild:
747 keyword ~x86-fbsd, bug #252315
748
749 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
750 ppc stable #254307
751
752 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
753 amd64/x86 stable, bug #254307
754
755 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
756 stable ppc64, bug 254307
757
758 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
759 Stable for HPPA (bug #254307).
760
761 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
762 ruby-1.8.6_p287-r11.ebuild:
763 Marked ~hppa (bug #252315).
764
765*ruby-1.8.6_p287-r11 (11 Jan 2009)
766
767 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
768 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
769 +ruby-1.8.6_p287-r11.ebuild:
770 Backport conditional definition of missing openssl functions from ruby 1.8.7.
771 Fixes #254307.
772
773 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
774 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
775
776 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
777 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
778
779 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
780 ruby-1.8.6_p287-r10.ebuild:
781 Add ~sparc keyword, bug #252315
782
783*ruby-1.8.6_p287-r10 (23 Dec 2008)
784
785 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
786 +ruby-1.8.6_p287-r10.ebuild:
787 Version bump which switches from ruby-config to eselect-ruby. Dropped most
788 keywords since eselect-ruby does not yet have these keywords.
789
790 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
791 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
792 Revert the ruby-config changes. We can't remove them until we provide an
793 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
794 for breaking things as mentioned in bug #251833.
795
796 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
797 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
798 ruby-1.8.7_p72-r1.ebuild:
799 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
800 Thanks for the people noticing this in bug #251833.
801
802 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
803 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
804 ruby-1.8.7_p72-r1.ebuild:
805 Drop dependency on ruby-config, which will be removed from the tree. We
806 currently only have one major version of ruby in the tree (Ruby 1.8), so there
807 is no need for ruby-config at this moment. For newer versions of Ruby we will
808 use eselect-ruby, which can be found in the ruby overlay at the moment.
809
810 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
811 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
812 Use mirror://ruby in SRC_URI, fixes #237392.
813
814 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
815 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
816 -ruby-1.8.7_p72.ebuild:
817 Remove old versions. Leave one old stable version with cjk support.
818
819*ruby-1.8.6_p287-r3 (29 Nov 2008)
820
821 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
822 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
823 +ruby-1.8.6_p287-r3.ebuild:
824 Fix our expansion limit patch according to debian bug report
825 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
826 make sure people will pick up the fixed version. Thanks to Alex Legler for
827 mentioning the patch.
828
829*ruby-1.8.7_p72-r1 (26 Nov 2008)
830*ruby-1.8.6_p287-r2 (26 Nov 2008)
831
832 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
833 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
834 +ruby-1.8.7_p72-r1.ebuild:
835 Fix problem with shortname constants #247790, already fixed in upstream SVN.
836 Thanks to Alex Legler for providing the patch.
837
838 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
839 -ruby-1.8.6_p287.ebuild:
840 Remove versions that will not become stable
841
842 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
843 ruby-1.8.6_p287-r1.ebuild:
844 ppc stable, bug #225465
845
846 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
847 ruby-1.8.6_p287-r1.ebuild:
848 amd64 stable wrt security bug #225465
849
850 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
851 alpha/ia64/x86 stable wrt #225465
852
853 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
854 ruby-1.8.6_p287-r1.ebuild:
855 Sparc stable --- Security Bug #225465 --- good since late August.
856
857 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
858 Stable on ppc64; bug #225465
859
860 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
861 Stable for HPPA (bug #225465).
862
863*ruby-1.8.6_p287-r1 (29 Aug 2008)
864
865 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
866 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
867 +ruby-1.8.6_p287-r1.ebuild:
868 Fix REXML security issues, bug #236060.
869
870 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
871 Add GLEP 56 USE flag descriptions.
872
873*ruby-1.8.7_p72 (15 Aug 2008)
874
875 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
876 +ruby-1.8.7_p72.ebuild:
877 bump 1.8.7 to latest patch release
878
879*ruby-1.8.6_p287 (11 Aug 2008)
880
881 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
882 Version bump for brown paper bag relelease.
883
884 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
885 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
886 Remove broken version in favor of the just-added 1.8.6_p286
887
888*ruby-1.8.6_p286 (10 Aug 2008)
889
890 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
891 Version bump to latest released version of ruby 1.8.6. This version fixes the
892 security issues reported in #225465 and #234224. The cjk USE flag has been
893 dropped since no compatible patches have been released yet.
894
895 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
896 ruby-1.8.6_p230.ebuild:
897 drop cjk from SRC_URI as well
898
899 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
900 Drop cjk support since the most recent oniguruma patches no longer apply to
901 this version, #230111.
902
903 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
904 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
905 Try to fix the security issues reported in #225465 for ruby 1.8.6.
906 Unfortunately the official p230 has a change which causes segmentation faults
907 for applications like Rails and RSpec, so we are reverting that specific
908 change.
909
910*ruby-1.8.7_p22 (29 Jun 2008)
911
912 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
913 +ruby-1.8.7_p22.ebuild:
914 bump 1.8.7 for security fix
915
916 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
917 nevermind, don't bump this yet
918
919*ruby-1.8.6_p230 (20 Jun 2008)
920
921 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
922 version bump
923
924*ruby-1.8.7 (10 Jun 2008)
925
926 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
927 +ruby-1.8.7.ebuild:
928 bump 1.8.7 to final
929
930*ruby-1.8.7_pre2 (21 Apr 2008)
931
932 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
933 +ruby-1.8.7_pre2.ebuild:
934 Version Bump
935
936*ruby-1.8.7_pre1 (16 Apr 2008)
937
938 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
939 Version bump. Drop cjk until a new version of oniguruma appears.
940
941 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
942 amd64 stable, bug 212264
943
944 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
945 Stable for HPPA (bug #212264).
946
947 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
948 ruby-1.8.6_p114.ebuild:
949 ppc stable, bug #212264
950
951 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
952 alpha/ia64 stable wrt #212264
953
954 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
955 ruby-1.8.6_p114.ebuild:
956 stable x86, security bug 212264
957
958 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
959 Sparc stable, Security Bug #212264, builds and installs, initial tests run
960 as expected.
961
962 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
963 Marking ruby-1.8.6_p114 ppc64 for bug 212264
964
965*ruby-1.8.6_p114 (05 Mar 2008)
966
967 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
968 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
969 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
970 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
971 Version bump for #212264. Remove old ebuilds.
972
973 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
974 alpha/ia64 stable wrt #208916
975
976 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
977 Stable on ppc wrt bug 208916
978
979 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
980 x86 stable, bug #208916
981
982 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
983 ruby-1.8.6_p111-r1.ebuild:
984 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
985
986 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
987 -files/ruby-1.8.6-exit-status.patch,
988 -files/ruby-1.8.6_p110-net-http-p111.patch,
989 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
990 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
991 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
992 Remove old versions
993
994 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
995 Stable on ppc64
996
997 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
998 Stable on amd64; bug 199191
999
1000 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1001 alpha/ia64/sparc stable wrt #199191
1002
1003 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1004 Remove now-obsolete warning about coreutils versions, #203156.
1005
1006 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1007 Stable for HPPA (bug #199191).
1008
1009*ruby-1.8.6_p111-r1 (23 Dec 2007)
1010
1011 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1012 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1013 ssl USE flags. Patch to p113.
1014
1015 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1016 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1017
1018 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1019 x86 stable, security bug #199191
1020
1021*ruby-1.8.6_p111 (23 Dec 2007)
1022
1023 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1024 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1025 Version bump with patch for bug #199191
1026
1027 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1028 Move dependency on (X)Emacs modes to PDEPEND.
1029
1030 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1031 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1032 bug 196413
1033
1034*ruby-1.8.6_p110-r2 (21 Oct 2007)
1035
1036 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1037 +ruby-1.8.6_p110-r2.ebuild:
1038 Add emacs and xemacs USE flags and use them to pull in the correct editing
1039 mode for each. Had to drop several arch keywords as reported on bug 196413.
1040
1041 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1042 amd64 stable, security bug 194236
1043
1044 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1045 ruby-1.8.6_p110-r1.ebuild:
1046 Stable on ppc64; bug #194236
1047
1048 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1049 amd64 stable, security bug 194236
1050
1051 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1052 Stable for HPPA (bug #194236).
1053
1054 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1055 alpha/ia64/sparc stable wrt security #194236
1056
1057 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1058 ruby-1.8.6_p110-r1.ebuild:
1059 ppc stable, bug #194236
1060
1061 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1062 ruby-1.8.6_p110-r1.ebuild:
1063 stable x86, security bug 194236
1064
1065 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1066 ruby-1.8.5_p113.ebuild:
1067 stable x86, security bug 194236
1068
1069 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1070 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1071 -ruby-1.8.6_p110.ebuild:
1072 Remove old versions
1073
1074*ruby-1.8.6_p110-r1 (30 Sep 2007)
1075*ruby-1.8.5_p113 (30 Sep 2007)
1076
1077 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1078 +files/ruby-1.8.5_p113-net-http-p114.patch,
1079 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1080 +ruby-1.8.6_p110-r1.ebuild:
1081 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1082 using 1.8.6-p110 as base ebuild.
1083
1084 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1085 More fixes from gentoo-dev and graaff
1086
1087 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1088 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1089
1090*ruby-1.8.6_p110 (24 Sep 2007)
1091
1092 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1093 Version bump
1094
1095*ruby-1.8.6_p36-r4 (26 Aug 2007)
1096
1097 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1098 +ruby-1.8.6_p36-r4.ebuild:
1099 Use user LDFLAGS, #181436
1100
1101 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1102 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1103 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1104 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1105
1106 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1107 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1108 -ruby-1.8.6_p36-r2.ebuild:
1109 Remove some older versions that will not be promoted to stable, keeping at
1110 least one version of each release.
1111
1112 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1113 ruby-1.8.6_p36-r3.ebuild:
1114 (QA) RESTRICT clean up.
1115
1116*ruby-1.8.6_p36-r3 (04 Jul 2007)
1117
1118 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1119 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1120 fixed memory leak loading .so bug #182946
1121
1122 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1123 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1124 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1125 ruby-1.8.6_p36-r2.ebuild:
1126 (QA) RESTRICT clean up.
1127
1128 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1129 Re-add stable keyword for alpha as per bug #181110
1130
1131 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1132 Back to ~amd64 wrt bug 181110
1133
1134 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1135 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1136
1137*ruby-1.8.6_p36-r2 (20 Jun 2007)
1138
1139 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1140 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1141
1142*ruby-1.8.6_p36-r1 (18 Jun 2007)
1143
1144 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1145 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1146 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1147 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1148 spbecker
1149
1150 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1151 Stable on amd64 wrt bug 181110
1152
1153*ruby-1.8.6_p36 (12 Jun 2007)
1154
1155 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1156 Version Bump. Bug #181379
1157
1158 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1159 Stable on mips, per #181110.
1160
1161 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1162 Stable on ppc wrt bug 181110
1163
1164 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1165 Stable for HPPA (bug #181110).
1166
1167 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1168 alpha/ia64/x86 stable wrt #181110
1169
1170 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1171 Stable on sparc wrt #181110
1172
1173 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1174 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1175
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1176 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1177 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1178 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1179 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.543

  ViewVC Help
Powered by ViewVC 1.1.20