/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.548
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.548 2012/09/18 17:54:34 blueness Exp $
4
5 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
6 stable ppc ppc64, bug #434480
7
8 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
9 Stable for x86, wrt bug #434480
10
11 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
12 ruby-1.9.3_p194-r1.ebuild:
13 Update LICENSE, bug 434332.
14
15 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
16 Stable for amd64, wrt bug #434480
17
18 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
19 Stable for amd64, wrt bug #427774
20
21 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
22 arm stable, bug #427774
23
24 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
25 ruby-1.9.3_p194-r1.ebuild:
26 Stable ppc64, bug #411507
27
28 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
29 marked x86 per bug 427774
30
31 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
32 -ruby-1.9.3_p194.ebuild:
33 Cleanup.
34
35 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
36 ppc stable #411507
37
38 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
39 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
40 424611.
41
42*ruby-1.8.7_p370 (07 Jul 2012)
43
44 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
45 Version bump. Fix bug 378567 thanks to slyfox.
46
47 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
48 x86 stable, see bug 411507
49
50 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
51 arm stable, bug #411507
52
53 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
54 Stable for amd64, wrt bug #411507
55
56*ruby-1.9.3_p194-r1 (12 May 2012)
57
58 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
59 +ruby-1.9.3_p194-r1.ebuild:
60 Revision bump to fix mkmf for parallel build/install. Also enable verbose
61 build, so that the log makes sense if it fails.
62
63*ruby-1.9.3_p194 (30 Apr 2012)
64
65 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
66 Version bump.
67
68 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
69 keyword ~amd64-fbsd
70
71*ruby-1.8.7_p358 (20 Apr 2012)
72
73 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
74 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
75 Rails 3.2.
76
77 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
78 Add ~x86-fbsd, #332593
79
80*ruby-1.9.3_p125 (18 Feb 2012)
81
82 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
83 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
84
85 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
86 add ~arm, bug #332593
87
88 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
89 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
90
91 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
92 x86 stable wrt bug #396301
93
94 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
95 Stable for HPPA (bug #396301).
96
97 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
98 Stable for ppc/ppc64; bug #396301
99
100 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
101 Marked ~hppa (bug #332593).
102
103 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
104 Add back ~alpha keyword now that rubygems is keyworded.
105
106 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
107 Stable for AMD64, wrt security bug #396301
108
109*ruby-1.8.7_p357 (28 Dec 2011)
110
111 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
112 Version bump for security bug 396301.
113
114 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
115 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
116
117 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
118 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
119 keyworded, bug 332593.
120
121 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
122 Block older versions of packages that are no longer compatible. Remove
123 ancient blocks on packags long gone from the tree.
124
125 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
126 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
127 Remove old versions.
128
129*ruby-1.9.3_p0 (18 Dec 2011)
130
131 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
132 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
133 suite which need to be diagnosed first.
134
135 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
136 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
137 #332593).
138
139 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
140 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
141 #332593).
142
143 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
144 alpha/ia64/s390/sh/sparc stable wrt #386369
145
146*ruby-1.9.3_rc1 (22 Oct 2011)
147
148 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
149 Version bump.
150
151 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
152 arm stable, bug #386369
153
154 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
155 x86 stable, bug 386369
156
157 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
158 Stable for HPPA (bug #386369).
159
160 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
161 ppc/ppc64 stable wrt #386369
162
163 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
164 Stable on amd64 wrt bug #386369
165
166 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
167 Remove vulnerable version, bug 386369.
168
169*ruby-1.8.7_p352 (30 Aug 2011)
170
171 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
172 +ruby-1.8.7_p352.ebuild:
173 Patchlevel bump for ruby:1.8. Removing old version
174
175*ruby-1.9.2_p290 (30 Aug 2011)
176
177 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
178 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
179 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
180 old patchlevels.
181
182 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
183 ruby-1.8.7_p334-r2.ebuild:
184 ppc/ppc64 stable wrt #378691
185
186*ruby-1.8.7_p334-r2 (22 Jul 2011)
187
188 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
189 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
190 for chasing down upstream and us.
191
192 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
193 Added ~mips, bug 332593
194
195 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
196 ruby-1.8.7_p334-r1.ebuild:
197 ppc64 stable wrt #369141
198
199 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
200 ia64/s390/sh/sparc stable wrt #369141
201
202 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
203 Stable for HPPA (bug #369141).
204
205 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
206 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
207
208 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
209 arm/x86 stable, bug #369141
210
211 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
212 Stable on amd64 wrt bug #369141
213
214 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
215 ruby-1.8.7_p334-r1.ebuild:
216 Stable on alpha, bug #369141
217
218*ruby-1.8.7_p334-r1 (31 May 2011)
219
220 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
221 Revision bump for security bug 369141 (CVE-2011-0188)
222
223*ruby-1.9.2-r1 (16 May 2011)
224
225 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
226 Don't remove racc files since all other ruby targets ship these files
227 themselves as well. Closes bug 363419.
228
229 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
230 ruby-1.8.7_p334.ebuild:
231 Remove old version. Remove obsolete and unused old-style virtual/ruby.
232
233 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
234 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
235
236 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
237 Add append-flags -mieee on sh, bug #357559
238
239 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
240 alpha/arm/ia64/s390/sh stable wrt #355439
241
242 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
243 Marked ~ppc64 wrt #332593
244
245 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
246 ruby-1.8.7_p334.ebuild:
247 x86 stable wrt security bug #355439
248
249 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
250 ruby-1.8.7_p334.ebuild:
251 ppc/ppc64 stable wrt #355439
252
253 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
254 Stable on amd64 wrt bug #355439
255
256 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
257 Stable for HPPA (bug #355439).
258
259*ruby-1.8.7_p334 (19 Feb 2011)
260
261 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
262 Version bump 1.8.7 series, security bug 355439
263
264 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
265 ruby-1.9.2.ebuild:
266 Remove PROVIDE for old-style virtual/ruby per bug 265054.
267
268 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
269 Remove masked ruby 1.8.6 per bug 332597.
270
271 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
272 -ruby-1.9.2_rc2.ebuild:
273 Removing old and vulnerable ebuilds
274
275 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
276 Marking ruby-1.8.7_p302 ppc64 for bug 332957
277
278 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
279 alpha/ia64/s390/sh/sparc stable wrt #332957
280
281*ruby-1.9.2 (24 Aug 2010)
282
283 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
284 metadata.xml:
285 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
286 and x86-fbsd due to a new dependency on rdoc.
287
288 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
289 arm stable, bug #332957
290
291 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
292 ruby-1.8.7_p302.ebuild:
293 x86 stable wrt security bug #332957
294
295 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
296 Stable on amd64 wrt bug #332957
297
298 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
299 Stable for PPC (bug #332957).
300
301 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
302 Stable for HPPA (bug #332957).
303
304*ruby-1.8.7_p302 (21 Aug 2010)
305
306 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
307 +ruby-1.8.7_p302.ebuild:
308 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
309 installation path.
310
311*ruby-1.8.6_p399 (19 Aug 2010)
312
313 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
314 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
315 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
316 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
317 installation path (reported by the x86 team in bug 332597)
318
319*ruby-1.9.2_rc2-r1 (18 Aug 2010)
320
321 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
322 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
323 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
324 the rubygems loading code. Add USE flag for psych.
325
326 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
327 ruby-1.9.2_rc2.ebuild:
328 Remove two keepdir that will try to keep an empty path, closes bug
329 #333163.
330
331 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
332 Marked ~ppc (bug #332593).
333
334 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
335 ruby-1.9.2_rc2.ebuild:
336 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
337
338 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
339 ruby-1.8.7_p299.ebuild:
340 Bump eselect-ruby dependency
341
342 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
343 -ruby-1.9.1_p429.ebuild:
344 Remove ebuild that is not target for unmask anyway.
345
346 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
347 ruby-1.9.2_rc2.ebuild:
348 Try 2 to fix the berkdb 5 issue on 1.9.
349
350 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
351 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
352 ruby-1.9.2_rc2.ebuild:
353 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
354 support for adding new patchsets without bumping the revision for all the
355 old ebuilds as well.
356
357*ruby-1.9.2_rc2 (14 Jul 2010)
358
359 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
360 +ruby-1.9.2_rc2.ebuild:
361 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
362 might cause _further_ build failures as it changed slightly behaviour.
363 You're going to need to rebuild rubygems and then all the packages
364 previously installed after upgrading to this.
365
366 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
367 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
368 -ruby-1.9.1_p376.ebuild:
369 Cleanup old versions.
370
371*ruby-1.9.1_p429 (04 Jul 2010)
372
373 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
374 +ruby-1.9.1_p429.ebuild:
375 Version bump to new 1.9.1 release.
376
377*ruby-1.8.7_p299 (23 Jun 2010)
378
379 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
380 +ruby-1.8.7_p299.ebuild:
381 Version bump.
382
383 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
384 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
385 remove useless comments
386
387 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
388 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
389 ruby-1.9.1_p376.ebuild:
390 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
391 dev.gentoo.org now.
392
393 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
394 ruby-1.9.1_p376.ebuild:
395 Use the correct RUBYLIB.
396
397*ruby-1.8.7_p249-r2 (18 May 2010)
398*ruby-1.8.6_p388-r1 (18 May 2010)
399
400 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
401 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
402 ruby-1.9.1_p376.ebuild, metadata.xml:
403 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
404 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
405 add USE flags for ncurses, readline and libedit, and properly depend on
406 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
407 Emacs versions support ruby-mode themselves and it should be even more
408 updated.
409
410*ruby-1.8.7_p249-r1 (06 May 2010)
411
412 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
413 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
414 309789 by Sune Kloppenborg Jeppesen.
415
416 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
417 ruby-1.8.7_p249.ebuild:
418 Use $PVR instead of $PV in patchset names
419
420 06 May 2010; Alex Legler <a3li@gentoo.org>
421 -files/ruby-1.8.6-memory-leak.diff,
422 -files/ruby18-mkmf-parallel-install.patch,
423 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
424 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
425 Remove old version. Cleanup in files/
426
427*ruby-1.9.1_p376 (01 May 2010)
428
429 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
430 Version bump. Fixes security bugs 296052 and 300468. No longer installs
431 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
432 instead.
433
434 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
435 -ruby-1.8.7_p174-r1.ebuild:
436 Remove vulnerable ebuilds, 300468
437
438 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
439 ruby-1.8.7_p249.ebuild:
440 amd64 stable, security bug 300468
441
442 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
443 ruby-1.8.7_p249.ebuild:
444 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
445
446 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
447 Stable for HPPA (bug #300468).
448
449 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
450 Stable for HPPA (bug #300468).
451
452 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
453 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
454
455 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
456 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
457
458 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
459 ruby-1.8.6_p388.ebuild:
460 stable x86, security bug 300468
461
462 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
463 ruby-1.8.7_p249.ebuild:
464 stable x86, security bug 300468
465
466*ruby-1.8.6_p388 (10 Jan 2010)
467
468 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
469 +ruby-1.8.6_p388.ebuild:
470 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
471 version. The new ebuild also has the fix for bug 168939.
472
473*ruby-1.8.7_p249 (10 Jan 2010)
474
475 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
476 +ruby-1.8.7_p249.ebuild:
477 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
478 version
479
480 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
481 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
482
483*ruby-1.8.7_p248 (25 Dec 2009)
484
485 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
486 Version bump
487
488 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
489 Remove old version.
490
491 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
492 Remove old version.
493
494 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
495 ia64/s390/sh stable wrt #288699
496
497 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
498 stable sparc, bug 288699
499
500 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
501 arm stable, bug #288699
502
503 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
504 amd64/x86 stable, bug #288699
505
506 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
507 ruby-1.8.7_p174-r1.ebuild:
508 Stable on alpha, bug #288699
509
510 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
511 ppc stable #288699
512
513 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
514 Stable for HPPA (bug #288699).
515
516 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
517 Marked ~hppa too.
518
519*ruby-1.8.7_p174-r1 (06 Oct 2009)
520
521 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
522 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
523 eselect-ruby cleanup feature.
524
525*ruby-1.9.1_p243 (09 Sep 2009)
526
527 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
528 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
529 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
530 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
531 -files/ruby19-rubygems-proxy.patch,
532 -files/ruby-1.9.1_p129-parallelmake.patch,
533 -files/ruby19-mkmf-parallel-install.patch:
534 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
535 168939. Cleaning up old patches.
536
537*ruby-1.8.6_p383 (20 Aug 2009)
538
539 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
540 Patchlevel bump.
541
542 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
543 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
544 ruby-1.9.1_p129-r1.ebuild:
545 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
546
547 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
548 Removing vulnerable ebuild, bug 273213.
549
550 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
551 Marking ruby-1.8.6_p369 ppc for bug 273213
552
553 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
554 ruby-1.9.1_p129-r1.ebuild:
555 Prepend our library path instead of overwriting it during src_install.
556 Thanks to the reporter of bug #274824.
557
558*ruby-1.8.7_p174 (18 Jun 2009)
559
560 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
561 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
562 Replacing 187_p173 with _p174 because of a regression. Unifying the
563 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
564 patchsets.
565
566 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
567 Marking ruby-1.8.6_p369 ppc64 for bug 273213
568
569 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
570 arm/ia64/s390/sh/sparc stable wrt #273213
571
572 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
573 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
574 Removing old version, minor cleanup
575
576 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
577 -files/ruby-1.8.6-openssl.patch,
578 -files/ruby-1.8.6-shortname_constants.patch,
579 -files/ruby-1.8.6_p111-r13657.patch,
580 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
581 Removing vulnerable old Ruby version and stale patches, bug 274108.
582
583 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
584 ruby-1.8.6_p369.ebuild:
585 Stable on alpha, bug #273213
586
587 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
588 Stable for HPPA (bug #273213).
589
590 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
591 ruby-1.8.6_p369.ebuild:
592 stable x86, security bug 273213
593
594 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
595 amd64 stable, security bug 273213.
596
597*ruby-1.8.7_p173 (10 Jun 2009)
598*ruby-1.8.6_p369 (10 Jun 2009)
599
600 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
601 +ruby-1.8.7_p173.ebuild:
602 Version bumps for bug #273213.
603
604*ruby-1.9.1_p129-r1 (27 May 2009)
605
606 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
607 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
608 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
609 +files/ruby-1.9.1_p129-parallelmake.patch:
610 Revision bump, add patches 1) to make Ruby behave more similarly between
611 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
612 extensions (undefined symbols in them will cause abort at runtime 3) to
613 remove a concurrency issue when building the dl extension that could
614 result in a broken dl.so.
615
616 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
617 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
618 Don't block rdoc-2 or later (which may enter Portage one day as it's
619 needed by some Rakefiles).
620
621 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
622 ruby-1.9.1_p129.ebuild:
623 Add ~x86-fbsd keyword.
624
625 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
626 keyword ~sparc-fbsd, bug #252315
627
628*ruby-1.9.1_p129 (15 May 2009)
629
630 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
631 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
632 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
633 included in every release.
634
635 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
636 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
637 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
638 ruby-1.8.7_p160.ebuild:
639 Removing vulnerable versions (#268515), fixing license (#233747).
640
641 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
642 Stable for HPPA (bug #268515).
643
644 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
645 Adapting rubygems notice.
646
647 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
648 amd64 stable, bug #268515.
649
650 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
651 arm/ia64/s390/sh/sparc stable wrt #268515
652
653 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
654 ruby-1.8.6_p368.ebuild:
655 stable x86, security bug 268515
656
657 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
658 ruby-1.8.6_p368.ebuild:
659 Stable on alpha, bug #268515
660
661 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
662 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
663
664*ruby-1.8.7_p160 (07 May 2009)
665*ruby-1.8.6_p368 (07 May 2009)
666
667 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
668 +ruby-1.8.7_p160.ebuild:
669 Version bump as per secbug 268515. NB: These are the first ebuilds that
670 no longer use ruby-config.
671
672*ruby-1.9.1-r1 (03 Apr 2009)
673*ruby-1.8.7_p72-r11 (03 Apr 2009)
674*ruby-1.8.6_p287-r13 (03 Apr 2009)
675
676 03 Apr 2009; Alex Legler <a3li@gentoo.org>
677 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
678 +files/ruby18-mkmf-parallel-install.patch,
679 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
680 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
681 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
682 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
683 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
684 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
685 happy.
686
687*ruby-1.9.1 (21 Mar 2009)
688
689 21 Mar 2009; Alex Legler <a3li@gentoo.org>
690 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
691 +ruby-1.9.1.ebuild:
692 Adding Ruby 1.9.1 for preliminary testing
693
694 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
695 ruby-1.8.6_p287-r12.ebuild:
696 Marked ~ppc for bug #252315.
697
698 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
699 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
700 bug 261982.
701
702 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
703 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
704 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
705 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
706 Cleanup
707
708*ruby-1.8.7_p72-r10 (07 Mar 2009)
709
710 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
711 +ruby-1.8.7_p72-r10.ebuild:
712 Add a revision of ruby 1.8.7 using eselect ruby.
713
714 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
715 ~mips keyworded, bug #252315.
716
717 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
718 ruby-1.8.6_p287-r5.ebuild:
719 ppc stable, bug #260006
720
721 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
722 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
723
724 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
725 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
726 Fixing Tk USE flag test, bug 258893.
727
728 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
729 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
730
731 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
732 ruby-1.8.6_p287-r5.ebuild:
733 amd64 stable wrt security bug #260006
734
735 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
736 Stable for HPPA (bug #260006).
737
738 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
739 ruby-1.8.6_p287-r5.ebuild:
740 Stable on alpha, bug #260006
741
742*ruby-1.8.7_p72-r2 (23 Feb 2009)
743*ruby-1.8.6_p287-r12 (23 Feb 2009)
744*ruby-1.8.6_p287-r5 (23 Feb 2009)
745
746 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
747 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
748 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
749 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
750 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
751 now before compilation if Tk useflags don't match) and 230748 (adding
752 --enable-option-checking=no for newer versions of autoconf).
753
754 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
755 arm/ia64/s390/sh/sparc stable wrt #254307
756
757 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
758 ruby-1.8.6_p287-r4.ebuild:
759 Stable on alpha, bug #254307
760
761 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
762 ruby-1.8.6_p287-r11.ebuild:
763 keyword ~x86-fbsd, bug #252315
764
765 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
766 ppc stable #254307
767
768 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
769 amd64/x86 stable, bug #254307
770
771 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
772 stable ppc64, bug 254307
773
774 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
775 Stable for HPPA (bug #254307).
776
777 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
778 ruby-1.8.6_p287-r11.ebuild:
779 Marked ~hppa (bug #252315).
780
781*ruby-1.8.6_p287-r11 (11 Jan 2009)
782
783 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
784 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
785 +ruby-1.8.6_p287-r11.ebuild:
786 Backport conditional definition of missing openssl functions from ruby 1.8.7.
787 Fixes #254307.
788
789 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
790 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
791
792 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
793 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
794
795 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
796 ruby-1.8.6_p287-r10.ebuild:
797 Add ~sparc keyword, bug #252315
798
799*ruby-1.8.6_p287-r10 (23 Dec 2008)
800
801 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
802 +ruby-1.8.6_p287-r10.ebuild:
803 Version bump which switches from ruby-config to eselect-ruby. Dropped most
804 keywords since eselect-ruby does not yet have these keywords.
805
806 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
807 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
808 Revert the ruby-config changes. We can't remove them until we provide an
809 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
810 for breaking things as mentioned in bug #251833.
811
812 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
813 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
814 ruby-1.8.7_p72-r1.ebuild:
815 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
816 Thanks for the people noticing this in bug #251833.
817
818 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
819 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
820 ruby-1.8.7_p72-r1.ebuild:
821 Drop dependency on ruby-config, which will be removed from the tree. We
822 currently only have one major version of ruby in the tree (Ruby 1.8), so there
823 is no need for ruby-config at this moment. For newer versions of Ruby we will
824 use eselect-ruby, which can be found in the ruby overlay at the moment.
825
826 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
827 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
828 Use mirror://ruby in SRC_URI, fixes #237392.
829
830 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
831 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
832 -ruby-1.8.7_p72.ebuild:
833 Remove old versions. Leave one old stable version with cjk support.
834
835*ruby-1.8.6_p287-r3 (29 Nov 2008)
836
837 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
838 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
839 +ruby-1.8.6_p287-r3.ebuild:
840 Fix our expansion limit patch according to debian bug report
841 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
842 make sure people will pick up the fixed version. Thanks to Alex Legler for
843 mentioning the patch.
844
845*ruby-1.8.7_p72-r1 (26 Nov 2008)
846*ruby-1.8.6_p287-r2 (26 Nov 2008)
847
848 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
849 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
850 +ruby-1.8.7_p72-r1.ebuild:
851 Fix problem with shortname constants #247790, already fixed in upstream SVN.
852 Thanks to Alex Legler for providing the patch.
853
854 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
855 -ruby-1.8.6_p287.ebuild:
856 Remove versions that will not become stable
857
858 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
859 ruby-1.8.6_p287-r1.ebuild:
860 ppc stable, bug #225465
861
862 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
863 ruby-1.8.6_p287-r1.ebuild:
864 amd64 stable wrt security bug #225465
865
866 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
867 alpha/ia64/x86 stable wrt #225465
868
869 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
870 ruby-1.8.6_p287-r1.ebuild:
871 Sparc stable --- Security Bug #225465 --- good since late August.
872
873 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
874 Stable on ppc64; bug #225465
875
876 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
877 Stable for HPPA (bug #225465).
878
879*ruby-1.8.6_p287-r1 (29 Aug 2008)
880
881 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
882 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
883 +ruby-1.8.6_p287-r1.ebuild:
884 Fix REXML security issues, bug #236060.
885
886 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
887 Add GLEP 56 USE flag descriptions.
888
889*ruby-1.8.7_p72 (15 Aug 2008)
890
891 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
892 +ruby-1.8.7_p72.ebuild:
893 bump 1.8.7 to latest patch release
894
895*ruby-1.8.6_p287 (11 Aug 2008)
896
897 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
898 Version bump for brown paper bag relelease.
899
900 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
901 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
902 Remove broken version in favor of the just-added 1.8.6_p286
903
904*ruby-1.8.6_p286 (10 Aug 2008)
905
906 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
907 Version bump to latest released version of ruby 1.8.6. This version fixes the
908 security issues reported in #225465 and #234224. The cjk USE flag has been
909 dropped since no compatible patches have been released yet.
910
911 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
912 ruby-1.8.6_p230.ebuild:
913 drop cjk from SRC_URI as well
914
915 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
916 Drop cjk support since the most recent oniguruma patches no longer apply to
917 this version, #230111.
918
919 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
920 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
921 Try to fix the security issues reported in #225465 for ruby 1.8.6.
922 Unfortunately the official p230 has a change which causes segmentation faults
923 for applications like Rails and RSpec, so we are reverting that specific
924 change.
925
926*ruby-1.8.7_p22 (29 Jun 2008)
927
928 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
929 +ruby-1.8.7_p22.ebuild:
930 bump 1.8.7 for security fix
931
932 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
933 nevermind, don't bump this yet
934
935*ruby-1.8.6_p230 (20 Jun 2008)
936
937 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
938 version bump
939
940*ruby-1.8.7 (10 Jun 2008)
941
942 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
943 +ruby-1.8.7.ebuild:
944 bump 1.8.7 to final
945
946*ruby-1.8.7_pre2 (21 Apr 2008)
947
948 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
949 +ruby-1.8.7_pre2.ebuild:
950 Version Bump
951
952*ruby-1.8.7_pre1 (16 Apr 2008)
953
954 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
955 Version bump. Drop cjk until a new version of oniguruma appears.
956
957 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
958 amd64 stable, bug 212264
959
960 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
961 Stable for HPPA (bug #212264).
962
963 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
964 ruby-1.8.6_p114.ebuild:
965 ppc stable, bug #212264
966
967 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
968 alpha/ia64 stable wrt #212264
969
970 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
971 ruby-1.8.6_p114.ebuild:
972 stable x86, security bug 212264
973
974 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
975 Sparc stable, Security Bug #212264, builds and installs, initial tests run
976 as expected.
977
978 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
979 Marking ruby-1.8.6_p114 ppc64 for bug 212264
980
981*ruby-1.8.6_p114 (05 Mar 2008)
982
983 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
984 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
985 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
986 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
987 Version bump for #212264. Remove old ebuilds.
988
989 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
990 alpha/ia64 stable wrt #208916
991
992 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
993 Stable on ppc wrt bug 208916
994
995 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
996 x86 stable, bug #208916
997
998 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
999 ruby-1.8.6_p111-r1.ebuild:
1000 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1001
1002 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1003 -files/ruby-1.8.6-exit-status.patch,
1004 -files/ruby-1.8.6_p110-net-http-p111.patch,
1005 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1006 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1007 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1008 Remove old versions
1009
1010 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1011 Stable on ppc64
1012
1013 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1014 Stable on amd64; bug 199191
1015
1016 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1017 alpha/ia64/sparc stable wrt #199191
1018
1019 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1020 Remove now-obsolete warning about coreutils versions, #203156.
1021
1022 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1023 Stable for HPPA (bug #199191).
1024
1025*ruby-1.8.6_p111-r1 (23 Dec 2007)
1026
1027 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1028 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1029 ssl USE flags. Patch to p113.
1030
1031 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1032 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1033
1034 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1035 x86 stable, security bug #199191
1036
1037*ruby-1.8.6_p111 (23 Dec 2007)
1038
1039 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1040 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1041 Version bump with patch for bug #199191
1042
1043 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1044 Move dependency on (X)Emacs modes to PDEPEND.
1045
1046 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1047 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1048 bug 196413
1049
1050*ruby-1.8.6_p110-r2 (21 Oct 2007)
1051
1052 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1053 +ruby-1.8.6_p110-r2.ebuild:
1054 Add emacs and xemacs USE flags and use them to pull in the correct editing
1055 mode for each. Had to drop several arch keywords as reported on bug 196413.
1056
1057 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1058 amd64 stable, security bug 194236
1059
1060 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1061 ruby-1.8.6_p110-r1.ebuild:
1062 Stable on ppc64; bug #194236
1063
1064 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1065 amd64 stable, security bug 194236
1066
1067 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1068 Stable for HPPA (bug #194236).
1069
1070 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1071 alpha/ia64/sparc stable wrt security #194236
1072
1073 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1074 ruby-1.8.6_p110-r1.ebuild:
1075 ppc stable, bug #194236
1076
1077 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1078 ruby-1.8.6_p110-r1.ebuild:
1079 stable x86, security bug 194236
1080
1081 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1082 ruby-1.8.5_p113.ebuild:
1083 stable x86, security bug 194236
1084
1085 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1086 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1087 -ruby-1.8.6_p110.ebuild:
1088 Remove old versions
1089
1090*ruby-1.8.6_p110-r1 (30 Sep 2007)
1091*ruby-1.8.5_p113 (30 Sep 2007)
1092
1093 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1094 +files/ruby-1.8.5_p113-net-http-p114.patch,
1095 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1096 +ruby-1.8.6_p110-r1.ebuild:
1097 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1098 using 1.8.6-p110 as base ebuild.
1099
1100 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1101 More fixes from gentoo-dev and graaff
1102
1103 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1104 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1105
1106*ruby-1.8.6_p110 (24 Sep 2007)
1107
1108 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1109 Version bump
1110
1111*ruby-1.8.6_p36-r4 (26 Aug 2007)
1112
1113 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1114 +ruby-1.8.6_p36-r4.ebuild:
1115 Use user LDFLAGS, #181436
1116
1117 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1118 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1119 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1120 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1121
1122 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1123 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1124 -ruby-1.8.6_p36-r2.ebuild:
1125 Remove some older versions that will not be promoted to stable, keeping at
1126 least one version of each release.
1127
1128 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1129 ruby-1.8.6_p36-r3.ebuild:
1130 (QA) RESTRICT clean up.
1131
1132*ruby-1.8.6_p36-r3 (04 Jul 2007)
1133
1134 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1135 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1136 fixed memory leak loading .so bug #182946
1137
1138 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1139 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1140 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1141 ruby-1.8.6_p36-r2.ebuild:
1142 (QA) RESTRICT clean up.
1143
1144 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1145 Re-add stable keyword for alpha as per bug #181110
1146
1147 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1148 Back to ~amd64 wrt bug 181110
1149
1150 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1151 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1152
1153*ruby-1.8.6_p36-r2 (20 Jun 2007)
1154
1155 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1156 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1157
1158*ruby-1.8.6_p36-r1 (18 Jun 2007)
1159
1160 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1161 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1162 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1163 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1164 spbecker
1165
1166 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1167 Stable on amd64 wrt bug 181110
1168
1169*ruby-1.8.6_p36 (12 Jun 2007)
1170
1171 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1172 Version Bump. Bug #181379
1173
1174 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1175 Stable on mips, per #181110.
1176
1177 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1178 Stable on ppc wrt bug 181110
1179
1180 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1181 Stable for HPPA (bug #181110).
1182
1183 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1184 alpha/ia64/x86 stable wrt #181110
1185
1186 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1187 Stable on sparc wrt #181110
1188
1189 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1190 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1191
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1192 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1193 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1194 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1195 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.548

  ViewVC Help
Powered by ViewVC 1.1.20