/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.556
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.556 2012/12/07 21:43:09 ago Exp $
4
5 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
6 Stable for ppc, wrt bug #427774
7
8 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
9 Stable for HPPA (bug #411507).
10
11 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
12 alpha/ia64/s390/sh/sparc stable wrt #434480
13
14 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
15 ruby-1.9.3_p286.ebuild:
16 Remove HPPA target hack (bug #342819).
17
18 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
19 alpha/ia64/s390/sh/sparc stable wrt #411507
20
21 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
22 Stable for HPPA (bug #434480).
23
24*ruby-1.9.3_p286 (15 Oct 2012)
25
26 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
27 Version bump. Fixes bugs #437264 and #437264.
28
29 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
30 stable arm, bug #434480
31
32 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
33 stable ppc ppc64, bug #434480
34
35 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
36 Stable for x86, wrt bug #434480
37
38 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
39 ruby-1.9.3_p194-r1.ebuild:
40 Update LICENSE, bug 434332.
41
42 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
43 Stable for amd64, wrt bug #434480
44
45 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
46 Stable for amd64, wrt bug #427774
47
48 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
49 arm stable, bug #427774
50
51 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
52 ruby-1.9.3_p194-r1.ebuild:
53 Stable ppc64, bug #411507
54
55 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
56 marked x86 per bug 427774
57
58 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
59 -ruby-1.9.3_p194.ebuild:
60 Cleanup.
61
62 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
63 ppc stable #411507
64
65 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
66 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
67 424611.
68
69*ruby-1.8.7_p370 (07 Jul 2012)
70
71 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
72 Version bump. Fix bug 378567 thanks to slyfox.
73
74 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
75 x86 stable, see bug 411507
76
77 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
78 arm stable, bug #411507
79
80 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
81 Stable for amd64, wrt bug #411507
82
83*ruby-1.9.3_p194-r1 (12 May 2012)
84
85 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
86 +ruby-1.9.3_p194-r1.ebuild:
87 Revision bump to fix mkmf for parallel build/install. Also enable verbose
88 build, so that the log makes sense if it fails.
89
90*ruby-1.9.3_p194 (30 Apr 2012)
91
92 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
93 Version bump.
94
95 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
96 keyword ~amd64-fbsd
97
98*ruby-1.8.7_p358 (20 Apr 2012)
99
100 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
101 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
102 Rails 3.2.
103
104 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
105 Add ~x86-fbsd, #332593
106
107*ruby-1.9.3_p125 (18 Feb 2012)
108
109 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
110 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
111
112 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
113 add ~arm, bug #332593
114
115 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
116 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
117
118 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
119 x86 stable wrt bug #396301
120
121 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
122 Stable for HPPA (bug #396301).
123
124 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
125 Stable for ppc/ppc64; bug #396301
126
127 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
128 Marked ~hppa (bug #332593).
129
130 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
131 Add back ~alpha keyword now that rubygems is keyworded.
132
133 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
134 Stable for AMD64, wrt security bug #396301
135
136*ruby-1.8.7_p357 (28 Dec 2011)
137
138 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
139 Version bump for security bug 396301.
140
141 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
142 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
143
144 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
145 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
146 keyworded, bug 332593.
147
148 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
149 Block older versions of packages that are no longer compatible. Remove
150 ancient blocks on packags long gone from the tree.
151
152 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
153 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
154 Remove old versions.
155
156*ruby-1.9.3_p0 (18 Dec 2011)
157
158 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
159 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
160 suite which need to be diagnosed first.
161
162 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
163 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
164 #332593).
165
166 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
167 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
168 #332593).
169
170 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
171 alpha/ia64/s390/sh/sparc stable wrt #386369
172
173*ruby-1.9.3_rc1 (22 Oct 2011)
174
175 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
176 Version bump.
177
178 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
179 arm stable, bug #386369
180
181 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
182 x86 stable, bug 386369
183
184 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
185 Stable for HPPA (bug #386369).
186
187 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
188 ppc/ppc64 stable wrt #386369
189
190 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
191 Stable on amd64 wrt bug #386369
192
193 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
194 Remove vulnerable version, bug 386369.
195
196*ruby-1.8.7_p352 (30 Aug 2011)
197
198 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
199 +ruby-1.8.7_p352.ebuild:
200 Patchlevel bump for ruby:1.8. Removing old version
201
202*ruby-1.9.2_p290 (30 Aug 2011)
203
204 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
205 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
206 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
207 old patchlevels.
208
209 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
210 ruby-1.8.7_p334-r2.ebuild:
211 ppc/ppc64 stable wrt #378691
212
213*ruby-1.8.7_p334-r2 (22 Jul 2011)
214
215 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
216 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
217 for chasing down upstream and us.
218
219 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
220 Added ~mips, bug 332593
221
222 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
223 ruby-1.8.7_p334-r1.ebuild:
224 ppc64 stable wrt #369141
225
226 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
227 ia64/s390/sh/sparc stable wrt #369141
228
229 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
230 Stable for HPPA (bug #369141).
231
232 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
233 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
234
235 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
236 arm/x86 stable, bug #369141
237
238 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
239 Stable on amd64 wrt bug #369141
240
241 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
242 ruby-1.8.7_p334-r1.ebuild:
243 Stable on alpha, bug #369141
244
245*ruby-1.8.7_p334-r1 (31 May 2011)
246
247 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
248 Revision bump for security bug 369141 (CVE-2011-0188)
249
250*ruby-1.9.2-r1 (16 May 2011)
251
252 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
253 Don't remove racc files since all other ruby targets ship these files
254 themselves as well. Closes bug 363419.
255
256 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
257 ruby-1.8.7_p334.ebuild:
258 Remove old version. Remove obsolete and unused old-style virtual/ruby.
259
260 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
261 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
262
263 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
264 Add append-flags -mieee on sh, bug #357559
265
266 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
267 alpha/arm/ia64/s390/sh stable wrt #355439
268
269 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
270 Marked ~ppc64 wrt #332593
271
272 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
273 ruby-1.8.7_p334.ebuild:
274 x86 stable wrt security bug #355439
275
276 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
277 ruby-1.8.7_p334.ebuild:
278 ppc/ppc64 stable wrt #355439
279
280 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
281 Stable on amd64 wrt bug #355439
282
283 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
284 Stable for HPPA (bug #355439).
285
286*ruby-1.8.7_p334 (19 Feb 2011)
287
288 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
289 Version bump 1.8.7 series, security bug 355439
290
291 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
292 ruby-1.9.2.ebuild:
293 Remove PROVIDE for old-style virtual/ruby per bug 265054.
294
295 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
296 Remove masked ruby 1.8.6 per bug 332597.
297
298 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
299 -ruby-1.9.2_rc2.ebuild:
300 Removing old and vulnerable ebuilds
301
302 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
303 Marking ruby-1.8.7_p302 ppc64 for bug 332957
304
305 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
306 alpha/ia64/s390/sh/sparc stable wrt #332957
307
308*ruby-1.9.2 (24 Aug 2010)
309
310 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
311 metadata.xml:
312 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
313 and x86-fbsd due to a new dependency on rdoc.
314
315 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
316 arm stable, bug #332957
317
318 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
319 ruby-1.8.7_p302.ebuild:
320 x86 stable wrt security bug #332957
321
322 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
323 Stable on amd64 wrt bug #332957
324
325 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
326 Stable for PPC (bug #332957).
327
328 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
329 Stable for HPPA (bug #332957).
330
331*ruby-1.8.7_p302 (21 Aug 2010)
332
333 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
334 +ruby-1.8.7_p302.ebuild:
335 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
336 installation path.
337
338*ruby-1.8.6_p399 (19 Aug 2010)
339
340 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
341 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
342 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
343 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
344 installation path (reported by the x86 team in bug 332597)
345
346*ruby-1.9.2_rc2-r1 (18 Aug 2010)
347
348 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
349 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
350 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
351 the rubygems loading code. Add USE flag for psych.
352
353 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
354 ruby-1.9.2_rc2.ebuild:
355 Remove two keepdir that will try to keep an empty path, closes bug
356 #333163.
357
358 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
359 Marked ~ppc (bug #332593).
360
361 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
362 ruby-1.9.2_rc2.ebuild:
363 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
364
365 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
366 ruby-1.8.7_p299.ebuild:
367 Bump eselect-ruby dependency
368
369 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
370 -ruby-1.9.1_p429.ebuild:
371 Remove ebuild that is not target for unmask anyway.
372
373 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
374 ruby-1.9.2_rc2.ebuild:
375 Try 2 to fix the berkdb 5 issue on 1.9.
376
377 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
378 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
379 ruby-1.9.2_rc2.ebuild:
380 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
381 support for adding new patchsets without bumping the revision for all the
382 old ebuilds as well.
383
384*ruby-1.9.2_rc2 (14 Jul 2010)
385
386 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
387 +ruby-1.9.2_rc2.ebuild:
388 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
389 might cause _further_ build failures as it changed slightly behaviour.
390 You're going to need to rebuild rubygems and then all the packages
391 previously installed after upgrading to this.
392
393 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
394 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
395 -ruby-1.9.1_p376.ebuild:
396 Cleanup old versions.
397
398*ruby-1.9.1_p429 (04 Jul 2010)
399
400 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
401 +ruby-1.9.1_p429.ebuild:
402 Version bump to new 1.9.1 release.
403
404*ruby-1.8.7_p299 (23 Jun 2010)
405
406 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
407 +ruby-1.8.7_p299.ebuild:
408 Version bump.
409
410 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
411 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
412 remove useless comments
413
414 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
415 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
416 ruby-1.9.1_p376.ebuild:
417 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
418 dev.gentoo.org now.
419
420 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
421 ruby-1.9.1_p376.ebuild:
422 Use the correct RUBYLIB.
423
424*ruby-1.8.7_p249-r2 (18 May 2010)
425*ruby-1.8.6_p388-r1 (18 May 2010)
426
427 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
428 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
429 ruby-1.9.1_p376.ebuild, metadata.xml:
430 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
431 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
432 add USE flags for ncurses, readline and libedit, and properly depend on
433 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
434 Emacs versions support ruby-mode themselves and it should be even more
435 updated.
436
437*ruby-1.8.7_p249-r1 (06 May 2010)
438
439 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
440 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
441 309789 by Sune Kloppenborg Jeppesen.
442
443 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
444 ruby-1.8.7_p249.ebuild:
445 Use $PVR instead of $PV in patchset names
446
447 06 May 2010; Alex Legler <a3li@gentoo.org>
448 -files/ruby-1.8.6-memory-leak.diff,
449 -files/ruby18-mkmf-parallel-install.patch,
450 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
451 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
452 Remove old version. Cleanup in files/
453
454*ruby-1.9.1_p376 (01 May 2010)
455
456 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
457 Version bump. Fixes security bugs 296052 and 300468. No longer installs
458 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
459 instead.
460
461 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
462 -ruby-1.8.7_p174-r1.ebuild:
463 Remove vulnerable ebuilds, 300468
464
465 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
466 ruby-1.8.7_p249.ebuild:
467 amd64 stable, security bug 300468
468
469 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
470 ruby-1.8.7_p249.ebuild:
471 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
472
473 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
474 Stable for HPPA (bug #300468).
475
476 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
477 Stable for HPPA (bug #300468).
478
479 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
480 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
481
482 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
483 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
484
485 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
486 ruby-1.8.6_p388.ebuild:
487 stable x86, security bug 300468
488
489 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
490 ruby-1.8.7_p249.ebuild:
491 stable x86, security bug 300468
492
493*ruby-1.8.6_p388 (10 Jan 2010)
494
495 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
496 +ruby-1.8.6_p388.ebuild:
497 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
498 version. The new ebuild also has the fix for bug 168939.
499
500*ruby-1.8.7_p249 (10 Jan 2010)
501
502 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
503 +ruby-1.8.7_p249.ebuild:
504 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
505 version
506
507 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
508 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
509
510*ruby-1.8.7_p248 (25 Dec 2009)
511
512 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
513 Version bump
514
515 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
516 Remove old version.
517
518 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
519 Remove old version.
520
521 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
522 ia64/s390/sh stable wrt #288699
523
524 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
525 stable sparc, bug 288699
526
527 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
528 arm stable, bug #288699
529
530 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
531 amd64/x86 stable, bug #288699
532
533 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
534 ruby-1.8.7_p174-r1.ebuild:
535 Stable on alpha, bug #288699
536
537 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
538 ppc stable #288699
539
540 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
541 Stable for HPPA (bug #288699).
542
543 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
544 Marked ~hppa too.
545
546*ruby-1.8.7_p174-r1 (06 Oct 2009)
547
548 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
549 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
550 eselect-ruby cleanup feature.
551
552*ruby-1.9.1_p243 (09 Sep 2009)
553
554 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
555 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
556 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
557 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
558 -files/ruby19-rubygems-proxy.patch,
559 -files/ruby-1.9.1_p129-parallelmake.patch,
560 -files/ruby19-mkmf-parallel-install.patch:
561 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
562 168939. Cleaning up old patches.
563
564*ruby-1.8.6_p383 (20 Aug 2009)
565
566 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
567 Patchlevel bump.
568
569 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
570 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
571 ruby-1.9.1_p129-r1.ebuild:
572 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
573
574 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
575 Removing vulnerable ebuild, bug 273213.
576
577 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
578 Marking ruby-1.8.6_p369 ppc for bug 273213
579
580 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
581 ruby-1.9.1_p129-r1.ebuild:
582 Prepend our library path instead of overwriting it during src_install.
583 Thanks to the reporter of bug #274824.
584
585*ruby-1.8.7_p174 (18 Jun 2009)
586
587 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
588 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
589 Replacing 187_p173 with _p174 because of a regression. Unifying the
590 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
591 patchsets.
592
593 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
594 Marking ruby-1.8.6_p369 ppc64 for bug 273213
595
596 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
597 arm/ia64/s390/sh/sparc stable wrt #273213
598
599 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
600 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
601 Removing old version, minor cleanup
602
603 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
604 -files/ruby-1.8.6-openssl.patch,
605 -files/ruby-1.8.6-shortname_constants.patch,
606 -files/ruby-1.8.6_p111-r13657.patch,
607 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
608 Removing vulnerable old Ruby version and stale patches, bug 274108.
609
610 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
611 ruby-1.8.6_p369.ebuild:
612 Stable on alpha, bug #273213
613
614 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
615 Stable for HPPA (bug #273213).
616
617 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
618 ruby-1.8.6_p369.ebuild:
619 stable x86, security bug 273213
620
621 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
622 amd64 stable, security bug 273213.
623
624*ruby-1.8.7_p173 (10 Jun 2009)
625*ruby-1.8.6_p369 (10 Jun 2009)
626
627 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
628 +ruby-1.8.7_p173.ebuild:
629 Version bumps for bug #273213.
630
631*ruby-1.9.1_p129-r1 (27 May 2009)
632
633 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
634 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
635 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
636 +files/ruby-1.9.1_p129-parallelmake.patch:
637 Revision bump, add patches 1) to make Ruby behave more similarly between
638 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
639 extensions (undefined symbols in them will cause abort at runtime 3) to
640 remove a concurrency issue when building the dl extension that could
641 result in a broken dl.so.
642
643 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
644 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
645 Don't block rdoc-2 or later (which may enter Portage one day as it's
646 needed by some Rakefiles).
647
648 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
649 ruby-1.9.1_p129.ebuild:
650 Add ~x86-fbsd keyword.
651
652 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
653 keyword ~sparc-fbsd, bug #252315
654
655*ruby-1.9.1_p129 (15 May 2009)
656
657 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
658 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
659 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
660 included in every release.
661
662 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
663 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
664 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
665 ruby-1.8.7_p160.ebuild:
666 Removing vulnerable versions (#268515), fixing license (#233747).
667
668 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
669 Stable for HPPA (bug #268515).
670
671 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
672 Adapting rubygems notice.
673
674 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
675 amd64 stable, bug #268515.
676
677 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
678 arm/ia64/s390/sh/sparc stable wrt #268515
679
680 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
681 ruby-1.8.6_p368.ebuild:
682 stable x86, security bug 268515
683
684 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
685 ruby-1.8.6_p368.ebuild:
686 Stable on alpha, bug #268515
687
688 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
689 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
690
691*ruby-1.8.7_p160 (07 May 2009)
692*ruby-1.8.6_p368 (07 May 2009)
693
694 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
695 +ruby-1.8.7_p160.ebuild:
696 Version bump as per secbug 268515. NB: These are the first ebuilds that
697 no longer use ruby-config.
698
699*ruby-1.9.1-r1 (03 Apr 2009)
700*ruby-1.8.7_p72-r11 (03 Apr 2009)
701*ruby-1.8.6_p287-r13 (03 Apr 2009)
702
703 03 Apr 2009; Alex Legler <a3li@gentoo.org>
704 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
705 +files/ruby18-mkmf-parallel-install.patch,
706 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
707 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
708 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
709 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
710 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
711 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
712 happy.
713
714*ruby-1.9.1 (21 Mar 2009)
715
716 21 Mar 2009; Alex Legler <a3li@gentoo.org>
717 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
718 +ruby-1.9.1.ebuild:
719 Adding Ruby 1.9.1 for preliminary testing
720
721 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
722 ruby-1.8.6_p287-r12.ebuild:
723 Marked ~ppc for bug #252315.
724
725 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
726 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
727 bug 261982.
728
729 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
730 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
731 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
732 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
733 Cleanup
734
735*ruby-1.8.7_p72-r10 (07 Mar 2009)
736
737 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
738 +ruby-1.8.7_p72-r10.ebuild:
739 Add a revision of ruby 1.8.7 using eselect ruby.
740
741 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
742 ~mips keyworded, bug #252315.
743
744 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
745 ruby-1.8.6_p287-r5.ebuild:
746 ppc stable, bug #260006
747
748 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
749 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
750
751 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
752 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
753 Fixing Tk USE flag test, bug 258893.
754
755 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
756 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
757
758 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
759 ruby-1.8.6_p287-r5.ebuild:
760 amd64 stable wrt security bug #260006
761
762 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
763 Stable for HPPA (bug #260006).
764
765 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
766 ruby-1.8.6_p287-r5.ebuild:
767 Stable on alpha, bug #260006
768
769*ruby-1.8.7_p72-r2 (23 Feb 2009)
770*ruby-1.8.6_p287-r12 (23 Feb 2009)
771*ruby-1.8.6_p287-r5 (23 Feb 2009)
772
773 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
774 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
775 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
776 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
777 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
778 now before compilation if Tk useflags don't match) and 230748 (adding
779 --enable-option-checking=no for newer versions of autoconf).
780
781 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
782 arm/ia64/s390/sh/sparc stable wrt #254307
783
784 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
785 ruby-1.8.6_p287-r4.ebuild:
786 Stable on alpha, bug #254307
787
788 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
789 ruby-1.8.6_p287-r11.ebuild:
790 keyword ~x86-fbsd, bug #252315
791
792 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
793 ppc stable #254307
794
795 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
796 amd64/x86 stable, bug #254307
797
798 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
799 stable ppc64, bug 254307
800
801 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
802 Stable for HPPA (bug #254307).
803
804 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
805 ruby-1.8.6_p287-r11.ebuild:
806 Marked ~hppa (bug #252315).
807
808*ruby-1.8.6_p287-r11 (11 Jan 2009)
809
810 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
811 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
812 +ruby-1.8.6_p287-r11.ebuild:
813 Backport conditional definition of missing openssl functions from ruby 1.8.7.
814 Fixes #254307.
815
816 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
817 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
818
819 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
820 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
821
822 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
823 ruby-1.8.6_p287-r10.ebuild:
824 Add ~sparc keyword, bug #252315
825
826*ruby-1.8.6_p287-r10 (23 Dec 2008)
827
828 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
829 +ruby-1.8.6_p287-r10.ebuild:
830 Version bump which switches from ruby-config to eselect-ruby. Dropped most
831 keywords since eselect-ruby does not yet have these keywords.
832
833 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
834 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
835 Revert the ruby-config changes. We can't remove them until we provide an
836 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
837 for breaking things as mentioned in bug #251833.
838
839 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
840 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
841 ruby-1.8.7_p72-r1.ebuild:
842 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
843 Thanks for the people noticing this in bug #251833.
844
845 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
846 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
847 ruby-1.8.7_p72-r1.ebuild:
848 Drop dependency on ruby-config, which will be removed from the tree. We
849 currently only have one major version of ruby in the tree (Ruby 1.8), so there
850 is no need for ruby-config at this moment. For newer versions of Ruby we will
851 use eselect-ruby, which can be found in the ruby overlay at the moment.
852
853 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
854 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
855 Use mirror://ruby in SRC_URI, fixes #237392.
856
857 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
858 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
859 -ruby-1.8.7_p72.ebuild:
860 Remove old versions. Leave one old stable version with cjk support.
861
862*ruby-1.8.6_p287-r3 (29 Nov 2008)
863
864 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
865 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
866 +ruby-1.8.6_p287-r3.ebuild:
867 Fix our expansion limit patch according to debian bug report
868 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
869 make sure people will pick up the fixed version. Thanks to Alex Legler for
870 mentioning the patch.
871
872*ruby-1.8.7_p72-r1 (26 Nov 2008)
873*ruby-1.8.6_p287-r2 (26 Nov 2008)
874
875 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
876 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
877 +ruby-1.8.7_p72-r1.ebuild:
878 Fix problem with shortname constants #247790, already fixed in upstream SVN.
879 Thanks to Alex Legler for providing the patch.
880
881 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
882 -ruby-1.8.6_p287.ebuild:
883 Remove versions that will not become stable
884
885 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
886 ruby-1.8.6_p287-r1.ebuild:
887 ppc stable, bug #225465
888
889 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
890 ruby-1.8.6_p287-r1.ebuild:
891 amd64 stable wrt security bug #225465
892
893 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
894 alpha/ia64/x86 stable wrt #225465
895
896 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
897 ruby-1.8.6_p287-r1.ebuild:
898 Sparc stable --- Security Bug #225465 --- good since late August.
899
900 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
901 Stable on ppc64; bug #225465
902
903 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
904 Stable for HPPA (bug #225465).
905
906*ruby-1.8.6_p287-r1 (29 Aug 2008)
907
908 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
909 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
910 +ruby-1.8.6_p287-r1.ebuild:
911 Fix REXML security issues, bug #236060.
912
913 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
914 Add GLEP 56 USE flag descriptions.
915
916*ruby-1.8.7_p72 (15 Aug 2008)
917
918 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
919 +ruby-1.8.7_p72.ebuild:
920 bump 1.8.7 to latest patch release
921
922*ruby-1.8.6_p287 (11 Aug 2008)
923
924 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
925 Version bump for brown paper bag relelease.
926
927 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
928 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
929 Remove broken version in favor of the just-added 1.8.6_p286
930
931*ruby-1.8.6_p286 (10 Aug 2008)
932
933 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
934 Version bump to latest released version of ruby 1.8.6. This version fixes the
935 security issues reported in #225465 and #234224. The cjk USE flag has been
936 dropped since no compatible patches have been released yet.
937
938 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
939 ruby-1.8.6_p230.ebuild:
940 drop cjk from SRC_URI as well
941
942 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
943 Drop cjk support since the most recent oniguruma patches no longer apply to
944 this version, #230111.
945
946 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
947 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
948 Try to fix the security issues reported in #225465 for ruby 1.8.6.
949 Unfortunately the official p230 has a change which causes segmentation faults
950 for applications like Rails and RSpec, so we are reverting that specific
951 change.
952
953*ruby-1.8.7_p22 (29 Jun 2008)
954
955 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
956 +ruby-1.8.7_p22.ebuild:
957 bump 1.8.7 for security fix
958
959 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
960 nevermind, don't bump this yet
961
962*ruby-1.8.6_p230 (20 Jun 2008)
963
964 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
965 version bump
966
967*ruby-1.8.7 (10 Jun 2008)
968
969 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
970 +ruby-1.8.7.ebuild:
971 bump 1.8.7 to final
972
973*ruby-1.8.7_pre2 (21 Apr 2008)
974
975 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
976 +ruby-1.8.7_pre2.ebuild:
977 Version Bump
978
979*ruby-1.8.7_pre1 (16 Apr 2008)
980
981 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
982 Version bump. Drop cjk until a new version of oniguruma appears.
983
984 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
985 amd64 stable, bug 212264
986
987 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
988 Stable for HPPA (bug #212264).
989
990 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
991 ruby-1.8.6_p114.ebuild:
992 ppc stable, bug #212264
993
994 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
995 alpha/ia64 stable wrt #212264
996
997 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
998 ruby-1.8.6_p114.ebuild:
999 stable x86, security bug 212264
1000
1001 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1002 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1003 as expected.
1004
1005 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1006 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1007
1008*ruby-1.8.6_p114 (05 Mar 2008)
1009
1010 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1011 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1012 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1013 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1014 Version bump for #212264. Remove old ebuilds.
1015
1016 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1017 alpha/ia64 stable wrt #208916
1018
1019 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1020 Stable on ppc wrt bug 208916
1021
1022 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1023 x86 stable, bug #208916
1024
1025 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1026 ruby-1.8.6_p111-r1.ebuild:
1027 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1028
1029 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1030 -files/ruby-1.8.6-exit-status.patch,
1031 -files/ruby-1.8.6_p110-net-http-p111.patch,
1032 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1033 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1034 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1035 Remove old versions
1036
1037 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1038 Stable on ppc64
1039
1040 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1041 Stable on amd64; bug 199191
1042
1043 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1044 alpha/ia64/sparc stable wrt #199191
1045
1046 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1047 Remove now-obsolete warning about coreutils versions, #203156.
1048
1049 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1050 Stable for HPPA (bug #199191).
1051
1052*ruby-1.8.6_p111-r1 (23 Dec 2007)
1053
1054 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1055 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1056 ssl USE flags. Patch to p113.
1057
1058 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1059 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1060
1061 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1062 x86 stable, security bug #199191
1063
1064*ruby-1.8.6_p111 (23 Dec 2007)
1065
1066 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1067 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1068 Version bump with patch for bug #199191
1069
1070 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1071 Move dependency on (X)Emacs modes to PDEPEND.
1072
1073 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1074 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1075 bug 196413
1076
1077*ruby-1.8.6_p110-r2 (21 Oct 2007)
1078
1079 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1080 +ruby-1.8.6_p110-r2.ebuild:
1081 Add emacs and xemacs USE flags and use them to pull in the correct editing
1082 mode for each. Had to drop several arch keywords as reported on bug 196413.
1083
1084 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1085 amd64 stable, security bug 194236
1086
1087 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1088 ruby-1.8.6_p110-r1.ebuild:
1089 Stable on ppc64; bug #194236
1090
1091 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1092 amd64 stable, security bug 194236
1093
1094 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1095 Stable for HPPA (bug #194236).
1096
1097 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1098 alpha/ia64/sparc stable wrt security #194236
1099
1100 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1101 ruby-1.8.6_p110-r1.ebuild:
1102 ppc stable, bug #194236
1103
1104 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1105 ruby-1.8.6_p110-r1.ebuild:
1106 stable x86, security bug 194236
1107
1108 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1109 ruby-1.8.5_p113.ebuild:
1110 stable x86, security bug 194236
1111
1112 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1113 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1114 -ruby-1.8.6_p110.ebuild:
1115 Remove old versions
1116
1117*ruby-1.8.6_p110-r1 (30 Sep 2007)
1118*ruby-1.8.5_p113 (30 Sep 2007)
1119
1120 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1121 +files/ruby-1.8.5_p113-net-http-p114.patch,
1122 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1123 +ruby-1.8.6_p110-r1.ebuild:
1124 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1125 using 1.8.6-p110 as base ebuild.
1126
1127 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1128 More fixes from gentoo-dev and graaff
1129
1130 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1131 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1132
1133*ruby-1.8.6_p110 (24 Sep 2007)
1134
1135 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1136 Version bump
1137
1138*ruby-1.8.6_p36-r4 (26 Aug 2007)
1139
1140 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1141 +ruby-1.8.6_p36-r4.ebuild:
1142 Use user LDFLAGS, #181436
1143
1144 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1145 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1146 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1147 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1148
1149 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1150 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1151 -ruby-1.8.6_p36-r2.ebuild:
1152 Remove some older versions that will not be promoted to stable, keeping at
1153 least one version of each release.
1154
1155 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1156 ruby-1.8.6_p36-r3.ebuild:
1157 (QA) RESTRICT clean up.
1158
1159*ruby-1.8.6_p36-r3 (04 Jul 2007)
1160
1161 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1162 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1163 fixed memory leak loading .so bug #182946
1164
1165 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1166 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1167 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1168 ruby-1.8.6_p36-r2.ebuild:
1169 (QA) RESTRICT clean up.
1170
1171 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1172 Re-add stable keyword for alpha as per bug #181110
1173
1174 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1175 Back to ~amd64 wrt bug 181110
1176
1177 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1178 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1179
1180*ruby-1.8.6_p36-r2 (20 Jun 2007)
1181
1182 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1183 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1184
1185*ruby-1.8.6_p36-r1 (18 Jun 2007)
1186
1187 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1188 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1189 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1190 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1191 spbecker
1192
1193 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1194 Stable on amd64 wrt bug 181110
1195
1196*ruby-1.8.6_p36 (12 Jun 2007)
1197
1198 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1199 Version Bump. Bug #181379
1200
1201 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1202 Stable on mips, per #181110.
1203
1204 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1205 Stable on ppc wrt bug 181110
1206
1207 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1208 Stable for HPPA (bug #181110).
1209
1210 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1211 alpha/ia64/x86 stable wrt #181110
1212
1213 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1214 Stable on sparc wrt #181110
1215
1216 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1217 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1218
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1219 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1220 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1221 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1222 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.556

  ViewVC Help
Powered by ViewVC 1.1.20