/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.557
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.557 2013/01/06 14:16:19 graaff Exp $
4
5*ruby-1.8.7_p371 (06 Jan 2013)
6
7 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
8 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
9 Version bump for security bug 437366.
10
11 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
12 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
13 Cleanup.
14
15 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
16 Stable for ppc, wrt bug #427774
17
18 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
19 Stable for HPPA (bug #411507).
20
21 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
22 alpha/ia64/s390/sh/sparc stable wrt #434480
23
24 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
25 ruby-1.9.3_p286.ebuild:
26 Remove HPPA target hack (bug #342819).
27
28 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
29 alpha/ia64/s390/sh/sparc stable wrt #411507
30
31 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
32 Stable for HPPA (bug #434480).
33
34*ruby-1.9.3_p286 (15 Oct 2012)
35
36 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
37 Version bump. Fixes bugs #437264 and #437264.
38
39 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
40 stable arm, bug #434480
41
42 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
43 stable ppc ppc64, bug #434480
44
45 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
46 Stable for x86, wrt bug #434480
47
48 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
49 ruby-1.9.3_p194-r1.ebuild:
50 Update LICENSE, bug 434332.
51
52 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
53 Stable for amd64, wrt bug #434480
54
55 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
56 Stable for amd64, wrt bug #427774
57
58 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
59 arm stable, bug #427774
60
61 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
62 ruby-1.9.3_p194-r1.ebuild:
63 Stable ppc64, bug #411507
64
65 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
66 marked x86 per bug 427774
67
68 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
69 -ruby-1.9.3_p194.ebuild:
70 Cleanup.
71
72 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
73 ppc stable #411507
74
75 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
76 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
77 424611.
78
79*ruby-1.8.7_p370 (07 Jul 2012)
80
81 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
82 Version bump. Fix bug 378567 thanks to slyfox.
83
84 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
85 x86 stable, see bug 411507
86
87 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
88 arm stable, bug #411507
89
90 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
91 Stable for amd64, wrt bug #411507
92
93*ruby-1.9.3_p194-r1 (12 May 2012)
94
95 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
96 +ruby-1.9.3_p194-r1.ebuild:
97 Revision bump to fix mkmf for parallel build/install. Also enable verbose
98 build, so that the log makes sense if it fails.
99
100*ruby-1.9.3_p194 (30 Apr 2012)
101
102 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
103 Version bump.
104
105 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
106 keyword ~amd64-fbsd
107
108*ruby-1.8.7_p358 (20 Apr 2012)
109
110 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
111 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
112 Rails 3.2.
113
114 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
115 Add ~x86-fbsd, #332593
116
117*ruby-1.9.3_p125 (18 Feb 2012)
118
119 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
120 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
121
122 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
123 add ~arm, bug #332593
124
125 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
126 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
127
128 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
129 x86 stable wrt bug #396301
130
131 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
132 Stable for HPPA (bug #396301).
133
134 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
135 Stable for ppc/ppc64; bug #396301
136
137 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
138 Marked ~hppa (bug #332593).
139
140 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
141 Add back ~alpha keyword now that rubygems is keyworded.
142
143 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
144 Stable for AMD64, wrt security bug #396301
145
146*ruby-1.8.7_p357 (28 Dec 2011)
147
148 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
149 Version bump for security bug 396301.
150
151 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
152 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
153
154 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
155 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
156 keyworded, bug 332593.
157
158 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
159 Block older versions of packages that are no longer compatible. Remove
160 ancient blocks on packags long gone from the tree.
161
162 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
163 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
164 Remove old versions.
165
166*ruby-1.9.3_p0 (18 Dec 2011)
167
168 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
169 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
170 suite which need to be diagnosed first.
171
172 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
173 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
174 #332593).
175
176 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
177 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
178 #332593).
179
180 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
181 alpha/ia64/s390/sh/sparc stable wrt #386369
182
183*ruby-1.9.3_rc1 (22 Oct 2011)
184
185 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
186 Version bump.
187
188 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
189 arm stable, bug #386369
190
191 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
192 x86 stable, bug 386369
193
194 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
195 Stable for HPPA (bug #386369).
196
197 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
198 ppc/ppc64 stable wrt #386369
199
200 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
201 Stable on amd64 wrt bug #386369
202
203 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
204 Remove vulnerable version, bug 386369.
205
206*ruby-1.8.7_p352 (30 Aug 2011)
207
208 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
209 +ruby-1.8.7_p352.ebuild:
210 Patchlevel bump for ruby:1.8. Removing old version
211
212*ruby-1.9.2_p290 (30 Aug 2011)
213
214 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
215 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
216 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
217 old patchlevels.
218
219 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
220 ruby-1.8.7_p334-r2.ebuild:
221 ppc/ppc64 stable wrt #378691
222
223*ruby-1.8.7_p334-r2 (22 Jul 2011)
224
225 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
226 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
227 for chasing down upstream and us.
228
229 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
230 Added ~mips, bug 332593
231
232 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
233 ruby-1.8.7_p334-r1.ebuild:
234 ppc64 stable wrt #369141
235
236 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
237 ia64/s390/sh/sparc stable wrt #369141
238
239 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
240 Stable for HPPA (bug #369141).
241
242 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
243 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
244
245 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
246 arm/x86 stable, bug #369141
247
248 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
249 Stable on amd64 wrt bug #369141
250
251 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
252 ruby-1.8.7_p334-r1.ebuild:
253 Stable on alpha, bug #369141
254
255*ruby-1.8.7_p334-r1 (31 May 2011)
256
257 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
258 Revision bump for security bug 369141 (CVE-2011-0188)
259
260*ruby-1.9.2-r1 (16 May 2011)
261
262 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
263 Don't remove racc files since all other ruby targets ship these files
264 themselves as well. Closes bug 363419.
265
266 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
267 ruby-1.8.7_p334.ebuild:
268 Remove old version. Remove obsolete and unused old-style virtual/ruby.
269
270 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
271 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
272
273 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
274 Add append-flags -mieee on sh, bug #357559
275
276 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
277 alpha/arm/ia64/s390/sh stable wrt #355439
278
279 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
280 Marked ~ppc64 wrt #332593
281
282 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
283 ruby-1.8.7_p334.ebuild:
284 x86 stable wrt security bug #355439
285
286 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
287 ruby-1.8.7_p334.ebuild:
288 ppc/ppc64 stable wrt #355439
289
290 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
291 Stable on amd64 wrt bug #355439
292
293 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
294 Stable for HPPA (bug #355439).
295
296*ruby-1.8.7_p334 (19 Feb 2011)
297
298 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
299 Version bump 1.8.7 series, security bug 355439
300
301 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
302 ruby-1.9.2.ebuild:
303 Remove PROVIDE for old-style virtual/ruby per bug 265054.
304
305 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
306 Remove masked ruby 1.8.6 per bug 332597.
307
308 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
309 -ruby-1.9.2_rc2.ebuild:
310 Removing old and vulnerable ebuilds
311
312 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
313 Marking ruby-1.8.7_p302 ppc64 for bug 332957
314
315 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
316 alpha/ia64/s390/sh/sparc stable wrt #332957
317
318*ruby-1.9.2 (24 Aug 2010)
319
320 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
321 metadata.xml:
322 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
323 and x86-fbsd due to a new dependency on rdoc.
324
325 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
326 arm stable, bug #332957
327
328 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
329 ruby-1.8.7_p302.ebuild:
330 x86 stable wrt security bug #332957
331
332 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
333 Stable on amd64 wrt bug #332957
334
335 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
336 Stable for PPC (bug #332957).
337
338 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
339 Stable for HPPA (bug #332957).
340
341*ruby-1.8.7_p302 (21 Aug 2010)
342
343 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
344 +ruby-1.8.7_p302.ebuild:
345 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
346 installation path.
347
348*ruby-1.8.6_p399 (19 Aug 2010)
349
350 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
351 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
352 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
353 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
354 installation path (reported by the x86 team in bug 332597)
355
356*ruby-1.9.2_rc2-r1 (18 Aug 2010)
357
358 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
359 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
360 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
361 the rubygems loading code. Add USE flag for psych.
362
363 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
364 ruby-1.9.2_rc2.ebuild:
365 Remove two keepdir that will try to keep an empty path, closes bug
366 #333163.
367
368 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
369 Marked ~ppc (bug #332593).
370
371 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
372 ruby-1.9.2_rc2.ebuild:
373 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
374
375 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
376 ruby-1.8.7_p299.ebuild:
377 Bump eselect-ruby dependency
378
379 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
380 -ruby-1.9.1_p429.ebuild:
381 Remove ebuild that is not target for unmask anyway.
382
383 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
384 ruby-1.9.2_rc2.ebuild:
385 Try 2 to fix the berkdb 5 issue on 1.9.
386
387 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
388 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
389 ruby-1.9.2_rc2.ebuild:
390 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
391 support for adding new patchsets without bumping the revision for all the
392 old ebuilds as well.
393
394*ruby-1.9.2_rc2 (14 Jul 2010)
395
396 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
397 +ruby-1.9.2_rc2.ebuild:
398 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
399 might cause _further_ build failures as it changed slightly behaviour.
400 You're going to need to rebuild rubygems and then all the packages
401 previously installed after upgrading to this.
402
403 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
404 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
405 -ruby-1.9.1_p376.ebuild:
406 Cleanup old versions.
407
408*ruby-1.9.1_p429 (04 Jul 2010)
409
410 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
411 +ruby-1.9.1_p429.ebuild:
412 Version bump to new 1.9.1 release.
413
414*ruby-1.8.7_p299 (23 Jun 2010)
415
416 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
417 +ruby-1.8.7_p299.ebuild:
418 Version bump.
419
420 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
421 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
422 remove useless comments
423
424 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
425 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
426 ruby-1.9.1_p376.ebuild:
427 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
428 dev.gentoo.org now.
429
430 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
431 ruby-1.9.1_p376.ebuild:
432 Use the correct RUBYLIB.
433
434*ruby-1.8.7_p249-r2 (18 May 2010)
435*ruby-1.8.6_p388-r1 (18 May 2010)
436
437 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
438 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
439 ruby-1.9.1_p376.ebuild, metadata.xml:
440 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
441 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
442 add USE flags for ncurses, readline and libedit, and properly depend on
443 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
444 Emacs versions support ruby-mode themselves and it should be even more
445 updated.
446
447*ruby-1.8.7_p249-r1 (06 May 2010)
448
449 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
450 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
451 309789 by Sune Kloppenborg Jeppesen.
452
453 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
454 ruby-1.8.7_p249.ebuild:
455 Use $PVR instead of $PV in patchset names
456
457 06 May 2010; Alex Legler <a3li@gentoo.org>
458 -files/ruby-1.8.6-memory-leak.diff,
459 -files/ruby18-mkmf-parallel-install.patch,
460 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
461 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
462 Remove old version. Cleanup in files/
463
464*ruby-1.9.1_p376 (01 May 2010)
465
466 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
467 Version bump. Fixes security bugs 296052 and 300468. No longer installs
468 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
469 instead.
470
471 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
472 -ruby-1.8.7_p174-r1.ebuild:
473 Remove vulnerable ebuilds, 300468
474
475 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
476 ruby-1.8.7_p249.ebuild:
477 amd64 stable, security bug 300468
478
479 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
480 ruby-1.8.7_p249.ebuild:
481 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
482
483 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
484 Stable for HPPA (bug #300468).
485
486 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
487 Stable for HPPA (bug #300468).
488
489 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
490 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
491
492 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
493 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
494
495 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
496 ruby-1.8.6_p388.ebuild:
497 stable x86, security bug 300468
498
499 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
500 ruby-1.8.7_p249.ebuild:
501 stable x86, security bug 300468
502
503*ruby-1.8.6_p388 (10 Jan 2010)
504
505 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
506 +ruby-1.8.6_p388.ebuild:
507 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
508 version. The new ebuild also has the fix for bug 168939.
509
510*ruby-1.8.7_p249 (10 Jan 2010)
511
512 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
513 +ruby-1.8.7_p249.ebuild:
514 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
515 version
516
517 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
518 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
519
520*ruby-1.8.7_p248 (25 Dec 2009)
521
522 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
523 Version bump
524
525 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
526 Remove old version.
527
528 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
529 Remove old version.
530
531 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
532 ia64/s390/sh stable wrt #288699
533
534 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
535 stable sparc, bug 288699
536
537 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
538 arm stable, bug #288699
539
540 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
541 amd64/x86 stable, bug #288699
542
543 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
544 ruby-1.8.7_p174-r1.ebuild:
545 Stable on alpha, bug #288699
546
547 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
548 ppc stable #288699
549
550 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
551 Stable for HPPA (bug #288699).
552
553 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
554 Marked ~hppa too.
555
556*ruby-1.8.7_p174-r1 (06 Oct 2009)
557
558 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
559 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
560 eselect-ruby cleanup feature.
561
562*ruby-1.9.1_p243 (09 Sep 2009)
563
564 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
565 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
566 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
567 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
568 -files/ruby19-rubygems-proxy.patch,
569 -files/ruby-1.9.1_p129-parallelmake.patch,
570 -files/ruby19-mkmf-parallel-install.patch:
571 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
572 168939. Cleaning up old patches.
573
574*ruby-1.8.6_p383 (20 Aug 2009)
575
576 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
577 Patchlevel bump.
578
579 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
580 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
581 ruby-1.9.1_p129-r1.ebuild:
582 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
583
584 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
585 Removing vulnerable ebuild, bug 273213.
586
587 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
588 Marking ruby-1.8.6_p369 ppc for bug 273213
589
590 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
591 ruby-1.9.1_p129-r1.ebuild:
592 Prepend our library path instead of overwriting it during src_install.
593 Thanks to the reporter of bug #274824.
594
595*ruby-1.8.7_p174 (18 Jun 2009)
596
597 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
598 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
599 Replacing 187_p173 with _p174 because of a regression. Unifying the
600 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
601 patchsets.
602
603 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
604 Marking ruby-1.8.6_p369 ppc64 for bug 273213
605
606 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
607 arm/ia64/s390/sh/sparc stable wrt #273213
608
609 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
610 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
611 Removing old version, minor cleanup
612
613 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
614 -files/ruby-1.8.6-openssl.patch,
615 -files/ruby-1.8.6-shortname_constants.patch,
616 -files/ruby-1.8.6_p111-r13657.patch,
617 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
618 Removing vulnerable old Ruby version and stale patches, bug 274108.
619
620 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
621 ruby-1.8.6_p369.ebuild:
622 Stable on alpha, bug #273213
623
624 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
625 Stable for HPPA (bug #273213).
626
627 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
628 ruby-1.8.6_p369.ebuild:
629 stable x86, security bug 273213
630
631 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
632 amd64 stable, security bug 273213.
633
634*ruby-1.8.7_p173 (10 Jun 2009)
635*ruby-1.8.6_p369 (10 Jun 2009)
636
637 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
638 +ruby-1.8.7_p173.ebuild:
639 Version bumps for bug #273213.
640
641*ruby-1.9.1_p129-r1 (27 May 2009)
642
643 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
644 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
645 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
646 +files/ruby-1.9.1_p129-parallelmake.patch:
647 Revision bump, add patches 1) to make Ruby behave more similarly between
648 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
649 extensions (undefined symbols in them will cause abort at runtime 3) to
650 remove a concurrency issue when building the dl extension that could
651 result in a broken dl.so.
652
653 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
654 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
655 Don't block rdoc-2 or later (which may enter Portage one day as it's
656 needed by some Rakefiles).
657
658 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
659 ruby-1.9.1_p129.ebuild:
660 Add ~x86-fbsd keyword.
661
662 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
663 keyword ~sparc-fbsd, bug #252315
664
665*ruby-1.9.1_p129 (15 May 2009)
666
667 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
668 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
669 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
670 included in every release.
671
672 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
673 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
674 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
675 ruby-1.8.7_p160.ebuild:
676 Removing vulnerable versions (#268515), fixing license (#233747).
677
678 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
679 Stable for HPPA (bug #268515).
680
681 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
682 Adapting rubygems notice.
683
684 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
685 amd64 stable, bug #268515.
686
687 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
688 arm/ia64/s390/sh/sparc stable wrt #268515
689
690 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
691 ruby-1.8.6_p368.ebuild:
692 stable x86, security bug 268515
693
694 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
695 ruby-1.8.6_p368.ebuild:
696 Stable on alpha, bug #268515
697
698 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
699 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
700
701*ruby-1.8.7_p160 (07 May 2009)
702*ruby-1.8.6_p368 (07 May 2009)
703
704 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
705 +ruby-1.8.7_p160.ebuild:
706 Version bump as per secbug 268515. NB: These are the first ebuilds that
707 no longer use ruby-config.
708
709*ruby-1.9.1-r1 (03 Apr 2009)
710*ruby-1.8.7_p72-r11 (03 Apr 2009)
711*ruby-1.8.6_p287-r13 (03 Apr 2009)
712
713 03 Apr 2009; Alex Legler <a3li@gentoo.org>
714 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
715 +files/ruby18-mkmf-parallel-install.patch,
716 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
717 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
718 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
719 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
720 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
721 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
722 happy.
723
724*ruby-1.9.1 (21 Mar 2009)
725
726 21 Mar 2009; Alex Legler <a3li@gentoo.org>
727 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
728 +ruby-1.9.1.ebuild:
729 Adding Ruby 1.9.1 for preliminary testing
730
731 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
732 ruby-1.8.6_p287-r12.ebuild:
733 Marked ~ppc for bug #252315.
734
735 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
736 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
737 bug 261982.
738
739 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
740 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
741 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
742 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
743 Cleanup
744
745*ruby-1.8.7_p72-r10 (07 Mar 2009)
746
747 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
748 +ruby-1.8.7_p72-r10.ebuild:
749 Add a revision of ruby 1.8.7 using eselect ruby.
750
751 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
752 ~mips keyworded, bug #252315.
753
754 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
755 ruby-1.8.6_p287-r5.ebuild:
756 ppc stable, bug #260006
757
758 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
759 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
760
761 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
762 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
763 Fixing Tk USE flag test, bug 258893.
764
765 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
766 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
767
768 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
769 ruby-1.8.6_p287-r5.ebuild:
770 amd64 stable wrt security bug #260006
771
772 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
773 Stable for HPPA (bug #260006).
774
775 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
776 ruby-1.8.6_p287-r5.ebuild:
777 Stable on alpha, bug #260006
778
779*ruby-1.8.7_p72-r2 (23 Feb 2009)
780*ruby-1.8.6_p287-r12 (23 Feb 2009)
781*ruby-1.8.6_p287-r5 (23 Feb 2009)
782
783 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
784 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
785 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
786 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
787 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
788 now before compilation if Tk useflags don't match) and 230748 (adding
789 --enable-option-checking=no for newer versions of autoconf).
790
791 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
792 arm/ia64/s390/sh/sparc stable wrt #254307
793
794 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
795 ruby-1.8.6_p287-r4.ebuild:
796 Stable on alpha, bug #254307
797
798 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
799 ruby-1.8.6_p287-r11.ebuild:
800 keyword ~x86-fbsd, bug #252315
801
802 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
803 ppc stable #254307
804
805 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
806 amd64/x86 stable, bug #254307
807
808 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
809 stable ppc64, bug 254307
810
811 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
812 Stable for HPPA (bug #254307).
813
814 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
815 ruby-1.8.6_p287-r11.ebuild:
816 Marked ~hppa (bug #252315).
817
818*ruby-1.8.6_p287-r11 (11 Jan 2009)
819
820 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
821 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
822 +ruby-1.8.6_p287-r11.ebuild:
823 Backport conditional definition of missing openssl functions from ruby 1.8.7.
824 Fixes #254307.
825
826 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
827 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
828
829 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
830 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
831
832 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
833 ruby-1.8.6_p287-r10.ebuild:
834 Add ~sparc keyword, bug #252315
835
836*ruby-1.8.6_p287-r10 (23 Dec 2008)
837
838 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
839 +ruby-1.8.6_p287-r10.ebuild:
840 Version bump which switches from ruby-config to eselect-ruby. Dropped most
841 keywords since eselect-ruby does not yet have these keywords.
842
843 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
844 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
845 Revert the ruby-config changes. We can't remove them until we provide an
846 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
847 for breaking things as mentioned in bug #251833.
848
849 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
850 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
851 ruby-1.8.7_p72-r1.ebuild:
852 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
853 Thanks for the people noticing this in bug #251833.
854
855 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
856 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
857 ruby-1.8.7_p72-r1.ebuild:
858 Drop dependency on ruby-config, which will be removed from the tree. We
859 currently only have one major version of ruby in the tree (Ruby 1.8), so there
860 is no need for ruby-config at this moment. For newer versions of Ruby we will
861 use eselect-ruby, which can be found in the ruby overlay at the moment.
862
863 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
864 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
865 Use mirror://ruby in SRC_URI, fixes #237392.
866
867 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
868 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
869 -ruby-1.8.7_p72.ebuild:
870 Remove old versions. Leave one old stable version with cjk support.
871
872*ruby-1.8.6_p287-r3 (29 Nov 2008)
873
874 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
875 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
876 +ruby-1.8.6_p287-r3.ebuild:
877 Fix our expansion limit patch according to debian bug report
878 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
879 make sure people will pick up the fixed version. Thanks to Alex Legler for
880 mentioning the patch.
881
882*ruby-1.8.7_p72-r1 (26 Nov 2008)
883*ruby-1.8.6_p287-r2 (26 Nov 2008)
884
885 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
886 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
887 +ruby-1.8.7_p72-r1.ebuild:
888 Fix problem with shortname constants #247790, already fixed in upstream SVN.
889 Thanks to Alex Legler for providing the patch.
890
891 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
892 -ruby-1.8.6_p287.ebuild:
893 Remove versions that will not become stable
894
895 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
896 ruby-1.8.6_p287-r1.ebuild:
897 ppc stable, bug #225465
898
899 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
900 ruby-1.8.6_p287-r1.ebuild:
901 amd64 stable wrt security bug #225465
902
903 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
904 alpha/ia64/x86 stable wrt #225465
905
906 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
907 ruby-1.8.6_p287-r1.ebuild:
908 Sparc stable --- Security Bug #225465 --- good since late August.
909
910 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
911 Stable on ppc64; bug #225465
912
913 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
914 Stable for HPPA (bug #225465).
915
916*ruby-1.8.6_p287-r1 (29 Aug 2008)
917
918 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
919 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
920 +ruby-1.8.6_p287-r1.ebuild:
921 Fix REXML security issues, bug #236060.
922
923 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
924 Add GLEP 56 USE flag descriptions.
925
926*ruby-1.8.7_p72 (15 Aug 2008)
927
928 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
929 +ruby-1.8.7_p72.ebuild:
930 bump 1.8.7 to latest patch release
931
932*ruby-1.8.6_p287 (11 Aug 2008)
933
934 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
935 Version bump for brown paper bag relelease.
936
937 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
938 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
939 Remove broken version in favor of the just-added 1.8.6_p286
940
941*ruby-1.8.6_p286 (10 Aug 2008)
942
943 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
944 Version bump to latest released version of ruby 1.8.6. This version fixes the
945 security issues reported in #225465 and #234224. The cjk USE flag has been
946 dropped since no compatible patches have been released yet.
947
948 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
949 ruby-1.8.6_p230.ebuild:
950 drop cjk from SRC_URI as well
951
952 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
953 Drop cjk support since the most recent oniguruma patches no longer apply to
954 this version, #230111.
955
956 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
957 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
958 Try to fix the security issues reported in #225465 for ruby 1.8.6.
959 Unfortunately the official p230 has a change which causes segmentation faults
960 for applications like Rails and RSpec, so we are reverting that specific
961 change.
962
963*ruby-1.8.7_p22 (29 Jun 2008)
964
965 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
966 +ruby-1.8.7_p22.ebuild:
967 bump 1.8.7 for security fix
968
969 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
970 nevermind, don't bump this yet
971
972*ruby-1.8.6_p230 (20 Jun 2008)
973
974 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
975 version bump
976
977*ruby-1.8.7 (10 Jun 2008)
978
979 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
980 +ruby-1.8.7.ebuild:
981 bump 1.8.7 to final
982
983*ruby-1.8.7_pre2 (21 Apr 2008)
984
985 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
986 +ruby-1.8.7_pre2.ebuild:
987 Version Bump
988
989*ruby-1.8.7_pre1 (16 Apr 2008)
990
991 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
992 Version bump. Drop cjk until a new version of oniguruma appears.
993
994 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
995 amd64 stable, bug 212264
996
997 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
998 Stable for HPPA (bug #212264).
999
1000 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1001 ruby-1.8.6_p114.ebuild:
1002 ppc stable, bug #212264
1003
1004 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1005 alpha/ia64 stable wrt #212264
1006
1007 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1008 ruby-1.8.6_p114.ebuild:
1009 stable x86, security bug 212264
1010
1011 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1012 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1013 as expected.
1014
1015 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1016 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1017
1018*ruby-1.8.6_p114 (05 Mar 2008)
1019
1020 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1021 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1022 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1023 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1024 Version bump for #212264. Remove old ebuilds.
1025
1026 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1027 alpha/ia64 stable wrt #208916
1028
1029 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1030 Stable on ppc wrt bug 208916
1031
1032 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1033 x86 stable, bug #208916
1034
1035 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1036 ruby-1.8.6_p111-r1.ebuild:
1037 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1038
1039 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1040 -files/ruby-1.8.6-exit-status.patch,
1041 -files/ruby-1.8.6_p110-net-http-p111.patch,
1042 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1043 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1044 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1045 Remove old versions
1046
1047 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1048 Stable on ppc64
1049
1050 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1051 Stable on amd64; bug 199191
1052
1053 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1054 alpha/ia64/sparc stable wrt #199191
1055
1056 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1057 Remove now-obsolete warning about coreutils versions, #203156.
1058
1059 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1060 Stable for HPPA (bug #199191).
1061
1062*ruby-1.8.6_p111-r1 (23 Dec 2007)
1063
1064 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1065 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1066 ssl USE flags. Patch to p113.
1067
1068 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1069 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1070
1071 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1072 x86 stable, security bug #199191
1073
1074*ruby-1.8.6_p111 (23 Dec 2007)
1075
1076 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1077 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1078 Version bump with patch for bug #199191
1079
1080 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1081 Move dependency on (X)Emacs modes to PDEPEND.
1082
1083 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1084 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1085 bug 196413
1086
1087*ruby-1.8.6_p110-r2 (21 Oct 2007)
1088
1089 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1090 +ruby-1.8.6_p110-r2.ebuild:
1091 Add emacs and xemacs USE flags and use them to pull in the correct editing
1092 mode for each. Had to drop several arch keywords as reported on bug 196413.
1093
1094 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1095 amd64 stable, security bug 194236
1096
1097 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1098 ruby-1.8.6_p110-r1.ebuild:
1099 Stable on ppc64; bug #194236
1100
1101 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1102 amd64 stable, security bug 194236
1103
1104 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1105 Stable for HPPA (bug #194236).
1106
1107 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1108 alpha/ia64/sparc stable wrt security #194236
1109
1110 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1111 ruby-1.8.6_p110-r1.ebuild:
1112 ppc stable, bug #194236
1113
1114 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1115 ruby-1.8.6_p110-r1.ebuild:
1116 stable x86, security bug 194236
1117
1118 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1119 ruby-1.8.5_p113.ebuild:
1120 stable x86, security bug 194236
1121
1122 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1123 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1124 -ruby-1.8.6_p110.ebuild:
1125 Remove old versions
1126
1127*ruby-1.8.6_p110-r1 (30 Sep 2007)
1128*ruby-1.8.5_p113 (30 Sep 2007)
1129
1130 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1131 +files/ruby-1.8.5_p113-net-http-p114.patch,
1132 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1133 +ruby-1.8.6_p110-r1.ebuild:
1134 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1135 using 1.8.6-p110 as base ebuild.
1136
1137 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1138 More fixes from gentoo-dev and graaff
1139
1140 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1141 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1142
1143*ruby-1.8.6_p110 (24 Sep 2007)
1144
1145 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1146 Version bump
1147
1148*ruby-1.8.6_p36-r4 (26 Aug 2007)
1149
1150 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1151 +ruby-1.8.6_p36-r4.ebuild:
1152 Use user LDFLAGS, #181436
1153
1154 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1155 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1156 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1157 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1158
1159 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1160 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1161 -ruby-1.8.6_p36-r2.ebuild:
1162 Remove some older versions that will not be promoted to stable, keeping at
1163 least one version of each release.
1164
1165 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1166 ruby-1.8.6_p36-r3.ebuild:
1167 (QA) RESTRICT clean up.
1168
1169*ruby-1.8.6_p36-r3 (04 Jul 2007)
1170
1171 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1172 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1173 fixed memory leak loading .so bug #182946
1174
1175 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1176 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1177 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1178 ruby-1.8.6_p36-r2.ebuild:
1179 (QA) RESTRICT clean up.
1180
1181 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1182 Re-add stable keyword for alpha as per bug #181110
1183
1184 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1185 Back to ~amd64 wrt bug 181110
1186
1187 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1188 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1189
1190*ruby-1.8.6_p36-r2 (20 Jun 2007)
1191
1192 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1193 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1194
1195*ruby-1.8.6_p36-r1 (18 Jun 2007)
1196
1197 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1198 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1199 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1200 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1201 spbecker
1202
1203 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1204 Stable on amd64 wrt bug 181110
1205
1206*ruby-1.8.6_p36 (12 Jun 2007)
1207
1208 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1209 Version Bump. Bug #181379
1210
1211 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1212 Stable on mips, per #181110.
1213
1214 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1215 Stable on ppc wrt bug 181110
1216
1217 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1218 Stable for HPPA (bug #181110).
1219
1220 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1221 alpha/ia64/x86 stable wrt #181110
1222
1223 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1224 Stable on sparc wrt #181110
1225
1226 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1227 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1228
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1229 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1230 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1231 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1232 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.557

  ViewVC Help
Powered by ViewVC 1.1.20