/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.560
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.560 2013/02/22 19:21:43 graaff Exp $
4
5*ruby-1.9.3_p392 (22 Feb 2013)
6
7 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
8 Version bump for security bug 458776.
9
10*ruby-1.9.3_p385 (10 Feb 2013)
11
12 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
13 Version bump. Fixes security bug 442580.
14
15 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
16 keyword ~amd64-fbsd
17
18*ruby-1.8.7_p371 (06 Jan 2013)
19
20 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
21 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
22 Version bump for security bug 437366.
23
24 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
25 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
26 Cleanup.
27
28 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
29 Stable for ppc, wrt bug #427774
30
31 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
32 Stable for HPPA (bug #411507).
33
34 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
35 alpha/ia64/s390/sh/sparc stable wrt #434480
36
37 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
38 ruby-1.9.3_p286.ebuild:
39 Remove HPPA target hack (bug #342819).
40
41 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
42 alpha/ia64/s390/sh/sparc stable wrt #411507
43
44 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
45 Stable for HPPA (bug #434480).
46
47*ruby-1.9.3_p286 (15 Oct 2012)
48
49 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
50 Version bump. Fixes bugs #437264 and #437264.
51
52 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
53 stable arm, bug #434480
54
55 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
56 stable ppc ppc64, bug #434480
57
58 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
59 Stable for x86, wrt bug #434480
60
61 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
62 ruby-1.9.3_p194-r1.ebuild:
63 Update LICENSE, bug 434332.
64
65 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
66 Stable for amd64, wrt bug #434480
67
68 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
69 Stable for amd64, wrt bug #427774
70
71 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
72 arm stable, bug #427774
73
74 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
75 ruby-1.9.3_p194-r1.ebuild:
76 Stable ppc64, bug #411507
77
78 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
79 marked x86 per bug 427774
80
81 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
82 -ruby-1.9.3_p194.ebuild:
83 Cleanup.
84
85 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
86 ppc stable #411507
87
88 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
89 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
90 424611.
91
92*ruby-1.8.7_p370 (07 Jul 2012)
93
94 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
95 Version bump. Fix bug 378567 thanks to slyfox.
96
97 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
98 x86 stable, see bug 411507
99
100 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
101 arm stable, bug #411507
102
103 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
104 Stable for amd64, wrt bug #411507
105
106*ruby-1.9.3_p194-r1 (12 May 2012)
107
108 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
109 +ruby-1.9.3_p194-r1.ebuild:
110 Revision bump to fix mkmf for parallel build/install. Also enable verbose
111 build, so that the log makes sense if it fails.
112
113*ruby-1.9.3_p194 (30 Apr 2012)
114
115 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
116 Version bump.
117
118 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
119 keyword ~amd64-fbsd
120
121*ruby-1.8.7_p358 (20 Apr 2012)
122
123 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
124 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
125 Rails 3.2.
126
127 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
128 Add ~x86-fbsd, #332593
129
130*ruby-1.9.3_p125 (18 Feb 2012)
131
132 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
133 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
134
135 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
136 add ~arm, bug #332593
137
138 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
139 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
140
141 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
142 x86 stable wrt bug #396301
143
144 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
145 Stable for HPPA (bug #396301).
146
147 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
148 Stable for ppc/ppc64; bug #396301
149
150 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
151 Marked ~hppa (bug #332593).
152
153 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
154 Add back ~alpha keyword now that rubygems is keyworded.
155
156 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
157 Stable for AMD64, wrt security bug #396301
158
159*ruby-1.8.7_p357 (28 Dec 2011)
160
161 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
162 Version bump for security bug 396301.
163
164 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
165 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
166
167 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
168 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
169 keyworded, bug 332593.
170
171 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
172 Block older versions of packages that are no longer compatible. Remove
173 ancient blocks on packags long gone from the tree.
174
175 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
176 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
177 Remove old versions.
178
179*ruby-1.9.3_p0 (18 Dec 2011)
180
181 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
182 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
183 suite which need to be diagnosed first.
184
185 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
186 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
187 #332593).
188
189 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
190 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
191 #332593).
192
193 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
194 alpha/ia64/s390/sh/sparc stable wrt #386369
195
196*ruby-1.9.3_rc1 (22 Oct 2011)
197
198 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
199 Version bump.
200
201 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
202 arm stable, bug #386369
203
204 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
205 x86 stable, bug 386369
206
207 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
208 Stable for HPPA (bug #386369).
209
210 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
211 ppc/ppc64 stable wrt #386369
212
213 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
214 Stable on amd64 wrt bug #386369
215
216 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
217 Remove vulnerable version, bug 386369.
218
219*ruby-1.8.7_p352 (30 Aug 2011)
220
221 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
222 +ruby-1.8.7_p352.ebuild:
223 Patchlevel bump for ruby:1.8. Removing old version
224
225*ruby-1.9.2_p290 (30 Aug 2011)
226
227 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
228 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
229 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
230 old patchlevels.
231
232 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
233 ruby-1.8.7_p334-r2.ebuild:
234 ppc/ppc64 stable wrt #378691
235
236*ruby-1.8.7_p334-r2 (22 Jul 2011)
237
238 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
239 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
240 for chasing down upstream and us.
241
242 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
243 Added ~mips, bug 332593
244
245 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
246 ruby-1.8.7_p334-r1.ebuild:
247 ppc64 stable wrt #369141
248
249 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
250 ia64/s390/sh/sparc stable wrt #369141
251
252 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
253 Stable for HPPA (bug #369141).
254
255 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
256 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
257
258 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
259 arm/x86 stable, bug #369141
260
261 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
262 Stable on amd64 wrt bug #369141
263
264 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
265 ruby-1.8.7_p334-r1.ebuild:
266 Stable on alpha, bug #369141
267
268*ruby-1.8.7_p334-r1 (31 May 2011)
269
270 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
271 Revision bump for security bug 369141 (CVE-2011-0188)
272
273*ruby-1.9.2-r1 (16 May 2011)
274
275 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
276 Don't remove racc files since all other ruby targets ship these files
277 themselves as well. Closes bug 363419.
278
279 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
280 ruby-1.8.7_p334.ebuild:
281 Remove old version. Remove obsolete and unused old-style virtual/ruby.
282
283 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
284 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
285
286 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
287 Add append-flags -mieee on sh, bug #357559
288
289 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
290 alpha/arm/ia64/s390/sh stable wrt #355439
291
292 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
293 Marked ~ppc64 wrt #332593
294
295 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
296 ruby-1.8.7_p334.ebuild:
297 x86 stable wrt security bug #355439
298
299 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
300 ruby-1.8.7_p334.ebuild:
301 ppc/ppc64 stable wrt #355439
302
303 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
304 Stable on amd64 wrt bug #355439
305
306 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
307 Stable for HPPA (bug #355439).
308
309*ruby-1.8.7_p334 (19 Feb 2011)
310
311 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
312 Version bump 1.8.7 series, security bug 355439
313
314 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
315 ruby-1.9.2.ebuild:
316 Remove PROVIDE for old-style virtual/ruby per bug 265054.
317
318 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
319 Remove masked ruby 1.8.6 per bug 332597.
320
321 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
322 -ruby-1.9.2_rc2.ebuild:
323 Removing old and vulnerable ebuilds
324
325 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
326 Marking ruby-1.8.7_p302 ppc64 for bug 332957
327
328 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
329 alpha/ia64/s390/sh/sparc stable wrt #332957
330
331*ruby-1.9.2 (24 Aug 2010)
332
333 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
334 metadata.xml:
335 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
336 and x86-fbsd due to a new dependency on rdoc.
337
338 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
339 arm stable, bug #332957
340
341 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
342 ruby-1.8.7_p302.ebuild:
343 x86 stable wrt security bug #332957
344
345 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
346 Stable on amd64 wrt bug #332957
347
348 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
349 Stable for PPC (bug #332957).
350
351 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
352 Stable for HPPA (bug #332957).
353
354*ruby-1.8.7_p302 (21 Aug 2010)
355
356 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
357 +ruby-1.8.7_p302.ebuild:
358 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
359 installation path.
360
361*ruby-1.8.6_p399 (19 Aug 2010)
362
363 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
364 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
365 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
366 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
367 installation path (reported by the x86 team in bug 332597)
368
369*ruby-1.9.2_rc2-r1 (18 Aug 2010)
370
371 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
372 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
373 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
374 the rubygems loading code. Add USE flag for psych.
375
376 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
377 ruby-1.9.2_rc2.ebuild:
378 Remove two keepdir that will try to keep an empty path, closes bug
379 #333163.
380
381 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
382 Marked ~ppc (bug #332593).
383
384 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
385 ruby-1.9.2_rc2.ebuild:
386 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
387
388 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
389 ruby-1.8.7_p299.ebuild:
390 Bump eselect-ruby dependency
391
392 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
393 -ruby-1.9.1_p429.ebuild:
394 Remove ebuild that is not target for unmask anyway.
395
396 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
397 ruby-1.9.2_rc2.ebuild:
398 Try 2 to fix the berkdb 5 issue on 1.9.
399
400 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
401 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
402 ruby-1.9.2_rc2.ebuild:
403 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
404 support for adding new patchsets without bumping the revision for all the
405 old ebuilds as well.
406
407*ruby-1.9.2_rc2 (14 Jul 2010)
408
409 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
410 +ruby-1.9.2_rc2.ebuild:
411 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
412 might cause _further_ build failures as it changed slightly behaviour.
413 You're going to need to rebuild rubygems and then all the packages
414 previously installed after upgrading to this.
415
416 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
417 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
418 -ruby-1.9.1_p376.ebuild:
419 Cleanup old versions.
420
421*ruby-1.9.1_p429 (04 Jul 2010)
422
423 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
424 +ruby-1.9.1_p429.ebuild:
425 Version bump to new 1.9.1 release.
426
427*ruby-1.8.7_p299 (23 Jun 2010)
428
429 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
430 +ruby-1.8.7_p299.ebuild:
431 Version bump.
432
433 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
434 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
435 remove useless comments
436
437 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
438 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
439 ruby-1.9.1_p376.ebuild:
440 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
441 dev.gentoo.org now.
442
443 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
444 ruby-1.9.1_p376.ebuild:
445 Use the correct RUBYLIB.
446
447*ruby-1.8.7_p249-r2 (18 May 2010)
448*ruby-1.8.6_p388-r1 (18 May 2010)
449
450 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
451 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
452 ruby-1.9.1_p376.ebuild, metadata.xml:
453 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
454 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
455 add USE flags for ncurses, readline and libedit, and properly depend on
456 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
457 Emacs versions support ruby-mode themselves and it should be even more
458 updated.
459
460*ruby-1.8.7_p249-r1 (06 May 2010)
461
462 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
463 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
464 309789 by Sune Kloppenborg Jeppesen.
465
466 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
467 ruby-1.8.7_p249.ebuild:
468 Use $PVR instead of $PV in patchset names
469
470 06 May 2010; Alex Legler <a3li@gentoo.org>
471 -files/ruby-1.8.6-memory-leak.diff,
472 -files/ruby18-mkmf-parallel-install.patch,
473 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
474 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
475 Remove old version. Cleanup in files/
476
477*ruby-1.9.1_p376 (01 May 2010)
478
479 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
480 Version bump. Fixes security bugs 296052 and 300468. No longer installs
481 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
482 instead.
483
484 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
485 -ruby-1.8.7_p174-r1.ebuild:
486 Remove vulnerable ebuilds, 300468
487
488 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
489 ruby-1.8.7_p249.ebuild:
490 amd64 stable, security bug 300468
491
492 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
493 ruby-1.8.7_p249.ebuild:
494 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
495
496 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
497 Stable for HPPA (bug #300468).
498
499 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
500 Stable for HPPA (bug #300468).
501
502 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
503 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
504
505 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
506 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
507
508 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
509 ruby-1.8.6_p388.ebuild:
510 stable x86, security bug 300468
511
512 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
513 ruby-1.8.7_p249.ebuild:
514 stable x86, security bug 300468
515
516*ruby-1.8.6_p388 (10 Jan 2010)
517
518 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
519 +ruby-1.8.6_p388.ebuild:
520 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
521 version. The new ebuild also has the fix for bug 168939.
522
523*ruby-1.8.7_p249 (10 Jan 2010)
524
525 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
526 +ruby-1.8.7_p249.ebuild:
527 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
528 version
529
530 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
531 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
532
533*ruby-1.8.7_p248 (25 Dec 2009)
534
535 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
536 Version bump
537
538 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
539 Remove old version.
540
541 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
542 Remove old version.
543
544 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
545 ia64/s390/sh stable wrt #288699
546
547 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
548 stable sparc, bug 288699
549
550 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
551 arm stable, bug #288699
552
553 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
554 amd64/x86 stable, bug #288699
555
556 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
557 ruby-1.8.7_p174-r1.ebuild:
558 Stable on alpha, bug #288699
559
560 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
561 ppc stable #288699
562
563 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
564 Stable for HPPA (bug #288699).
565
566 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
567 Marked ~hppa too.
568
569*ruby-1.8.7_p174-r1 (06 Oct 2009)
570
571 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
572 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
573 eselect-ruby cleanup feature.
574
575*ruby-1.9.1_p243 (09 Sep 2009)
576
577 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
578 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
579 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
580 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
581 -files/ruby19-rubygems-proxy.patch,
582 -files/ruby-1.9.1_p129-parallelmake.patch,
583 -files/ruby19-mkmf-parallel-install.patch:
584 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
585 168939. Cleaning up old patches.
586
587*ruby-1.8.6_p383 (20 Aug 2009)
588
589 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
590 Patchlevel bump.
591
592 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
593 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
594 ruby-1.9.1_p129-r1.ebuild:
595 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
596
597 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
598 Removing vulnerable ebuild, bug 273213.
599
600 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
601 Marking ruby-1.8.6_p369 ppc for bug 273213
602
603 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
604 ruby-1.9.1_p129-r1.ebuild:
605 Prepend our library path instead of overwriting it during src_install.
606 Thanks to the reporter of bug #274824.
607
608*ruby-1.8.7_p174 (18 Jun 2009)
609
610 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
611 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
612 Replacing 187_p173 with _p174 because of a regression. Unifying the
613 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
614 patchsets.
615
616 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
617 Marking ruby-1.8.6_p369 ppc64 for bug 273213
618
619 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
620 arm/ia64/s390/sh/sparc stable wrt #273213
621
622 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
623 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
624 Removing old version, minor cleanup
625
626 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
627 -files/ruby-1.8.6-openssl.patch,
628 -files/ruby-1.8.6-shortname_constants.patch,
629 -files/ruby-1.8.6_p111-r13657.patch,
630 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
631 Removing vulnerable old Ruby version and stale patches, bug 274108.
632
633 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
634 ruby-1.8.6_p369.ebuild:
635 Stable on alpha, bug #273213
636
637 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
638 Stable for HPPA (bug #273213).
639
640 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
641 ruby-1.8.6_p369.ebuild:
642 stable x86, security bug 273213
643
644 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
645 amd64 stable, security bug 273213.
646
647*ruby-1.8.7_p173 (10 Jun 2009)
648*ruby-1.8.6_p369 (10 Jun 2009)
649
650 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
651 +ruby-1.8.7_p173.ebuild:
652 Version bumps for bug #273213.
653
654*ruby-1.9.1_p129-r1 (27 May 2009)
655
656 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
657 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
658 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
659 +files/ruby-1.9.1_p129-parallelmake.patch:
660 Revision bump, add patches 1) to make Ruby behave more similarly between
661 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
662 extensions (undefined symbols in them will cause abort at runtime 3) to
663 remove a concurrency issue when building the dl extension that could
664 result in a broken dl.so.
665
666 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
667 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
668 Don't block rdoc-2 or later (which may enter Portage one day as it's
669 needed by some Rakefiles).
670
671 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
672 ruby-1.9.1_p129.ebuild:
673 Add ~x86-fbsd keyword.
674
675 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
676 keyword ~sparc-fbsd, bug #252315
677
678*ruby-1.9.1_p129 (15 May 2009)
679
680 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
681 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
682 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
683 included in every release.
684
685 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
686 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
687 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
688 ruby-1.8.7_p160.ebuild:
689 Removing vulnerable versions (#268515), fixing license (#233747).
690
691 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
692 Stable for HPPA (bug #268515).
693
694 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
695 Adapting rubygems notice.
696
697 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
698 amd64 stable, bug #268515.
699
700 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
701 arm/ia64/s390/sh/sparc stable wrt #268515
702
703 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
704 ruby-1.8.6_p368.ebuild:
705 stable x86, security bug 268515
706
707 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
708 ruby-1.8.6_p368.ebuild:
709 Stable on alpha, bug #268515
710
711 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
712 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
713
714*ruby-1.8.7_p160 (07 May 2009)
715*ruby-1.8.6_p368 (07 May 2009)
716
717 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
718 +ruby-1.8.7_p160.ebuild:
719 Version bump as per secbug 268515. NB: These are the first ebuilds that
720 no longer use ruby-config.
721
722*ruby-1.9.1-r1 (03 Apr 2009)
723*ruby-1.8.7_p72-r11 (03 Apr 2009)
724*ruby-1.8.6_p287-r13 (03 Apr 2009)
725
726 03 Apr 2009; Alex Legler <a3li@gentoo.org>
727 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
728 +files/ruby18-mkmf-parallel-install.patch,
729 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
730 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
731 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
732 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
733 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
734 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
735 happy.
736
737*ruby-1.9.1 (21 Mar 2009)
738
739 21 Mar 2009; Alex Legler <a3li@gentoo.org>
740 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
741 +ruby-1.9.1.ebuild:
742 Adding Ruby 1.9.1 for preliminary testing
743
744 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
745 ruby-1.8.6_p287-r12.ebuild:
746 Marked ~ppc for bug #252315.
747
748 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
749 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
750 bug 261982.
751
752 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
753 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
754 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
755 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
756 Cleanup
757
758*ruby-1.8.7_p72-r10 (07 Mar 2009)
759
760 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
761 +ruby-1.8.7_p72-r10.ebuild:
762 Add a revision of ruby 1.8.7 using eselect ruby.
763
764 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
765 ~mips keyworded, bug #252315.
766
767 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
768 ruby-1.8.6_p287-r5.ebuild:
769 ppc stable, bug #260006
770
771 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
772 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
773
774 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
775 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
776 Fixing Tk USE flag test, bug 258893.
777
778 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
779 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
780
781 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
782 ruby-1.8.6_p287-r5.ebuild:
783 amd64 stable wrt security bug #260006
784
785 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
786 Stable for HPPA (bug #260006).
787
788 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
789 ruby-1.8.6_p287-r5.ebuild:
790 Stable on alpha, bug #260006
791
792*ruby-1.8.7_p72-r2 (23 Feb 2009)
793*ruby-1.8.6_p287-r12 (23 Feb 2009)
794*ruby-1.8.6_p287-r5 (23 Feb 2009)
795
796 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
797 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
798 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
799 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
800 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
801 now before compilation if Tk useflags don't match) and 230748 (adding
802 --enable-option-checking=no for newer versions of autoconf).
803
804 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
805 arm/ia64/s390/sh/sparc stable wrt #254307
806
807 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
808 ruby-1.8.6_p287-r4.ebuild:
809 Stable on alpha, bug #254307
810
811 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
812 ruby-1.8.6_p287-r11.ebuild:
813 keyword ~x86-fbsd, bug #252315
814
815 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
816 ppc stable #254307
817
818 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
819 amd64/x86 stable, bug #254307
820
821 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
822 stable ppc64, bug 254307
823
824 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
825 Stable for HPPA (bug #254307).
826
827 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
828 ruby-1.8.6_p287-r11.ebuild:
829 Marked ~hppa (bug #252315).
830
831*ruby-1.8.6_p287-r11 (11 Jan 2009)
832
833 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
834 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
835 +ruby-1.8.6_p287-r11.ebuild:
836 Backport conditional definition of missing openssl functions from ruby 1.8.7.
837 Fixes #254307.
838
839 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
840 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
841
842 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
843 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
844
845 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
846 ruby-1.8.6_p287-r10.ebuild:
847 Add ~sparc keyword, bug #252315
848
849*ruby-1.8.6_p287-r10 (23 Dec 2008)
850
851 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
852 +ruby-1.8.6_p287-r10.ebuild:
853 Version bump which switches from ruby-config to eselect-ruby. Dropped most
854 keywords since eselect-ruby does not yet have these keywords.
855
856 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
857 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
858 Revert the ruby-config changes. We can't remove them until we provide an
859 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
860 for breaking things as mentioned in bug #251833.
861
862 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
863 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
864 ruby-1.8.7_p72-r1.ebuild:
865 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
866 Thanks for the people noticing this in bug #251833.
867
868 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
869 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
870 ruby-1.8.7_p72-r1.ebuild:
871 Drop dependency on ruby-config, which will be removed from the tree. We
872 currently only have one major version of ruby in the tree (Ruby 1.8), so there
873 is no need for ruby-config at this moment. For newer versions of Ruby we will
874 use eselect-ruby, which can be found in the ruby overlay at the moment.
875
876 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
877 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
878 Use mirror://ruby in SRC_URI, fixes #237392.
879
880 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
881 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
882 -ruby-1.8.7_p72.ebuild:
883 Remove old versions. Leave one old stable version with cjk support.
884
885*ruby-1.8.6_p287-r3 (29 Nov 2008)
886
887 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
888 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
889 +ruby-1.8.6_p287-r3.ebuild:
890 Fix our expansion limit patch according to debian bug report
891 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
892 make sure people will pick up the fixed version. Thanks to Alex Legler for
893 mentioning the patch.
894
895*ruby-1.8.7_p72-r1 (26 Nov 2008)
896*ruby-1.8.6_p287-r2 (26 Nov 2008)
897
898 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
899 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
900 +ruby-1.8.7_p72-r1.ebuild:
901 Fix problem with shortname constants #247790, already fixed in upstream SVN.
902 Thanks to Alex Legler for providing the patch.
903
904 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
905 -ruby-1.8.6_p287.ebuild:
906 Remove versions that will not become stable
907
908 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
909 ruby-1.8.6_p287-r1.ebuild:
910 ppc stable, bug #225465
911
912 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
913 ruby-1.8.6_p287-r1.ebuild:
914 amd64 stable wrt security bug #225465
915
916 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
917 alpha/ia64/x86 stable wrt #225465
918
919 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
920 ruby-1.8.6_p287-r1.ebuild:
921 Sparc stable --- Security Bug #225465 --- good since late August.
922
923 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
924 Stable on ppc64; bug #225465
925
926 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
927 Stable for HPPA (bug #225465).
928
929*ruby-1.8.6_p287-r1 (29 Aug 2008)
930
931 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
932 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
933 +ruby-1.8.6_p287-r1.ebuild:
934 Fix REXML security issues, bug #236060.
935
936 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
937 Add GLEP 56 USE flag descriptions.
938
939*ruby-1.8.7_p72 (15 Aug 2008)
940
941 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
942 +ruby-1.8.7_p72.ebuild:
943 bump 1.8.7 to latest patch release
944
945*ruby-1.8.6_p287 (11 Aug 2008)
946
947 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
948 Version bump for brown paper bag relelease.
949
950 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
951 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
952 Remove broken version in favor of the just-added 1.8.6_p286
953
954*ruby-1.8.6_p286 (10 Aug 2008)
955
956 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
957 Version bump to latest released version of ruby 1.8.6. This version fixes the
958 security issues reported in #225465 and #234224. The cjk USE flag has been
959 dropped since no compatible patches have been released yet.
960
961 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
962 ruby-1.8.6_p230.ebuild:
963 drop cjk from SRC_URI as well
964
965 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
966 Drop cjk support since the most recent oniguruma patches no longer apply to
967 this version, #230111.
968
969 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
970 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
971 Try to fix the security issues reported in #225465 for ruby 1.8.6.
972 Unfortunately the official p230 has a change which causes segmentation faults
973 for applications like Rails and RSpec, so we are reverting that specific
974 change.
975
976*ruby-1.8.7_p22 (29 Jun 2008)
977
978 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
979 +ruby-1.8.7_p22.ebuild:
980 bump 1.8.7 for security fix
981
982 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
983 nevermind, don't bump this yet
984
985*ruby-1.8.6_p230 (20 Jun 2008)
986
987 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
988 version bump
989
990*ruby-1.8.7 (10 Jun 2008)
991
992 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
993 +ruby-1.8.7.ebuild:
994 bump 1.8.7 to final
995
996*ruby-1.8.7_pre2 (21 Apr 2008)
997
998 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
999 +ruby-1.8.7_pre2.ebuild:
1000 Version Bump
1001
1002*ruby-1.8.7_pre1 (16 Apr 2008)
1003
1004 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1005 Version bump. Drop cjk until a new version of oniguruma appears.
1006
1007 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1008 amd64 stable, bug 212264
1009
1010 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1011 Stable for HPPA (bug #212264).
1012
1013 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1014 ruby-1.8.6_p114.ebuild:
1015 ppc stable, bug #212264
1016
1017 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1018 alpha/ia64 stable wrt #212264
1019
1020 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1021 ruby-1.8.6_p114.ebuild:
1022 stable x86, security bug 212264
1023
1024 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1025 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1026 as expected.
1027
1028 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1029 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1030
1031*ruby-1.8.6_p114 (05 Mar 2008)
1032
1033 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1034 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1035 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1036 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1037 Version bump for #212264. Remove old ebuilds.
1038
1039 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1040 alpha/ia64 stable wrt #208916
1041
1042 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1043 Stable on ppc wrt bug 208916
1044
1045 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1046 x86 stable, bug #208916
1047
1048 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1049 ruby-1.8.6_p111-r1.ebuild:
1050 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1051
1052 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1053 -files/ruby-1.8.6-exit-status.patch,
1054 -files/ruby-1.8.6_p110-net-http-p111.patch,
1055 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1056 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1057 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1058 Remove old versions
1059
1060 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1061 Stable on ppc64
1062
1063 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1064 Stable on amd64; bug 199191
1065
1066 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1067 alpha/ia64/sparc stable wrt #199191
1068
1069 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1070 Remove now-obsolete warning about coreutils versions, #203156.
1071
1072 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1073 Stable for HPPA (bug #199191).
1074
1075*ruby-1.8.6_p111-r1 (23 Dec 2007)
1076
1077 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1078 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1079 ssl USE flags. Patch to p113.
1080
1081 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1082 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1083
1084 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1085 x86 stable, security bug #199191
1086
1087*ruby-1.8.6_p111 (23 Dec 2007)
1088
1089 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1090 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1091 Version bump with patch for bug #199191
1092
1093 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1094 Move dependency on (X)Emacs modes to PDEPEND.
1095
1096 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1097 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1098 bug 196413
1099
1100*ruby-1.8.6_p110-r2 (21 Oct 2007)
1101
1102 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1103 +ruby-1.8.6_p110-r2.ebuild:
1104 Add emacs and xemacs USE flags and use them to pull in the correct editing
1105 mode for each. Had to drop several arch keywords as reported on bug 196413.
1106
1107 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1108 amd64 stable, security bug 194236
1109
1110 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1111 ruby-1.8.6_p110-r1.ebuild:
1112 Stable on ppc64; bug #194236
1113
1114 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1115 amd64 stable, security bug 194236
1116
1117 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1118 Stable for HPPA (bug #194236).
1119
1120 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1121 alpha/ia64/sparc stable wrt security #194236
1122
1123 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1124 ruby-1.8.6_p110-r1.ebuild:
1125 ppc stable, bug #194236
1126
1127 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1128 ruby-1.8.6_p110-r1.ebuild:
1129 stable x86, security bug 194236
1130
1131 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1132 ruby-1.8.5_p113.ebuild:
1133 stable x86, security bug 194236
1134
1135 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1136 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1137 -ruby-1.8.6_p110.ebuild:
1138 Remove old versions
1139
1140*ruby-1.8.6_p110-r1 (30 Sep 2007)
1141*ruby-1.8.5_p113 (30 Sep 2007)
1142
1143 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1144 +files/ruby-1.8.5_p113-net-http-p114.patch,
1145 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1146 +ruby-1.8.6_p110-r1.ebuild:
1147 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1148 using 1.8.6-p110 as base ebuild.
1149
1150 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1151 More fixes from gentoo-dev and graaff
1152
1153 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1154 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1155
1156*ruby-1.8.6_p110 (24 Sep 2007)
1157
1158 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1159 Version bump
1160
1161*ruby-1.8.6_p36-r4 (26 Aug 2007)
1162
1163 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1164 +ruby-1.8.6_p36-r4.ebuild:
1165 Use user LDFLAGS, #181436
1166
1167 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1168 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1169 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1170 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1171
1172 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1173 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1174 -ruby-1.8.6_p36-r2.ebuild:
1175 Remove some older versions that will not be promoted to stable, keeping at
1176 least one version of each release.
1177
1178 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1179 ruby-1.8.6_p36-r3.ebuild:
1180 (QA) RESTRICT clean up.
1181
1182*ruby-1.8.6_p36-r3 (04 Jul 2007)
1183
1184 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1185 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1186 fixed memory leak loading .so bug #182946
1187
1188 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1189 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1190 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1191 ruby-1.8.6_p36-r2.ebuild:
1192 (QA) RESTRICT clean up.
1193
1194 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1195 Re-add stable keyword for alpha as per bug #181110
1196
1197 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1198 Back to ~amd64 wrt bug 181110
1199
1200 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1201 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1202
1203*ruby-1.8.6_p36-r2 (20 Jun 2007)
1204
1205 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1206 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1207
1208*ruby-1.8.6_p36-r1 (18 Jun 2007)
1209
1210 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1211 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1212 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1213 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1214 spbecker
1215
1216 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1217 Stable on amd64 wrt bug 181110
1218
1219*ruby-1.8.6_p36 (12 Jun 2007)
1220
1221 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1222 Version Bump. Bug #181379
1223
1224 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1225 Stable on mips, per #181110.
1226
1227 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1228 Stable on ppc wrt bug 181110
1229
1230 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1231 Stable for HPPA (bug #181110).
1232
1233 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1234 alpha/ia64/x86 stable wrt #181110
1235
1236 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1237 Stable on sparc wrt #181110
1238
1239 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1240 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1241
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1242 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1243 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1244 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1245 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.560

  ViewVC Help
Powered by ViewVC 1.1.20