/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.567
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.567 2013/02/24 18:50:48 ago Exp $
4
5 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
6 Stable for sparc, wrt bug #458776
7
8 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
9 Stable for hppa, wrt bug #458776
10
11 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
12 Stable for ia64, wrt bug #458776
13
14 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
15 Stable for x86, wrt bug #458776
16
17 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
18 Stable for amd64, wrt bug #458776
19
20 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
21 Stable for ppc64, wrt bug #458776
22
23 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
24 Stable for ppc, wrt bug #458776
25
26*ruby-1.9.3_p392 (22 Feb 2013)
27
28 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
29 Version bump for security bug 458776.
30
31*ruby-1.9.3_p385 (10 Feb 2013)
32
33 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
34 Version bump. Fixes security bug 442580.
35
36 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
37 keyword ~amd64-fbsd
38
39*ruby-1.8.7_p371 (06 Jan 2013)
40
41 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
42 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
43 Version bump for security bug 437366.
44
45 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
46 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
47 Cleanup.
48
49 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
50 Stable for ppc, wrt bug #427774
51
52 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
53 Stable for HPPA (bug #411507).
54
55 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
56 alpha/ia64/s390/sh/sparc stable wrt #434480
57
58 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
59 ruby-1.9.3_p286.ebuild:
60 Remove HPPA target hack (bug #342819).
61
62 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
63 alpha/ia64/s390/sh/sparc stable wrt #411507
64
65 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
66 Stable for HPPA (bug #434480).
67
68*ruby-1.9.3_p286 (15 Oct 2012)
69
70 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
71 Version bump. Fixes bugs #437264 and #437264.
72
73 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
74 stable arm, bug #434480
75
76 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
77 stable ppc ppc64, bug #434480
78
79 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
80 Stable for x86, wrt bug #434480
81
82 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
83 ruby-1.9.3_p194-r1.ebuild:
84 Update LICENSE, bug 434332.
85
86 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
87 Stable for amd64, wrt bug #434480
88
89 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
90 Stable for amd64, wrt bug #427774
91
92 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
93 arm stable, bug #427774
94
95 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
96 ruby-1.9.3_p194-r1.ebuild:
97 Stable ppc64, bug #411507
98
99 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
100 marked x86 per bug 427774
101
102 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
103 -ruby-1.9.3_p194.ebuild:
104 Cleanup.
105
106 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
107 ppc stable #411507
108
109 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
110 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
111 424611.
112
113*ruby-1.8.7_p370 (07 Jul 2012)
114
115 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
116 Version bump. Fix bug 378567 thanks to slyfox.
117
118 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
119 x86 stable, see bug 411507
120
121 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
122 arm stable, bug #411507
123
124 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
125 Stable for amd64, wrt bug #411507
126
127*ruby-1.9.3_p194-r1 (12 May 2012)
128
129 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
130 +ruby-1.9.3_p194-r1.ebuild:
131 Revision bump to fix mkmf for parallel build/install. Also enable verbose
132 build, so that the log makes sense if it fails.
133
134*ruby-1.9.3_p194 (30 Apr 2012)
135
136 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
137 Version bump.
138
139 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
140 keyword ~amd64-fbsd
141
142*ruby-1.8.7_p358 (20 Apr 2012)
143
144 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
145 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
146 Rails 3.2.
147
148 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
149 Add ~x86-fbsd, #332593
150
151*ruby-1.9.3_p125 (18 Feb 2012)
152
153 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
154 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
155
156 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
157 add ~arm, bug #332593
158
159 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
160 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
161
162 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
163 x86 stable wrt bug #396301
164
165 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
166 Stable for HPPA (bug #396301).
167
168 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
169 Stable for ppc/ppc64; bug #396301
170
171 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
172 Marked ~hppa (bug #332593).
173
174 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
175 Add back ~alpha keyword now that rubygems is keyworded.
176
177 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
178 Stable for AMD64, wrt security bug #396301
179
180*ruby-1.8.7_p357 (28 Dec 2011)
181
182 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
183 Version bump for security bug 396301.
184
185 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
186 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
187
188 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
189 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
190 keyworded, bug 332593.
191
192 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
193 Block older versions of packages that are no longer compatible. Remove
194 ancient blocks on packags long gone from the tree.
195
196 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
197 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
198 Remove old versions.
199
200*ruby-1.9.3_p0 (18 Dec 2011)
201
202 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
203 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
204 suite which need to be diagnosed first.
205
206 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
207 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
208 #332593).
209
210 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
211 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
212 #332593).
213
214 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
215 alpha/ia64/s390/sh/sparc stable wrt #386369
216
217*ruby-1.9.3_rc1 (22 Oct 2011)
218
219 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
220 Version bump.
221
222 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
223 arm stable, bug #386369
224
225 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
226 x86 stable, bug 386369
227
228 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
229 Stable for HPPA (bug #386369).
230
231 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
232 ppc/ppc64 stable wrt #386369
233
234 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
235 Stable on amd64 wrt bug #386369
236
237 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
238 Remove vulnerable version, bug 386369.
239
240*ruby-1.8.7_p352 (30 Aug 2011)
241
242 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
243 +ruby-1.8.7_p352.ebuild:
244 Patchlevel bump for ruby:1.8. Removing old version
245
246*ruby-1.9.2_p290 (30 Aug 2011)
247
248 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
249 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
250 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
251 old patchlevels.
252
253 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
254 ruby-1.8.7_p334-r2.ebuild:
255 ppc/ppc64 stable wrt #378691
256
257*ruby-1.8.7_p334-r2 (22 Jul 2011)
258
259 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
260 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
261 for chasing down upstream and us.
262
263 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
264 Added ~mips, bug 332593
265
266 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
267 ruby-1.8.7_p334-r1.ebuild:
268 ppc64 stable wrt #369141
269
270 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
271 ia64/s390/sh/sparc stable wrt #369141
272
273 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
274 Stable for HPPA (bug #369141).
275
276 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
277 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
278
279 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
280 arm/x86 stable, bug #369141
281
282 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
283 Stable on amd64 wrt bug #369141
284
285 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
286 ruby-1.8.7_p334-r1.ebuild:
287 Stable on alpha, bug #369141
288
289*ruby-1.8.7_p334-r1 (31 May 2011)
290
291 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
292 Revision bump for security bug 369141 (CVE-2011-0188)
293
294*ruby-1.9.2-r1 (16 May 2011)
295
296 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
297 Don't remove racc files since all other ruby targets ship these files
298 themselves as well. Closes bug 363419.
299
300 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
301 ruby-1.8.7_p334.ebuild:
302 Remove old version. Remove obsolete and unused old-style virtual/ruby.
303
304 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
305 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
306
307 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
308 Add append-flags -mieee on sh, bug #357559
309
310 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
311 alpha/arm/ia64/s390/sh stable wrt #355439
312
313 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
314 Marked ~ppc64 wrt #332593
315
316 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
317 ruby-1.8.7_p334.ebuild:
318 x86 stable wrt security bug #355439
319
320 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
321 ruby-1.8.7_p334.ebuild:
322 ppc/ppc64 stable wrt #355439
323
324 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
325 Stable on amd64 wrt bug #355439
326
327 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
328 Stable for HPPA (bug #355439).
329
330*ruby-1.8.7_p334 (19 Feb 2011)
331
332 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
333 Version bump 1.8.7 series, security bug 355439
334
335 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
336 ruby-1.9.2.ebuild:
337 Remove PROVIDE for old-style virtual/ruby per bug 265054.
338
339 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
340 Remove masked ruby 1.8.6 per bug 332597.
341
342 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
343 -ruby-1.9.2_rc2.ebuild:
344 Removing old and vulnerable ebuilds
345
346 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
347 Marking ruby-1.8.7_p302 ppc64 for bug 332957
348
349 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
350 alpha/ia64/s390/sh/sparc stable wrt #332957
351
352*ruby-1.9.2 (24 Aug 2010)
353
354 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
355 metadata.xml:
356 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
357 and x86-fbsd due to a new dependency on rdoc.
358
359 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
360 arm stable, bug #332957
361
362 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
363 ruby-1.8.7_p302.ebuild:
364 x86 stable wrt security bug #332957
365
366 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
367 Stable on amd64 wrt bug #332957
368
369 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
370 Stable for PPC (bug #332957).
371
372 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
373 Stable for HPPA (bug #332957).
374
375*ruby-1.8.7_p302 (21 Aug 2010)
376
377 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
378 +ruby-1.8.7_p302.ebuild:
379 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
380 installation path.
381
382*ruby-1.8.6_p399 (19 Aug 2010)
383
384 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
385 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
386 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
387 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
388 installation path (reported by the x86 team in bug 332597)
389
390*ruby-1.9.2_rc2-r1 (18 Aug 2010)
391
392 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
393 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
394 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
395 the rubygems loading code. Add USE flag for psych.
396
397 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
398 ruby-1.9.2_rc2.ebuild:
399 Remove two keepdir that will try to keep an empty path, closes bug
400 #333163.
401
402 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
403 Marked ~ppc (bug #332593).
404
405 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
406 ruby-1.9.2_rc2.ebuild:
407 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
408
409 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
410 ruby-1.8.7_p299.ebuild:
411 Bump eselect-ruby dependency
412
413 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
414 -ruby-1.9.1_p429.ebuild:
415 Remove ebuild that is not target for unmask anyway.
416
417 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
418 ruby-1.9.2_rc2.ebuild:
419 Try 2 to fix the berkdb 5 issue on 1.9.
420
421 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
422 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
423 ruby-1.9.2_rc2.ebuild:
424 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
425 support for adding new patchsets without bumping the revision for all the
426 old ebuilds as well.
427
428*ruby-1.9.2_rc2 (14 Jul 2010)
429
430 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
431 +ruby-1.9.2_rc2.ebuild:
432 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
433 might cause _further_ build failures as it changed slightly behaviour.
434 You're going to need to rebuild rubygems and then all the packages
435 previously installed after upgrading to this.
436
437 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
438 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
439 -ruby-1.9.1_p376.ebuild:
440 Cleanup old versions.
441
442*ruby-1.9.1_p429 (04 Jul 2010)
443
444 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
445 +ruby-1.9.1_p429.ebuild:
446 Version bump to new 1.9.1 release.
447
448*ruby-1.8.7_p299 (23 Jun 2010)
449
450 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
451 +ruby-1.8.7_p299.ebuild:
452 Version bump.
453
454 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
455 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
456 remove useless comments
457
458 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
459 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
460 ruby-1.9.1_p376.ebuild:
461 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
462 dev.gentoo.org now.
463
464 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
465 ruby-1.9.1_p376.ebuild:
466 Use the correct RUBYLIB.
467
468*ruby-1.8.7_p249-r2 (18 May 2010)
469*ruby-1.8.6_p388-r1 (18 May 2010)
470
471 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
472 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
473 ruby-1.9.1_p376.ebuild, metadata.xml:
474 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
475 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
476 add USE flags for ncurses, readline and libedit, and properly depend on
477 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
478 Emacs versions support ruby-mode themselves and it should be even more
479 updated.
480
481*ruby-1.8.7_p249-r1 (06 May 2010)
482
483 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
484 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
485 309789 by Sune Kloppenborg Jeppesen.
486
487 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
488 ruby-1.8.7_p249.ebuild:
489 Use $PVR instead of $PV in patchset names
490
491 06 May 2010; Alex Legler <a3li@gentoo.org>
492 -files/ruby-1.8.6-memory-leak.diff,
493 -files/ruby18-mkmf-parallel-install.patch,
494 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
495 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
496 Remove old version. Cleanup in files/
497
498*ruby-1.9.1_p376 (01 May 2010)
499
500 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
501 Version bump. Fixes security bugs 296052 and 300468. No longer installs
502 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
503 instead.
504
505 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
506 -ruby-1.8.7_p174-r1.ebuild:
507 Remove vulnerable ebuilds, 300468
508
509 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
510 ruby-1.8.7_p249.ebuild:
511 amd64 stable, security bug 300468
512
513 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
514 ruby-1.8.7_p249.ebuild:
515 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
516
517 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
518 Stable for HPPA (bug #300468).
519
520 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
521 Stable for HPPA (bug #300468).
522
523 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
524 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
525
526 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
527 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
528
529 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
530 ruby-1.8.6_p388.ebuild:
531 stable x86, security bug 300468
532
533 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
534 ruby-1.8.7_p249.ebuild:
535 stable x86, security bug 300468
536
537*ruby-1.8.6_p388 (10 Jan 2010)
538
539 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
540 +ruby-1.8.6_p388.ebuild:
541 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
542 version. The new ebuild also has the fix for bug 168939.
543
544*ruby-1.8.7_p249 (10 Jan 2010)
545
546 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
547 +ruby-1.8.7_p249.ebuild:
548 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
549 version
550
551 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
552 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
553
554*ruby-1.8.7_p248 (25 Dec 2009)
555
556 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
557 Version bump
558
559 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
560 Remove old version.
561
562 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
563 Remove old version.
564
565 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
566 ia64/s390/sh stable wrt #288699
567
568 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
569 stable sparc, bug 288699
570
571 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
572 arm stable, bug #288699
573
574 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
575 amd64/x86 stable, bug #288699
576
577 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
578 ruby-1.8.7_p174-r1.ebuild:
579 Stable on alpha, bug #288699
580
581 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
582 ppc stable #288699
583
584 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
585 Stable for HPPA (bug #288699).
586
587 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
588 Marked ~hppa too.
589
590*ruby-1.8.7_p174-r1 (06 Oct 2009)
591
592 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
593 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
594 eselect-ruby cleanup feature.
595
596*ruby-1.9.1_p243 (09 Sep 2009)
597
598 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
599 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
600 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
601 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
602 -files/ruby19-rubygems-proxy.patch,
603 -files/ruby-1.9.1_p129-parallelmake.patch,
604 -files/ruby19-mkmf-parallel-install.patch:
605 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
606 168939. Cleaning up old patches.
607
608*ruby-1.8.6_p383 (20 Aug 2009)
609
610 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
611 Patchlevel bump.
612
613 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
614 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
615 ruby-1.9.1_p129-r1.ebuild:
616 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
617
618 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
619 Removing vulnerable ebuild, bug 273213.
620
621 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
622 Marking ruby-1.8.6_p369 ppc for bug 273213
623
624 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
625 ruby-1.9.1_p129-r1.ebuild:
626 Prepend our library path instead of overwriting it during src_install.
627 Thanks to the reporter of bug #274824.
628
629*ruby-1.8.7_p174 (18 Jun 2009)
630
631 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
632 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
633 Replacing 187_p173 with _p174 because of a regression. Unifying the
634 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
635 patchsets.
636
637 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
638 Marking ruby-1.8.6_p369 ppc64 for bug 273213
639
640 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
641 arm/ia64/s390/sh/sparc stable wrt #273213
642
643 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
644 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
645 Removing old version, minor cleanup
646
647 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
648 -files/ruby-1.8.6-openssl.patch,
649 -files/ruby-1.8.6-shortname_constants.patch,
650 -files/ruby-1.8.6_p111-r13657.patch,
651 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
652 Removing vulnerable old Ruby version and stale patches, bug 274108.
653
654 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
655 ruby-1.8.6_p369.ebuild:
656 Stable on alpha, bug #273213
657
658 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
659 Stable for HPPA (bug #273213).
660
661 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
662 ruby-1.8.6_p369.ebuild:
663 stable x86, security bug 273213
664
665 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
666 amd64 stable, security bug 273213.
667
668*ruby-1.8.7_p173 (10 Jun 2009)
669*ruby-1.8.6_p369 (10 Jun 2009)
670
671 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
672 +ruby-1.8.7_p173.ebuild:
673 Version bumps for bug #273213.
674
675*ruby-1.9.1_p129-r1 (27 May 2009)
676
677 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
678 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
679 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
680 +files/ruby-1.9.1_p129-parallelmake.patch:
681 Revision bump, add patches 1) to make Ruby behave more similarly between
682 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
683 extensions (undefined symbols in them will cause abort at runtime 3) to
684 remove a concurrency issue when building the dl extension that could
685 result in a broken dl.so.
686
687 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
688 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
689 Don't block rdoc-2 or later (which may enter Portage one day as it's
690 needed by some Rakefiles).
691
692 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
693 ruby-1.9.1_p129.ebuild:
694 Add ~x86-fbsd keyword.
695
696 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
697 keyword ~sparc-fbsd, bug #252315
698
699*ruby-1.9.1_p129 (15 May 2009)
700
701 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
702 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
703 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
704 included in every release.
705
706 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
707 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
708 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
709 ruby-1.8.7_p160.ebuild:
710 Removing vulnerable versions (#268515), fixing license (#233747).
711
712 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
713 Stable for HPPA (bug #268515).
714
715 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
716 Adapting rubygems notice.
717
718 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
719 amd64 stable, bug #268515.
720
721 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
722 arm/ia64/s390/sh/sparc stable wrt #268515
723
724 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
725 ruby-1.8.6_p368.ebuild:
726 stable x86, security bug 268515
727
728 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
729 ruby-1.8.6_p368.ebuild:
730 Stable on alpha, bug #268515
731
732 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
733 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
734
735*ruby-1.8.7_p160 (07 May 2009)
736*ruby-1.8.6_p368 (07 May 2009)
737
738 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
739 +ruby-1.8.7_p160.ebuild:
740 Version bump as per secbug 268515. NB: These are the first ebuilds that
741 no longer use ruby-config.
742
743*ruby-1.9.1-r1 (03 Apr 2009)
744*ruby-1.8.7_p72-r11 (03 Apr 2009)
745*ruby-1.8.6_p287-r13 (03 Apr 2009)
746
747 03 Apr 2009; Alex Legler <a3li@gentoo.org>
748 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
749 +files/ruby18-mkmf-parallel-install.patch,
750 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
751 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
752 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
753 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
754 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
755 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
756 happy.
757
758*ruby-1.9.1 (21 Mar 2009)
759
760 21 Mar 2009; Alex Legler <a3li@gentoo.org>
761 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
762 +ruby-1.9.1.ebuild:
763 Adding Ruby 1.9.1 for preliminary testing
764
765 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
766 ruby-1.8.6_p287-r12.ebuild:
767 Marked ~ppc for bug #252315.
768
769 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
770 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
771 bug 261982.
772
773 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
774 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
775 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
776 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
777 Cleanup
778
779*ruby-1.8.7_p72-r10 (07 Mar 2009)
780
781 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
782 +ruby-1.8.7_p72-r10.ebuild:
783 Add a revision of ruby 1.8.7 using eselect ruby.
784
785 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
786 ~mips keyworded, bug #252315.
787
788 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
789 ruby-1.8.6_p287-r5.ebuild:
790 ppc stable, bug #260006
791
792 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
793 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
794
795 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
796 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
797 Fixing Tk USE flag test, bug 258893.
798
799 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
800 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
801
802 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
803 ruby-1.8.6_p287-r5.ebuild:
804 amd64 stable wrt security bug #260006
805
806 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
807 Stable for HPPA (bug #260006).
808
809 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
810 ruby-1.8.6_p287-r5.ebuild:
811 Stable on alpha, bug #260006
812
813*ruby-1.8.7_p72-r2 (23 Feb 2009)
814*ruby-1.8.6_p287-r12 (23 Feb 2009)
815*ruby-1.8.6_p287-r5 (23 Feb 2009)
816
817 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
818 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
819 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
820 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
821 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
822 now before compilation if Tk useflags don't match) and 230748 (adding
823 --enable-option-checking=no for newer versions of autoconf).
824
825 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
826 arm/ia64/s390/sh/sparc stable wrt #254307
827
828 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
829 ruby-1.8.6_p287-r4.ebuild:
830 Stable on alpha, bug #254307
831
832 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
833 ruby-1.8.6_p287-r11.ebuild:
834 keyword ~x86-fbsd, bug #252315
835
836 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
837 ppc stable #254307
838
839 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
840 amd64/x86 stable, bug #254307
841
842 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
843 stable ppc64, bug 254307
844
845 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
846 Stable for HPPA (bug #254307).
847
848 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
849 ruby-1.8.6_p287-r11.ebuild:
850 Marked ~hppa (bug #252315).
851
852*ruby-1.8.6_p287-r11 (11 Jan 2009)
853
854 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
855 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
856 +ruby-1.8.6_p287-r11.ebuild:
857 Backport conditional definition of missing openssl functions from ruby 1.8.7.
858 Fixes #254307.
859
860 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
861 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
862
863 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
864 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
865
866 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
867 ruby-1.8.6_p287-r10.ebuild:
868 Add ~sparc keyword, bug #252315
869
870*ruby-1.8.6_p287-r10 (23 Dec 2008)
871
872 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
873 +ruby-1.8.6_p287-r10.ebuild:
874 Version bump which switches from ruby-config to eselect-ruby. Dropped most
875 keywords since eselect-ruby does not yet have these keywords.
876
877 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
878 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
879 Revert the ruby-config changes. We can't remove them until we provide an
880 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
881 for breaking things as mentioned in bug #251833.
882
883 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
884 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
885 ruby-1.8.7_p72-r1.ebuild:
886 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
887 Thanks for the people noticing this in bug #251833.
888
889 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
890 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
891 ruby-1.8.7_p72-r1.ebuild:
892 Drop dependency on ruby-config, which will be removed from the tree. We
893 currently only have one major version of ruby in the tree (Ruby 1.8), so there
894 is no need for ruby-config at this moment. For newer versions of Ruby we will
895 use eselect-ruby, which can be found in the ruby overlay at the moment.
896
897 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
898 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
899 Use mirror://ruby in SRC_URI, fixes #237392.
900
901 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
902 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
903 -ruby-1.8.7_p72.ebuild:
904 Remove old versions. Leave one old stable version with cjk support.
905
906*ruby-1.8.6_p287-r3 (29 Nov 2008)
907
908 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
909 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
910 +ruby-1.8.6_p287-r3.ebuild:
911 Fix our expansion limit patch according to debian bug report
912 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
913 make sure people will pick up the fixed version. Thanks to Alex Legler for
914 mentioning the patch.
915
916*ruby-1.8.7_p72-r1 (26 Nov 2008)
917*ruby-1.8.6_p287-r2 (26 Nov 2008)
918
919 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
920 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
921 +ruby-1.8.7_p72-r1.ebuild:
922 Fix problem with shortname constants #247790, already fixed in upstream SVN.
923 Thanks to Alex Legler for providing the patch.
924
925 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
926 -ruby-1.8.6_p287.ebuild:
927 Remove versions that will not become stable
928
929 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
930 ruby-1.8.6_p287-r1.ebuild:
931 ppc stable, bug #225465
932
933 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
934 ruby-1.8.6_p287-r1.ebuild:
935 amd64 stable wrt security bug #225465
936
937 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
938 alpha/ia64/x86 stable wrt #225465
939
940 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
941 ruby-1.8.6_p287-r1.ebuild:
942 Sparc stable --- Security Bug #225465 --- good since late August.
943
944 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
945 Stable on ppc64; bug #225465
946
947 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
948 Stable for HPPA (bug #225465).
949
950*ruby-1.8.6_p287-r1 (29 Aug 2008)
951
952 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
953 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
954 +ruby-1.8.6_p287-r1.ebuild:
955 Fix REXML security issues, bug #236060.
956
957 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
958 Add GLEP 56 USE flag descriptions.
959
960*ruby-1.8.7_p72 (15 Aug 2008)
961
962 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
963 +ruby-1.8.7_p72.ebuild:
964 bump 1.8.7 to latest patch release
965
966*ruby-1.8.6_p287 (11 Aug 2008)
967
968 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
969 Version bump for brown paper bag relelease.
970
971 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
972 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
973 Remove broken version in favor of the just-added 1.8.6_p286
974
975*ruby-1.8.6_p286 (10 Aug 2008)
976
977 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
978 Version bump to latest released version of ruby 1.8.6. This version fixes the
979 security issues reported in #225465 and #234224. The cjk USE flag has been
980 dropped since no compatible patches have been released yet.
981
982 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
983 ruby-1.8.6_p230.ebuild:
984 drop cjk from SRC_URI as well
985
986 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
987 Drop cjk support since the most recent oniguruma patches no longer apply to
988 this version, #230111.
989
990 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
991 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
992 Try to fix the security issues reported in #225465 for ruby 1.8.6.
993 Unfortunately the official p230 has a change which causes segmentation faults
994 for applications like Rails and RSpec, so we are reverting that specific
995 change.
996
997*ruby-1.8.7_p22 (29 Jun 2008)
998
999 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1000 +ruby-1.8.7_p22.ebuild:
1001 bump 1.8.7 for security fix
1002
1003 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1004 nevermind, don't bump this yet
1005
1006*ruby-1.8.6_p230 (20 Jun 2008)
1007
1008 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1009 version bump
1010
1011*ruby-1.8.7 (10 Jun 2008)
1012
1013 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1014 +ruby-1.8.7.ebuild:
1015 bump 1.8.7 to final
1016
1017*ruby-1.8.7_pre2 (21 Apr 2008)
1018
1019 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1020 +ruby-1.8.7_pre2.ebuild:
1021 Version Bump
1022
1023*ruby-1.8.7_pre1 (16 Apr 2008)
1024
1025 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1026 Version bump. Drop cjk until a new version of oniguruma appears.
1027
1028 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1029 amd64 stable, bug 212264
1030
1031 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1032 Stable for HPPA (bug #212264).
1033
1034 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1035 ruby-1.8.6_p114.ebuild:
1036 ppc stable, bug #212264
1037
1038 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1039 alpha/ia64 stable wrt #212264
1040
1041 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1042 ruby-1.8.6_p114.ebuild:
1043 stable x86, security bug 212264
1044
1045 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1046 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1047 as expected.
1048
1049 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1050 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1051
1052*ruby-1.8.6_p114 (05 Mar 2008)
1053
1054 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1055 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1056 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1057 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1058 Version bump for #212264. Remove old ebuilds.
1059
1060 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1061 alpha/ia64 stable wrt #208916
1062
1063 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1064 Stable on ppc wrt bug 208916
1065
1066 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1067 x86 stable, bug #208916
1068
1069 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1070 ruby-1.8.6_p111-r1.ebuild:
1071 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1072
1073 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1074 -files/ruby-1.8.6-exit-status.patch,
1075 -files/ruby-1.8.6_p110-net-http-p111.patch,
1076 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1077 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1078 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1079 Remove old versions
1080
1081 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1082 Stable on ppc64
1083
1084 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1085 Stable on amd64; bug 199191
1086
1087 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1088 alpha/ia64/sparc stable wrt #199191
1089
1090 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1091 Remove now-obsolete warning about coreutils versions, #203156.
1092
1093 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1094 Stable for HPPA (bug #199191).
1095
1096*ruby-1.8.6_p111-r1 (23 Dec 2007)
1097
1098 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1099 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1100 ssl USE flags. Patch to p113.
1101
1102 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1103 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1104
1105 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1106 x86 stable, security bug #199191
1107
1108*ruby-1.8.6_p111 (23 Dec 2007)
1109
1110 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1111 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1112 Version bump with patch for bug #199191
1113
1114 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1115 Move dependency on (X)Emacs modes to PDEPEND.
1116
1117 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1118 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1119 bug 196413
1120
1121*ruby-1.8.6_p110-r2 (21 Oct 2007)
1122
1123 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1124 +ruby-1.8.6_p110-r2.ebuild:
1125 Add emacs and xemacs USE flags and use them to pull in the correct editing
1126 mode for each. Had to drop several arch keywords as reported on bug 196413.
1127
1128 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1129 amd64 stable, security bug 194236
1130
1131 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1132 ruby-1.8.6_p110-r1.ebuild:
1133 Stable on ppc64; bug #194236
1134
1135 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1136 amd64 stable, security bug 194236
1137
1138 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1139 Stable for HPPA (bug #194236).
1140
1141 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1142 alpha/ia64/sparc stable wrt security #194236
1143
1144 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1145 ruby-1.8.6_p110-r1.ebuild:
1146 ppc stable, bug #194236
1147
1148 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1149 ruby-1.8.6_p110-r1.ebuild:
1150 stable x86, security bug 194236
1151
1152 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1153 ruby-1.8.5_p113.ebuild:
1154 stable x86, security bug 194236
1155
1156 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1157 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1158 -ruby-1.8.6_p110.ebuild:
1159 Remove old versions
1160
1161*ruby-1.8.6_p110-r1 (30 Sep 2007)
1162*ruby-1.8.5_p113 (30 Sep 2007)
1163
1164 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1165 +files/ruby-1.8.5_p113-net-http-p114.patch,
1166 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1167 +ruby-1.8.6_p110-r1.ebuild:
1168 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1169 using 1.8.6-p110 as base ebuild.
1170
1171 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1172 More fixes from gentoo-dev and graaff
1173
1174 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1175 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1176
1177*ruby-1.8.6_p110 (24 Sep 2007)
1178
1179 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1180 Version bump
1181
1182*ruby-1.8.6_p36-r4 (26 Aug 2007)
1183
1184 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1185 +ruby-1.8.6_p36-r4.ebuild:
1186 Use user LDFLAGS, #181436
1187
1188 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1189 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1190 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1191 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1192
1193 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1194 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1195 -ruby-1.8.6_p36-r2.ebuild:
1196 Remove some older versions that will not be promoted to stable, keeping at
1197 least one version of each release.
1198
1199 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1200 ruby-1.8.6_p36-r3.ebuild:
1201 (QA) RESTRICT clean up.
1202
1203*ruby-1.8.6_p36-r3 (04 Jul 2007)
1204
1205 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1206 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1207 fixed memory leak loading .so bug #182946
1208
1209 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1210 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1211 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1212 ruby-1.8.6_p36-r2.ebuild:
1213 (QA) RESTRICT clean up.
1214
1215 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1216 Re-add stable keyword for alpha as per bug #181110
1217
1218 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1219 Back to ~amd64 wrt bug 181110
1220
1221 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1222 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1223
1224*ruby-1.8.6_p36-r2 (20 Jun 2007)
1225
1226 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1227 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1228
1229*ruby-1.8.6_p36-r1 (18 Jun 2007)
1230
1231 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1232 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1233 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1234 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1235 spbecker
1236
1237 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1238 Stable on amd64 wrt bug 181110
1239
1240*ruby-1.8.6_p36 (12 Jun 2007)
1241
1242 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1243 Version Bump. Bug #181379
1244
1245 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1246 Stable on mips, per #181110.
1247
1248 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1249 Stable on ppc wrt bug 181110
1250
1251 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1252 Stable for HPPA (bug #181110).
1253
1254 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1255 alpha/ia64/x86 stable wrt #181110
1256
1257 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1258 Stable on sparc wrt #181110
1259
1260 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1261 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1262
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1263 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1264 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1265 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1266 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.567

  ViewVC Help
Powered by ViewVC 1.1.20