/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.664
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.664 2014/09/20 06:47:39 graaff Exp $
4
5*ruby-2.0.0_p576 (20 Sep 2014)
6
7 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
8 Version bump.
9
10 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
11 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
12 Depend on the rubygems virtual with an explicit SLOT now that the specific
13 rubygems versions are listed in virtual/rubygems. This will make the
14 dependencies more explicit and should decrease resolver surprises picking the
15 wrong virtual/rubygems SLOT later on.
16
17 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
18 Cleanup.
19
20 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
21 ruby-2.0.0_p481.ebuild:
22 x86 stable wrt bug #512904
23
24 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
25 Stable on alpha, bug #512904
26
27 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
28 arm stable, bug #512904
29
30 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
31 arm stable, bug #512904
32
33 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
34 ruby-2.0.0_p481.ebuild:
35 ia64 stable wrt bug #512904
36
37 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
38 Stable for HPPA (bug #512904).
39
40 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
41 Stable for HPPA (bug #512904).
42
43 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
44 -ruby-2.1.1-r1.ebuild:
45 Cleanup.
46
47 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
48 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
49 512848.
50
51*ruby-1.9.3_p547 (17 May 2014)
52
53 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
54 Version bump.
55
56*ruby-2.1.2 (10 May 2014)
57*ruby-2.0.0_p481 (10 May 2014)
58
59 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
60 +ruby-2.1.2.ebuild:
61 Version bump.
62
63 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
64 -ruby-2.0.0_p353-r2.ebuild:
65 Cleanup.
66
67 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
68 ruby-2.1.1-r1.ebuild:
69 Remove useless libruby symlinks, bug 503584.
70
71 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
72 -ruby-2.1.1.ebuild:
73 Cleanup.
74
75 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
76 Remove unneeded useflag descriptions from metadata.xml
77
78 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
79 -ruby-1.8.7_p374.ebuild:
80 Remove Ruby 1.8. See bug #434064.
81
82*ruby-2.1.1-r1 (14 Apr 2014)
83
84 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
85 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
86 Thanks to Andrew Savchenko for providing a patch.
87
88 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
89 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
90 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
91 ruby-2.1.1.ebuild:
92 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
93
94*ruby-2.1.1 (06 Mar 2014)
95
96 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
97 Version bump. Update module selection code to fix automagic dependencies.
98 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
99 503106.
100
101*ruby-2.0.0_p451 (05 Mar 2014)
102
103 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
104 Version bump. Update module selection code to fix automagic dependencies.
105 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
106 503106.
107
108*ruby-1.9.3_p545 (26 Feb 2014)
109
110 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
111 Version bump. Drop tk USE flag due to bug 500894.
112
113*ruby-2.0.0_p353-r2 (23 Feb 2014)
114
115 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
116 Backport support for uclibc, fixing bug 484534.
117
118 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
119 Stable for alpha, wrt bug #483254
120
121 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
122 Stable for sparc, wrt bug #483254
123
124 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
125 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
126 Fix slot conflicts, #498970
127
128 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
129 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
130 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
131 bug 497130.
132
133 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
134 -ruby-1.9.3_p448-r1.ebuild:
135 Remove vulnerable versions.
136
137 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
138 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
139 Remove vulnerable versions.
140
141 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
142 arm stable, bug #492282
143
144*ruby-2.0.0_p353-r1 (03 Jan 2014)
145
146 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
147 ruby-2.1.0.ebuild:
148 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
149
150 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
151 arm stable, bug #483254
152
153 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
154 ruby-2.0.0_p353.ebuild:
155 ia64 stable wrt bug #492282
156
157*ruby-2.1.0 (26 Dec 2013)
158
159 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
160 Version bump.
161
162 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
163 ia64 stable wrt bug #483254
164
165 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
166 Stable for sparc, wrt bug #492282
167
168 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
169 Stable for arm, wrt bug #492282
170
171 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
172 Stable for alpha, wrt bug #492282
173
174 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
175 ruby-2.0.0_p353.ebuild:
176 Stable for x86, wrt bug #492282
177
178 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
179 ruby-2.0.0_p353.ebuild:
180 Stable for ppc64, wrt bug #492282
181
182 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
183 ruby-2.0.0_p353.ebuild:
184 Stable for ppc, wrt bug #492282
185
186 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
187 Stable for ppc64, wrt bug #483254
188
189 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
190 Stable for ppc, wrt bug #483254
191
192 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
193 ruby-2.0.0_p353.ebuild:
194 Stable for amd64, wrt bug #492282
195
196 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
197 Stable for HPPA (bug #492282).
198
199 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
200 Stable for HPPA (bug #492282).
201
202*ruby-2.0.0_p353 (22 Nov 2013)
203*ruby-1.9.3_p484 (22 Nov 2013)
204
205 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
206 +ruby-2.0.0_p353.ebuild:
207 Version bumps for security bug 492282.
208
209*ruby-2.0.0_p247-r2 (14 Oct 2013)
210
211 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
212 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
213 2.x. Fixes bug 483466.
214
215 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
216 -ruby-1.9.3_p429.ebuild:
217 Cleanup.
218
219 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
220 Stable for HPPA (bug #483254).
221
222 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
223 Stable for x86, wrt bug #483254
224
225 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
226 Stable for amd64, wrt bug #483254
227
228 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
229 ruby-1.9.3_p448.ebuild:
230 Stable for s390, wrt bug #475074
231
232*ruby-2.0.0_p247-r1 (29 Jul 2013)
233*ruby-1.9.3_p448-r1 (29 Jul 2013)
234*ruby-1.8.7_p374-r1 (29 Jul 2013)
235
236 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
237 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
238 Revision bump to counter breakage introduced in portage 2.1.13 for bug
239 465000. Thanks to thansen for reporting.
240
241 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
242 ruby-1.9.3_p448.ebuild:
243 Stable for sparc, wrt bug #475074
244
245 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
246 ruby-1.9.3_p448.ebuild:
247 Stable for sh, wrt bug #475074
248
249 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
250 ruby-1.9.3_p448.ebuild:
251 Stable for ia64, wrt bug #475074
252
253*ruby-2.0.0_p247 (07 Jul 2013)
254
255 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
256 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
257 ruby20.
258
259 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
260 ruby-1.9.3_p448.ebuild:
261 Stable for alpha, wrt bug #475074
262
263 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
264 ruby-1.9.3_p448.ebuild:
265 Stable for ppc64, wrt bug #475074
266
267 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
268 ruby-1.9.3_p448.ebuild:
269 Stable for HPPA (bug #475074).
270
271 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
272 ruby-1.9.3_p448.ebuild:
273 Stable for ppc, wrt bug #475074
274
275 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
276 ruby-1.9.3_p448.ebuild:
277 Stable for arm, wrt bug #475074
278
279 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
280 ruby-1.9.3_p448.ebuild:
281 Stable for x86, wrt bug #475074
282
283 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
284 ruby-1.9.3_p448.ebuild:
285 Stable for amd64, wrt bug #475074
286
287*ruby-1.9.3_p448 (30 Jun 2013)
288*ruby-1.8.7_p374 (30 Jun 2013)
289
290 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
291 +ruby-1.9.3_p448.ebuild:
292 Version bumps for security bug 475074.
293
294 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
295 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
296 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
297 Cleanup. Remove vulnerable versions.
298
299 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
300 Stable for sh, wrt bug #469984
301
302 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
303 Stable for s390, wrt bug #469984
304
305 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
306 Stable for ppc64, wrt bug #469984
307
308 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
309 Stable for ia64, wrt bug #469984
310
311 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
312 Stable for alpha, wrt bug #469984
313
314 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
315 Stable for sparc, wrt bug #469984
316
317 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
318 Remove non-functional dosym calls, bug 442462.
319
320 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
321 Stable for arm, wrt bug #469984
322
323 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
324 Stable for ppc, wrt bug #469984
325
326 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
327 Stable for x86, wrt bug #469984
328
329 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
330 Stable for amd64, wrt bug #469984
331
332 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
333 Stable for HPPA (bug #469984).
334
335*ruby-1.9.3_p429 (16 May 2013)
336
337 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
338 Version bump for security bug #469984.
339
340 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
341 Stable for s390, wrt bug #437366
342
343 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
344 Stable for sparc, wrt bug #437366
345
346 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
347 Stable for ia64, wrt bug #437366
348
349 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
350 Stable for alpha, wrt bug #437366
351
352 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
353 Stable for ppc64, wrt bug #437366
354
355 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
356 Stable for arm, wrt bug #437366
357
358 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
359 Stable for sh, wrt bug #437366
360
361 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
362 Marking ruby-1.8.7_p371 ppc for bug 437366
363
364 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
365 Stable for HPPA (bug #437366).
366
367 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
368 Stable for x86, wrt bug #437366
369
370 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
371 Stable for amd64, wrt bug #437366
372
373 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
374 Stable for sh, wrt bug #458776
375
376 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
377 Stable for alpha, wrt bug #458776
378
379 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
380 Add patch to fix bug #459074 (parallel build).
381
382 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
383 Stable for arm, wrt bug #458776
384
385 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
386 Stable for s390, wrt bug #458776
387
388 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
389 Stable for sparc, wrt bug #458776
390
391 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
392 Stable for hppa, wrt bug #458776
393
394 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
395 Stable for ia64, wrt bug #458776
396
397 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
398 Stable for x86, wrt bug #458776
399
400 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
401 Stable for amd64, wrt bug #458776
402
403 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
404 Stable for ppc64, wrt bug #458776
405
406 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
407 Stable for ppc, wrt bug #458776
408
409*ruby-1.9.3_p392 (22 Feb 2013)
410
411 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
412 Version bump for security bug 458776.
413
414*ruby-1.9.3_p385 (10 Feb 2013)
415
416 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
417 Version bump. Fixes security bug 442580.
418
419 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
420 keyword ~amd64-fbsd
421
422*ruby-1.8.7_p371 (06 Jan 2013)
423
424 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
425 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
426 Version bump for security bug 437366.
427
428 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
429 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
430 Cleanup.
431
432 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
433 Stable for ppc, wrt bug #427774
434
435 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
436 Stable for HPPA (bug #411507).
437
438 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
439 alpha/ia64/s390/sh/sparc stable wrt #434480
440
441 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
442 ruby-1.9.3_p286.ebuild:
443 Remove HPPA target hack (bug #342819).
444
445 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
446 alpha/ia64/s390/sh/sparc stable wrt #411507
447
448 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
449 Stable for HPPA (bug #434480).
450
451*ruby-1.9.3_p286 (15 Oct 2012)
452
453 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
454 Version bump. Fixes bugs #437264 and #437264.
455
456 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
457 stable arm, bug #434480
458
459 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
460 stable ppc ppc64, bug #434480
461
462 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
463 Stable for x86, wrt bug #434480
464
465 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
466 ruby-1.9.3_p194-r1.ebuild:
467 Update LICENSE, bug 434332.
468
469 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
470 Stable for amd64, wrt bug #434480
471
472 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
473 Stable for amd64, wrt bug #427774
474
475 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
476 arm stable, bug #427774
477
478 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
479 ruby-1.9.3_p194-r1.ebuild:
480 Stable ppc64, bug #411507
481
482 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
483 marked x86 per bug 427774
484
485 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
486 -ruby-1.9.3_p194.ebuild:
487 Cleanup.
488
489 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
490 ppc stable #411507
491
492 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
493 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
494 424611.
495
496*ruby-1.8.7_p370 (07 Jul 2012)
497
498 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
499 Version bump. Fix bug 378567 thanks to slyfox.
500
501 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
502 x86 stable, see bug 411507
503
504 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
505 arm stable, bug #411507
506
507 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
508 Stable for amd64, wrt bug #411507
509
510*ruby-1.9.3_p194-r1 (12 May 2012)
511
512 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
513 +ruby-1.9.3_p194-r1.ebuild:
514 Revision bump to fix mkmf for parallel build/install. Also enable verbose
515 build, so that the log makes sense if it fails.
516
517*ruby-1.9.3_p194 (30 Apr 2012)
518
519 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
520 Version bump.
521
522 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
523 keyword ~amd64-fbsd
524
525*ruby-1.8.7_p358 (20 Apr 2012)
526
527 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
528 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
529 Rails 3.2.
530
531 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
532 Add ~x86-fbsd, #332593
533
534*ruby-1.9.3_p125 (18 Feb 2012)
535
536 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
537 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
538
539 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
540 add ~arm, bug #332593
541
542 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
543 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
544
545 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
546 x86 stable wrt bug #396301
547
548 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
549 Stable for HPPA (bug #396301).
550
551 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
552 Stable for ppc/ppc64; bug #396301
553
554 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
555 Marked ~hppa (bug #332593).
556
557 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
558 Add back ~alpha keyword now that rubygems is keyworded.
559
560 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
561 Stable for AMD64, wrt security bug #396301
562
563*ruby-1.8.7_p357 (28 Dec 2011)
564
565 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
566 Version bump for security bug 396301.
567
568 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
569 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
570
571 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
572 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
573 keyworded, bug 332593.
574
575 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
576 Block older versions of packages that are no longer compatible. Remove
577 ancient blocks on packags long gone from the tree.
578
579 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
580 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
581 Remove old versions.
582
583*ruby-1.9.3_p0 (18 Dec 2011)
584
585 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
586 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
587 suite which need to be diagnosed first.
588
589 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
590 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
591 #332593).
592
593 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
594 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
595 #332593).
596
597 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
598 alpha/ia64/s390/sh/sparc stable wrt #386369
599
600*ruby-1.9.3_rc1 (22 Oct 2011)
601
602 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
603 Version bump.
604
605 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
606 arm stable, bug #386369
607
608 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
609 x86 stable, bug 386369
610
611 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
612 Stable for HPPA (bug #386369).
613
614 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
615 ppc/ppc64 stable wrt #386369
616
617 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
618 Stable on amd64 wrt bug #386369
619
620 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
621 Remove vulnerable version, bug 386369.
622
623*ruby-1.8.7_p352 (30 Aug 2011)
624
625 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
626 +ruby-1.8.7_p352.ebuild:
627 Patchlevel bump for ruby:1.8. Removing old version
628
629*ruby-1.9.2_p290 (30 Aug 2011)
630
631 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
632 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
633 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
634 old patchlevels.
635
636 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
637 ruby-1.8.7_p334-r2.ebuild:
638 ppc/ppc64 stable wrt #378691
639
640*ruby-1.8.7_p334-r2 (22 Jul 2011)
641
642 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
643 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
644 for chasing down upstream and us.
645
646 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
647 Added ~mips, bug 332593
648
649 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
650 ruby-1.8.7_p334-r1.ebuild:
651 ppc64 stable wrt #369141
652
653 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
654 ia64/s390/sh/sparc stable wrt #369141
655
656 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
657 Stable for HPPA (bug #369141).
658
659 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
660 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
661
662 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
663 arm/x86 stable, bug #369141
664
665 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
666 Stable on amd64 wrt bug #369141
667
668 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
669 ruby-1.8.7_p334-r1.ebuild:
670 Stable on alpha, bug #369141
671
672*ruby-1.8.7_p334-r1 (31 May 2011)
673
674 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
675 Revision bump for security bug 369141 (CVE-2011-0188)
676
677*ruby-1.9.2-r1 (16 May 2011)
678
679 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
680 Don't remove racc files since all other ruby targets ship these files
681 themselves as well. Closes bug 363419.
682
683 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
684 ruby-1.8.7_p334.ebuild:
685 Remove old version. Remove obsolete and unused old-style virtual/ruby.
686
687 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
688 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
689
690 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
691 Add append-flags -mieee on sh, bug #357559
692
693 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
694 alpha/arm/ia64/s390/sh stable wrt #355439
695
696 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
697 Marked ~ppc64 wrt #332593
698
699 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
700 ruby-1.8.7_p334.ebuild:
701 x86 stable wrt security bug #355439
702
703 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
704 ruby-1.8.7_p334.ebuild:
705 ppc/ppc64 stable wrt #355439
706
707 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
708 Stable on amd64 wrt bug #355439
709
710 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
711 Stable for HPPA (bug #355439).
712
713*ruby-1.8.7_p334 (19 Feb 2011)
714
715 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
716 Version bump 1.8.7 series, security bug 355439
717
718 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
719 ruby-1.9.2.ebuild:
720 Remove PROVIDE for old-style virtual/ruby per bug 265054.
721
722 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
723 Remove masked ruby 1.8.6 per bug 332597.
724
725 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
726 -ruby-1.9.2_rc2.ebuild:
727 Removing old and vulnerable ebuilds
728
729 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
730 Marking ruby-1.8.7_p302 ppc64 for bug 332957
731
732 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
733 alpha/ia64/s390/sh/sparc stable wrt #332957
734
735*ruby-1.9.2 (24 Aug 2010)
736
737 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
738 metadata.xml:
739 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
740 and x86-fbsd due to a new dependency on rdoc.
741
742 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
743 arm stable, bug #332957
744
745 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
746 ruby-1.8.7_p302.ebuild:
747 x86 stable wrt security bug #332957
748
749 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
750 Stable on amd64 wrt bug #332957
751
752 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
753 Stable for PPC (bug #332957).
754
755 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
756 Stable for HPPA (bug #332957).
757
758*ruby-1.8.7_p302 (21 Aug 2010)
759
760 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
761 +ruby-1.8.7_p302.ebuild:
762 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
763 installation path.
764
765*ruby-1.8.6_p399 (19 Aug 2010)
766
767 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
768 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
769 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
770 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
771 installation path (reported by the x86 team in bug 332597)
772
773*ruby-1.9.2_rc2-r1 (18 Aug 2010)
774
775 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
776 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
777 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
778 the rubygems loading code. Add USE flag for psych.
779
780 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
781 ruby-1.9.2_rc2.ebuild:
782 Remove two keepdir that will try to keep an empty path, closes bug
783 #333163.
784
785 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
786 Marked ~ppc (bug #332593).
787
788 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
789 ruby-1.9.2_rc2.ebuild:
790 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
791
792 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
793 ruby-1.8.7_p299.ebuild:
794 Bump eselect-ruby dependency
795
796 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
797 -ruby-1.9.1_p429.ebuild:
798 Remove ebuild that is not target for unmask anyway.
799
800 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
801 ruby-1.9.2_rc2.ebuild:
802 Try 2 to fix the berkdb 5 issue on 1.9.
803
804 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
805 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
806 ruby-1.9.2_rc2.ebuild:
807 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
808 support for adding new patchsets without bumping the revision for all the
809 old ebuilds as well.
810
811*ruby-1.9.2_rc2 (14 Jul 2010)
812
813 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
814 +ruby-1.9.2_rc2.ebuild:
815 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
816 might cause _further_ build failures as it changed slightly behaviour.
817 You're going to need to rebuild rubygems and then all the packages
818 previously installed after upgrading to this.
819
820 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
821 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
822 -ruby-1.9.1_p376.ebuild:
823 Cleanup old versions.
824
825*ruby-1.9.1_p429 (04 Jul 2010)
826
827 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
828 +ruby-1.9.1_p429.ebuild:
829 Version bump to new 1.9.1 release.
830
831*ruby-1.8.7_p299 (23 Jun 2010)
832
833 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
834 +ruby-1.8.7_p299.ebuild:
835 Version bump.
836
837 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
838 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
839 remove useless comments
840
841 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
842 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
843 ruby-1.9.1_p376.ebuild:
844 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
845 dev.gentoo.org now.
846
847 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
848 ruby-1.9.1_p376.ebuild:
849 Use the correct RUBYLIB.
850
851*ruby-1.8.7_p249-r2 (18 May 2010)
852*ruby-1.8.6_p388-r1 (18 May 2010)
853
854 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
855 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
856 ruby-1.9.1_p376.ebuild, metadata.xml:
857 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
858 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
859 add USE flags for ncurses, readline and libedit, and properly depend on
860 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
861 Emacs versions support ruby-mode themselves and it should be even more
862 updated.
863
864*ruby-1.8.7_p249-r1 (06 May 2010)
865
866 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
867 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
868 309789 by Sune Kloppenborg Jeppesen.
869
870 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
871 ruby-1.8.7_p249.ebuild:
872 Use $PVR instead of $PV in patchset names
873
874 06 May 2010; Alex Legler <a3li@gentoo.org>
875 -files/ruby-1.8.6-memory-leak.diff,
876 -files/ruby18-mkmf-parallel-install.patch,
877 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
878 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
879 Remove old version. Cleanup in files/
880
881*ruby-1.9.1_p376 (01 May 2010)
882
883 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
884 Version bump. Fixes security bugs 296052 and 300468. No longer installs
885 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
886 instead.
887
888 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
889 -ruby-1.8.7_p174-r1.ebuild:
890 Remove vulnerable ebuilds, 300468
891
892 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
893 ruby-1.8.7_p249.ebuild:
894 amd64 stable, security bug 300468
895
896 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
897 ruby-1.8.7_p249.ebuild:
898 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
899
900 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
901 Stable for HPPA (bug #300468).
902
903 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
904 Stable for HPPA (bug #300468).
905
906 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
907 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
908
909 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
910 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
911
912 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
913 ruby-1.8.6_p388.ebuild:
914 stable x86, security bug 300468
915
916 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
917 ruby-1.8.7_p249.ebuild:
918 stable x86, security bug 300468
919
920*ruby-1.8.6_p388 (10 Jan 2010)
921
922 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
923 +ruby-1.8.6_p388.ebuild:
924 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
925 version. The new ebuild also has the fix for bug 168939.
926
927*ruby-1.8.7_p249 (10 Jan 2010)
928
929 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
930 +ruby-1.8.7_p249.ebuild:
931 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
932 version
933
934 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
935 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
936
937*ruby-1.8.7_p248 (25 Dec 2009)
938
939 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
940 Version bump
941
942 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
943 Remove old version.
944
945 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
946 Remove old version.
947
948 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
949 ia64/s390/sh stable wrt #288699
950
951 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
952 stable sparc, bug 288699
953
954 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
955 arm stable, bug #288699
956
957 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
958 amd64/x86 stable, bug #288699
959
960 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
961 ruby-1.8.7_p174-r1.ebuild:
962 Stable on alpha, bug #288699
963
964 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
965 ppc stable #288699
966
967 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
968 Stable for HPPA (bug #288699).
969
970 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
971 Marked ~hppa too.
972
973*ruby-1.8.7_p174-r1 (06 Oct 2009)
974
975 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
976 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
977 eselect-ruby cleanup feature.
978
979*ruby-1.9.1_p243 (09 Sep 2009)
980
981 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
982 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
983 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
984 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
985 -files/ruby19-rubygems-proxy.patch,
986 -files/ruby-1.9.1_p129-parallelmake.patch,
987 -files/ruby19-mkmf-parallel-install.patch:
988 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
989 168939. Cleaning up old patches.
990
991*ruby-1.8.6_p383 (20 Aug 2009)
992
993 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
994 Patchlevel bump.
995
996 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
997 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
998 ruby-1.9.1_p129-r1.ebuild:
999 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1000
1001 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1002 Removing vulnerable ebuild, bug 273213.
1003
1004 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1005 Marking ruby-1.8.6_p369 ppc for bug 273213
1006
1007 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1008 ruby-1.9.1_p129-r1.ebuild:
1009 Prepend our library path instead of overwriting it during src_install.
1010 Thanks to the reporter of bug #274824.
1011
1012*ruby-1.8.7_p174 (18 Jun 2009)
1013
1014 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1015 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1016 Replacing 187_p173 with _p174 because of a regression. Unifying the
1017 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1018 patchsets.
1019
1020 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1021 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1022
1023 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1024 arm/ia64/s390/sh/sparc stable wrt #273213
1025
1026 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1027 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1028 Removing old version, minor cleanup
1029
1030 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1031 -files/ruby-1.8.6-openssl.patch,
1032 -files/ruby-1.8.6-shortname_constants.patch,
1033 -files/ruby-1.8.6_p111-r13657.patch,
1034 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1035 Removing vulnerable old Ruby version and stale patches, bug 274108.
1036
1037 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1038 ruby-1.8.6_p369.ebuild:
1039 Stable on alpha, bug #273213
1040
1041 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1042 Stable for HPPA (bug #273213).
1043
1044 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1045 ruby-1.8.6_p369.ebuild:
1046 stable x86, security bug 273213
1047
1048 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1049 amd64 stable, security bug 273213.
1050
1051*ruby-1.8.7_p173 (10 Jun 2009)
1052*ruby-1.8.6_p369 (10 Jun 2009)
1053
1054 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1055 +ruby-1.8.7_p173.ebuild:
1056 Version bumps for bug #273213.
1057
1058*ruby-1.9.1_p129-r1 (27 May 2009)
1059
1060 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1061 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1062 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1063 +files/ruby-1.9.1_p129-parallelmake.patch:
1064 Revision bump, add patches 1) to make Ruby behave more similarly between
1065 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1066 extensions (undefined symbols in them will cause abort at runtime 3) to
1067 remove a concurrency issue when building the dl extension that could
1068 result in a broken dl.so.
1069
1070 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1071 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1072 Don't block rdoc-2 or later (which may enter Portage one day as it's
1073 needed by some Rakefiles).
1074
1075 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1076 ruby-1.9.1_p129.ebuild:
1077 Add ~x86-fbsd keyword.
1078
1079 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1080 keyword ~sparc-fbsd, bug #252315
1081
1082*ruby-1.9.1_p129 (15 May 2009)
1083
1084 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1085 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1086 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1087 included in every release.
1088
1089 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1090 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1091 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1092 ruby-1.8.7_p160.ebuild:
1093 Removing vulnerable versions (#268515), fixing license (#233747).
1094
1095 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1096 Stable for HPPA (bug #268515).
1097
1098 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1099 Adapting rubygems notice.
1100
1101 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1102 amd64 stable, bug #268515.
1103
1104 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1105 arm/ia64/s390/sh/sparc stable wrt #268515
1106
1107 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1108 ruby-1.8.6_p368.ebuild:
1109 stable x86, security bug 268515
1110
1111 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1112 ruby-1.8.6_p368.ebuild:
1113 Stable on alpha, bug #268515
1114
1115 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1116 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1117
1118*ruby-1.8.7_p160 (07 May 2009)
1119*ruby-1.8.6_p368 (07 May 2009)
1120
1121 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1122 +ruby-1.8.7_p160.ebuild:
1123 Version bump as per secbug 268515. NB: These are the first ebuilds that
1124 no longer use ruby-config.
1125
1126*ruby-1.9.1-r1 (03 Apr 2009)
1127*ruby-1.8.7_p72-r11 (03 Apr 2009)
1128*ruby-1.8.6_p287-r13 (03 Apr 2009)
1129
1130 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1131 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1132 +files/ruby18-mkmf-parallel-install.patch,
1133 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1134 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1135 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1136 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1137 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1138 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1139 happy.
1140
1141*ruby-1.9.1 (21 Mar 2009)
1142
1143 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1144 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1145 +ruby-1.9.1.ebuild:
1146 Adding Ruby 1.9.1 for preliminary testing
1147
1148 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1149 ruby-1.8.6_p287-r12.ebuild:
1150 Marked ~ppc for bug #252315.
1151
1152 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1153 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1154 bug 261982.
1155
1156 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1157 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1158 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1159 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1160 Cleanup
1161
1162*ruby-1.8.7_p72-r10 (07 Mar 2009)
1163
1164 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1165 +ruby-1.8.7_p72-r10.ebuild:
1166 Add a revision of ruby 1.8.7 using eselect ruby.
1167
1168 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1169 ~mips keyworded, bug #252315.
1170
1171 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1172 ruby-1.8.6_p287-r5.ebuild:
1173 ppc stable, bug #260006
1174
1175 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1176 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1177
1178 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1179 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1180 Fixing Tk USE flag test, bug 258893.
1181
1182 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1183 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1184
1185 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1186 ruby-1.8.6_p287-r5.ebuild:
1187 amd64 stable wrt security bug #260006
1188
1189 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1190 Stable for HPPA (bug #260006).
1191
1192 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1193 ruby-1.8.6_p287-r5.ebuild:
1194 Stable on alpha, bug #260006
1195
1196*ruby-1.8.7_p72-r2 (23 Feb 2009)
1197*ruby-1.8.6_p287-r12 (23 Feb 2009)
1198*ruby-1.8.6_p287-r5 (23 Feb 2009)
1199
1200 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1201 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1202 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1203 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1204 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1205 now before compilation if Tk useflags don't match) and 230748 (adding
1206 --enable-option-checking=no for newer versions of autoconf).
1207
1208 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1209 arm/ia64/s390/sh/sparc stable wrt #254307
1210
1211 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1212 ruby-1.8.6_p287-r4.ebuild:
1213 Stable on alpha, bug #254307
1214
1215 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1216 ruby-1.8.6_p287-r11.ebuild:
1217 keyword ~x86-fbsd, bug #252315
1218
1219 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1220 ppc stable #254307
1221
1222 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1223 amd64/x86 stable, bug #254307
1224
1225 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1226 stable ppc64, bug 254307
1227
1228 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1229 Stable for HPPA (bug #254307).
1230
1231 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1232 ruby-1.8.6_p287-r11.ebuild:
1233 Marked ~hppa (bug #252315).
1234
1235*ruby-1.8.6_p287-r11 (11 Jan 2009)
1236
1237 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1238 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1239 +ruby-1.8.6_p287-r11.ebuild:
1240 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1241 Fixes #254307.
1242
1243 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1244 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1245
1246 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1247 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1248
1249 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1250 ruby-1.8.6_p287-r10.ebuild:
1251 Add ~sparc keyword, bug #252315
1252
1253*ruby-1.8.6_p287-r10 (23 Dec 2008)
1254
1255 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1256 +ruby-1.8.6_p287-r10.ebuild:
1257 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1258 keywords since eselect-ruby does not yet have these keywords.
1259
1260 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1261 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1262 Revert the ruby-config changes. We can't remove them until we provide an
1263 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1264 for breaking things as mentioned in bug #251833.
1265
1266 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1267 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1268 ruby-1.8.7_p72-r1.ebuild:
1269 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1270 Thanks for the people noticing this in bug #251833.
1271
1272 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1273 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1274 ruby-1.8.7_p72-r1.ebuild:
1275 Drop dependency on ruby-config, which will be removed from the tree. We
1276 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1277 is no need for ruby-config at this moment. For newer versions of Ruby we will
1278 use eselect-ruby, which can be found in the ruby overlay at the moment.
1279
1280 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1281 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1282 Use mirror://ruby in SRC_URI, fixes #237392.
1283
1284 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1285 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1286 -ruby-1.8.7_p72.ebuild:
1287 Remove old versions. Leave one old stable version with cjk support.
1288
1289*ruby-1.8.6_p287-r3 (29 Nov 2008)
1290
1291 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1292 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1293 +ruby-1.8.6_p287-r3.ebuild:
1294 Fix our expansion limit patch according to debian bug report
1295 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1296 make sure people will pick up the fixed version. Thanks to Alex Legler for
1297 mentioning the patch.
1298
1299*ruby-1.8.7_p72-r1 (26 Nov 2008)
1300*ruby-1.8.6_p287-r2 (26 Nov 2008)
1301
1302 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1303 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1304 +ruby-1.8.7_p72-r1.ebuild:
1305 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1306 Thanks to Alex Legler for providing the patch.
1307
1308 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1309 -ruby-1.8.6_p287.ebuild:
1310 Remove versions that will not become stable
1311
1312 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1313 ruby-1.8.6_p287-r1.ebuild:
1314 ppc stable, bug #225465
1315
1316 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1317 ruby-1.8.6_p287-r1.ebuild:
1318 amd64 stable wrt security bug #225465
1319
1320 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1321 alpha/ia64/x86 stable wrt #225465
1322
1323 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1324 ruby-1.8.6_p287-r1.ebuild:
1325 Sparc stable --- Security Bug #225465 --- good since late August.
1326
1327 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1328 Stable on ppc64; bug #225465
1329
1330 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1331 Stable for HPPA (bug #225465).
1332
1333*ruby-1.8.6_p287-r1 (29 Aug 2008)
1334
1335 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1336 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1337 +ruby-1.8.6_p287-r1.ebuild:
1338 Fix REXML security issues, bug #236060.
1339
1340 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1341 Add GLEP 56 USE flag descriptions.
1342
1343*ruby-1.8.7_p72 (15 Aug 2008)
1344
1345 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1346 +ruby-1.8.7_p72.ebuild:
1347 bump 1.8.7 to latest patch release
1348
1349*ruby-1.8.6_p287 (11 Aug 2008)
1350
1351 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1352 Version bump for brown paper bag relelease.
1353
1354 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1355 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1356 Remove broken version in favor of the just-added 1.8.6_p286
1357
1358*ruby-1.8.6_p286 (10 Aug 2008)
1359
1360 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1361 Version bump to latest released version of ruby 1.8.6. This version fixes the
1362 security issues reported in #225465 and #234224. The cjk USE flag has been
1363 dropped since no compatible patches have been released yet.
1364
1365 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1366 ruby-1.8.6_p230.ebuild:
1367 drop cjk from SRC_URI as well
1368
1369 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1370 Drop cjk support since the most recent oniguruma patches no longer apply to
1371 this version, #230111.
1372
1373 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1374 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1375 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1376 Unfortunately the official p230 has a change which causes segmentation faults
1377 for applications like Rails and RSpec, so we are reverting that specific
1378 change.
1379
1380*ruby-1.8.7_p22 (29 Jun 2008)
1381
1382 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1383 +ruby-1.8.7_p22.ebuild:
1384 bump 1.8.7 for security fix
1385
1386 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1387 nevermind, don't bump this yet
1388
1389*ruby-1.8.6_p230 (20 Jun 2008)
1390
1391 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1392 version bump
1393
1394*ruby-1.8.7 (10 Jun 2008)
1395
1396 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1397 +ruby-1.8.7.ebuild:
1398 bump 1.8.7 to final
1399
1400*ruby-1.8.7_pre2 (21 Apr 2008)
1401
1402 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1403 +ruby-1.8.7_pre2.ebuild:
1404 Version Bump
1405
1406*ruby-1.8.7_pre1 (16 Apr 2008)
1407
1408 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1409 Version bump. Drop cjk until a new version of oniguruma appears.
1410
1411 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1412 amd64 stable, bug 212264
1413
1414 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1415 Stable for HPPA (bug #212264).
1416
1417 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1418 ruby-1.8.6_p114.ebuild:
1419 ppc stable, bug #212264
1420
1421 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1422 alpha/ia64 stable wrt #212264
1423
1424 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1425 ruby-1.8.6_p114.ebuild:
1426 stable x86, security bug 212264
1427
1428 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1429 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1430 as expected.
1431
1432 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1433 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1434
1435*ruby-1.8.6_p114 (05 Mar 2008)
1436
1437 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1438 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1439 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1440 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1441 Version bump for #212264. Remove old ebuilds.
1442
1443 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1444 alpha/ia64 stable wrt #208916
1445
1446 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1447 Stable on ppc wrt bug 208916
1448
1449 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1450 x86 stable, bug #208916
1451
1452 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1453 ruby-1.8.6_p111-r1.ebuild:
1454 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1455
1456 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1457 -files/ruby-1.8.6-exit-status.patch,
1458 -files/ruby-1.8.6_p110-net-http-p111.patch,
1459 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1460 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1461 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1462 Remove old versions
1463
1464 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1465 Stable on ppc64
1466
1467 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1468 Stable on amd64; bug 199191
1469
1470 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1471 alpha/ia64/sparc stable wrt #199191
1472
1473 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1474 Remove now-obsolete warning about coreutils versions, #203156.
1475
1476 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1477 Stable for HPPA (bug #199191).
1478
1479*ruby-1.8.6_p111-r1 (23 Dec 2007)
1480
1481 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1482 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1483 ssl USE flags. Patch to p113.
1484
1485 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1486 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1487
1488 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1489 x86 stable, security bug #199191
1490
1491*ruby-1.8.6_p111 (23 Dec 2007)
1492
1493 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1494 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1495 Version bump with patch for bug #199191
1496
1497 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1498 Move dependency on (X)Emacs modes to PDEPEND.
1499
1500 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1501 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1502 bug 196413
1503
1504*ruby-1.8.6_p110-r2 (21 Oct 2007)
1505
1506 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1507 +ruby-1.8.6_p110-r2.ebuild:
1508 Add emacs and xemacs USE flags and use them to pull in the correct editing
1509 mode for each. Had to drop several arch keywords as reported on bug 196413.
1510
1511 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1512 amd64 stable, security bug 194236
1513
1514 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1515 ruby-1.8.6_p110-r1.ebuild:
1516 Stable on ppc64; bug #194236
1517
1518 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1519 amd64 stable, security bug 194236
1520
1521 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1522 Stable for HPPA (bug #194236).
1523
1524 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1525 alpha/ia64/sparc stable wrt security #194236
1526
1527 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1528 ruby-1.8.6_p110-r1.ebuild:
1529 ppc stable, bug #194236
1530
1531 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1532 ruby-1.8.6_p110-r1.ebuild:
1533 stable x86, security bug 194236
1534
1535 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1536 ruby-1.8.5_p113.ebuild:
1537 stable x86, security bug 194236
1538
1539 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1540 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1541 -ruby-1.8.6_p110.ebuild:
1542 Remove old versions
1543
1544*ruby-1.8.6_p110-r1 (30 Sep 2007)
1545*ruby-1.8.5_p113 (30 Sep 2007)
1546
1547 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1548 +files/ruby-1.8.5_p113-net-http-p114.patch,
1549 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1550 +ruby-1.8.6_p110-r1.ebuild:
1551 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1552 using 1.8.6-p110 as base ebuild.
1553
1554 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1555 More fixes from gentoo-dev and graaff
1556
1557 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1558 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1559
1560*ruby-1.8.6_p110 (24 Sep 2007)
1561
1562 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1563 Version bump
1564
1565*ruby-1.8.6_p36-r4 (26 Aug 2007)
1566
1567 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1568 +ruby-1.8.6_p36-r4.ebuild:
1569 Use user LDFLAGS, #181436
1570
1571 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1572 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1573 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1574 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1575
1576 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1577 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1578 -ruby-1.8.6_p36-r2.ebuild:
1579 Remove some older versions that will not be promoted to stable, keeping at
1580 least one version of each release.
1581
1582 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1583 ruby-1.8.6_p36-r3.ebuild:
1584 (QA) RESTRICT clean up.
1585
1586*ruby-1.8.6_p36-r3 (04 Jul 2007)
1587
1588 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1589 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1590 fixed memory leak loading .so bug #182946
1591
1592 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1593 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1594 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1595 ruby-1.8.6_p36-r2.ebuild:
1596 (QA) RESTRICT clean up.
1597
1598 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1599 Re-add stable keyword for alpha as per bug #181110
1600
1601 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1602 Back to ~amd64 wrt bug 181110
1603
1604 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1605 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1606
1607*ruby-1.8.6_p36-r2 (20 Jun 2007)
1608
1609 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1610 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1611
1612*ruby-1.8.6_p36-r1 (18 Jun 2007)
1613
1614 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1615 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1616 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1617 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1618 spbecker
1619
1620 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1621 Stable on amd64 wrt bug 181110
1622
1623*ruby-1.8.6_p36 (12 Jun 2007)
1624
1625 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1626 Version Bump. Bug #181379
1627
1628 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1629 Stable on mips, per #181110.
1630
1631 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1632 Stable on ppc wrt bug 181110
1633
1634 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1635 Stable for HPPA (bug #181110).
1636
1637 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1638 alpha/ia64/x86 stable wrt #181110
1639
1640 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1641 Stable on sparc wrt #181110
1642
1643 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1644 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1645
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1646 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1647 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1648 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1649 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.664

  ViewVC Help
Powered by ViewVC 1.1.20