/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.678
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.678 2014/11/10 18:30:19 graaff Exp $
4
5*ruby-2.1.4-r1 (10 Nov 2014)
6*ruby-2.0.0_p594-r1 (10 Nov 2014)
7
8 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
9 +ruby-2.1.4-r1.ebuild:
10 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
11 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
12
13 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
14 ruby-2.0.0_p594.ebuild:
15 Stable for ppc64, wrt bug #527084
16
17 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
18 ruby-2.0.0_p594.ebuild:
19 Stable for ppc, wrt bug #527084
20
21 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
22 arm stable, bug #527084
23
24 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
25 arm stable, bug #527084
26
27 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
28 ruby-2.0.0_p594.ebuild:
29 Stable for x86, wrt bug #527084
30
31 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
32 ruby-2.0.0_p594.ebuild:
33 Stable for amd64, wrt bug #527084
34
35 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
36 ruby-2.0.0_p594.ebuild:
37 Stable for HPPA (bug #527084).
38
39*ruby-2.1.4 (27 Oct 2014)
40*ruby-2.0.0_p594 (27 Oct 2014)
41*ruby-1.9.3_p550 (27 Oct 2014)
42
43 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
44 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
45 Version bump for security bug 527084. Note that OpenSSL defaults have changed
46 in these versions which may lead to incompatibilities:
47 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
48 -openssl/
49
50 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
51 ruby-2.0.0_p481.ebuild:
52 Stable for sparc, wrt bug #512904
53
54 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
55 ruby-2.0.0_p481.ebuild:
56 Stable for ppc64, wrt bug #512904
57
58 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
59 ruby-2.0.0_p481.ebuild:
60 Stable for ppc, wrt bug #512904
61
62 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
63 ruby-2.0.0_p481.ebuild:
64 Stable for amd64, wrt bug #512904
65
66*ruby-2.1.3 (20 Sep 2014)
67
68 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
69 Version bump:
70 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
71
72*ruby-2.0.0_p576 (20 Sep 2014)
73
74 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
75 Version bump.
76
77 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
78 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
79 Depend on the rubygems virtual with an explicit SLOT now that the specific
80 rubygems versions are listed in virtual/rubygems. This will make the
81 dependencies more explicit and should decrease resolver surprises picking the
82 wrong virtual/rubygems SLOT later on.
83
84 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
85 Cleanup.
86
87 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
88 ruby-2.0.0_p481.ebuild:
89 x86 stable wrt bug #512904
90
91 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
92 Stable on alpha, bug #512904
93
94 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
95 arm stable, bug #512904
96
97 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
98 arm stable, bug #512904
99
100 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
101 ruby-2.0.0_p481.ebuild:
102 ia64 stable wrt bug #512904
103
104 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
105 Stable for HPPA (bug #512904).
106
107 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
108 Stable for HPPA (bug #512904).
109
110 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
111 -ruby-2.1.1-r1.ebuild:
112 Cleanup.
113
114 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
115 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
116 512848.
117
118*ruby-1.9.3_p547 (17 May 2014)
119
120 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
121 Version bump.
122
123*ruby-2.1.2 (10 May 2014)
124*ruby-2.0.0_p481 (10 May 2014)
125
126 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
127 +ruby-2.1.2.ebuild:
128 Version bump.
129
130 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
131 -ruby-2.0.0_p353-r2.ebuild:
132 Cleanup.
133
134 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
135 ruby-2.1.1-r1.ebuild:
136 Remove useless libruby symlinks, bug 503584.
137
138 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
139 -ruby-2.1.1.ebuild:
140 Cleanup.
141
142 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
143 Remove unneeded useflag descriptions from metadata.xml
144
145 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
146 -ruby-1.8.7_p374.ebuild:
147 Remove Ruby 1.8. See bug #434064.
148
149*ruby-2.1.1-r1 (14 Apr 2014)
150
151 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
152 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
153 Thanks to Andrew Savchenko for providing a patch.
154
155 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
156 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
157 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
158 ruby-2.1.1.ebuild:
159 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
160
161*ruby-2.1.1 (06 Mar 2014)
162
163 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
164 Version bump. Update module selection code to fix automagic dependencies.
165 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
166 503106.
167
168*ruby-2.0.0_p451 (05 Mar 2014)
169
170 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
171 Version bump. Update module selection code to fix automagic dependencies.
172 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
173 503106.
174
175*ruby-1.9.3_p545 (26 Feb 2014)
176
177 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
178 Version bump. Drop tk USE flag due to bug 500894.
179
180*ruby-2.0.0_p353-r2 (23 Feb 2014)
181
182 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
183 Backport support for uclibc, fixing bug 484534.
184
185 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
186 Stable for alpha, wrt bug #483254
187
188 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
189 Stable for sparc, wrt bug #483254
190
191 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
192 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
193 Fix slot conflicts, #498970
194
195 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
196 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
197 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
198 bug 497130.
199
200 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
201 -ruby-1.9.3_p448-r1.ebuild:
202 Remove vulnerable versions.
203
204 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
205 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
206 Remove vulnerable versions.
207
208 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
209 arm stable, bug #492282
210
211*ruby-2.0.0_p353-r1 (03 Jan 2014)
212
213 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
214 ruby-2.1.0.ebuild:
215 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
216
217 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
218 arm stable, bug #483254
219
220 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
221 ruby-2.0.0_p353.ebuild:
222 ia64 stable wrt bug #492282
223
224*ruby-2.1.0 (26 Dec 2013)
225
226 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
227 Version bump.
228
229 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
230 ia64 stable wrt bug #483254
231
232 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
233 Stable for sparc, wrt bug #492282
234
235 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
236 Stable for arm, wrt bug #492282
237
238 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
239 Stable for alpha, wrt bug #492282
240
241 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
242 ruby-2.0.0_p353.ebuild:
243 Stable for x86, wrt bug #492282
244
245 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
246 ruby-2.0.0_p353.ebuild:
247 Stable for ppc64, wrt bug #492282
248
249 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
250 ruby-2.0.0_p353.ebuild:
251 Stable for ppc, wrt bug #492282
252
253 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
254 Stable for ppc64, wrt bug #483254
255
256 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
257 Stable for ppc, wrt bug #483254
258
259 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
260 ruby-2.0.0_p353.ebuild:
261 Stable for amd64, wrt bug #492282
262
263 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
264 Stable for HPPA (bug #492282).
265
266 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
267 Stable for HPPA (bug #492282).
268
269*ruby-2.0.0_p353 (22 Nov 2013)
270*ruby-1.9.3_p484 (22 Nov 2013)
271
272 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
273 +ruby-2.0.0_p353.ebuild:
274 Version bumps for security bug 492282.
275
276*ruby-2.0.0_p247-r2 (14 Oct 2013)
277
278 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
279 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
280 2.x. Fixes bug 483466.
281
282 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
283 -ruby-1.9.3_p429.ebuild:
284 Cleanup.
285
286 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
287 Stable for HPPA (bug #483254).
288
289 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
290 Stable for x86, wrt bug #483254
291
292 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
293 Stable for amd64, wrt bug #483254
294
295 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
296 ruby-1.9.3_p448.ebuild:
297 Stable for s390, wrt bug #475074
298
299*ruby-2.0.0_p247-r1 (29 Jul 2013)
300*ruby-1.9.3_p448-r1 (29 Jul 2013)
301*ruby-1.8.7_p374-r1 (29 Jul 2013)
302
303 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
304 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
305 Revision bump to counter breakage introduced in portage 2.1.13 for bug
306 465000. Thanks to thansen for reporting.
307
308 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
309 ruby-1.9.3_p448.ebuild:
310 Stable for sparc, wrt bug #475074
311
312 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
313 ruby-1.9.3_p448.ebuild:
314 Stable for sh, wrt bug #475074
315
316 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
317 ruby-1.9.3_p448.ebuild:
318 Stable for ia64, wrt bug #475074
319
320*ruby-2.0.0_p247 (07 Jul 2013)
321
322 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
323 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
324 ruby20.
325
326 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
327 ruby-1.9.3_p448.ebuild:
328 Stable for alpha, wrt bug #475074
329
330 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
331 ruby-1.9.3_p448.ebuild:
332 Stable for ppc64, wrt bug #475074
333
334 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
335 ruby-1.9.3_p448.ebuild:
336 Stable for HPPA (bug #475074).
337
338 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
339 ruby-1.9.3_p448.ebuild:
340 Stable for ppc, wrt bug #475074
341
342 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
343 ruby-1.9.3_p448.ebuild:
344 Stable for arm, wrt bug #475074
345
346 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
347 ruby-1.9.3_p448.ebuild:
348 Stable for x86, wrt bug #475074
349
350 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
351 ruby-1.9.3_p448.ebuild:
352 Stable for amd64, wrt bug #475074
353
354*ruby-1.9.3_p448 (30 Jun 2013)
355*ruby-1.8.7_p374 (30 Jun 2013)
356
357 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
358 +ruby-1.9.3_p448.ebuild:
359 Version bumps for security bug 475074.
360
361 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
362 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
363 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
364 Cleanup. Remove vulnerable versions.
365
366 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
367 Stable for sh, wrt bug #469984
368
369 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
370 Stable for s390, wrt bug #469984
371
372 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
373 Stable for ppc64, wrt bug #469984
374
375 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
376 Stable for ia64, wrt bug #469984
377
378 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
379 Stable for alpha, wrt bug #469984
380
381 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
382 Stable for sparc, wrt bug #469984
383
384 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
385 Remove non-functional dosym calls, bug 442462.
386
387 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
388 Stable for arm, wrt bug #469984
389
390 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
391 Stable for ppc, wrt bug #469984
392
393 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
394 Stable for x86, wrt bug #469984
395
396 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
397 Stable for amd64, wrt bug #469984
398
399 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
400 Stable for HPPA (bug #469984).
401
402*ruby-1.9.3_p429 (16 May 2013)
403
404 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
405 Version bump for security bug #469984.
406
407 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
408 Stable for s390, wrt bug #437366
409
410 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
411 Stable for sparc, wrt bug #437366
412
413 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
414 Stable for ia64, wrt bug #437366
415
416 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
417 Stable for alpha, wrt bug #437366
418
419 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
420 Stable for ppc64, wrt bug #437366
421
422 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
423 Stable for arm, wrt bug #437366
424
425 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
426 Stable for sh, wrt bug #437366
427
428 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
429 Marking ruby-1.8.7_p371 ppc for bug 437366
430
431 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
432 Stable for HPPA (bug #437366).
433
434 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
435 Stable for x86, wrt bug #437366
436
437 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
438 Stable for amd64, wrt bug #437366
439
440 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
441 Stable for sh, wrt bug #458776
442
443 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
444 Stable for alpha, wrt bug #458776
445
446 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
447 Add patch to fix bug #459074 (parallel build).
448
449 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
450 Stable for arm, wrt bug #458776
451
452 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
453 Stable for s390, wrt bug #458776
454
455 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
456 Stable for sparc, wrt bug #458776
457
458 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
459 Stable for hppa, wrt bug #458776
460
461 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
462 Stable for ia64, wrt bug #458776
463
464 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
465 Stable for x86, wrt bug #458776
466
467 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
468 Stable for amd64, wrt bug #458776
469
470 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
471 Stable for ppc64, wrt bug #458776
472
473 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
474 Stable for ppc, wrt bug #458776
475
476*ruby-1.9.3_p392 (22 Feb 2013)
477
478 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
479 Version bump for security bug 458776.
480
481*ruby-1.9.3_p385 (10 Feb 2013)
482
483 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
484 Version bump. Fixes security bug 442580.
485
486 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
487 keyword ~amd64-fbsd
488
489*ruby-1.8.7_p371 (06 Jan 2013)
490
491 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
492 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
493 Version bump for security bug 437366.
494
495 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
496 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
497 Cleanup.
498
499 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
500 Stable for ppc, wrt bug #427774
501
502 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
503 Stable for HPPA (bug #411507).
504
505 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
506 alpha/ia64/s390/sh/sparc stable wrt #434480
507
508 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
509 ruby-1.9.3_p286.ebuild:
510 Remove HPPA target hack (bug #342819).
511
512 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
513 alpha/ia64/s390/sh/sparc stable wrt #411507
514
515 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
516 Stable for HPPA (bug #434480).
517
518*ruby-1.9.3_p286 (15 Oct 2012)
519
520 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
521 Version bump. Fixes bugs #437264 and #437264.
522
523 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
524 stable arm, bug #434480
525
526 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
527 stable ppc ppc64, bug #434480
528
529 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
530 Stable for x86, wrt bug #434480
531
532 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
533 ruby-1.9.3_p194-r1.ebuild:
534 Update LICENSE, bug 434332.
535
536 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
537 Stable for amd64, wrt bug #434480
538
539 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
540 Stable for amd64, wrt bug #427774
541
542 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
543 arm stable, bug #427774
544
545 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
546 ruby-1.9.3_p194-r1.ebuild:
547 Stable ppc64, bug #411507
548
549 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
550 marked x86 per bug 427774
551
552 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
553 -ruby-1.9.3_p194.ebuild:
554 Cleanup.
555
556 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
557 ppc stable #411507
558
559 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
560 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
561 424611.
562
563*ruby-1.8.7_p370 (07 Jul 2012)
564
565 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
566 Version bump. Fix bug 378567 thanks to slyfox.
567
568 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
569 x86 stable, see bug 411507
570
571 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
572 arm stable, bug #411507
573
574 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
575 Stable for amd64, wrt bug #411507
576
577*ruby-1.9.3_p194-r1 (12 May 2012)
578
579 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
580 +ruby-1.9.3_p194-r1.ebuild:
581 Revision bump to fix mkmf for parallel build/install. Also enable verbose
582 build, so that the log makes sense if it fails.
583
584*ruby-1.9.3_p194 (30 Apr 2012)
585
586 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
587 Version bump.
588
589 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
590 keyword ~amd64-fbsd
591
592*ruby-1.8.7_p358 (20 Apr 2012)
593
594 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
595 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
596 Rails 3.2.
597
598 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
599 Add ~x86-fbsd, #332593
600
601*ruby-1.9.3_p125 (18 Feb 2012)
602
603 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
604 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
605
606 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
607 add ~arm, bug #332593
608
609 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
610 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
611
612 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
613 x86 stable wrt bug #396301
614
615 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
616 Stable for HPPA (bug #396301).
617
618 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
619 Stable for ppc/ppc64; bug #396301
620
621 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
622 Marked ~hppa (bug #332593).
623
624 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
625 Add back ~alpha keyword now that rubygems is keyworded.
626
627 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
628 Stable for AMD64, wrt security bug #396301
629
630*ruby-1.8.7_p357 (28 Dec 2011)
631
632 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
633 Version bump for security bug 396301.
634
635 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
636 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
637
638 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
639 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
640 keyworded, bug 332593.
641
642 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
643 Block older versions of packages that are no longer compatible. Remove
644 ancient blocks on packags long gone from the tree.
645
646 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
647 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
648 Remove old versions.
649
650*ruby-1.9.3_p0 (18 Dec 2011)
651
652 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
653 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
654 suite which need to be diagnosed first.
655
656 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
657 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
658 #332593).
659
660 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
661 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
662 #332593).
663
664 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
665 alpha/ia64/s390/sh/sparc stable wrt #386369
666
667*ruby-1.9.3_rc1 (22 Oct 2011)
668
669 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
670 Version bump.
671
672 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
673 arm stable, bug #386369
674
675 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
676 x86 stable, bug 386369
677
678 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
679 Stable for HPPA (bug #386369).
680
681 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
682 ppc/ppc64 stable wrt #386369
683
684 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
685 Stable on amd64 wrt bug #386369
686
687 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
688 Remove vulnerable version, bug 386369.
689
690*ruby-1.8.7_p352 (30 Aug 2011)
691
692 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
693 +ruby-1.8.7_p352.ebuild:
694 Patchlevel bump for ruby:1.8. Removing old version
695
696*ruby-1.9.2_p290 (30 Aug 2011)
697
698 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
699 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
700 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
701 old patchlevels.
702
703 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
704 ruby-1.8.7_p334-r2.ebuild:
705 ppc/ppc64 stable wrt #378691
706
707*ruby-1.8.7_p334-r2 (22 Jul 2011)
708
709 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
710 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
711 for chasing down upstream and us.
712
713 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
714 Added ~mips, bug 332593
715
716 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
717 ruby-1.8.7_p334-r1.ebuild:
718 ppc64 stable wrt #369141
719
720 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
721 ia64/s390/sh/sparc stable wrt #369141
722
723 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
724 Stable for HPPA (bug #369141).
725
726 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
727 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
728
729 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
730 arm/x86 stable, bug #369141
731
732 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
733 Stable on amd64 wrt bug #369141
734
735 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
736 ruby-1.8.7_p334-r1.ebuild:
737 Stable on alpha, bug #369141
738
739*ruby-1.8.7_p334-r1 (31 May 2011)
740
741 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
742 Revision bump for security bug 369141 (CVE-2011-0188)
743
744*ruby-1.9.2-r1 (16 May 2011)
745
746 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
747 Don't remove racc files since all other ruby targets ship these files
748 themselves as well. Closes bug 363419.
749
750 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
751 ruby-1.8.7_p334.ebuild:
752 Remove old version. Remove obsolete and unused old-style virtual/ruby.
753
754 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
755 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
756
757 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
758 Add append-flags -mieee on sh, bug #357559
759
760 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
761 alpha/arm/ia64/s390/sh stable wrt #355439
762
763 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
764 Marked ~ppc64 wrt #332593
765
766 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
767 ruby-1.8.7_p334.ebuild:
768 x86 stable wrt security bug #355439
769
770 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
771 ruby-1.8.7_p334.ebuild:
772 ppc/ppc64 stable wrt #355439
773
774 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
775 Stable on amd64 wrt bug #355439
776
777 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
778 Stable for HPPA (bug #355439).
779
780*ruby-1.8.7_p334 (19 Feb 2011)
781
782 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
783 Version bump 1.8.7 series, security bug 355439
784
785 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
786 ruby-1.9.2.ebuild:
787 Remove PROVIDE for old-style virtual/ruby per bug 265054.
788
789 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
790 Remove masked ruby 1.8.6 per bug 332597.
791
792 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
793 -ruby-1.9.2_rc2.ebuild:
794 Removing old and vulnerable ebuilds
795
796 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
797 Marking ruby-1.8.7_p302 ppc64 for bug 332957
798
799 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
800 alpha/ia64/s390/sh/sparc stable wrt #332957
801
802*ruby-1.9.2 (24 Aug 2010)
803
804 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
805 metadata.xml:
806 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
807 and x86-fbsd due to a new dependency on rdoc.
808
809 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
810 arm stable, bug #332957
811
812 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
813 ruby-1.8.7_p302.ebuild:
814 x86 stable wrt security bug #332957
815
816 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
817 Stable on amd64 wrt bug #332957
818
819 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
820 Stable for PPC (bug #332957).
821
822 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
823 Stable for HPPA (bug #332957).
824
825*ruby-1.8.7_p302 (21 Aug 2010)
826
827 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
828 +ruby-1.8.7_p302.ebuild:
829 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
830 installation path.
831
832*ruby-1.8.6_p399 (19 Aug 2010)
833
834 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
835 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
836 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
837 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
838 installation path (reported by the x86 team in bug 332597)
839
840*ruby-1.9.2_rc2-r1 (18 Aug 2010)
841
842 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
843 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
844 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
845 the rubygems loading code. Add USE flag for psych.
846
847 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
848 ruby-1.9.2_rc2.ebuild:
849 Remove two keepdir that will try to keep an empty path, closes bug
850 #333163.
851
852 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
853 Marked ~ppc (bug #332593).
854
855 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
856 ruby-1.9.2_rc2.ebuild:
857 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
858
859 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
860 ruby-1.8.7_p299.ebuild:
861 Bump eselect-ruby dependency
862
863 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
864 -ruby-1.9.1_p429.ebuild:
865 Remove ebuild that is not target for unmask anyway.
866
867 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
868 ruby-1.9.2_rc2.ebuild:
869 Try 2 to fix the berkdb 5 issue on 1.9.
870
871 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
872 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
873 ruby-1.9.2_rc2.ebuild:
874 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
875 support for adding new patchsets without bumping the revision for all the
876 old ebuilds as well.
877
878*ruby-1.9.2_rc2 (14 Jul 2010)
879
880 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
881 +ruby-1.9.2_rc2.ebuild:
882 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
883 might cause _further_ build failures as it changed slightly behaviour.
884 You're going to need to rebuild rubygems and then all the packages
885 previously installed after upgrading to this.
886
887 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
888 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
889 -ruby-1.9.1_p376.ebuild:
890 Cleanup old versions.
891
892*ruby-1.9.1_p429 (04 Jul 2010)
893
894 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
895 +ruby-1.9.1_p429.ebuild:
896 Version bump to new 1.9.1 release.
897
898*ruby-1.8.7_p299 (23 Jun 2010)
899
900 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
901 +ruby-1.8.7_p299.ebuild:
902 Version bump.
903
904 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
905 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
906 remove useless comments
907
908 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
909 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
910 ruby-1.9.1_p376.ebuild:
911 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
912 dev.gentoo.org now.
913
914 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
915 ruby-1.9.1_p376.ebuild:
916 Use the correct RUBYLIB.
917
918*ruby-1.8.7_p249-r2 (18 May 2010)
919*ruby-1.8.6_p388-r1 (18 May 2010)
920
921 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
922 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
923 ruby-1.9.1_p376.ebuild, metadata.xml:
924 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
925 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
926 add USE flags for ncurses, readline and libedit, and properly depend on
927 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
928 Emacs versions support ruby-mode themselves and it should be even more
929 updated.
930
931*ruby-1.8.7_p249-r1 (06 May 2010)
932
933 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
934 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
935 309789 by Sune Kloppenborg Jeppesen.
936
937 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
938 ruby-1.8.7_p249.ebuild:
939 Use $PVR instead of $PV in patchset names
940
941 06 May 2010; Alex Legler <a3li@gentoo.org>
942 -files/ruby-1.8.6-memory-leak.diff,
943 -files/ruby18-mkmf-parallel-install.patch,
944 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
945 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
946 Remove old version. Cleanup in files/
947
948*ruby-1.9.1_p376 (01 May 2010)
949
950 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
951 Version bump. Fixes security bugs 296052 and 300468. No longer installs
952 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
953 instead.
954
955 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
956 -ruby-1.8.7_p174-r1.ebuild:
957 Remove vulnerable ebuilds, 300468
958
959 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
960 ruby-1.8.7_p249.ebuild:
961 amd64 stable, security bug 300468
962
963 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
964 ruby-1.8.7_p249.ebuild:
965 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
966
967 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
968 Stable for HPPA (bug #300468).
969
970 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
971 Stable for HPPA (bug #300468).
972
973 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
974 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
975
976 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
977 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
978
979 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
980 ruby-1.8.6_p388.ebuild:
981 stable x86, security bug 300468
982
983 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
984 ruby-1.8.7_p249.ebuild:
985 stable x86, security bug 300468
986
987*ruby-1.8.6_p388 (10 Jan 2010)
988
989 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
990 +ruby-1.8.6_p388.ebuild:
991 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
992 version. The new ebuild also has the fix for bug 168939.
993
994*ruby-1.8.7_p249 (10 Jan 2010)
995
996 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
997 +ruby-1.8.7_p249.ebuild:
998 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
999 version
1000
1001 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1002 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1003
1004*ruby-1.8.7_p248 (25 Dec 2009)
1005
1006 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1007 Version bump
1008
1009 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1010 Remove old version.
1011
1012 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1013 Remove old version.
1014
1015 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1016 ia64/s390/sh stable wrt #288699
1017
1018 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1019 stable sparc, bug 288699
1020
1021 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1022 arm stable, bug #288699
1023
1024 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1025 amd64/x86 stable, bug #288699
1026
1027 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1028 ruby-1.8.7_p174-r1.ebuild:
1029 Stable on alpha, bug #288699
1030
1031 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1032 ppc stable #288699
1033
1034 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1035 Stable for HPPA (bug #288699).
1036
1037 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1038 Marked ~hppa too.
1039
1040*ruby-1.8.7_p174-r1 (06 Oct 2009)
1041
1042 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1043 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1044 eselect-ruby cleanup feature.
1045
1046*ruby-1.9.1_p243 (09 Sep 2009)
1047
1048 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1049 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1050 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1051 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1052 -files/ruby19-rubygems-proxy.patch,
1053 -files/ruby-1.9.1_p129-parallelmake.patch,
1054 -files/ruby19-mkmf-parallel-install.patch:
1055 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1056 168939. Cleaning up old patches.
1057
1058*ruby-1.8.6_p383 (20 Aug 2009)
1059
1060 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1061 Patchlevel bump.
1062
1063 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1064 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1065 ruby-1.9.1_p129-r1.ebuild:
1066 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1067
1068 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1069 Removing vulnerable ebuild, bug 273213.
1070
1071 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1072 Marking ruby-1.8.6_p369 ppc for bug 273213
1073
1074 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1075 ruby-1.9.1_p129-r1.ebuild:
1076 Prepend our library path instead of overwriting it during src_install.
1077 Thanks to the reporter of bug #274824.
1078
1079*ruby-1.8.7_p174 (18 Jun 2009)
1080
1081 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1082 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1083 Replacing 187_p173 with _p174 because of a regression. Unifying the
1084 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1085 patchsets.
1086
1087 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1088 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1089
1090 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1091 arm/ia64/s390/sh/sparc stable wrt #273213
1092
1093 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1094 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1095 Removing old version, minor cleanup
1096
1097 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1098 -files/ruby-1.8.6-openssl.patch,
1099 -files/ruby-1.8.6-shortname_constants.patch,
1100 -files/ruby-1.8.6_p111-r13657.patch,
1101 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1102 Removing vulnerable old Ruby version and stale patches, bug 274108.
1103
1104 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1105 ruby-1.8.6_p369.ebuild:
1106 Stable on alpha, bug #273213
1107
1108 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1109 Stable for HPPA (bug #273213).
1110
1111 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1112 ruby-1.8.6_p369.ebuild:
1113 stable x86, security bug 273213
1114
1115 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1116 amd64 stable, security bug 273213.
1117
1118*ruby-1.8.7_p173 (10 Jun 2009)
1119*ruby-1.8.6_p369 (10 Jun 2009)
1120
1121 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1122 +ruby-1.8.7_p173.ebuild:
1123 Version bumps for bug #273213.
1124
1125*ruby-1.9.1_p129-r1 (27 May 2009)
1126
1127 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1128 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1129 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1130 +files/ruby-1.9.1_p129-parallelmake.patch:
1131 Revision bump, add patches 1) to make Ruby behave more similarly between
1132 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1133 extensions (undefined symbols in them will cause abort at runtime 3) to
1134 remove a concurrency issue when building the dl extension that could
1135 result in a broken dl.so.
1136
1137 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1138 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1139 Don't block rdoc-2 or later (which may enter Portage one day as it's
1140 needed by some Rakefiles).
1141
1142 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1143 ruby-1.9.1_p129.ebuild:
1144 Add ~x86-fbsd keyword.
1145
1146 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1147 keyword ~sparc-fbsd, bug #252315
1148
1149*ruby-1.9.1_p129 (15 May 2009)
1150
1151 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1152 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1153 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1154 included in every release.
1155
1156 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1157 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1158 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1159 ruby-1.8.7_p160.ebuild:
1160 Removing vulnerable versions (#268515), fixing license (#233747).
1161
1162 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1163 Stable for HPPA (bug #268515).
1164
1165 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1166 Adapting rubygems notice.
1167
1168 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1169 amd64 stable, bug #268515.
1170
1171 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1172 arm/ia64/s390/sh/sparc stable wrt #268515
1173
1174 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1175 ruby-1.8.6_p368.ebuild:
1176 stable x86, security bug 268515
1177
1178 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1179 ruby-1.8.6_p368.ebuild:
1180 Stable on alpha, bug #268515
1181
1182 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1183 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1184
1185*ruby-1.8.7_p160 (07 May 2009)
1186*ruby-1.8.6_p368 (07 May 2009)
1187
1188 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1189 +ruby-1.8.7_p160.ebuild:
1190 Version bump as per secbug 268515. NB: These are the first ebuilds that
1191 no longer use ruby-config.
1192
1193*ruby-1.9.1-r1 (03 Apr 2009)
1194*ruby-1.8.7_p72-r11 (03 Apr 2009)
1195*ruby-1.8.6_p287-r13 (03 Apr 2009)
1196
1197 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1198 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1199 +files/ruby18-mkmf-parallel-install.patch,
1200 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1201 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1202 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1203 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1204 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1205 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1206 happy.
1207
1208*ruby-1.9.1 (21 Mar 2009)
1209
1210 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1211 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1212 +ruby-1.9.1.ebuild:
1213 Adding Ruby 1.9.1 for preliminary testing
1214
1215 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1216 ruby-1.8.6_p287-r12.ebuild:
1217 Marked ~ppc for bug #252315.
1218
1219 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1220 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1221 bug 261982.
1222
1223 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1224 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1225 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1226 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1227 Cleanup
1228
1229*ruby-1.8.7_p72-r10 (07 Mar 2009)
1230
1231 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1232 +ruby-1.8.7_p72-r10.ebuild:
1233 Add a revision of ruby 1.8.7 using eselect ruby.
1234
1235 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1236 ~mips keyworded, bug #252315.
1237
1238 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1239 ruby-1.8.6_p287-r5.ebuild:
1240 ppc stable, bug #260006
1241
1242 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1243 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1244
1245 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1246 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1247 Fixing Tk USE flag test, bug 258893.
1248
1249 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1250 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1251
1252 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1253 ruby-1.8.6_p287-r5.ebuild:
1254 amd64 stable wrt security bug #260006
1255
1256 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1257 Stable for HPPA (bug #260006).
1258
1259 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1260 ruby-1.8.6_p287-r5.ebuild:
1261 Stable on alpha, bug #260006
1262
1263*ruby-1.8.7_p72-r2 (23 Feb 2009)
1264*ruby-1.8.6_p287-r12 (23 Feb 2009)
1265*ruby-1.8.6_p287-r5 (23 Feb 2009)
1266
1267 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1268 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1269 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1270 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1271 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1272 now before compilation if Tk useflags don't match) and 230748 (adding
1273 --enable-option-checking=no for newer versions of autoconf).
1274
1275 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1276 arm/ia64/s390/sh/sparc stable wrt #254307
1277
1278 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1279 ruby-1.8.6_p287-r4.ebuild:
1280 Stable on alpha, bug #254307
1281
1282 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1283 ruby-1.8.6_p287-r11.ebuild:
1284 keyword ~x86-fbsd, bug #252315
1285
1286 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1287 ppc stable #254307
1288
1289 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1290 amd64/x86 stable, bug #254307
1291
1292 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1293 stable ppc64, bug 254307
1294
1295 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1296 Stable for HPPA (bug #254307).
1297
1298 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1299 ruby-1.8.6_p287-r11.ebuild:
1300 Marked ~hppa (bug #252315).
1301
1302*ruby-1.8.6_p287-r11 (11 Jan 2009)
1303
1304 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1305 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1306 +ruby-1.8.6_p287-r11.ebuild:
1307 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1308 Fixes #254307.
1309
1310 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1311 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1312
1313 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1314 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1315
1316 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1317 ruby-1.8.6_p287-r10.ebuild:
1318 Add ~sparc keyword, bug #252315
1319
1320*ruby-1.8.6_p287-r10 (23 Dec 2008)
1321
1322 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1323 +ruby-1.8.6_p287-r10.ebuild:
1324 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1325 keywords since eselect-ruby does not yet have these keywords.
1326
1327 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1328 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1329 Revert the ruby-config changes. We can't remove them until we provide an
1330 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1331 for breaking things as mentioned in bug #251833.
1332
1333 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1334 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1335 ruby-1.8.7_p72-r1.ebuild:
1336 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1337 Thanks for the people noticing this in bug #251833.
1338
1339 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1340 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1341 ruby-1.8.7_p72-r1.ebuild:
1342 Drop dependency on ruby-config, which will be removed from the tree. We
1343 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1344 is no need for ruby-config at this moment. For newer versions of Ruby we will
1345 use eselect-ruby, which can be found in the ruby overlay at the moment.
1346
1347 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1348 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1349 Use mirror://ruby in SRC_URI, fixes #237392.
1350
1351 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1352 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1353 -ruby-1.8.7_p72.ebuild:
1354 Remove old versions. Leave one old stable version with cjk support.
1355
1356*ruby-1.8.6_p287-r3 (29 Nov 2008)
1357
1358 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1359 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1360 +ruby-1.8.6_p287-r3.ebuild:
1361 Fix our expansion limit patch according to debian bug report
1362 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1363 make sure people will pick up the fixed version. Thanks to Alex Legler for
1364 mentioning the patch.
1365
1366*ruby-1.8.7_p72-r1 (26 Nov 2008)
1367*ruby-1.8.6_p287-r2 (26 Nov 2008)
1368
1369 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1370 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1371 +ruby-1.8.7_p72-r1.ebuild:
1372 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1373 Thanks to Alex Legler for providing the patch.
1374
1375 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1376 -ruby-1.8.6_p287.ebuild:
1377 Remove versions that will not become stable
1378
1379 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1380 ruby-1.8.6_p287-r1.ebuild:
1381 ppc stable, bug #225465
1382
1383 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1384 ruby-1.8.6_p287-r1.ebuild:
1385 amd64 stable wrt security bug #225465
1386
1387 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1388 alpha/ia64/x86 stable wrt #225465
1389
1390 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1391 ruby-1.8.6_p287-r1.ebuild:
1392 Sparc stable --- Security Bug #225465 --- good since late August.
1393
1394 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1395 Stable on ppc64; bug #225465
1396
1397 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1398 Stable for HPPA (bug #225465).
1399
1400*ruby-1.8.6_p287-r1 (29 Aug 2008)
1401
1402 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1403 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1404 +ruby-1.8.6_p287-r1.ebuild:
1405 Fix REXML security issues, bug #236060.
1406
1407 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1408 Add GLEP 56 USE flag descriptions.
1409
1410*ruby-1.8.7_p72 (15 Aug 2008)
1411
1412 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1413 +ruby-1.8.7_p72.ebuild:
1414 bump 1.8.7 to latest patch release
1415
1416*ruby-1.8.6_p287 (11 Aug 2008)
1417
1418 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1419 Version bump for brown paper bag relelease.
1420
1421 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1422 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1423 Remove broken version in favor of the just-added 1.8.6_p286
1424
1425*ruby-1.8.6_p286 (10 Aug 2008)
1426
1427 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1428 Version bump to latest released version of ruby 1.8.6. This version fixes the
1429 security issues reported in #225465 and #234224. The cjk USE flag has been
1430 dropped since no compatible patches have been released yet.
1431
1432 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1433 ruby-1.8.6_p230.ebuild:
1434 drop cjk from SRC_URI as well
1435
1436 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1437 Drop cjk support since the most recent oniguruma patches no longer apply to
1438 this version, #230111.
1439
1440 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1441 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1442 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1443 Unfortunately the official p230 has a change which causes segmentation faults
1444 for applications like Rails and RSpec, so we are reverting that specific
1445 change.
1446
1447*ruby-1.8.7_p22 (29 Jun 2008)
1448
1449 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1450 +ruby-1.8.7_p22.ebuild:
1451 bump 1.8.7 for security fix
1452
1453 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1454 nevermind, don't bump this yet
1455
1456*ruby-1.8.6_p230 (20 Jun 2008)
1457
1458 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1459 version bump
1460
1461*ruby-1.8.7 (10 Jun 2008)
1462
1463 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1464 +ruby-1.8.7.ebuild:
1465 bump 1.8.7 to final
1466
1467*ruby-1.8.7_pre2 (21 Apr 2008)
1468
1469 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1470 +ruby-1.8.7_pre2.ebuild:
1471 Version Bump
1472
1473*ruby-1.8.7_pre1 (16 Apr 2008)
1474
1475 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1476 Version bump. Drop cjk until a new version of oniguruma appears.
1477
1478 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1479 amd64 stable, bug 212264
1480
1481 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1482 Stable for HPPA (bug #212264).
1483
1484 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1485 ruby-1.8.6_p114.ebuild:
1486 ppc stable, bug #212264
1487
1488 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1489 alpha/ia64 stable wrt #212264
1490
1491 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1492 ruby-1.8.6_p114.ebuild:
1493 stable x86, security bug 212264
1494
1495 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1496 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1497 as expected.
1498
1499 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1500 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1501
1502*ruby-1.8.6_p114 (05 Mar 2008)
1503
1504 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1505 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1506 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1507 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1508 Version bump for #212264. Remove old ebuilds.
1509
1510 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1511 alpha/ia64 stable wrt #208916
1512
1513 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1514 Stable on ppc wrt bug 208916
1515
1516 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1517 x86 stable, bug #208916
1518
1519 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1520 ruby-1.8.6_p111-r1.ebuild:
1521 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1522
1523 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1524 -files/ruby-1.8.6-exit-status.patch,
1525 -files/ruby-1.8.6_p110-net-http-p111.patch,
1526 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1527 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1528 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1529 Remove old versions
1530
1531 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1532 Stable on ppc64
1533
1534 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1535 Stable on amd64; bug 199191
1536
1537 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1538 alpha/ia64/sparc stable wrt #199191
1539
1540 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1541 Remove now-obsolete warning about coreutils versions, #203156.
1542
1543 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1544 Stable for HPPA (bug #199191).
1545
1546*ruby-1.8.6_p111-r1 (23 Dec 2007)
1547
1548 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1549 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1550 ssl USE flags. Patch to p113.
1551
1552 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1553 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1554
1555 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1556 x86 stable, security bug #199191
1557
1558*ruby-1.8.6_p111 (23 Dec 2007)
1559
1560 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1561 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1562 Version bump with patch for bug #199191
1563
1564 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1565 Move dependency on (X)Emacs modes to PDEPEND.
1566
1567 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1568 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1569 bug 196413
1570
1571*ruby-1.8.6_p110-r2 (21 Oct 2007)
1572
1573 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1574 +ruby-1.8.6_p110-r2.ebuild:
1575 Add emacs and xemacs USE flags and use them to pull in the correct editing
1576 mode for each. Had to drop several arch keywords as reported on bug 196413.
1577
1578 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1579 amd64 stable, security bug 194236
1580
1581 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1582 ruby-1.8.6_p110-r1.ebuild:
1583 Stable on ppc64; bug #194236
1584
1585 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1586 amd64 stable, security bug 194236
1587
1588 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1589 Stable for HPPA (bug #194236).
1590
1591 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1592 alpha/ia64/sparc stable wrt security #194236
1593
1594 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1595 ruby-1.8.6_p110-r1.ebuild:
1596 ppc stable, bug #194236
1597
1598 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1599 ruby-1.8.6_p110-r1.ebuild:
1600 stable x86, security bug 194236
1601
1602 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1603 ruby-1.8.5_p113.ebuild:
1604 stable x86, security bug 194236
1605
1606 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1607 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1608 -ruby-1.8.6_p110.ebuild:
1609 Remove old versions
1610
1611*ruby-1.8.6_p110-r1 (30 Sep 2007)
1612*ruby-1.8.5_p113 (30 Sep 2007)
1613
1614 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1615 +files/ruby-1.8.5_p113-net-http-p114.patch,
1616 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1617 +ruby-1.8.6_p110-r1.ebuild:
1618 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1619 using 1.8.6-p110 as base ebuild.
1620
1621 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1622 More fixes from gentoo-dev and graaff
1623
1624 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1625 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1626
1627*ruby-1.8.6_p110 (24 Sep 2007)
1628
1629 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1630 Version bump
1631
1632*ruby-1.8.6_p36-r4 (26 Aug 2007)
1633
1634 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1635 +ruby-1.8.6_p36-r4.ebuild:
1636 Use user LDFLAGS, #181436
1637
1638 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1639 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1640 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1641 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1642
1643 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1644 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1645 -ruby-1.8.6_p36-r2.ebuild:
1646 Remove some older versions that will not be promoted to stable, keeping at
1647 least one version of each release.
1648
1649 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1650 ruby-1.8.6_p36-r3.ebuild:
1651 (QA) RESTRICT clean up.
1652
1653*ruby-1.8.6_p36-r3 (04 Jul 2007)
1654
1655 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1656 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1657 fixed memory leak loading .so bug #182946
1658
1659 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1660 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1661 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1662 ruby-1.8.6_p36-r2.ebuild:
1663 (QA) RESTRICT clean up.
1664
1665 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1666 Re-add stable keyword for alpha as per bug #181110
1667
1668 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1669 Back to ~amd64 wrt bug 181110
1670
1671 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1672 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1673
1674*ruby-1.8.6_p36-r2 (20 Jun 2007)
1675
1676 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1677 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1678
1679*ruby-1.8.6_p36-r1 (18 Jun 2007)
1680
1681 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1682 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1683 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1684 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1685 spbecker
1686
1687 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1688 Stable on amd64 wrt bug 181110
1689
1690*ruby-1.8.6_p36 (12 Jun 2007)
1691
1692 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1693 Version Bump. Bug #181379
1694
1695 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1696 Stable on mips, per #181110.
1697
1698 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1699 Stable on ppc wrt bug 181110
1700
1701 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1702 Stable for HPPA (bug #181110).
1703
1704 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1705 alpha/ia64/x86 stable wrt #181110
1706
1707 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1708 Stable on sparc wrt #181110
1709
1710 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1711 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1712
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1713 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1714 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1715 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1716 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.678

  ViewVC Help
Powered by ViewVC 1.1.20