/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.679
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.679 2014/11/11 10:35:29 ago Exp $
4
5 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
6 ruby-2.0.0_p594.ebuild:
7 Stable for ia64, wrt bug #527084
8
9*ruby-2.1.4-r1 (10 Nov 2014)
10*ruby-2.0.0_p594-r1 (10 Nov 2014)
11
12 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
13 +ruby-2.1.4-r1.ebuild:
14 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
15 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
16
17 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
18 ruby-2.0.0_p594.ebuild:
19 Stable for ppc64, wrt bug #527084
20
21 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
22 ruby-2.0.0_p594.ebuild:
23 Stable for ppc, wrt bug #527084
24
25 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
26 arm stable, bug #527084
27
28 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
29 arm stable, bug #527084
30
31 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
32 ruby-2.0.0_p594.ebuild:
33 Stable for x86, wrt bug #527084
34
35 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
36 ruby-2.0.0_p594.ebuild:
37 Stable for amd64, wrt bug #527084
38
39 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
40 ruby-2.0.0_p594.ebuild:
41 Stable for HPPA (bug #527084).
42
43*ruby-2.1.4 (27 Oct 2014)
44*ruby-2.0.0_p594 (27 Oct 2014)
45*ruby-1.9.3_p550 (27 Oct 2014)
46
47 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
48 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
49 Version bump for security bug 527084. Note that OpenSSL defaults have changed
50 in these versions which may lead to incompatibilities:
51 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
52 -openssl/
53
54 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
55 ruby-2.0.0_p481.ebuild:
56 Stable for sparc, wrt bug #512904
57
58 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
59 ruby-2.0.0_p481.ebuild:
60 Stable for ppc64, wrt bug #512904
61
62 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
63 ruby-2.0.0_p481.ebuild:
64 Stable for ppc, wrt bug #512904
65
66 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
67 ruby-2.0.0_p481.ebuild:
68 Stable for amd64, wrt bug #512904
69
70*ruby-2.1.3 (20 Sep 2014)
71
72 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
73 Version bump:
74 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
75
76*ruby-2.0.0_p576 (20 Sep 2014)
77
78 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
79 Version bump.
80
81 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
82 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
83 Depend on the rubygems virtual with an explicit SLOT now that the specific
84 rubygems versions are listed in virtual/rubygems. This will make the
85 dependencies more explicit and should decrease resolver surprises picking the
86 wrong virtual/rubygems SLOT later on.
87
88 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
89 Cleanup.
90
91 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
92 ruby-2.0.0_p481.ebuild:
93 x86 stable wrt bug #512904
94
95 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
96 Stable on alpha, bug #512904
97
98 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
99 arm stable, bug #512904
100
101 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
102 arm stable, bug #512904
103
104 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
105 ruby-2.0.0_p481.ebuild:
106 ia64 stable wrt bug #512904
107
108 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
109 Stable for HPPA (bug #512904).
110
111 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
112 Stable for HPPA (bug #512904).
113
114 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
115 -ruby-2.1.1-r1.ebuild:
116 Cleanup.
117
118 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
119 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
120 512848.
121
122*ruby-1.9.3_p547 (17 May 2014)
123
124 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
125 Version bump.
126
127*ruby-2.1.2 (10 May 2014)
128*ruby-2.0.0_p481 (10 May 2014)
129
130 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
131 +ruby-2.1.2.ebuild:
132 Version bump.
133
134 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
135 -ruby-2.0.0_p353-r2.ebuild:
136 Cleanup.
137
138 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
139 ruby-2.1.1-r1.ebuild:
140 Remove useless libruby symlinks, bug 503584.
141
142 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
143 -ruby-2.1.1.ebuild:
144 Cleanup.
145
146 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
147 Remove unneeded useflag descriptions from metadata.xml
148
149 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
150 -ruby-1.8.7_p374.ebuild:
151 Remove Ruby 1.8. See bug #434064.
152
153*ruby-2.1.1-r1 (14 Apr 2014)
154
155 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
156 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
157 Thanks to Andrew Savchenko for providing a patch.
158
159 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
160 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
161 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
162 ruby-2.1.1.ebuild:
163 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
164
165*ruby-2.1.1 (06 Mar 2014)
166
167 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
168 Version bump. Update module selection code to fix automagic dependencies.
169 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
170 503106.
171
172*ruby-2.0.0_p451 (05 Mar 2014)
173
174 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
175 Version bump. Update module selection code to fix automagic dependencies.
176 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
177 503106.
178
179*ruby-1.9.3_p545 (26 Feb 2014)
180
181 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
182 Version bump. Drop tk USE flag due to bug 500894.
183
184*ruby-2.0.0_p353-r2 (23 Feb 2014)
185
186 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
187 Backport support for uclibc, fixing bug 484534.
188
189 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
190 Stable for alpha, wrt bug #483254
191
192 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
193 Stable for sparc, wrt bug #483254
194
195 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
196 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
197 Fix slot conflicts, #498970
198
199 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
200 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
201 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
202 bug 497130.
203
204 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
205 -ruby-1.9.3_p448-r1.ebuild:
206 Remove vulnerable versions.
207
208 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
209 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
210 Remove vulnerable versions.
211
212 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
213 arm stable, bug #492282
214
215*ruby-2.0.0_p353-r1 (03 Jan 2014)
216
217 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
218 ruby-2.1.0.ebuild:
219 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
220
221 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
222 arm stable, bug #483254
223
224 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
225 ruby-2.0.0_p353.ebuild:
226 ia64 stable wrt bug #492282
227
228*ruby-2.1.0 (26 Dec 2013)
229
230 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
231 Version bump.
232
233 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
234 ia64 stable wrt bug #483254
235
236 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
237 Stable for sparc, wrt bug #492282
238
239 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
240 Stable for arm, wrt bug #492282
241
242 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
243 Stable for alpha, wrt bug #492282
244
245 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
246 ruby-2.0.0_p353.ebuild:
247 Stable for x86, wrt bug #492282
248
249 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
250 ruby-2.0.0_p353.ebuild:
251 Stable for ppc64, wrt bug #492282
252
253 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
254 ruby-2.0.0_p353.ebuild:
255 Stable for ppc, wrt bug #492282
256
257 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
258 Stable for ppc64, wrt bug #483254
259
260 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
261 Stable for ppc, wrt bug #483254
262
263 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
264 ruby-2.0.0_p353.ebuild:
265 Stable for amd64, wrt bug #492282
266
267 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
268 Stable for HPPA (bug #492282).
269
270 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
271 Stable for HPPA (bug #492282).
272
273*ruby-2.0.0_p353 (22 Nov 2013)
274*ruby-1.9.3_p484 (22 Nov 2013)
275
276 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
277 +ruby-2.0.0_p353.ebuild:
278 Version bumps for security bug 492282.
279
280*ruby-2.0.0_p247-r2 (14 Oct 2013)
281
282 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
283 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
284 2.x. Fixes bug 483466.
285
286 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
287 -ruby-1.9.3_p429.ebuild:
288 Cleanup.
289
290 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
291 Stable for HPPA (bug #483254).
292
293 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
294 Stable for x86, wrt bug #483254
295
296 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
297 Stable for amd64, wrt bug #483254
298
299 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
300 ruby-1.9.3_p448.ebuild:
301 Stable for s390, wrt bug #475074
302
303*ruby-2.0.0_p247-r1 (29 Jul 2013)
304*ruby-1.9.3_p448-r1 (29 Jul 2013)
305*ruby-1.8.7_p374-r1 (29 Jul 2013)
306
307 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
308 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
309 Revision bump to counter breakage introduced in portage 2.1.13 for bug
310 465000. Thanks to thansen for reporting.
311
312 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
313 ruby-1.9.3_p448.ebuild:
314 Stable for sparc, wrt bug #475074
315
316 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
317 ruby-1.9.3_p448.ebuild:
318 Stable for sh, wrt bug #475074
319
320 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
321 ruby-1.9.3_p448.ebuild:
322 Stable for ia64, wrt bug #475074
323
324*ruby-2.0.0_p247 (07 Jul 2013)
325
326 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
327 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
328 ruby20.
329
330 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
331 ruby-1.9.3_p448.ebuild:
332 Stable for alpha, wrt bug #475074
333
334 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
335 ruby-1.9.3_p448.ebuild:
336 Stable for ppc64, wrt bug #475074
337
338 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
339 ruby-1.9.3_p448.ebuild:
340 Stable for HPPA (bug #475074).
341
342 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
343 ruby-1.9.3_p448.ebuild:
344 Stable for ppc, wrt bug #475074
345
346 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
347 ruby-1.9.3_p448.ebuild:
348 Stable for arm, wrt bug #475074
349
350 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
351 ruby-1.9.3_p448.ebuild:
352 Stable for x86, wrt bug #475074
353
354 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
355 ruby-1.9.3_p448.ebuild:
356 Stable for amd64, wrt bug #475074
357
358*ruby-1.9.3_p448 (30 Jun 2013)
359*ruby-1.8.7_p374 (30 Jun 2013)
360
361 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
362 +ruby-1.9.3_p448.ebuild:
363 Version bumps for security bug 475074.
364
365 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
366 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
367 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
368 Cleanup. Remove vulnerable versions.
369
370 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
371 Stable for sh, wrt bug #469984
372
373 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
374 Stable for s390, wrt bug #469984
375
376 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
377 Stable for ppc64, wrt bug #469984
378
379 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
380 Stable for ia64, wrt bug #469984
381
382 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
383 Stable for alpha, wrt bug #469984
384
385 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
386 Stable for sparc, wrt bug #469984
387
388 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
389 Remove non-functional dosym calls, bug 442462.
390
391 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
392 Stable for arm, wrt bug #469984
393
394 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
395 Stable for ppc, wrt bug #469984
396
397 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
398 Stable for x86, wrt bug #469984
399
400 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
401 Stable for amd64, wrt bug #469984
402
403 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
404 Stable for HPPA (bug #469984).
405
406*ruby-1.9.3_p429 (16 May 2013)
407
408 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
409 Version bump for security bug #469984.
410
411 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
412 Stable for s390, wrt bug #437366
413
414 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
415 Stable for sparc, wrt bug #437366
416
417 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
418 Stable for ia64, wrt bug #437366
419
420 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
421 Stable for alpha, wrt bug #437366
422
423 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
424 Stable for ppc64, wrt bug #437366
425
426 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
427 Stable for arm, wrt bug #437366
428
429 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
430 Stable for sh, wrt bug #437366
431
432 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
433 Marking ruby-1.8.7_p371 ppc for bug 437366
434
435 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
436 Stable for HPPA (bug #437366).
437
438 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
439 Stable for x86, wrt bug #437366
440
441 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
442 Stable for amd64, wrt bug #437366
443
444 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
445 Stable for sh, wrt bug #458776
446
447 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
448 Stable for alpha, wrt bug #458776
449
450 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
451 Add patch to fix bug #459074 (parallel build).
452
453 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
454 Stable for arm, wrt bug #458776
455
456 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
457 Stable for s390, wrt bug #458776
458
459 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
460 Stable for sparc, wrt bug #458776
461
462 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
463 Stable for hppa, wrt bug #458776
464
465 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
466 Stable for ia64, wrt bug #458776
467
468 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
469 Stable for x86, wrt bug #458776
470
471 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
472 Stable for amd64, wrt bug #458776
473
474 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
475 Stable for ppc64, wrt bug #458776
476
477 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
478 Stable for ppc, wrt bug #458776
479
480*ruby-1.9.3_p392 (22 Feb 2013)
481
482 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
483 Version bump for security bug 458776.
484
485*ruby-1.9.3_p385 (10 Feb 2013)
486
487 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
488 Version bump. Fixes security bug 442580.
489
490 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
491 keyword ~amd64-fbsd
492
493*ruby-1.8.7_p371 (06 Jan 2013)
494
495 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
496 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
497 Version bump for security bug 437366.
498
499 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
500 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
501 Cleanup.
502
503 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
504 Stable for ppc, wrt bug #427774
505
506 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
507 Stable for HPPA (bug #411507).
508
509 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
510 alpha/ia64/s390/sh/sparc stable wrt #434480
511
512 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
513 ruby-1.9.3_p286.ebuild:
514 Remove HPPA target hack (bug #342819).
515
516 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
517 alpha/ia64/s390/sh/sparc stable wrt #411507
518
519 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
520 Stable for HPPA (bug #434480).
521
522*ruby-1.9.3_p286 (15 Oct 2012)
523
524 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
525 Version bump. Fixes bugs #437264 and #437264.
526
527 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
528 stable arm, bug #434480
529
530 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
531 stable ppc ppc64, bug #434480
532
533 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
534 Stable for x86, wrt bug #434480
535
536 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
537 ruby-1.9.3_p194-r1.ebuild:
538 Update LICENSE, bug 434332.
539
540 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
541 Stable for amd64, wrt bug #434480
542
543 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
544 Stable for amd64, wrt bug #427774
545
546 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
547 arm stable, bug #427774
548
549 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
550 ruby-1.9.3_p194-r1.ebuild:
551 Stable ppc64, bug #411507
552
553 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
554 marked x86 per bug 427774
555
556 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
557 -ruby-1.9.3_p194.ebuild:
558 Cleanup.
559
560 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
561 ppc stable #411507
562
563 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
564 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
565 424611.
566
567*ruby-1.8.7_p370 (07 Jul 2012)
568
569 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
570 Version bump. Fix bug 378567 thanks to slyfox.
571
572 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
573 x86 stable, see bug 411507
574
575 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
576 arm stable, bug #411507
577
578 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
579 Stable for amd64, wrt bug #411507
580
581*ruby-1.9.3_p194-r1 (12 May 2012)
582
583 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
584 +ruby-1.9.3_p194-r1.ebuild:
585 Revision bump to fix mkmf for parallel build/install. Also enable verbose
586 build, so that the log makes sense if it fails.
587
588*ruby-1.9.3_p194 (30 Apr 2012)
589
590 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
591 Version bump.
592
593 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
594 keyword ~amd64-fbsd
595
596*ruby-1.8.7_p358 (20 Apr 2012)
597
598 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
599 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
600 Rails 3.2.
601
602 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
603 Add ~x86-fbsd, #332593
604
605*ruby-1.9.3_p125 (18 Feb 2012)
606
607 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
608 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
609
610 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
611 add ~arm, bug #332593
612
613 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
614 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
615
616 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
617 x86 stable wrt bug #396301
618
619 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
620 Stable for HPPA (bug #396301).
621
622 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
623 Stable for ppc/ppc64; bug #396301
624
625 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
626 Marked ~hppa (bug #332593).
627
628 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
629 Add back ~alpha keyword now that rubygems is keyworded.
630
631 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
632 Stable for AMD64, wrt security bug #396301
633
634*ruby-1.8.7_p357 (28 Dec 2011)
635
636 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
637 Version bump for security bug 396301.
638
639 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
640 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
641
642 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
643 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
644 keyworded, bug 332593.
645
646 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
647 Block older versions of packages that are no longer compatible. Remove
648 ancient blocks on packags long gone from the tree.
649
650 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
651 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
652 Remove old versions.
653
654*ruby-1.9.3_p0 (18 Dec 2011)
655
656 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
657 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
658 suite which need to be diagnosed first.
659
660 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
661 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
662 #332593).
663
664 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
665 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
666 #332593).
667
668 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
669 alpha/ia64/s390/sh/sparc stable wrt #386369
670
671*ruby-1.9.3_rc1 (22 Oct 2011)
672
673 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
674 Version bump.
675
676 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
677 arm stable, bug #386369
678
679 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
680 x86 stable, bug 386369
681
682 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
683 Stable for HPPA (bug #386369).
684
685 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
686 ppc/ppc64 stable wrt #386369
687
688 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
689 Stable on amd64 wrt bug #386369
690
691 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
692 Remove vulnerable version, bug 386369.
693
694*ruby-1.8.7_p352 (30 Aug 2011)
695
696 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
697 +ruby-1.8.7_p352.ebuild:
698 Patchlevel bump for ruby:1.8. Removing old version
699
700*ruby-1.9.2_p290 (30 Aug 2011)
701
702 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
703 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
704 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
705 old patchlevels.
706
707 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
708 ruby-1.8.7_p334-r2.ebuild:
709 ppc/ppc64 stable wrt #378691
710
711*ruby-1.8.7_p334-r2 (22 Jul 2011)
712
713 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
714 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
715 for chasing down upstream and us.
716
717 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
718 Added ~mips, bug 332593
719
720 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
721 ruby-1.8.7_p334-r1.ebuild:
722 ppc64 stable wrt #369141
723
724 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
725 ia64/s390/sh/sparc stable wrt #369141
726
727 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
728 Stable for HPPA (bug #369141).
729
730 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
731 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
732
733 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
734 arm/x86 stable, bug #369141
735
736 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
737 Stable on amd64 wrt bug #369141
738
739 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
740 ruby-1.8.7_p334-r1.ebuild:
741 Stable on alpha, bug #369141
742
743*ruby-1.8.7_p334-r1 (31 May 2011)
744
745 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
746 Revision bump for security bug 369141 (CVE-2011-0188)
747
748*ruby-1.9.2-r1 (16 May 2011)
749
750 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
751 Don't remove racc files since all other ruby targets ship these files
752 themselves as well. Closes bug 363419.
753
754 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
755 ruby-1.8.7_p334.ebuild:
756 Remove old version. Remove obsolete and unused old-style virtual/ruby.
757
758 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
759 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
760
761 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
762 Add append-flags -mieee on sh, bug #357559
763
764 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
765 alpha/arm/ia64/s390/sh stable wrt #355439
766
767 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
768 Marked ~ppc64 wrt #332593
769
770 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
771 ruby-1.8.7_p334.ebuild:
772 x86 stable wrt security bug #355439
773
774 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
775 ruby-1.8.7_p334.ebuild:
776 ppc/ppc64 stable wrt #355439
777
778 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
779 Stable on amd64 wrt bug #355439
780
781 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
782 Stable for HPPA (bug #355439).
783
784*ruby-1.8.7_p334 (19 Feb 2011)
785
786 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
787 Version bump 1.8.7 series, security bug 355439
788
789 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
790 ruby-1.9.2.ebuild:
791 Remove PROVIDE for old-style virtual/ruby per bug 265054.
792
793 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
794 Remove masked ruby 1.8.6 per bug 332597.
795
796 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
797 -ruby-1.9.2_rc2.ebuild:
798 Removing old and vulnerable ebuilds
799
800 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
801 Marking ruby-1.8.7_p302 ppc64 for bug 332957
802
803 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
804 alpha/ia64/s390/sh/sparc stable wrt #332957
805
806*ruby-1.9.2 (24 Aug 2010)
807
808 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
809 metadata.xml:
810 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
811 and x86-fbsd due to a new dependency on rdoc.
812
813 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
814 arm stable, bug #332957
815
816 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
817 ruby-1.8.7_p302.ebuild:
818 x86 stable wrt security bug #332957
819
820 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
821 Stable on amd64 wrt bug #332957
822
823 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
824 Stable for PPC (bug #332957).
825
826 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
827 Stable for HPPA (bug #332957).
828
829*ruby-1.8.7_p302 (21 Aug 2010)
830
831 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
832 +ruby-1.8.7_p302.ebuild:
833 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
834 installation path.
835
836*ruby-1.8.6_p399 (19 Aug 2010)
837
838 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
839 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
840 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
841 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
842 installation path (reported by the x86 team in bug 332597)
843
844*ruby-1.9.2_rc2-r1 (18 Aug 2010)
845
846 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
847 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
848 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
849 the rubygems loading code. Add USE flag for psych.
850
851 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
852 ruby-1.9.2_rc2.ebuild:
853 Remove two keepdir that will try to keep an empty path, closes bug
854 #333163.
855
856 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
857 Marked ~ppc (bug #332593).
858
859 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
860 ruby-1.9.2_rc2.ebuild:
861 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
862
863 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
864 ruby-1.8.7_p299.ebuild:
865 Bump eselect-ruby dependency
866
867 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
868 -ruby-1.9.1_p429.ebuild:
869 Remove ebuild that is not target for unmask anyway.
870
871 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
872 ruby-1.9.2_rc2.ebuild:
873 Try 2 to fix the berkdb 5 issue on 1.9.
874
875 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
876 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
877 ruby-1.9.2_rc2.ebuild:
878 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
879 support for adding new patchsets without bumping the revision for all the
880 old ebuilds as well.
881
882*ruby-1.9.2_rc2 (14 Jul 2010)
883
884 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
885 +ruby-1.9.2_rc2.ebuild:
886 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
887 might cause _further_ build failures as it changed slightly behaviour.
888 You're going to need to rebuild rubygems and then all the packages
889 previously installed after upgrading to this.
890
891 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
892 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
893 -ruby-1.9.1_p376.ebuild:
894 Cleanup old versions.
895
896*ruby-1.9.1_p429 (04 Jul 2010)
897
898 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
899 +ruby-1.9.1_p429.ebuild:
900 Version bump to new 1.9.1 release.
901
902*ruby-1.8.7_p299 (23 Jun 2010)
903
904 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
905 +ruby-1.8.7_p299.ebuild:
906 Version bump.
907
908 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
909 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
910 remove useless comments
911
912 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
913 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
914 ruby-1.9.1_p376.ebuild:
915 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
916 dev.gentoo.org now.
917
918 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
919 ruby-1.9.1_p376.ebuild:
920 Use the correct RUBYLIB.
921
922*ruby-1.8.7_p249-r2 (18 May 2010)
923*ruby-1.8.6_p388-r1 (18 May 2010)
924
925 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
926 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
927 ruby-1.9.1_p376.ebuild, metadata.xml:
928 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
929 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
930 add USE flags for ncurses, readline and libedit, and properly depend on
931 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
932 Emacs versions support ruby-mode themselves and it should be even more
933 updated.
934
935*ruby-1.8.7_p249-r1 (06 May 2010)
936
937 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
938 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
939 309789 by Sune Kloppenborg Jeppesen.
940
941 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
942 ruby-1.8.7_p249.ebuild:
943 Use $PVR instead of $PV in patchset names
944
945 06 May 2010; Alex Legler <a3li@gentoo.org>
946 -files/ruby-1.8.6-memory-leak.diff,
947 -files/ruby18-mkmf-parallel-install.patch,
948 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
949 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
950 Remove old version. Cleanup in files/
951
952*ruby-1.9.1_p376 (01 May 2010)
953
954 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
955 Version bump. Fixes security bugs 296052 and 300468. No longer installs
956 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
957 instead.
958
959 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
960 -ruby-1.8.7_p174-r1.ebuild:
961 Remove vulnerable ebuilds, 300468
962
963 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
964 ruby-1.8.7_p249.ebuild:
965 amd64 stable, security bug 300468
966
967 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
968 ruby-1.8.7_p249.ebuild:
969 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
970
971 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
972 Stable for HPPA (bug #300468).
973
974 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
975 Stable for HPPA (bug #300468).
976
977 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
978 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
979
980 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
981 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
982
983 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
984 ruby-1.8.6_p388.ebuild:
985 stable x86, security bug 300468
986
987 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
988 ruby-1.8.7_p249.ebuild:
989 stable x86, security bug 300468
990
991*ruby-1.8.6_p388 (10 Jan 2010)
992
993 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
994 +ruby-1.8.6_p388.ebuild:
995 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
996 version. The new ebuild also has the fix for bug 168939.
997
998*ruby-1.8.7_p249 (10 Jan 2010)
999
1000 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1001 +ruby-1.8.7_p249.ebuild:
1002 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1003 version
1004
1005 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1006 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1007
1008*ruby-1.8.7_p248 (25 Dec 2009)
1009
1010 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1011 Version bump
1012
1013 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1014 Remove old version.
1015
1016 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1017 Remove old version.
1018
1019 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1020 ia64/s390/sh stable wrt #288699
1021
1022 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1023 stable sparc, bug 288699
1024
1025 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1026 arm stable, bug #288699
1027
1028 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1029 amd64/x86 stable, bug #288699
1030
1031 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1032 ruby-1.8.7_p174-r1.ebuild:
1033 Stable on alpha, bug #288699
1034
1035 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1036 ppc stable #288699
1037
1038 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1039 Stable for HPPA (bug #288699).
1040
1041 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1042 Marked ~hppa too.
1043
1044*ruby-1.8.7_p174-r1 (06 Oct 2009)
1045
1046 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1047 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1048 eselect-ruby cleanup feature.
1049
1050*ruby-1.9.1_p243 (09 Sep 2009)
1051
1052 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1053 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1054 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1055 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1056 -files/ruby19-rubygems-proxy.patch,
1057 -files/ruby-1.9.1_p129-parallelmake.patch,
1058 -files/ruby19-mkmf-parallel-install.patch:
1059 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1060 168939. Cleaning up old patches.
1061
1062*ruby-1.8.6_p383 (20 Aug 2009)
1063
1064 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1065 Patchlevel bump.
1066
1067 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1068 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1069 ruby-1.9.1_p129-r1.ebuild:
1070 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1071
1072 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1073 Removing vulnerable ebuild, bug 273213.
1074
1075 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1076 Marking ruby-1.8.6_p369 ppc for bug 273213
1077
1078 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1079 ruby-1.9.1_p129-r1.ebuild:
1080 Prepend our library path instead of overwriting it during src_install.
1081 Thanks to the reporter of bug #274824.
1082
1083*ruby-1.8.7_p174 (18 Jun 2009)
1084
1085 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1086 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1087 Replacing 187_p173 with _p174 because of a regression. Unifying the
1088 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1089 patchsets.
1090
1091 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1092 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1093
1094 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1095 arm/ia64/s390/sh/sparc stable wrt #273213
1096
1097 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1098 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1099 Removing old version, minor cleanup
1100
1101 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1102 -files/ruby-1.8.6-openssl.patch,
1103 -files/ruby-1.8.6-shortname_constants.patch,
1104 -files/ruby-1.8.6_p111-r13657.patch,
1105 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1106 Removing vulnerable old Ruby version and stale patches, bug 274108.
1107
1108 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1109 ruby-1.8.6_p369.ebuild:
1110 Stable on alpha, bug #273213
1111
1112 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1113 Stable for HPPA (bug #273213).
1114
1115 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1116 ruby-1.8.6_p369.ebuild:
1117 stable x86, security bug 273213
1118
1119 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1120 amd64 stable, security bug 273213.
1121
1122*ruby-1.8.7_p173 (10 Jun 2009)
1123*ruby-1.8.6_p369 (10 Jun 2009)
1124
1125 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1126 +ruby-1.8.7_p173.ebuild:
1127 Version bumps for bug #273213.
1128
1129*ruby-1.9.1_p129-r1 (27 May 2009)
1130
1131 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1132 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1133 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1134 +files/ruby-1.9.1_p129-parallelmake.patch:
1135 Revision bump, add patches 1) to make Ruby behave more similarly between
1136 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1137 extensions (undefined symbols in them will cause abort at runtime 3) to
1138 remove a concurrency issue when building the dl extension that could
1139 result in a broken dl.so.
1140
1141 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1142 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1143 Don't block rdoc-2 or later (which may enter Portage one day as it's
1144 needed by some Rakefiles).
1145
1146 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1147 ruby-1.9.1_p129.ebuild:
1148 Add ~x86-fbsd keyword.
1149
1150 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1151 keyword ~sparc-fbsd, bug #252315
1152
1153*ruby-1.9.1_p129 (15 May 2009)
1154
1155 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1156 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1157 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1158 included in every release.
1159
1160 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1161 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1162 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1163 ruby-1.8.7_p160.ebuild:
1164 Removing vulnerable versions (#268515), fixing license (#233747).
1165
1166 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1167 Stable for HPPA (bug #268515).
1168
1169 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1170 Adapting rubygems notice.
1171
1172 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1173 amd64 stable, bug #268515.
1174
1175 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1176 arm/ia64/s390/sh/sparc stable wrt #268515
1177
1178 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1179 ruby-1.8.6_p368.ebuild:
1180 stable x86, security bug 268515
1181
1182 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1183 ruby-1.8.6_p368.ebuild:
1184 Stable on alpha, bug #268515
1185
1186 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1187 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1188
1189*ruby-1.8.7_p160 (07 May 2009)
1190*ruby-1.8.6_p368 (07 May 2009)
1191
1192 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1193 +ruby-1.8.7_p160.ebuild:
1194 Version bump as per secbug 268515. NB: These are the first ebuilds that
1195 no longer use ruby-config.
1196
1197*ruby-1.9.1-r1 (03 Apr 2009)
1198*ruby-1.8.7_p72-r11 (03 Apr 2009)
1199*ruby-1.8.6_p287-r13 (03 Apr 2009)
1200
1201 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1202 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1203 +files/ruby18-mkmf-parallel-install.patch,
1204 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1205 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1206 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1207 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1208 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1209 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1210 happy.
1211
1212*ruby-1.9.1 (21 Mar 2009)
1213
1214 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1215 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1216 +ruby-1.9.1.ebuild:
1217 Adding Ruby 1.9.1 for preliminary testing
1218
1219 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1220 ruby-1.8.6_p287-r12.ebuild:
1221 Marked ~ppc for bug #252315.
1222
1223 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1224 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1225 bug 261982.
1226
1227 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1228 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1229 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1230 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1231 Cleanup
1232
1233*ruby-1.8.7_p72-r10 (07 Mar 2009)
1234
1235 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1236 +ruby-1.8.7_p72-r10.ebuild:
1237 Add a revision of ruby 1.8.7 using eselect ruby.
1238
1239 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1240 ~mips keyworded, bug #252315.
1241
1242 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1243 ruby-1.8.6_p287-r5.ebuild:
1244 ppc stable, bug #260006
1245
1246 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1247 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1248
1249 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1250 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1251 Fixing Tk USE flag test, bug 258893.
1252
1253 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1254 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1255
1256 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1257 ruby-1.8.6_p287-r5.ebuild:
1258 amd64 stable wrt security bug #260006
1259
1260 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1261 Stable for HPPA (bug #260006).
1262
1263 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1264 ruby-1.8.6_p287-r5.ebuild:
1265 Stable on alpha, bug #260006
1266
1267*ruby-1.8.7_p72-r2 (23 Feb 2009)
1268*ruby-1.8.6_p287-r12 (23 Feb 2009)
1269*ruby-1.8.6_p287-r5 (23 Feb 2009)
1270
1271 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1272 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1273 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1274 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1275 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1276 now before compilation if Tk useflags don't match) and 230748 (adding
1277 --enable-option-checking=no for newer versions of autoconf).
1278
1279 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1280 arm/ia64/s390/sh/sparc stable wrt #254307
1281
1282 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1283 ruby-1.8.6_p287-r4.ebuild:
1284 Stable on alpha, bug #254307
1285
1286 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1287 ruby-1.8.6_p287-r11.ebuild:
1288 keyword ~x86-fbsd, bug #252315
1289
1290 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1291 ppc stable #254307
1292
1293 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1294 amd64/x86 stable, bug #254307
1295
1296 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1297 stable ppc64, bug 254307
1298
1299 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1300 Stable for HPPA (bug #254307).
1301
1302 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1303 ruby-1.8.6_p287-r11.ebuild:
1304 Marked ~hppa (bug #252315).
1305
1306*ruby-1.8.6_p287-r11 (11 Jan 2009)
1307
1308 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1309 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1310 +ruby-1.8.6_p287-r11.ebuild:
1311 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1312 Fixes #254307.
1313
1314 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1315 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1316
1317 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1318 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1319
1320 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1321 ruby-1.8.6_p287-r10.ebuild:
1322 Add ~sparc keyword, bug #252315
1323
1324*ruby-1.8.6_p287-r10 (23 Dec 2008)
1325
1326 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1327 +ruby-1.8.6_p287-r10.ebuild:
1328 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1329 keywords since eselect-ruby does not yet have these keywords.
1330
1331 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1332 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1333 Revert the ruby-config changes. We can't remove them until we provide an
1334 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1335 for breaking things as mentioned in bug #251833.
1336
1337 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1338 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1339 ruby-1.8.7_p72-r1.ebuild:
1340 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1341 Thanks for the people noticing this in bug #251833.
1342
1343 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1344 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1345 ruby-1.8.7_p72-r1.ebuild:
1346 Drop dependency on ruby-config, which will be removed from the tree. We
1347 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1348 is no need for ruby-config at this moment. For newer versions of Ruby we will
1349 use eselect-ruby, which can be found in the ruby overlay at the moment.
1350
1351 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1352 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1353 Use mirror://ruby in SRC_URI, fixes #237392.
1354
1355 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1356 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1357 -ruby-1.8.7_p72.ebuild:
1358 Remove old versions. Leave one old stable version with cjk support.
1359
1360*ruby-1.8.6_p287-r3 (29 Nov 2008)
1361
1362 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1363 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1364 +ruby-1.8.6_p287-r3.ebuild:
1365 Fix our expansion limit patch according to debian bug report
1366 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1367 make sure people will pick up the fixed version. Thanks to Alex Legler for
1368 mentioning the patch.
1369
1370*ruby-1.8.7_p72-r1 (26 Nov 2008)
1371*ruby-1.8.6_p287-r2 (26 Nov 2008)
1372
1373 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1374 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1375 +ruby-1.8.7_p72-r1.ebuild:
1376 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1377 Thanks to Alex Legler for providing the patch.
1378
1379 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1380 -ruby-1.8.6_p287.ebuild:
1381 Remove versions that will not become stable
1382
1383 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1384 ruby-1.8.6_p287-r1.ebuild:
1385 ppc stable, bug #225465
1386
1387 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1388 ruby-1.8.6_p287-r1.ebuild:
1389 amd64 stable wrt security bug #225465
1390
1391 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1392 alpha/ia64/x86 stable wrt #225465
1393
1394 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1395 ruby-1.8.6_p287-r1.ebuild:
1396 Sparc stable --- Security Bug #225465 --- good since late August.
1397
1398 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1399 Stable on ppc64; bug #225465
1400
1401 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1402 Stable for HPPA (bug #225465).
1403
1404*ruby-1.8.6_p287-r1 (29 Aug 2008)
1405
1406 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1407 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1408 +ruby-1.8.6_p287-r1.ebuild:
1409 Fix REXML security issues, bug #236060.
1410
1411 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1412 Add GLEP 56 USE flag descriptions.
1413
1414*ruby-1.8.7_p72 (15 Aug 2008)
1415
1416 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1417 +ruby-1.8.7_p72.ebuild:
1418 bump 1.8.7 to latest patch release
1419
1420*ruby-1.8.6_p287 (11 Aug 2008)
1421
1422 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1423 Version bump for brown paper bag relelease.
1424
1425 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1426 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1427 Remove broken version in favor of the just-added 1.8.6_p286
1428
1429*ruby-1.8.6_p286 (10 Aug 2008)
1430
1431 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1432 Version bump to latest released version of ruby 1.8.6. This version fixes the
1433 security issues reported in #225465 and #234224. The cjk USE flag has been
1434 dropped since no compatible patches have been released yet.
1435
1436 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1437 ruby-1.8.6_p230.ebuild:
1438 drop cjk from SRC_URI as well
1439
1440 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1441 Drop cjk support since the most recent oniguruma patches no longer apply to
1442 this version, #230111.
1443
1444 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1445 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1446 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1447 Unfortunately the official p230 has a change which causes segmentation faults
1448 for applications like Rails and RSpec, so we are reverting that specific
1449 change.
1450
1451*ruby-1.8.7_p22 (29 Jun 2008)
1452
1453 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1454 +ruby-1.8.7_p22.ebuild:
1455 bump 1.8.7 for security fix
1456
1457 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1458 nevermind, don't bump this yet
1459
1460*ruby-1.8.6_p230 (20 Jun 2008)
1461
1462 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1463 version bump
1464
1465*ruby-1.8.7 (10 Jun 2008)
1466
1467 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1468 +ruby-1.8.7.ebuild:
1469 bump 1.8.7 to final
1470
1471*ruby-1.8.7_pre2 (21 Apr 2008)
1472
1473 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1474 +ruby-1.8.7_pre2.ebuild:
1475 Version Bump
1476
1477*ruby-1.8.7_pre1 (16 Apr 2008)
1478
1479 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1480 Version bump. Drop cjk until a new version of oniguruma appears.
1481
1482 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1483 amd64 stable, bug 212264
1484
1485 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1486 Stable for HPPA (bug #212264).
1487
1488 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1489 ruby-1.8.6_p114.ebuild:
1490 ppc stable, bug #212264
1491
1492 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1493 alpha/ia64 stable wrt #212264
1494
1495 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1496 ruby-1.8.6_p114.ebuild:
1497 stable x86, security bug 212264
1498
1499 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1500 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1501 as expected.
1502
1503 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1504 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1505
1506*ruby-1.8.6_p114 (05 Mar 2008)
1507
1508 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1509 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1510 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1511 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1512 Version bump for #212264. Remove old ebuilds.
1513
1514 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1515 alpha/ia64 stable wrt #208916
1516
1517 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1518 Stable on ppc wrt bug 208916
1519
1520 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1521 x86 stable, bug #208916
1522
1523 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1524 ruby-1.8.6_p111-r1.ebuild:
1525 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1526
1527 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1528 -files/ruby-1.8.6-exit-status.patch,
1529 -files/ruby-1.8.6_p110-net-http-p111.patch,
1530 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1531 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1532 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1533 Remove old versions
1534
1535 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1536 Stable on ppc64
1537
1538 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1539 Stable on amd64; bug 199191
1540
1541 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1542 alpha/ia64/sparc stable wrt #199191
1543
1544 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1545 Remove now-obsolete warning about coreutils versions, #203156.
1546
1547 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1548 Stable for HPPA (bug #199191).
1549
1550*ruby-1.8.6_p111-r1 (23 Dec 2007)
1551
1552 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1553 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1554 ssl USE flags. Patch to p113.
1555
1556 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1557 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1558
1559 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1560 x86 stable, security bug #199191
1561
1562*ruby-1.8.6_p111 (23 Dec 2007)
1563
1564 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1565 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1566 Version bump with patch for bug #199191
1567
1568 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1569 Move dependency on (X)Emacs modes to PDEPEND.
1570
1571 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1572 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1573 bug 196413
1574
1575*ruby-1.8.6_p110-r2 (21 Oct 2007)
1576
1577 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1578 +ruby-1.8.6_p110-r2.ebuild:
1579 Add emacs and xemacs USE flags and use them to pull in the correct editing
1580 mode for each. Had to drop several arch keywords as reported on bug 196413.
1581
1582 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1583 amd64 stable, security bug 194236
1584
1585 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1586 ruby-1.8.6_p110-r1.ebuild:
1587 Stable on ppc64; bug #194236
1588
1589 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1590 amd64 stable, security bug 194236
1591
1592 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1593 Stable for HPPA (bug #194236).
1594
1595 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1596 alpha/ia64/sparc stable wrt security #194236
1597
1598 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1599 ruby-1.8.6_p110-r1.ebuild:
1600 ppc stable, bug #194236
1601
1602 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1603 ruby-1.8.6_p110-r1.ebuild:
1604 stable x86, security bug 194236
1605
1606 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1607 ruby-1.8.5_p113.ebuild:
1608 stable x86, security bug 194236
1609
1610 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1611 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1612 -ruby-1.8.6_p110.ebuild:
1613 Remove old versions
1614
1615*ruby-1.8.6_p110-r1 (30 Sep 2007)
1616*ruby-1.8.5_p113 (30 Sep 2007)
1617
1618 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1619 +files/ruby-1.8.5_p113-net-http-p114.patch,
1620 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1621 +ruby-1.8.6_p110-r1.ebuild:
1622 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1623 using 1.8.6-p110 as base ebuild.
1624
1625 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1626 More fixes from gentoo-dev and graaff
1627
1628 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1629 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1630
1631*ruby-1.8.6_p110 (24 Sep 2007)
1632
1633 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1634 Version bump
1635
1636*ruby-1.8.6_p36-r4 (26 Aug 2007)
1637
1638 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1639 +ruby-1.8.6_p36-r4.ebuild:
1640 Use user LDFLAGS, #181436
1641
1642 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1643 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1644 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1645 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1646
1647 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1648 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1649 -ruby-1.8.6_p36-r2.ebuild:
1650 Remove some older versions that will not be promoted to stable, keeping at
1651 least one version of each release.
1652
1653 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1654 ruby-1.8.6_p36-r3.ebuild:
1655 (QA) RESTRICT clean up.
1656
1657*ruby-1.8.6_p36-r3 (04 Jul 2007)
1658
1659 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1660 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1661 fixed memory leak loading .so bug #182946
1662
1663 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1664 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1665 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1666 ruby-1.8.6_p36-r2.ebuild:
1667 (QA) RESTRICT clean up.
1668
1669 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1670 Re-add stable keyword for alpha as per bug #181110
1671
1672 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1673 Back to ~amd64 wrt bug 181110
1674
1675 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1676 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1677
1678*ruby-1.8.6_p36-r2 (20 Jun 2007)
1679
1680 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1681 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1682
1683*ruby-1.8.6_p36-r1 (18 Jun 2007)
1684
1685 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1686 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1687 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1688 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1689 spbecker
1690
1691 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1692 Stable on amd64 wrt bug 181110
1693
1694*ruby-1.8.6_p36 (12 Jun 2007)
1695
1696 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1697 Version Bump. Bug #181379
1698
1699 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1700 Stable on mips, per #181110.
1701
1702 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1703 Stable on ppc wrt bug 181110
1704
1705 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1706 Stable for HPPA (bug #181110).
1707
1708 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1709 alpha/ia64/x86 stable wrt #181110
1710
1711 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1712 Stable on sparc wrt #181110
1713
1714 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1715 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1716
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1717 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1718 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1719 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1720 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.679

  ViewVC Help
Powered by ViewVC 1.1.20