/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.687
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.687 2014/11/28 14:02:14 ago Exp $
4
5 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
6 ruby-2.0.0_p598.ebuild:
7 Stable for ppc, wrt bug #529216
8
9 26 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p551.ebuild,
10 ruby-2.0.0_p598.ebuild:
11 Stable for HPPA (bug #529216).
12
13 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
14 ruby-2.0.0_p598.ebuild:
15 Stable for x86, wrt bug #529216
16
17 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
18 ruby-2.0.0_p598.ebuild:
19 Stable for amd64, wrt bug #529216
20
21*ruby-2.1.5 (14 Nov 2014)
22*ruby-2.0.0_p598 (14 Nov 2014)
23*ruby-1.9.3_p551 (14 Nov 2014)
24
25 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p551.ebuild,
26 +ruby-2.0.0_p598.ebuild, +ruby-2.1.5.ebuild:
27 Version bumps for security bug 529216.
28
29 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p484.ebuild,
30 -ruby-1.9.3_p547.ebuild, -ruby-2.0.0_p353.ebuild, -ruby-2.0.0_p481.ebuild,
31 -ruby-2.0.0_p576.ebuild, -ruby-2.1.2.ebuild, -ruby-2.1.3.ebuild:
32 Cleanup.
33
34 12 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
35 ruby-2.0.0_p594.ebuild:
36 Stable for alpha, wrt bug #527084
37
38 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
39 ruby-2.0.0_p594.ebuild:
40 Stable for sparc, wrt bug #527084
41
42 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
43 ruby-2.0.0_p594.ebuild:
44 Stable for ia64, wrt bug #527084
45
46*ruby-2.1.4-r1 (10 Nov 2014)
47*ruby-2.0.0_p594-r1 (10 Nov 2014)
48
49 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
50 +ruby-2.1.4-r1.ebuild:
51 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
52 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
53
54 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
55 ruby-2.0.0_p594.ebuild:
56 Stable for ppc64, wrt bug #527084
57
58 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
59 ruby-2.0.0_p594.ebuild:
60 Stable for ppc, wrt bug #527084
61
62 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
63 arm stable, bug #527084
64
65 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
66 arm stable, bug #527084
67
68 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
69 ruby-2.0.0_p594.ebuild:
70 Stable for x86, wrt bug #527084
71
72 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
73 ruby-2.0.0_p594.ebuild:
74 Stable for amd64, wrt bug #527084
75
76 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
77 ruby-2.0.0_p594.ebuild:
78 Stable for HPPA (bug #527084).
79
80*ruby-2.1.4 (27 Oct 2014)
81*ruby-2.0.0_p594 (27 Oct 2014)
82*ruby-1.9.3_p550 (27 Oct 2014)
83
84 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
85 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
86 Version bump for security bug 527084. Note that OpenSSL defaults have changed
87 in these versions which may lead to incompatibilities:
88 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
89 -openssl/
90
91 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
92 ruby-2.0.0_p481.ebuild:
93 Stable for sparc, wrt bug #512904
94
95 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
96 ruby-2.0.0_p481.ebuild:
97 Stable for ppc64, wrt bug #512904
98
99 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
100 ruby-2.0.0_p481.ebuild:
101 Stable for ppc, wrt bug #512904
102
103 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
104 ruby-2.0.0_p481.ebuild:
105 Stable for amd64, wrt bug #512904
106
107*ruby-2.1.3 (20 Sep 2014)
108
109 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
110 Version bump:
111 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
112
113*ruby-2.0.0_p576 (20 Sep 2014)
114
115 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
116 Version bump.
117
118 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
119 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
120 Depend on the rubygems virtual with an explicit SLOT now that the specific
121 rubygems versions are listed in virtual/rubygems. This will make the
122 dependencies more explicit and should decrease resolver surprises picking the
123 wrong virtual/rubygems SLOT later on.
124
125 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
126 Cleanup.
127
128 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
129 ruby-2.0.0_p481.ebuild:
130 x86 stable wrt bug #512904
131
132 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
133 Stable on alpha, bug #512904
134
135 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
136 arm stable, bug #512904
137
138 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
139 arm stable, bug #512904
140
141 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
142 ruby-2.0.0_p481.ebuild:
143 ia64 stable wrt bug #512904
144
145 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
146 Stable for HPPA (bug #512904).
147
148 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
149 Stable for HPPA (bug #512904).
150
151 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
152 -ruby-2.1.1-r1.ebuild:
153 Cleanup.
154
155 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
156 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
157 512848.
158
159*ruby-1.9.3_p547 (17 May 2014)
160
161 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
162 Version bump.
163
164*ruby-2.1.2 (10 May 2014)
165*ruby-2.0.0_p481 (10 May 2014)
166
167 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
168 +ruby-2.1.2.ebuild:
169 Version bump.
170
171 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
172 -ruby-2.0.0_p353-r2.ebuild:
173 Cleanup.
174
175 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
176 ruby-2.1.1-r1.ebuild:
177 Remove useless libruby symlinks, bug 503584.
178
179 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
180 -ruby-2.1.1.ebuild:
181 Cleanup.
182
183 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
184 Remove unneeded useflag descriptions from metadata.xml
185
186 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
187 -ruby-1.8.7_p374.ebuild:
188 Remove Ruby 1.8. See bug #434064.
189
190*ruby-2.1.1-r1 (14 Apr 2014)
191
192 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
193 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
194 Thanks to Andrew Savchenko for providing a patch.
195
196 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
197 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
198 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
199 ruby-2.1.1.ebuild:
200 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
201
202*ruby-2.1.1 (06 Mar 2014)
203
204 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
205 Version bump. Update module selection code to fix automagic dependencies.
206 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
207 503106.
208
209*ruby-2.0.0_p451 (05 Mar 2014)
210
211 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
212 Version bump. Update module selection code to fix automagic dependencies.
213 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
214 503106.
215
216*ruby-1.9.3_p545 (26 Feb 2014)
217
218 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
219 Version bump. Drop tk USE flag due to bug 500894.
220
221*ruby-2.0.0_p353-r2 (23 Feb 2014)
222
223 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
224 Backport support for uclibc, fixing bug 484534.
225
226 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
227 Stable for alpha, wrt bug #483254
228
229 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
230 Stable for sparc, wrt bug #483254
231
232 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
233 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
234 Fix slot conflicts, #498970
235
236 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
237 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
238 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
239 bug 497130.
240
241 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
242 -ruby-1.9.3_p448-r1.ebuild:
243 Remove vulnerable versions.
244
245 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
246 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
247 Remove vulnerable versions.
248
249 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
250 arm stable, bug #492282
251
252*ruby-2.0.0_p353-r1 (03 Jan 2014)
253
254 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
255 ruby-2.1.0.ebuild:
256 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
257
258 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
259 arm stable, bug #483254
260
261 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
262 ruby-2.0.0_p353.ebuild:
263 ia64 stable wrt bug #492282
264
265*ruby-2.1.0 (26 Dec 2013)
266
267 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
268 Version bump.
269
270 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
271 ia64 stable wrt bug #483254
272
273 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
274 Stable for sparc, wrt bug #492282
275
276 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
277 Stable for arm, wrt bug #492282
278
279 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
280 Stable for alpha, wrt bug #492282
281
282 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
283 ruby-2.0.0_p353.ebuild:
284 Stable for x86, wrt bug #492282
285
286 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
287 ruby-2.0.0_p353.ebuild:
288 Stable for ppc64, wrt bug #492282
289
290 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
291 ruby-2.0.0_p353.ebuild:
292 Stable for ppc, wrt bug #492282
293
294 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
295 Stable for ppc64, wrt bug #483254
296
297 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
298 Stable for ppc, wrt bug #483254
299
300 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
301 ruby-2.0.0_p353.ebuild:
302 Stable for amd64, wrt bug #492282
303
304 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
305 Stable for HPPA (bug #492282).
306
307 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
308 Stable for HPPA (bug #492282).
309
310*ruby-2.0.0_p353 (22 Nov 2013)
311*ruby-1.9.3_p484 (22 Nov 2013)
312
313 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
314 +ruby-2.0.0_p353.ebuild:
315 Version bumps for security bug 492282.
316
317*ruby-2.0.0_p247-r2 (14 Oct 2013)
318
319 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
320 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
321 2.x. Fixes bug 483466.
322
323 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
324 -ruby-1.9.3_p429.ebuild:
325 Cleanup.
326
327 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
328 Stable for HPPA (bug #483254).
329
330 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
331 Stable for x86, wrt bug #483254
332
333 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
334 Stable for amd64, wrt bug #483254
335
336 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
337 ruby-1.9.3_p448.ebuild:
338 Stable for s390, wrt bug #475074
339
340*ruby-2.0.0_p247-r1 (29 Jul 2013)
341*ruby-1.9.3_p448-r1 (29 Jul 2013)
342*ruby-1.8.7_p374-r1 (29 Jul 2013)
343
344 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
345 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
346 Revision bump to counter breakage introduced in portage 2.1.13 for bug
347 465000. Thanks to thansen for reporting.
348
349 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
350 ruby-1.9.3_p448.ebuild:
351 Stable for sparc, wrt bug #475074
352
353 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
354 ruby-1.9.3_p448.ebuild:
355 Stable for sh, wrt bug #475074
356
357 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
358 ruby-1.9.3_p448.ebuild:
359 Stable for ia64, wrt bug #475074
360
361*ruby-2.0.0_p247 (07 Jul 2013)
362
363 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
364 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
365 ruby20.
366
367 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
368 ruby-1.9.3_p448.ebuild:
369 Stable for alpha, wrt bug #475074
370
371 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
372 ruby-1.9.3_p448.ebuild:
373 Stable for ppc64, wrt bug #475074
374
375 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
376 ruby-1.9.3_p448.ebuild:
377 Stable for HPPA (bug #475074).
378
379 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
380 ruby-1.9.3_p448.ebuild:
381 Stable for ppc, wrt bug #475074
382
383 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
384 ruby-1.9.3_p448.ebuild:
385 Stable for arm, wrt bug #475074
386
387 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
388 ruby-1.9.3_p448.ebuild:
389 Stable for x86, wrt bug #475074
390
391 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
392 ruby-1.9.3_p448.ebuild:
393 Stable for amd64, wrt bug #475074
394
395*ruby-1.9.3_p448 (30 Jun 2013)
396*ruby-1.8.7_p374 (30 Jun 2013)
397
398 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
399 +ruby-1.9.3_p448.ebuild:
400 Version bumps for security bug 475074.
401
402 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
403 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
404 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
405 Cleanup. Remove vulnerable versions.
406
407 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
408 Stable for sh, wrt bug #469984
409
410 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
411 Stable for s390, wrt bug #469984
412
413 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
414 Stable for ppc64, wrt bug #469984
415
416 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
417 Stable for ia64, wrt bug #469984
418
419 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
420 Stable for alpha, wrt bug #469984
421
422 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
423 Stable for sparc, wrt bug #469984
424
425 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
426 Remove non-functional dosym calls, bug 442462.
427
428 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
429 Stable for arm, wrt bug #469984
430
431 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
432 Stable for ppc, wrt bug #469984
433
434 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
435 Stable for x86, wrt bug #469984
436
437 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
438 Stable for amd64, wrt bug #469984
439
440 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
441 Stable for HPPA (bug #469984).
442
443*ruby-1.9.3_p429 (16 May 2013)
444
445 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
446 Version bump for security bug #469984.
447
448 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
449 Stable for s390, wrt bug #437366
450
451 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
452 Stable for sparc, wrt bug #437366
453
454 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
455 Stable for ia64, wrt bug #437366
456
457 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
458 Stable for alpha, wrt bug #437366
459
460 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
461 Stable for ppc64, wrt bug #437366
462
463 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
464 Stable for arm, wrt bug #437366
465
466 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
467 Stable for sh, wrt bug #437366
468
469 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
470 Marking ruby-1.8.7_p371 ppc for bug 437366
471
472 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
473 Stable for HPPA (bug #437366).
474
475 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
476 Stable for x86, wrt bug #437366
477
478 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
479 Stable for amd64, wrt bug #437366
480
481 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
482 Stable for sh, wrt bug #458776
483
484 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
485 Stable for alpha, wrt bug #458776
486
487 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
488 Add patch to fix bug #459074 (parallel build).
489
490 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
491 Stable for arm, wrt bug #458776
492
493 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
494 Stable for s390, wrt bug #458776
495
496 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
497 Stable for sparc, wrt bug #458776
498
499 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
500 Stable for hppa, wrt bug #458776
501
502 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
503 Stable for ia64, wrt bug #458776
504
505 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
506 Stable for x86, wrt bug #458776
507
508 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
509 Stable for amd64, wrt bug #458776
510
511 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
512 Stable for ppc64, wrt bug #458776
513
514 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
515 Stable for ppc, wrt bug #458776
516
517*ruby-1.9.3_p392 (22 Feb 2013)
518
519 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
520 Version bump for security bug 458776.
521
522*ruby-1.9.3_p385 (10 Feb 2013)
523
524 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
525 Version bump. Fixes security bug 442580.
526
527 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
528 keyword ~amd64-fbsd
529
530*ruby-1.8.7_p371 (06 Jan 2013)
531
532 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
533 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
534 Version bump for security bug 437366.
535
536 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
537 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
538 Cleanup.
539
540 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
541 Stable for ppc, wrt bug #427774
542
543 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
544 Stable for HPPA (bug #411507).
545
546 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
547 alpha/ia64/s390/sh/sparc stable wrt #434480
548
549 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
550 ruby-1.9.3_p286.ebuild:
551 Remove HPPA target hack (bug #342819).
552
553 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
554 alpha/ia64/s390/sh/sparc stable wrt #411507
555
556 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
557 Stable for HPPA (bug #434480).
558
559*ruby-1.9.3_p286 (15 Oct 2012)
560
561 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
562 Version bump. Fixes bugs #437264 and #437264.
563
564 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
565 stable arm, bug #434480
566
567 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
568 stable ppc ppc64, bug #434480
569
570 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
571 Stable for x86, wrt bug #434480
572
573 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
574 ruby-1.9.3_p194-r1.ebuild:
575 Update LICENSE, bug 434332.
576
577 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
578 Stable for amd64, wrt bug #434480
579
580 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
581 Stable for amd64, wrt bug #427774
582
583 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
584 arm stable, bug #427774
585
586 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
587 ruby-1.9.3_p194-r1.ebuild:
588 Stable ppc64, bug #411507
589
590 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
591 marked x86 per bug 427774
592
593 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
594 -ruby-1.9.3_p194.ebuild:
595 Cleanup.
596
597 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
598 ppc stable #411507
599
600 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
601 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
602 424611.
603
604*ruby-1.8.7_p370 (07 Jul 2012)
605
606 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
607 Version bump. Fix bug 378567 thanks to slyfox.
608
609 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
610 x86 stable, see bug 411507
611
612 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
613 arm stable, bug #411507
614
615 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
616 Stable for amd64, wrt bug #411507
617
618*ruby-1.9.3_p194-r1 (12 May 2012)
619
620 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
621 +ruby-1.9.3_p194-r1.ebuild:
622 Revision bump to fix mkmf for parallel build/install. Also enable verbose
623 build, so that the log makes sense if it fails.
624
625*ruby-1.9.3_p194 (30 Apr 2012)
626
627 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
628 Version bump.
629
630 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
631 keyword ~amd64-fbsd
632
633*ruby-1.8.7_p358 (20 Apr 2012)
634
635 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
636 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
637 Rails 3.2.
638
639 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
640 Add ~x86-fbsd, #332593
641
642*ruby-1.9.3_p125 (18 Feb 2012)
643
644 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
645 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
646
647 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
648 add ~arm, bug #332593
649
650 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
651 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
652
653 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
654 x86 stable wrt bug #396301
655
656 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
657 Stable for HPPA (bug #396301).
658
659 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
660 Stable for ppc/ppc64; bug #396301
661
662 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
663 Marked ~hppa (bug #332593).
664
665 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
666 Add back ~alpha keyword now that rubygems is keyworded.
667
668 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
669 Stable for AMD64, wrt security bug #396301
670
671*ruby-1.8.7_p357 (28 Dec 2011)
672
673 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
674 Version bump for security bug 396301.
675
676 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
677 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
678
679 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
680 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
681 keyworded, bug 332593.
682
683 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
684 Block older versions of packages that are no longer compatible. Remove
685 ancient blocks on packags long gone from the tree.
686
687 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
688 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
689 Remove old versions.
690
691*ruby-1.9.3_p0 (18 Dec 2011)
692
693 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
694 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
695 suite which need to be diagnosed first.
696
697 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
698 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
699 #332593).
700
701 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
702 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
703 #332593).
704
705 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
706 alpha/ia64/s390/sh/sparc stable wrt #386369
707
708*ruby-1.9.3_rc1 (22 Oct 2011)
709
710 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
711 Version bump.
712
713 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
714 arm stable, bug #386369
715
716 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
717 x86 stable, bug 386369
718
719 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
720 Stable for HPPA (bug #386369).
721
722 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
723 ppc/ppc64 stable wrt #386369
724
725 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
726 Stable on amd64 wrt bug #386369
727
728 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
729 Remove vulnerable version, bug 386369.
730
731*ruby-1.8.7_p352 (30 Aug 2011)
732
733 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
734 +ruby-1.8.7_p352.ebuild:
735 Patchlevel bump for ruby:1.8. Removing old version
736
737*ruby-1.9.2_p290 (30 Aug 2011)
738
739 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
740 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
741 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
742 old patchlevels.
743
744 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
745 ruby-1.8.7_p334-r2.ebuild:
746 ppc/ppc64 stable wrt #378691
747
748*ruby-1.8.7_p334-r2 (22 Jul 2011)
749
750 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
751 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
752 for chasing down upstream and us.
753
754 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
755 Added ~mips, bug 332593
756
757 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
758 ruby-1.8.7_p334-r1.ebuild:
759 ppc64 stable wrt #369141
760
761 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
762 ia64/s390/sh/sparc stable wrt #369141
763
764 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
765 Stable for HPPA (bug #369141).
766
767 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
768 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
769
770 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
771 arm/x86 stable, bug #369141
772
773 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
774 Stable on amd64 wrt bug #369141
775
776 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
777 ruby-1.8.7_p334-r1.ebuild:
778 Stable on alpha, bug #369141
779
780*ruby-1.8.7_p334-r1 (31 May 2011)
781
782 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
783 Revision bump for security bug 369141 (CVE-2011-0188)
784
785*ruby-1.9.2-r1 (16 May 2011)
786
787 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
788 Don't remove racc files since all other ruby targets ship these files
789 themselves as well. Closes bug 363419.
790
791 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
792 ruby-1.8.7_p334.ebuild:
793 Remove old version. Remove obsolete and unused old-style virtual/ruby.
794
795 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
796 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
797
798 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
799 Add append-flags -mieee on sh, bug #357559
800
801 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
802 alpha/arm/ia64/s390/sh stable wrt #355439
803
804 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
805 Marked ~ppc64 wrt #332593
806
807 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
808 ruby-1.8.7_p334.ebuild:
809 x86 stable wrt security bug #355439
810
811 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
812 ruby-1.8.7_p334.ebuild:
813 ppc/ppc64 stable wrt #355439
814
815 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
816 Stable on amd64 wrt bug #355439
817
818 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
819 Stable for HPPA (bug #355439).
820
821*ruby-1.8.7_p334 (19 Feb 2011)
822
823 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
824 Version bump 1.8.7 series, security bug 355439
825
826 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
827 ruby-1.9.2.ebuild:
828 Remove PROVIDE for old-style virtual/ruby per bug 265054.
829
830 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
831 Remove masked ruby 1.8.6 per bug 332597.
832
833 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
834 -ruby-1.9.2_rc2.ebuild:
835 Removing old and vulnerable ebuilds
836
837 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
838 Marking ruby-1.8.7_p302 ppc64 for bug 332957
839
840 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
841 alpha/ia64/s390/sh/sparc stable wrt #332957
842
843*ruby-1.9.2 (24 Aug 2010)
844
845 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
846 metadata.xml:
847 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
848 and x86-fbsd due to a new dependency on rdoc.
849
850 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
851 arm stable, bug #332957
852
853 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
854 ruby-1.8.7_p302.ebuild:
855 x86 stable wrt security bug #332957
856
857 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
858 Stable on amd64 wrt bug #332957
859
860 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
861 Stable for PPC (bug #332957).
862
863 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
864 Stable for HPPA (bug #332957).
865
866*ruby-1.8.7_p302 (21 Aug 2010)
867
868 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
869 +ruby-1.8.7_p302.ebuild:
870 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
871 installation path.
872
873*ruby-1.8.6_p399 (19 Aug 2010)
874
875 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
876 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
877 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
878 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
879 installation path (reported by the x86 team in bug 332597)
880
881*ruby-1.9.2_rc2-r1 (18 Aug 2010)
882
883 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
884 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
885 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
886 the rubygems loading code. Add USE flag for psych.
887
888 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
889 ruby-1.9.2_rc2.ebuild:
890 Remove two keepdir that will try to keep an empty path, closes bug
891 #333163.
892
893 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
894 Marked ~ppc (bug #332593).
895
896 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
897 ruby-1.9.2_rc2.ebuild:
898 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
899
900 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
901 ruby-1.8.7_p299.ebuild:
902 Bump eselect-ruby dependency
903
904 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
905 -ruby-1.9.1_p429.ebuild:
906 Remove ebuild that is not target for unmask anyway.
907
908 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
909 ruby-1.9.2_rc2.ebuild:
910 Try 2 to fix the berkdb 5 issue on 1.9.
911
912 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
913 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
914 ruby-1.9.2_rc2.ebuild:
915 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
916 support for adding new patchsets without bumping the revision for all the
917 old ebuilds as well.
918
919*ruby-1.9.2_rc2 (14 Jul 2010)
920
921 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
922 +ruby-1.9.2_rc2.ebuild:
923 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
924 might cause _further_ build failures as it changed slightly behaviour.
925 You're going to need to rebuild rubygems and then all the packages
926 previously installed after upgrading to this.
927
928 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
929 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
930 -ruby-1.9.1_p376.ebuild:
931 Cleanup old versions.
932
933*ruby-1.9.1_p429 (04 Jul 2010)
934
935 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
936 +ruby-1.9.1_p429.ebuild:
937 Version bump to new 1.9.1 release.
938
939*ruby-1.8.7_p299 (23 Jun 2010)
940
941 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
942 +ruby-1.8.7_p299.ebuild:
943 Version bump.
944
945 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
946 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
947 remove useless comments
948
949 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
950 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
951 ruby-1.9.1_p376.ebuild:
952 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
953 dev.gentoo.org now.
954
955 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
956 ruby-1.9.1_p376.ebuild:
957 Use the correct RUBYLIB.
958
959*ruby-1.8.7_p249-r2 (18 May 2010)
960*ruby-1.8.6_p388-r1 (18 May 2010)
961
962 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
963 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
964 ruby-1.9.1_p376.ebuild, metadata.xml:
965 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
966 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
967 add USE flags for ncurses, readline and libedit, and properly depend on
968 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
969 Emacs versions support ruby-mode themselves and it should be even more
970 updated.
971
972*ruby-1.8.7_p249-r1 (06 May 2010)
973
974 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
975 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
976 309789 by Sune Kloppenborg Jeppesen.
977
978 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
979 ruby-1.8.7_p249.ebuild:
980 Use $PVR instead of $PV in patchset names
981
982 06 May 2010; Alex Legler <a3li@gentoo.org>
983 -files/ruby-1.8.6-memory-leak.diff,
984 -files/ruby18-mkmf-parallel-install.patch,
985 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
986 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
987 Remove old version. Cleanup in files/
988
989*ruby-1.9.1_p376 (01 May 2010)
990
991 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
992 Version bump. Fixes security bugs 296052 and 300468. No longer installs
993 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
994 instead.
995
996 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
997 -ruby-1.8.7_p174-r1.ebuild:
998 Remove vulnerable ebuilds, 300468
999
1000 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
1001 ruby-1.8.7_p249.ebuild:
1002 amd64 stable, security bug 300468
1003
1004 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
1005 ruby-1.8.7_p249.ebuild:
1006 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
1007
1008 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
1009 Stable for HPPA (bug #300468).
1010
1011 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
1012 Stable for HPPA (bug #300468).
1013
1014 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
1015 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
1016
1017 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
1018 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
1019
1020 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1021 ruby-1.8.6_p388.ebuild:
1022 stable x86, security bug 300468
1023
1024 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1025 ruby-1.8.7_p249.ebuild:
1026 stable x86, security bug 300468
1027
1028*ruby-1.8.6_p388 (10 Jan 2010)
1029
1030 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
1031 +ruby-1.8.6_p388.ebuild:
1032 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
1033 version. The new ebuild also has the fix for bug 168939.
1034
1035*ruby-1.8.7_p249 (10 Jan 2010)
1036
1037 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1038 +ruby-1.8.7_p249.ebuild:
1039 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1040 version
1041
1042 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1043 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1044
1045*ruby-1.8.7_p248 (25 Dec 2009)
1046
1047 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1048 Version bump
1049
1050 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1051 Remove old version.
1052
1053 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1054 Remove old version.
1055
1056 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1057 ia64/s390/sh stable wrt #288699
1058
1059 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1060 stable sparc, bug 288699
1061
1062 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1063 arm stable, bug #288699
1064
1065 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1066 amd64/x86 stable, bug #288699
1067
1068 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1069 ruby-1.8.7_p174-r1.ebuild:
1070 Stable on alpha, bug #288699
1071
1072 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1073 ppc stable #288699
1074
1075 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1076 Stable for HPPA (bug #288699).
1077
1078 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1079 Marked ~hppa too.
1080
1081*ruby-1.8.7_p174-r1 (06 Oct 2009)
1082
1083 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1084 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1085 eselect-ruby cleanup feature.
1086
1087*ruby-1.9.1_p243 (09 Sep 2009)
1088
1089 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1090 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1091 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1092 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1093 -files/ruby19-rubygems-proxy.patch,
1094 -files/ruby-1.9.1_p129-parallelmake.patch,
1095 -files/ruby19-mkmf-parallel-install.patch:
1096 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1097 168939. Cleaning up old patches.
1098
1099*ruby-1.8.6_p383 (20 Aug 2009)
1100
1101 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1102 Patchlevel bump.
1103
1104 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1105 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1106 ruby-1.9.1_p129-r1.ebuild:
1107 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1108
1109 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1110 Removing vulnerable ebuild, bug 273213.
1111
1112 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1113 Marking ruby-1.8.6_p369 ppc for bug 273213
1114
1115 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1116 ruby-1.9.1_p129-r1.ebuild:
1117 Prepend our library path instead of overwriting it during src_install.
1118 Thanks to the reporter of bug #274824.
1119
1120*ruby-1.8.7_p174 (18 Jun 2009)
1121
1122 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1123 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1124 Replacing 187_p173 with _p174 because of a regression. Unifying the
1125 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1126 patchsets.
1127
1128 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1129 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1130
1131 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1132 arm/ia64/s390/sh/sparc stable wrt #273213
1133
1134 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1135 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1136 Removing old version, minor cleanup
1137
1138 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1139 -files/ruby-1.8.6-openssl.patch,
1140 -files/ruby-1.8.6-shortname_constants.patch,
1141 -files/ruby-1.8.6_p111-r13657.patch,
1142 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1143 Removing vulnerable old Ruby version and stale patches, bug 274108.
1144
1145 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1146 ruby-1.8.6_p369.ebuild:
1147 Stable on alpha, bug #273213
1148
1149 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1150 Stable for HPPA (bug #273213).
1151
1152 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1153 ruby-1.8.6_p369.ebuild:
1154 stable x86, security bug 273213
1155
1156 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1157 amd64 stable, security bug 273213.
1158
1159*ruby-1.8.7_p173 (10 Jun 2009)
1160*ruby-1.8.6_p369 (10 Jun 2009)
1161
1162 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1163 +ruby-1.8.7_p173.ebuild:
1164 Version bumps for bug #273213.
1165
1166*ruby-1.9.1_p129-r1 (27 May 2009)
1167
1168 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1169 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1170 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1171 +files/ruby-1.9.1_p129-parallelmake.patch:
1172 Revision bump, add patches 1) to make Ruby behave more similarly between
1173 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1174 extensions (undefined symbols in them will cause abort at runtime 3) to
1175 remove a concurrency issue when building the dl extension that could
1176 result in a broken dl.so.
1177
1178 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1179 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1180 Don't block rdoc-2 or later (which may enter Portage one day as it's
1181 needed by some Rakefiles).
1182
1183 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1184 ruby-1.9.1_p129.ebuild:
1185 Add ~x86-fbsd keyword.
1186
1187 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1188 keyword ~sparc-fbsd, bug #252315
1189
1190*ruby-1.9.1_p129 (15 May 2009)
1191
1192 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1193 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1194 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1195 included in every release.
1196
1197 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1198 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1199 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1200 ruby-1.8.7_p160.ebuild:
1201 Removing vulnerable versions (#268515), fixing license (#233747).
1202
1203 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1204 Stable for HPPA (bug #268515).
1205
1206 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1207 Adapting rubygems notice.
1208
1209 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1210 amd64 stable, bug #268515.
1211
1212 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1213 arm/ia64/s390/sh/sparc stable wrt #268515
1214
1215 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1216 ruby-1.8.6_p368.ebuild:
1217 stable x86, security bug 268515
1218
1219 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1220 ruby-1.8.6_p368.ebuild:
1221 Stable on alpha, bug #268515
1222
1223 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1224 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1225
1226*ruby-1.8.7_p160 (07 May 2009)
1227*ruby-1.8.6_p368 (07 May 2009)
1228
1229 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1230 +ruby-1.8.7_p160.ebuild:
1231 Version bump as per secbug 268515. NB: These are the first ebuilds that
1232 no longer use ruby-config.
1233
1234*ruby-1.9.1-r1 (03 Apr 2009)
1235*ruby-1.8.7_p72-r11 (03 Apr 2009)
1236*ruby-1.8.6_p287-r13 (03 Apr 2009)
1237
1238 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1239 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1240 +files/ruby18-mkmf-parallel-install.patch,
1241 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1242 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1243 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1244 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1245 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1246 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1247 happy.
1248
1249*ruby-1.9.1 (21 Mar 2009)
1250
1251 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1252 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1253 +ruby-1.9.1.ebuild:
1254 Adding Ruby 1.9.1 for preliminary testing
1255
1256 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1257 ruby-1.8.6_p287-r12.ebuild:
1258 Marked ~ppc for bug #252315.
1259
1260 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1261 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1262 bug 261982.
1263
1264 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1265 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1266 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1267 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1268 Cleanup
1269
1270*ruby-1.8.7_p72-r10 (07 Mar 2009)
1271
1272 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1273 +ruby-1.8.7_p72-r10.ebuild:
1274 Add a revision of ruby 1.8.7 using eselect ruby.
1275
1276 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1277 ~mips keyworded, bug #252315.
1278
1279 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1280 ruby-1.8.6_p287-r5.ebuild:
1281 ppc stable, bug #260006
1282
1283 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1284 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1285
1286 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1287 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1288 Fixing Tk USE flag test, bug 258893.
1289
1290 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1291 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1292
1293 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1294 ruby-1.8.6_p287-r5.ebuild:
1295 amd64 stable wrt security bug #260006
1296
1297 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1298 Stable for HPPA (bug #260006).
1299
1300 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1301 ruby-1.8.6_p287-r5.ebuild:
1302 Stable on alpha, bug #260006
1303
1304*ruby-1.8.7_p72-r2 (23 Feb 2009)
1305*ruby-1.8.6_p287-r12 (23 Feb 2009)
1306*ruby-1.8.6_p287-r5 (23 Feb 2009)
1307
1308 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1309 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1310 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1311 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1312 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1313 now before compilation if Tk useflags don't match) and 230748 (adding
1314 --enable-option-checking=no for newer versions of autoconf).
1315
1316 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1317 arm/ia64/s390/sh/sparc stable wrt #254307
1318
1319 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1320 ruby-1.8.6_p287-r4.ebuild:
1321 Stable on alpha, bug #254307
1322
1323 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1324 ruby-1.8.6_p287-r11.ebuild:
1325 keyword ~x86-fbsd, bug #252315
1326
1327 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1328 ppc stable #254307
1329
1330 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1331 amd64/x86 stable, bug #254307
1332
1333 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1334 stable ppc64, bug 254307
1335
1336 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1337 Stable for HPPA (bug #254307).
1338
1339 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1340 ruby-1.8.6_p287-r11.ebuild:
1341 Marked ~hppa (bug #252315).
1342
1343*ruby-1.8.6_p287-r11 (11 Jan 2009)
1344
1345 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1346 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1347 +ruby-1.8.6_p287-r11.ebuild:
1348 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1349 Fixes #254307.
1350
1351 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1352 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1353
1354 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1355 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1356
1357 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1358 ruby-1.8.6_p287-r10.ebuild:
1359 Add ~sparc keyword, bug #252315
1360
1361*ruby-1.8.6_p287-r10 (23 Dec 2008)
1362
1363 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1364 +ruby-1.8.6_p287-r10.ebuild:
1365 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1366 keywords since eselect-ruby does not yet have these keywords.
1367
1368 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1369 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1370 Revert the ruby-config changes. We can't remove them until we provide an
1371 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1372 for breaking things as mentioned in bug #251833.
1373
1374 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1375 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1376 ruby-1.8.7_p72-r1.ebuild:
1377 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1378 Thanks for the people noticing this in bug #251833.
1379
1380 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1381 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1382 ruby-1.8.7_p72-r1.ebuild:
1383 Drop dependency on ruby-config, which will be removed from the tree. We
1384 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1385 is no need for ruby-config at this moment. For newer versions of Ruby we will
1386 use eselect-ruby, which can be found in the ruby overlay at the moment.
1387
1388 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1389 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1390 Use mirror://ruby in SRC_URI, fixes #237392.
1391
1392 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1393 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1394 -ruby-1.8.7_p72.ebuild:
1395 Remove old versions. Leave one old stable version with cjk support.
1396
1397*ruby-1.8.6_p287-r3 (29 Nov 2008)
1398
1399 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1400 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1401 +ruby-1.8.6_p287-r3.ebuild:
1402 Fix our expansion limit patch according to debian bug report
1403 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1404 make sure people will pick up the fixed version. Thanks to Alex Legler for
1405 mentioning the patch.
1406
1407*ruby-1.8.7_p72-r1 (26 Nov 2008)
1408*ruby-1.8.6_p287-r2 (26 Nov 2008)
1409
1410 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1411 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1412 +ruby-1.8.7_p72-r1.ebuild:
1413 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1414 Thanks to Alex Legler for providing the patch.
1415
1416 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1417 -ruby-1.8.6_p287.ebuild:
1418 Remove versions that will not become stable
1419
1420 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1421 ruby-1.8.6_p287-r1.ebuild:
1422 ppc stable, bug #225465
1423
1424 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1425 ruby-1.8.6_p287-r1.ebuild:
1426 amd64 stable wrt security bug #225465
1427
1428 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1429 alpha/ia64/x86 stable wrt #225465
1430
1431 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1432 ruby-1.8.6_p287-r1.ebuild:
1433 Sparc stable --- Security Bug #225465 --- good since late August.
1434
1435 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1436 Stable on ppc64; bug #225465
1437
1438 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1439 Stable for HPPA (bug #225465).
1440
1441*ruby-1.8.6_p287-r1 (29 Aug 2008)
1442
1443 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1444 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1445 +ruby-1.8.6_p287-r1.ebuild:
1446 Fix REXML security issues, bug #236060.
1447
1448 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1449 Add GLEP 56 USE flag descriptions.
1450
1451*ruby-1.8.7_p72 (15 Aug 2008)
1452
1453 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1454 +ruby-1.8.7_p72.ebuild:
1455 bump 1.8.7 to latest patch release
1456
1457*ruby-1.8.6_p287 (11 Aug 2008)
1458
1459 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1460 Version bump for brown paper bag relelease.
1461
1462 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1463 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1464 Remove broken version in favor of the just-added 1.8.6_p286
1465
1466*ruby-1.8.6_p286 (10 Aug 2008)
1467
1468 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1469 Version bump to latest released version of ruby 1.8.6. This version fixes the
1470 security issues reported in #225465 and #234224. The cjk USE flag has been
1471 dropped since no compatible patches have been released yet.
1472
1473 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1474 ruby-1.8.6_p230.ebuild:
1475 drop cjk from SRC_URI as well
1476
1477 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1478 Drop cjk support since the most recent oniguruma patches no longer apply to
1479 this version, #230111.
1480
1481 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1482 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1483 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1484 Unfortunately the official p230 has a change which causes segmentation faults
1485 for applications like Rails and RSpec, so we are reverting that specific
1486 change.
1487
1488*ruby-1.8.7_p22 (29 Jun 2008)
1489
1490 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1491 +ruby-1.8.7_p22.ebuild:
1492 bump 1.8.7 for security fix
1493
1494 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1495 nevermind, don't bump this yet
1496
1497*ruby-1.8.6_p230 (20 Jun 2008)
1498
1499 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1500 version bump
1501
1502*ruby-1.8.7 (10 Jun 2008)
1503
1504 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1505 +ruby-1.8.7.ebuild:
1506 bump 1.8.7 to final
1507
1508*ruby-1.8.7_pre2 (21 Apr 2008)
1509
1510 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1511 +ruby-1.8.7_pre2.ebuild:
1512 Version Bump
1513
1514*ruby-1.8.7_pre1 (16 Apr 2008)
1515
1516 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1517 Version bump. Drop cjk until a new version of oniguruma appears.
1518
1519 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1520 amd64 stable, bug 212264
1521
1522 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1523 Stable for HPPA (bug #212264).
1524
1525 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1526 ruby-1.8.6_p114.ebuild:
1527 ppc stable, bug #212264
1528
1529 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1530 alpha/ia64 stable wrt #212264
1531
1532 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1533 ruby-1.8.6_p114.ebuild:
1534 stable x86, security bug 212264
1535
1536 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1537 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1538 as expected.
1539
1540 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1541 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1542
1543*ruby-1.8.6_p114 (05 Mar 2008)
1544
1545 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1546 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1547 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1548 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1549 Version bump for #212264. Remove old ebuilds.
1550
1551 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1552 alpha/ia64 stable wrt #208916
1553
1554 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1555 Stable on ppc wrt bug 208916
1556
1557 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1558 x86 stable, bug #208916
1559
1560 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1561 ruby-1.8.6_p111-r1.ebuild:
1562 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1563
1564 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1565 -files/ruby-1.8.6-exit-status.patch,
1566 -files/ruby-1.8.6_p110-net-http-p111.patch,
1567 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1568 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1569 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1570 Remove old versions
1571
1572 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1573 Stable on ppc64
1574
1575 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1576 Stable on amd64; bug 199191
1577
1578 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1579 alpha/ia64/sparc stable wrt #199191
1580
1581 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1582 Remove now-obsolete warning about coreutils versions, #203156.
1583
1584 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1585 Stable for HPPA (bug #199191).
1586
1587*ruby-1.8.6_p111-r1 (23 Dec 2007)
1588
1589 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1590 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1591 ssl USE flags. Patch to p113.
1592
1593 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1594 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1595
1596 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1597 x86 stable, security bug #199191
1598
1599*ruby-1.8.6_p111 (23 Dec 2007)
1600
1601 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1602 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1603 Version bump with patch for bug #199191
1604
1605 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1606 Move dependency on (X)Emacs modes to PDEPEND.
1607
1608 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1609 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1610 bug 196413
1611
1612*ruby-1.8.6_p110-r2 (21 Oct 2007)
1613
1614 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1615 +ruby-1.8.6_p110-r2.ebuild:
1616 Add emacs and xemacs USE flags and use them to pull in the correct editing
1617 mode for each. Had to drop several arch keywords as reported on bug 196413.
1618
1619 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1620 amd64 stable, security bug 194236
1621
1622 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1623 ruby-1.8.6_p110-r1.ebuild:
1624 Stable on ppc64; bug #194236
1625
1626 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1627 amd64 stable, security bug 194236
1628
1629 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1630 Stable for HPPA (bug #194236).
1631
1632 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1633 alpha/ia64/sparc stable wrt security #194236
1634
1635 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1636 ruby-1.8.6_p110-r1.ebuild:
1637 ppc stable, bug #194236
1638
1639 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1640 ruby-1.8.6_p110-r1.ebuild:
1641 stable x86, security bug 194236
1642
1643 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1644 ruby-1.8.5_p113.ebuild:
1645 stable x86, security bug 194236
1646
1647 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1648 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1649 -ruby-1.8.6_p110.ebuild:
1650 Remove old versions
1651
1652*ruby-1.8.6_p110-r1 (30 Sep 2007)
1653*ruby-1.8.5_p113 (30 Sep 2007)
1654
1655 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1656 +files/ruby-1.8.5_p113-net-http-p114.patch,
1657 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1658 +ruby-1.8.6_p110-r1.ebuild:
1659 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1660 using 1.8.6-p110 as base ebuild.
1661
1662 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1663 More fixes from gentoo-dev and graaff
1664
1665 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1666 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1667
1668*ruby-1.8.6_p110 (24 Sep 2007)
1669
1670 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1671 Version bump
1672
1673*ruby-1.8.6_p36-r4 (26 Aug 2007)
1674
1675 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1676 +ruby-1.8.6_p36-r4.ebuild:
1677 Use user LDFLAGS, #181436
1678
1679 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1680 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1681 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1682 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1683
1684 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1685 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1686 -ruby-1.8.6_p36-r2.ebuild:
1687 Remove some older versions that will not be promoted to stable, keeping at
1688 least one version of each release.
1689
1690 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1691 ruby-1.8.6_p36-r3.ebuild:
1692 (QA) RESTRICT clean up.
1693
1694*ruby-1.8.6_p36-r3 (04 Jul 2007)
1695
1696 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1697 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1698 fixed memory leak loading .so bug #182946
1699
1700 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1701 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1702 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1703 ruby-1.8.6_p36-r2.ebuild:
1704 (QA) RESTRICT clean up.
1705
1706 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1707 Re-add stable keyword for alpha as per bug #181110
1708
1709 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1710 Back to ~amd64 wrt bug 181110
1711
1712 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1713 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1714
1715*ruby-1.8.6_p36-r2 (20 Jun 2007)
1716
1717 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1718 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1719
1720*ruby-1.8.6_p36-r1 (18 Jun 2007)
1721
1722 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1723 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1724 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1725 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1726 spbecker
1727
1728 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1729 Stable on amd64 wrt bug 181110
1730
1731*ruby-1.8.6_p36 (12 Jun 2007)
1732
1733 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1734 Version Bump. Bug #181379
1735
1736 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1737 Stable on mips, per #181110.
1738
1739 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1740 Stable on ppc wrt bug 181110
1741
1742 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1743 Stable for HPPA (bug #181110).
1744
1745 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1746 alpha/ia64/x86 stable wrt #181110
1747
1748 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1749 Stable on sparc wrt #181110
1750
1751 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1752 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1753
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1754 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1755 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1756 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1757 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.687

  ViewVC Help
Powered by ViewVC 1.1.20