/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.690
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.690 2014/11/29 19:49:26 maekke Exp $
4
5 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p598.ebuild:
6 arm stable, bug #529216
7
8 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p551.ebuild:
9 arm stable, bug #529216
10
11 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
12 ruby-2.0.0_p598.ebuild:
13 Stable for ppc64, wrt bug #529216
14
15 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
16 ruby-2.0.0_p598.ebuild:
17 Stable for ppc, wrt bug #529216
18
19 26 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p551.ebuild,
20 ruby-2.0.0_p598.ebuild:
21 Stable for HPPA (bug #529216).
22
23 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
24 ruby-2.0.0_p598.ebuild:
25 Stable for x86, wrt bug #529216
26
27 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
28 ruby-2.0.0_p598.ebuild:
29 Stable for amd64, wrt bug #529216
30
31*ruby-2.1.5 (14 Nov 2014)
32*ruby-2.0.0_p598 (14 Nov 2014)
33*ruby-1.9.3_p551 (14 Nov 2014)
34
35 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p551.ebuild,
36 +ruby-2.0.0_p598.ebuild, +ruby-2.1.5.ebuild:
37 Version bumps for security bug 529216.
38
39 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p484.ebuild,
40 -ruby-1.9.3_p547.ebuild, -ruby-2.0.0_p353.ebuild, -ruby-2.0.0_p481.ebuild,
41 -ruby-2.0.0_p576.ebuild, -ruby-2.1.2.ebuild, -ruby-2.1.3.ebuild:
42 Cleanup.
43
44 12 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
45 ruby-2.0.0_p594.ebuild:
46 Stable for alpha, wrt bug #527084
47
48 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
49 ruby-2.0.0_p594.ebuild:
50 Stable for sparc, wrt bug #527084
51
52 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
53 ruby-2.0.0_p594.ebuild:
54 Stable for ia64, wrt bug #527084
55
56*ruby-2.1.4-r1 (10 Nov 2014)
57*ruby-2.0.0_p594-r1 (10 Nov 2014)
58
59 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
60 +ruby-2.1.4-r1.ebuild:
61 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
62 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
63
64 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
65 ruby-2.0.0_p594.ebuild:
66 Stable for ppc64, wrt bug #527084
67
68 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
69 ruby-2.0.0_p594.ebuild:
70 Stable for ppc, wrt bug #527084
71
72 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
73 arm stable, bug #527084
74
75 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
76 arm stable, bug #527084
77
78 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
79 ruby-2.0.0_p594.ebuild:
80 Stable for x86, wrt bug #527084
81
82 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
83 ruby-2.0.0_p594.ebuild:
84 Stable for amd64, wrt bug #527084
85
86 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
87 ruby-2.0.0_p594.ebuild:
88 Stable for HPPA (bug #527084).
89
90*ruby-2.1.4 (27 Oct 2014)
91*ruby-2.0.0_p594 (27 Oct 2014)
92*ruby-1.9.3_p550 (27 Oct 2014)
93
94 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
95 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
96 Version bump for security bug 527084. Note that OpenSSL defaults have changed
97 in these versions which may lead to incompatibilities:
98 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
99 -openssl/
100
101 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
102 ruby-2.0.0_p481.ebuild:
103 Stable for sparc, wrt bug #512904
104
105 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
106 ruby-2.0.0_p481.ebuild:
107 Stable for ppc64, wrt bug #512904
108
109 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
110 ruby-2.0.0_p481.ebuild:
111 Stable for ppc, wrt bug #512904
112
113 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
114 ruby-2.0.0_p481.ebuild:
115 Stable for amd64, wrt bug #512904
116
117*ruby-2.1.3 (20 Sep 2014)
118
119 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
120 Version bump:
121 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
122
123*ruby-2.0.0_p576 (20 Sep 2014)
124
125 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
126 Version bump.
127
128 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
129 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
130 Depend on the rubygems virtual with an explicit SLOT now that the specific
131 rubygems versions are listed in virtual/rubygems. This will make the
132 dependencies more explicit and should decrease resolver surprises picking the
133 wrong virtual/rubygems SLOT later on.
134
135 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
136 Cleanup.
137
138 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
139 ruby-2.0.0_p481.ebuild:
140 x86 stable wrt bug #512904
141
142 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
143 Stable on alpha, bug #512904
144
145 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
146 arm stable, bug #512904
147
148 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
149 arm stable, bug #512904
150
151 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
152 ruby-2.0.0_p481.ebuild:
153 ia64 stable wrt bug #512904
154
155 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
156 Stable for HPPA (bug #512904).
157
158 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
159 Stable for HPPA (bug #512904).
160
161 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
162 -ruby-2.1.1-r1.ebuild:
163 Cleanup.
164
165 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
166 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
167 512848.
168
169*ruby-1.9.3_p547 (17 May 2014)
170
171 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
172 Version bump.
173
174*ruby-2.1.2 (10 May 2014)
175*ruby-2.0.0_p481 (10 May 2014)
176
177 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
178 +ruby-2.1.2.ebuild:
179 Version bump.
180
181 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
182 -ruby-2.0.0_p353-r2.ebuild:
183 Cleanup.
184
185 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
186 ruby-2.1.1-r1.ebuild:
187 Remove useless libruby symlinks, bug 503584.
188
189 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
190 -ruby-2.1.1.ebuild:
191 Cleanup.
192
193 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
194 Remove unneeded useflag descriptions from metadata.xml
195
196 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
197 -ruby-1.8.7_p374.ebuild:
198 Remove Ruby 1.8. See bug #434064.
199
200*ruby-2.1.1-r1 (14 Apr 2014)
201
202 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
203 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
204 Thanks to Andrew Savchenko for providing a patch.
205
206 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
207 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
208 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
209 ruby-2.1.1.ebuild:
210 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
211
212*ruby-2.1.1 (06 Mar 2014)
213
214 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
215 Version bump. Update module selection code to fix automagic dependencies.
216 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
217 503106.
218
219*ruby-2.0.0_p451 (05 Mar 2014)
220
221 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
222 Version bump. Update module selection code to fix automagic dependencies.
223 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
224 503106.
225
226*ruby-1.9.3_p545 (26 Feb 2014)
227
228 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
229 Version bump. Drop tk USE flag due to bug 500894.
230
231*ruby-2.0.0_p353-r2 (23 Feb 2014)
232
233 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
234 Backport support for uclibc, fixing bug 484534.
235
236 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
237 Stable for alpha, wrt bug #483254
238
239 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
240 Stable for sparc, wrt bug #483254
241
242 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
243 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
244 Fix slot conflicts, #498970
245
246 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
247 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
248 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
249 bug 497130.
250
251 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
252 -ruby-1.9.3_p448-r1.ebuild:
253 Remove vulnerable versions.
254
255 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
256 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
257 Remove vulnerable versions.
258
259 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
260 arm stable, bug #492282
261
262*ruby-2.0.0_p353-r1 (03 Jan 2014)
263
264 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
265 ruby-2.1.0.ebuild:
266 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
267
268 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
269 arm stable, bug #483254
270
271 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
272 ruby-2.0.0_p353.ebuild:
273 ia64 stable wrt bug #492282
274
275*ruby-2.1.0 (26 Dec 2013)
276
277 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
278 Version bump.
279
280 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
281 ia64 stable wrt bug #483254
282
283 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
284 Stable for sparc, wrt bug #492282
285
286 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
287 Stable for arm, wrt bug #492282
288
289 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
290 Stable for alpha, wrt bug #492282
291
292 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
293 ruby-2.0.0_p353.ebuild:
294 Stable for x86, wrt bug #492282
295
296 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
297 ruby-2.0.0_p353.ebuild:
298 Stable for ppc64, wrt bug #492282
299
300 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
301 ruby-2.0.0_p353.ebuild:
302 Stable for ppc, wrt bug #492282
303
304 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
305 Stable for ppc64, wrt bug #483254
306
307 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
308 Stable for ppc, wrt bug #483254
309
310 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
311 ruby-2.0.0_p353.ebuild:
312 Stable for amd64, wrt bug #492282
313
314 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
315 Stable for HPPA (bug #492282).
316
317 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
318 Stable for HPPA (bug #492282).
319
320*ruby-2.0.0_p353 (22 Nov 2013)
321*ruby-1.9.3_p484 (22 Nov 2013)
322
323 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
324 +ruby-2.0.0_p353.ebuild:
325 Version bumps for security bug 492282.
326
327*ruby-2.0.0_p247-r2 (14 Oct 2013)
328
329 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
330 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
331 2.x. Fixes bug 483466.
332
333 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
334 -ruby-1.9.3_p429.ebuild:
335 Cleanup.
336
337 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
338 Stable for HPPA (bug #483254).
339
340 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
341 Stable for x86, wrt bug #483254
342
343 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
344 Stable for amd64, wrt bug #483254
345
346 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
347 ruby-1.9.3_p448.ebuild:
348 Stable for s390, wrt bug #475074
349
350*ruby-2.0.0_p247-r1 (29 Jul 2013)
351*ruby-1.9.3_p448-r1 (29 Jul 2013)
352*ruby-1.8.7_p374-r1 (29 Jul 2013)
353
354 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
355 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
356 Revision bump to counter breakage introduced in portage 2.1.13 for bug
357 465000. Thanks to thansen for reporting.
358
359 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
360 ruby-1.9.3_p448.ebuild:
361 Stable for sparc, wrt bug #475074
362
363 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
364 ruby-1.9.3_p448.ebuild:
365 Stable for sh, wrt bug #475074
366
367 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
368 ruby-1.9.3_p448.ebuild:
369 Stable for ia64, wrt bug #475074
370
371*ruby-2.0.0_p247 (07 Jul 2013)
372
373 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
374 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
375 ruby20.
376
377 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
378 ruby-1.9.3_p448.ebuild:
379 Stable for alpha, wrt bug #475074
380
381 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
382 ruby-1.9.3_p448.ebuild:
383 Stable for ppc64, wrt bug #475074
384
385 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
386 ruby-1.9.3_p448.ebuild:
387 Stable for HPPA (bug #475074).
388
389 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
390 ruby-1.9.3_p448.ebuild:
391 Stable for ppc, wrt bug #475074
392
393 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
394 ruby-1.9.3_p448.ebuild:
395 Stable for arm, wrt bug #475074
396
397 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
398 ruby-1.9.3_p448.ebuild:
399 Stable for x86, wrt bug #475074
400
401 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
402 ruby-1.9.3_p448.ebuild:
403 Stable for amd64, wrt bug #475074
404
405*ruby-1.9.3_p448 (30 Jun 2013)
406*ruby-1.8.7_p374 (30 Jun 2013)
407
408 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
409 +ruby-1.9.3_p448.ebuild:
410 Version bumps for security bug 475074.
411
412 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
413 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
414 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
415 Cleanup. Remove vulnerable versions.
416
417 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
418 Stable for sh, wrt bug #469984
419
420 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
421 Stable for s390, wrt bug #469984
422
423 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
424 Stable for ppc64, wrt bug #469984
425
426 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
427 Stable for ia64, wrt bug #469984
428
429 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
430 Stable for alpha, wrt bug #469984
431
432 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
433 Stable for sparc, wrt bug #469984
434
435 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
436 Remove non-functional dosym calls, bug 442462.
437
438 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
439 Stable for arm, wrt bug #469984
440
441 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
442 Stable for ppc, wrt bug #469984
443
444 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
445 Stable for x86, wrt bug #469984
446
447 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
448 Stable for amd64, wrt bug #469984
449
450 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
451 Stable for HPPA (bug #469984).
452
453*ruby-1.9.3_p429 (16 May 2013)
454
455 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
456 Version bump for security bug #469984.
457
458 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
459 Stable for s390, wrt bug #437366
460
461 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
462 Stable for sparc, wrt bug #437366
463
464 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
465 Stable for ia64, wrt bug #437366
466
467 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
468 Stable for alpha, wrt bug #437366
469
470 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
471 Stable for ppc64, wrt bug #437366
472
473 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
474 Stable for arm, wrt bug #437366
475
476 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
477 Stable for sh, wrt bug #437366
478
479 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
480 Marking ruby-1.8.7_p371 ppc for bug 437366
481
482 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
483 Stable for HPPA (bug #437366).
484
485 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
486 Stable for x86, wrt bug #437366
487
488 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
489 Stable for amd64, wrt bug #437366
490
491 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
492 Stable for sh, wrt bug #458776
493
494 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
495 Stable for alpha, wrt bug #458776
496
497 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
498 Add patch to fix bug #459074 (parallel build).
499
500 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
501 Stable for arm, wrt bug #458776
502
503 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
504 Stable for s390, wrt bug #458776
505
506 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
507 Stable for sparc, wrt bug #458776
508
509 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
510 Stable for hppa, wrt bug #458776
511
512 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
513 Stable for ia64, wrt bug #458776
514
515 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
516 Stable for x86, wrt bug #458776
517
518 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
519 Stable for amd64, wrt bug #458776
520
521 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
522 Stable for ppc64, wrt bug #458776
523
524 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
525 Stable for ppc, wrt bug #458776
526
527*ruby-1.9.3_p392 (22 Feb 2013)
528
529 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
530 Version bump for security bug 458776.
531
532*ruby-1.9.3_p385 (10 Feb 2013)
533
534 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
535 Version bump. Fixes security bug 442580.
536
537 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
538 keyword ~amd64-fbsd
539
540*ruby-1.8.7_p371 (06 Jan 2013)
541
542 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
543 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
544 Version bump for security bug 437366.
545
546 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
547 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
548 Cleanup.
549
550 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
551 Stable for ppc, wrt bug #427774
552
553 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
554 Stable for HPPA (bug #411507).
555
556 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
557 alpha/ia64/s390/sh/sparc stable wrt #434480
558
559 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
560 ruby-1.9.3_p286.ebuild:
561 Remove HPPA target hack (bug #342819).
562
563 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
564 alpha/ia64/s390/sh/sparc stable wrt #411507
565
566 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
567 Stable for HPPA (bug #434480).
568
569*ruby-1.9.3_p286 (15 Oct 2012)
570
571 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
572 Version bump. Fixes bugs #437264 and #437264.
573
574 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
575 stable arm, bug #434480
576
577 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
578 stable ppc ppc64, bug #434480
579
580 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
581 Stable for x86, wrt bug #434480
582
583 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
584 ruby-1.9.3_p194-r1.ebuild:
585 Update LICENSE, bug 434332.
586
587 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
588 Stable for amd64, wrt bug #434480
589
590 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
591 Stable for amd64, wrt bug #427774
592
593 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
594 arm stable, bug #427774
595
596 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
597 ruby-1.9.3_p194-r1.ebuild:
598 Stable ppc64, bug #411507
599
600 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
601 marked x86 per bug 427774
602
603 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
604 -ruby-1.9.3_p194.ebuild:
605 Cleanup.
606
607 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
608 ppc stable #411507
609
610 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
611 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
612 424611.
613
614*ruby-1.8.7_p370 (07 Jul 2012)
615
616 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
617 Version bump. Fix bug 378567 thanks to slyfox.
618
619 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
620 x86 stable, see bug 411507
621
622 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
623 arm stable, bug #411507
624
625 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
626 Stable for amd64, wrt bug #411507
627
628*ruby-1.9.3_p194-r1 (12 May 2012)
629
630 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
631 +ruby-1.9.3_p194-r1.ebuild:
632 Revision bump to fix mkmf for parallel build/install. Also enable verbose
633 build, so that the log makes sense if it fails.
634
635*ruby-1.9.3_p194 (30 Apr 2012)
636
637 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
638 Version bump.
639
640 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
641 keyword ~amd64-fbsd
642
643*ruby-1.8.7_p358 (20 Apr 2012)
644
645 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
646 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
647 Rails 3.2.
648
649 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
650 Add ~x86-fbsd, #332593
651
652*ruby-1.9.3_p125 (18 Feb 2012)
653
654 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
655 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
656
657 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
658 add ~arm, bug #332593
659
660 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
661 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
662
663 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
664 x86 stable wrt bug #396301
665
666 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
667 Stable for HPPA (bug #396301).
668
669 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
670 Stable for ppc/ppc64; bug #396301
671
672 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
673 Marked ~hppa (bug #332593).
674
675 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
676 Add back ~alpha keyword now that rubygems is keyworded.
677
678 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
679 Stable for AMD64, wrt security bug #396301
680
681*ruby-1.8.7_p357 (28 Dec 2011)
682
683 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
684 Version bump for security bug 396301.
685
686 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
687 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
688
689 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
690 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
691 keyworded, bug 332593.
692
693 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
694 Block older versions of packages that are no longer compatible. Remove
695 ancient blocks on packags long gone from the tree.
696
697 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
698 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
699 Remove old versions.
700
701*ruby-1.9.3_p0 (18 Dec 2011)
702
703 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
704 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
705 suite which need to be diagnosed first.
706
707 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
708 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
709 #332593).
710
711 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
712 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
713 #332593).
714
715 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
716 alpha/ia64/s390/sh/sparc stable wrt #386369
717
718*ruby-1.9.3_rc1 (22 Oct 2011)
719
720 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
721 Version bump.
722
723 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
724 arm stable, bug #386369
725
726 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
727 x86 stable, bug 386369
728
729 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
730 Stable for HPPA (bug #386369).
731
732 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
733 ppc/ppc64 stable wrt #386369
734
735 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
736 Stable on amd64 wrt bug #386369
737
738 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
739 Remove vulnerable version, bug 386369.
740
741*ruby-1.8.7_p352 (30 Aug 2011)
742
743 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
744 +ruby-1.8.7_p352.ebuild:
745 Patchlevel bump for ruby:1.8. Removing old version
746
747*ruby-1.9.2_p290 (30 Aug 2011)
748
749 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
750 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
751 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
752 old patchlevels.
753
754 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
755 ruby-1.8.7_p334-r2.ebuild:
756 ppc/ppc64 stable wrt #378691
757
758*ruby-1.8.7_p334-r2 (22 Jul 2011)
759
760 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
761 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
762 for chasing down upstream and us.
763
764 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
765 Added ~mips, bug 332593
766
767 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
768 ruby-1.8.7_p334-r1.ebuild:
769 ppc64 stable wrt #369141
770
771 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
772 ia64/s390/sh/sparc stable wrt #369141
773
774 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
775 Stable for HPPA (bug #369141).
776
777 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
778 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
779
780 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
781 arm/x86 stable, bug #369141
782
783 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
784 Stable on amd64 wrt bug #369141
785
786 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
787 ruby-1.8.7_p334-r1.ebuild:
788 Stable on alpha, bug #369141
789
790*ruby-1.8.7_p334-r1 (31 May 2011)
791
792 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
793 Revision bump for security bug 369141 (CVE-2011-0188)
794
795*ruby-1.9.2-r1 (16 May 2011)
796
797 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
798 Don't remove racc files since all other ruby targets ship these files
799 themselves as well. Closes bug 363419.
800
801 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
802 ruby-1.8.7_p334.ebuild:
803 Remove old version. Remove obsolete and unused old-style virtual/ruby.
804
805 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
806 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
807
808 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
809 Add append-flags -mieee on sh, bug #357559
810
811 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
812 alpha/arm/ia64/s390/sh stable wrt #355439
813
814 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
815 Marked ~ppc64 wrt #332593
816
817 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
818 ruby-1.8.7_p334.ebuild:
819 x86 stable wrt security bug #355439
820
821 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
822 ruby-1.8.7_p334.ebuild:
823 ppc/ppc64 stable wrt #355439
824
825 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
826 Stable on amd64 wrt bug #355439
827
828 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
829 Stable for HPPA (bug #355439).
830
831*ruby-1.8.7_p334 (19 Feb 2011)
832
833 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
834 Version bump 1.8.7 series, security bug 355439
835
836 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
837 ruby-1.9.2.ebuild:
838 Remove PROVIDE for old-style virtual/ruby per bug 265054.
839
840 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
841 Remove masked ruby 1.8.6 per bug 332597.
842
843 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
844 -ruby-1.9.2_rc2.ebuild:
845 Removing old and vulnerable ebuilds
846
847 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
848 Marking ruby-1.8.7_p302 ppc64 for bug 332957
849
850 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
851 alpha/ia64/s390/sh/sparc stable wrt #332957
852
853*ruby-1.9.2 (24 Aug 2010)
854
855 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
856 metadata.xml:
857 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
858 and x86-fbsd due to a new dependency on rdoc.
859
860 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
861 arm stable, bug #332957
862
863 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
864 ruby-1.8.7_p302.ebuild:
865 x86 stable wrt security bug #332957
866
867 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
868 Stable on amd64 wrt bug #332957
869
870 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
871 Stable for PPC (bug #332957).
872
873 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
874 Stable for HPPA (bug #332957).
875
876*ruby-1.8.7_p302 (21 Aug 2010)
877
878 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
879 +ruby-1.8.7_p302.ebuild:
880 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
881 installation path.
882
883*ruby-1.8.6_p399 (19 Aug 2010)
884
885 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
886 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
887 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
888 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
889 installation path (reported by the x86 team in bug 332597)
890
891*ruby-1.9.2_rc2-r1 (18 Aug 2010)
892
893 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
894 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
895 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
896 the rubygems loading code. Add USE flag for psych.
897
898 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
899 ruby-1.9.2_rc2.ebuild:
900 Remove two keepdir that will try to keep an empty path, closes bug
901 #333163.
902
903 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
904 Marked ~ppc (bug #332593).
905
906 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
907 ruby-1.9.2_rc2.ebuild:
908 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
909
910 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
911 ruby-1.8.7_p299.ebuild:
912 Bump eselect-ruby dependency
913
914 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
915 -ruby-1.9.1_p429.ebuild:
916 Remove ebuild that is not target for unmask anyway.
917
918 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
919 ruby-1.9.2_rc2.ebuild:
920 Try 2 to fix the berkdb 5 issue on 1.9.
921
922 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
923 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
924 ruby-1.9.2_rc2.ebuild:
925 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
926 support for adding new patchsets without bumping the revision for all the
927 old ebuilds as well.
928
929*ruby-1.9.2_rc2 (14 Jul 2010)
930
931 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
932 +ruby-1.9.2_rc2.ebuild:
933 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
934 might cause _further_ build failures as it changed slightly behaviour.
935 You're going to need to rebuild rubygems and then all the packages
936 previously installed after upgrading to this.
937
938 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
939 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
940 -ruby-1.9.1_p376.ebuild:
941 Cleanup old versions.
942
943*ruby-1.9.1_p429 (04 Jul 2010)
944
945 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
946 +ruby-1.9.1_p429.ebuild:
947 Version bump to new 1.9.1 release.
948
949*ruby-1.8.7_p299 (23 Jun 2010)
950
951 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
952 +ruby-1.8.7_p299.ebuild:
953 Version bump.
954
955 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
956 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
957 remove useless comments
958
959 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
960 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
961 ruby-1.9.1_p376.ebuild:
962 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
963 dev.gentoo.org now.
964
965 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
966 ruby-1.9.1_p376.ebuild:
967 Use the correct RUBYLIB.
968
969*ruby-1.8.7_p249-r2 (18 May 2010)
970*ruby-1.8.6_p388-r1 (18 May 2010)
971
972 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
973 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
974 ruby-1.9.1_p376.ebuild, metadata.xml:
975 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
976 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
977 add USE flags for ncurses, readline and libedit, and properly depend on
978 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
979 Emacs versions support ruby-mode themselves and it should be even more
980 updated.
981
982*ruby-1.8.7_p249-r1 (06 May 2010)
983
984 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
985 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
986 309789 by Sune Kloppenborg Jeppesen.
987
988 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
989 ruby-1.8.7_p249.ebuild:
990 Use $PVR instead of $PV in patchset names
991
992 06 May 2010; Alex Legler <a3li@gentoo.org>
993 -files/ruby-1.8.6-memory-leak.diff,
994 -files/ruby18-mkmf-parallel-install.patch,
995 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
996 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
997 Remove old version. Cleanup in files/
998
999*ruby-1.9.1_p376 (01 May 2010)
1000
1001 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
1002 Version bump. Fixes security bugs 296052 and 300468. No longer installs
1003 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
1004 instead.
1005
1006 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
1007 -ruby-1.8.7_p174-r1.ebuild:
1008 Remove vulnerable ebuilds, 300468
1009
1010 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
1011 ruby-1.8.7_p249.ebuild:
1012 amd64 stable, security bug 300468
1013
1014 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
1015 ruby-1.8.7_p249.ebuild:
1016 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
1017
1018 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
1019 Stable for HPPA (bug #300468).
1020
1021 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
1022 Stable for HPPA (bug #300468).
1023
1024 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
1025 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
1026
1027 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
1028 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
1029
1030 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1031 ruby-1.8.6_p388.ebuild:
1032 stable x86, security bug 300468
1033
1034 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1035 ruby-1.8.7_p249.ebuild:
1036 stable x86, security bug 300468
1037
1038*ruby-1.8.6_p388 (10 Jan 2010)
1039
1040 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
1041 +ruby-1.8.6_p388.ebuild:
1042 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
1043 version. The new ebuild also has the fix for bug 168939.
1044
1045*ruby-1.8.7_p249 (10 Jan 2010)
1046
1047 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1048 +ruby-1.8.7_p249.ebuild:
1049 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1050 version
1051
1052 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1053 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1054
1055*ruby-1.8.7_p248 (25 Dec 2009)
1056
1057 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1058 Version bump
1059
1060 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1061 Remove old version.
1062
1063 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1064 Remove old version.
1065
1066 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1067 ia64/s390/sh stable wrt #288699
1068
1069 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1070 stable sparc, bug 288699
1071
1072 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1073 arm stable, bug #288699
1074
1075 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1076 amd64/x86 stable, bug #288699
1077
1078 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1079 ruby-1.8.7_p174-r1.ebuild:
1080 Stable on alpha, bug #288699
1081
1082 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1083 ppc stable #288699
1084
1085 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1086 Stable for HPPA (bug #288699).
1087
1088 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1089 Marked ~hppa too.
1090
1091*ruby-1.8.7_p174-r1 (06 Oct 2009)
1092
1093 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1094 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1095 eselect-ruby cleanup feature.
1096
1097*ruby-1.9.1_p243 (09 Sep 2009)
1098
1099 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1100 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1101 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1102 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1103 -files/ruby19-rubygems-proxy.patch,
1104 -files/ruby-1.9.1_p129-parallelmake.patch,
1105 -files/ruby19-mkmf-parallel-install.patch:
1106 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1107 168939. Cleaning up old patches.
1108
1109*ruby-1.8.6_p383 (20 Aug 2009)
1110
1111 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1112 Patchlevel bump.
1113
1114 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1115 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1116 ruby-1.9.1_p129-r1.ebuild:
1117 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1118
1119 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1120 Removing vulnerable ebuild, bug 273213.
1121
1122 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1123 Marking ruby-1.8.6_p369 ppc for bug 273213
1124
1125 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1126 ruby-1.9.1_p129-r1.ebuild:
1127 Prepend our library path instead of overwriting it during src_install.
1128 Thanks to the reporter of bug #274824.
1129
1130*ruby-1.8.7_p174 (18 Jun 2009)
1131
1132 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1133 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1134 Replacing 187_p173 with _p174 because of a regression. Unifying the
1135 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1136 patchsets.
1137
1138 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1139 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1140
1141 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1142 arm/ia64/s390/sh/sparc stable wrt #273213
1143
1144 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1145 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1146 Removing old version, minor cleanup
1147
1148 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1149 -files/ruby-1.8.6-openssl.patch,
1150 -files/ruby-1.8.6-shortname_constants.patch,
1151 -files/ruby-1.8.6_p111-r13657.patch,
1152 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1153 Removing vulnerable old Ruby version and stale patches, bug 274108.
1154
1155 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1156 ruby-1.8.6_p369.ebuild:
1157 Stable on alpha, bug #273213
1158
1159 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1160 Stable for HPPA (bug #273213).
1161
1162 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1163 ruby-1.8.6_p369.ebuild:
1164 stable x86, security bug 273213
1165
1166 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1167 amd64 stable, security bug 273213.
1168
1169*ruby-1.8.7_p173 (10 Jun 2009)
1170*ruby-1.8.6_p369 (10 Jun 2009)
1171
1172 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1173 +ruby-1.8.7_p173.ebuild:
1174 Version bumps for bug #273213.
1175
1176*ruby-1.9.1_p129-r1 (27 May 2009)
1177
1178 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1179 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1180 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1181 +files/ruby-1.9.1_p129-parallelmake.patch:
1182 Revision bump, add patches 1) to make Ruby behave more similarly between
1183 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1184 extensions (undefined symbols in them will cause abort at runtime 3) to
1185 remove a concurrency issue when building the dl extension that could
1186 result in a broken dl.so.
1187
1188 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1189 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1190 Don't block rdoc-2 or later (which may enter Portage one day as it's
1191 needed by some Rakefiles).
1192
1193 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1194 ruby-1.9.1_p129.ebuild:
1195 Add ~x86-fbsd keyword.
1196
1197 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1198 keyword ~sparc-fbsd, bug #252315
1199
1200*ruby-1.9.1_p129 (15 May 2009)
1201
1202 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1203 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1204 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1205 included in every release.
1206
1207 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1208 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1209 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1210 ruby-1.8.7_p160.ebuild:
1211 Removing vulnerable versions (#268515), fixing license (#233747).
1212
1213 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1214 Stable for HPPA (bug #268515).
1215
1216 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1217 Adapting rubygems notice.
1218
1219 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1220 amd64 stable, bug #268515.
1221
1222 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1223 arm/ia64/s390/sh/sparc stable wrt #268515
1224
1225 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1226 ruby-1.8.6_p368.ebuild:
1227 stable x86, security bug 268515
1228
1229 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1230 ruby-1.8.6_p368.ebuild:
1231 Stable on alpha, bug #268515
1232
1233 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1234 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1235
1236*ruby-1.8.7_p160 (07 May 2009)
1237*ruby-1.8.6_p368 (07 May 2009)
1238
1239 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1240 +ruby-1.8.7_p160.ebuild:
1241 Version bump as per secbug 268515. NB: These are the first ebuilds that
1242 no longer use ruby-config.
1243
1244*ruby-1.9.1-r1 (03 Apr 2009)
1245*ruby-1.8.7_p72-r11 (03 Apr 2009)
1246*ruby-1.8.6_p287-r13 (03 Apr 2009)
1247
1248 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1249 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1250 +files/ruby18-mkmf-parallel-install.patch,
1251 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1252 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1253 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1254 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1255 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1256 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1257 happy.
1258
1259*ruby-1.9.1 (21 Mar 2009)
1260
1261 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1262 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1263 +ruby-1.9.1.ebuild:
1264 Adding Ruby 1.9.1 for preliminary testing
1265
1266 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1267 ruby-1.8.6_p287-r12.ebuild:
1268 Marked ~ppc for bug #252315.
1269
1270 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1271 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1272 bug 261982.
1273
1274 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1275 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1276 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1277 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1278 Cleanup
1279
1280*ruby-1.8.7_p72-r10 (07 Mar 2009)
1281
1282 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1283 +ruby-1.8.7_p72-r10.ebuild:
1284 Add a revision of ruby 1.8.7 using eselect ruby.
1285
1286 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1287 ~mips keyworded, bug #252315.
1288
1289 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1290 ruby-1.8.6_p287-r5.ebuild:
1291 ppc stable, bug #260006
1292
1293 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1294 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1295
1296 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1297 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1298 Fixing Tk USE flag test, bug 258893.
1299
1300 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1301 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1302
1303 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1304 ruby-1.8.6_p287-r5.ebuild:
1305 amd64 stable wrt security bug #260006
1306
1307 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1308 Stable for HPPA (bug #260006).
1309
1310 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1311 ruby-1.8.6_p287-r5.ebuild:
1312 Stable on alpha, bug #260006
1313
1314*ruby-1.8.7_p72-r2 (23 Feb 2009)
1315*ruby-1.8.6_p287-r12 (23 Feb 2009)
1316*ruby-1.8.6_p287-r5 (23 Feb 2009)
1317
1318 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1319 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1320 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1321 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1322 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1323 now before compilation if Tk useflags don't match) and 230748 (adding
1324 --enable-option-checking=no for newer versions of autoconf).
1325
1326 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1327 arm/ia64/s390/sh/sparc stable wrt #254307
1328
1329 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1330 ruby-1.8.6_p287-r4.ebuild:
1331 Stable on alpha, bug #254307
1332
1333 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1334 ruby-1.8.6_p287-r11.ebuild:
1335 keyword ~x86-fbsd, bug #252315
1336
1337 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1338 ppc stable #254307
1339
1340 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1341 amd64/x86 stable, bug #254307
1342
1343 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1344 stable ppc64, bug 254307
1345
1346 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1347 Stable for HPPA (bug #254307).
1348
1349 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1350 ruby-1.8.6_p287-r11.ebuild:
1351 Marked ~hppa (bug #252315).
1352
1353*ruby-1.8.6_p287-r11 (11 Jan 2009)
1354
1355 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1356 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1357 +ruby-1.8.6_p287-r11.ebuild:
1358 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1359 Fixes #254307.
1360
1361 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1362 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1363
1364 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1365 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1366
1367 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1368 ruby-1.8.6_p287-r10.ebuild:
1369 Add ~sparc keyword, bug #252315
1370
1371*ruby-1.8.6_p287-r10 (23 Dec 2008)
1372
1373 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1374 +ruby-1.8.6_p287-r10.ebuild:
1375 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1376 keywords since eselect-ruby does not yet have these keywords.
1377
1378 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1379 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1380 Revert the ruby-config changes. We can't remove them until we provide an
1381 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1382 for breaking things as mentioned in bug #251833.
1383
1384 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1385 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1386 ruby-1.8.7_p72-r1.ebuild:
1387 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1388 Thanks for the people noticing this in bug #251833.
1389
1390 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1391 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1392 ruby-1.8.7_p72-r1.ebuild:
1393 Drop dependency on ruby-config, which will be removed from the tree. We
1394 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1395 is no need for ruby-config at this moment. For newer versions of Ruby we will
1396 use eselect-ruby, which can be found in the ruby overlay at the moment.
1397
1398 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1399 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1400 Use mirror://ruby in SRC_URI, fixes #237392.
1401
1402 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1403 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1404 -ruby-1.8.7_p72.ebuild:
1405 Remove old versions. Leave one old stable version with cjk support.
1406
1407*ruby-1.8.6_p287-r3 (29 Nov 2008)
1408
1409 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1410 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1411 +ruby-1.8.6_p287-r3.ebuild:
1412 Fix our expansion limit patch according to debian bug report
1413 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1414 make sure people will pick up the fixed version. Thanks to Alex Legler for
1415 mentioning the patch.
1416
1417*ruby-1.8.7_p72-r1 (26 Nov 2008)
1418*ruby-1.8.6_p287-r2 (26 Nov 2008)
1419
1420 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1421 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1422 +ruby-1.8.7_p72-r1.ebuild:
1423 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1424 Thanks to Alex Legler for providing the patch.
1425
1426 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1427 -ruby-1.8.6_p287.ebuild:
1428 Remove versions that will not become stable
1429
1430 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1431 ruby-1.8.6_p287-r1.ebuild:
1432 ppc stable, bug #225465
1433
1434 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1435 ruby-1.8.6_p287-r1.ebuild:
1436 amd64 stable wrt security bug #225465
1437
1438 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1439 alpha/ia64/x86 stable wrt #225465
1440
1441 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1442 ruby-1.8.6_p287-r1.ebuild:
1443 Sparc stable --- Security Bug #225465 --- good since late August.
1444
1445 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1446 Stable on ppc64; bug #225465
1447
1448 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1449 Stable for HPPA (bug #225465).
1450
1451*ruby-1.8.6_p287-r1 (29 Aug 2008)
1452
1453 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1454 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1455 +ruby-1.8.6_p287-r1.ebuild:
1456 Fix REXML security issues, bug #236060.
1457
1458 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1459 Add GLEP 56 USE flag descriptions.
1460
1461*ruby-1.8.7_p72 (15 Aug 2008)
1462
1463 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1464 +ruby-1.8.7_p72.ebuild:
1465 bump 1.8.7 to latest patch release
1466
1467*ruby-1.8.6_p287 (11 Aug 2008)
1468
1469 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1470 Version bump for brown paper bag relelease.
1471
1472 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1473 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1474 Remove broken version in favor of the just-added 1.8.6_p286
1475
1476*ruby-1.8.6_p286 (10 Aug 2008)
1477
1478 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1479 Version bump to latest released version of ruby 1.8.6. This version fixes the
1480 security issues reported in #225465 and #234224. The cjk USE flag has been
1481 dropped since no compatible patches have been released yet.
1482
1483 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1484 ruby-1.8.6_p230.ebuild:
1485 drop cjk from SRC_URI as well
1486
1487 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1488 Drop cjk support since the most recent oniguruma patches no longer apply to
1489 this version, #230111.
1490
1491 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1492 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1493 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1494 Unfortunately the official p230 has a change which causes segmentation faults
1495 for applications like Rails and RSpec, so we are reverting that specific
1496 change.
1497
1498*ruby-1.8.7_p22 (29 Jun 2008)
1499
1500 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1501 +ruby-1.8.7_p22.ebuild:
1502 bump 1.8.7 for security fix
1503
1504 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1505 nevermind, don't bump this yet
1506
1507*ruby-1.8.6_p230 (20 Jun 2008)
1508
1509 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1510 version bump
1511
1512*ruby-1.8.7 (10 Jun 2008)
1513
1514 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1515 +ruby-1.8.7.ebuild:
1516 bump 1.8.7 to final
1517
1518*ruby-1.8.7_pre2 (21 Apr 2008)
1519
1520 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1521 +ruby-1.8.7_pre2.ebuild:
1522 Version Bump
1523
1524*ruby-1.8.7_pre1 (16 Apr 2008)
1525
1526 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1527 Version bump. Drop cjk until a new version of oniguruma appears.
1528
1529 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1530 amd64 stable, bug 212264
1531
1532 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1533 Stable for HPPA (bug #212264).
1534
1535 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1536 ruby-1.8.6_p114.ebuild:
1537 ppc stable, bug #212264
1538
1539 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1540 alpha/ia64 stable wrt #212264
1541
1542 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1543 ruby-1.8.6_p114.ebuild:
1544 stable x86, security bug 212264
1545
1546 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1547 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1548 as expected.
1549
1550 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1551 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1552
1553*ruby-1.8.6_p114 (05 Mar 2008)
1554
1555 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1556 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1557 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1558 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1559 Version bump for #212264. Remove old ebuilds.
1560
1561 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1562 alpha/ia64 stable wrt #208916
1563
1564 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1565 Stable on ppc wrt bug 208916
1566
1567 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1568 x86 stable, bug #208916
1569
1570 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1571 ruby-1.8.6_p111-r1.ebuild:
1572 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1573
1574 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1575 -files/ruby-1.8.6-exit-status.patch,
1576 -files/ruby-1.8.6_p110-net-http-p111.patch,
1577 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1578 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1579 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1580 Remove old versions
1581
1582 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1583 Stable on ppc64
1584
1585 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1586 Stable on amd64; bug 199191
1587
1588 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1589 alpha/ia64/sparc stable wrt #199191
1590
1591 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1592 Remove now-obsolete warning about coreutils versions, #203156.
1593
1594 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1595 Stable for HPPA (bug #199191).
1596
1597*ruby-1.8.6_p111-r1 (23 Dec 2007)
1598
1599 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1600 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1601 ssl USE flags. Patch to p113.
1602
1603 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1604 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1605
1606 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1607 x86 stable, security bug #199191
1608
1609*ruby-1.8.6_p111 (23 Dec 2007)
1610
1611 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1612 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1613 Version bump with patch for bug #199191
1614
1615 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1616 Move dependency on (X)Emacs modes to PDEPEND.
1617
1618 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1619 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1620 bug 196413
1621
1622*ruby-1.8.6_p110-r2 (21 Oct 2007)
1623
1624 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1625 +ruby-1.8.6_p110-r2.ebuild:
1626 Add emacs and xemacs USE flags and use them to pull in the correct editing
1627 mode for each. Had to drop several arch keywords as reported on bug 196413.
1628
1629 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1630 amd64 stable, security bug 194236
1631
1632 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1633 ruby-1.8.6_p110-r1.ebuild:
1634 Stable on ppc64; bug #194236
1635
1636 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1637 amd64 stable, security bug 194236
1638
1639 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1640 Stable for HPPA (bug #194236).
1641
1642 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1643 alpha/ia64/sparc stable wrt security #194236
1644
1645 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1646 ruby-1.8.6_p110-r1.ebuild:
1647 ppc stable, bug #194236
1648
1649 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1650 ruby-1.8.6_p110-r1.ebuild:
1651 stable x86, security bug 194236
1652
1653 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1654 ruby-1.8.5_p113.ebuild:
1655 stable x86, security bug 194236
1656
1657 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1658 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1659 -ruby-1.8.6_p110.ebuild:
1660 Remove old versions
1661
1662*ruby-1.8.6_p110-r1 (30 Sep 2007)
1663*ruby-1.8.5_p113 (30 Sep 2007)
1664
1665 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1666 +files/ruby-1.8.5_p113-net-http-p114.patch,
1667 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1668 +ruby-1.8.6_p110-r1.ebuild:
1669 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1670 using 1.8.6-p110 as base ebuild.
1671
1672 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1673 More fixes from gentoo-dev and graaff
1674
1675 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1676 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1677
1678*ruby-1.8.6_p110 (24 Sep 2007)
1679
1680 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1681 Version bump
1682
1683*ruby-1.8.6_p36-r4 (26 Aug 2007)
1684
1685 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1686 +ruby-1.8.6_p36-r4.ebuild:
1687 Use user LDFLAGS, #181436
1688
1689 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1690 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1691 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1692 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1693
1694 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1695 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1696 -ruby-1.8.6_p36-r2.ebuild:
1697 Remove some older versions that will not be promoted to stable, keeping at
1698 least one version of each release.
1699
1700 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1701 ruby-1.8.6_p36-r3.ebuild:
1702 (QA) RESTRICT clean up.
1703
1704*ruby-1.8.6_p36-r3 (04 Jul 2007)
1705
1706 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1707 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1708 fixed memory leak loading .so bug #182946
1709
1710 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1711 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1712 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1713 ruby-1.8.6_p36-r2.ebuild:
1714 (QA) RESTRICT clean up.
1715
1716 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1717 Re-add stable keyword for alpha as per bug #181110
1718
1719 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1720 Back to ~amd64 wrt bug 181110
1721
1722 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1723 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1724
1725*ruby-1.8.6_p36-r2 (20 Jun 2007)
1726
1727 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1728 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1729
1730*ruby-1.8.6_p36-r1 (18 Jun 2007)
1731
1732 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1733 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1734 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1735 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1736 spbecker
1737
1738 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1739 Stable on amd64 wrt bug 181110
1740
1741*ruby-1.8.6_p36 (12 Jun 2007)
1742
1743 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1744 Version Bump. Bug #181379
1745
1746 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1747 Stable on mips, per #181110.
1748
1749 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1750 Stable on ppc wrt bug 181110
1751
1752 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1753 Stable for HPPA (bug #181110).
1754
1755 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1756 alpha/ia64/x86 stable wrt #181110
1757
1758 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1759 Stable on sparc wrt #181110
1760
1761 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1762 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1763
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1764 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1765 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1766 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1767 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.690

  ViewVC Help
Powered by ViewVC 1.1.20