/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.276 Revision 1.675
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.276 2007/06/06 19:07:01 ranger Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.675 2014/11/05 18:22:03 maekke Exp $
4
5 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
6 arm stable, bug #527084
7
8 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
9 arm stable, bug #527084
10
11 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
12 ruby-2.0.0_p594.ebuild:
13 Stable for x86, wrt bug #527084
14
15 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
16 ruby-2.0.0_p594.ebuild:
17 Stable for amd64, wrt bug #527084
18
19 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
20 ruby-2.0.0_p594.ebuild:
21 Stable for HPPA (bug #527084).
22
23*ruby-2.1.4 (27 Oct 2014)
24*ruby-2.0.0_p594 (27 Oct 2014)
25*ruby-1.9.3_p550 (27 Oct 2014)
26
27 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
28 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
29 Version bump for security bug 527084. Note that OpenSSL defaults have changed
30 in these versions which may lead to incompatibilities:
31 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
32 -openssl/
33
34 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
35 ruby-2.0.0_p481.ebuild:
36 Stable for sparc, wrt bug #512904
37
38 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
39 ruby-2.0.0_p481.ebuild:
40 Stable for ppc64, wrt bug #512904
41
42 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
43 ruby-2.0.0_p481.ebuild:
44 Stable for ppc, wrt bug #512904
45
46 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
47 ruby-2.0.0_p481.ebuild:
48 Stable for amd64, wrt bug #512904
49
50*ruby-2.1.3 (20 Sep 2014)
51
52 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
53 Version bump:
54 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
55
56*ruby-2.0.0_p576 (20 Sep 2014)
57
58 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
59 Version bump.
60
61 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
62 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
63 Depend on the rubygems virtual with an explicit SLOT now that the specific
64 rubygems versions are listed in virtual/rubygems. This will make the
65 dependencies more explicit and should decrease resolver surprises picking the
66 wrong virtual/rubygems SLOT later on.
67
68 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
69 Cleanup.
70
71 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
72 ruby-2.0.0_p481.ebuild:
73 x86 stable wrt bug #512904
74
75 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
76 Stable on alpha, bug #512904
77
78 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
79 arm stable, bug #512904
80
81 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
82 arm stable, bug #512904
83
84 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
85 ruby-2.0.0_p481.ebuild:
86 ia64 stable wrt bug #512904
87
88 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
89 Stable for HPPA (bug #512904).
90
91 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
92 Stable for HPPA (bug #512904).
93
94 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
95 -ruby-2.1.1-r1.ebuild:
96 Cleanup.
97
98 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
99 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
100 512848.
101
102*ruby-1.9.3_p547 (17 May 2014)
103
104 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
105 Version bump.
106
107*ruby-2.1.2 (10 May 2014)
108*ruby-2.0.0_p481 (10 May 2014)
109
110 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
111 +ruby-2.1.2.ebuild:
112 Version bump.
113
114 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
115 -ruby-2.0.0_p353-r2.ebuild:
116 Cleanup.
117
118 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
119 ruby-2.1.1-r1.ebuild:
120 Remove useless libruby symlinks, bug 503584.
121
122 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
123 -ruby-2.1.1.ebuild:
124 Cleanup.
125
126 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
127 Remove unneeded useflag descriptions from metadata.xml
128
129 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
130 -ruby-1.8.7_p374.ebuild:
131 Remove Ruby 1.8. See bug #434064.
132
133*ruby-2.1.1-r1 (14 Apr 2014)
134
135 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
136 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
137 Thanks to Andrew Savchenko for providing a patch.
138
139 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
140 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
141 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
142 ruby-2.1.1.ebuild:
143 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
144
145*ruby-2.1.1 (06 Mar 2014)
146
147 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
148 Version bump. Update module selection code to fix automagic dependencies.
149 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
150 503106.
151
152*ruby-2.0.0_p451 (05 Mar 2014)
153
154 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
155 Version bump. Update module selection code to fix automagic dependencies.
156 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
157 503106.
158
159*ruby-1.9.3_p545 (26 Feb 2014)
160
161 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
162 Version bump. Drop tk USE flag due to bug 500894.
163
164*ruby-2.0.0_p353-r2 (23 Feb 2014)
165
166 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
167 Backport support for uclibc, fixing bug 484534.
168
169 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
170 Stable for alpha, wrt bug #483254
171
172 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
173 Stable for sparc, wrt bug #483254
174
175 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
176 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
177 Fix slot conflicts, #498970
178
179 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
180 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
181 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
182 bug 497130.
183
184 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
185 -ruby-1.9.3_p448-r1.ebuild:
186 Remove vulnerable versions.
187
188 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
189 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
190 Remove vulnerable versions.
191
192 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
193 arm stable, bug #492282
194
195*ruby-2.0.0_p353-r1 (03 Jan 2014)
196
197 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
198 ruby-2.1.0.ebuild:
199 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
200
201 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
202 arm stable, bug #483254
203
204 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
205 ruby-2.0.0_p353.ebuild:
206 ia64 stable wrt bug #492282
207
208*ruby-2.1.0 (26 Dec 2013)
209
210 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
211 Version bump.
212
213 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
214 ia64 stable wrt bug #483254
215
216 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
217 Stable for sparc, wrt bug #492282
218
219 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
220 Stable for arm, wrt bug #492282
221
222 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
223 Stable for alpha, wrt bug #492282
224
225 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
226 ruby-2.0.0_p353.ebuild:
227 Stable for x86, wrt bug #492282
228
229 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
230 ruby-2.0.0_p353.ebuild:
231 Stable for ppc64, wrt bug #492282
232
233 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
234 ruby-2.0.0_p353.ebuild:
235 Stable for ppc, wrt bug #492282
236
237 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
238 Stable for ppc64, wrt bug #483254
239
240 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
241 Stable for ppc, wrt bug #483254
242
243 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
244 ruby-2.0.0_p353.ebuild:
245 Stable for amd64, wrt bug #492282
246
247 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
248 Stable for HPPA (bug #492282).
249
250 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
251 Stable for HPPA (bug #492282).
252
253*ruby-2.0.0_p353 (22 Nov 2013)
254*ruby-1.9.3_p484 (22 Nov 2013)
255
256 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
257 +ruby-2.0.0_p353.ebuild:
258 Version bumps for security bug 492282.
259
260*ruby-2.0.0_p247-r2 (14 Oct 2013)
261
262 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
263 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
264 2.x. Fixes bug 483466.
265
266 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
267 -ruby-1.9.3_p429.ebuild:
268 Cleanup.
269
270 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
271 Stable for HPPA (bug #483254).
272
273 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
274 Stable for x86, wrt bug #483254
275
276 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
277 Stable for amd64, wrt bug #483254
278
279 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
280 ruby-1.9.3_p448.ebuild:
281 Stable for s390, wrt bug #475074
282
283*ruby-2.0.0_p247-r1 (29 Jul 2013)
284*ruby-1.9.3_p448-r1 (29 Jul 2013)
285*ruby-1.8.7_p374-r1 (29 Jul 2013)
286
287 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
288 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
289 Revision bump to counter breakage introduced in portage 2.1.13 for bug
290 465000. Thanks to thansen for reporting.
291
292 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
293 ruby-1.9.3_p448.ebuild:
294 Stable for sparc, wrt bug #475074
295
296 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
297 ruby-1.9.3_p448.ebuild:
298 Stable for sh, wrt bug #475074
299
300 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
301 ruby-1.9.3_p448.ebuild:
302 Stable for ia64, wrt bug #475074
303
304*ruby-2.0.0_p247 (07 Jul 2013)
305
306 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
307 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
308 ruby20.
309
310 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
311 ruby-1.9.3_p448.ebuild:
312 Stable for alpha, wrt bug #475074
313
314 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
315 ruby-1.9.3_p448.ebuild:
316 Stable for ppc64, wrt bug #475074
317
318 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
319 ruby-1.9.3_p448.ebuild:
320 Stable for HPPA (bug #475074).
321
322 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
323 ruby-1.9.3_p448.ebuild:
324 Stable for ppc, wrt bug #475074
325
326 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
327 ruby-1.9.3_p448.ebuild:
328 Stable for arm, wrt bug #475074
329
330 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
331 ruby-1.9.3_p448.ebuild:
332 Stable for x86, wrt bug #475074
333
334 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
335 ruby-1.9.3_p448.ebuild:
336 Stable for amd64, wrt bug #475074
337
338*ruby-1.9.3_p448 (30 Jun 2013)
339*ruby-1.8.7_p374 (30 Jun 2013)
340
341 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
342 +ruby-1.9.3_p448.ebuild:
343 Version bumps for security bug 475074.
344
345 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
346 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
347 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
348 Cleanup. Remove vulnerable versions.
349
350 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
351 Stable for sh, wrt bug #469984
352
353 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
354 Stable for s390, wrt bug #469984
355
356 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
357 Stable for ppc64, wrt bug #469984
358
359 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
360 Stable for ia64, wrt bug #469984
361
362 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
363 Stable for alpha, wrt bug #469984
364
365 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
366 Stable for sparc, wrt bug #469984
367
368 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
369 Remove non-functional dosym calls, bug 442462.
370
371 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
372 Stable for arm, wrt bug #469984
373
374 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
375 Stable for ppc, wrt bug #469984
376
377 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
378 Stable for x86, wrt bug #469984
379
380 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
381 Stable for amd64, wrt bug #469984
382
383 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
384 Stable for HPPA (bug #469984).
385
386*ruby-1.9.3_p429 (16 May 2013)
387
388 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
389 Version bump for security bug #469984.
390
391 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
392 Stable for s390, wrt bug #437366
393
394 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
395 Stable for sparc, wrt bug #437366
396
397 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
398 Stable for ia64, wrt bug #437366
399
400 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
401 Stable for alpha, wrt bug #437366
402
403 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
404 Stable for ppc64, wrt bug #437366
405
406 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
407 Stable for arm, wrt bug #437366
408
409 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
410 Stable for sh, wrt bug #437366
411
412 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
413 Marking ruby-1.8.7_p371 ppc for bug 437366
414
415 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
416 Stable for HPPA (bug #437366).
417
418 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
419 Stable for x86, wrt bug #437366
420
421 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
422 Stable for amd64, wrt bug #437366
423
424 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
425 Stable for sh, wrt bug #458776
426
427 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
428 Stable for alpha, wrt bug #458776
429
430 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
431 Add patch to fix bug #459074 (parallel build).
432
433 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
434 Stable for arm, wrt bug #458776
435
436 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
437 Stable for s390, wrt bug #458776
438
439 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
440 Stable for sparc, wrt bug #458776
441
442 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
443 Stable for hppa, wrt bug #458776
444
445 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
446 Stable for ia64, wrt bug #458776
447
448 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
449 Stable for x86, wrt bug #458776
450
451 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
452 Stable for amd64, wrt bug #458776
453
454 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
455 Stable for ppc64, wrt bug #458776
456
457 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
458 Stable for ppc, wrt bug #458776
459
460*ruby-1.9.3_p392 (22 Feb 2013)
461
462 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
463 Version bump for security bug 458776.
464
465*ruby-1.9.3_p385 (10 Feb 2013)
466
467 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
468 Version bump. Fixes security bug 442580.
469
470 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
471 keyword ~amd64-fbsd
472
473*ruby-1.8.7_p371 (06 Jan 2013)
474
475 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
476 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
477 Version bump for security bug 437366.
478
479 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
480 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
481 Cleanup.
482
483 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
484 Stable for ppc, wrt bug #427774
485
486 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
487 Stable for HPPA (bug #411507).
488
489 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
490 alpha/ia64/s390/sh/sparc stable wrt #434480
491
492 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
493 ruby-1.9.3_p286.ebuild:
494 Remove HPPA target hack (bug #342819).
495
496 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
497 alpha/ia64/s390/sh/sparc stable wrt #411507
498
499 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
500 Stable for HPPA (bug #434480).
501
502*ruby-1.9.3_p286 (15 Oct 2012)
503
504 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
505 Version bump. Fixes bugs #437264 and #437264.
506
507 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
508 stable arm, bug #434480
509
510 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
511 stable ppc ppc64, bug #434480
512
513 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
514 Stable for x86, wrt bug #434480
515
516 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
517 ruby-1.9.3_p194-r1.ebuild:
518 Update LICENSE, bug 434332.
519
520 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
521 Stable for amd64, wrt bug #434480
522
523 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
524 Stable for amd64, wrt bug #427774
525
526 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
527 arm stable, bug #427774
528
529 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
530 ruby-1.9.3_p194-r1.ebuild:
531 Stable ppc64, bug #411507
532
533 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
534 marked x86 per bug 427774
535
536 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
537 -ruby-1.9.3_p194.ebuild:
538 Cleanup.
539
540 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
541 ppc stable #411507
542
543 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
544 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
545 424611.
546
547*ruby-1.8.7_p370 (07 Jul 2012)
548
549 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
550 Version bump. Fix bug 378567 thanks to slyfox.
551
552 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
553 x86 stable, see bug 411507
554
555 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
556 arm stable, bug #411507
557
558 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
559 Stable for amd64, wrt bug #411507
560
561*ruby-1.9.3_p194-r1 (12 May 2012)
562
563 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
564 +ruby-1.9.3_p194-r1.ebuild:
565 Revision bump to fix mkmf for parallel build/install. Also enable verbose
566 build, so that the log makes sense if it fails.
567
568*ruby-1.9.3_p194 (30 Apr 2012)
569
570 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
571 Version bump.
572
573 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
574 keyword ~amd64-fbsd
575
576*ruby-1.8.7_p358 (20 Apr 2012)
577
578 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
579 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
580 Rails 3.2.
581
582 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
583 Add ~x86-fbsd, #332593
584
585*ruby-1.9.3_p125 (18 Feb 2012)
586
587 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
588 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
589
590 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
591 add ~arm, bug #332593
592
593 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
594 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
595
596 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
597 x86 stable wrt bug #396301
598
599 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
600 Stable for HPPA (bug #396301).
601
602 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
603 Stable for ppc/ppc64; bug #396301
604
605 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
606 Marked ~hppa (bug #332593).
607
608 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
609 Add back ~alpha keyword now that rubygems is keyworded.
610
611 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
612 Stable for AMD64, wrt security bug #396301
613
614*ruby-1.8.7_p357 (28 Dec 2011)
615
616 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
617 Version bump for security bug 396301.
618
619 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
620 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
621
622 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
623 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
624 keyworded, bug 332593.
625
626 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
627 Block older versions of packages that are no longer compatible. Remove
628 ancient blocks on packags long gone from the tree.
629
630 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
631 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
632 Remove old versions.
633
634*ruby-1.9.3_p0 (18 Dec 2011)
635
636 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
637 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
638 suite which need to be diagnosed first.
639
640 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
641 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
642 #332593).
643
644 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
645 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
646 #332593).
647
648 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
649 alpha/ia64/s390/sh/sparc stable wrt #386369
650
651*ruby-1.9.3_rc1 (22 Oct 2011)
652
653 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
654 Version bump.
655
656 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
657 arm stable, bug #386369
658
659 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
660 x86 stable, bug 386369
661
662 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
663 Stable for HPPA (bug #386369).
664
665 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
666 ppc/ppc64 stable wrt #386369
667
668 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
669 Stable on amd64 wrt bug #386369
670
671 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
672 Remove vulnerable version, bug 386369.
673
674*ruby-1.8.7_p352 (30 Aug 2011)
675
676 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
677 +ruby-1.8.7_p352.ebuild:
678 Patchlevel bump for ruby:1.8. Removing old version
679
680*ruby-1.9.2_p290 (30 Aug 2011)
681
682 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
683 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
684 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
685 old patchlevels.
686
687 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
688 ruby-1.8.7_p334-r2.ebuild:
689 ppc/ppc64 stable wrt #378691
690
691*ruby-1.8.7_p334-r2 (22 Jul 2011)
692
693 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
694 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
695 for chasing down upstream and us.
696
697 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
698 Added ~mips, bug 332593
699
700 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
701 ruby-1.8.7_p334-r1.ebuild:
702 ppc64 stable wrt #369141
703
704 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
705 ia64/s390/sh/sparc stable wrt #369141
706
707 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
708 Stable for HPPA (bug #369141).
709
710 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
711 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
712
713 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
714 arm/x86 stable, bug #369141
715
716 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
717 Stable on amd64 wrt bug #369141
718
719 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
720 ruby-1.8.7_p334-r1.ebuild:
721 Stable on alpha, bug #369141
722
723*ruby-1.8.7_p334-r1 (31 May 2011)
724
725 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
726 Revision bump for security bug 369141 (CVE-2011-0188)
727
728*ruby-1.9.2-r1 (16 May 2011)
729
730 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
731 Don't remove racc files since all other ruby targets ship these files
732 themselves as well. Closes bug 363419.
733
734 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
735 ruby-1.8.7_p334.ebuild:
736 Remove old version. Remove obsolete and unused old-style virtual/ruby.
737
738 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
739 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
740
741 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
742 Add append-flags -mieee on sh, bug #357559
743
744 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
745 alpha/arm/ia64/s390/sh stable wrt #355439
746
747 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
748 Marked ~ppc64 wrt #332593
749
750 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
751 ruby-1.8.7_p334.ebuild:
752 x86 stable wrt security bug #355439
753
754 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
755 ruby-1.8.7_p334.ebuild:
756 ppc/ppc64 stable wrt #355439
757
758 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
759 Stable on amd64 wrt bug #355439
760
761 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
762 Stable for HPPA (bug #355439).
763
764*ruby-1.8.7_p334 (19 Feb 2011)
765
766 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
767 Version bump 1.8.7 series, security bug 355439
768
769 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
770 ruby-1.9.2.ebuild:
771 Remove PROVIDE for old-style virtual/ruby per bug 265054.
772
773 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
774 Remove masked ruby 1.8.6 per bug 332597.
775
776 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
777 -ruby-1.9.2_rc2.ebuild:
778 Removing old and vulnerable ebuilds
779
780 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
781 Marking ruby-1.8.7_p302 ppc64 for bug 332957
782
783 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
784 alpha/ia64/s390/sh/sparc stable wrt #332957
785
786*ruby-1.9.2 (24 Aug 2010)
787
788 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
789 metadata.xml:
790 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
791 and x86-fbsd due to a new dependency on rdoc.
792
793 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
794 arm stable, bug #332957
795
796 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
797 ruby-1.8.7_p302.ebuild:
798 x86 stable wrt security bug #332957
799
800 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
801 Stable on amd64 wrt bug #332957
802
803 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
804 Stable for PPC (bug #332957).
805
806 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
807 Stable for HPPA (bug #332957).
808
809*ruby-1.8.7_p302 (21 Aug 2010)
810
811 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
812 +ruby-1.8.7_p302.ebuild:
813 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
814 installation path.
815
816*ruby-1.8.6_p399 (19 Aug 2010)
817
818 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
819 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
820 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
821 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
822 installation path (reported by the x86 team in bug 332597)
823
824*ruby-1.9.2_rc2-r1 (18 Aug 2010)
825
826 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
827 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
828 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
829 the rubygems loading code. Add USE flag for psych.
830
831 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
832 ruby-1.9.2_rc2.ebuild:
833 Remove two keepdir that will try to keep an empty path, closes bug
834 #333163.
835
836 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
837 Marked ~ppc (bug #332593).
838
839 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
840 ruby-1.9.2_rc2.ebuild:
841 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
842
843 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
844 ruby-1.8.7_p299.ebuild:
845 Bump eselect-ruby dependency
846
847 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
848 -ruby-1.9.1_p429.ebuild:
849 Remove ebuild that is not target for unmask anyway.
850
851 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
852 ruby-1.9.2_rc2.ebuild:
853 Try 2 to fix the berkdb 5 issue on 1.9.
854
855 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
856 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
857 ruby-1.9.2_rc2.ebuild:
858 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
859 support for adding new patchsets without bumping the revision for all the
860 old ebuilds as well.
861
862*ruby-1.9.2_rc2 (14 Jul 2010)
863
864 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
865 +ruby-1.9.2_rc2.ebuild:
866 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
867 might cause _further_ build failures as it changed slightly behaviour.
868 You're going to need to rebuild rubygems and then all the packages
869 previously installed after upgrading to this.
870
871 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
872 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
873 -ruby-1.9.1_p376.ebuild:
874 Cleanup old versions.
875
876*ruby-1.9.1_p429 (04 Jul 2010)
877
878 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
879 +ruby-1.9.1_p429.ebuild:
880 Version bump to new 1.9.1 release.
881
882*ruby-1.8.7_p299 (23 Jun 2010)
883
884 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
885 +ruby-1.8.7_p299.ebuild:
886 Version bump.
887
888 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
889 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
890 remove useless comments
891
892 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
893 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
894 ruby-1.9.1_p376.ebuild:
895 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
896 dev.gentoo.org now.
897
898 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
899 ruby-1.9.1_p376.ebuild:
900 Use the correct RUBYLIB.
901
902*ruby-1.8.7_p249-r2 (18 May 2010)
903*ruby-1.8.6_p388-r1 (18 May 2010)
904
905 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
906 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
907 ruby-1.9.1_p376.ebuild, metadata.xml:
908 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
909 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
910 add USE flags for ncurses, readline and libedit, and properly depend on
911 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
912 Emacs versions support ruby-mode themselves and it should be even more
913 updated.
914
915*ruby-1.8.7_p249-r1 (06 May 2010)
916
917 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
918 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
919 309789 by Sune Kloppenborg Jeppesen.
920
921 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
922 ruby-1.8.7_p249.ebuild:
923 Use $PVR instead of $PV in patchset names
924
925 06 May 2010; Alex Legler <a3li@gentoo.org>
926 -files/ruby-1.8.6-memory-leak.diff,
927 -files/ruby18-mkmf-parallel-install.patch,
928 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
929 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
930 Remove old version. Cleanup in files/
931
932*ruby-1.9.1_p376 (01 May 2010)
933
934 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
935 Version bump. Fixes security bugs 296052 and 300468. No longer installs
936 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
937 instead.
938
939 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
940 -ruby-1.8.7_p174-r1.ebuild:
941 Remove vulnerable ebuilds, 300468
942
943 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
944 ruby-1.8.7_p249.ebuild:
945 amd64 stable, security bug 300468
946
947 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
948 ruby-1.8.7_p249.ebuild:
949 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
950
951 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
952 Stable for HPPA (bug #300468).
953
954 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
955 Stable for HPPA (bug #300468).
956
957 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
958 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
959
960 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
961 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
962
963 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
964 ruby-1.8.6_p388.ebuild:
965 stable x86, security bug 300468
966
967 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
968 ruby-1.8.7_p249.ebuild:
969 stable x86, security bug 300468
970
971*ruby-1.8.6_p388 (10 Jan 2010)
972
973 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
974 +ruby-1.8.6_p388.ebuild:
975 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
976 version. The new ebuild also has the fix for bug 168939.
977
978*ruby-1.8.7_p249 (10 Jan 2010)
979
980 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
981 +ruby-1.8.7_p249.ebuild:
982 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
983 version
984
985 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
986 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
987
988*ruby-1.8.7_p248 (25 Dec 2009)
989
990 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
991 Version bump
992
993 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
994 Remove old version.
995
996 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
997 Remove old version.
998
999 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1000 ia64/s390/sh stable wrt #288699
1001
1002 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1003 stable sparc, bug 288699
1004
1005 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1006 arm stable, bug #288699
1007
1008 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1009 amd64/x86 stable, bug #288699
1010
1011 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1012 ruby-1.8.7_p174-r1.ebuild:
1013 Stable on alpha, bug #288699
1014
1015 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1016 ppc stable #288699
1017
1018 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1019 Stable for HPPA (bug #288699).
1020
1021 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1022 Marked ~hppa too.
1023
1024*ruby-1.8.7_p174-r1 (06 Oct 2009)
1025
1026 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1027 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1028 eselect-ruby cleanup feature.
1029
1030*ruby-1.9.1_p243 (09 Sep 2009)
1031
1032 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1033 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1034 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1035 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1036 -files/ruby19-rubygems-proxy.patch,
1037 -files/ruby-1.9.1_p129-parallelmake.patch,
1038 -files/ruby19-mkmf-parallel-install.patch:
1039 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1040 168939. Cleaning up old patches.
1041
1042*ruby-1.8.6_p383 (20 Aug 2009)
1043
1044 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1045 Patchlevel bump.
1046
1047 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1048 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1049 ruby-1.9.1_p129-r1.ebuild:
1050 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1051
1052 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1053 Removing vulnerable ebuild, bug 273213.
1054
1055 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1056 Marking ruby-1.8.6_p369 ppc for bug 273213
1057
1058 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1059 ruby-1.9.1_p129-r1.ebuild:
1060 Prepend our library path instead of overwriting it during src_install.
1061 Thanks to the reporter of bug #274824.
1062
1063*ruby-1.8.7_p174 (18 Jun 2009)
1064
1065 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1066 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1067 Replacing 187_p173 with _p174 because of a regression. Unifying the
1068 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1069 patchsets.
1070
1071 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1072 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1073
1074 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1075 arm/ia64/s390/sh/sparc stable wrt #273213
1076
1077 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1078 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1079 Removing old version, minor cleanup
1080
1081 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1082 -files/ruby-1.8.6-openssl.patch,
1083 -files/ruby-1.8.6-shortname_constants.patch,
1084 -files/ruby-1.8.6_p111-r13657.patch,
1085 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1086 Removing vulnerable old Ruby version and stale patches, bug 274108.
1087
1088 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1089 ruby-1.8.6_p369.ebuild:
1090 Stable on alpha, bug #273213
1091
1092 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1093 Stable for HPPA (bug #273213).
1094
1095 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1096 ruby-1.8.6_p369.ebuild:
1097 stable x86, security bug 273213
1098
1099 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1100 amd64 stable, security bug 273213.
1101
1102*ruby-1.8.7_p173 (10 Jun 2009)
1103*ruby-1.8.6_p369 (10 Jun 2009)
1104
1105 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1106 +ruby-1.8.7_p173.ebuild:
1107 Version bumps for bug #273213.
1108
1109*ruby-1.9.1_p129-r1 (27 May 2009)
1110
1111 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1112 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1113 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1114 +files/ruby-1.9.1_p129-parallelmake.patch:
1115 Revision bump, add patches 1) to make Ruby behave more similarly between
1116 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1117 extensions (undefined symbols in them will cause abort at runtime 3) to
1118 remove a concurrency issue when building the dl extension that could
1119 result in a broken dl.so.
1120
1121 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1122 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1123 Don't block rdoc-2 or later (which may enter Portage one day as it's
1124 needed by some Rakefiles).
1125
1126 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1127 ruby-1.9.1_p129.ebuild:
1128 Add ~x86-fbsd keyword.
1129
1130 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1131 keyword ~sparc-fbsd, bug #252315
1132
1133*ruby-1.9.1_p129 (15 May 2009)
1134
1135 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1136 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1137 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1138 included in every release.
1139
1140 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1141 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1142 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1143 ruby-1.8.7_p160.ebuild:
1144 Removing vulnerable versions (#268515), fixing license (#233747).
1145
1146 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1147 Stable for HPPA (bug #268515).
1148
1149 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1150 Adapting rubygems notice.
1151
1152 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1153 amd64 stable, bug #268515.
1154
1155 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1156 arm/ia64/s390/sh/sparc stable wrt #268515
1157
1158 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1159 ruby-1.8.6_p368.ebuild:
1160 stable x86, security bug 268515
1161
1162 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1163 ruby-1.8.6_p368.ebuild:
1164 Stable on alpha, bug #268515
1165
1166 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1167 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1168
1169*ruby-1.8.7_p160 (07 May 2009)
1170*ruby-1.8.6_p368 (07 May 2009)
1171
1172 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1173 +ruby-1.8.7_p160.ebuild:
1174 Version bump as per secbug 268515. NB: These are the first ebuilds that
1175 no longer use ruby-config.
1176
1177*ruby-1.9.1-r1 (03 Apr 2009)
1178*ruby-1.8.7_p72-r11 (03 Apr 2009)
1179*ruby-1.8.6_p287-r13 (03 Apr 2009)
1180
1181 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1182 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1183 +files/ruby18-mkmf-parallel-install.patch,
1184 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1185 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1186 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1187 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1188 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1189 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1190 happy.
1191
1192*ruby-1.9.1 (21 Mar 2009)
1193
1194 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1195 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1196 +ruby-1.9.1.ebuild:
1197 Adding Ruby 1.9.1 for preliminary testing
1198
1199 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1200 ruby-1.8.6_p287-r12.ebuild:
1201 Marked ~ppc for bug #252315.
1202
1203 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1204 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1205 bug 261982.
1206
1207 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1208 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1209 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1210 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1211 Cleanup
1212
1213*ruby-1.8.7_p72-r10 (07 Mar 2009)
1214
1215 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1216 +ruby-1.8.7_p72-r10.ebuild:
1217 Add a revision of ruby 1.8.7 using eselect ruby.
1218
1219 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1220 ~mips keyworded, bug #252315.
1221
1222 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1223 ruby-1.8.6_p287-r5.ebuild:
1224 ppc stable, bug #260006
1225
1226 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1227 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1228
1229 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1230 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1231 Fixing Tk USE flag test, bug 258893.
1232
1233 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1234 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1235
1236 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1237 ruby-1.8.6_p287-r5.ebuild:
1238 amd64 stable wrt security bug #260006
1239
1240 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1241 Stable for HPPA (bug #260006).
1242
1243 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1244 ruby-1.8.6_p287-r5.ebuild:
1245 Stable on alpha, bug #260006
1246
1247*ruby-1.8.7_p72-r2 (23 Feb 2009)
1248*ruby-1.8.6_p287-r12 (23 Feb 2009)
1249*ruby-1.8.6_p287-r5 (23 Feb 2009)
1250
1251 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1252 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1253 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1254 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1255 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1256 now before compilation if Tk useflags don't match) and 230748 (adding
1257 --enable-option-checking=no for newer versions of autoconf).
1258
1259 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1260 arm/ia64/s390/sh/sparc stable wrt #254307
1261
1262 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1263 ruby-1.8.6_p287-r4.ebuild:
1264 Stable on alpha, bug #254307
1265
1266 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1267 ruby-1.8.6_p287-r11.ebuild:
1268 keyword ~x86-fbsd, bug #252315
1269
1270 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1271 ppc stable #254307
1272
1273 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1274 amd64/x86 stable, bug #254307
1275
1276 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1277 stable ppc64, bug 254307
1278
1279 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1280 Stable for HPPA (bug #254307).
1281
1282 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1283 ruby-1.8.6_p287-r11.ebuild:
1284 Marked ~hppa (bug #252315).
1285
1286*ruby-1.8.6_p287-r11 (11 Jan 2009)
1287
1288 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1289 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1290 +ruby-1.8.6_p287-r11.ebuild:
1291 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1292 Fixes #254307.
1293
1294 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1295 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1296
1297 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1298 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1299
1300 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1301 ruby-1.8.6_p287-r10.ebuild:
1302 Add ~sparc keyword, bug #252315
1303
1304*ruby-1.8.6_p287-r10 (23 Dec 2008)
1305
1306 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1307 +ruby-1.8.6_p287-r10.ebuild:
1308 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1309 keywords since eselect-ruby does not yet have these keywords.
1310
1311 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1312 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1313 Revert the ruby-config changes. We can't remove them until we provide an
1314 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1315 for breaking things as mentioned in bug #251833.
1316
1317 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1318 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1319 ruby-1.8.7_p72-r1.ebuild:
1320 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1321 Thanks for the people noticing this in bug #251833.
1322
1323 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1324 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1325 ruby-1.8.7_p72-r1.ebuild:
1326 Drop dependency on ruby-config, which will be removed from the tree. We
1327 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1328 is no need for ruby-config at this moment. For newer versions of Ruby we will
1329 use eselect-ruby, which can be found in the ruby overlay at the moment.
1330
1331 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1332 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1333 Use mirror://ruby in SRC_URI, fixes #237392.
1334
1335 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1336 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1337 -ruby-1.8.7_p72.ebuild:
1338 Remove old versions. Leave one old stable version with cjk support.
1339
1340*ruby-1.8.6_p287-r3 (29 Nov 2008)
1341
1342 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1343 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1344 +ruby-1.8.6_p287-r3.ebuild:
1345 Fix our expansion limit patch according to debian bug report
1346 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1347 make sure people will pick up the fixed version. Thanks to Alex Legler for
1348 mentioning the patch.
1349
1350*ruby-1.8.7_p72-r1 (26 Nov 2008)
1351*ruby-1.8.6_p287-r2 (26 Nov 2008)
1352
1353 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1354 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1355 +ruby-1.8.7_p72-r1.ebuild:
1356 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1357 Thanks to Alex Legler for providing the patch.
1358
1359 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1360 -ruby-1.8.6_p287.ebuild:
1361 Remove versions that will not become stable
1362
1363 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1364 ruby-1.8.6_p287-r1.ebuild:
1365 ppc stable, bug #225465
1366
1367 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1368 ruby-1.8.6_p287-r1.ebuild:
1369 amd64 stable wrt security bug #225465
1370
1371 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1372 alpha/ia64/x86 stable wrt #225465
1373
1374 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1375 ruby-1.8.6_p287-r1.ebuild:
1376 Sparc stable --- Security Bug #225465 --- good since late August.
1377
1378 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1379 Stable on ppc64; bug #225465
1380
1381 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1382 Stable for HPPA (bug #225465).
1383
1384*ruby-1.8.6_p287-r1 (29 Aug 2008)
1385
1386 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1387 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1388 +ruby-1.8.6_p287-r1.ebuild:
1389 Fix REXML security issues, bug #236060.
1390
1391 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1392 Add GLEP 56 USE flag descriptions.
1393
1394*ruby-1.8.7_p72 (15 Aug 2008)
1395
1396 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1397 +ruby-1.8.7_p72.ebuild:
1398 bump 1.8.7 to latest patch release
1399
1400*ruby-1.8.6_p287 (11 Aug 2008)
1401
1402 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1403 Version bump for brown paper bag relelease.
1404
1405 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1406 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1407 Remove broken version in favor of the just-added 1.8.6_p286
1408
1409*ruby-1.8.6_p286 (10 Aug 2008)
1410
1411 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1412 Version bump to latest released version of ruby 1.8.6. This version fixes the
1413 security issues reported in #225465 and #234224. The cjk USE flag has been
1414 dropped since no compatible patches have been released yet.
1415
1416 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1417 ruby-1.8.6_p230.ebuild:
1418 drop cjk from SRC_URI as well
1419
1420 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1421 Drop cjk support since the most recent oniguruma patches no longer apply to
1422 this version, #230111.
1423
1424 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1425 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1426 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1427 Unfortunately the official p230 has a change which causes segmentation faults
1428 for applications like Rails and RSpec, so we are reverting that specific
1429 change.
1430
1431*ruby-1.8.7_p22 (29 Jun 2008)
1432
1433 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1434 +ruby-1.8.7_p22.ebuild:
1435 bump 1.8.7 for security fix
1436
1437 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1438 nevermind, don't bump this yet
1439
1440*ruby-1.8.6_p230 (20 Jun 2008)
1441
1442 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1443 version bump
1444
1445*ruby-1.8.7 (10 Jun 2008)
1446
1447 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1448 +ruby-1.8.7.ebuild:
1449 bump 1.8.7 to final
1450
1451*ruby-1.8.7_pre2 (21 Apr 2008)
1452
1453 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1454 +ruby-1.8.7_pre2.ebuild:
1455 Version Bump
1456
1457*ruby-1.8.7_pre1 (16 Apr 2008)
1458
1459 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1460 Version bump. Drop cjk until a new version of oniguruma appears.
1461
1462 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1463 amd64 stable, bug 212264
1464
1465 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1466 Stable for HPPA (bug #212264).
1467
1468 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1469 ruby-1.8.6_p114.ebuild:
1470 ppc stable, bug #212264
1471
1472 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1473 alpha/ia64 stable wrt #212264
1474
1475 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1476 ruby-1.8.6_p114.ebuild:
1477 stable x86, security bug 212264
1478
1479 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1480 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1481 as expected.
1482
1483 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1484 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1485
1486*ruby-1.8.6_p114 (05 Mar 2008)
1487
1488 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1489 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1490 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1491 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1492 Version bump for #212264. Remove old ebuilds.
1493
1494 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1495 alpha/ia64 stable wrt #208916
1496
1497 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1498 Stable on ppc wrt bug 208916
1499
1500 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1501 x86 stable, bug #208916
1502
1503 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1504 ruby-1.8.6_p111-r1.ebuild:
1505 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1506
1507 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1508 -files/ruby-1.8.6-exit-status.patch,
1509 -files/ruby-1.8.6_p110-net-http-p111.patch,
1510 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1511 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1512 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1513 Remove old versions
1514
1515 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1516 Stable on ppc64
1517
1518 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1519 Stable on amd64; bug 199191
1520
1521 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1522 alpha/ia64/sparc stable wrt #199191
1523
1524 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1525 Remove now-obsolete warning about coreutils versions, #203156.
1526
1527 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1528 Stable for HPPA (bug #199191).
1529
1530*ruby-1.8.6_p111-r1 (23 Dec 2007)
1531
1532 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1533 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1534 ssl USE flags. Patch to p113.
1535
1536 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1537 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1538
1539 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1540 x86 stable, security bug #199191
1541
1542*ruby-1.8.6_p111 (23 Dec 2007)
1543
1544 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1545 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1546 Version bump with patch for bug #199191
1547
1548 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1549 Move dependency on (X)Emacs modes to PDEPEND.
1550
1551 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1552 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1553 bug 196413
1554
1555*ruby-1.8.6_p110-r2 (21 Oct 2007)
1556
1557 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1558 +ruby-1.8.6_p110-r2.ebuild:
1559 Add emacs and xemacs USE flags and use them to pull in the correct editing
1560 mode for each. Had to drop several arch keywords as reported on bug 196413.
1561
1562 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1563 amd64 stable, security bug 194236
1564
1565 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1566 ruby-1.8.6_p110-r1.ebuild:
1567 Stable on ppc64; bug #194236
1568
1569 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1570 amd64 stable, security bug 194236
1571
1572 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1573 Stable for HPPA (bug #194236).
1574
1575 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1576 alpha/ia64/sparc stable wrt security #194236
1577
1578 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1579 ruby-1.8.6_p110-r1.ebuild:
1580 ppc stable, bug #194236
1581
1582 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1583 ruby-1.8.6_p110-r1.ebuild:
1584 stable x86, security bug 194236
1585
1586 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1587 ruby-1.8.5_p113.ebuild:
1588 stable x86, security bug 194236
1589
1590 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1591 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1592 -ruby-1.8.6_p110.ebuild:
1593 Remove old versions
1594
1595*ruby-1.8.6_p110-r1 (30 Sep 2007)
1596*ruby-1.8.5_p113 (30 Sep 2007)
1597
1598 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1599 +files/ruby-1.8.5_p113-net-http-p114.patch,
1600 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1601 +ruby-1.8.6_p110-r1.ebuild:
1602 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1603 using 1.8.6-p110 as base ebuild.
1604
1605 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1606 More fixes from gentoo-dev and graaff
1607
1608 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1609 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1610
1611*ruby-1.8.6_p110 (24 Sep 2007)
1612
1613 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1614 Version bump
1615
1616*ruby-1.8.6_p36-r4 (26 Aug 2007)
1617
1618 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1619 +ruby-1.8.6_p36-r4.ebuild:
1620 Use user LDFLAGS, #181436
1621
1622 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1623 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1624 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1625 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1626
1627 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1628 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1629 -ruby-1.8.6_p36-r2.ebuild:
1630 Remove some older versions that will not be promoted to stable, keeping at
1631 least one version of each release.
1632
1633 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1634 ruby-1.8.6_p36-r3.ebuild:
1635 (QA) RESTRICT clean up.
1636
1637*ruby-1.8.6_p36-r3 (04 Jul 2007)
1638
1639 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1640 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1641 fixed memory leak loading .so bug #182946
1642
1643 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1644 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1645 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1646 ruby-1.8.6_p36-r2.ebuild:
1647 (QA) RESTRICT clean up.
1648
1649 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1650 Re-add stable keyword for alpha as per bug #181110
1651
1652 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1653 Back to ~amd64 wrt bug 181110
1654
1655 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1656 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1657
1658*ruby-1.8.6_p36-r2 (20 Jun 2007)
1659
1660 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1661 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1662
1663*ruby-1.8.6_p36-r1 (18 Jun 2007)
1664
1665 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1666 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1667 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1668 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1669 spbecker
1670
1671 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1672 Stable on amd64 wrt bug 181110
1673
1674*ruby-1.8.6_p36 (12 Jun 2007)
1675
1676 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1677 Version Bump. Bug #181379
1678
1679 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1680 Stable on mips, per #181110.
1681
1682 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1683 Stable on ppc wrt bug 181110
1684
1685 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1686 Stable for HPPA (bug #181110).
1687
1688 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1689 alpha/ia64/x86 stable wrt #181110
1690
1691 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1692 Stable on sparc wrt #181110
4 1693
5 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild: 1694 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
6 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110 1695 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
7 1696
8 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1697 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,

Legend:
Removed from v.1.276  
changed lines
  Added in v.1.675

  ViewVC Help
Powered by ViewVC 1.1.20