/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.511
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.511 2011/10/22 10:13:46 graaff Exp $
4
5*ruby-1.9.3_rc1 (22 Oct 2011)
6
7 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
8 Version bump.
9
10 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
11 arm stable, bug #386369
12
13 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
14 x86 stable, bug 386369
15
16 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
17 Stable for HPPA (bug #386369).
18
19 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
20 ppc/ppc64 stable wrt #386369
21
22 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
23 Stable on amd64 wrt bug #386369
24
25 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
26 Remove vulnerable version, bug 386369.
27
28*ruby-1.8.7_p352 (30 Aug 2011)
29
30 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
31 +ruby-1.8.7_p352.ebuild:
32 Patchlevel bump for ruby:1.8. Removing old version
33
34*ruby-1.9.2_p290 (30 Aug 2011)
35
36 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
37 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
38 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
39 old patchlevels.
40
41 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
42 ruby-1.8.7_p334-r2.ebuild:
43 ppc/ppc64 stable wrt #378691
44
45*ruby-1.8.7_p334-r2 (22 Jul 2011)
46
47 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
48 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
49 for chasing down upstream and us.
50
51 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
52 Added ~mips, bug 332593
53
54 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
55 ruby-1.8.7_p334-r1.ebuild:
56 ppc64 stable wrt #369141
57
58 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
59 ia64/s390/sh/sparc stable wrt #369141
60
61 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
62 Stable for HPPA (bug #369141).
63
64 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
65 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
66
67 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
68 arm/x86 stable, bug #369141
69
70 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
71 Stable on amd64 wrt bug #369141
72
73 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
74 ruby-1.8.7_p334-r1.ebuild:
75 Stable on alpha, bug #369141
76
77*ruby-1.8.7_p334-r1 (31 May 2011)
78
79 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
80 Revision bump for security bug 369141 (CVE-2011-0188)
81
82*ruby-1.9.2-r1 (16 May 2011)
83
84 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
85 Don't remove racc files since all other ruby targets ship these files
86 themselves as well. Closes bug 363419.
87
88 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
89 ruby-1.8.7_p334.ebuild:
90 Remove old version. Remove obsolete and unused old-style virtual/ruby.
91
92 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
93 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
94
95 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
96 Add append-flags -mieee on sh, bug #357559
97
98 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
99 alpha/arm/ia64/s390/sh stable wrt #355439
100
101 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
102 Marked ~ppc64 wrt #332593
103
104 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
105 ruby-1.8.7_p334.ebuild:
106 x86 stable wrt security bug #355439
107
108 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
109 ruby-1.8.7_p334.ebuild:
110 ppc/ppc64 stable wrt #355439
111
112 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
113 Stable on amd64 wrt bug #355439
114
115 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
116 Stable for HPPA (bug #355439).
117
118*ruby-1.8.7_p334 (19 Feb 2011)
119
120 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
121 Version bump 1.8.7 series, security bug 355439
122
123 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
124 ruby-1.9.2.ebuild:
125 Remove PROVIDE for old-style virtual/ruby per bug 265054.
126
127 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
128 Remove masked ruby 1.8.6 per bug 332597.
129
130 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
131 -ruby-1.9.2_rc2.ebuild:
132 Removing old and vulnerable ebuilds
133
134 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
135 Marking ruby-1.8.7_p302 ppc64 for bug 332957
136
137 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
138 alpha/ia64/s390/sh/sparc stable wrt #332957
139
140*ruby-1.9.2 (24 Aug 2010)
141
142 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
143 metadata.xml:
144 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
145 and x86-fbsd due to a new dependency on rdoc.
146
147 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
148 arm stable, bug #332957
149
150 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
151 ruby-1.8.7_p302.ebuild:
152 x86 stable wrt security bug #332957
153
154 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
155 Stable on amd64 wrt bug #332957
156
157 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
158 Stable for PPC (bug #332957).
159
160 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
161 Stable for HPPA (bug #332957).
162
163*ruby-1.8.7_p302 (21 Aug 2010)
164
165 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
166 +ruby-1.8.7_p302.ebuild:
167 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
168 installation path.
169
170*ruby-1.8.6_p399 (19 Aug 2010)
171
172 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
173 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
174 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
175 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
176 installation path (reported by the x86 team in bug 332597)
177
178*ruby-1.9.2_rc2-r1 (18 Aug 2010)
179
180 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
181 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
182 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
183 the rubygems loading code. Add USE flag for psych.
184
185 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
186 ruby-1.9.2_rc2.ebuild:
187 Remove two keepdir that will try to keep an empty path, closes bug
188 #333163.
189
190 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
191 Marked ~ppc (bug #332593).
192
193 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
194 ruby-1.9.2_rc2.ebuild:
195 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
196
197 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
198 ruby-1.8.7_p299.ebuild:
199 Bump eselect-ruby dependency
200
201 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
202 -ruby-1.9.1_p429.ebuild:
203 Remove ebuild that is not target for unmask anyway.
204
205 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
206 ruby-1.9.2_rc2.ebuild:
207 Try 2 to fix the berkdb 5 issue on 1.9.
208
209 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
210 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
211 ruby-1.9.2_rc2.ebuild:
212 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
213 support for adding new patchsets without bumping the revision for all the
214 old ebuilds as well.
215
216*ruby-1.9.2_rc2 (14 Jul 2010)
217
218 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
219 +ruby-1.9.2_rc2.ebuild:
220 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
221 might cause _further_ build failures as it changed slightly behaviour.
222 You're going to need to rebuild rubygems and then all the packages
223 previously installed after upgrading to this.
224
225 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
226 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
227 -ruby-1.9.1_p376.ebuild:
228 Cleanup old versions.
229
230*ruby-1.9.1_p429 (04 Jul 2010)
231
232 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
233 +ruby-1.9.1_p429.ebuild:
234 Version bump to new 1.9.1 release.
235
236*ruby-1.8.7_p299 (23 Jun 2010)
237
238 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
239 +ruby-1.8.7_p299.ebuild:
240 Version bump.
241
242 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
243 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
244 remove useless comments
245
246 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
247 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
248 ruby-1.9.1_p376.ebuild:
249 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
250 dev.gentoo.org now.
251
252 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
253 ruby-1.9.1_p376.ebuild:
254 Use the correct RUBYLIB.
255
256*ruby-1.8.7_p249-r2 (18 May 2010)
257*ruby-1.8.6_p388-r1 (18 May 2010)
258
259 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
260 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
261 ruby-1.9.1_p376.ebuild, metadata.xml:
262 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
263 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
264 add USE flags for ncurses, readline and libedit, and properly depend on
265 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
266 Emacs versions support ruby-mode themselves and it should be even more
267 updated.
268
269*ruby-1.8.7_p249-r1 (06 May 2010)
270
271 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
272 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
273 309789 by Sune Kloppenborg Jeppesen.
274
275 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
276 ruby-1.8.7_p249.ebuild:
277 Use $PVR instead of $PV in patchset names
278
279 06 May 2010; Alex Legler <a3li@gentoo.org>
280 -files/ruby-1.8.6-memory-leak.diff,
281 -files/ruby18-mkmf-parallel-install.patch,
282 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
283 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
284 Remove old version. Cleanup in files/
285
286*ruby-1.9.1_p376 (01 May 2010)
287
288 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
289 Version bump. Fixes security bugs 296052 and 300468. No longer installs
290 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
291 instead.
292
293 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
294 -ruby-1.8.7_p174-r1.ebuild:
295 Remove vulnerable ebuilds, 300468
296
297 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
298 ruby-1.8.7_p249.ebuild:
299 amd64 stable, security bug 300468
300
301 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
302 ruby-1.8.7_p249.ebuild:
303 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
304
305 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
306 Stable for HPPA (bug #300468).
307
308 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
309 Stable for HPPA (bug #300468).
310
311 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
312 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
313
314 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
315 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
316
317 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
318 ruby-1.8.6_p388.ebuild:
319 stable x86, security bug 300468
320
321 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
322 ruby-1.8.7_p249.ebuild:
323 stable x86, security bug 300468
324
325*ruby-1.8.6_p388 (10 Jan 2010)
326
327 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
328 +ruby-1.8.6_p388.ebuild:
329 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
330 version. The new ebuild also has the fix for bug 168939.
331
332*ruby-1.8.7_p249 (10 Jan 2010)
333
334 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
335 +ruby-1.8.7_p249.ebuild:
336 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
337 version
338
339 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
340 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
341
342*ruby-1.8.7_p248 (25 Dec 2009)
343
344 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
345 Version bump
346
347 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
348 Remove old version.
349
350 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
351 Remove old version.
352
353 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
354 ia64/s390/sh stable wrt #288699
355
356 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
357 stable sparc, bug 288699
358
359 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
360 arm stable, bug #288699
361
362 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
363 amd64/x86 stable, bug #288699
364
365 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
366 ruby-1.8.7_p174-r1.ebuild:
367 Stable on alpha, bug #288699
368
369 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
370 ppc stable #288699
371
372 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
373 Stable for HPPA (bug #288699).
374
375 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
376 Marked ~hppa too.
377
378*ruby-1.8.7_p174-r1 (06 Oct 2009)
379
380 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
381 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
382 eselect-ruby cleanup feature.
383
384*ruby-1.9.1_p243 (09 Sep 2009)
385
386 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
387 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
388 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
389 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
390 -files/ruby19-rubygems-proxy.patch,
391 -files/ruby-1.9.1_p129-parallelmake.patch,
392 -files/ruby19-mkmf-parallel-install.patch:
393 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
394 168939. Cleaning up old patches.
395
396*ruby-1.8.6_p383 (20 Aug 2009)
397
398 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
399 Patchlevel bump.
400
401 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
402 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
403 ruby-1.9.1_p129-r1.ebuild:
404 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
405
406 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
407 Removing vulnerable ebuild, bug 273213.
408
409 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
410 Marking ruby-1.8.6_p369 ppc for bug 273213
411
412 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
413 ruby-1.9.1_p129-r1.ebuild:
414 Prepend our library path instead of overwriting it during src_install.
415 Thanks to the reporter of bug #274824.
416
417*ruby-1.8.7_p174 (18 Jun 2009)
418
419 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
420 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
421 Replacing 187_p173 with _p174 because of a regression. Unifying the
422 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
423 patchsets.
424
425 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
426 Marking ruby-1.8.6_p369 ppc64 for bug 273213
427
428 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
429 arm/ia64/s390/sh/sparc stable wrt #273213
430
431 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
432 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
433 Removing old version, minor cleanup
434
435 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
436 -files/ruby-1.8.6-openssl.patch,
437 -files/ruby-1.8.6-shortname_constants.patch,
438 -files/ruby-1.8.6_p111-r13657.patch,
439 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
440 Removing vulnerable old Ruby version and stale patches, bug 274108.
441
442 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
443 ruby-1.8.6_p369.ebuild:
444 Stable on alpha, bug #273213
445
446 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
447 Stable for HPPA (bug #273213).
448
449 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
450 ruby-1.8.6_p369.ebuild:
451 stable x86, security bug 273213
452
453 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
454 amd64 stable, security bug 273213.
455
456*ruby-1.8.7_p173 (10 Jun 2009)
457*ruby-1.8.6_p369 (10 Jun 2009)
458
459 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
460 +ruby-1.8.7_p173.ebuild:
461 Version bumps for bug #273213.
462
463*ruby-1.9.1_p129-r1 (27 May 2009)
464
465 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
466 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
467 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
468 +files/ruby-1.9.1_p129-parallelmake.patch:
469 Revision bump, add patches 1) to make Ruby behave more similarly between
470 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
471 extensions (undefined symbols in them will cause abort at runtime 3) to
472 remove a concurrency issue when building the dl extension that could
473 result in a broken dl.so.
474
475 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
476 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
477 Don't block rdoc-2 or later (which may enter Portage one day as it's
478 needed by some Rakefiles).
479
480 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
481 ruby-1.9.1_p129.ebuild:
482 Add ~x86-fbsd keyword.
483
484 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
485 keyword ~sparc-fbsd, bug #252315
486
487*ruby-1.9.1_p129 (15 May 2009)
488
489 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
490 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
491 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
492 included in every release.
493
494 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
495 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
496 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
497 ruby-1.8.7_p160.ebuild:
498 Removing vulnerable versions (#268515), fixing license (#233747).
499
500 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
501 Stable for HPPA (bug #268515).
502
503 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
504 Adapting rubygems notice.
505
506 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
507 amd64 stable, bug #268515.
508
509 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
510 arm/ia64/s390/sh/sparc stable wrt #268515
511
512 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
513 ruby-1.8.6_p368.ebuild:
514 stable x86, security bug 268515
515
516 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
517 ruby-1.8.6_p368.ebuild:
518 Stable on alpha, bug #268515
519
520 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
521 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
522
523*ruby-1.8.7_p160 (07 May 2009)
524*ruby-1.8.6_p368 (07 May 2009)
525
526 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
527 +ruby-1.8.7_p160.ebuild:
528 Version bump as per secbug 268515. NB: These are the first ebuilds that
529 no longer use ruby-config.
530
531*ruby-1.9.1-r1 (03 Apr 2009)
532*ruby-1.8.7_p72-r11 (03 Apr 2009)
533*ruby-1.8.6_p287-r13 (03 Apr 2009)
534
535 03 Apr 2009; Alex Legler <a3li@gentoo.org>
536 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
537 +files/ruby18-mkmf-parallel-install.patch,
538 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
539 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
540 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
541 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
542 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
543 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
544 happy.
545
546*ruby-1.9.1 (21 Mar 2009)
547
548 21 Mar 2009; Alex Legler <a3li@gentoo.org>
549 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
550 +ruby-1.9.1.ebuild:
551 Adding Ruby 1.9.1 for preliminary testing
552
553 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
554 ruby-1.8.6_p287-r12.ebuild:
555 Marked ~ppc for bug #252315.
556
557 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
558 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
559 bug 261982.
560
561 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
562 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
563 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
564 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
565 Cleanup
566
567*ruby-1.8.7_p72-r10 (07 Mar 2009)
568
569 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
570 +ruby-1.8.7_p72-r10.ebuild:
571 Add a revision of ruby 1.8.7 using eselect ruby.
572
573 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
574 ~mips keyworded, bug #252315.
575
576 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
577 ruby-1.8.6_p287-r5.ebuild:
578 ppc stable, bug #260006
579
580 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
581 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
582
583 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
584 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
585 Fixing Tk USE flag test, bug 258893.
586
587 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
588 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
589
590 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
591 ruby-1.8.6_p287-r5.ebuild:
592 amd64 stable wrt security bug #260006
593
594 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
595 Stable for HPPA (bug #260006).
596
597 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
598 ruby-1.8.6_p287-r5.ebuild:
599 Stable on alpha, bug #260006
600
601*ruby-1.8.7_p72-r2 (23 Feb 2009)
602*ruby-1.8.6_p287-r12 (23 Feb 2009)
603*ruby-1.8.6_p287-r5 (23 Feb 2009)
604
605 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
606 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
607 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
608 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
609 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
610 now before compilation if Tk useflags don't match) and 230748 (adding
611 --enable-option-checking=no for newer versions of autoconf).
612
613 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
614 arm/ia64/s390/sh/sparc stable wrt #254307
615
616 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
617 ruby-1.8.6_p287-r4.ebuild:
618 Stable on alpha, bug #254307
619
620 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
621 ruby-1.8.6_p287-r11.ebuild:
622 keyword ~x86-fbsd, bug #252315
623
624 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
625 ppc stable #254307
626
627 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
628 amd64/x86 stable, bug #254307
629
630 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
631 stable ppc64, bug 254307
632
633 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
634 Stable for HPPA (bug #254307).
635
636 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
637 ruby-1.8.6_p287-r11.ebuild:
638 Marked ~hppa (bug #252315).
639
640*ruby-1.8.6_p287-r11 (11 Jan 2009)
641
642 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
643 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
644 +ruby-1.8.6_p287-r11.ebuild:
645 Backport conditional definition of missing openssl functions from ruby 1.8.7.
646 Fixes #254307.
647
648 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
649 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
650
651 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
652 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
653
654 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
655 ruby-1.8.6_p287-r10.ebuild:
656 Add ~sparc keyword, bug #252315
657
658*ruby-1.8.6_p287-r10 (23 Dec 2008)
659
660 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
661 +ruby-1.8.6_p287-r10.ebuild:
662 Version bump which switches from ruby-config to eselect-ruby. Dropped most
663 keywords since eselect-ruby does not yet have these keywords.
664
665 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
666 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
667 Revert the ruby-config changes. We can't remove them until we provide an
668 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
669 for breaking things as mentioned in bug #251833.
670
671 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
672 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
673 ruby-1.8.7_p72-r1.ebuild:
674 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
675 Thanks for the people noticing this in bug #251833.
676
677 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
678 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
679 ruby-1.8.7_p72-r1.ebuild:
680 Drop dependency on ruby-config, which will be removed from the tree. We
681 currently only have one major version of ruby in the tree (Ruby 1.8), so there
682 is no need for ruby-config at this moment. For newer versions of Ruby we will
683 use eselect-ruby, which can be found in the ruby overlay at the moment.
684
685 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
686 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
687 Use mirror://ruby in SRC_URI, fixes #237392.
688
689 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
690 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
691 -ruby-1.8.7_p72.ebuild:
692 Remove old versions. Leave one old stable version with cjk support.
693
694*ruby-1.8.6_p287-r3 (29 Nov 2008)
695
696 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
697 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
698 +ruby-1.8.6_p287-r3.ebuild:
699 Fix our expansion limit patch according to debian bug report
700 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
701 make sure people will pick up the fixed version. Thanks to Alex Legler for
702 mentioning the patch.
703
704*ruby-1.8.7_p72-r1 (26 Nov 2008)
705*ruby-1.8.6_p287-r2 (26 Nov 2008)
706
707 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
708 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
709 +ruby-1.8.7_p72-r1.ebuild:
710 Fix problem with shortname constants #247790, already fixed in upstream SVN.
711 Thanks to Alex Legler for providing the patch.
712
713 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
714 -ruby-1.8.6_p287.ebuild:
715 Remove versions that will not become stable
716
717 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
718 ruby-1.8.6_p287-r1.ebuild:
719 ppc stable, bug #225465
720
721 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
722 ruby-1.8.6_p287-r1.ebuild:
723 amd64 stable wrt security bug #225465
724
725 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
726 alpha/ia64/x86 stable wrt #225465
727
728 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
729 ruby-1.8.6_p287-r1.ebuild:
730 Sparc stable --- Security Bug #225465 --- good since late August.
731
732 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
733 Stable on ppc64; bug #225465
734
735 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
736 Stable for HPPA (bug #225465).
737
738*ruby-1.8.6_p287-r1 (29 Aug 2008)
739
740 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
741 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
742 +ruby-1.8.6_p287-r1.ebuild:
743 Fix REXML security issues, bug #236060.
744
745 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
746 Add GLEP 56 USE flag descriptions.
747
748*ruby-1.8.7_p72 (15 Aug 2008)
749
750 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
751 +ruby-1.8.7_p72.ebuild:
752 bump 1.8.7 to latest patch release
753
754*ruby-1.8.6_p287 (11 Aug 2008)
755
756 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
757 Version bump for brown paper bag relelease.
758
759 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
760 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
761 Remove broken version in favor of the just-added 1.8.6_p286
762
763*ruby-1.8.6_p286 (10 Aug 2008)
764
765 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
766 Version bump to latest released version of ruby 1.8.6. This version fixes the
767 security issues reported in #225465 and #234224. The cjk USE flag has been
768 dropped since no compatible patches have been released yet.
769
770 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
771 ruby-1.8.6_p230.ebuild:
772 drop cjk from SRC_URI as well
773
774 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
775 Drop cjk support since the most recent oniguruma patches no longer apply to
776 this version, #230111.
777
778 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
779 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
780 Try to fix the security issues reported in #225465 for ruby 1.8.6.
781 Unfortunately the official p230 has a change which causes segmentation faults
782 for applications like Rails and RSpec, so we are reverting that specific
783 change.
784
785*ruby-1.8.7_p22 (29 Jun 2008)
786
787 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
788 +ruby-1.8.7_p22.ebuild:
789 bump 1.8.7 for security fix
790
791 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
792 nevermind, don't bump this yet
793
794*ruby-1.8.6_p230 (20 Jun 2008)
795
796 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
797 version bump
798
799*ruby-1.8.7 (10 Jun 2008)
800
801 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
802 +ruby-1.8.7.ebuild:
803 bump 1.8.7 to final
804
805*ruby-1.8.7_pre2 (21 Apr 2008)
806
807 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
808 +ruby-1.8.7_pre2.ebuild:
809 Version Bump
810
811*ruby-1.8.7_pre1 (16 Apr 2008)
812
813 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
814 Version bump. Drop cjk until a new version of oniguruma appears.
815
816 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
817 amd64 stable, bug 212264
818
819 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
820 Stable for HPPA (bug #212264).
821
822 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
823 ruby-1.8.6_p114.ebuild:
824 ppc stable, bug #212264
825
826 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
827 alpha/ia64 stable wrt #212264
828
829 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
830 ruby-1.8.6_p114.ebuild:
831 stable x86, security bug 212264
832
833 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
834 Sparc stable, Security Bug #212264, builds and installs, initial tests run
835 as expected.
836
837 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
838 Marking ruby-1.8.6_p114 ppc64 for bug 212264
839
840*ruby-1.8.6_p114 (05 Mar 2008)
841
842 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
843 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
844 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
845 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
846 Version bump for #212264. Remove old ebuilds.
847
848 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
849 alpha/ia64 stable wrt #208916
850
851 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
852 Stable on ppc wrt bug 208916
853
854 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
855 x86 stable, bug #208916
856
857 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
858 ruby-1.8.6_p111-r1.ebuild:
859 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
860
861 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
862 -files/ruby-1.8.6-exit-status.patch,
863 -files/ruby-1.8.6_p110-net-http-p111.patch,
864 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
865 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
866 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
867 Remove old versions
868
869 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
870 Stable on ppc64
871
872 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
873 Stable on amd64; bug 199191
874
875 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
876 alpha/ia64/sparc stable wrt #199191
877
878 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
879 Remove now-obsolete warning about coreutils versions, #203156.
880
881 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
882 Stable for HPPA (bug #199191).
883
884*ruby-1.8.6_p111-r1 (23 Dec 2007)
885
886 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
887 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
888 ssl USE flags. Patch to p113.
889
890 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
891 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
892
893 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
894 x86 stable, security bug #199191
895
896*ruby-1.8.6_p111 (23 Dec 2007)
897
898 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
899 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
900 Version bump with patch for bug #199191
901
902 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
903 Move dependency on (X)Emacs modes to PDEPEND.
904
905 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
906 Add back ~hppa keyword now that XEmacs support files have been keyworded,
907 bug 196413
908
909*ruby-1.8.6_p110-r2 (21 Oct 2007)
910
911 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
912 +ruby-1.8.6_p110-r2.ebuild:
913 Add emacs and xemacs USE flags and use them to pull in the correct editing
914 mode for each. Had to drop several arch keywords as reported on bug 196413.
915
916 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
917 amd64 stable, security bug 194236
918
919 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
920 ruby-1.8.6_p110-r1.ebuild:
921 Stable on ppc64; bug #194236
922
923 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
924 amd64 stable, security bug 194236
925
926 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
927 Stable for HPPA (bug #194236).
928
929 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
930 alpha/ia64/sparc stable wrt security #194236
931
932 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
933 ruby-1.8.6_p110-r1.ebuild:
934 ppc stable, bug #194236
935
936 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
937 ruby-1.8.6_p110-r1.ebuild:
938 stable x86, security bug 194236
939
940 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
941 ruby-1.8.5_p113.ebuild:
942 stable x86, security bug 194236
943
944 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
945 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
946 -ruby-1.8.6_p110.ebuild:
947 Remove old versions
948
949*ruby-1.8.6_p110-r1 (30 Sep 2007)
950*ruby-1.8.5_p113 (30 Sep 2007)
951
952 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
953 +files/ruby-1.8.5_p113-net-http-p114.patch,
954 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
955 +ruby-1.8.6_p110-r1.ebuild:
956 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
957 using 1.8.6-p110 as base ebuild.
958
959 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
960 More fixes from gentoo-dev and graaff
961
962 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
963 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
964
965*ruby-1.8.6_p110 (24 Sep 2007)
966
967 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
968 Version bump
969
970*ruby-1.8.6_p36-r4 (26 Aug 2007)
971
972 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
973 +ruby-1.8.6_p36-r4.ebuild:
974 Use user LDFLAGS, #181436
975
976 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
977 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
978 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
979 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
980
981 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
982 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
983 -ruby-1.8.6_p36-r2.ebuild:
984 Remove some older versions that will not be promoted to stable, keeping at
985 least one version of each release.
986
987 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
988 ruby-1.8.6_p36-r3.ebuild:
989 (QA) RESTRICT clean up.
990
991*ruby-1.8.6_p36-r3 (04 Jul 2007)
992
993 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
994 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
995 fixed memory leak loading .so bug #182946
996
997 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
998 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
999 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1000 ruby-1.8.6_p36-r2.ebuild:
1001 (QA) RESTRICT clean up.
1002
1003 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1004 Re-add stable keyword for alpha as per bug #181110
1005
1006 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1007 Back to ~amd64 wrt bug 181110
1008
1009 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1010 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1011
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1012*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1013
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1014 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1015 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.511

  ViewVC Help
Powered by ViewVC 1.1.20