/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.513
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.513 2011/10/22 16:53:31 jer Exp $
4
5 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
6 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
7 #332593).
8
9 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
10 alpha/ia64/s390/sh/sparc stable wrt #386369
11
12*ruby-1.9.3_rc1 (22 Oct 2011)
13
14 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
15 Version bump.
16
17 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
18 arm stable, bug #386369
19
20 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
21 x86 stable, bug 386369
22
23 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
24 Stable for HPPA (bug #386369).
25
26 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
27 ppc/ppc64 stable wrt #386369
28
29 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
30 Stable on amd64 wrt bug #386369
31
32 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
33 Remove vulnerable version, bug 386369.
34
35*ruby-1.8.7_p352 (30 Aug 2011)
36
37 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
38 +ruby-1.8.7_p352.ebuild:
39 Patchlevel bump for ruby:1.8. Removing old version
40
41*ruby-1.9.2_p290 (30 Aug 2011)
42
43 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
44 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
45 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
46 old patchlevels.
47
48 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
49 ruby-1.8.7_p334-r2.ebuild:
50 ppc/ppc64 stable wrt #378691
51
52*ruby-1.8.7_p334-r2 (22 Jul 2011)
53
54 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
55 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
56 for chasing down upstream and us.
57
58 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
59 Added ~mips, bug 332593
60
61 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
62 ruby-1.8.7_p334-r1.ebuild:
63 ppc64 stable wrt #369141
64
65 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
66 ia64/s390/sh/sparc stable wrt #369141
67
68 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
69 Stable for HPPA (bug #369141).
70
71 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
72 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
73
74 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
75 arm/x86 stable, bug #369141
76
77 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
78 Stable on amd64 wrt bug #369141
79
80 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
81 ruby-1.8.7_p334-r1.ebuild:
82 Stable on alpha, bug #369141
83
84*ruby-1.8.7_p334-r1 (31 May 2011)
85
86 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
87 Revision bump for security bug 369141 (CVE-2011-0188)
88
89*ruby-1.9.2-r1 (16 May 2011)
90
91 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
92 Don't remove racc files since all other ruby targets ship these files
93 themselves as well. Closes bug 363419.
94
95 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
96 ruby-1.8.7_p334.ebuild:
97 Remove old version. Remove obsolete and unused old-style virtual/ruby.
98
99 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
100 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
101
102 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
103 Add append-flags -mieee on sh, bug #357559
104
105 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
106 alpha/arm/ia64/s390/sh stable wrt #355439
107
108 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
109 Marked ~ppc64 wrt #332593
110
111 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
112 ruby-1.8.7_p334.ebuild:
113 x86 stable wrt security bug #355439
114
115 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
116 ruby-1.8.7_p334.ebuild:
117 ppc/ppc64 stable wrt #355439
118
119 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
120 Stable on amd64 wrt bug #355439
121
122 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
123 Stable for HPPA (bug #355439).
124
125*ruby-1.8.7_p334 (19 Feb 2011)
126
127 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
128 Version bump 1.8.7 series, security bug 355439
129
130 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
131 ruby-1.9.2.ebuild:
132 Remove PROVIDE for old-style virtual/ruby per bug 265054.
133
134 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
135 Remove masked ruby 1.8.6 per bug 332597.
136
137 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
138 -ruby-1.9.2_rc2.ebuild:
139 Removing old and vulnerable ebuilds
140
141 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
142 Marking ruby-1.8.7_p302 ppc64 for bug 332957
143
144 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
145 alpha/ia64/s390/sh/sparc stable wrt #332957
146
147*ruby-1.9.2 (24 Aug 2010)
148
149 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
150 metadata.xml:
151 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
152 and x86-fbsd due to a new dependency on rdoc.
153
154 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
155 arm stable, bug #332957
156
157 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
158 ruby-1.8.7_p302.ebuild:
159 x86 stable wrt security bug #332957
160
161 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
162 Stable on amd64 wrt bug #332957
163
164 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
165 Stable for PPC (bug #332957).
166
167 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
168 Stable for HPPA (bug #332957).
169
170*ruby-1.8.7_p302 (21 Aug 2010)
171
172 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
173 +ruby-1.8.7_p302.ebuild:
174 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
175 installation path.
176
177*ruby-1.8.6_p399 (19 Aug 2010)
178
179 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
180 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
181 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
182 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
183 installation path (reported by the x86 team in bug 332597)
184
185*ruby-1.9.2_rc2-r1 (18 Aug 2010)
186
187 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
188 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
189 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
190 the rubygems loading code. Add USE flag for psych.
191
192 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
193 ruby-1.9.2_rc2.ebuild:
194 Remove two keepdir that will try to keep an empty path, closes bug
195 #333163.
196
197 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
198 Marked ~ppc (bug #332593).
199
200 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
201 ruby-1.9.2_rc2.ebuild:
202 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
203
204 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
205 ruby-1.8.7_p299.ebuild:
206 Bump eselect-ruby dependency
207
208 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
209 -ruby-1.9.1_p429.ebuild:
210 Remove ebuild that is not target for unmask anyway.
211
212 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
213 ruby-1.9.2_rc2.ebuild:
214 Try 2 to fix the berkdb 5 issue on 1.9.
215
216 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
217 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
218 ruby-1.9.2_rc2.ebuild:
219 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
220 support for adding new patchsets without bumping the revision for all the
221 old ebuilds as well.
222
223*ruby-1.9.2_rc2 (14 Jul 2010)
224
225 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
226 +ruby-1.9.2_rc2.ebuild:
227 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
228 might cause _further_ build failures as it changed slightly behaviour.
229 You're going to need to rebuild rubygems and then all the packages
230 previously installed after upgrading to this.
231
232 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
233 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
234 -ruby-1.9.1_p376.ebuild:
235 Cleanup old versions.
236
237*ruby-1.9.1_p429 (04 Jul 2010)
238
239 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
240 +ruby-1.9.1_p429.ebuild:
241 Version bump to new 1.9.1 release.
242
243*ruby-1.8.7_p299 (23 Jun 2010)
244
245 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
246 +ruby-1.8.7_p299.ebuild:
247 Version bump.
248
249 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
250 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
251 remove useless comments
252
253 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
254 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
255 ruby-1.9.1_p376.ebuild:
256 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
257 dev.gentoo.org now.
258
259 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
260 ruby-1.9.1_p376.ebuild:
261 Use the correct RUBYLIB.
262
263*ruby-1.8.7_p249-r2 (18 May 2010)
264*ruby-1.8.6_p388-r1 (18 May 2010)
265
266 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
267 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
268 ruby-1.9.1_p376.ebuild, metadata.xml:
269 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
270 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
271 add USE flags for ncurses, readline and libedit, and properly depend on
272 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
273 Emacs versions support ruby-mode themselves and it should be even more
274 updated.
275
276*ruby-1.8.7_p249-r1 (06 May 2010)
277
278 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
279 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
280 309789 by Sune Kloppenborg Jeppesen.
281
282 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
283 ruby-1.8.7_p249.ebuild:
284 Use $PVR instead of $PV in patchset names
285
286 06 May 2010; Alex Legler <a3li@gentoo.org>
287 -files/ruby-1.8.6-memory-leak.diff,
288 -files/ruby18-mkmf-parallel-install.patch,
289 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
290 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
291 Remove old version. Cleanup in files/
292
293*ruby-1.9.1_p376 (01 May 2010)
294
295 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
296 Version bump. Fixes security bugs 296052 and 300468. No longer installs
297 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
298 instead.
299
300 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
301 -ruby-1.8.7_p174-r1.ebuild:
302 Remove vulnerable ebuilds, 300468
303
304 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
305 ruby-1.8.7_p249.ebuild:
306 amd64 stable, security bug 300468
307
308 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
309 ruby-1.8.7_p249.ebuild:
310 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
311
312 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
313 Stable for HPPA (bug #300468).
314
315 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
316 Stable for HPPA (bug #300468).
317
318 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
319 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
320
321 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
322 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
323
324 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
325 ruby-1.8.6_p388.ebuild:
326 stable x86, security bug 300468
327
328 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
329 ruby-1.8.7_p249.ebuild:
330 stable x86, security bug 300468
331
332*ruby-1.8.6_p388 (10 Jan 2010)
333
334 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
335 +ruby-1.8.6_p388.ebuild:
336 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
337 version. The new ebuild also has the fix for bug 168939.
338
339*ruby-1.8.7_p249 (10 Jan 2010)
340
341 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
342 +ruby-1.8.7_p249.ebuild:
343 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
344 version
345
346 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
347 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
348
349*ruby-1.8.7_p248 (25 Dec 2009)
350
351 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
352 Version bump
353
354 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
355 Remove old version.
356
357 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
358 Remove old version.
359
360 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
361 ia64/s390/sh stable wrt #288699
362
363 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
364 stable sparc, bug 288699
365
366 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
367 arm stable, bug #288699
368
369 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
370 amd64/x86 stable, bug #288699
371
372 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
373 ruby-1.8.7_p174-r1.ebuild:
374 Stable on alpha, bug #288699
375
376 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
377 ppc stable #288699
378
379 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
380 Stable for HPPA (bug #288699).
381
382 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
383 Marked ~hppa too.
384
385*ruby-1.8.7_p174-r1 (06 Oct 2009)
386
387 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
388 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
389 eselect-ruby cleanup feature.
390
391*ruby-1.9.1_p243 (09 Sep 2009)
392
393 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
394 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
395 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
396 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
397 -files/ruby19-rubygems-proxy.patch,
398 -files/ruby-1.9.1_p129-parallelmake.patch,
399 -files/ruby19-mkmf-parallel-install.patch:
400 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
401 168939. Cleaning up old patches.
402
403*ruby-1.8.6_p383 (20 Aug 2009)
404
405 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
406 Patchlevel bump.
407
408 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
409 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
410 ruby-1.9.1_p129-r1.ebuild:
411 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
412
413 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
414 Removing vulnerable ebuild, bug 273213.
415
416 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
417 Marking ruby-1.8.6_p369 ppc for bug 273213
418
419 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
420 ruby-1.9.1_p129-r1.ebuild:
421 Prepend our library path instead of overwriting it during src_install.
422 Thanks to the reporter of bug #274824.
423
424*ruby-1.8.7_p174 (18 Jun 2009)
425
426 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
427 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
428 Replacing 187_p173 with _p174 because of a regression. Unifying the
429 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
430 patchsets.
431
432 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
433 Marking ruby-1.8.6_p369 ppc64 for bug 273213
434
435 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
436 arm/ia64/s390/sh/sparc stable wrt #273213
437
438 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
439 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
440 Removing old version, minor cleanup
441
442 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
443 -files/ruby-1.8.6-openssl.patch,
444 -files/ruby-1.8.6-shortname_constants.patch,
445 -files/ruby-1.8.6_p111-r13657.patch,
446 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
447 Removing vulnerable old Ruby version and stale patches, bug 274108.
448
449 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
450 ruby-1.8.6_p369.ebuild:
451 Stable on alpha, bug #273213
452
453 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
454 Stable for HPPA (bug #273213).
455
456 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
457 ruby-1.8.6_p369.ebuild:
458 stable x86, security bug 273213
459
460 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
461 amd64 stable, security bug 273213.
462
463*ruby-1.8.7_p173 (10 Jun 2009)
464*ruby-1.8.6_p369 (10 Jun 2009)
465
466 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
467 +ruby-1.8.7_p173.ebuild:
468 Version bumps for bug #273213.
469
470*ruby-1.9.1_p129-r1 (27 May 2009)
471
472 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
473 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
474 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
475 +files/ruby-1.9.1_p129-parallelmake.patch:
476 Revision bump, add patches 1) to make Ruby behave more similarly between
477 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
478 extensions (undefined symbols in them will cause abort at runtime 3) to
479 remove a concurrency issue when building the dl extension that could
480 result in a broken dl.so.
481
482 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
483 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
484 Don't block rdoc-2 or later (which may enter Portage one day as it's
485 needed by some Rakefiles).
486
487 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
488 ruby-1.9.1_p129.ebuild:
489 Add ~x86-fbsd keyword.
490
491 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
492 keyword ~sparc-fbsd, bug #252315
493
494*ruby-1.9.1_p129 (15 May 2009)
495
496 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
497 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
498 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
499 included in every release.
500
501 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
502 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
503 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
504 ruby-1.8.7_p160.ebuild:
505 Removing vulnerable versions (#268515), fixing license (#233747).
506
507 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
508 Stable for HPPA (bug #268515).
509
510 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
511 Adapting rubygems notice.
512
513 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
514 amd64 stable, bug #268515.
515
516 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
517 arm/ia64/s390/sh/sparc stable wrt #268515
518
519 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
520 ruby-1.8.6_p368.ebuild:
521 stable x86, security bug 268515
522
523 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
524 ruby-1.8.6_p368.ebuild:
525 Stable on alpha, bug #268515
526
527 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
528 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
529
530*ruby-1.8.7_p160 (07 May 2009)
531*ruby-1.8.6_p368 (07 May 2009)
532
533 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
534 +ruby-1.8.7_p160.ebuild:
535 Version bump as per secbug 268515. NB: These are the first ebuilds that
536 no longer use ruby-config.
537
538*ruby-1.9.1-r1 (03 Apr 2009)
539*ruby-1.8.7_p72-r11 (03 Apr 2009)
540*ruby-1.8.6_p287-r13 (03 Apr 2009)
541
542 03 Apr 2009; Alex Legler <a3li@gentoo.org>
543 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
544 +files/ruby18-mkmf-parallel-install.patch,
545 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
546 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
547 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
548 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
549 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
550 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
551 happy.
552
553*ruby-1.9.1 (21 Mar 2009)
554
555 21 Mar 2009; Alex Legler <a3li@gentoo.org>
556 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
557 +ruby-1.9.1.ebuild:
558 Adding Ruby 1.9.1 for preliminary testing
559
560 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
561 ruby-1.8.6_p287-r12.ebuild:
562 Marked ~ppc for bug #252315.
563
564 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
565 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
566 bug 261982.
567
568 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
569 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
570 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
571 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
572 Cleanup
573
574*ruby-1.8.7_p72-r10 (07 Mar 2009)
575
576 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
577 +ruby-1.8.7_p72-r10.ebuild:
578 Add a revision of ruby 1.8.7 using eselect ruby.
579
580 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
581 ~mips keyworded, bug #252315.
582
583 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
584 ruby-1.8.6_p287-r5.ebuild:
585 ppc stable, bug #260006
586
587 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
588 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
589
590 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
591 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
592 Fixing Tk USE flag test, bug 258893.
593
594 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
595 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
596
597 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
598 ruby-1.8.6_p287-r5.ebuild:
599 amd64 stable wrt security bug #260006
600
601 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
602 Stable for HPPA (bug #260006).
603
604 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
605 ruby-1.8.6_p287-r5.ebuild:
606 Stable on alpha, bug #260006
607
608*ruby-1.8.7_p72-r2 (23 Feb 2009)
609*ruby-1.8.6_p287-r12 (23 Feb 2009)
610*ruby-1.8.6_p287-r5 (23 Feb 2009)
611
612 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
613 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
614 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
615 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
616 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
617 now before compilation if Tk useflags don't match) and 230748 (adding
618 --enable-option-checking=no for newer versions of autoconf).
619
620 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
621 arm/ia64/s390/sh/sparc stable wrt #254307
622
623 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
624 ruby-1.8.6_p287-r4.ebuild:
625 Stable on alpha, bug #254307
626
627 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
628 ruby-1.8.6_p287-r11.ebuild:
629 keyword ~x86-fbsd, bug #252315
630
631 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
632 ppc stable #254307
633
634 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
635 amd64/x86 stable, bug #254307
636
637 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
638 stable ppc64, bug 254307
639
640 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
641 Stable for HPPA (bug #254307).
642
643 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
644 ruby-1.8.6_p287-r11.ebuild:
645 Marked ~hppa (bug #252315).
646
647*ruby-1.8.6_p287-r11 (11 Jan 2009)
648
649 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
650 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
651 +ruby-1.8.6_p287-r11.ebuild:
652 Backport conditional definition of missing openssl functions from ruby 1.8.7.
653 Fixes #254307.
654
655 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
656 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
657
658 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
659 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
660
661 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
662 ruby-1.8.6_p287-r10.ebuild:
663 Add ~sparc keyword, bug #252315
664
665*ruby-1.8.6_p287-r10 (23 Dec 2008)
666
667 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
668 +ruby-1.8.6_p287-r10.ebuild:
669 Version bump which switches from ruby-config to eselect-ruby. Dropped most
670 keywords since eselect-ruby does not yet have these keywords.
671
672 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
673 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
674 Revert the ruby-config changes. We can't remove them until we provide an
675 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
676 for breaking things as mentioned in bug #251833.
677
678 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
679 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
680 ruby-1.8.7_p72-r1.ebuild:
681 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
682 Thanks for the people noticing this in bug #251833.
683
684 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
685 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
686 ruby-1.8.7_p72-r1.ebuild:
687 Drop dependency on ruby-config, which will be removed from the tree. We
688 currently only have one major version of ruby in the tree (Ruby 1.8), so there
689 is no need for ruby-config at this moment. For newer versions of Ruby we will
690 use eselect-ruby, which can be found in the ruby overlay at the moment.
691
692 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
693 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
694 Use mirror://ruby in SRC_URI, fixes #237392.
695
696 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
697 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
698 -ruby-1.8.7_p72.ebuild:
699 Remove old versions. Leave one old stable version with cjk support.
700
701*ruby-1.8.6_p287-r3 (29 Nov 2008)
702
703 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
704 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
705 +ruby-1.8.6_p287-r3.ebuild:
706 Fix our expansion limit patch according to debian bug report
707 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
708 make sure people will pick up the fixed version. Thanks to Alex Legler for
709 mentioning the patch.
710
711*ruby-1.8.7_p72-r1 (26 Nov 2008)
712*ruby-1.8.6_p287-r2 (26 Nov 2008)
713
714 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
715 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
716 +ruby-1.8.7_p72-r1.ebuild:
717 Fix problem with shortname constants #247790, already fixed in upstream SVN.
718 Thanks to Alex Legler for providing the patch.
719
720 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
721 -ruby-1.8.6_p287.ebuild:
722 Remove versions that will not become stable
723
724 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
725 ruby-1.8.6_p287-r1.ebuild:
726 ppc stable, bug #225465
727
728 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
729 ruby-1.8.6_p287-r1.ebuild:
730 amd64 stable wrt security bug #225465
731
732 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
733 alpha/ia64/x86 stable wrt #225465
734
735 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
736 ruby-1.8.6_p287-r1.ebuild:
737 Sparc stable --- Security Bug #225465 --- good since late August.
738
739 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
740 Stable on ppc64; bug #225465
741
742 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
743 Stable for HPPA (bug #225465).
744
745*ruby-1.8.6_p287-r1 (29 Aug 2008)
746
747 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
748 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
749 +ruby-1.8.6_p287-r1.ebuild:
750 Fix REXML security issues, bug #236060.
751
752 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
753 Add GLEP 56 USE flag descriptions.
754
755*ruby-1.8.7_p72 (15 Aug 2008)
756
757 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
758 +ruby-1.8.7_p72.ebuild:
759 bump 1.8.7 to latest patch release
760
761*ruby-1.8.6_p287 (11 Aug 2008)
762
763 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
764 Version bump for brown paper bag relelease.
765
766 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
767 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
768 Remove broken version in favor of the just-added 1.8.6_p286
769
770*ruby-1.8.6_p286 (10 Aug 2008)
771
772 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
773 Version bump to latest released version of ruby 1.8.6. This version fixes the
774 security issues reported in #225465 and #234224. The cjk USE flag has been
775 dropped since no compatible patches have been released yet.
776
777 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
778 ruby-1.8.6_p230.ebuild:
779 drop cjk from SRC_URI as well
780
781 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
782 Drop cjk support since the most recent oniguruma patches no longer apply to
783 this version, #230111.
784
785 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
786 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
787 Try to fix the security issues reported in #225465 for ruby 1.8.6.
788 Unfortunately the official p230 has a change which causes segmentation faults
789 for applications like Rails and RSpec, so we are reverting that specific
790 change.
791
792*ruby-1.8.7_p22 (29 Jun 2008)
793
794 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
795 +ruby-1.8.7_p22.ebuild:
796 bump 1.8.7 for security fix
797
798 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
799 nevermind, don't bump this yet
800
801*ruby-1.8.6_p230 (20 Jun 2008)
802
803 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
804 version bump
805
806*ruby-1.8.7 (10 Jun 2008)
807
808 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
809 +ruby-1.8.7.ebuild:
810 bump 1.8.7 to final
811
812*ruby-1.8.7_pre2 (21 Apr 2008)
813
814 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
815 +ruby-1.8.7_pre2.ebuild:
816 Version Bump
817
818*ruby-1.8.7_pre1 (16 Apr 2008)
819
820 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
821 Version bump. Drop cjk until a new version of oniguruma appears.
822
823 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
824 amd64 stable, bug 212264
825
826 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
827 Stable for HPPA (bug #212264).
828
829 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
830 ruby-1.8.6_p114.ebuild:
831 ppc stable, bug #212264
832
833 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
834 alpha/ia64 stable wrt #212264
835
836 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
837 ruby-1.8.6_p114.ebuild:
838 stable x86, security bug 212264
839
840 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
841 Sparc stable, Security Bug #212264, builds and installs, initial tests run
842 as expected.
843
844 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
845 Marking ruby-1.8.6_p114 ppc64 for bug 212264
846
847*ruby-1.8.6_p114 (05 Mar 2008)
848
849 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
850 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
851 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
852 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
853 Version bump for #212264. Remove old ebuilds.
854
855 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
856 alpha/ia64 stable wrt #208916
857
858 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
859 Stable on ppc wrt bug 208916
860
861 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
862 x86 stable, bug #208916
863
864 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
865 ruby-1.8.6_p111-r1.ebuild:
866 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
867
868 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
869 -files/ruby-1.8.6-exit-status.patch,
870 -files/ruby-1.8.6_p110-net-http-p111.patch,
871 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
872 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
873 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
874 Remove old versions
875
876 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
877 Stable on ppc64
878
879 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
880 Stable on amd64; bug 199191
881
882 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
883 alpha/ia64/sparc stable wrt #199191
884
885 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
886 Remove now-obsolete warning about coreutils versions, #203156.
887
888 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
889 Stable for HPPA (bug #199191).
890
891*ruby-1.8.6_p111-r1 (23 Dec 2007)
892
893 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
894 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
895 ssl USE flags. Patch to p113.
896
897 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
898 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
899
900 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
901 x86 stable, security bug #199191
902
903*ruby-1.8.6_p111 (23 Dec 2007)
904
905 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
906 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
907 Version bump with patch for bug #199191
908
909 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
910 Move dependency on (X)Emacs modes to PDEPEND.
911
912 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
913 Add back ~hppa keyword now that XEmacs support files have been keyworded,
914 bug 196413
915
916*ruby-1.8.6_p110-r2 (21 Oct 2007)
917
918 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
919 +ruby-1.8.6_p110-r2.ebuild:
920 Add emacs and xemacs USE flags and use them to pull in the correct editing
921 mode for each. Had to drop several arch keywords as reported on bug 196413.
922
923 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
924 amd64 stable, security bug 194236
925
926 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
927 ruby-1.8.6_p110-r1.ebuild:
928 Stable on ppc64; bug #194236
929
930 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
931 amd64 stable, security bug 194236
932
933 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
934 Stable for HPPA (bug #194236).
935
936 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
937 alpha/ia64/sparc stable wrt security #194236
938
939 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
940 ruby-1.8.6_p110-r1.ebuild:
941 ppc stable, bug #194236
942
943 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
944 ruby-1.8.6_p110-r1.ebuild:
945 stable x86, security bug 194236
946
947 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
948 ruby-1.8.5_p113.ebuild:
949 stable x86, security bug 194236
950
951 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
952 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
953 -ruby-1.8.6_p110.ebuild:
954 Remove old versions
955
956*ruby-1.8.6_p110-r1 (30 Sep 2007)
957*ruby-1.8.5_p113 (30 Sep 2007)
958
959 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
960 +files/ruby-1.8.5_p113-net-http-p114.patch,
961 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
962 +ruby-1.8.6_p110-r1.ebuild:
963 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
964 using 1.8.6-p110 as base ebuild.
965
966 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
967 More fixes from gentoo-dev and graaff
968
969 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
970 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
971
972*ruby-1.8.6_p110 (24 Sep 2007)
973
974 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
975 Version bump
976
977*ruby-1.8.6_p36-r4 (26 Aug 2007)
978
979 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
980 +ruby-1.8.6_p36-r4.ebuild:
981 Use user LDFLAGS, #181436
982
983 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
984 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
985 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
986 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
987
988 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
989 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
990 -ruby-1.8.6_p36-r2.ebuild:
991 Remove some older versions that will not be promoted to stable, keeping at
992 least one version of each release.
993
994 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
995 ruby-1.8.6_p36-r3.ebuild:
996 (QA) RESTRICT clean up.
997
998*ruby-1.8.6_p36-r3 (04 Jul 2007)
999
1000 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1001 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1002 fixed memory leak loading .so bug #182946
1003
1004 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1005 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1006 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1007 ruby-1.8.6_p36-r2.ebuild:
1008 (QA) RESTRICT clean up.
1009
1010 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1011 Re-add stable keyword for alpha as per bug #181110
1012
1013 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1014 Back to ~amd64 wrt bug 181110
1015
1016 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1017 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1018
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1019*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1020
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1021 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1022 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.513

  ViewVC Help
Powered by ViewVC 1.1.20