/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.514
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.514 2011/10/22 17:16:53 jer Exp $
4
5 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
6 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
7 #332593).
8
9 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
10 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
11 #332593).
12
13 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
14 alpha/ia64/s390/sh/sparc stable wrt #386369
15
16*ruby-1.9.3_rc1 (22 Oct 2011)
17
18 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
19 Version bump.
20
21 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
22 arm stable, bug #386369
23
24 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
25 x86 stable, bug 386369
26
27 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
28 Stable for HPPA (bug #386369).
29
30 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
31 ppc/ppc64 stable wrt #386369
32
33 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
34 Stable on amd64 wrt bug #386369
35
36 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
37 Remove vulnerable version, bug 386369.
38
39*ruby-1.8.7_p352 (30 Aug 2011)
40
41 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
42 +ruby-1.8.7_p352.ebuild:
43 Patchlevel bump for ruby:1.8. Removing old version
44
45*ruby-1.9.2_p290 (30 Aug 2011)
46
47 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
48 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
49 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
50 old patchlevels.
51
52 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
53 ruby-1.8.7_p334-r2.ebuild:
54 ppc/ppc64 stable wrt #378691
55
56*ruby-1.8.7_p334-r2 (22 Jul 2011)
57
58 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
59 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
60 for chasing down upstream and us.
61
62 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
63 Added ~mips, bug 332593
64
65 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
66 ruby-1.8.7_p334-r1.ebuild:
67 ppc64 stable wrt #369141
68
69 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
70 ia64/s390/sh/sparc stable wrt #369141
71
72 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
73 Stable for HPPA (bug #369141).
74
75 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
76 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
77
78 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
79 arm/x86 stable, bug #369141
80
81 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
82 Stable on amd64 wrt bug #369141
83
84 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
85 ruby-1.8.7_p334-r1.ebuild:
86 Stable on alpha, bug #369141
87
88*ruby-1.8.7_p334-r1 (31 May 2011)
89
90 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
91 Revision bump for security bug 369141 (CVE-2011-0188)
92
93*ruby-1.9.2-r1 (16 May 2011)
94
95 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
96 Don't remove racc files since all other ruby targets ship these files
97 themselves as well. Closes bug 363419.
98
99 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
100 ruby-1.8.7_p334.ebuild:
101 Remove old version. Remove obsolete and unused old-style virtual/ruby.
102
103 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
104 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
105
106 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
107 Add append-flags -mieee on sh, bug #357559
108
109 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
110 alpha/arm/ia64/s390/sh stable wrt #355439
111
112 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
113 Marked ~ppc64 wrt #332593
114
115 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
116 ruby-1.8.7_p334.ebuild:
117 x86 stable wrt security bug #355439
118
119 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
120 ruby-1.8.7_p334.ebuild:
121 ppc/ppc64 stable wrt #355439
122
123 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
124 Stable on amd64 wrt bug #355439
125
126 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
127 Stable for HPPA (bug #355439).
128
129*ruby-1.8.7_p334 (19 Feb 2011)
130
131 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
132 Version bump 1.8.7 series, security bug 355439
133
134 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
135 ruby-1.9.2.ebuild:
136 Remove PROVIDE for old-style virtual/ruby per bug 265054.
137
138 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
139 Remove masked ruby 1.8.6 per bug 332597.
140
141 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
142 -ruby-1.9.2_rc2.ebuild:
143 Removing old and vulnerable ebuilds
144
145 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
146 Marking ruby-1.8.7_p302 ppc64 for bug 332957
147
148 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
149 alpha/ia64/s390/sh/sparc stable wrt #332957
150
151*ruby-1.9.2 (24 Aug 2010)
152
153 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
154 metadata.xml:
155 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
156 and x86-fbsd due to a new dependency on rdoc.
157
158 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
159 arm stable, bug #332957
160
161 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
162 ruby-1.8.7_p302.ebuild:
163 x86 stable wrt security bug #332957
164
165 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
166 Stable on amd64 wrt bug #332957
167
168 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
169 Stable for PPC (bug #332957).
170
171 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
172 Stable for HPPA (bug #332957).
173
174*ruby-1.8.7_p302 (21 Aug 2010)
175
176 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
177 +ruby-1.8.7_p302.ebuild:
178 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
179 installation path.
180
181*ruby-1.8.6_p399 (19 Aug 2010)
182
183 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
184 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
185 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
186 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
187 installation path (reported by the x86 team in bug 332597)
188
189*ruby-1.9.2_rc2-r1 (18 Aug 2010)
190
191 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
192 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
193 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
194 the rubygems loading code. Add USE flag for psych.
195
196 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
197 ruby-1.9.2_rc2.ebuild:
198 Remove two keepdir that will try to keep an empty path, closes bug
199 #333163.
200
201 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
202 Marked ~ppc (bug #332593).
203
204 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
205 ruby-1.9.2_rc2.ebuild:
206 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
207
208 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
209 ruby-1.8.7_p299.ebuild:
210 Bump eselect-ruby dependency
211
212 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
213 -ruby-1.9.1_p429.ebuild:
214 Remove ebuild that is not target for unmask anyway.
215
216 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
217 ruby-1.9.2_rc2.ebuild:
218 Try 2 to fix the berkdb 5 issue on 1.9.
219
220 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
221 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
222 ruby-1.9.2_rc2.ebuild:
223 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
224 support for adding new patchsets without bumping the revision for all the
225 old ebuilds as well.
226
227*ruby-1.9.2_rc2 (14 Jul 2010)
228
229 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
230 +ruby-1.9.2_rc2.ebuild:
231 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
232 might cause _further_ build failures as it changed slightly behaviour.
233 You're going to need to rebuild rubygems and then all the packages
234 previously installed after upgrading to this.
235
236 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
237 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
238 -ruby-1.9.1_p376.ebuild:
239 Cleanup old versions.
240
241*ruby-1.9.1_p429 (04 Jul 2010)
242
243 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
244 +ruby-1.9.1_p429.ebuild:
245 Version bump to new 1.9.1 release.
246
247*ruby-1.8.7_p299 (23 Jun 2010)
248
249 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
250 +ruby-1.8.7_p299.ebuild:
251 Version bump.
252
253 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
254 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
255 remove useless comments
256
257 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
258 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
259 ruby-1.9.1_p376.ebuild:
260 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
261 dev.gentoo.org now.
262
263 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
264 ruby-1.9.1_p376.ebuild:
265 Use the correct RUBYLIB.
266
267*ruby-1.8.7_p249-r2 (18 May 2010)
268*ruby-1.8.6_p388-r1 (18 May 2010)
269
270 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
272 ruby-1.9.1_p376.ebuild, metadata.xml:
273 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
274 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
275 add USE flags for ncurses, readline and libedit, and properly depend on
276 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
277 Emacs versions support ruby-mode themselves and it should be even more
278 updated.
279
280*ruby-1.8.7_p249-r1 (06 May 2010)
281
282 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
283 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
284 309789 by Sune Kloppenborg Jeppesen.
285
286 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
287 ruby-1.8.7_p249.ebuild:
288 Use $PVR instead of $PV in patchset names
289
290 06 May 2010; Alex Legler <a3li@gentoo.org>
291 -files/ruby-1.8.6-memory-leak.diff,
292 -files/ruby18-mkmf-parallel-install.patch,
293 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
294 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
295 Remove old version. Cleanup in files/
296
297*ruby-1.9.1_p376 (01 May 2010)
298
299 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
300 Version bump. Fixes security bugs 296052 and 300468. No longer installs
301 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
302 instead.
303
304 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
305 -ruby-1.8.7_p174-r1.ebuild:
306 Remove vulnerable ebuilds, 300468
307
308 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
309 ruby-1.8.7_p249.ebuild:
310 amd64 stable, security bug 300468
311
312 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
313 ruby-1.8.7_p249.ebuild:
314 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
315
316 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
317 Stable for HPPA (bug #300468).
318
319 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
320 Stable for HPPA (bug #300468).
321
322 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
323 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
324
325 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
326 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
327
328 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
329 ruby-1.8.6_p388.ebuild:
330 stable x86, security bug 300468
331
332 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
333 ruby-1.8.7_p249.ebuild:
334 stable x86, security bug 300468
335
336*ruby-1.8.6_p388 (10 Jan 2010)
337
338 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
339 +ruby-1.8.6_p388.ebuild:
340 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
341 version. The new ebuild also has the fix for bug 168939.
342
343*ruby-1.8.7_p249 (10 Jan 2010)
344
345 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
346 +ruby-1.8.7_p249.ebuild:
347 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
348 version
349
350 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
351 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
352
353*ruby-1.8.7_p248 (25 Dec 2009)
354
355 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
356 Version bump
357
358 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
359 Remove old version.
360
361 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
362 Remove old version.
363
364 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
365 ia64/s390/sh stable wrt #288699
366
367 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
368 stable sparc, bug 288699
369
370 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
371 arm stable, bug #288699
372
373 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
374 amd64/x86 stable, bug #288699
375
376 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
377 ruby-1.8.7_p174-r1.ebuild:
378 Stable on alpha, bug #288699
379
380 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
381 ppc stable #288699
382
383 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
384 Stable for HPPA (bug #288699).
385
386 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
387 Marked ~hppa too.
388
389*ruby-1.8.7_p174-r1 (06 Oct 2009)
390
391 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
392 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
393 eselect-ruby cleanup feature.
394
395*ruby-1.9.1_p243 (09 Sep 2009)
396
397 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
398 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
399 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
400 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
401 -files/ruby19-rubygems-proxy.patch,
402 -files/ruby-1.9.1_p129-parallelmake.patch,
403 -files/ruby19-mkmf-parallel-install.patch:
404 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
405 168939. Cleaning up old patches.
406
407*ruby-1.8.6_p383 (20 Aug 2009)
408
409 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
410 Patchlevel bump.
411
412 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
413 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
414 ruby-1.9.1_p129-r1.ebuild:
415 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
416
417 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
418 Removing vulnerable ebuild, bug 273213.
419
420 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
421 Marking ruby-1.8.6_p369 ppc for bug 273213
422
423 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
424 ruby-1.9.1_p129-r1.ebuild:
425 Prepend our library path instead of overwriting it during src_install.
426 Thanks to the reporter of bug #274824.
427
428*ruby-1.8.7_p174 (18 Jun 2009)
429
430 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
431 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
432 Replacing 187_p173 with _p174 because of a regression. Unifying the
433 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
434 patchsets.
435
436 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
437 Marking ruby-1.8.6_p369 ppc64 for bug 273213
438
439 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
440 arm/ia64/s390/sh/sparc stable wrt #273213
441
442 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
443 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
444 Removing old version, minor cleanup
445
446 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
447 -files/ruby-1.8.6-openssl.patch,
448 -files/ruby-1.8.6-shortname_constants.patch,
449 -files/ruby-1.8.6_p111-r13657.patch,
450 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
451 Removing vulnerable old Ruby version and stale patches, bug 274108.
452
453 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
454 ruby-1.8.6_p369.ebuild:
455 Stable on alpha, bug #273213
456
457 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
458 Stable for HPPA (bug #273213).
459
460 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
461 ruby-1.8.6_p369.ebuild:
462 stable x86, security bug 273213
463
464 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
465 amd64 stable, security bug 273213.
466
467*ruby-1.8.7_p173 (10 Jun 2009)
468*ruby-1.8.6_p369 (10 Jun 2009)
469
470 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
471 +ruby-1.8.7_p173.ebuild:
472 Version bumps for bug #273213.
473
474*ruby-1.9.1_p129-r1 (27 May 2009)
475
476 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
477 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
478 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
479 +files/ruby-1.9.1_p129-parallelmake.patch:
480 Revision bump, add patches 1) to make Ruby behave more similarly between
481 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
482 extensions (undefined symbols in them will cause abort at runtime 3) to
483 remove a concurrency issue when building the dl extension that could
484 result in a broken dl.so.
485
486 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
487 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
488 Don't block rdoc-2 or later (which may enter Portage one day as it's
489 needed by some Rakefiles).
490
491 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
492 ruby-1.9.1_p129.ebuild:
493 Add ~x86-fbsd keyword.
494
495 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
496 keyword ~sparc-fbsd, bug #252315
497
498*ruby-1.9.1_p129 (15 May 2009)
499
500 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
501 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
502 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
503 included in every release.
504
505 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
506 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
507 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
508 ruby-1.8.7_p160.ebuild:
509 Removing vulnerable versions (#268515), fixing license (#233747).
510
511 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
512 Stable for HPPA (bug #268515).
513
514 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
515 Adapting rubygems notice.
516
517 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
518 amd64 stable, bug #268515.
519
520 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
521 arm/ia64/s390/sh/sparc stable wrt #268515
522
523 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
524 ruby-1.8.6_p368.ebuild:
525 stable x86, security bug 268515
526
527 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
528 ruby-1.8.6_p368.ebuild:
529 Stable on alpha, bug #268515
530
531 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
532 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
533
534*ruby-1.8.7_p160 (07 May 2009)
535*ruby-1.8.6_p368 (07 May 2009)
536
537 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
538 +ruby-1.8.7_p160.ebuild:
539 Version bump as per secbug 268515. NB: These are the first ebuilds that
540 no longer use ruby-config.
541
542*ruby-1.9.1-r1 (03 Apr 2009)
543*ruby-1.8.7_p72-r11 (03 Apr 2009)
544*ruby-1.8.6_p287-r13 (03 Apr 2009)
545
546 03 Apr 2009; Alex Legler <a3li@gentoo.org>
547 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
548 +files/ruby18-mkmf-parallel-install.patch,
549 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
550 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
551 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
552 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
553 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
554 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
555 happy.
556
557*ruby-1.9.1 (21 Mar 2009)
558
559 21 Mar 2009; Alex Legler <a3li@gentoo.org>
560 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
561 +ruby-1.9.1.ebuild:
562 Adding Ruby 1.9.1 for preliminary testing
563
564 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
565 ruby-1.8.6_p287-r12.ebuild:
566 Marked ~ppc for bug #252315.
567
568 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
569 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
570 bug 261982.
571
572 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
573 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
574 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
575 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
576 Cleanup
577
578*ruby-1.8.7_p72-r10 (07 Mar 2009)
579
580 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
581 +ruby-1.8.7_p72-r10.ebuild:
582 Add a revision of ruby 1.8.7 using eselect ruby.
583
584 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
585 ~mips keyworded, bug #252315.
586
587 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
588 ruby-1.8.6_p287-r5.ebuild:
589 ppc stable, bug #260006
590
591 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
592 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
593
594 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
595 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
596 Fixing Tk USE flag test, bug 258893.
597
598 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
599 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
600
601 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
602 ruby-1.8.6_p287-r5.ebuild:
603 amd64 stable wrt security bug #260006
604
605 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
606 Stable for HPPA (bug #260006).
607
608 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
609 ruby-1.8.6_p287-r5.ebuild:
610 Stable on alpha, bug #260006
611
612*ruby-1.8.7_p72-r2 (23 Feb 2009)
613*ruby-1.8.6_p287-r12 (23 Feb 2009)
614*ruby-1.8.6_p287-r5 (23 Feb 2009)
615
616 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
617 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
618 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
619 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
620 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
621 now before compilation if Tk useflags don't match) and 230748 (adding
622 --enable-option-checking=no for newer versions of autoconf).
623
624 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
625 arm/ia64/s390/sh/sparc stable wrt #254307
626
627 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
628 ruby-1.8.6_p287-r4.ebuild:
629 Stable on alpha, bug #254307
630
631 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
632 ruby-1.8.6_p287-r11.ebuild:
633 keyword ~x86-fbsd, bug #252315
634
635 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
636 ppc stable #254307
637
638 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
639 amd64/x86 stable, bug #254307
640
641 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
642 stable ppc64, bug 254307
643
644 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
645 Stable for HPPA (bug #254307).
646
647 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
648 ruby-1.8.6_p287-r11.ebuild:
649 Marked ~hppa (bug #252315).
650
651*ruby-1.8.6_p287-r11 (11 Jan 2009)
652
653 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
654 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
655 +ruby-1.8.6_p287-r11.ebuild:
656 Backport conditional definition of missing openssl functions from ruby 1.8.7.
657 Fixes #254307.
658
659 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
660 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
661
662 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
663 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
664
665 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
666 ruby-1.8.6_p287-r10.ebuild:
667 Add ~sparc keyword, bug #252315
668
669*ruby-1.8.6_p287-r10 (23 Dec 2008)
670
671 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
672 +ruby-1.8.6_p287-r10.ebuild:
673 Version bump which switches from ruby-config to eselect-ruby. Dropped most
674 keywords since eselect-ruby does not yet have these keywords.
675
676 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
677 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
678 Revert the ruby-config changes. We can't remove them until we provide an
679 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
680 for breaking things as mentioned in bug #251833.
681
682 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
683 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
684 ruby-1.8.7_p72-r1.ebuild:
685 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
686 Thanks for the people noticing this in bug #251833.
687
688 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
689 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
690 ruby-1.8.7_p72-r1.ebuild:
691 Drop dependency on ruby-config, which will be removed from the tree. We
692 currently only have one major version of ruby in the tree (Ruby 1.8), so there
693 is no need for ruby-config at this moment. For newer versions of Ruby we will
694 use eselect-ruby, which can be found in the ruby overlay at the moment.
695
696 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
697 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
698 Use mirror://ruby in SRC_URI, fixes #237392.
699
700 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
701 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
702 -ruby-1.8.7_p72.ebuild:
703 Remove old versions. Leave one old stable version with cjk support.
704
705*ruby-1.8.6_p287-r3 (29 Nov 2008)
706
707 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
708 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
709 +ruby-1.8.6_p287-r3.ebuild:
710 Fix our expansion limit patch according to debian bug report
711 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
712 make sure people will pick up the fixed version. Thanks to Alex Legler for
713 mentioning the patch.
714
715*ruby-1.8.7_p72-r1 (26 Nov 2008)
716*ruby-1.8.6_p287-r2 (26 Nov 2008)
717
718 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
719 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
720 +ruby-1.8.7_p72-r1.ebuild:
721 Fix problem with shortname constants #247790, already fixed in upstream SVN.
722 Thanks to Alex Legler for providing the patch.
723
724 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
725 -ruby-1.8.6_p287.ebuild:
726 Remove versions that will not become stable
727
728 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
729 ruby-1.8.6_p287-r1.ebuild:
730 ppc stable, bug #225465
731
732 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
733 ruby-1.8.6_p287-r1.ebuild:
734 amd64 stable wrt security bug #225465
735
736 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
737 alpha/ia64/x86 stable wrt #225465
738
739 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
740 ruby-1.8.6_p287-r1.ebuild:
741 Sparc stable --- Security Bug #225465 --- good since late August.
742
743 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
744 Stable on ppc64; bug #225465
745
746 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
747 Stable for HPPA (bug #225465).
748
749*ruby-1.8.6_p287-r1 (29 Aug 2008)
750
751 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
752 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
753 +ruby-1.8.6_p287-r1.ebuild:
754 Fix REXML security issues, bug #236060.
755
756 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
757 Add GLEP 56 USE flag descriptions.
758
759*ruby-1.8.7_p72 (15 Aug 2008)
760
761 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
762 +ruby-1.8.7_p72.ebuild:
763 bump 1.8.7 to latest patch release
764
765*ruby-1.8.6_p287 (11 Aug 2008)
766
767 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
768 Version bump for brown paper bag relelease.
769
770 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
771 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
772 Remove broken version in favor of the just-added 1.8.6_p286
773
774*ruby-1.8.6_p286 (10 Aug 2008)
775
776 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
777 Version bump to latest released version of ruby 1.8.6. This version fixes the
778 security issues reported in #225465 and #234224. The cjk USE flag has been
779 dropped since no compatible patches have been released yet.
780
781 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
782 ruby-1.8.6_p230.ebuild:
783 drop cjk from SRC_URI as well
784
785 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
786 Drop cjk support since the most recent oniguruma patches no longer apply to
787 this version, #230111.
788
789 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
790 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
791 Try to fix the security issues reported in #225465 for ruby 1.8.6.
792 Unfortunately the official p230 has a change which causes segmentation faults
793 for applications like Rails and RSpec, so we are reverting that specific
794 change.
795
796*ruby-1.8.7_p22 (29 Jun 2008)
797
798 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
799 +ruby-1.8.7_p22.ebuild:
800 bump 1.8.7 for security fix
801
802 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
803 nevermind, don't bump this yet
804
805*ruby-1.8.6_p230 (20 Jun 2008)
806
807 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
808 version bump
809
810*ruby-1.8.7 (10 Jun 2008)
811
812 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
813 +ruby-1.8.7.ebuild:
814 bump 1.8.7 to final
815
816*ruby-1.8.7_pre2 (21 Apr 2008)
817
818 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
819 +ruby-1.8.7_pre2.ebuild:
820 Version Bump
821
822*ruby-1.8.7_pre1 (16 Apr 2008)
823
824 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
825 Version bump. Drop cjk until a new version of oniguruma appears.
826
827 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
828 amd64 stable, bug 212264
829
830 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
831 Stable for HPPA (bug #212264).
832
833 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
834 ruby-1.8.6_p114.ebuild:
835 ppc stable, bug #212264
836
837 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
838 alpha/ia64 stable wrt #212264
839
840 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
841 ruby-1.8.6_p114.ebuild:
842 stable x86, security bug 212264
843
844 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
845 Sparc stable, Security Bug #212264, builds and installs, initial tests run
846 as expected.
847
848 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
849 Marking ruby-1.8.6_p114 ppc64 for bug 212264
850
851*ruby-1.8.6_p114 (05 Mar 2008)
852
853 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
854 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
855 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
856 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
857 Version bump for #212264. Remove old ebuilds.
858
859 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
860 alpha/ia64 stable wrt #208916
861
862 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
863 Stable on ppc wrt bug 208916
864
865 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
866 x86 stable, bug #208916
867
868 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
869 ruby-1.8.6_p111-r1.ebuild:
870 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
871
872 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
873 -files/ruby-1.8.6-exit-status.patch,
874 -files/ruby-1.8.6_p110-net-http-p111.patch,
875 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
876 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
877 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
878 Remove old versions
879
880 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
881 Stable on ppc64
882
883 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
884 Stable on amd64; bug 199191
885
886 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
887 alpha/ia64/sparc stable wrt #199191
888
889 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
890 Remove now-obsolete warning about coreutils versions, #203156.
891
892 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
893 Stable for HPPA (bug #199191).
894
895*ruby-1.8.6_p111-r1 (23 Dec 2007)
896
897 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
898 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
899 ssl USE flags. Patch to p113.
900
901 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
902 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
903
904 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
905 x86 stable, security bug #199191
906
907*ruby-1.8.6_p111 (23 Dec 2007)
908
909 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
910 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
911 Version bump with patch for bug #199191
912
913 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
914 Move dependency on (X)Emacs modes to PDEPEND.
915
916 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
917 Add back ~hppa keyword now that XEmacs support files have been keyworded,
918 bug 196413
919
920*ruby-1.8.6_p110-r2 (21 Oct 2007)
921
922 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
923 +ruby-1.8.6_p110-r2.ebuild:
924 Add emacs and xemacs USE flags and use them to pull in the correct editing
925 mode for each. Had to drop several arch keywords as reported on bug 196413.
926
927 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
928 amd64 stable, security bug 194236
929
930 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
931 ruby-1.8.6_p110-r1.ebuild:
932 Stable on ppc64; bug #194236
933
934 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
935 amd64 stable, security bug 194236
936
937 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
938 Stable for HPPA (bug #194236).
939
940 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
941 alpha/ia64/sparc stable wrt security #194236
942
943 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
944 ruby-1.8.6_p110-r1.ebuild:
945 ppc stable, bug #194236
946
947 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
948 ruby-1.8.6_p110-r1.ebuild:
949 stable x86, security bug 194236
950
951 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
952 ruby-1.8.5_p113.ebuild:
953 stable x86, security bug 194236
954
955 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
956 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
957 -ruby-1.8.6_p110.ebuild:
958 Remove old versions
959
960*ruby-1.8.6_p110-r1 (30 Sep 2007)
961*ruby-1.8.5_p113 (30 Sep 2007)
962
963 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
964 +files/ruby-1.8.5_p113-net-http-p114.patch,
965 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
966 +ruby-1.8.6_p110-r1.ebuild:
967 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
968 using 1.8.6-p110 as base ebuild.
969
970 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
971 More fixes from gentoo-dev and graaff
972
973 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
974 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
975
976*ruby-1.8.6_p110 (24 Sep 2007)
977
978 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
979 Version bump
980
981*ruby-1.8.6_p36-r4 (26 Aug 2007)
982
983 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
984 +ruby-1.8.6_p36-r4.ebuild:
985 Use user LDFLAGS, #181436
986
987 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
988 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
989 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
990 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
991
992 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
993 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
994 -ruby-1.8.6_p36-r2.ebuild:
995 Remove some older versions that will not be promoted to stable, keeping at
996 least one version of each release.
997
998 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
999 ruby-1.8.6_p36-r3.ebuild:
1000 (QA) RESTRICT clean up.
1001
1002*ruby-1.8.6_p36-r3 (04 Jul 2007)
1003
1004 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1005 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1006 fixed memory leak loading .so bug #182946
1007
1008 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1009 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1010 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1011 ruby-1.8.6_p36-r2.ebuild:
1012 (QA) RESTRICT clean up.
1013
1014 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1015 Re-add stable keyword for alpha as per bug #181110
1016
1017 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1018 Back to ~amd64 wrt bug 181110
1019
1020 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1021 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1022
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1023*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1024
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1025 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1026 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.514

  ViewVC Help
Powered by ViewVC 1.1.20