/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.519
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.519 2011/12/28 17:33:12 graaff Exp $
4
5*ruby-1.8.7_p357 (28 Dec 2011)
6
7 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
8 Version bump for security bug 396301.
9
10 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
11 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
12
13 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
14 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
15 keyworded, bug 332593.
16
17 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
18 Block older versions of packages that are no longer compatible. Remove
19 ancient blocks on packags long gone from the tree.
20
21 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
22 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
23 Remove old versions.
24
25*ruby-1.9.3_p0 (18 Dec 2011)
26
27 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
28 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
29 suite which need to be diagnosed first.
30
31 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
32 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
33 #332593).
34
35 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
36 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
37 #332593).
38
39 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
40 alpha/ia64/s390/sh/sparc stable wrt #386369
41
42*ruby-1.9.3_rc1 (22 Oct 2011)
43
44 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
45 Version bump.
46
47 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
48 arm stable, bug #386369
49
50 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
51 x86 stable, bug 386369
52
53 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
54 Stable for HPPA (bug #386369).
55
56 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
57 ppc/ppc64 stable wrt #386369
58
59 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
60 Stable on amd64 wrt bug #386369
61
62 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
63 Remove vulnerable version, bug 386369.
64
65*ruby-1.8.7_p352 (30 Aug 2011)
66
67 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
68 +ruby-1.8.7_p352.ebuild:
69 Patchlevel bump for ruby:1.8. Removing old version
70
71*ruby-1.9.2_p290 (30 Aug 2011)
72
73 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
74 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
75 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
76 old patchlevels.
77
78 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
79 ruby-1.8.7_p334-r2.ebuild:
80 ppc/ppc64 stable wrt #378691
81
82*ruby-1.8.7_p334-r2 (22 Jul 2011)
83
84 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
85 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
86 for chasing down upstream and us.
87
88 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
89 Added ~mips, bug 332593
90
91 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
92 ruby-1.8.7_p334-r1.ebuild:
93 ppc64 stable wrt #369141
94
95 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
96 ia64/s390/sh/sparc stable wrt #369141
97
98 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
99 Stable for HPPA (bug #369141).
100
101 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
102 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
103
104 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
105 arm/x86 stable, bug #369141
106
107 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
108 Stable on amd64 wrt bug #369141
109
110 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
111 ruby-1.8.7_p334-r1.ebuild:
112 Stable on alpha, bug #369141
113
114*ruby-1.8.7_p334-r1 (31 May 2011)
115
116 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
117 Revision bump for security bug 369141 (CVE-2011-0188)
118
119*ruby-1.9.2-r1 (16 May 2011)
120
121 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
122 Don't remove racc files since all other ruby targets ship these files
123 themselves as well. Closes bug 363419.
124
125 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
126 ruby-1.8.7_p334.ebuild:
127 Remove old version. Remove obsolete and unused old-style virtual/ruby.
128
129 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
130 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
131
132 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
133 Add append-flags -mieee on sh, bug #357559
134
135 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
136 alpha/arm/ia64/s390/sh stable wrt #355439
137
138 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
139 Marked ~ppc64 wrt #332593
140
141 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
142 ruby-1.8.7_p334.ebuild:
143 x86 stable wrt security bug #355439
144
145 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
146 ruby-1.8.7_p334.ebuild:
147 ppc/ppc64 stable wrt #355439
148
149 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
150 Stable on amd64 wrt bug #355439
151
152 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
153 Stable for HPPA (bug #355439).
154
155*ruby-1.8.7_p334 (19 Feb 2011)
156
157 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
158 Version bump 1.8.7 series, security bug 355439
159
160 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
161 ruby-1.9.2.ebuild:
162 Remove PROVIDE for old-style virtual/ruby per bug 265054.
163
164 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
165 Remove masked ruby 1.8.6 per bug 332597.
166
167 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
168 -ruby-1.9.2_rc2.ebuild:
169 Removing old and vulnerable ebuilds
170
171 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
172 Marking ruby-1.8.7_p302 ppc64 for bug 332957
173
174 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
175 alpha/ia64/s390/sh/sparc stable wrt #332957
176
177*ruby-1.9.2 (24 Aug 2010)
178
179 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
180 metadata.xml:
181 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
182 and x86-fbsd due to a new dependency on rdoc.
183
184 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
185 arm stable, bug #332957
186
187 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
188 ruby-1.8.7_p302.ebuild:
189 x86 stable wrt security bug #332957
190
191 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
192 Stable on amd64 wrt bug #332957
193
194 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
195 Stable for PPC (bug #332957).
196
197 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
198 Stable for HPPA (bug #332957).
199
200*ruby-1.8.7_p302 (21 Aug 2010)
201
202 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
203 +ruby-1.8.7_p302.ebuild:
204 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
205 installation path.
206
207*ruby-1.8.6_p399 (19 Aug 2010)
208
209 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
210 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
211 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
212 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
213 installation path (reported by the x86 team in bug 332597)
214
215*ruby-1.9.2_rc2-r1 (18 Aug 2010)
216
217 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
218 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
219 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
220 the rubygems loading code. Add USE flag for psych.
221
222 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
223 ruby-1.9.2_rc2.ebuild:
224 Remove two keepdir that will try to keep an empty path, closes bug
225 #333163.
226
227 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
228 Marked ~ppc (bug #332593).
229
230 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
231 ruby-1.9.2_rc2.ebuild:
232 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
233
234 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
235 ruby-1.8.7_p299.ebuild:
236 Bump eselect-ruby dependency
237
238 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
239 -ruby-1.9.1_p429.ebuild:
240 Remove ebuild that is not target for unmask anyway.
241
242 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
243 ruby-1.9.2_rc2.ebuild:
244 Try 2 to fix the berkdb 5 issue on 1.9.
245
246 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
247 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
248 ruby-1.9.2_rc2.ebuild:
249 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
250 support for adding new patchsets without bumping the revision for all the
251 old ebuilds as well.
252
253*ruby-1.9.2_rc2 (14 Jul 2010)
254
255 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
256 +ruby-1.9.2_rc2.ebuild:
257 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
258 might cause _further_ build failures as it changed slightly behaviour.
259 You're going to need to rebuild rubygems and then all the packages
260 previously installed after upgrading to this.
261
262 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
263 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
264 -ruby-1.9.1_p376.ebuild:
265 Cleanup old versions.
266
267*ruby-1.9.1_p429 (04 Jul 2010)
268
269 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
270 +ruby-1.9.1_p429.ebuild:
271 Version bump to new 1.9.1 release.
272
273*ruby-1.8.7_p299 (23 Jun 2010)
274
275 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
276 +ruby-1.8.7_p299.ebuild:
277 Version bump.
278
279 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
280 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
281 remove useless comments
282
283 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
284 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
285 ruby-1.9.1_p376.ebuild:
286 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
287 dev.gentoo.org now.
288
289 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
290 ruby-1.9.1_p376.ebuild:
291 Use the correct RUBYLIB.
292
293*ruby-1.8.7_p249-r2 (18 May 2010)
294*ruby-1.8.6_p388-r1 (18 May 2010)
295
296 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
297 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
298 ruby-1.9.1_p376.ebuild, metadata.xml:
299 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
300 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
301 add USE flags for ncurses, readline and libedit, and properly depend on
302 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
303 Emacs versions support ruby-mode themselves and it should be even more
304 updated.
305
306*ruby-1.8.7_p249-r1 (06 May 2010)
307
308 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
309 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
310 309789 by Sune Kloppenborg Jeppesen.
311
312 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
313 ruby-1.8.7_p249.ebuild:
314 Use $PVR instead of $PV in patchset names
315
316 06 May 2010; Alex Legler <a3li@gentoo.org>
317 -files/ruby-1.8.6-memory-leak.diff,
318 -files/ruby18-mkmf-parallel-install.patch,
319 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
320 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
321 Remove old version. Cleanup in files/
322
323*ruby-1.9.1_p376 (01 May 2010)
324
325 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
326 Version bump. Fixes security bugs 296052 and 300468. No longer installs
327 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
328 instead.
329
330 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
331 -ruby-1.8.7_p174-r1.ebuild:
332 Remove vulnerable ebuilds, 300468
333
334 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
335 ruby-1.8.7_p249.ebuild:
336 amd64 stable, security bug 300468
337
338 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
339 ruby-1.8.7_p249.ebuild:
340 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
341
342 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
343 Stable for HPPA (bug #300468).
344
345 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
346 Stable for HPPA (bug #300468).
347
348 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
349 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
350
351 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
352 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
353
354 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
355 ruby-1.8.6_p388.ebuild:
356 stable x86, security bug 300468
357
358 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
359 ruby-1.8.7_p249.ebuild:
360 stable x86, security bug 300468
361
362*ruby-1.8.6_p388 (10 Jan 2010)
363
364 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
365 +ruby-1.8.6_p388.ebuild:
366 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
367 version. The new ebuild also has the fix for bug 168939.
368
369*ruby-1.8.7_p249 (10 Jan 2010)
370
371 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
372 +ruby-1.8.7_p249.ebuild:
373 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
374 version
375
376 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
377 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
378
379*ruby-1.8.7_p248 (25 Dec 2009)
380
381 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
382 Version bump
383
384 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
385 Remove old version.
386
387 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
388 Remove old version.
389
390 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
391 ia64/s390/sh stable wrt #288699
392
393 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
394 stable sparc, bug 288699
395
396 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
397 arm stable, bug #288699
398
399 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
400 amd64/x86 stable, bug #288699
401
402 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
403 ruby-1.8.7_p174-r1.ebuild:
404 Stable on alpha, bug #288699
405
406 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
407 ppc stable #288699
408
409 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
410 Stable for HPPA (bug #288699).
411
412 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
413 Marked ~hppa too.
414
415*ruby-1.8.7_p174-r1 (06 Oct 2009)
416
417 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
418 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
419 eselect-ruby cleanup feature.
420
421*ruby-1.9.1_p243 (09 Sep 2009)
422
423 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
424 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
425 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
426 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
427 -files/ruby19-rubygems-proxy.patch,
428 -files/ruby-1.9.1_p129-parallelmake.patch,
429 -files/ruby19-mkmf-parallel-install.patch:
430 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
431 168939. Cleaning up old patches.
432
433*ruby-1.8.6_p383 (20 Aug 2009)
434
435 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
436 Patchlevel bump.
437
438 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
439 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
440 ruby-1.9.1_p129-r1.ebuild:
441 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
442
443 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
444 Removing vulnerable ebuild, bug 273213.
445
446 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
447 Marking ruby-1.8.6_p369 ppc for bug 273213
448
449 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
450 ruby-1.9.1_p129-r1.ebuild:
451 Prepend our library path instead of overwriting it during src_install.
452 Thanks to the reporter of bug #274824.
453
454*ruby-1.8.7_p174 (18 Jun 2009)
455
456 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
457 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
458 Replacing 187_p173 with _p174 because of a regression. Unifying the
459 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
460 patchsets.
461
462 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
463 Marking ruby-1.8.6_p369 ppc64 for bug 273213
464
465 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
466 arm/ia64/s390/sh/sparc stable wrt #273213
467
468 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
469 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
470 Removing old version, minor cleanup
471
472 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
473 -files/ruby-1.8.6-openssl.patch,
474 -files/ruby-1.8.6-shortname_constants.patch,
475 -files/ruby-1.8.6_p111-r13657.patch,
476 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
477 Removing vulnerable old Ruby version and stale patches, bug 274108.
478
479 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
480 ruby-1.8.6_p369.ebuild:
481 Stable on alpha, bug #273213
482
483 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
484 Stable for HPPA (bug #273213).
485
486 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
487 ruby-1.8.6_p369.ebuild:
488 stable x86, security bug 273213
489
490 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
491 amd64 stable, security bug 273213.
492
493*ruby-1.8.7_p173 (10 Jun 2009)
494*ruby-1.8.6_p369 (10 Jun 2009)
495
496 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
497 +ruby-1.8.7_p173.ebuild:
498 Version bumps for bug #273213.
499
500*ruby-1.9.1_p129-r1 (27 May 2009)
501
502 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
503 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
504 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
505 +files/ruby-1.9.1_p129-parallelmake.patch:
506 Revision bump, add patches 1) to make Ruby behave more similarly between
507 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
508 extensions (undefined symbols in them will cause abort at runtime 3) to
509 remove a concurrency issue when building the dl extension that could
510 result in a broken dl.so.
511
512 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
513 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
514 Don't block rdoc-2 or later (which may enter Portage one day as it's
515 needed by some Rakefiles).
516
517 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
518 ruby-1.9.1_p129.ebuild:
519 Add ~x86-fbsd keyword.
520
521 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
522 keyword ~sparc-fbsd, bug #252315
523
524*ruby-1.9.1_p129 (15 May 2009)
525
526 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
527 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
528 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
529 included in every release.
530
531 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
532 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
533 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
534 ruby-1.8.7_p160.ebuild:
535 Removing vulnerable versions (#268515), fixing license (#233747).
536
537 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
538 Stable for HPPA (bug #268515).
539
540 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
541 Adapting rubygems notice.
542
543 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
544 amd64 stable, bug #268515.
545
546 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
547 arm/ia64/s390/sh/sparc stable wrt #268515
548
549 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
550 ruby-1.8.6_p368.ebuild:
551 stable x86, security bug 268515
552
553 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
554 ruby-1.8.6_p368.ebuild:
555 Stable on alpha, bug #268515
556
557 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
558 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
559
560*ruby-1.8.7_p160 (07 May 2009)
561*ruby-1.8.6_p368 (07 May 2009)
562
563 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
564 +ruby-1.8.7_p160.ebuild:
565 Version bump as per secbug 268515. NB: These are the first ebuilds that
566 no longer use ruby-config.
567
568*ruby-1.9.1-r1 (03 Apr 2009)
569*ruby-1.8.7_p72-r11 (03 Apr 2009)
570*ruby-1.8.6_p287-r13 (03 Apr 2009)
571
572 03 Apr 2009; Alex Legler <a3li@gentoo.org>
573 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
574 +files/ruby18-mkmf-parallel-install.patch,
575 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
576 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
577 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
578 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
579 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
580 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
581 happy.
582
583*ruby-1.9.1 (21 Mar 2009)
584
585 21 Mar 2009; Alex Legler <a3li@gentoo.org>
586 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
587 +ruby-1.9.1.ebuild:
588 Adding Ruby 1.9.1 for preliminary testing
589
590 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
591 ruby-1.8.6_p287-r12.ebuild:
592 Marked ~ppc for bug #252315.
593
594 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
595 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
596 bug 261982.
597
598 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
599 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
600 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
601 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
602 Cleanup
603
604*ruby-1.8.7_p72-r10 (07 Mar 2009)
605
606 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
607 +ruby-1.8.7_p72-r10.ebuild:
608 Add a revision of ruby 1.8.7 using eselect ruby.
609
610 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
611 ~mips keyworded, bug #252315.
612
613 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
614 ruby-1.8.6_p287-r5.ebuild:
615 ppc stable, bug #260006
616
617 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
618 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
619
620 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
621 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
622 Fixing Tk USE flag test, bug 258893.
623
624 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
625 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
626
627 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
628 ruby-1.8.6_p287-r5.ebuild:
629 amd64 stable wrt security bug #260006
630
631 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
632 Stable for HPPA (bug #260006).
633
634 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
635 ruby-1.8.6_p287-r5.ebuild:
636 Stable on alpha, bug #260006
637
638*ruby-1.8.7_p72-r2 (23 Feb 2009)
639*ruby-1.8.6_p287-r12 (23 Feb 2009)
640*ruby-1.8.6_p287-r5 (23 Feb 2009)
641
642 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
643 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
644 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
645 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
646 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
647 now before compilation if Tk useflags don't match) and 230748 (adding
648 --enable-option-checking=no for newer versions of autoconf).
649
650 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
651 arm/ia64/s390/sh/sparc stable wrt #254307
652
653 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
654 ruby-1.8.6_p287-r4.ebuild:
655 Stable on alpha, bug #254307
656
657 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
658 ruby-1.8.6_p287-r11.ebuild:
659 keyword ~x86-fbsd, bug #252315
660
661 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
662 ppc stable #254307
663
664 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
665 amd64/x86 stable, bug #254307
666
667 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
668 stable ppc64, bug 254307
669
670 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
671 Stable for HPPA (bug #254307).
672
673 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
674 ruby-1.8.6_p287-r11.ebuild:
675 Marked ~hppa (bug #252315).
676
677*ruby-1.8.6_p287-r11 (11 Jan 2009)
678
679 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
680 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
681 +ruby-1.8.6_p287-r11.ebuild:
682 Backport conditional definition of missing openssl functions from ruby 1.8.7.
683 Fixes #254307.
684
685 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
686 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
687
688 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
689 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
690
691 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
692 ruby-1.8.6_p287-r10.ebuild:
693 Add ~sparc keyword, bug #252315
694
695*ruby-1.8.6_p287-r10 (23 Dec 2008)
696
697 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
698 +ruby-1.8.6_p287-r10.ebuild:
699 Version bump which switches from ruby-config to eselect-ruby. Dropped most
700 keywords since eselect-ruby does not yet have these keywords.
701
702 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
703 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
704 Revert the ruby-config changes. We can't remove them until we provide an
705 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
706 for breaking things as mentioned in bug #251833.
707
708 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
709 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
710 ruby-1.8.7_p72-r1.ebuild:
711 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
712 Thanks for the people noticing this in bug #251833.
713
714 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
715 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
716 ruby-1.8.7_p72-r1.ebuild:
717 Drop dependency on ruby-config, which will be removed from the tree. We
718 currently only have one major version of ruby in the tree (Ruby 1.8), so there
719 is no need for ruby-config at this moment. For newer versions of Ruby we will
720 use eselect-ruby, which can be found in the ruby overlay at the moment.
721
722 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
723 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
724 Use mirror://ruby in SRC_URI, fixes #237392.
725
726 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
727 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
728 -ruby-1.8.7_p72.ebuild:
729 Remove old versions. Leave one old stable version with cjk support.
730
731*ruby-1.8.6_p287-r3 (29 Nov 2008)
732
733 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
734 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
735 +ruby-1.8.6_p287-r3.ebuild:
736 Fix our expansion limit patch according to debian bug report
737 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
738 make sure people will pick up the fixed version. Thanks to Alex Legler for
739 mentioning the patch.
740
741*ruby-1.8.7_p72-r1 (26 Nov 2008)
742*ruby-1.8.6_p287-r2 (26 Nov 2008)
743
744 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
745 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
746 +ruby-1.8.7_p72-r1.ebuild:
747 Fix problem with shortname constants #247790, already fixed in upstream SVN.
748 Thanks to Alex Legler for providing the patch.
749
750 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
751 -ruby-1.8.6_p287.ebuild:
752 Remove versions that will not become stable
753
754 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
755 ruby-1.8.6_p287-r1.ebuild:
756 ppc stable, bug #225465
757
758 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
759 ruby-1.8.6_p287-r1.ebuild:
760 amd64 stable wrt security bug #225465
761
762 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
763 alpha/ia64/x86 stable wrt #225465
764
765 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
766 ruby-1.8.6_p287-r1.ebuild:
767 Sparc stable --- Security Bug #225465 --- good since late August.
768
769 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
770 Stable on ppc64; bug #225465
771
772 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
773 Stable for HPPA (bug #225465).
774
775*ruby-1.8.6_p287-r1 (29 Aug 2008)
776
777 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
778 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
779 +ruby-1.8.6_p287-r1.ebuild:
780 Fix REXML security issues, bug #236060.
781
782 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
783 Add GLEP 56 USE flag descriptions.
784
785*ruby-1.8.7_p72 (15 Aug 2008)
786
787 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
788 +ruby-1.8.7_p72.ebuild:
789 bump 1.8.7 to latest patch release
790
791*ruby-1.8.6_p287 (11 Aug 2008)
792
793 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
794 Version bump for brown paper bag relelease.
795
796 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
797 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
798 Remove broken version in favor of the just-added 1.8.6_p286
799
800*ruby-1.8.6_p286 (10 Aug 2008)
801
802 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
803 Version bump to latest released version of ruby 1.8.6. This version fixes the
804 security issues reported in #225465 and #234224. The cjk USE flag has been
805 dropped since no compatible patches have been released yet.
806
807 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
808 ruby-1.8.6_p230.ebuild:
809 drop cjk from SRC_URI as well
810
811 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
812 Drop cjk support since the most recent oniguruma patches no longer apply to
813 this version, #230111.
814
815 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
816 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
817 Try to fix the security issues reported in #225465 for ruby 1.8.6.
818 Unfortunately the official p230 has a change which causes segmentation faults
819 for applications like Rails and RSpec, so we are reverting that specific
820 change.
821
822*ruby-1.8.7_p22 (29 Jun 2008)
823
824 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
825 +ruby-1.8.7_p22.ebuild:
826 bump 1.8.7 for security fix
827
828 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
829 nevermind, don't bump this yet
830
831*ruby-1.8.6_p230 (20 Jun 2008)
832
833 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
834 version bump
835
836*ruby-1.8.7 (10 Jun 2008)
837
838 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
839 +ruby-1.8.7.ebuild:
840 bump 1.8.7 to final
841
842*ruby-1.8.7_pre2 (21 Apr 2008)
843
844 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
845 +ruby-1.8.7_pre2.ebuild:
846 Version Bump
847
848*ruby-1.8.7_pre1 (16 Apr 2008)
849
850 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
851 Version bump. Drop cjk until a new version of oniguruma appears.
852
853 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
854 amd64 stable, bug 212264
855
856 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
857 Stable for HPPA (bug #212264).
858
859 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
860 ruby-1.8.6_p114.ebuild:
861 ppc stable, bug #212264
862
863 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
864 alpha/ia64 stable wrt #212264
865
866 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
867 ruby-1.8.6_p114.ebuild:
868 stable x86, security bug 212264
869
870 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
871 Sparc stable, Security Bug #212264, builds and installs, initial tests run
872 as expected.
873
874 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
875 Marking ruby-1.8.6_p114 ppc64 for bug 212264
876
877*ruby-1.8.6_p114 (05 Mar 2008)
878
879 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
880 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
881 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
882 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
883 Version bump for #212264. Remove old ebuilds.
884
885 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
886 alpha/ia64 stable wrt #208916
887
888 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
889 Stable on ppc wrt bug 208916
890
891 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
892 x86 stable, bug #208916
893
894 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
895 ruby-1.8.6_p111-r1.ebuild:
896 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
897
898 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
899 -files/ruby-1.8.6-exit-status.patch,
900 -files/ruby-1.8.6_p110-net-http-p111.patch,
901 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
902 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
903 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
904 Remove old versions
905
906 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
907 Stable on ppc64
908
909 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
910 Stable on amd64; bug 199191
911
912 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
913 alpha/ia64/sparc stable wrt #199191
914
915 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
916 Remove now-obsolete warning about coreutils versions, #203156.
917
918 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
919 Stable for HPPA (bug #199191).
920
921*ruby-1.8.6_p111-r1 (23 Dec 2007)
922
923 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
924 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
925 ssl USE flags. Patch to p113.
926
927 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
928 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
929
930 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
931 x86 stable, security bug #199191
932
933*ruby-1.8.6_p111 (23 Dec 2007)
934
935 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
936 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
937 Version bump with patch for bug #199191
938
939 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
940 Move dependency on (X)Emacs modes to PDEPEND.
941
942 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
943 Add back ~hppa keyword now that XEmacs support files have been keyworded,
944 bug 196413
945
946*ruby-1.8.6_p110-r2 (21 Oct 2007)
947
948 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
949 +ruby-1.8.6_p110-r2.ebuild:
950 Add emacs and xemacs USE flags and use them to pull in the correct editing
951 mode for each. Had to drop several arch keywords as reported on bug 196413.
952
953 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
954 amd64 stable, security bug 194236
955
956 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
957 ruby-1.8.6_p110-r1.ebuild:
958 Stable on ppc64; bug #194236
959
960 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
961 amd64 stable, security bug 194236
962
963 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
964 Stable for HPPA (bug #194236).
965
966 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
967 alpha/ia64/sparc stable wrt security #194236
968
969 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
970 ruby-1.8.6_p110-r1.ebuild:
971 ppc stable, bug #194236
972
973 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
974 ruby-1.8.6_p110-r1.ebuild:
975 stable x86, security bug 194236
976
977 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
978 ruby-1.8.5_p113.ebuild:
979 stable x86, security bug 194236
980
981 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
982 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
983 -ruby-1.8.6_p110.ebuild:
984 Remove old versions
985
986*ruby-1.8.6_p110-r1 (30 Sep 2007)
987*ruby-1.8.5_p113 (30 Sep 2007)
988
989 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
990 +files/ruby-1.8.5_p113-net-http-p114.patch,
991 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
992 +ruby-1.8.6_p110-r1.ebuild:
993 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
994 using 1.8.6-p110 as base ebuild.
995
996 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
997 More fixes from gentoo-dev and graaff
998
999 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1000 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1001
1002*ruby-1.8.6_p110 (24 Sep 2007)
1003
1004 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1005 Version bump
1006
1007*ruby-1.8.6_p36-r4 (26 Aug 2007)
1008
1009 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1010 +ruby-1.8.6_p36-r4.ebuild:
1011 Use user LDFLAGS, #181436
1012
1013 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1014 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1015 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1016 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1017
1018 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1019 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1020 -ruby-1.8.6_p36-r2.ebuild:
1021 Remove some older versions that will not be promoted to stable, keeping at
1022 least one version of each release.
1023
1024 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1025 ruby-1.8.6_p36-r3.ebuild:
1026 (QA) RESTRICT clean up.
1027
1028*ruby-1.8.6_p36-r3 (04 Jul 2007)
1029
1030 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1031 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1032 fixed memory leak loading .so bug #182946
1033
1034 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1035 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1036 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1037 ruby-1.8.6_p36-r2.ebuild:
1038 (QA) RESTRICT clean up.
1039
1040 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1041 Re-add stable keyword for alpha as per bug #181110
1042
1043 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1044 Back to ~amd64 wrt bug 181110
1045
1046 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1047 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1048
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1049*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1050
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1051 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1052 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.519

  ViewVC Help
Powered by ViewVC 1.1.20