/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.524
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.524 2011/12/30 03:53:09 jer Exp $
4
5 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
6 Stable for HPPA (bug #396301).
7
8 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
9 Stable for ppc/ppc64; bug #396301
10
11 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
12 Marked ~hppa (bug #332593).
13
14 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
15 Add back ~alpha keyword now that rubygems is keyworded.
16
17 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
18 Stable for AMD64, wrt security bug #396301
19
20*ruby-1.8.7_p357 (28 Dec 2011)
21
22 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
23 Version bump for security bug 396301.
24
25 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
26 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
27
28 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
29 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
30 keyworded, bug 332593.
31
32 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
33 Block older versions of packages that are no longer compatible. Remove
34 ancient blocks on packags long gone from the tree.
35
36 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
37 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
38 Remove old versions.
39
40*ruby-1.9.3_p0 (18 Dec 2011)
41
42 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
43 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
44 suite which need to be diagnosed first.
45
46 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
47 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
48 #332593).
49
50 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
51 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
52 #332593).
53
54 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
55 alpha/ia64/s390/sh/sparc stable wrt #386369
56
57*ruby-1.9.3_rc1 (22 Oct 2011)
58
59 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
60 Version bump.
61
62 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
63 arm stable, bug #386369
64
65 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
66 x86 stable, bug 386369
67
68 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
69 Stable for HPPA (bug #386369).
70
71 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
72 ppc/ppc64 stable wrt #386369
73
74 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
75 Stable on amd64 wrt bug #386369
76
77 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
78 Remove vulnerable version, bug 386369.
79
80*ruby-1.8.7_p352 (30 Aug 2011)
81
82 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
83 +ruby-1.8.7_p352.ebuild:
84 Patchlevel bump for ruby:1.8. Removing old version
85
86*ruby-1.9.2_p290 (30 Aug 2011)
87
88 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
89 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
90 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
91 old patchlevels.
92
93 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
94 ruby-1.8.7_p334-r2.ebuild:
95 ppc/ppc64 stable wrt #378691
96
97*ruby-1.8.7_p334-r2 (22 Jul 2011)
98
99 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
100 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
101 for chasing down upstream and us.
102
103 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
104 Added ~mips, bug 332593
105
106 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
107 ruby-1.8.7_p334-r1.ebuild:
108 ppc64 stable wrt #369141
109
110 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
111 ia64/s390/sh/sparc stable wrt #369141
112
113 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
114 Stable for HPPA (bug #369141).
115
116 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
117 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
118
119 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
120 arm/x86 stable, bug #369141
121
122 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
123 Stable on amd64 wrt bug #369141
124
125 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
126 ruby-1.8.7_p334-r1.ebuild:
127 Stable on alpha, bug #369141
128
129*ruby-1.8.7_p334-r1 (31 May 2011)
130
131 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
132 Revision bump for security bug 369141 (CVE-2011-0188)
133
134*ruby-1.9.2-r1 (16 May 2011)
135
136 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
137 Don't remove racc files since all other ruby targets ship these files
138 themselves as well. Closes bug 363419.
139
140 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
141 ruby-1.8.7_p334.ebuild:
142 Remove old version. Remove obsolete and unused old-style virtual/ruby.
143
144 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
145 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
146
147 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
148 Add append-flags -mieee on sh, bug #357559
149
150 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
151 alpha/arm/ia64/s390/sh stable wrt #355439
152
153 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
154 Marked ~ppc64 wrt #332593
155
156 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
157 ruby-1.8.7_p334.ebuild:
158 x86 stable wrt security bug #355439
159
160 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
161 ruby-1.8.7_p334.ebuild:
162 ppc/ppc64 stable wrt #355439
163
164 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
165 Stable on amd64 wrt bug #355439
166
167 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
168 Stable for HPPA (bug #355439).
169
170*ruby-1.8.7_p334 (19 Feb 2011)
171
172 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
173 Version bump 1.8.7 series, security bug 355439
174
175 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
176 ruby-1.9.2.ebuild:
177 Remove PROVIDE for old-style virtual/ruby per bug 265054.
178
179 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
180 Remove masked ruby 1.8.6 per bug 332597.
181
182 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
183 -ruby-1.9.2_rc2.ebuild:
184 Removing old and vulnerable ebuilds
185
186 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
187 Marking ruby-1.8.7_p302 ppc64 for bug 332957
188
189 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
190 alpha/ia64/s390/sh/sparc stable wrt #332957
191
192*ruby-1.9.2 (24 Aug 2010)
193
194 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
195 metadata.xml:
196 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
197 and x86-fbsd due to a new dependency on rdoc.
198
199 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
200 arm stable, bug #332957
201
202 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
203 ruby-1.8.7_p302.ebuild:
204 x86 stable wrt security bug #332957
205
206 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
207 Stable on amd64 wrt bug #332957
208
209 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
210 Stable for PPC (bug #332957).
211
212 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
213 Stable for HPPA (bug #332957).
214
215*ruby-1.8.7_p302 (21 Aug 2010)
216
217 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
218 +ruby-1.8.7_p302.ebuild:
219 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
220 installation path.
221
222*ruby-1.8.6_p399 (19 Aug 2010)
223
224 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
225 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
226 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
227 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
228 installation path (reported by the x86 team in bug 332597)
229
230*ruby-1.9.2_rc2-r1 (18 Aug 2010)
231
232 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
233 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
234 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
235 the rubygems loading code. Add USE flag for psych.
236
237 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
238 ruby-1.9.2_rc2.ebuild:
239 Remove two keepdir that will try to keep an empty path, closes bug
240 #333163.
241
242 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
243 Marked ~ppc (bug #332593).
244
245 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
246 ruby-1.9.2_rc2.ebuild:
247 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
248
249 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
250 ruby-1.8.7_p299.ebuild:
251 Bump eselect-ruby dependency
252
253 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
254 -ruby-1.9.1_p429.ebuild:
255 Remove ebuild that is not target for unmask anyway.
256
257 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
258 ruby-1.9.2_rc2.ebuild:
259 Try 2 to fix the berkdb 5 issue on 1.9.
260
261 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
262 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
263 ruby-1.9.2_rc2.ebuild:
264 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
265 support for adding new patchsets without bumping the revision for all the
266 old ebuilds as well.
267
268*ruby-1.9.2_rc2 (14 Jul 2010)
269
270 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 +ruby-1.9.2_rc2.ebuild:
272 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
273 might cause _further_ build failures as it changed slightly behaviour.
274 You're going to need to rebuild rubygems and then all the packages
275 previously installed after upgrading to this.
276
277 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
278 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
279 -ruby-1.9.1_p376.ebuild:
280 Cleanup old versions.
281
282*ruby-1.9.1_p429 (04 Jul 2010)
283
284 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 +ruby-1.9.1_p429.ebuild:
286 Version bump to new 1.9.1 release.
287
288*ruby-1.8.7_p299 (23 Jun 2010)
289
290 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
291 +ruby-1.8.7_p299.ebuild:
292 Version bump.
293
294 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
295 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
296 remove useless comments
297
298 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
299 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
300 ruby-1.9.1_p376.ebuild:
301 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
302 dev.gentoo.org now.
303
304 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
305 ruby-1.9.1_p376.ebuild:
306 Use the correct RUBYLIB.
307
308*ruby-1.8.7_p249-r2 (18 May 2010)
309*ruby-1.8.6_p388-r1 (18 May 2010)
310
311 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
312 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
313 ruby-1.9.1_p376.ebuild, metadata.xml:
314 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
315 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
316 add USE flags for ncurses, readline and libedit, and properly depend on
317 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
318 Emacs versions support ruby-mode themselves and it should be even more
319 updated.
320
321*ruby-1.8.7_p249-r1 (06 May 2010)
322
323 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
324 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
325 309789 by Sune Kloppenborg Jeppesen.
326
327 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
328 ruby-1.8.7_p249.ebuild:
329 Use $PVR instead of $PV in patchset names
330
331 06 May 2010; Alex Legler <a3li@gentoo.org>
332 -files/ruby-1.8.6-memory-leak.diff,
333 -files/ruby18-mkmf-parallel-install.patch,
334 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
335 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
336 Remove old version. Cleanup in files/
337
338*ruby-1.9.1_p376 (01 May 2010)
339
340 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
341 Version bump. Fixes security bugs 296052 and 300468. No longer installs
342 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
343 instead.
344
345 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
346 -ruby-1.8.7_p174-r1.ebuild:
347 Remove vulnerable ebuilds, 300468
348
349 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
350 ruby-1.8.7_p249.ebuild:
351 amd64 stable, security bug 300468
352
353 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
354 ruby-1.8.7_p249.ebuild:
355 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
356
357 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
358 Stable for HPPA (bug #300468).
359
360 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
361 Stable for HPPA (bug #300468).
362
363 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
364 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
365
366 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
367 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
368
369 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
370 ruby-1.8.6_p388.ebuild:
371 stable x86, security bug 300468
372
373 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
374 ruby-1.8.7_p249.ebuild:
375 stable x86, security bug 300468
376
377*ruby-1.8.6_p388 (10 Jan 2010)
378
379 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
380 +ruby-1.8.6_p388.ebuild:
381 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
382 version. The new ebuild also has the fix for bug 168939.
383
384*ruby-1.8.7_p249 (10 Jan 2010)
385
386 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
387 +ruby-1.8.7_p249.ebuild:
388 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
389 version
390
391 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
392 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
393
394*ruby-1.8.7_p248 (25 Dec 2009)
395
396 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
397 Version bump
398
399 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
400 Remove old version.
401
402 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
403 Remove old version.
404
405 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
406 ia64/s390/sh stable wrt #288699
407
408 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
409 stable sparc, bug 288699
410
411 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
412 arm stable, bug #288699
413
414 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
415 amd64/x86 stable, bug #288699
416
417 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
418 ruby-1.8.7_p174-r1.ebuild:
419 Stable on alpha, bug #288699
420
421 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
422 ppc stable #288699
423
424 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
425 Stable for HPPA (bug #288699).
426
427 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
428 Marked ~hppa too.
429
430*ruby-1.8.7_p174-r1 (06 Oct 2009)
431
432 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
433 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
434 eselect-ruby cleanup feature.
435
436*ruby-1.9.1_p243 (09 Sep 2009)
437
438 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
439 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
440 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
441 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
442 -files/ruby19-rubygems-proxy.patch,
443 -files/ruby-1.9.1_p129-parallelmake.patch,
444 -files/ruby19-mkmf-parallel-install.patch:
445 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
446 168939. Cleaning up old patches.
447
448*ruby-1.8.6_p383 (20 Aug 2009)
449
450 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
451 Patchlevel bump.
452
453 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
454 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
455 ruby-1.9.1_p129-r1.ebuild:
456 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
457
458 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
459 Removing vulnerable ebuild, bug 273213.
460
461 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
462 Marking ruby-1.8.6_p369 ppc for bug 273213
463
464 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
465 ruby-1.9.1_p129-r1.ebuild:
466 Prepend our library path instead of overwriting it during src_install.
467 Thanks to the reporter of bug #274824.
468
469*ruby-1.8.7_p174 (18 Jun 2009)
470
471 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
472 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
473 Replacing 187_p173 with _p174 because of a regression. Unifying the
474 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
475 patchsets.
476
477 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
478 Marking ruby-1.8.6_p369 ppc64 for bug 273213
479
480 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
481 arm/ia64/s390/sh/sparc stable wrt #273213
482
483 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
484 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
485 Removing old version, minor cleanup
486
487 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
488 -files/ruby-1.8.6-openssl.patch,
489 -files/ruby-1.8.6-shortname_constants.patch,
490 -files/ruby-1.8.6_p111-r13657.patch,
491 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
492 Removing vulnerable old Ruby version and stale patches, bug 274108.
493
494 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
495 ruby-1.8.6_p369.ebuild:
496 Stable on alpha, bug #273213
497
498 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
499 Stable for HPPA (bug #273213).
500
501 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
502 ruby-1.8.6_p369.ebuild:
503 stable x86, security bug 273213
504
505 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
506 amd64 stable, security bug 273213.
507
508*ruby-1.8.7_p173 (10 Jun 2009)
509*ruby-1.8.6_p369 (10 Jun 2009)
510
511 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
512 +ruby-1.8.7_p173.ebuild:
513 Version bumps for bug #273213.
514
515*ruby-1.9.1_p129-r1 (27 May 2009)
516
517 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
518 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
519 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
520 +files/ruby-1.9.1_p129-parallelmake.patch:
521 Revision bump, add patches 1) to make Ruby behave more similarly between
522 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
523 extensions (undefined symbols in them will cause abort at runtime 3) to
524 remove a concurrency issue when building the dl extension that could
525 result in a broken dl.so.
526
527 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
528 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
529 Don't block rdoc-2 or later (which may enter Portage one day as it's
530 needed by some Rakefiles).
531
532 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
533 ruby-1.9.1_p129.ebuild:
534 Add ~x86-fbsd keyword.
535
536 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
537 keyword ~sparc-fbsd, bug #252315
538
539*ruby-1.9.1_p129 (15 May 2009)
540
541 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
542 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
543 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
544 included in every release.
545
546 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
547 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
548 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
549 ruby-1.8.7_p160.ebuild:
550 Removing vulnerable versions (#268515), fixing license (#233747).
551
552 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
553 Stable for HPPA (bug #268515).
554
555 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
556 Adapting rubygems notice.
557
558 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
559 amd64 stable, bug #268515.
560
561 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
562 arm/ia64/s390/sh/sparc stable wrt #268515
563
564 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
565 ruby-1.8.6_p368.ebuild:
566 stable x86, security bug 268515
567
568 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
569 ruby-1.8.6_p368.ebuild:
570 Stable on alpha, bug #268515
571
572 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
573 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
574
575*ruby-1.8.7_p160 (07 May 2009)
576*ruby-1.8.6_p368 (07 May 2009)
577
578 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
579 +ruby-1.8.7_p160.ebuild:
580 Version bump as per secbug 268515. NB: These are the first ebuilds that
581 no longer use ruby-config.
582
583*ruby-1.9.1-r1 (03 Apr 2009)
584*ruby-1.8.7_p72-r11 (03 Apr 2009)
585*ruby-1.8.6_p287-r13 (03 Apr 2009)
586
587 03 Apr 2009; Alex Legler <a3li@gentoo.org>
588 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
589 +files/ruby18-mkmf-parallel-install.patch,
590 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
591 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
592 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
593 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
594 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
595 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
596 happy.
597
598*ruby-1.9.1 (21 Mar 2009)
599
600 21 Mar 2009; Alex Legler <a3li@gentoo.org>
601 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
602 +ruby-1.9.1.ebuild:
603 Adding Ruby 1.9.1 for preliminary testing
604
605 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
606 ruby-1.8.6_p287-r12.ebuild:
607 Marked ~ppc for bug #252315.
608
609 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
610 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
611 bug 261982.
612
613 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
614 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
615 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
616 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
617 Cleanup
618
619*ruby-1.8.7_p72-r10 (07 Mar 2009)
620
621 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
622 +ruby-1.8.7_p72-r10.ebuild:
623 Add a revision of ruby 1.8.7 using eselect ruby.
624
625 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
626 ~mips keyworded, bug #252315.
627
628 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
629 ruby-1.8.6_p287-r5.ebuild:
630 ppc stable, bug #260006
631
632 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
633 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
634
635 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
636 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
637 Fixing Tk USE flag test, bug 258893.
638
639 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
640 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
641
642 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
643 ruby-1.8.6_p287-r5.ebuild:
644 amd64 stable wrt security bug #260006
645
646 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
647 Stable for HPPA (bug #260006).
648
649 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
650 ruby-1.8.6_p287-r5.ebuild:
651 Stable on alpha, bug #260006
652
653*ruby-1.8.7_p72-r2 (23 Feb 2009)
654*ruby-1.8.6_p287-r12 (23 Feb 2009)
655*ruby-1.8.6_p287-r5 (23 Feb 2009)
656
657 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
658 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
659 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
660 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
661 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
662 now before compilation if Tk useflags don't match) and 230748 (adding
663 --enable-option-checking=no for newer versions of autoconf).
664
665 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
666 arm/ia64/s390/sh/sparc stable wrt #254307
667
668 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
669 ruby-1.8.6_p287-r4.ebuild:
670 Stable on alpha, bug #254307
671
672 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
673 ruby-1.8.6_p287-r11.ebuild:
674 keyword ~x86-fbsd, bug #252315
675
676 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
677 ppc stable #254307
678
679 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
680 amd64/x86 stable, bug #254307
681
682 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
683 stable ppc64, bug 254307
684
685 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
686 Stable for HPPA (bug #254307).
687
688 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
689 ruby-1.8.6_p287-r11.ebuild:
690 Marked ~hppa (bug #252315).
691
692*ruby-1.8.6_p287-r11 (11 Jan 2009)
693
694 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
695 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
696 +ruby-1.8.6_p287-r11.ebuild:
697 Backport conditional definition of missing openssl functions from ruby 1.8.7.
698 Fixes #254307.
699
700 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
701 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
702
703 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
704 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
705
706 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
707 ruby-1.8.6_p287-r10.ebuild:
708 Add ~sparc keyword, bug #252315
709
710*ruby-1.8.6_p287-r10 (23 Dec 2008)
711
712 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
713 +ruby-1.8.6_p287-r10.ebuild:
714 Version bump which switches from ruby-config to eselect-ruby. Dropped most
715 keywords since eselect-ruby does not yet have these keywords.
716
717 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
718 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
719 Revert the ruby-config changes. We can't remove them until we provide an
720 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
721 for breaking things as mentioned in bug #251833.
722
723 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
724 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
725 ruby-1.8.7_p72-r1.ebuild:
726 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
727 Thanks for the people noticing this in bug #251833.
728
729 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
730 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
731 ruby-1.8.7_p72-r1.ebuild:
732 Drop dependency on ruby-config, which will be removed from the tree. We
733 currently only have one major version of ruby in the tree (Ruby 1.8), so there
734 is no need for ruby-config at this moment. For newer versions of Ruby we will
735 use eselect-ruby, which can be found in the ruby overlay at the moment.
736
737 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
738 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
739 Use mirror://ruby in SRC_URI, fixes #237392.
740
741 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
742 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
743 -ruby-1.8.7_p72.ebuild:
744 Remove old versions. Leave one old stable version with cjk support.
745
746*ruby-1.8.6_p287-r3 (29 Nov 2008)
747
748 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
749 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
750 +ruby-1.8.6_p287-r3.ebuild:
751 Fix our expansion limit patch according to debian bug report
752 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
753 make sure people will pick up the fixed version. Thanks to Alex Legler for
754 mentioning the patch.
755
756*ruby-1.8.7_p72-r1 (26 Nov 2008)
757*ruby-1.8.6_p287-r2 (26 Nov 2008)
758
759 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
760 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
761 +ruby-1.8.7_p72-r1.ebuild:
762 Fix problem with shortname constants #247790, already fixed in upstream SVN.
763 Thanks to Alex Legler for providing the patch.
764
765 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
766 -ruby-1.8.6_p287.ebuild:
767 Remove versions that will not become stable
768
769 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
770 ruby-1.8.6_p287-r1.ebuild:
771 ppc stable, bug #225465
772
773 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
774 ruby-1.8.6_p287-r1.ebuild:
775 amd64 stable wrt security bug #225465
776
777 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
778 alpha/ia64/x86 stable wrt #225465
779
780 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
781 ruby-1.8.6_p287-r1.ebuild:
782 Sparc stable --- Security Bug #225465 --- good since late August.
783
784 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
785 Stable on ppc64; bug #225465
786
787 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
788 Stable for HPPA (bug #225465).
789
790*ruby-1.8.6_p287-r1 (29 Aug 2008)
791
792 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
793 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
794 +ruby-1.8.6_p287-r1.ebuild:
795 Fix REXML security issues, bug #236060.
796
797 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
798 Add GLEP 56 USE flag descriptions.
799
800*ruby-1.8.7_p72 (15 Aug 2008)
801
802 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
803 +ruby-1.8.7_p72.ebuild:
804 bump 1.8.7 to latest patch release
805
806*ruby-1.8.6_p287 (11 Aug 2008)
807
808 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
809 Version bump for brown paper bag relelease.
810
811 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
812 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
813 Remove broken version in favor of the just-added 1.8.6_p286
814
815*ruby-1.8.6_p286 (10 Aug 2008)
816
817 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
818 Version bump to latest released version of ruby 1.8.6. This version fixes the
819 security issues reported in #225465 and #234224. The cjk USE flag has been
820 dropped since no compatible patches have been released yet.
821
822 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
823 ruby-1.8.6_p230.ebuild:
824 drop cjk from SRC_URI as well
825
826 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
827 Drop cjk support since the most recent oniguruma patches no longer apply to
828 this version, #230111.
829
830 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
831 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
832 Try to fix the security issues reported in #225465 for ruby 1.8.6.
833 Unfortunately the official p230 has a change which causes segmentation faults
834 for applications like Rails and RSpec, so we are reverting that specific
835 change.
836
837*ruby-1.8.7_p22 (29 Jun 2008)
838
839 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
840 +ruby-1.8.7_p22.ebuild:
841 bump 1.8.7 for security fix
842
843 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
844 nevermind, don't bump this yet
845
846*ruby-1.8.6_p230 (20 Jun 2008)
847
848 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
849 version bump
850
851*ruby-1.8.7 (10 Jun 2008)
852
853 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
854 +ruby-1.8.7.ebuild:
855 bump 1.8.7 to final
856
857*ruby-1.8.7_pre2 (21 Apr 2008)
858
859 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
860 +ruby-1.8.7_pre2.ebuild:
861 Version Bump
862
863*ruby-1.8.7_pre1 (16 Apr 2008)
864
865 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
866 Version bump. Drop cjk until a new version of oniguruma appears.
867
868 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
869 amd64 stable, bug 212264
870
871 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
872 Stable for HPPA (bug #212264).
873
874 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
875 ruby-1.8.6_p114.ebuild:
876 ppc stable, bug #212264
877
878 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
879 alpha/ia64 stable wrt #212264
880
881 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
882 ruby-1.8.6_p114.ebuild:
883 stable x86, security bug 212264
884
885 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
886 Sparc stable, Security Bug #212264, builds and installs, initial tests run
887 as expected.
888
889 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
890 Marking ruby-1.8.6_p114 ppc64 for bug 212264
891
892*ruby-1.8.6_p114 (05 Mar 2008)
893
894 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
895 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
896 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
897 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
898 Version bump for #212264. Remove old ebuilds.
899
900 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
901 alpha/ia64 stable wrt #208916
902
903 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
904 Stable on ppc wrt bug 208916
905
906 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
907 x86 stable, bug #208916
908
909 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
910 ruby-1.8.6_p111-r1.ebuild:
911 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
912
913 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
914 -files/ruby-1.8.6-exit-status.patch,
915 -files/ruby-1.8.6_p110-net-http-p111.patch,
916 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
917 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
918 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
919 Remove old versions
920
921 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
922 Stable on ppc64
923
924 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
925 Stable on amd64; bug 199191
926
927 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
928 alpha/ia64/sparc stable wrt #199191
929
930 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
931 Remove now-obsolete warning about coreutils versions, #203156.
932
933 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
934 Stable for HPPA (bug #199191).
935
936*ruby-1.8.6_p111-r1 (23 Dec 2007)
937
938 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
939 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
940 ssl USE flags. Patch to p113.
941
942 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
943 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
944
945 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
946 x86 stable, security bug #199191
947
948*ruby-1.8.6_p111 (23 Dec 2007)
949
950 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
951 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
952 Version bump with patch for bug #199191
953
954 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
955 Move dependency on (X)Emacs modes to PDEPEND.
956
957 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
958 Add back ~hppa keyword now that XEmacs support files have been keyworded,
959 bug 196413
960
961*ruby-1.8.6_p110-r2 (21 Oct 2007)
962
963 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
964 +ruby-1.8.6_p110-r2.ebuild:
965 Add emacs and xemacs USE flags and use them to pull in the correct editing
966 mode for each. Had to drop several arch keywords as reported on bug 196413.
967
968 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
969 amd64 stable, security bug 194236
970
971 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
972 ruby-1.8.6_p110-r1.ebuild:
973 Stable on ppc64; bug #194236
974
975 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
976 amd64 stable, security bug 194236
977
978 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
979 Stable for HPPA (bug #194236).
980
981 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
982 alpha/ia64/sparc stable wrt security #194236
983
984 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
985 ruby-1.8.6_p110-r1.ebuild:
986 ppc stable, bug #194236
987
988 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
989 ruby-1.8.6_p110-r1.ebuild:
990 stable x86, security bug 194236
991
992 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
993 ruby-1.8.5_p113.ebuild:
994 stable x86, security bug 194236
995
996 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
997 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
998 -ruby-1.8.6_p110.ebuild:
999 Remove old versions
1000
1001*ruby-1.8.6_p110-r1 (30 Sep 2007)
1002*ruby-1.8.5_p113 (30 Sep 2007)
1003
1004 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1005 +files/ruby-1.8.5_p113-net-http-p114.patch,
1006 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1007 +ruby-1.8.6_p110-r1.ebuild:
1008 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1009 using 1.8.6-p110 as base ebuild.
1010
1011 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1012 More fixes from gentoo-dev and graaff
1013
1014 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1015 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1016
1017*ruby-1.8.6_p110 (24 Sep 2007)
1018
1019 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1020 Version bump
1021
1022*ruby-1.8.6_p36-r4 (26 Aug 2007)
1023
1024 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1025 +ruby-1.8.6_p36-r4.ebuild:
1026 Use user LDFLAGS, #181436
1027
1028 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1029 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1030 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1031 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1032
1033 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1034 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1035 -ruby-1.8.6_p36-r2.ebuild:
1036 Remove some older versions that will not be promoted to stable, keeping at
1037 least one version of each release.
1038
1039 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1040 ruby-1.8.6_p36-r3.ebuild:
1041 (QA) RESTRICT clean up.
1042
1043*ruby-1.8.6_p36-r3 (04 Jul 2007)
1044
1045 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1046 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1047 fixed memory leak loading .so bug #182946
1048
1049 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1050 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1051 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1052 ruby-1.8.6_p36-r2.ebuild:
1053 (QA) RESTRICT clean up.
1054
1055 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1056 Re-add stable keyword for alpha as per bug #181110
1057
1058 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1059 Back to ~amd64 wrt bug 181110
1060
1061 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1062 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1063
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1064*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1065
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1066 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1067 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.524

  ViewVC Help
Powered by ViewVC 1.1.20