/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.532
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.532 2012/04/30 11:14:18 graaff Exp $
4
5*ruby-1.9.3_p194 (30 Apr 2012)
6
7 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
8 Version bump.
9
10 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
11 keyword ~amd64-fbsd
12
13*ruby-1.8.7_p358 (20 Apr 2012)
14
15 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
16 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
17 Rails 3.2.
18
19 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
20 Add ~x86-fbsd, #332593
21
22*ruby-1.9.3_p125 (18 Feb 2012)
23
24 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
25 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
26
27 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
28 add ~arm, bug #332593
29
30 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
31 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
32
33 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
34 x86 stable wrt bug #396301
35
36 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
37 Stable for HPPA (bug #396301).
38
39 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
40 Stable for ppc/ppc64; bug #396301
41
42 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
43 Marked ~hppa (bug #332593).
44
45 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
46 Add back ~alpha keyword now that rubygems is keyworded.
47
48 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
49 Stable for AMD64, wrt security bug #396301
50
51*ruby-1.8.7_p357 (28 Dec 2011)
52
53 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
54 Version bump for security bug 396301.
55
56 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
57 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
58
59 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
60 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
61 keyworded, bug 332593.
62
63 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
64 Block older versions of packages that are no longer compatible. Remove
65 ancient blocks on packags long gone from the tree.
66
67 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
68 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
69 Remove old versions.
70
71*ruby-1.9.3_p0 (18 Dec 2011)
72
73 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
74 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
75 suite which need to be diagnosed first.
76
77 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
78 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
79 #332593).
80
81 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
82 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
83 #332593).
84
85 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
86 alpha/ia64/s390/sh/sparc stable wrt #386369
87
88*ruby-1.9.3_rc1 (22 Oct 2011)
89
90 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
91 Version bump.
92
93 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
94 arm stable, bug #386369
95
96 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
97 x86 stable, bug 386369
98
99 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
100 Stable for HPPA (bug #386369).
101
102 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
103 ppc/ppc64 stable wrt #386369
104
105 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
106 Stable on amd64 wrt bug #386369
107
108 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
109 Remove vulnerable version, bug 386369.
110
111*ruby-1.8.7_p352 (30 Aug 2011)
112
113 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
114 +ruby-1.8.7_p352.ebuild:
115 Patchlevel bump for ruby:1.8. Removing old version
116
117*ruby-1.9.2_p290 (30 Aug 2011)
118
119 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
120 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
121 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
122 old patchlevels.
123
124 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
125 ruby-1.8.7_p334-r2.ebuild:
126 ppc/ppc64 stable wrt #378691
127
128*ruby-1.8.7_p334-r2 (22 Jul 2011)
129
130 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
131 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
132 for chasing down upstream and us.
133
134 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
135 Added ~mips, bug 332593
136
137 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
138 ruby-1.8.7_p334-r1.ebuild:
139 ppc64 stable wrt #369141
140
141 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
142 ia64/s390/sh/sparc stable wrt #369141
143
144 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
145 Stable for HPPA (bug #369141).
146
147 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
148 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
149
150 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
151 arm/x86 stable, bug #369141
152
153 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
154 Stable on amd64 wrt bug #369141
155
156 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
157 ruby-1.8.7_p334-r1.ebuild:
158 Stable on alpha, bug #369141
159
160*ruby-1.8.7_p334-r1 (31 May 2011)
161
162 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
163 Revision bump for security bug 369141 (CVE-2011-0188)
164
165*ruby-1.9.2-r1 (16 May 2011)
166
167 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
168 Don't remove racc files since all other ruby targets ship these files
169 themselves as well. Closes bug 363419.
170
171 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
172 ruby-1.8.7_p334.ebuild:
173 Remove old version. Remove obsolete and unused old-style virtual/ruby.
174
175 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
176 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
177
178 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
179 Add append-flags -mieee on sh, bug #357559
180
181 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
182 alpha/arm/ia64/s390/sh stable wrt #355439
183
184 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
185 Marked ~ppc64 wrt #332593
186
187 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
188 ruby-1.8.7_p334.ebuild:
189 x86 stable wrt security bug #355439
190
191 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
192 ruby-1.8.7_p334.ebuild:
193 ppc/ppc64 stable wrt #355439
194
195 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
196 Stable on amd64 wrt bug #355439
197
198 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
199 Stable for HPPA (bug #355439).
200
201*ruby-1.8.7_p334 (19 Feb 2011)
202
203 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
204 Version bump 1.8.7 series, security bug 355439
205
206 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
207 ruby-1.9.2.ebuild:
208 Remove PROVIDE for old-style virtual/ruby per bug 265054.
209
210 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
211 Remove masked ruby 1.8.6 per bug 332597.
212
213 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
214 -ruby-1.9.2_rc2.ebuild:
215 Removing old and vulnerable ebuilds
216
217 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
218 Marking ruby-1.8.7_p302 ppc64 for bug 332957
219
220 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
221 alpha/ia64/s390/sh/sparc stable wrt #332957
222
223*ruby-1.9.2 (24 Aug 2010)
224
225 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
226 metadata.xml:
227 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
228 and x86-fbsd due to a new dependency on rdoc.
229
230 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
231 arm stable, bug #332957
232
233 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
234 ruby-1.8.7_p302.ebuild:
235 x86 stable wrt security bug #332957
236
237 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
238 Stable on amd64 wrt bug #332957
239
240 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
241 Stable for PPC (bug #332957).
242
243 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
244 Stable for HPPA (bug #332957).
245
246*ruby-1.8.7_p302 (21 Aug 2010)
247
248 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
249 +ruby-1.8.7_p302.ebuild:
250 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
251 installation path.
252
253*ruby-1.8.6_p399 (19 Aug 2010)
254
255 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
256 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
257 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
258 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
259 installation path (reported by the x86 team in bug 332597)
260
261*ruby-1.9.2_rc2-r1 (18 Aug 2010)
262
263 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
264 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
265 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
266 the rubygems loading code. Add USE flag for psych.
267
268 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
269 ruby-1.9.2_rc2.ebuild:
270 Remove two keepdir that will try to keep an empty path, closes bug
271 #333163.
272
273 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
274 Marked ~ppc (bug #332593).
275
276 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
277 ruby-1.9.2_rc2.ebuild:
278 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
279
280 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
281 ruby-1.8.7_p299.ebuild:
282 Bump eselect-ruby dependency
283
284 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 -ruby-1.9.1_p429.ebuild:
286 Remove ebuild that is not target for unmask anyway.
287
288 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
289 ruby-1.9.2_rc2.ebuild:
290 Try 2 to fix the berkdb 5 issue on 1.9.
291
292 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
293 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
294 ruby-1.9.2_rc2.ebuild:
295 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
296 support for adding new patchsets without bumping the revision for all the
297 old ebuilds as well.
298
299*ruby-1.9.2_rc2 (14 Jul 2010)
300
301 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
302 +ruby-1.9.2_rc2.ebuild:
303 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
304 might cause _further_ build failures as it changed slightly behaviour.
305 You're going to need to rebuild rubygems and then all the packages
306 previously installed after upgrading to this.
307
308 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
309 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
310 -ruby-1.9.1_p376.ebuild:
311 Cleanup old versions.
312
313*ruby-1.9.1_p429 (04 Jul 2010)
314
315 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
316 +ruby-1.9.1_p429.ebuild:
317 Version bump to new 1.9.1 release.
318
319*ruby-1.8.7_p299 (23 Jun 2010)
320
321 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
322 +ruby-1.8.7_p299.ebuild:
323 Version bump.
324
325 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
326 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
327 remove useless comments
328
329 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
330 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
331 ruby-1.9.1_p376.ebuild:
332 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
333 dev.gentoo.org now.
334
335 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
336 ruby-1.9.1_p376.ebuild:
337 Use the correct RUBYLIB.
338
339*ruby-1.8.7_p249-r2 (18 May 2010)
340*ruby-1.8.6_p388-r1 (18 May 2010)
341
342 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
343 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
344 ruby-1.9.1_p376.ebuild, metadata.xml:
345 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
346 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
347 add USE flags for ncurses, readline and libedit, and properly depend on
348 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
349 Emacs versions support ruby-mode themselves and it should be even more
350 updated.
351
352*ruby-1.8.7_p249-r1 (06 May 2010)
353
354 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
355 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
356 309789 by Sune Kloppenborg Jeppesen.
357
358 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
359 ruby-1.8.7_p249.ebuild:
360 Use $PVR instead of $PV in patchset names
361
362 06 May 2010; Alex Legler <a3li@gentoo.org>
363 -files/ruby-1.8.6-memory-leak.diff,
364 -files/ruby18-mkmf-parallel-install.patch,
365 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
366 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
367 Remove old version. Cleanup in files/
368
369*ruby-1.9.1_p376 (01 May 2010)
370
371 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
372 Version bump. Fixes security bugs 296052 and 300468. No longer installs
373 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
374 instead.
375
376 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
377 -ruby-1.8.7_p174-r1.ebuild:
378 Remove vulnerable ebuilds, 300468
379
380 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
381 ruby-1.8.7_p249.ebuild:
382 amd64 stable, security bug 300468
383
384 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
385 ruby-1.8.7_p249.ebuild:
386 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
387
388 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
389 Stable for HPPA (bug #300468).
390
391 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
392 Stable for HPPA (bug #300468).
393
394 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
395 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
396
397 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
398 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
399
400 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
401 ruby-1.8.6_p388.ebuild:
402 stable x86, security bug 300468
403
404 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
405 ruby-1.8.7_p249.ebuild:
406 stable x86, security bug 300468
407
408*ruby-1.8.6_p388 (10 Jan 2010)
409
410 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
411 +ruby-1.8.6_p388.ebuild:
412 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
413 version. The new ebuild also has the fix for bug 168939.
414
415*ruby-1.8.7_p249 (10 Jan 2010)
416
417 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
418 +ruby-1.8.7_p249.ebuild:
419 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
420 version
421
422 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
423 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
424
425*ruby-1.8.7_p248 (25 Dec 2009)
426
427 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
428 Version bump
429
430 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
431 Remove old version.
432
433 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
434 Remove old version.
435
436 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
437 ia64/s390/sh stable wrt #288699
438
439 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
440 stable sparc, bug 288699
441
442 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
443 arm stable, bug #288699
444
445 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
446 amd64/x86 stable, bug #288699
447
448 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
449 ruby-1.8.7_p174-r1.ebuild:
450 Stable on alpha, bug #288699
451
452 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
453 ppc stable #288699
454
455 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
456 Stable for HPPA (bug #288699).
457
458 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
459 Marked ~hppa too.
460
461*ruby-1.8.7_p174-r1 (06 Oct 2009)
462
463 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
464 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
465 eselect-ruby cleanup feature.
466
467*ruby-1.9.1_p243 (09 Sep 2009)
468
469 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
470 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
471 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
472 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
473 -files/ruby19-rubygems-proxy.patch,
474 -files/ruby-1.9.1_p129-parallelmake.patch,
475 -files/ruby19-mkmf-parallel-install.patch:
476 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
477 168939. Cleaning up old patches.
478
479*ruby-1.8.6_p383 (20 Aug 2009)
480
481 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
482 Patchlevel bump.
483
484 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
485 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
486 ruby-1.9.1_p129-r1.ebuild:
487 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
488
489 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
490 Removing vulnerable ebuild, bug 273213.
491
492 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
493 Marking ruby-1.8.6_p369 ppc for bug 273213
494
495 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
496 ruby-1.9.1_p129-r1.ebuild:
497 Prepend our library path instead of overwriting it during src_install.
498 Thanks to the reporter of bug #274824.
499
500*ruby-1.8.7_p174 (18 Jun 2009)
501
502 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
503 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
504 Replacing 187_p173 with _p174 because of a regression. Unifying the
505 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
506 patchsets.
507
508 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
509 Marking ruby-1.8.6_p369 ppc64 for bug 273213
510
511 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
512 arm/ia64/s390/sh/sparc stable wrt #273213
513
514 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
515 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
516 Removing old version, minor cleanup
517
518 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
519 -files/ruby-1.8.6-openssl.patch,
520 -files/ruby-1.8.6-shortname_constants.patch,
521 -files/ruby-1.8.6_p111-r13657.patch,
522 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
523 Removing vulnerable old Ruby version and stale patches, bug 274108.
524
525 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
526 ruby-1.8.6_p369.ebuild:
527 Stable on alpha, bug #273213
528
529 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
530 Stable for HPPA (bug #273213).
531
532 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
533 ruby-1.8.6_p369.ebuild:
534 stable x86, security bug 273213
535
536 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
537 amd64 stable, security bug 273213.
538
539*ruby-1.8.7_p173 (10 Jun 2009)
540*ruby-1.8.6_p369 (10 Jun 2009)
541
542 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
543 +ruby-1.8.7_p173.ebuild:
544 Version bumps for bug #273213.
545
546*ruby-1.9.1_p129-r1 (27 May 2009)
547
548 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
549 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
550 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
551 +files/ruby-1.9.1_p129-parallelmake.patch:
552 Revision bump, add patches 1) to make Ruby behave more similarly between
553 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
554 extensions (undefined symbols in them will cause abort at runtime 3) to
555 remove a concurrency issue when building the dl extension that could
556 result in a broken dl.so.
557
558 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
559 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
560 Don't block rdoc-2 or later (which may enter Portage one day as it's
561 needed by some Rakefiles).
562
563 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
564 ruby-1.9.1_p129.ebuild:
565 Add ~x86-fbsd keyword.
566
567 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
568 keyword ~sparc-fbsd, bug #252315
569
570*ruby-1.9.1_p129 (15 May 2009)
571
572 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
573 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
574 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
575 included in every release.
576
577 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
578 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
579 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
580 ruby-1.8.7_p160.ebuild:
581 Removing vulnerable versions (#268515), fixing license (#233747).
582
583 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
584 Stable for HPPA (bug #268515).
585
586 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
587 Adapting rubygems notice.
588
589 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
590 amd64 stable, bug #268515.
591
592 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
593 arm/ia64/s390/sh/sparc stable wrt #268515
594
595 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
596 ruby-1.8.6_p368.ebuild:
597 stable x86, security bug 268515
598
599 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
600 ruby-1.8.6_p368.ebuild:
601 Stable on alpha, bug #268515
602
603 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
604 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
605
606*ruby-1.8.7_p160 (07 May 2009)
607*ruby-1.8.6_p368 (07 May 2009)
608
609 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
610 +ruby-1.8.7_p160.ebuild:
611 Version bump as per secbug 268515. NB: These are the first ebuilds that
612 no longer use ruby-config.
613
614*ruby-1.9.1-r1 (03 Apr 2009)
615*ruby-1.8.7_p72-r11 (03 Apr 2009)
616*ruby-1.8.6_p287-r13 (03 Apr 2009)
617
618 03 Apr 2009; Alex Legler <a3li@gentoo.org>
619 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
620 +files/ruby18-mkmf-parallel-install.patch,
621 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
622 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
623 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
624 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
625 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
626 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
627 happy.
628
629*ruby-1.9.1 (21 Mar 2009)
630
631 21 Mar 2009; Alex Legler <a3li@gentoo.org>
632 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
633 +ruby-1.9.1.ebuild:
634 Adding Ruby 1.9.1 for preliminary testing
635
636 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
637 ruby-1.8.6_p287-r12.ebuild:
638 Marked ~ppc for bug #252315.
639
640 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
641 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
642 bug 261982.
643
644 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
645 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
646 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
647 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
648 Cleanup
649
650*ruby-1.8.7_p72-r10 (07 Mar 2009)
651
652 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
653 +ruby-1.8.7_p72-r10.ebuild:
654 Add a revision of ruby 1.8.7 using eselect ruby.
655
656 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
657 ~mips keyworded, bug #252315.
658
659 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
660 ruby-1.8.6_p287-r5.ebuild:
661 ppc stable, bug #260006
662
663 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
664 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
665
666 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
667 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
668 Fixing Tk USE flag test, bug 258893.
669
670 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
671 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
672
673 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
674 ruby-1.8.6_p287-r5.ebuild:
675 amd64 stable wrt security bug #260006
676
677 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
678 Stable for HPPA (bug #260006).
679
680 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
681 ruby-1.8.6_p287-r5.ebuild:
682 Stable on alpha, bug #260006
683
684*ruby-1.8.7_p72-r2 (23 Feb 2009)
685*ruby-1.8.6_p287-r12 (23 Feb 2009)
686*ruby-1.8.6_p287-r5 (23 Feb 2009)
687
688 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
689 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
690 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
691 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
692 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
693 now before compilation if Tk useflags don't match) and 230748 (adding
694 --enable-option-checking=no for newer versions of autoconf).
695
696 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
697 arm/ia64/s390/sh/sparc stable wrt #254307
698
699 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
700 ruby-1.8.6_p287-r4.ebuild:
701 Stable on alpha, bug #254307
702
703 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
704 ruby-1.8.6_p287-r11.ebuild:
705 keyword ~x86-fbsd, bug #252315
706
707 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
708 ppc stable #254307
709
710 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
711 amd64/x86 stable, bug #254307
712
713 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
714 stable ppc64, bug 254307
715
716 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
717 Stable for HPPA (bug #254307).
718
719 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
720 ruby-1.8.6_p287-r11.ebuild:
721 Marked ~hppa (bug #252315).
722
723*ruby-1.8.6_p287-r11 (11 Jan 2009)
724
725 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
726 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
727 +ruby-1.8.6_p287-r11.ebuild:
728 Backport conditional definition of missing openssl functions from ruby 1.8.7.
729 Fixes #254307.
730
731 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
732 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
733
734 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
735 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
736
737 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
738 ruby-1.8.6_p287-r10.ebuild:
739 Add ~sparc keyword, bug #252315
740
741*ruby-1.8.6_p287-r10 (23 Dec 2008)
742
743 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
744 +ruby-1.8.6_p287-r10.ebuild:
745 Version bump which switches from ruby-config to eselect-ruby. Dropped most
746 keywords since eselect-ruby does not yet have these keywords.
747
748 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
749 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
750 Revert the ruby-config changes. We can't remove them until we provide an
751 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
752 for breaking things as mentioned in bug #251833.
753
754 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
755 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
756 ruby-1.8.7_p72-r1.ebuild:
757 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
758 Thanks for the people noticing this in bug #251833.
759
760 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
761 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
762 ruby-1.8.7_p72-r1.ebuild:
763 Drop dependency on ruby-config, which will be removed from the tree. We
764 currently only have one major version of ruby in the tree (Ruby 1.8), so there
765 is no need for ruby-config at this moment. For newer versions of Ruby we will
766 use eselect-ruby, which can be found in the ruby overlay at the moment.
767
768 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
769 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
770 Use mirror://ruby in SRC_URI, fixes #237392.
771
772 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
773 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
774 -ruby-1.8.7_p72.ebuild:
775 Remove old versions. Leave one old stable version with cjk support.
776
777*ruby-1.8.6_p287-r3 (29 Nov 2008)
778
779 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
780 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
781 +ruby-1.8.6_p287-r3.ebuild:
782 Fix our expansion limit patch according to debian bug report
783 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
784 make sure people will pick up the fixed version. Thanks to Alex Legler for
785 mentioning the patch.
786
787*ruby-1.8.7_p72-r1 (26 Nov 2008)
788*ruby-1.8.6_p287-r2 (26 Nov 2008)
789
790 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
791 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
792 +ruby-1.8.7_p72-r1.ebuild:
793 Fix problem with shortname constants #247790, already fixed in upstream SVN.
794 Thanks to Alex Legler for providing the patch.
795
796 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
797 -ruby-1.8.6_p287.ebuild:
798 Remove versions that will not become stable
799
800 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
801 ruby-1.8.6_p287-r1.ebuild:
802 ppc stable, bug #225465
803
804 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
805 ruby-1.8.6_p287-r1.ebuild:
806 amd64 stable wrt security bug #225465
807
808 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
809 alpha/ia64/x86 stable wrt #225465
810
811 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
812 ruby-1.8.6_p287-r1.ebuild:
813 Sparc stable --- Security Bug #225465 --- good since late August.
814
815 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
816 Stable on ppc64; bug #225465
817
818 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
819 Stable for HPPA (bug #225465).
820
821*ruby-1.8.6_p287-r1 (29 Aug 2008)
822
823 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
824 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
825 +ruby-1.8.6_p287-r1.ebuild:
826 Fix REXML security issues, bug #236060.
827
828 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
829 Add GLEP 56 USE flag descriptions.
830
831*ruby-1.8.7_p72 (15 Aug 2008)
832
833 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
834 +ruby-1.8.7_p72.ebuild:
835 bump 1.8.7 to latest patch release
836
837*ruby-1.8.6_p287 (11 Aug 2008)
838
839 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
840 Version bump for brown paper bag relelease.
841
842 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
843 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
844 Remove broken version in favor of the just-added 1.8.6_p286
845
846*ruby-1.8.6_p286 (10 Aug 2008)
847
848 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
849 Version bump to latest released version of ruby 1.8.6. This version fixes the
850 security issues reported in #225465 and #234224. The cjk USE flag has been
851 dropped since no compatible patches have been released yet.
852
853 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
854 ruby-1.8.6_p230.ebuild:
855 drop cjk from SRC_URI as well
856
857 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
858 Drop cjk support since the most recent oniguruma patches no longer apply to
859 this version, #230111.
860
861 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
862 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
863 Try to fix the security issues reported in #225465 for ruby 1.8.6.
864 Unfortunately the official p230 has a change which causes segmentation faults
865 for applications like Rails and RSpec, so we are reverting that specific
866 change.
867
868*ruby-1.8.7_p22 (29 Jun 2008)
869
870 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
871 +ruby-1.8.7_p22.ebuild:
872 bump 1.8.7 for security fix
873
874 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
875 nevermind, don't bump this yet
876
877*ruby-1.8.6_p230 (20 Jun 2008)
878
879 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
880 version bump
881
882*ruby-1.8.7 (10 Jun 2008)
883
884 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
885 +ruby-1.8.7.ebuild:
886 bump 1.8.7 to final
887
888*ruby-1.8.7_pre2 (21 Apr 2008)
889
890 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
891 +ruby-1.8.7_pre2.ebuild:
892 Version Bump
893
894*ruby-1.8.7_pre1 (16 Apr 2008)
895
896 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
897 Version bump. Drop cjk until a new version of oniguruma appears.
898
899 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
900 amd64 stable, bug 212264
901
902 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
903 Stable for HPPA (bug #212264).
904
905 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
906 ruby-1.8.6_p114.ebuild:
907 ppc stable, bug #212264
908
909 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
910 alpha/ia64 stable wrt #212264
911
912 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
913 ruby-1.8.6_p114.ebuild:
914 stable x86, security bug 212264
915
916 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
917 Sparc stable, Security Bug #212264, builds and installs, initial tests run
918 as expected.
919
920 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
921 Marking ruby-1.8.6_p114 ppc64 for bug 212264
922
923*ruby-1.8.6_p114 (05 Mar 2008)
924
925 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
926 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
927 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
928 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
929 Version bump for #212264. Remove old ebuilds.
930
931 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
932 alpha/ia64 stable wrt #208916
933
934 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
935 Stable on ppc wrt bug 208916
936
937 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
938 x86 stable, bug #208916
939
940 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
941 ruby-1.8.6_p111-r1.ebuild:
942 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
943
944 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
945 -files/ruby-1.8.6-exit-status.patch,
946 -files/ruby-1.8.6_p110-net-http-p111.patch,
947 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
948 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
949 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
950 Remove old versions
951
952 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
953 Stable on ppc64
954
955 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
956 Stable on amd64; bug 199191
957
958 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
959 alpha/ia64/sparc stable wrt #199191
960
961 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
962 Remove now-obsolete warning about coreutils versions, #203156.
963
964 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
965 Stable for HPPA (bug #199191).
966
967*ruby-1.8.6_p111-r1 (23 Dec 2007)
968
969 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
970 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
971 ssl USE flags. Patch to p113.
972
973 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
974 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
975
976 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
977 x86 stable, security bug #199191
978
979*ruby-1.8.6_p111 (23 Dec 2007)
980
981 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
982 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
983 Version bump with patch for bug #199191
984
985 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
986 Move dependency on (X)Emacs modes to PDEPEND.
987
988 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
989 Add back ~hppa keyword now that XEmacs support files have been keyworded,
990 bug 196413
991
992*ruby-1.8.6_p110-r2 (21 Oct 2007)
993
994 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
995 +ruby-1.8.6_p110-r2.ebuild:
996 Add emacs and xemacs USE flags and use them to pull in the correct editing
997 mode for each. Had to drop several arch keywords as reported on bug 196413.
998
999 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1000 amd64 stable, security bug 194236
1001
1002 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1003 ruby-1.8.6_p110-r1.ebuild:
1004 Stable on ppc64; bug #194236
1005
1006 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1007 amd64 stable, security bug 194236
1008
1009 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1010 Stable for HPPA (bug #194236).
1011
1012 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1013 alpha/ia64/sparc stable wrt security #194236
1014
1015 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1016 ruby-1.8.6_p110-r1.ebuild:
1017 ppc stable, bug #194236
1018
1019 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1020 ruby-1.8.6_p110-r1.ebuild:
1021 stable x86, security bug 194236
1022
1023 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1024 ruby-1.8.5_p113.ebuild:
1025 stable x86, security bug 194236
1026
1027 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1028 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1029 -ruby-1.8.6_p110.ebuild:
1030 Remove old versions
1031
1032*ruby-1.8.6_p110-r1 (30 Sep 2007)
1033*ruby-1.8.5_p113 (30 Sep 2007)
1034
1035 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1036 +files/ruby-1.8.5_p113-net-http-p114.patch,
1037 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1038 +ruby-1.8.6_p110-r1.ebuild:
1039 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1040 using 1.8.6-p110 as base ebuild.
1041
1042 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1043 More fixes from gentoo-dev and graaff
1044
1045 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1046 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1047
1048*ruby-1.8.6_p110 (24 Sep 2007)
1049
1050 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1051 Version bump
1052
1053*ruby-1.8.6_p36-r4 (26 Aug 2007)
1054
1055 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1056 +ruby-1.8.6_p36-r4.ebuild:
1057 Use user LDFLAGS, #181436
1058
1059 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1060 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1061 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1062 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1063
1064 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1065 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1066 -ruby-1.8.6_p36-r2.ebuild:
1067 Remove some older versions that will not be promoted to stable, keeping at
1068 least one version of each release.
1069
1070 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1071 ruby-1.8.6_p36-r3.ebuild:
1072 (QA) RESTRICT clean up.
1073
1074*ruby-1.8.6_p36-r3 (04 Jul 2007)
1075
1076 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1077 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1078 fixed memory leak loading .so bug #182946
1079
1080 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1081 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1082 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1083 ruby-1.8.6_p36-r2.ebuild:
1084 (QA) RESTRICT clean up.
1085
1086 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1087 Re-add stable keyword for alpha as per bug #181110
1088
1089 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1090 Back to ~amd64 wrt bug 181110
1091
1092 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1093 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1094
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1095*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1096
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1097 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1098 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.532

  ViewVC Help
Powered by ViewVC 1.1.20