/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.293 Revision 1.530
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.293 2007/08/17 19:37:18 graaff Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.530 2012/04/20 10:42:50 graaff Exp $
4
5*ruby-1.8.7_p358 (20 Apr 2012)
6
7 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
8 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
9 Rails 3.2.
10
11 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
12 Add ~x86-fbsd, #332593
13
14*ruby-1.9.3_p125 (18 Feb 2012)
15
16 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
17 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
18
19 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
20 add ~arm, bug #332593
21
22 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
23 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
24
25 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
26 x86 stable wrt bug #396301
27
28 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
29 Stable for HPPA (bug #396301).
30
31 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
32 Stable for ppc/ppc64; bug #396301
33
34 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
35 Marked ~hppa (bug #332593).
36
37 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
38 Add back ~alpha keyword now that rubygems is keyworded.
39
40 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
41 Stable for AMD64, wrt security bug #396301
42
43*ruby-1.8.7_p357 (28 Dec 2011)
44
45 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
46 Version bump for security bug 396301.
47
48 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
49 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
50
51 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
52 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
53 keyworded, bug 332593.
54
55 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
56 Block older versions of packages that are no longer compatible. Remove
57 ancient blocks on packags long gone from the tree.
58
59 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
60 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
61 Remove old versions.
62
63*ruby-1.9.3_p0 (18 Dec 2011)
64
65 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
66 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
67 suite which need to be diagnosed first.
68
69 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
70 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
71 #332593).
72
73 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
74 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
75 #332593).
76
77 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
78 alpha/ia64/s390/sh/sparc stable wrt #386369
79
80*ruby-1.9.3_rc1 (22 Oct 2011)
81
82 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
83 Version bump.
84
85 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
86 arm stable, bug #386369
87
88 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
89 x86 stable, bug 386369
90
91 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
92 Stable for HPPA (bug #386369).
93
94 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
95 ppc/ppc64 stable wrt #386369
96
97 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
98 Stable on amd64 wrt bug #386369
99
100 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
101 Remove vulnerable version, bug 386369.
102
103*ruby-1.8.7_p352 (30 Aug 2011)
104
105 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
106 +ruby-1.8.7_p352.ebuild:
107 Patchlevel bump for ruby:1.8. Removing old version
108
109*ruby-1.9.2_p290 (30 Aug 2011)
110
111 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
112 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
113 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
114 old patchlevels.
115
116 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
117 ruby-1.8.7_p334-r2.ebuild:
118 ppc/ppc64 stable wrt #378691
119
120*ruby-1.8.7_p334-r2 (22 Jul 2011)
121
122 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
123 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
124 for chasing down upstream and us.
125
126 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
127 Added ~mips, bug 332593
128
129 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
130 ruby-1.8.7_p334-r1.ebuild:
131 ppc64 stable wrt #369141
132
133 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
134 ia64/s390/sh/sparc stable wrt #369141
135
136 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
137 Stable for HPPA (bug #369141).
138
139 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
140 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
141
142 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
143 arm/x86 stable, bug #369141
144
145 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
146 Stable on amd64 wrt bug #369141
147
148 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
149 ruby-1.8.7_p334-r1.ebuild:
150 Stable on alpha, bug #369141
151
152*ruby-1.8.7_p334-r1 (31 May 2011)
153
154 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
155 Revision bump for security bug 369141 (CVE-2011-0188)
156
157*ruby-1.9.2-r1 (16 May 2011)
158
159 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
160 Don't remove racc files since all other ruby targets ship these files
161 themselves as well. Closes bug 363419.
162
163 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
164 ruby-1.8.7_p334.ebuild:
165 Remove old version. Remove obsolete and unused old-style virtual/ruby.
166
167 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
168 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
169
170 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
171 Add append-flags -mieee on sh, bug #357559
172
173 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
174 alpha/arm/ia64/s390/sh stable wrt #355439
175
176 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
177 Marked ~ppc64 wrt #332593
178
179 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
180 ruby-1.8.7_p334.ebuild:
181 x86 stable wrt security bug #355439
182
183 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
184 ruby-1.8.7_p334.ebuild:
185 ppc/ppc64 stable wrt #355439
186
187 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
188 Stable on amd64 wrt bug #355439
189
190 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
191 Stable for HPPA (bug #355439).
192
193*ruby-1.8.7_p334 (19 Feb 2011)
194
195 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
196 Version bump 1.8.7 series, security bug 355439
197
198 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
199 ruby-1.9.2.ebuild:
200 Remove PROVIDE for old-style virtual/ruby per bug 265054.
201
202 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
203 Remove masked ruby 1.8.6 per bug 332597.
204
205 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
206 -ruby-1.9.2_rc2.ebuild:
207 Removing old and vulnerable ebuilds
208
209 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
210 Marking ruby-1.8.7_p302 ppc64 for bug 332957
211
212 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
213 alpha/ia64/s390/sh/sparc stable wrt #332957
214
215*ruby-1.9.2 (24 Aug 2010)
216
217 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
218 metadata.xml:
219 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
220 and x86-fbsd due to a new dependency on rdoc.
221
222 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
223 arm stable, bug #332957
224
225 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
226 ruby-1.8.7_p302.ebuild:
227 x86 stable wrt security bug #332957
228
229 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
230 Stable on amd64 wrt bug #332957
231
232 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
233 Stable for PPC (bug #332957).
234
235 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
236 Stable for HPPA (bug #332957).
237
238*ruby-1.8.7_p302 (21 Aug 2010)
239
240 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
241 +ruby-1.8.7_p302.ebuild:
242 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
243 installation path.
244
245*ruby-1.8.6_p399 (19 Aug 2010)
246
247 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
248 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
249 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
250 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
251 installation path (reported by the x86 team in bug 332597)
252
253*ruby-1.9.2_rc2-r1 (18 Aug 2010)
254
255 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
256 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
257 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
258 the rubygems loading code. Add USE flag for psych.
259
260 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
261 ruby-1.9.2_rc2.ebuild:
262 Remove two keepdir that will try to keep an empty path, closes bug
263 #333163.
264
265 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
266 Marked ~ppc (bug #332593).
267
268 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
269 ruby-1.9.2_rc2.ebuild:
270 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
271
272 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
273 ruby-1.8.7_p299.ebuild:
274 Bump eselect-ruby dependency
275
276 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
277 -ruby-1.9.1_p429.ebuild:
278 Remove ebuild that is not target for unmask anyway.
279
280 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
281 ruby-1.9.2_rc2.ebuild:
282 Try 2 to fix the berkdb 5 issue on 1.9.
283
284 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
286 ruby-1.9.2_rc2.ebuild:
287 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
288 support for adding new patchsets without bumping the revision for all the
289 old ebuilds as well.
290
291*ruby-1.9.2_rc2 (14 Jul 2010)
292
293 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
294 +ruby-1.9.2_rc2.ebuild:
295 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
296 might cause _further_ build failures as it changed slightly behaviour.
297 You're going to need to rebuild rubygems and then all the packages
298 previously installed after upgrading to this.
299
300 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
301 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
302 -ruby-1.9.1_p376.ebuild:
303 Cleanup old versions.
304
305*ruby-1.9.1_p429 (04 Jul 2010)
306
307 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
308 +ruby-1.9.1_p429.ebuild:
309 Version bump to new 1.9.1 release.
310
311*ruby-1.8.7_p299 (23 Jun 2010)
312
313 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
314 +ruby-1.8.7_p299.ebuild:
315 Version bump.
316
317 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
318 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
319 remove useless comments
320
321 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
322 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
323 ruby-1.9.1_p376.ebuild:
324 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
325 dev.gentoo.org now.
326
327 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
328 ruby-1.9.1_p376.ebuild:
329 Use the correct RUBYLIB.
330
331*ruby-1.8.7_p249-r2 (18 May 2010)
332*ruby-1.8.6_p388-r1 (18 May 2010)
333
334 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
335 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
336 ruby-1.9.1_p376.ebuild, metadata.xml:
337 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
338 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
339 add USE flags for ncurses, readline and libedit, and properly depend on
340 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
341 Emacs versions support ruby-mode themselves and it should be even more
342 updated.
343
344*ruby-1.8.7_p249-r1 (06 May 2010)
345
346 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
347 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
348 309789 by Sune Kloppenborg Jeppesen.
349
350 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
351 ruby-1.8.7_p249.ebuild:
352 Use $PVR instead of $PV in patchset names
353
354 06 May 2010; Alex Legler <a3li@gentoo.org>
355 -files/ruby-1.8.6-memory-leak.diff,
356 -files/ruby18-mkmf-parallel-install.patch,
357 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
358 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
359 Remove old version. Cleanup in files/
360
361*ruby-1.9.1_p376 (01 May 2010)
362
363 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
364 Version bump. Fixes security bugs 296052 and 300468. No longer installs
365 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
366 instead.
367
368 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
369 -ruby-1.8.7_p174-r1.ebuild:
370 Remove vulnerable ebuilds, 300468
371
372 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
373 ruby-1.8.7_p249.ebuild:
374 amd64 stable, security bug 300468
375
376 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
377 ruby-1.8.7_p249.ebuild:
378 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
379
380 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
381 Stable for HPPA (bug #300468).
382
383 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
384 Stable for HPPA (bug #300468).
385
386 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
387 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
388
389 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
390 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
391
392 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
393 ruby-1.8.6_p388.ebuild:
394 stable x86, security bug 300468
395
396 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
397 ruby-1.8.7_p249.ebuild:
398 stable x86, security bug 300468
399
400*ruby-1.8.6_p388 (10 Jan 2010)
401
402 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
403 +ruby-1.8.6_p388.ebuild:
404 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
405 version. The new ebuild also has the fix for bug 168939.
406
407*ruby-1.8.7_p249 (10 Jan 2010)
408
409 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
410 +ruby-1.8.7_p249.ebuild:
411 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
412 version
413
414 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
415 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
416
417*ruby-1.8.7_p248 (25 Dec 2009)
418
419 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
420 Version bump
421
422 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
423 Remove old version.
424
425 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
426 Remove old version.
427
428 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
429 ia64/s390/sh stable wrt #288699
430
431 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
432 stable sparc, bug 288699
433
434 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
435 arm stable, bug #288699
436
437 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
438 amd64/x86 stable, bug #288699
439
440 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
441 ruby-1.8.7_p174-r1.ebuild:
442 Stable on alpha, bug #288699
443
444 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
445 ppc stable #288699
446
447 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
448 Stable for HPPA (bug #288699).
449
450 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
451 Marked ~hppa too.
452
453*ruby-1.8.7_p174-r1 (06 Oct 2009)
454
455 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
456 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
457 eselect-ruby cleanup feature.
458
459*ruby-1.9.1_p243 (09 Sep 2009)
460
461 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
462 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
463 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
464 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
465 -files/ruby19-rubygems-proxy.patch,
466 -files/ruby-1.9.1_p129-parallelmake.patch,
467 -files/ruby19-mkmf-parallel-install.patch:
468 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
469 168939. Cleaning up old patches.
470
471*ruby-1.8.6_p383 (20 Aug 2009)
472
473 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
474 Patchlevel bump.
475
476 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
477 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
478 ruby-1.9.1_p129-r1.ebuild:
479 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
480
481 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
482 Removing vulnerable ebuild, bug 273213.
483
484 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
485 Marking ruby-1.8.6_p369 ppc for bug 273213
486
487 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
488 ruby-1.9.1_p129-r1.ebuild:
489 Prepend our library path instead of overwriting it during src_install.
490 Thanks to the reporter of bug #274824.
491
492*ruby-1.8.7_p174 (18 Jun 2009)
493
494 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
495 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
496 Replacing 187_p173 with _p174 because of a regression. Unifying the
497 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
498 patchsets.
499
500 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
501 Marking ruby-1.8.6_p369 ppc64 for bug 273213
502
503 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
504 arm/ia64/s390/sh/sparc stable wrt #273213
505
506 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
507 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
508 Removing old version, minor cleanup
509
510 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
511 -files/ruby-1.8.6-openssl.patch,
512 -files/ruby-1.8.6-shortname_constants.patch,
513 -files/ruby-1.8.6_p111-r13657.patch,
514 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
515 Removing vulnerable old Ruby version and stale patches, bug 274108.
516
517 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
518 ruby-1.8.6_p369.ebuild:
519 Stable on alpha, bug #273213
520
521 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
522 Stable for HPPA (bug #273213).
523
524 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
525 ruby-1.8.6_p369.ebuild:
526 stable x86, security bug 273213
527
528 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
529 amd64 stable, security bug 273213.
530
531*ruby-1.8.7_p173 (10 Jun 2009)
532*ruby-1.8.6_p369 (10 Jun 2009)
533
534 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
535 +ruby-1.8.7_p173.ebuild:
536 Version bumps for bug #273213.
537
538*ruby-1.9.1_p129-r1 (27 May 2009)
539
540 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
541 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
542 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
543 +files/ruby-1.9.1_p129-parallelmake.patch:
544 Revision bump, add patches 1) to make Ruby behave more similarly between
545 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
546 extensions (undefined symbols in them will cause abort at runtime 3) to
547 remove a concurrency issue when building the dl extension that could
548 result in a broken dl.so.
549
550 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
551 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
552 Don't block rdoc-2 or later (which may enter Portage one day as it's
553 needed by some Rakefiles).
554
555 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
556 ruby-1.9.1_p129.ebuild:
557 Add ~x86-fbsd keyword.
558
559 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
560 keyword ~sparc-fbsd, bug #252315
561
562*ruby-1.9.1_p129 (15 May 2009)
563
564 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
565 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
566 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
567 included in every release.
568
569 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
570 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
571 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
572 ruby-1.8.7_p160.ebuild:
573 Removing vulnerable versions (#268515), fixing license (#233747).
574
575 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
576 Stable for HPPA (bug #268515).
577
578 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
579 Adapting rubygems notice.
580
581 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
582 amd64 stable, bug #268515.
583
584 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
585 arm/ia64/s390/sh/sparc stable wrt #268515
586
587 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
588 ruby-1.8.6_p368.ebuild:
589 stable x86, security bug 268515
590
591 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
592 ruby-1.8.6_p368.ebuild:
593 Stable on alpha, bug #268515
594
595 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
596 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
597
598*ruby-1.8.7_p160 (07 May 2009)
599*ruby-1.8.6_p368 (07 May 2009)
600
601 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
602 +ruby-1.8.7_p160.ebuild:
603 Version bump as per secbug 268515. NB: These are the first ebuilds that
604 no longer use ruby-config.
605
606*ruby-1.9.1-r1 (03 Apr 2009)
607*ruby-1.8.7_p72-r11 (03 Apr 2009)
608*ruby-1.8.6_p287-r13 (03 Apr 2009)
609
610 03 Apr 2009; Alex Legler <a3li@gentoo.org>
611 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
612 +files/ruby18-mkmf-parallel-install.patch,
613 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
614 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
615 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
616 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
617 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
618 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
619 happy.
620
621*ruby-1.9.1 (21 Mar 2009)
622
623 21 Mar 2009; Alex Legler <a3li@gentoo.org>
624 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
625 +ruby-1.9.1.ebuild:
626 Adding Ruby 1.9.1 for preliminary testing
627
628 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
629 ruby-1.8.6_p287-r12.ebuild:
630 Marked ~ppc for bug #252315.
631
632 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
633 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
634 bug 261982.
635
636 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
637 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
638 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
639 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
640 Cleanup
641
642*ruby-1.8.7_p72-r10 (07 Mar 2009)
643
644 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
645 +ruby-1.8.7_p72-r10.ebuild:
646 Add a revision of ruby 1.8.7 using eselect ruby.
647
648 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
649 ~mips keyworded, bug #252315.
650
651 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
652 ruby-1.8.6_p287-r5.ebuild:
653 ppc stable, bug #260006
654
655 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
656 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
657
658 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
659 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
660 Fixing Tk USE flag test, bug 258893.
661
662 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
663 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
664
665 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
666 ruby-1.8.6_p287-r5.ebuild:
667 amd64 stable wrt security bug #260006
668
669 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
670 Stable for HPPA (bug #260006).
671
672 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
673 ruby-1.8.6_p287-r5.ebuild:
674 Stable on alpha, bug #260006
675
676*ruby-1.8.7_p72-r2 (23 Feb 2009)
677*ruby-1.8.6_p287-r12 (23 Feb 2009)
678*ruby-1.8.6_p287-r5 (23 Feb 2009)
679
680 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
681 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
682 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
683 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
684 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
685 now before compilation if Tk useflags don't match) and 230748 (adding
686 --enable-option-checking=no for newer versions of autoconf).
687
688 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
689 arm/ia64/s390/sh/sparc stable wrt #254307
690
691 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
692 ruby-1.8.6_p287-r4.ebuild:
693 Stable on alpha, bug #254307
694
695 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
696 ruby-1.8.6_p287-r11.ebuild:
697 keyword ~x86-fbsd, bug #252315
698
699 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
700 ppc stable #254307
701
702 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
703 amd64/x86 stable, bug #254307
704
705 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
706 stable ppc64, bug 254307
707
708 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
709 Stable for HPPA (bug #254307).
710
711 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
712 ruby-1.8.6_p287-r11.ebuild:
713 Marked ~hppa (bug #252315).
714
715*ruby-1.8.6_p287-r11 (11 Jan 2009)
716
717 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
718 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
719 +ruby-1.8.6_p287-r11.ebuild:
720 Backport conditional definition of missing openssl functions from ruby 1.8.7.
721 Fixes #254307.
722
723 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
724 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
725
726 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
727 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
728
729 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
730 ruby-1.8.6_p287-r10.ebuild:
731 Add ~sparc keyword, bug #252315
732
733*ruby-1.8.6_p287-r10 (23 Dec 2008)
734
735 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
736 +ruby-1.8.6_p287-r10.ebuild:
737 Version bump which switches from ruby-config to eselect-ruby. Dropped most
738 keywords since eselect-ruby does not yet have these keywords.
739
740 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
741 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
742 Revert the ruby-config changes. We can't remove them until we provide an
743 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
744 for breaking things as mentioned in bug #251833.
745
746 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
747 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
748 ruby-1.8.7_p72-r1.ebuild:
749 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
750 Thanks for the people noticing this in bug #251833.
751
752 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
753 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
754 ruby-1.8.7_p72-r1.ebuild:
755 Drop dependency on ruby-config, which will be removed from the tree. We
756 currently only have one major version of ruby in the tree (Ruby 1.8), so there
757 is no need for ruby-config at this moment. For newer versions of Ruby we will
758 use eselect-ruby, which can be found in the ruby overlay at the moment.
759
760 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
761 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
762 Use mirror://ruby in SRC_URI, fixes #237392.
763
764 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
765 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
766 -ruby-1.8.7_p72.ebuild:
767 Remove old versions. Leave one old stable version with cjk support.
768
769*ruby-1.8.6_p287-r3 (29 Nov 2008)
770
771 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
772 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
773 +ruby-1.8.6_p287-r3.ebuild:
774 Fix our expansion limit patch according to debian bug report
775 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
776 make sure people will pick up the fixed version. Thanks to Alex Legler for
777 mentioning the patch.
778
779*ruby-1.8.7_p72-r1 (26 Nov 2008)
780*ruby-1.8.6_p287-r2 (26 Nov 2008)
781
782 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
783 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
784 +ruby-1.8.7_p72-r1.ebuild:
785 Fix problem with shortname constants #247790, already fixed in upstream SVN.
786 Thanks to Alex Legler for providing the patch.
787
788 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
789 -ruby-1.8.6_p287.ebuild:
790 Remove versions that will not become stable
791
792 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
793 ruby-1.8.6_p287-r1.ebuild:
794 ppc stable, bug #225465
795
796 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
797 ruby-1.8.6_p287-r1.ebuild:
798 amd64 stable wrt security bug #225465
799
800 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
801 alpha/ia64/x86 stable wrt #225465
802
803 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
804 ruby-1.8.6_p287-r1.ebuild:
805 Sparc stable --- Security Bug #225465 --- good since late August.
806
807 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
808 Stable on ppc64; bug #225465
809
810 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
811 Stable for HPPA (bug #225465).
812
813*ruby-1.8.6_p287-r1 (29 Aug 2008)
814
815 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
816 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
817 +ruby-1.8.6_p287-r1.ebuild:
818 Fix REXML security issues, bug #236060.
819
820 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
821 Add GLEP 56 USE flag descriptions.
822
823*ruby-1.8.7_p72 (15 Aug 2008)
824
825 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
826 +ruby-1.8.7_p72.ebuild:
827 bump 1.8.7 to latest patch release
828
829*ruby-1.8.6_p287 (11 Aug 2008)
830
831 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
832 Version bump for brown paper bag relelease.
833
834 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
835 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
836 Remove broken version in favor of the just-added 1.8.6_p286
837
838*ruby-1.8.6_p286 (10 Aug 2008)
839
840 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
841 Version bump to latest released version of ruby 1.8.6. This version fixes the
842 security issues reported in #225465 and #234224. The cjk USE flag has been
843 dropped since no compatible patches have been released yet.
844
845 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
846 ruby-1.8.6_p230.ebuild:
847 drop cjk from SRC_URI as well
848
849 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
850 Drop cjk support since the most recent oniguruma patches no longer apply to
851 this version, #230111.
852
853 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
854 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
855 Try to fix the security issues reported in #225465 for ruby 1.8.6.
856 Unfortunately the official p230 has a change which causes segmentation faults
857 for applications like Rails and RSpec, so we are reverting that specific
858 change.
859
860*ruby-1.8.7_p22 (29 Jun 2008)
861
862 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
863 +ruby-1.8.7_p22.ebuild:
864 bump 1.8.7 for security fix
865
866 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
867 nevermind, don't bump this yet
868
869*ruby-1.8.6_p230 (20 Jun 2008)
870
871 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
872 version bump
873
874*ruby-1.8.7 (10 Jun 2008)
875
876 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
877 +ruby-1.8.7.ebuild:
878 bump 1.8.7 to final
879
880*ruby-1.8.7_pre2 (21 Apr 2008)
881
882 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
883 +ruby-1.8.7_pre2.ebuild:
884 Version Bump
885
886*ruby-1.8.7_pre1 (16 Apr 2008)
887
888 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
889 Version bump. Drop cjk until a new version of oniguruma appears.
890
891 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
892 amd64 stable, bug 212264
893
894 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
895 Stable for HPPA (bug #212264).
896
897 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
898 ruby-1.8.6_p114.ebuild:
899 ppc stable, bug #212264
900
901 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
902 alpha/ia64 stable wrt #212264
903
904 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
905 ruby-1.8.6_p114.ebuild:
906 stable x86, security bug 212264
907
908 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
909 Sparc stable, Security Bug #212264, builds and installs, initial tests run
910 as expected.
911
912 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
913 Marking ruby-1.8.6_p114 ppc64 for bug 212264
914
915*ruby-1.8.6_p114 (05 Mar 2008)
916
917 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
918 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
919 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
920 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
921 Version bump for #212264. Remove old ebuilds.
922
923 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
924 alpha/ia64 stable wrt #208916
925
926 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
927 Stable on ppc wrt bug 208916
928
929 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
930 x86 stable, bug #208916
931
932 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
933 ruby-1.8.6_p111-r1.ebuild:
934 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
935
936 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
937 -files/ruby-1.8.6-exit-status.patch,
938 -files/ruby-1.8.6_p110-net-http-p111.patch,
939 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
940 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
941 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
942 Remove old versions
943
944 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
945 Stable on ppc64
946
947 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
948 Stable on amd64; bug 199191
949
950 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
951 alpha/ia64/sparc stable wrt #199191
952
953 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
954 Remove now-obsolete warning about coreutils versions, #203156.
955
956 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
957 Stable for HPPA (bug #199191).
958
959*ruby-1.8.6_p111-r1 (23 Dec 2007)
960
961 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
962 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
963 ssl USE flags. Patch to p113.
964
965 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
966 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
967
968 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
969 x86 stable, security bug #199191
970
971*ruby-1.8.6_p111 (23 Dec 2007)
972
973 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
974 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
975 Version bump with patch for bug #199191
976
977 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
978 Move dependency on (X)Emacs modes to PDEPEND.
979
980 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
981 Add back ~hppa keyword now that XEmacs support files have been keyworded,
982 bug 196413
983
984*ruby-1.8.6_p110-r2 (21 Oct 2007)
985
986 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
987 +ruby-1.8.6_p110-r2.ebuild:
988 Add emacs and xemacs USE flags and use them to pull in the correct editing
989 mode for each. Had to drop several arch keywords as reported on bug 196413.
990
991 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
992 amd64 stable, security bug 194236
993
994 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
995 ruby-1.8.6_p110-r1.ebuild:
996 Stable on ppc64; bug #194236
997
998 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
999 amd64 stable, security bug 194236
1000
1001 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1002 Stable for HPPA (bug #194236).
1003
1004 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1005 alpha/ia64/sparc stable wrt security #194236
1006
1007 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1008 ruby-1.8.6_p110-r1.ebuild:
1009 ppc stable, bug #194236
1010
1011 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1012 ruby-1.8.6_p110-r1.ebuild:
1013 stable x86, security bug 194236
1014
1015 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1016 ruby-1.8.5_p113.ebuild:
1017 stable x86, security bug 194236
1018
1019 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1020 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1021 -ruby-1.8.6_p110.ebuild:
1022 Remove old versions
1023
1024*ruby-1.8.6_p110-r1 (30 Sep 2007)
1025*ruby-1.8.5_p113 (30 Sep 2007)
1026
1027 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1028 +files/ruby-1.8.5_p113-net-http-p114.patch,
1029 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1030 +ruby-1.8.6_p110-r1.ebuild:
1031 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1032 using 1.8.6-p110 as base ebuild.
1033
1034 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1035 More fixes from gentoo-dev and graaff
1036
1037 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1038 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1039
1040*ruby-1.8.6_p110 (24 Sep 2007)
1041
1042 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1043 Version bump
1044
1045*ruby-1.8.6_p36-r4 (26 Aug 2007)
1046
1047 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1048 +ruby-1.8.6_p36-r4.ebuild:
1049 Use user LDFLAGS, #181436
4 1050
5 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild, 1051 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild: 1052 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
7 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old 1053 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
8 ebuilds, including the currently stable 1.8.5_p2-r1, #189241. 1054 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.

Legend:
Removed from v.1.293  
changed lines
  Added in v.1.530

  ViewVC Help
Powered by ViewVC 1.1.20