/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.297 Revision 1.520
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.297 2007/09/24 12:49:03 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.520 2011/12/29 09:54:42 ago Exp $
4
5 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
6 Stable for AMD64, wrt security bug #396301
7
8*ruby-1.8.7_p357 (28 Dec 2011)
9
10 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
11 Version bump for security bug 396301.
12
13 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
14 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
15
16 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
17 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
18 keyworded, bug 332593.
19
20 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
21 Block older versions of packages that are no longer compatible. Remove
22 ancient blocks on packags long gone from the tree.
23
24 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
25 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
26 Remove old versions.
27
28*ruby-1.9.3_p0 (18 Dec 2011)
29
30 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
31 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
32 suite which need to be diagnosed first.
33
34 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
35 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
36 #332593).
37
38 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
39 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
40 #332593).
41
42 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
43 alpha/ia64/s390/sh/sparc stable wrt #386369
44
45*ruby-1.9.3_rc1 (22 Oct 2011)
46
47 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
48 Version bump.
49
50 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
51 arm stable, bug #386369
52
53 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
54 x86 stable, bug 386369
55
56 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
57 Stable for HPPA (bug #386369).
58
59 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
60 ppc/ppc64 stable wrt #386369
61
62 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
63 Stable on amd64 wrt bug #386369
64
65 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
66 Remove vulnerable version, bug 386369.
67
68*ruby-1.8.7_p352 (30 Aug 2011)
69
70 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
71 +ruby-1.8.7_p352.ebuild:
72 Patchlevel bump for ruby:1.8. Removing old version
73
74*ruby-1.9.2_p290 (30 Aug 2011)
75
76 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
77 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
78 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
79 old patchlevels.
80
81 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
82 ruby-1.8.7_p334-r2.ebuild:
83 ppc/ppc64 stable wrt #378691
84
85*ruby-1.8.7_p334-r2 (22 Jul 2011)
86
87 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
88 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
89 for chasing down upstream and us.
90
91 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
92 Added ~mips, bug 332593
93
94 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
95 ruby-1.8.7_p334-r1.ebuild:
96 ppc64 stable wrt #369141
97
98 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
99 ia64/s390/sh/sparc stable wrt #369141
100
101 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
102 Stable for HPPA (bug #369141).
103
104 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
105 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
106
107 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
108 arm/x86 stable, bug #369141
109
110 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
111 Stable on amd64 wrt bug #369141
112
113 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
114 ruby-1.8.7_p334-r1.ebuild:
115 Stable on alpha, bug #369141
116
117*ruby-1.8.7_p334-r1 (31 May 2011)
118
119 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
120 Revision bump for security bug 369141 (CVE-2011-0188)
121
122*ruby-1.9.2-r1 (16 May 2011)
123
124 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
125 Don't remove racc files since all other ruby targets ship these files
126 themselves as well. Closes bug 363419.
127
128 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
129 ruby-1.8.7_p334.ebuild:
130 Remove old version. Remove obsolete and unused old-style virtual/ruby.
131
132 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
133 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
134
135 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
136 Add append-flags -mieee on sh, bug #357559
137
138 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
139 alpha/arm/ia64/s390/sh stable wrt #355439
140
141 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
142 Marked ~ppc64 wrt #332593
143
144 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
145 ruby-1.8.7_p334.ebuild:
146 x86 stable wrt security bug #355439
147
148 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
149 ruby-1.8.7_p334.ebuild:
150 ppc/ppc64 stable wrt #355439
151
152 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
153 Stable on amd64 wrt bug #355439
154
155 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
156 Stable for HPPA (bug #355439).
157
158*ruby-1.8.7_p334 (19 Feb 2011)
159
160 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
161 Version bump 1.8.7 series, security bug 355439
162
163 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
164 ruby-1.9.2.ebuild:
165 Remove PROVIDE for old-style virtual/ruby per bug 265054.
166
167 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
168 Remove masked ruby 1.8.6 per bug 332597.
169
170 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
171 -ruby-1.9.2_rc2.ebuild:
172 Removing old and vulnerable ebuilds
173
174 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
175 Marking ruby-1.8.7_p302 ppc64 for bug 332957
176
177 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
178 alpha/ia64/s390/sh/sparc stable wrt #332957
179
180*ruby-1.9.2 (24 Aug 2010)
181
182 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
183 metadata.xml:
184 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
185 and x86-fbsd due to a new dependency on rdoc.
186
187 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
188 arm stable, bug #332957
189
190 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
191 ruby-1.8.7_p302.ebuild:
192 x86 stable wrt security bug #332957
193
194 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
195 Stable on amd64 wrt bug #332957
196
197 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
198 Stable for PPC (bug #332957).
199
200 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
201 Stable for HPPA (bug #332957).
202
203*ruby-1.8.7_p302 (21 Aug 2010)
204
205 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
206 +ruby-1.8.7_p302.ebuild:
207 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
208 installation path.
209
210*ruby-1.8.6_p399 (19 Aug 2010)
211
212 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
213 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
214 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
215 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
216 installation path (reported by the x86 team in bug 332597)
217
218*ruby-1.9.2_rc2-r1 (18 Aug 2010)
219
220 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
221 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
222 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
223 the rubygems loading code. Add USE flag for psych.
224
225 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
226 ruby-1.9.2_rc2.ebuild:
227 Remove two keepdir that will try to keep an empty path, closes bug
228 #333163.
229
230 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
231 Marked ~ppc (bug #332593).
232
233 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
234 ruby-1.9.2_rc2.ebuild:
235 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
236
237 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
238 ruby-1.8.7_p299.ebuild:
239 Bump eselect-ruby dependency
240
241 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
242 -ruby-1.9.1_p429.ebuild:
243 Remove ebuild that is not target for unmask anyway.
244
245 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
246 ruby-1.9.2_rc2.ebuild:
247 Try 2 to fix the berkdb 5 issue on 1.9.
248
249 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
250 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
251 ruby-1.9.2_rc2.ebuild:
252 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
253 support for adding new patchsets without bumping the revision for all the
254 old ebuilds as well.
255
256*ruby-1.9.2_rc2 (14 Jul 2010)
257
258 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
259 +ruby-1.9.2_rc2.ebuild:
260 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
261 might cause _further_ build failures as it changed slightly behaviour.
262 You're going to need to rebuild rubygems and then all the packages
263 previously installed after upgrading to this.
264
265 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
266 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
267 -ruby-1.9.1_p376.ebuild:
268 Cleanup old versions.
269
270*ruby-1.9.1_p429 (04 Jul 2010)
271
272 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
273 +ruby-1.9.1_p429.ebuild:
274 Version bump to new 1.9.1 release.
275
276*ruby-1.8.7_p299 (23 Jun 2010)
277
278 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
279 +ruby-1.8.7_p299.ebuild:
280 Version bump.
281
282 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
283 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
284 remove useless comments
285
286 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
287 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
288 ruby-1.9.1_p376.ebuild:
289 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
290 dev.gentoo.org now.
291
292 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
293 ruby-1.9.1_p376.ebuild:
294 Use the correct RUBYLIB.
295
296*ruby-1.8.7_p249-r2 (18 May 2010)
297*ruby-1.8.6_p388-r1 (18 May 2010)
298
299 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
300 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
301 ruby-1.9.1_p376.ebuild, metadata.xml:
302 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
303 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
304 add USE flags for ncurses, readline and libedit, and properly depend on
305 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
306 Emacs versions support ruby-mode themselves and it should be even more
307 updated.
308
309*ruby-1.8.7_p249-r1 (06 May 2010)
310
311 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
312 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
313 309789 by Sune Kloppenborg Jeppesen.
314
315 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
316 ruby-1.8.7_p249.ebuild:
317 Use $PVR instead of $PV in patchset names
318
319 06 May 2010; Alex Legler <a3li@gentoo.org>
320 -files/ruby-1.8.6-memory-leak.diff,
321 -files/ruby18-mkmf-parallel-install.patch,
322 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
323 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
324 Remove old version. Cleanup in files/
325
326*ruby-1.9.1_p376 (01 May 2010)
327
328 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
329 Version bump. Fixes security bugs 296052 and 300468. No longer installs
330 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
331 instead.
332
333 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
334 -ruby-1.8.7_p174-r1.ebuild:
335 Remove vulnerable ebuilds, 300468
336
337 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
338 ruby-1.8.7_p249.ebuild:
339 amd64 stable, security bug 300468
340
341 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
342 ruby-1.8.7_p249.ebuild:
343 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
344
345 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
346 Stable for HPPA (bug #300468).
347
348 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
349 Stable for HPPA (bug #300468).
350
351 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
352 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
353
354 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
355 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
356
357 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
358 ruby-1.8.6_p388.ebuild:
359 stable x86, security bug 300468
360
361 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
362 ruby-1.8.7_p249.ebuild:
363 stable x86, security bug 300468
364
365*ruby-1.8.6_p388 (10 Jan 2010)
366
367 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
368 +ruby-1.8.6_p388.ebuild:
369 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
370 version. The new ebuild also has the fix for bug 168939.
371
372*ruby-1.8.7_p249 (10 Jan 2010)
373
374 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
375 +ruby-1.8.7_p249.ebuild:
376 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
377 version
378
379 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
380 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
381
382*ruby-1.8.7_p248 (25 Dec 2009)
383
384 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
385 Version bump
386
387 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
388 Remove old version.
389
390 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
391 Remove old version.
392
393 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
394 ia64/s390/sh stable wrt #288699
395
396 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
397 stable sparc, bug 288699
398
399 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
400 arm stable, bug #288699
401
402 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
403 amd64/x86 stable, bug #288699
404
405 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
406 ruby-1.8.7_p174-r1.ebuild:
407 Stable on alpha, bug #288699
408
409 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
410 ppc stable #288699
411
412 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
413 Stable for HPPA (bug #288699).
414
415 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
416 Marked ~hppa too.
417
418*ruby-1.8.7_p174-r1 (06 Oct 2009)
419
420 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
421 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
422 eselect-ruby cleanup feature.
423
424*ruby-1.9.1_p243 (09 Sep 2009)
425
426 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
427 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
428 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
429 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
430 -files/ruby19-rubygems-proxy.patch,
431 -files/ruby-1.9.1_p129-parallelmake.patch,
432 -files/ruby19-mkmf-parallel-install.patch:
433 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
434 168939. Cleaning up old patches.
435
436*ruby-1.8.6_p383 (20 Aug 2009)
437
438 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
439 Patchlevel bump.
440
441 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
442 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
443 ruby-1.9.1_p129-r1.ebuild:
444 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
445
446 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
447 Removing vulnerable ebuild, bug 273213.
448
449 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
450 Marking ruby-1.8.6_p369 ppc for bug 273213
451
452 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
453 ruby-1.9.1_p129-r1.ebuild:
454 Prepend our library path instead of overwriting it during src_install.
455 Thanks to the reporter of bug #274824.
456
457*ruby-1.8.7_p174 (18 Jun 2009)
458
459 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
460 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
461 Replacing 187_p173 with _p174 because of a regression. Unifying the
462 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
463 patchsets.
464
465 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
466 Marking ruby-1.8.6_p369 ppc64 for bug 273213
467
468 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
469 arm/ia64/s390/sh/sparc stable wrt #273213
470
471 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
472 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
473 Removing old version, minor cleanup
474
475 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
476 -files/ruby-1.8.6-openssl.patch,
477 -files/ruby-1.8.6-shortname_constants.patch,
478 -files/ruby-1.8.6_p111-r13657.patch,
479 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
480 Removing vulnerable old Ruby version and stale patches, bug 274108.
481
482 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
483 ruby-1.8.6_p369.ebuild:
484 Stable on alpha, bug #273213
485
486 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
487 Stable for HPPA (bug #273213).
488
489 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
490 ruby-1.8.6_p369.ebuild:
491 stable x86, security bug 273213
492
493 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
494 amd64 stable, security bug 273213.
495
496*ruby-1.8.7_p173 (10 Jun 2009)
497*ruby-1.8.6_p369 (10 Jun 2009)
498
499 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
500 +ruby-1.8.7_p173.ebuild:
501 Version bumps for bug #273213.
502
503*ruby-1.9.1_p129-r1 (27 May 2009)
504
505 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
506 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
507 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
508 +files/ruby-1.9.1_p129-parallelmake.patch:
509 Revision bump, add patches 1) to make Ruby behave more similarly between
510 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
511 extensions (undefined symbols in them will cause abort at runtime 3) to
512 remove a concurrency issue when building the dl extension that could
513 result in a broken dl.so.
514
515 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
516 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
517 Don't block rdoc-2 or later (which may enter Portage one day as it's
518 needed by some Rakefiles).
519
520 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
521 ruby-1.9.1_p129.ebuild:
522 Add ~x86-fbsd keyword.
523
524 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
525 keyword ~sparc-fbsd, bug #252315
526
527*ruby-1.9.1_p129 (15 May 2009)
528
529 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
530 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
531 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
532 included in every release.
533
534 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
535 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
536 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
537 ruby-1.8.7_p160.ebuild:
538 Removing vulnerable versions (#268515), fixing license (#233747).
539
540 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
541 Stable for HPPA (bug #268515).
542
543 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
544 Adapting rubygems notice.
545
546 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
547 amd64 stable, bug #268515.
548
549 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
550 arm/ia64/s390/sh/sparc stable wrt #268515
551
552 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
553 ruby-1.8.6_p368.ebuild:
554 stable x86, security bug 268515
555
556 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
557 ruby-1.8.6_p368.ebuild:
558 Stable on alpha, bug #268515
559
560 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
561 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
562
563*ruby-1.8.7_p160 (07 May 2009)
564*ruby-1.8.6_p368 (07 May 2009)
565
566 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
567 +ruby-1.8.7_p160.ebuild:
568 Version bump as per secbug 268515. NB: These are the first ebuilds that
569 no longer use ruby-config.
570
571*ruby-1.9.1-r1 (03 Apr 2009)
572*ruby-1.8.7_p72-r11 (03 Apr 2009)
573*ruby-1.8.6_p287-r13 (03 Apr 2009)
574
575 03 Apr 2009; Alex Legler <a3li@gentoo.org>
576 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
577 +files/ruby18-mkmf-parallel-install.patch,
578 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
579 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
580 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
581 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
582 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
583 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
584 happy.
585
586*ruby-1.9.1 (21 Mar 2009)
587
588 21 Mar 2009; Alex Legler <a3li@gentoo.org>
589 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
590 +ruby-1.9.1.ebuild:
591 Adding Ruby 1.9.1 for preliminary testing
592
593 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
594 ruby-1.8.6_p287-r12.ebuild:
595 Marked ~ppc for bug #252315.
596
597 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
598 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
599 bug 261982.
600
601 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
602 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
603 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
604 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
605 Cleanup
606
607*ruby-1.8.7_p72-r10 (07 Mar 2009)
608
609 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
610 +ruby-1.8.7_p72-r10.ebuild:
611 Add a revision of ruby 1.8.7 using eselect ruby.
612
613 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
614 ~mips keyworded, bug #252315.
615
616 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
617 ruby-1.8.6_p287-r5.ebuild:
618 ppc stable, bug #260006
619
620 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
621 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
622
623 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
624 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
625 Fixing Tk USE flag test, bug 258893.
626
627 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
628 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
629
630 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
631 ruby-1.8.6_p287-r5.ebuild:
632 amd64 stable wrt security bug #260006
633
634 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
635 Stable for HPPA (bug #260006).
636
637 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
638 ruby-1.8.6_p287-r5.ebuild:
639 Stable on alpha, bug #260006
640
641*ruby-1.8.7_p72-r2 (23 Feb 2009)
642*ruby-1.8.6_p287-r12 (23 Feb 2009)
643*ruby-1.8.6_p287-r5 (23 Feb 2009)
644
645 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
646 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
647 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
648 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
649 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
650 now before compilation if Tk useflags don't match) and 230748 (adding
651 --enable-option-checking=no for newer versions of autoconf).
652
653 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
654 arm/ia64/s390/sh/sparc stable wrt #254307
655
656 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
657 ruby-1.8.6_p287-r4.ebuild:
658 Stable on alpha, bug #254307
659
660 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
661 ruby-1.8.6_p287-r11.ebuild:
662 keyword ~x86-fbsd, bug #252315
663
664 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
665 ppc stable #254307
666
667 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
668 amd64/x86 stable, bug #254307
669
670 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
671 stable ppc64, bug 254307
672
673 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
674 Stable for HPPA (bug #254307).
675
676 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
677 ruby-1.8.6_p287-r11.ebuild:
678 Marked ~hppa (bug #252315).
679
680*ruby-1.8.6_p287-r11 (11 Jan 2009)
681
682 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
683 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
684 +ruby-1.8.6_p287-r11.ebuild:
685 Backport conditional definition of missing openssl functions from ruby 1.8.7.
686 Fixes #254307.
687
688 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
689 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
690
691 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
692 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
693
694 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
695 ruby-1.8.6_p287-r10.ebuild:
696 Add ~sparc keyword, bug #252315
697
698*ruby-1.8.6_p287-r10 (23 Dec 2008)
699
700 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
701 +ruby-1.8.6_p287-r10.ebuild:
702 Version bump which switches from ruby-config to eselect-ruby. Dropped most
703 keywords since eselect-ruby does not yet have these keywords.
704
705 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
706 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
707 Revert the ruby-config changes. We can't remove them until we provide an
708 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
709 for breaking things as mentioned in bug #251833.
710
711 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
712 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
713 ruby-1.8.7_p72-r1.ebuild:
714 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
715 Thanks for the people noticing this in bug #251833.
716
717 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
718 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
719 ruby-1.8.7_p72-r1.ebuild:
720 Drop dependency on ruby-config, which will be removed from the tree. We
721 currently only have one major version of ruby in the tree (Ruby 1.8), so there
722 is no need for ruby-config at this moment. For newer versions of Ruby we will
723 use eselect-ruby, which can be found in the ruby overlay at the moment.
724
725 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
726 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
727 Use mirror://ruby in SRC_URI, fixes #237392.
728
729 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
730 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
731 -ruby-1.8.7_p72.ebuild:
732 Remove old versions. Leave one old stable version with cjk support.
733
734*ruby-1.8.6_p287-r3 (29 Nov 2008)
735
736 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
737 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
738 +ruby-1.8.6_p287-r3.ebuild:
739 Fix our expansion limit patch according to debian bug report
740 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
741 make sure people will pick up the fixed version. Thanks to Alex Legler for
742 mentioning the patch.
743
744*ruby-1.8.7_p72-r1 (26 Nov 2008)
745*ruby-1.8.6_p287-r2 (26 Nov 2008)
746
747 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
748 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
749 +ruby-1.8.7_p72-r1.ebuild:
750 Fix problem with shortname constants #247790, already fixed in upstream SVN.
751 Thanks to Alex Legler for providing the patch.
752
753 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
754 -ruby-1.8.6_p287.ebuild:
755 Remove versions that will not become stable
756
757 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
758 ruby-1.8.6_p287-r1.ebuild:
759 ppc stable, bug #225465
760
761 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
762 ruby-1.8.6_p287-r1.ebuild:
763 amd64 stable wrt security bug #225465
764
765 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
766 alpha/ia64/x86 stable wrt #225465
767
768 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
769 ruby-1.8.6_p287-r1.ebuild:
770 Sparc stable --- Security Bug #225465 --- good since late August.
771
772 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
773 Stable on ppc64; bug #225465
774
775 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
776 Stable for HPPA (bug #225465).
777
778*ruby-1.8.6_p287-r1 (29 Aug 2008)
779
780 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
781 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
782 +ruby-1.8.6_p287-r1.ebuild:
783 Fix REXML security issues, bug #236060.
784
785 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
786 Add GLEP 56 USE flag descriptions.
787
788*ruby-1.8.7_p72 (15 Aug 2008)
789
790 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
791 +ruby-1.8.7_p72.ebuild:
792 bump 1.8.7 to latest patch release
793
794*ruby-1.8.6_p287 (11 Aug 2008)
795
796 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
797 Version bump for brown paper bag relelease.
798
799 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
800 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
801 Remove broken version in favor of the just-added 1.8.6_p286
802
803*ruby-1.8.6_p286 (10 Aug 2008)
804
805 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
806 Version bump to latest released version of ruby 1.8.6. This version fixes the
807 security issues reported in #225465 and #234224. The cjk USE flag has been
808 dropped since no compatible patches have been released yet.
809
810 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
811 ruby-1.8.6_p230.ebuild:
812 drop cjk from SRC_URI as well
813
814 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
815 Drop cjk support since the most recent oniguruma patches no longer apply to
816 this version, #230111.
817
818 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
819 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
820 Try to fix the security issues reported in #225465 for ruby 1.8.6.
821 Unfortunately the official p230 has a change which causes segmentation faults
822 for applications like Rails and RSpec, so we are reverting that specific
823 change.
824
825*ruby-1.8.7_p22 (29 Jun 2008)
826
827 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
828 +ruby-1.8.7_p22.ebuild:
829 bump 1.8.7 for security fix
830
831 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
832 nevermind, don't bump this yet
833
834*ruby-1.8.6_p230 (20 Jun 2008)
835
836 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
837 version bump
838
839*ruby-1.8.7 (10 Jun 2008)
840
841 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
842 +ruby-1.8.7.ebuild:
843 bump 1.8.7 to final
844
845*ruby-1.8.7_pre2 (21 Apr 2008)
846
847 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
848 +ruby-1.8.7_pre2.ebuild:
849 Version Bump
850
851*ruby-1.8.7_pre1 (16 Apr 2008)
852
853 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
854 Version bump. Drop cjk until a new version of oniguruma appears.
855
856 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
857 amd64 stable, bug 212264
858
859 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
860 Stable for HPPA (bug #212264).
861
862 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
863 ruby-1.8.6_p114.ebuild:
864 ppc stable, bug #212264
865
866 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
867 alpha/ia64 stable wrt #212264
868
869 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
870 ruby-1.8.6_p114.ebuild:
871 stable x86, security bug 212264
872
873 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
874 Sparc stable, Security Bug #212264, builds and installs, initial tests run
875 as expected.
876
877 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
878 Marking ruby-1.8.6_p114 ppc64 for bug 212264
879
880*ruby-1.8.6_p114 (05 Mar 2008)
881
882 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
883 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
884 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
885 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
886 Version bump for #212264. Remove old ebuilds.
887
888 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
889 alpha/ia64 stable wrt #208916
890
891 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
892 Stable on ppc wrt bug 208916
893
894 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
895 x86 stable, bug #208916
896
897 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
898 ruby-1.8.6_p111-r1.ebuild:
899 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
900
901 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
902 -files/ruby-1.8.6-exit-status.patch,
903 -files/ruby-1.8.6_p110-net-http-p111.patch,
904 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
905 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
906 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
907 Remove old versions
908
909 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
910 Stable on ppc64
911
912 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
913 Stable on amd64; bug 199191
914
915 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
916 alpha/ia64/sparc stable wrt #199191
917
918 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
919 Remove now-obsolete warning about coreutils versions, #203156.
920
921 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
922 Stable for HPPA (bug #199191).
923
924*ruby-1.8.6_p111-r1 (23 Dec 2007)
925
926 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
927 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
928 ssl USE flags. Patch to p113.
929
930 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
931 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
932
933 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
934 x86 stable, security bug #199191
935
936*ruby-1.8.6_p111 (23 Dec 2007)
937
938 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
939 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
940 Version bump with patch for bug #199191
941
942 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
943 Move dependency on (X)Emacs modes to PDEPEND.
944
945 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
946 Add back ~hppa keyword now that XEmacs support files have been keyworded,
947 bug 196413
948
949*ruby-1.8.6_p110-r2 (21 Oct 2007)
950
951 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
952 +ruby-1.8.6_p110-r2.ebuild:
953 Add emacs and xemacs USE flags and use them to pull in the correct editing
954 mode for each. Had to drop several arch keywords as reported on bug 196413.
955
956 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
957 amd64 stable, security bug 194236
958
959 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
960 ruby-1.8.6_p110-r1.ebuild:
961 Stable on ppc64; bug #194236
962
963 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
964 amd64 stable, security bug 194236
965
966 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
967 Stable for HPPA (bug #194236).
968
969 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
970 alpha/ia64/sparc stable wrt security #194236
971
972 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
973 ruby-1.8.6_p110-r1.ebuild:
974 ppc stable, bug #194236
975
976 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
977 ruby-1.8.6_p110-r1.ebuild:
978 stable x86, security bug 194236
979
980 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
981 ruby-1.8.5_p113.ebuild:
982 stable x86, security bug 194236
983
984 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
985 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
986 -ruby-1.8.6_p110.ebuild:
987 Remove old versions
988
989*ruby-1.8.6_p110-r1 (30 Sep 2007)
990*ruby-1.8.5_p113 (30 Sep 2007)
991
992 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
993 +files/ruby-1.8.5_p113-net-http-p114.patch,
994 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
995 +ruby-1.8.6_p110-r1.ebuild:
996 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
997 using 1.8.6-p110 as base ebuild.
4 998
5 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild: 999 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
6 More fixes from gentoo-dev and graaff 1000 More fixes from gentoo-dev and graaff
7 1001
8 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild: 1002 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:

Legend:
Removed from v.1.297  
changed lines
  Added in v.1.520

  ViewVC Help
Powered by ViewVC 1.1.20