/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.297 Revision 1.529
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.297 2007/09/24 12:49:03 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.529 2012/03/01 22:49:37 naota Exp $
4
5 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
6 Add ~x86-fbsd, #332593
7
8*ruby-1.9.3_p125 (18 Feb 2012)
9
10 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
11 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
12
13 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
14 add ~arm, bug #332593
15
16 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
17 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
18
19 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
20 x86 stable wrt bug #396301
21
22 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
23 Stable for HPPA (bug #396301).
24
25 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
26 Stable for ppc/ppc64; bug #396301
27
28 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
29 Marked ~hppa (bug #332593).
30
31 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
32 Add back ~alpha keyword now that rubygems is keyworded.
33
34 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
35 Stable for AMD64, wrt security bug #396301
36
37*ruby-1.8.7_p357 (28 Dec 2011)
38
39 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
40 Version bump for security bug 396301.
41
42 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
43 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
44
45 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
46 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
47 keyworded, bug 332593.
48
49 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
50 Block older versions of packages that are no longer compatible. Remove
51 ancient blocks on packags long gone from the tree.
52
53 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
54 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
55 Remove old versions.
56
57*ruby-1.9.3_p0 (18 Dec 2011)
58
59 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
60 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
61 suite which need to be diagnosed first.
62
63 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
64 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
65 #332593).
66
67 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
68 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
69 #332593).
70
71 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
72 alpha/ia64/s390/sh/sparc stable wrt #386369
73
74*ruby-1.9.3_rc1 (22 Oct 2011)
75
76 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
77 Version bump.
78
79 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
80 arm stable, bug #386369
81
82 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
83 x86 stable, bug 386369
84
85 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
86 Stable for HPPA (bug #386369).
87
88 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
89 ppc/ppc64 stable wrt #386369
90
91 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
92 Stable on amd64 wrt bug #386369
93
94 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
95 Remove vulnerable version, bug 386369.
96
97*ruby-1.8.7_p352 (30 Aug 2011)
98
99 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
100 +ruby-1.8.7_p352.ebuild:
101 Patchlevel bump for ruby:1.8. Removing old version
102
103*ruby-1.9.2_p290 (30 Aug 2011)
104
105 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
106 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
107 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
108 old patchlevels.
109
110 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
111 ruby-1.8.7_p334-r2.ebuild:
112 ppc/ppc64 stable wrt #378691
113
114*ruby-1.8.7_p334-r2 (22 Jul 2011)
115
116 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
117 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
118 for chasing down upstream and us.
119
120 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
121 Added ~mips, bug 332593
122
123 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
124 ruby-1.8.7_p334-r1.ebuild:
125 ppc64 stable wrt #369141
126
127 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
128 ia64/s390/sh/sparc stable wrt #369141
129
130 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
131 Stable for HPPA (bug #369141).
132
133 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
134 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
135
136 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
137 arm/x86 stable, bug #369141
138
139 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
140 Stable on amd64 wrt bug #369141
141
142 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
143 ruby-1.8.7_p334-r1.ebuild:
144 Stable on alpha, bug #369141
145
146*ruby-1.8.7_p334-r1 (31 May 2011)
147
148 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
149 Revision bump for security bug 369141 (CVE-2011-0188)
150
151*ruby-1.9.2-r1 (16 May 2011)
152
153 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
154 Don't remove racc files since all other ruby targets ship these files
155 themselves as well. Closes bug 363419.
156
157 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
158 ruby-1.8.7_p334.ebuild:
159 Remove old version. Remove obsolete and unused old-style virtual/ruby.
160
161 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
162 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
163
164 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
165 Add append-flags -mieee on sh, bug #357559
166
167 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
168 alpha/arm/ia64/s390/sh stable wrt #355439
169
170 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
171 Marked ~ppc64 wrt #332593
172
173 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
174 ruby-1.8.7_p334.ebuild:
175 x86 stable wrt security bug #355439
176
177 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
178 ruby-1.8.7_p334.ebuild:
179 ppc/ppc64 stable wrt #355439
180
181 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
182 Stable on amd64 wrt bug #355439
183
184 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
185 Stable for HPPA (bug #355439).
186
187*ruby-1.8.7_p334 (19 Feb 2011)
188
189 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
190 Version bump 1.8.7 series, security bug 355439
191
192 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
193 ruby-1.9.2.ebuild:
194 Remove PROVIDE for old-style virtual/ruby per bug 265054.
195
196 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
197 Remove masked ruby 1.8.6 per bug 332597.
198
199 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
200 -ruby-1.9.2_rc2.ebuild:
201 Removing old and vulnerable ebuilds
202
203 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
204 Marking ruby-1.8.7_p302 ppc64 for bug 332957
205
206 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
207 alpha/ia64/s390/sh/sparc stable wrt #332957
208
209*ruby-1.9.2 (24 Aug 2010)
210
211 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
212 metadata.xml:
213 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
214 and x86-fbsd due to a new dependency on rdoc.
215
216 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
217 arm stable, bug #332957
218
219 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
220 ruby-1.8.7_p302.ebuild:
221 x86 stable wrt security bug #332957
222
223 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
224 Stable on amd64 wrt bug #332957
225
226 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
227 Stable for PPC (bug #332957).
228
229 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
230 Stable for HPPA (bug #332957).
231
232*ruby-1.8.7_p302 (21 Aug 2010)
233
234 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
235 +ruby-1.8.7_p302.ebuild:
236 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
237 installation path.
238
239*ruby-1.8.6_p399 (19 Aug 2010)
240
241 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
242 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
243 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
244 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
245 installation path (reported by the x86 team in bug 332597)
246
247*ruby-1.9.2_rc2-r1 (18 Aug 2010)
248
249 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
250 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
251 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
252 the rubygems loading code. Add USE flag for psych.
253
254 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
255 ruby-1.9.2_rc2.ebuild:
256 Remove two keepdir that will try to keep an empty path, closes bug
257 #333163.
258
259 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
260 Marked ~ppc (bug #332593).
261
262 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
263 ruby-1.9.2_rc2.ebuild:
264 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
265
266 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
267 ruby-1.8.7_p299.ebuild:
268 Bump eselect-ruby dependency
269
270 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
271 -ruby-1.9.1_p429.ebuild:
272 Remove ebuild that is not target for unmask anyway.
273
274 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
275 ruby-1.9.2_rc2.ebuild:
276 Try 2 to fix the berkdb 5 issue on 1.9.
277
278 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
279 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
280 ruby-1.9.2_rc2.ebuild:
281 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
282 support for adding new patchsets without bumping the revision for all the
283 old ebuilds as well.
284
285*ruby-1.9.2_rc2 (14 Jul 2010)
286
287 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
288 +ruby-1.9.2_rc2.ebuild:
289 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
290 might cause _further_ build failures as it changed slightly behaviour.
291 You're going to need to rebuild rubygems and then all the packages
292 previously installed after upgrading to this.
293
294 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
295 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
296 -ruby-1.9.1_p376.ebuild:
297 Cleanup old versions.
298
299*ruby-1.9.1_p429 (04 Jul 2010)
300
301 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
302 +ruby-1.9.1_p429.ebuild:
303 Version bump to new 1.9.1 release.
304
305*ruby-1.8.7_p299 (23 Jun 2010)
306
307 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
308 +ruby-1.8.7_p299.ebuild:
309 Version bump.
310
311 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
312 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
313 remove useless comments
314
315 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
316 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
317 ruby-1.9.1_p376.ebuild:
318 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
319 dev.gentoo.org now.
320
321 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
322 ruby-1.9.1_p376.ebuild:
323 Use the correct RUBYLIB.
324
325*ruby-1.8.7_p249-r2 (18 May 2010)
326*ruby-1.8.6_p388-r1 (18 May 2010)
327
328 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
329 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
330 ruby-1.9.1_p376.ebuild, metadata.xml:
331 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
332 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
333 add USE flags for ncurses, readline and libedit, and properly depend on
334 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
335 Emacs versions support ruby-mode themselves and it should be even more
336 updated.
337
338*ruby-1.8.7_p249-r1 (06 May 2010)
339
340 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
341 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
342 309789 by Sune Kloppenborg Jeppesen.
343
344 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
345 ruby-1.8.7_p249.ebuild:
346 Use $PVR instead of $PV in patchset names
347
348 06 May 2010; Alex Legler <a3li@gentoo.org>
349 -files/ruby-1.8.6-memory-leak.diff,
350 -files/ruby18-mkmf-parallel-install.patch,
351 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
352 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
353 Remove old version. Cleanup in files/
354
355*ruby-1.9.1_p376 (01 May 2010)
356
357 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
358 Version bump. Fixes security bugs 296052 and 300468. No longer installs
359 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
360 instead.
361
362 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
363 -ruby-1.8.7_p174-r1.ebuild:
364 Remove vulnerable ebuilds, 300468
365
366 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
367 ruby-1.8.7_p249.ebuild:
368 amd64 stable, security bug 300468
369
370 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
371 ruby-1.8.7_p249.ebuild:
372 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
373
374 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
375 Stable for HPPA (bug #300468).
376
377 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
378 Stable for HPPA (bug #300468).
379
380 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
381 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
382
383 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
384 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
385
386 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
387 ruby-1.8.6_p388.ebuild:
388 stable x86, security bug 300468
389
390 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
391 ruby-1.8.7_p249.ebuild:
392 stable x86, security bug 300468
393
394*ruby-1.8.6_p388 (10 Jan 2010)
395
396 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
397 +ruby-1.8.6_p388.ebuild:
398 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
399 version. The new ebuild also has the fix for bug 168939.
400
401*ruby-1.8.7_p249 (10 Jan 2010)
402
403 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
404 +ruby-1.8.7_p249.ebuild:
405 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
406 version
407
408 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
409 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
410
411*ruby-1.8.7_p248 (25 Dec 2009)
412
413 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
414 Version bump
415
416 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
417 Remove old version.
418
419 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
420 Remove old version.
421
422 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
423 ia64/s390/sh stable wrt #288699
424
425 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
426 stable sparc, bug 288699
427
428 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
429 arm stable, bug #288699
430
431 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
432 amd64/x86 stable, bug #288699
433
434 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
435 ruby-1.8.7_p174-r1.ebuild:
436 Stable on alpha, bug #288699
437
438 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
439 ppc stable #288699
440
441 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
442 Stable for HPPA (bug #288699).
443
444 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
445 Marked ~hppa too.
446
447*ruby-1.8.7_p174-r1 (06 Oct 2009)
448
449 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
450 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
451 eselect-ruby cleanup feature.
452
453*ruby-1.9.1_p243 (09 Sep 2009)
454
455 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
456 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
457 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
458 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
459 -files/ruby19-rubygems-proxy.patch,
460 -files/ruby-1.9.1_p129-parallelmake.patch,
461 -files/ruby19-mkmf-parallel-install.patch:
462 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
463 168939. Cleaning up old patches.
464
465*ruby-1.8.6_p383 (20 Aug 2009)
466
467 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
468 Patchlevel bump.
469
470 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
471 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
472 ruby-1.9.1_p129-r1.ebuild:
473 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
474
475 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
476 Removing vulnerable ebuild, bug 273213.
477
478 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
479 Marking ruby-1.8.6_p369 ppc for bug 273213
480
481 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
482 ruby-1.9.1_p129-r1.ebuild:
483 Prepend our library path instead of overwriting it during src_install.
484 Thanks to the reporter of bug #274824.
485
486*ruby-1.8.7_p174 (18 Jun 2009)
487
488 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
489 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
490 Replacing 187_p173 with _p174 because of a regression. Unifying the
491 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
492 patchsets.
493
494 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
495 Marking ruby-1.8.6_p369 ppc64 for bug 273213
496
497 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
498 arm/ia64/s390/sh/sparc stable wrt #273213
499
500 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
501 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
502 Removing old version, minor cleanup
503
504 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
505 -files/ruby-1.8.6-openssl.patch,
506 -files/ruby-1.8.6-shortname_constants.patch,
507 -files/ruby-1.8.6_p111-r13657.patch,
508 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
509 Removing vulnerable old Ruby version and stale patches, bug 274108.
510
511 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
512 ruby-1.8.6_p369.ebuild:
513 Stable on alpha, bug #273213
514
515 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
516 Stable for HPPA (bug #273213).
517
518 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
519 ruby-1.8.6_p369.ebuild:
520 stable x86, security bug 273213
521
522 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
523 amd64 stable, security bug 273213.
524
525*ruby-1.8.7_p173 (10 Jun 2009)
526*ruby-1.8.6_p369 (10 Jun 2009)
527
528 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
529 +ruby-1.8.7_p173.ebuild:
530 Version bumps for bug #273213.
531
532*ruby-1.9.1_p129-r1 (27 May 2009)
533
534 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
535 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
536 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
537 +files/ruby-1.9.1_p129-parallelmake.patch:
538 Revision bump, add patches 1) to make Ruby behave more similarly between
539 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
540 extensions (undefined symbols in them will cause abort at runtime 3) to
541 remove a concurrency issue when building the dl extension that could
542 result in a broken dl.so.
543
544 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
545 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
546 Don't block rdoc-2 or later (which may enter Portage one day as it's
547 needed by some Rakefiles).
548
549 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
550 ruby-1.9.1_p129.ebuild:
551 Add ~x86-fbsd keyword.
552
553 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
554 keyword ~sparc-fbsd, bug #252315
555
556*ruby-1.9.1_p129 (15 May 2009)
557
558 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
559 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
560 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
561 included in every release.
562
563 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
564 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
565 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
566 ruby-1.8.7_p160.ebuild:
567 Removing vulnerable versions (#268515), fixing license (#233747).
568
569 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
570 Stable for HPPA (bug #268515).
571
572 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
573 Adapting rubygems notice.
574
575 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
576 amd64 stable, bug #268515.
577
578 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
579 arm/ia64/s390/sh/sparc stable wrt #268515
580
581 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
582 ruby-1.8.6_p368.ebuild:
583 stable x86, security bug 268515
584
585 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
586 ruby-1.8.6_p368.ebuild:
587 Stable on alpha, bug #268515
588
589 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
590 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
591
592*ruby-1.8.7_p160 (07 May 2009)
593*ruby-1.8.6_p368 (07 May 2009)
594
595 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
596 +ruby-1.8.7_p160.ebuild:
597 Version bump as per secbug 268515. NB: These are the first ebuilds that
598 no longer use ruby-config.
599
600*ruby-1.9.1-r1 (03 Apr 2009)
601*ruby-1.8.7_p72-r11 (03 Apr 2009)
602*ruby-1.8.6_p287-r13 (03 Apr 2009)
603
604 03 Apr 2009; Alex Legler <a3li@gentoo.org>
605 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
606 +files/ruby18-mkmf-parallel-install.patch,
607 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
608 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
609 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
610 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
611 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
612 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
613 happy.
614
615*ruby-1.9.1 (21 Mar 2009)
616
617 21 Mar 2009; Alex Legler <a3li@gentoo.org>
618 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
619 +ruby-1.9.1.ebuild:
620 Adding Ruby 1.9.1 for preliminary testing
621
622 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
623 ruby-1.8.6_p287-r12.ebuild:
624 Marked ~ppc for bug #252315.
625
626 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
627 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
628 bug 261982.
629
630 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
631 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
632 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
633 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
634 Cleanup
635
636*ruby-1.8.7_p72-r10 (07 Mar 2009)
637
638 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
639 +ruby-1.8.7_p72-r10.ebuild:
640 Add a revision of ruby 1.8.7 using eselect ruby.
641
642 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
643 ~mips keyworded, bug #252315.
644
645 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
646 ruby-1.8.6_p287-r5.ebuild:
647 ppc stable, bug #260006
648
649 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
650 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
651
652 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
653 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
654 Fixing Tk USE flag test, bug 258893.
655
656 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
657 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
658
659 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
660 ruby-1.8.6_p287-r5.ebuild:
661 amd64 stable wrt security bug #260006
662
663 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
664 Stable for HPPA (bug #260006).
665
666 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
667 ruby-1.8.6_p287-r5.ebuild:
668 Stable on alpha, bug #260006
669
670*ruby-1.8.7_p72-r2 (23 Feb 2009)
671*ruby-1.8.6_p287-r12 (23 Feb 2009)
672*ruby-1.8.6_p287-r5 (23 Feb 2009)
673
674 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
675 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
676 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
677 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
678 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
679 now before compilation if Tk useflags don't match) and 230748 (adding
680 --enable-option-checking=no for newer versions of autoconf).
681
682 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
683 arm/ia64/s390/sh/sparc stable wrt #254307
684
685 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
686 ruby-1.8.6_p287-r4.ebuild:
687 Stable on alpha, bug #254307
688
689 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
690 ruby-1.8.6_p287-r11.ebuild:
691 keyword ~x86-fbsd, bug #252315
692
693 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
694 ppc stable #254307
695
696 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
697 amd64/x86 stable, bug #254307
698
699 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
700 stable ppc64, bug 254307
701
702 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
703 Stable for HPPA (bug #254307).
704
705 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
706 ruby-1.8.6_p287-r11.ebuild:
707 Marked ~hppa (bug #252315).
708
709*ruby-1.8.6_p287-r11 (11 Jan 2009)
710
711 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
712 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
713 +ruby-1.8.6_p287-r11.ebuild:
714 Backport conditional definition of missing openssl functions from ruby 1.8.7.
715 Fixes #254307.
716
717 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
718 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
719
720 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
721 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
722
723 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
724 ruby-1.8.6_p287-r10.ebuild:
725 Add ~sparc keyword, bug #252315
726
727*ruby-1.8.6_p287-r10 (23 Dec 2008)
728
729 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
730 +ruby-1.8.6_p287-r10.ebuild:
731 Version bump which switches from ruby-config to eselect-ruby. Dropped most
732 keywords since eselect-ruby does not yet have these keywords.
733
734 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
735 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
736 Revert the ruby-config changes. We can't remove them until we provide an
737 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
738 for breaking things as mentioned in bug #251833.
739
740 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
741 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
742 ruby-1.8.7_p72-r1.ebuild:
743 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
744 Thanks for the people noticing this in bug #251833.
745
746 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
747 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
748 ruby-1.8.7_p72-r1.ebuild:
749 Drop dependency on ruby-config, which will be removed from the tree. We
750 currently only have one major version of ruby in the tree (Ruby 1.8), so there
751 is no need for ruby-config at this moment. For newer versions of Ruby we will
752 use eselect-ruby, which can be found in the ruby overlay at the moment.
753
754 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
755 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
756 Use mirror://ruby in SRC_URI, fixes #237392.
757
758 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
759 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
760 -ruby-1.8.7_p72.ebuild:
761 Remove old versions. Leave one old stable version with cjk support.
762
763*ruby-1.8.6_p287-r3 (29 Nov 2008)
764
765 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
766 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
767 +ruby-1.8.6_p287-r3.ebuild:
768 Fix our expansion limit patch according to debian bug report
769 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
770 make sure people will pick up the fixed version. Thanks to Alex Legler for
771 mentioning the patch.
772
773*ruby-1.8.7_p72-r1 (26 Nov 2008)
774*ruby-1.8.6_p287-r2 (26 Nov 2008)
775
776 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
777 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
778 +ruby-1.8.7_p72-r1.ebuild:
779 Fix problem with shortname constants #247790, already fixed in upstream SVN.
780 Thanks to Alex Legler for providing the patch.
781
782 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
783 -ruby-1.8.6_p287.ebuild:
784 Remove versions that will not become stable
785
786 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
787 ruby-1.8.6_p287-r1.ebuild:
788 ppc stable, bug #225465
789
790 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
791 ruby-1.8.6_p287-r1.ebuild:
792 amd64 stable wrt security bug #225465
793
794 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
795 alpha/ia64/x86 stable wrt #225465
796
797 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
798 ruby-1.8.6_p287-r1.ebuild:
799 Sparc stable --- Security Bug #225465 --- good since late August.
800
801 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
802 Stable on ppc64; bug #225465
803
804 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
805 Stable for HPPA (bug #225465).
806
807*ruby-1.8.6_p287-r1 (29 Aug 2008)
808
809 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
810 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
811 +ruby-1.8.6_p287-r1.ebuild:
812 Fix REXML security issues, bug #236060.
813
814 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
815 Add GLEP 56 USE flag descriptions.
816
817*ruby-1.8.7_p72 (15 Aug 2008)
818
819 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
820 +ruby-1.8.7_p72.ebuild:
821 bump 1.8.7 to latest patch release
822
823*ruby-1.8.6_p287 (11 Aug 2008)
824
825 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
826 Version bump for brown paper bag relelease.
827
828 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
829 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
830 Remove broken version in favor of the just-added 1.8.6_p286
831
832*ruby-1.8.6_p286 (10 Aug 2008)
833
834 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
835 Version bump to latest released version of ruby 1.8.6. This version fixes the
836 security issues reported in #225465 and #234224. The cjk USE flag has been
837 dropped since no compatible patches have been released yet.
838
839 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
840 ruby-1.8.6_p230.ebuild:
841 drop cjk from SRC_URI as well
842
843 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
844 Drop cjk support since the most recent oniguruma patches no longer apply to
845 this version, #230111.
846
847 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
848 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
849 Try to fix the security issues reported in #225465 for ruby 1.8.6.
850 Unfortunately the official p230 has a change which causes segmentation faults
851 for applications like Rails and RSpec, so we are reverting that specific
852 change.
853
854*ruby-1.8.7_p22 (29 Jun 2008)
855
856 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
857 +ruby-1.8.7_p22.ebuild:
858 bump 1.8.7 for security fix
859
860 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
861 nevermind, don't bump this yet
862
863*ruby-1.8.6_p230 (20 Jun 2008)
864
865 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
866 version bump
867
868*ruby-1.8.7 (10 Jun 2008)
869
870 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
871 +ruby-1.8.7.ebuild:
872 bump 1.8.7 to final
873
874*ruby-1.8.7_pre2 (21 Apr 2008)
875
876 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
877 +ruby-1.8.7_pre2.ebuild:
878 Version Bump
879
880*ruby-1.8.7_pre1 (16 Apr 2008)
881
882 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
883 Version bump. Drop cjk until a new version of oniguruma appears.
884
885 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
886 amd64 stable, bug 212264
887
888 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
889 Stable for HPPA (bug #212264).
890
891 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
892 ruby-1.8.6_p114.ebuild:
893 ppc stable, bug #212264
894
895 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
896 alpha/ia64 stable wrt #212264
897
898 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
899 ruby-1.8.6_p114.ebuild:
900 stable x86, security bug 212264
901
902 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
903 Sparc stable, Security Bug #212264, builds and installs, initial tests run
904 as expected.
905
906 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
907 Marking ruby-1.8.6_p114 ppc64 for bug 212264
908
909*ruby-1.8.6_p114 (05 Mar 2008)
910
911 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
912 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
913 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
914 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
915 Version bump for #212264. Remove old ebuilds.
916
917 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
918 alpha/ia64 stable wrt #208916
919
920 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
921 Stable on ppc wrt bug 208916
922
923 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
924 x86 stable, bug #208916
925
926 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
927 ruby-1.8.6_p111-r1.ebuild:
928 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
929
930 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
931 -files/ruby-1.8.6-exit-status.patch,
932 -files/ruby-1.8.6_p110-net-http-p111.patch,
933 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
934 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
935 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
936 Remove old versions
937
938 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
939 Stable on ppc64
940
941 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
942 Stable on amd64; bug 199191
943
944 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
945 alpha/ia64/sparc stable wrt #199191
946
947 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
948 Remove now-obsolete warning about coreutils versions, #203156.
949
950 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
951 Stable for HPPA (bug #199191).
952
953*ruby-1.8.6_p111-r1 (23 Dec 2007)
954
955 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
956 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
957 ssl USE flags. Patch to p113.
958
959 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
960 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
961
962 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
963 x86 stable, security bug #199191
964
965*ruby-1.8.6_p111 (23 Dec 2007)
966
967 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
968 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
969 Version bump with patch for bug #199191
970
971 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
972 Move dependency on (X)Emacs modes to PDEPEND.
973
974 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
975 Add back ~hppa keyword now that XEmacs support files have been keyworded,
976 bug 196413
977
978*ruby-1.8.6_p110-r2 (21 Oct 2007)
979
980 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
981 +ruby-1.8.6_p110-r2.ebuild:
982 Add emacs and xemacs USE flags and use them to pull in the correct editing
983 mode for each. Had to drop several arch keywords as reported on bug 196413.
984
985 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
986 amd64 stable, security bug 194236
987
988 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
989 ruby-1.8.6_p110-r1.ebuild:
990 Stable on ppc64; bug #194236
991
992 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
993 amd64 stable, security bug 194236
994
995 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
996 Stable for HPPA (bug #194236).
997
998 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
999 alpha/ia64/sparc stable wrt security #194236
1000
1001 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1002 ruby-1.8.6_p110-r1.ebuild:
1003 ppc stable, bug #194236
1004
1005 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1006 ruby-1.8.6_p110-r1.ebuild:
1007 stable x86, security bug 194236
1008
1009 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1010 ruby-1.8.5_p113.ebuild:
1011 stable x86, security bug 194236
1012
1013 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1014 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1015 -ruby-1.8.6_p110.ebuild:
1016 Remove old versions
1017
1018*ruby-1.8.6_p110-r1 (30 Sep 2007)
1019*ruby-1.8.5_p113 (30 Sep 2007)
1020
1021 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1022 +files/ruby-1.8.5_p113-net-http-p114.patch,
1023 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1024 +ruby-1.8.6_p110-r1.ebuild:
1025 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1026 using 1.8.6-p110 as base ebuild.
4 1027
5 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild: 1028 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
6 More fixes from gentoo-dev and graaff 1029 More fixes from gentoo-dev and graaff
7 1030
8 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild: 1031 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:

Legend:
Removed from v.1.297  
changed lines
  Added in v.1.529

  ViewVC Help
Powered by ViewVC 1.1.20