/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.307 Revision 1.346
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.307 2007/10/13 02:47:26 beandog Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.346 2008/08/23 05:41:32 jer Exp $
4
5 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
6 Add GLEP 56 USE flag descriptions.
7
8*ruby-1.8.7_p72 (15 Aug 2008)
9
10 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
11 +ruby-1.8.7_p72.ebuild:
12 bump 1.8.7 to latest patch release
13
14*ruby-1.8.6_p287 (11 Aug 2008)
15
16 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
17 Version bump for brown paper bag relelease.
18
19 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
20 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
21 Remove broken version in favor of the just-added 1.8.6_p286
22
23*ruby-1.8.6_p286 (10 Aug 2008)
24
25 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
26 Version bump to latest released version of ruby 1.8.6. This version fixes the
27 security issues reported in #225465 and #234224. The cjk USE flag has been
28 dropped since no compatible patches have been released yet.
29
30 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
31 ruby-1.8.6_p230.ebuild:
32 drop cjk from SRC_URI as well
33
34 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
35 Drop cjk support since the most recent oniguruma patches no longer apply to
36 this version, #230111.
37
38 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
39 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
40 Try to fix the security issues reported in #225465 for ruby 1.8.6.
41 Unfortunately the official p230 has a change which causes segmentation faults
42 for applications like Rails and RSpec, so we are reverting that specific
43 change.
44
45*ruby-1.8.7_p22 (29 Jun 2008)
46
47 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
48 +ruby-1.8.7_p22.ebuild:
49 bump 1.8.7 for security fix
50
51 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
52 nevermind, don't bump this yet
53
54*ruby-1.8.6_p230 (20 Jun 2008)
55
56 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
57 version bump
58
59*ruby-1.8.7 (10 Jun 2008)
60
61 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
62 +ruby-1.8.7.ebuild:
63 bump 1.8.7 to final
64
65*ruby-1.8.7_pre2 (21 Apr 2008)
66
67 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
68 +ruby-1.8.7_pre2.ebuild:
69 Version Bump
70
71*ruby-1.8.7_pre1 (16 Apr 2008)
72
73 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
74 Version bump. Drop cjk until a new version of oniguruma appears.
75
76 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
77 amd64 stable, bug 212264
78
79 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
80 Stable for HPPA (bug #212264).
81
82 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
83 ruby-1.8.6_p114.ebuild:
84 ppc stable, bug #212264
85
86 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
87 alpha/ia64 stable wrt #212264
88
89 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
90 ruby-1.8.6_p114.ebuild:
91 stable x86, security bug 212264
92
93 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
94 Sparc stable, Security Bug #212264, builds and installs, initial tests run
95 as expected.
96
97 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
98 Marking ruby-1.8.6_p114 ppc64 for bug 212264
99
100*ruby-1.8.6_p114 (05 Mar 2008)
101
102 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
103 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
104 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
105 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
106 Version bump for #212264. Remove old ebuilds.
107
108 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
109 alpha/ia64 stable wrt #208916
110
111 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
112 Stable on ppc wrt bug 208916
113
114 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
115 x86 stable, bug #208916
116
117 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
118 ruby-1.8.6_p111-r1.ebuild:
119 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
120
121 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
122 -files/ruby-1.8.6-exit-status.patch,
123 -files/ruby-1.8.6_p110-net-http-p111.patch,
124 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
125 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
126 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
127 Remove old versions
128
129 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
130 Stable on ppc64
131
132 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
133 Stable on amd64; bug 199191
134
135 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
136 alpha/ia64/sparc stable wrt #199191
137
138 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
139 Remove now-obsolete warning about coreutils versions, #203156.
140
141 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
142 Stable for HPPA (bug #199191).
143
144*ruby-1.8.6_p111-r1 (23 Dec 2007)
145
146 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
147 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
148 ssl USE flags. Patch to p113.
149
150 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
151 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
152
153 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
154 x86 stable, security bug #199191
155
156*ruby-1.8.6_p111 (23 Dec 2007)
157
158 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
159 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
160 Version bump with patch for bug #199191
161
162 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
163 Move dependency on (X)Emacs modes to PDEPEND.
164
165 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
166 Add back ~hppa keyword now that XEmacs support files have been keyworded,
167 bug 196413
168
169*ruby-1.8.6_p110-r2 (21 Oct 2007)
170
171 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
172 +ruby-1.8.6_p110-r2.ebuild:
173 Add emacs and xemacs USE flags and use them to pull in the correct editing
174 mode for each. Had to drop several arch keywords as reported on bug 196413.
4 175
5 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild: 176 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
6 amd64 stable, security bug 194236 177 amd64 stable, security bug 194236
7 178
8 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild, 179 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,

Legend:
Removed from v.1.307  
changed lines
  Added in v.1.346

  ViewVC Help
Powered by ViewVC 1.1.20