/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.307 Revision 1.357
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.307 2007/10/13 02:47:26 beandog Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.357 2008/12/21 09:01:59 graaff Exp $
4
5 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
6 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
7 -ruby-1.8.7_p72.ebuild:
8 Remove old versions. Leave one old stable version with cjk support.
9
10*ruby-1.8.6_p287-r3 (29 Nov 2008)
11
12 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
13 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
14 +ruby-1.8.6_p287-r3.ebuild:
15 Fix our expansion limit patch according to debian bug report
16 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
17 make sure people will pick up the fixed version. Thanks to Alex Legler for
18 mentioning the patch.
19
20*ruby-1.8.7_p72-r1 (26 Nov 2008)
21*ruby-1.8.6_p287-r2 (26 Nov 2008)
22
23 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
24 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
25 +ruby-1.8.7_p72-r1.ebuild:
26 Fix problem with shortname constants #247790, already fixed in upstream SVN.
27 Thanks to Alex Legler for providing the patch.
28
29 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
30 -ruby-1.8.6_p287.ebuild:
31 Remove versions that will not become stable
32
33 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
34 ruby-1.8.6_p287-r1.ebuild:
35 ppc stable, bug #225465
36
37 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
38 ruby-1.8.6_p287-r1.ebuild:
39 amd64 stable wrt security bug #225465
40
41 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
42 alpha/ia64/x86 stable wrt #225465
43
44 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
45 ruby-1.8.6_p287-r1.ebuild:
46 Sparc stable --- Security Bug #225465 --- good since late August.
47
48 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
49 Stable on ppc64; bug #225465
50
51 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
52 Stable for HPPA (bug #225465).
53
54*ruby-1.8.6_p287-r1 (29 Aug 2008)
55
56 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
57 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
58 +ruby-1.8.6_p287-r1.ebuild:
59 Fix REXML security issues, bug #236060.
60
61 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
62 Add GLEP 56 USE flag descriptions.
63
64*ruby-1.8.7_p72 (15 Aug 2008)
65
66 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
67 +ruby-1.8.7_p72.ebuild:
68 bump 1.8.7 to latest patch release
69
70*ruby-1.8.6_p287 (11 Aug 2008)
71
72 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
73 Version bump for brown paper bag relelease.
74
75 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
76 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
77 Remove broken version in favor of the just-added 1.8.6_p286
78
79*ruby-1.8.6_p286 (10 Aug 2008)
80
81 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
82 Version bump to latest released version of ruby 1.8.6. This version fixes the
83 security issues reported in #225465 and #234224. The cjk USE flag has been
84 dropped since no compatible patches have been released yet.
85
86 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
87 ruby-1.8.6_p230.ebuild:
88 drop cjk from SRC_URI as well
89
90 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
91 Drop cjk support since the most recent oniguruma patches no longer apply to
92 this version, #230111.
93
94 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
95 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
96 Try to fix the security issues reported in #225465 for ruby 1.8.6.
97 Unfortunately the official p230 has a change which causes segmentation faults
98 for applications like Rails and RSpec, so we are reverting that specific
99 change.
100
101*ruby-1.8.7_p22 (29 Jun 2008)
102
103 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
104 +ruby-1.8.7_p22.ebuild:
105 bump 1.8.7 for security fix
106
107 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
108 nevermind, don't bump this yet
109
110*ruby-1.8.6_p230 (20 Jun 2008)
111
112 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
113 version bump
114
115*ruby-1.8.7 (10 Jun 2008)
116
117 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
118 +ruby-1.8.7.ebuild:
119 bump 1.8.7 to final
120
121*ruby-1.8.7_pre2 (21 Apr 2008)
122
123 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
124 +ruby-1.8.7_pre2.ebuild:
125 Version Bump
126
127*ruby-1.8.7_pre1 (16 Apr 2008)
128
129 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
130 Version bump. Drop cjk until a new version of oniguruma appears.
131
132 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
133 amd64 stable, bug 212264
134
135 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
136 Stable for HPPA (bug #212264).
137
138 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
139 ruby-1.8.6_p114.ebuild:
140 ppc stable, bug #212264
141
142 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
143 alpha/ia64 stable wrt #212264
144
145 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
146 ruby-1.8.6_p114.ebuild:
147 stable x86, security bug 212264
148
149 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
150 Sparc stable, Security Bug #212264, builds and installs, initial tests run
151 as expected.
152
153 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
154 Marking ruby-1.8.6_p114 ppc64 for bug 212264
155
156*ruby-1.8.6_p114 (05 Mar 2008)
157
158 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
159 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
160 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
161 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
162 Version bump for #212264. Remove old ebuilds.
163
164 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
165 alpha/ia64 stable wrt #208916
166
167 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
168 Stable on ppc wrt bug 208916
169
170 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
171 x86 stable, bug #208916
172
173 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
174 ruby-1.8.6_p111-r1.ebuild:
175 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
176
177 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
178 -files/ruby-1.8.6-exit-status.patch,
179 -files/ruby-1.8.6_p110-net-http-p111.patch,
180 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
181 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
182 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
183 Remove old versions
184
185 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
186 Stable on ppc64
187
188 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
189 Stable on amd64; bug 199191
190
191 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
192 alpha/ia64/sparc stable wrt #199191
193
194 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
195 Remove now-obsolete warning about coreutils versions, #203156.
196
197 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
198 Stable for HPPA (bug #199191).
199
200*ruby-1.8.6_p111-r1 (23 Dec 2007)
201
202 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
203 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
204 ssl USE flags. Patch to p113.
205
206 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
207 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
208
209 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
210 x86 stable, security bug #199191
211
212*ruby-1.8.6_p111 (23 Dec 2007)
213
214 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
215 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
216 Version bump with patch for bug #199191
217
218 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
219 Move dependency on (X)Emacs modes to PDEPEND.
220
221 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
222 Add back ~hppa keyword now that XEmacs support files have been keyworded,
223 bug 196413
224
225*ruby-1.8.6_p110-r2 (21 Oct 2007)
226
227 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
228 +ruby-1.8.6_p110-r2.ebuild:
229 Add emacs and xemacs USE flags and use them to pull in the correct editing
230 mode for each. Had to drop several arch keywords as reported on bug 196413.
4 231
5 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild: 232 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
6 amd64 stable, security bug 194236 233 amd64 stable, security bug 194236
7 234
8 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild, 235 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,

Legend:
Removed from v.1.307  
changed lines
  Added in v.1.357

  ViewVC Help
Powered by ViewVC 1.1.20