/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.307 Revision 1.364
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.307 2007/10/13 02:47:26 beandog Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.364 2008/12/26 19:07:09 armin76 Exp $
4
5 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
6 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
7
8 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
9 ruby-1.8.6_p287-r10.ebuild:
10 Add ~sparc keyword, bug #252315
11
12*ruby-1.8.6_p287-r10 (23 Dec 2008)
13
14 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
15 +ruby-1.8.6_p287-r10.ebuild:
16 Version bump which switches from ruby-config to eselect-ruby. Dropped most
17 keywords since eselect-ruby does not yet have these keywords.
18
19 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
20 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
21 Revert the ruby-config changes. We can't remove them until we provide an
22 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
23 for breaking things as mentioned in bug #251833.
24
25 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
26 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
27 ruby-1.8.7_p72-r1.ebuild:
28 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
29 Thanks for the people noticing this in bug #251833.
30
31 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
32 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
33 ruby-1.8.7_p72-r1.ebuild:
34 Drop dependency on ruby-config, which will be removed from the tree. We
35 currently only have one major version of ruby in the tree (Ruby 1.8), so there
36 is no need for ruby-config at this moment. For newer versions of Ruby we will
37 use eselect-ruby, which can be found in the ruby overlay at the moment.
38
39 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
40 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
41 Use mirror://ruby in SRC_URI, fixes #237392.
42
43 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
44 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
45 -ruby-1.8.7_p72.ebuild:
46 Remove old versions. Leave one old stable version with cjk support.
47
48*ruby-1.8.6_p287-r3 (29 Nov 2008)
49
50 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
51 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
52 +ruby-1.8.6_p287-r3.ebuild:
53 Fix our expansion limit patch according to debian bug report
54 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
55 make sure people will pick up the fixed version. Thanks to Alex Legler for
56 mentioning the patch.
57
58*ruby-1.8.7_p72-r1 (26 Nov 2008)
59*ruby-1.8.6_p287-r2 (26 Nov 2008)
60
61 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
62 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
63 +ruby-1.8.7_p72-r1.ebuild:
64 Fix problem with shortname constants #247790, already fixed in upstream SVN.
65 Thanks to Alex Legler for providing the patch.
66
67 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
68 -ruby-1.8.6_p287.ebuild:
69 Remove versions that will not become stable
70
71 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
72 ruby-1.8.6_p287-r1.ebuild:
73 ppc stable, bug #225465
74
75 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
76 ruby-1.8.6_p287-r1.ebuild:
77 amd64 stable wrt security bug #225465
78
79 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
80 alpha/ia64/x86 stable wrt #225465
81
82 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
83 ruby-1.8.6_p287-r1.ebuild:
84 Sparc stable --- Security Bug #225465 --- good since late August.
85
86 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
87 Stable on ppc64; bug #225465
88
89 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
90 Stable for HPPA (bug #225465).
91
92*ruby-1.8.6_p287-r1 (29 Aug 2008)
93
94 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
95 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
96 +ruby-1.8.6_p287-r1.ebuild:
97 Fix REXML security issues, bug #236060.
98
99 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
100 Add GLEP 56 USE flag descriptions.
101
102*ruby-1.8.7_p72 (15 Aug 2008)
103
104 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
105 +ruby-1.8.7_p72.ebuild:
106 bump 1.8.7 to latest patch release
107
108*ruby-1.8.6_p287 (11 Aug 2008)
109
110 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
111 Version bump for brown paper bag relelease.
112
113 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
114 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
115 Remove broken version in favor of the just-added 1.8.6_p286
116
117*ruby-1.8.6_p286 (10 Aug 2008)
118
119 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
120 Version bump to latest released version of ruby 1.8.6. This version fixes the
121 security issues reported in #225465 and #234224. The cjk USE flag has been
122 dropped since no compatible patches have been released yet.
123
124 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
125 ruby-1.8.6_p230.ebuild:
126 drop cjk from SRC_URI as well
127
128 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
129 Drop cjk support since the most recent oniguruma patches no longer apply to
130 this version, #230111.
131
132 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
133 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
134 Try to fix the security issues reported in #225465 for ruby 1.8.6.
135 Unfortunately the official p230 has a change which causes segmentation faults
136 for applications like Rails and RSpec, so we are reverting that specific
137 change.
138
139*ruby-1.8.7_p22 (29 Jun 2008)
140
141 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
142 +ruby-1.8.7_p22.ebuild:
143 bump 1.8.7 for security fix
144
145 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
146 nevermind, don't bump this yet
147
148*ruby-1.8.6_p230 (20 Jun 2008)
149
150 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
151 version bump
152
153*ruby-1.8.7 (10 Jun 2008)
154
155 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
156 +ruby-1.8.7.ebuild:
157 bump 1.8.7 to final
158
159*ruby-1.8.7_pre2 (21 Apr 2008)
160
161 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
162 +ruby-1.8.7_pre2.ebuild:
163 Version Bump
164
165*ruby-1.8.7_pre1 (16 Apr 2008)
166
167 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
168 Version bump. Drop cjk until a new version of oniguruma appears.
169
170 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
171 amd64 stable, bug 212264
172
173 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
174 Stable for HPPA (bug #212264).
175
176 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
177 ruby-1.8.6_p114.ebuild:
178 ppc stable, bug #212264
179
180 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
181 alpha/ia64 stable wrt #212264
182
183 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
184 ruby-1.8.6_p114.ebuild:
185 stable x86, security bug 212264
186
187 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
188 Sparc stable, Security Bug #212264, builds and installs, initial tests run
189 as expected.
190
191 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
192 Marking ruby-1.8.6_p114 ppc64 for bug 212264
193
194*ruby-1.8.6_p114 (05 Mar 2008)
195
196 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
197 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
198 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
199 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
200 Version bump for #212264. Remove old ebuilds.
201
202 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
203 alpha/ia64 stable wrt #208916
204
205 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
206 Stable on ppc wrt bug 208916
207
208 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
209 x86 stable, bug #208916
210
211 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
212 ruby-1.8.6_p111-r1.ebuild:
213 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
214
215 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
216 -files/ruby-1.8.6-exit-status.patch,
217 -files/ruby-1.8.6_p110-net-http-p111.patch,
218 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
219 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
220 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
221 Remove old versions
222
223 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
224 Stable on ppc64
225
226 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
227 Stable on amd64; bug 199191
228
229 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
230 alpha/ia64/sparc stable wrt #199191
231
232 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
233 Remove now-obsolete warning about coreutils versions, #203156.
234
235 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
236 Stable for HPPA (bug #199191).
237
238*ruby-1.8.6_p111-r1 (23 Dec 2007)
239
240 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
241 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
242 ssl USE flags. Patch to p113.
243
244 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
245 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
246
247 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
248 x86 stable, security bug #199191
249
250*ruby-1.8.6_p111 (23 Dec 2007)
251
252 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
253 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
254 Version bump with patch for bug #199191
255
256 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
257 Move dependency on (X)Emacs modes to PDEPEND.
258
259 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
260 Add back ~hppa keyword now that XEmacs support files have been keyworded,
261 bug 196413
262
263*ruby-1.8.6_p110-r2 (21 Oct 2007)
264
265 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
266 +ruby-1.8.6_p110-r2.ebuild:
267 Add emacs and xemacs USE flags and use them to pull in the correct editing
268 mode for each. Had to drop several arch keywords as reported on bug 196413.
4 269
5 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild: 270 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
6 amd64 stable, security bug 194236 271 amd64 stable, security bug 194236
7 272
8 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild, 273 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,

Legend:
Removed from v.1.307  
changed lines
  Added in v.1.364

  ViewVC Help
Powered by ViewVC 1.1.20