/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.329 Revision 1.667
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.329 2008/03/05 18:19:47 armin76 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.667 2014/09/20 21:10:55 ago Exp $
4
5 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
6 ruby-2.0.0_p481.ebuild:
7 Stable for ppc, wrt bug #512904
8
9 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
10 ruby-2.0.0_p481.ebuild:
11 Stable for amd64, wrt bug #512904
12
13*ruby-2.1.3 (20 Sep 2014)
14
15 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
16 Version bump:
17 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
18
19*ruby-2.0.0_p576 (20 Sep 2014)
20
21 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
22 Version bump.
23
24 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
25 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
26 Depend on the rubygems virtual with an explicit SLOT now that the specific
27 rubygems versions are listed in virtual/rubygems. This will make the
28 dependencies more explicit and should decrease resolver surprises picking the
29 wrong virtual/rubygems SLOT later on.
30
31 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
32 Cleanup.
33
34 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
35 ruby-2.0.0_p481.ebuild:
36 x86 stable wrt bug #512904
37
38 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
39 Stable on alpha, bug #512904
40
41 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
42 arm stable, bug #512904
43
44 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
45 arm stable, bug #512904
46
47 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
48 ruby-2.0.0_p481.ebuild:
49 ia64 stable wrt bug #512904
50
51 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
52 Stable for HPPA (bug #512904).
53
54 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
55 Stable for HPPA (bug #512904).
56
57 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
58 -ruby-2.1.1-r1.ebuild:
59 Cleanup.
60
61 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
62 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
63 512848.
64
65*ruby-1.9.3_p547 (17 May 2014)
66
67 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
68 Version bump.
69
70*ruby-2.1.2 (10 May 2014)
71*ruby-2.0.0_p481 (10 May 2014)
72
73 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
74 +ruby-2.1.2.ebuild:
75 Version bump.
76
77 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
78 -ruby-2.0.0_p353-r2.ebuild:
79 Cleanup.
80
81 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
82 ruby-2.1.1-r1.ebuild:
83 Remove useless libruby symlinks, bug 503584.
84
85 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
86 -ruby-2.1.1.ebuild:
87 Cleanup.
88
89 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
90 Remove unneeded useflag descriptions from metadata.xml
91
92 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
93 -ruby-1.8.7_p374.ebuild:
94 Remove Ruby 1.8. See bug #434064.
95
96*ruby-2.1.1-r1 (14 Apr 2014)
97
98 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
99 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
100 Thanks to Andrew Savchenko for providing a patch.
101
102 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
103 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
104 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
105 ruby-2.1.1.ebuild:
106 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
107
108*ruby-2.1.1 (06 Mar 2014)
109
110 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
111 Version bump. Update module selection code to fix automagic dependencies.
112 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
113 503106.
114
115*ruby-2.0.0_p451 (05 Mar 2014)
116
117 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
118 Version bump. Update module selection code to fix automagic dependencies.
119 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
120 503106.
121
122*ruby-1.9.3_p545 (26 Feb 2014)
123
124 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
125 Version bump. Drop tk USE flag due to bug 500894.
126
127*ruby-2.0.0_p353-r2 (23 Feb 2014)
128
129 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
130 Backport support for uclibc, fixing bug 484534.
131
132 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
133 Stable for alpha, wrt bug #483254
134
135 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
136 Stable for sparc, wrt bug #483254
137
138 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
139 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
140 Fix slot conflicts, #498970
141
142 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
143 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
144 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
145 bug 497130.
146
147 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
148 -ruby-1.9.3_p448-r1.ebuild:
149 Remove vulnerable versions.
150
151 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
152 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
153 Remove vulnerable versions.
154
155 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
156 arm stable, bug #492282
157
158*ruby-2.0.0_p353-r1 (03 Jan 2014)
159
160 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
161 ruby-2.1.0.ebuild:
162 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
163
164 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
165 arm stable, bug #483254
166
167 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
168 ruby-2.0.0_p353.ebuild:
169 ia64 stable wrt bug #492282
170
171*ruby-2.1.0 (26 Dec 2013)
172
173 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
174 Version bump.
175
176 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
177 ia64 stable wrt bug #483254
178
179 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
180 Stable for sparc, wrt bug #492282
181
182 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
183 Stable for arm, wrt bug #492282
184
185 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
186 Stable for alpha, wrt bug #492282
187
188 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
189 ruby-2.0.0_p353.ebuild:
190 Stable for x86, wrt bug #492282
191
192 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
193 ruby-2.0.0_p353.ebuild:
194 Stable for ppc64, wrt bug #492282
195
196 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
197 ruby-2.0.0_p353.ebuild:
198 Stable for ppc, wrt bug #492282
199
200 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
201 Stable for ppc64, wrt bug #483254
202
203 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
204 Stable for ppc, wrt bug #483254
205
206 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
207 ruby-2.0.0_p353.ebuild:
208 Stable for amd64, wrt bug #492282
209
210 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
211 Stable for HPPA (bug #492282).
212
213 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
214 Stable for HPPA (bug #492282).
215
216*ruby-2.0.0_p353 (22 Nov 2013)
217*ruby-1.9.3_p484 (22 Nov 2013)
218
219 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
220 +ruby-2.0.0_p353.ebuild:
221 Version bumps for security bug 492282.
222
223*ruby-2.0.0_p247-r2 (14 Oct 2013)
224
225 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
226 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
227 2.x. Fixes bug 483466.
228
229 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
230 -ruby-1.9.3_p429.ebuild:
231 Cleanup.
232
233 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
234 Stable for HPPA (bug #483254).
235
236 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
237 Stable for x86, wrt bug #483254
238
239 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
240 Stable for amd64, wrt bug #483254
241
242 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
243 ruby-1.9.3_p448.ebuild:
244 Stable for s390, wrt bug #475074
245
246*ruby-2.0.0_p247-r1 (29 Jul 2013)
247*ruby-1.9.3_p448-r1 (29 Jul 2013)
248*ruby-1.8.7_p374-r1 (29 Jul 2013)
249
250 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
251 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
252 Revision bump to counter breakage introduced in portage 2.1.13 for bug
253 465000. Thanks to thansen for reporting.
254
255 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
256 ruby-1.9.3_p448.ebuild:
257 Stable for sparc, wrt bug #475074
258
259 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
260 ruby-1.9.3_p448.ebuild:
261 Stable for sh, wrt bug #475074
262
263 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
264 ruby-1.9.3_p448.ebuild:
265 Stable for ia64, wrt bug #475074
266
267*ruby-2.0.0_p247 (07 Jul 2013)
268
269 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
270 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
271 ruby20.
272
273 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
274 ruby-1.9.3_p448.ebuild:
275 Stable for alpha, wrt bug #475074
276
277 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
278 ruby-1.9.3_p448.ebuild:
279 Stable for ppc64, wrt bug #475074
280
281 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
282 ruby-1.9.3_p448.ebuild:
283 Stable for HPPA (bug #475074).
284
285 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
286 ruby-1.9.3_p448.ebuild:
287 Stable for ppc, wrt bug #475074
288
289 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
290 ruby-1.9.3_p448.ebuild:
291 Stable for arm, wrt bug #475074
292
293 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
294 ruby-1.9.3_p448.ebuild:
295 Stable for x86, wrt bug #475074
296
297 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
298 ruby-1.9.3_p448.ebuild:
299 Stable for amd64, wrt bug #475074
300
301*ruby-1.9.3_p448 (30 Jun 2013)
302*ruby-1.8.7_p374 (30 Jun 2013)
303
304 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
305 +ruby-1.9.3_p448.ebuild:
306 Version bumps for security bug 475074.
307
308 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
309 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
310 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
311 Cleanup. Remove vulnerable versions.
312
313 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
314 Stable for sh, wrt bug #469984
315
316 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
317 Stable for s390, wrt bug #469984
318
319 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
320 Stable for ppc64, wrt bug #469984
321
322 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
323 Stable for ia64, wrt bug #469984
324
325 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
326 Stable for alpha, wrt bug #469984
327
328 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
329 Stable for sparc, wrt bug #469984
330
331 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
332 Remove non-functional dosym calls, bug 442462.
333
334 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
335 Stable for arm, wrt bug #469984
336
337 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
338 Stable for ppc, wrt bug #469984
339
340 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
341 Stable for x86, wrt bug #469984
342
343 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
344 Stable for amd64, wrt bug #469984
345
346 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
347 Stable for HPPA (bug #469984).
348
349*ruby-1.9.3_p429 (16 May 2013)
350
351 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
352 Version bump for security bug #469984.
353
354 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
355 Stable for s390, wrt bug #437366
356
357 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
358 Stable for sparc, wrt bug #437366
359
360 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
361 Stable for ia64, wrt bug #437366
362
363 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
364 Stable for alpha, wrt bug #437366
365
366 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
367 Stable for ppc64, wrt bug #437366
368
369 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
370 Stable for arm, wrt bug #437366
371
372 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
373 Stable for sh, wrt bug #437366
374
375 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
376 Marking ruby-1.8.7_p371 ppc for bug 437366
377
378 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
379 Stable for HPPA (bug #437366).
380
381 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
382 Stable for x86, wrt bug #437366
383
384 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
385 Stable for amd64, wrt bug #437366
386
387 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
388 Stable for sh, wrt bug #458776
389
390 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
391 Stable for alpha, wrt bug #458776
392
393 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
394 Add patch to fix bug #459074 (parallel build).
395
396 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
397 Stable for arm, wrt bug #458776
398
399 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
400 Stable for s390, wrt bug #458776
401
402 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
403 Stable for sparc, wrt bug #458776
404
405 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
406 Stable for hppa, wrt bug #458776
407
408 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
409 Stable for ia64, wrt bug #458776
410
411 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
412 Stable for x86, wrt bug #458776
413
414 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
415 Stable for amd64, wrt bug #458776
416
417 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
418 Stable for ppc64, wrt bug #458776
419
420 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
421 Stable for ppc, wrt bug #458776
422
423*ruby-1.9.3_p392 (22 Feb 2013)
424
425 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
426 Version bump for security bug 458776.
427
428*ruby-1.9.3_p385 (10 Feb 2013)
429
430 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
431 Version bump. Fixes security bug 442580.
432
433 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
434 keyword ~amd64-fbsd
435
436*ruby-1.8.7_p371 (06 Jan 2013)
437
438 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
439 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
440 Version bump for security bug 437366.
441
442 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
443 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
444 Cleanup.
445
446 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
447 Stable for ppc, wrt bug #427774
448
449 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
450 Stable for HPPA (bug #411507).
451
452 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
453 alpha/ia64/s390/sh/sparc stable wrt #434480
454
455 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
456 ruby-1.9.3_p286.ebuild:
457 Remove HPPA target hack (bug #342819).
458
459 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
460 alpha/ia64/s390/sh/sparc stable wrt #411507
461
462 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
463 Stable for HPPA (bug #434480).
464
465*ruby-1.9.3_p286 (15 Oct 2012)
466
467 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
468 Version bump. Fixes bugs #437264 and #437264.
469
470 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
471 stable arm, bug #434480
472
473 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
474 stable ppc ppc64, bug #434480
475
476 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
477 Stable for x86, wrt bug #434480
478
479 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
480 ruby-1.9.3_p194-r1.ebuild:
481 Update LICENSE, bug 434332.
482
483 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
484 Stable for amd64, wrt bug #434480
485
486 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
487 Stable for amd64, wrt bug #427774
488
489 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
490 arm stable, bug #427774
491
492 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
493 ruby-1.9.3_p194-r1.ebuild:
494 Stable ppc64, bug #411507
495
496 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
497 marked x86 per bug 427774
498
499 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
500 -ruby-1.9.3_p194.ebuild:
501 Cleanup.
502
503 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
504 ppc stable #411507
505
506 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
507 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
508 424611.
509
510*ruby-1.8.7_p370 (07 Jul 2012)
511
512 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
513 Version bump. Fix bug 378567 thanks to slyfox.
514
515 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
516 x86 stable, see bug 411507
517
518 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
519 arm stable, bug #411507
520
521 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
522 Stable for amd64, wrt bug #411507
523
524*ruby-1.9.3_p194-r1 (12 May 2012)
525
526 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
527 +ruby-1.9.3_p194-r1.ebuild:
528 Revision bump to fix mkmf for parallel build/install. Also enable verbose
529 build, so that the log makes sense if it fails.
530
531*ruby-1.9.3_p194 (30 Apr 2012)
532
533 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
534 Version bump.
535
536 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
537 keyword ~amd64-fbsd
538
539*ruby-1.8.7_p358 (20 Apr 2012)
540
541 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
542 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
543 Rails 3.2.
544
545 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
546 Add ~x86-fbsd, #332593
547
548*ruby-1.9.3_p125 (18 Feb 2012)
549
550 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
551 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
552
553 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
554 add ~arm, bug #332593
555
556 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
557 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
558
559 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
560 x86 stable wrt bug #396301
561
562 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
563 Stable for HPPA (bug #396301).
564
565 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
566 Stable for ppc/ppc64; bug #396301
567
568 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
569 Marked ~hppa (bug #332593).
570
571 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
572 Add back ~alpha keyword now that rubygems is keyworded.
573
574 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
575 Stable for AMD64, wrt security bug #396301
576
577*ruby-1.8.7_p357 (28 Dec 2011)
578
579 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
580 Version bump for security bug 396301.
581
582 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
583 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
584
585 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
586 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
587 keyworded, bug 332593.
588
589 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
590 Block older versions of packages that are no longer compatible. Remove
591 ancient blocks on packags long gone from the tree.
592
593 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
594 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
595 Remove old versions.
596
597*ruby-1.9.3_p0 (18 Dec 2011)
598
599 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
600 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
601 suite which need to be diagnosed first.
602
603 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
604 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
605 #332593).
606
607 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
608 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
609 #332593).
610
611 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
612 alpha/ia64/s390/sh/sparc stable wrt #386369
613
614*ruby-1.9.3_rc1 (22 Oct 2011)
615
616 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
617 Version bump.
618
619 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
620 arm stable, bug #386369
621
622 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
623 x86 stable, bug 386369
624
625 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
626 Stable for HPPA (bug #386369).
627
628 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
629 ppc/ppc64 stable wrt #386369
630
631 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
632 Stable on amd64 wrt bug #386369
633
634 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
635 Remove vulnerable version, bug 386369.
636
637*ruby-1.8.7_p352 (30 Aug 2011)
638
639 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
640 +ruby-1.8.7_p352.ebuild:
641 Patchlevel bump for ruby:1.8. Removing old version
642
643*ruby-1.9.2_p290 (30 Aug 2011)
644
645 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
646 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
647 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
648 old patchlevels.
649
650 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
651 ruby-1.8.7_p334-r2.ebuild:
652 ppc/ppc64 stable wrt #378691
653
654*ruby-1.8.7_p334-r2 (22 Jul 2011)
655
656 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
657 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
658 for chasing down upstream and us.
659
660 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
661 Added ~mips, bug 332593
662
663 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
664 ruby-1.8.7_p334-r1.ebuild:
665 ppc64 stable wrt #369141
666
667 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
668 ia64/s390/sh/sparc stable wrt #369141
669
670 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
671 Stable for HPPA (bug #369141).
672
673 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
674 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
675
676 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
677 arm/x86 stable, bug #369141
678
679 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
680 Stable on amd64 wrt bug #369141
681
682 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
683 ruby-1.8.7_p334-r1.ebuild:
684 Stable on alpha, bug #369141
685
686*ruby-1.8.7_p334-r1 (31 May 2011)
687
688 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
689 Revision bump for security bug 369141 (CVE-2011-0188)
690
691*ruby-1.9.2-r1 (16 May 2011)
692
693 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
694 Don't remove racc files since all other ruby targets ship these files
695 themselves as well. Closes bug 363419.
696
697 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
698 ruby-1.8.7_p334.ebuild:
699 Remove old version. Remove obsolete and unused old-style virtual/ruby.
700
701 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
702 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
703
704 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
705 Add append-flags -mieee on sh, bug #357559
706
707 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
708 alpha/arm/ia64/s390/sh stable wrt #355439
709
710 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
711 Marked ~ppc64 wrt #332593
712
713 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
714 ruby-1.8.7_p334.ebuild:
715 x86 stable wrt security bug #355439
716
717 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
718 ruby-1.8.7_p334.ebuild:
719 ppc/ppc64 stable wrt #355439
720
721 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
722 Stable on amd64 wrt bug #355439
723
724 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
725 Stable for HPPA (bug #355439).
726
727*ruby-1.8.7_p334 (19 Feb 2011)
728
729 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
730 Version bump 1.8.7 series, security bug 355439
731
732 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
733 ruby-1.9.2.ebuild:
734 Remove PROVIDE for old-style virtual/ruby per bug 265054.
735
736 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
737 Remove masked ruby 1.8.6 per bug 332597.
738
739 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
740 -ruby-1.9.2_rc2.ebuild:
741 Removing old and vulnerable ebuilds
742
743 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
744 Marking ruby-1.8.7_p302 ppc64 for bug 332957
745
746 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
747 alpha/ia64/s390/sh/sparc stable wrt #332957
748
749*ruby-1.9.2 (24 Aug 2010)
750
751 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
752 metadata.xml:
753 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
754 and x86-fbsd due to a new dependency on rdoc.
755
756 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
757 arm stable, bug #332957
758
759 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
760 ruby-1.8.7_p302.ebuild:
761 x86 stable wrt security bug #332957
762
763 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
764 Stable on amd64 wrt bug #332957
765
766 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
767 Stable for PPC (bug #332957).
768
769 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
770 Stable for HPPA (bug #332957).
771
772*ruby-1.8.7_p302 (21 Aug 2010)
773
774 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
775 +ruby-1.8.7_p302.ebuild:
776 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
777 installation path.
778
779*ruby-1.8.6_p399 (19 Aug 2010)
780
781 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
782 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
783 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
784 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
785 installation path (reported by the x86 team in bug 332597)
786
787*ruby-1.9.2_rc2-r1 (18 Aug 2010)
788
789 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
790 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
791 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
792 the rubygems loading code. Add USE flag for psych.
793
794 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
795 ruby-1.9.2_rc2.ebuild:
796 Remove two keepdir that will try to keep an empty path, closes bug
797 #333163.
798
799 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
800 Marked ~ppc (bug #332593).
801
802 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
803 ruby-1.9.2_rc2.ebuild:
804 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
805
806 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
807 ruby-1.8.7_p299.ebuild:
808 Bump eselect-ruby dependency
809
810 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
811 -ruby-1.9.1_p429.ebuild:
812 Remove ebuild that is not target for unmask anyway.
813
814 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
815 ruby-1.9.2_rc2.ebuild:
816 Try 2 to fix the berkdb 5 issue on 1.9.
817
818 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
819 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
820 ruby-1.9.2_rc2.ebuild:
821 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
822 support for adding new patchsets without bumping the revision for all the
823 old ebuilds as well.
824
825*ruby-1.9.2_rc2 (14 Jul 2010)
826
827 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
828 +ruby-1.9.2_rc2.ebuild:
829 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
830 might cause _further_ build failures as it changed slightly behaviour.
831 You're going to need to rebuild rubygems and then all the packages
832 previously installed after upgrading to this.
833
834 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
835 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
836 -ruby-1.9.1_p376.ebuild:
837 Cleanup old versions.
838
839*ruby-1.9.1_p429 (04 Jul 2010)
840
841 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
842 +ruby-1.9.1_p429.ebuild:
843 Version bump to new 1.9.1 release.
844
845*ruby-1.8.7_p299 (23 Jun 2010)
846
847 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
848 +ruby-1.8.7_p299.ebuild:
849 Version bump.
850
851 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
852 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
853 remove useless comments
854
855 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
856 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
857 ruby-1.9.1_p376.ebuild:
858 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
859 dev.gentoo.org now.
860
861 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
862 ruby-1.9.1_p376.ebuild:
863 Use the correct RUBYLIB.
864
865*ruby-1.8.7_p249-r2 (18 May 2010)
866*ruby-1.8.6_p388-r1 (18 May 2010)
867
868 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
869 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
870 ruby-1.9.1_p376.ebuild, metadata.xml:
871 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
872 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
873 add USE flags for ncurses, readline and libedit, and properly depend on
874 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
875 Emacs versions support ruby-mode themselves and it should be even more
876 updated.
877
878*ruby-1.8.7_p249-r1 (06 May 2010)
879
880 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
881 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
882 309789 by Sune Kloppenborg Jeppesen.
883
884 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
885 ruby-1.8.7_p249.ebuild:
886 Use $PVR instead of $PV in patchset names
887
888 06 May 2010; Alex Legler <a3li@gentoo.org>
889 -files/ruby-1.8.6-memory-leak.diff,
890 -files/ruby18-mkmf-parallel-install.patch,
891 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
892 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
893 Remove old version. Cleanup in files/
894
895*ruby-1.9.1_p376 (01 May 2010)
896
897 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
898 Version bump. Fixes security bugs 296052 and 300468. No longer installs
899 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
900 instead.
901
902 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
903 -ruby-1.8.7_p174-r1.ebuild:
904 Remove vulnerable ebuilds, 300468
905
906 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
907 ruby-1.8.7_p249.ebuild:
908 amd64 stable, security bug 300468
909
910 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
911 ruby-1.8.7_p249.ebuild:
912 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
913
914 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
915 Stable for HPPA (bug #300468).
916
917 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
918 Stable for HPPA (bug #300468).
919
920 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
921 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
922
923 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
924 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
925
926 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
927 ruby-1.8.6_p388.ebuild:
928 stable x86, security bug 300468
929
930 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
931 ruby-1.8.7_p249.ebuild:
932 stable x86, security bug 300468
933
934*ruby-1.8.6_p388 (10 Jan 2010)
935
936 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
937 +ruby-1.8.6_p388.ebuild:
938 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
939 version. The new ebuild also has the fix for bug 168939.
940
941*ruby-1.8.7_p249 (10 Jan 2010)
942
943 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
944 +ruby-1.8.7_p249.ebuild:
945 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
946 version
947
948 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
949 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
950
951*ruby-1.8.7_p248 (25 Dec 2009)
952
953 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
954 Version bump
955
956 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
957 Remove old version.
958
959 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
960 Remove old version.
961
962 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
963 ia64/s390/sh stable wrt #288699
964
965 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
966 stable sparc, bug 288699
967
968 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
969 arm stable, bug #288699
970
971 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
972 amd64/x86 stable, bug #288699
973
974 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
975 ruby-1.8.7_p174-r1.ebuild:
976 Stable on alpha, bug #288699
977
978 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
979 ppc stable #288699
980
981 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
982 Stable for HPPA (bug #288699).
983
984 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
985 Marked ~hppa too.
986
987*ruby-1.8.7_p174-r1 (06 Oct 2009)
988
989 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
990 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
991 eselect-ruby cleanup feature.
992
993*ruby-1.9.1_p243 (09 Sep 2009)
994
995 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
996 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
997 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
998 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
999 -files/ruby19-rubygems-proxy.patch,
1000 -files/ruby-1.9.1_p129-parallelmake.patch,
1001 -files/ruby19-mkmf-parallel-install.patch:
1002 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1003 168939. Cleaning up old patches.
1004
1005*ruby-1.8.6_p383 (20 Aug 2009)
1006
1007 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1008 Patchlevel bump.
1009
1010 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1011 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1012 ruby-1.9.1_p129-r1.ebuild:
1013 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1014
1015 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1016 Removing vulnerable ebuild, bug 273213.
1017
1018 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1019 Marking ruby-1.8.6_p369 ppc for bug 273213
1020
1021 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1022 ruby-1.9.1_p129-r1.ebuild:
1023 Prepend our library path instead of overwriting it during src_install.
1024 Thanks to the reporter of bug #274824.
1025
1026*ruby-1.8.7_p174 (18 Jun 2009)
1027
1028 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1029 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1030 Replacing 187_p173 with _p174 because of a regression. Unifying the
1031 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1032 patchsets.
1033
1034 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1035 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1036
1037 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1038 arm/ia64/s390/sh/sparc stable wrt #273213
1039
1040 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1041 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1042 Removing old version, minor cleanup
1043
1044 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1045 -files/ruby-1.8.6-openssl.patch,
1046 -files/ruby-1.8.6-shortname_constants.patch,
1047 -files/ruby-1.8.6_p111-r13657.patch,
1048 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1049 Removing vulnerable old Ruby version and stale patches, bug 274108.
1050
1051 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1052 ruby-1.8.6_p369.ebuild:
1053 Stable on alpha, bug #273213
1054
1055 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1056 Stable for HPPA (bug #273213).
1057
1058 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1059 ruby-1.8.6_p369.ebuild:
1060 stable x86, security bug 273213
1061
1062 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1063 amd64 stable, security bug 273213.
1064
1065*ruby-1.8.7_p173 (10 Jun 2009)
1066*ruby-1.8.6_p369 (10 Jun 2009)
1067
1068 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1069 +ruby-1.8.7_p173.ebuild:
1070 Version bumps for bug #273213.
1071
1072*ruby-1.9.1_p129-r1 (27 May 2009)
1073
1074 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1075 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1076 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1077 +files/ruby-1.9.1_p129-parallelmake.patch:
1078 Revision bump, add patches 1) to make Ruby behave more similarly between
1079 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1080 extensions (undefined symbols in them will cause abort at runtime 3) to
1081 remove a concurrency issue when building the dl extension that could
1082 result in a broken dl.so.
1083
1084 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1085 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1086 Don't block rdoc-2 or later (which may enter Portage one day as it's
1087 needed by some Rakefiles).
1088
1089 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1090 ruby-1.9.1_p129.ebuild:
1091 Add ~x86-fbsd keyword.
1092
1093 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1094 keyword ~sparc-fbsd, bug #252315
1095
1096*ruby-1.9.1_p129 (15 May 2009)
1097
1098 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1099 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1100 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1101 included in every release.
1102
1103 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1104 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1105 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1106 ruby-1.8.7_p160.ebuild:
1107 Removing vulnerable versions (#268515), fixing license (#233747).
1108
1109 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1110 Stable for HPPA (bug #268515).
1111
1112 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1113 Adapting rubygems notice.
1114
1115 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1116 amd64 stable, bug #268515.
1117
1118 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1119 arm/ia64/s390/sh/sparc stable wrt #268515
1120
1121 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1122 ruby-1.8.6_p368.ebuild:
1123 stable x86, security bug 268515
1124
1125 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1126 ruby-1.8.6_p368.ebuild:
1127 Stable on alpha, bug #268515
1128
1129 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1130 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1131
1132*ruby-1.8.7_p160 (07 May 2009)
1133*ruby-1.8.6_p368 (07 May 2009)
1134
1135 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1136 +ruby-1.8.7_p160.ebuild:
1137 Version bump as per secbug 268515. NB: These are the first ebuilds that
1138 no longer use ruby-config.
1139
1140*ruby-1.9.1-r1 (03 Apr 2009)
1141*ruby-1.8.7_p72-r11 (03 Apr 2009)
1142*ruby-1.8.6_p287-r13 (03 Apr 2009)
1143
1144 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1145 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1146 +files/ruby18-mkmf-parallel-install.patch,
1147 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1148 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1149 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1150 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1151 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1152 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1153 happy.
1154
1155*ruby-1.9.1 (21 Mar 2009)
1156
1157 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1158 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1159 +ruby-1.9.1.ebuild:
1160 Adding Ruby 1.9.1 for preliminary testing
1161
1162 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1163 ruby-1.8.6_p287-r12.ebuild:
1164 Marked ~ppc for bug #252315.
1165
1166 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1167 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1168 bug 261982.
1169
1170 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1171 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1172 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1173 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1174 Cleanup
1175
1176*ruby-1.8.7_p72-r10 (07 Mar 2009)
1177
1178 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1179 +ruby-1.8.7_p72-r10.ebuild:
1180 Add a revision of ruby 1.8.7 using eselect ruby.
1181
1182 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1183 ~mips keyworded, bug #252315.
1184
1185 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1186 ruby-1.8.6_p287-r5.ebuild:
1187 ppc stable, bug #260006
1188
1189 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1190 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1191
1192 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1193 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1194 Fixing Tk USE flag test, bug 258893.
1195
1196 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1197 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1198
1199 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1200 ruby-1.8.6_p287-r5.ebuild:
1201 amd64 stable wrt security bug #260006
1202
1203 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1204 Stable for HPPA (bug #260006).
1205
1206 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1207 ruby-1.8.6_p287-r5.ebuild:
1208 Stable on alpha, bug #260006
1209
1210*ruby-1.8.7_p72-r2 (23 Feb 2009)
1211*ruby-1.8.6_p287-r12 (23 Feb 2009)
1212*ruby-1.8.6_p287-r5 (23 Feb 2009)
1213
1214 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1215 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1216 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1217 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1218 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1219 now before compilation if Tk useflags don't match) and 230748 (adding
1220 --enable-option-checking=no for newer versions of autoconf).
1221
1222 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1223 arm/ia64/s390/sh/sparc stable wrt #254307
1224
1225 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1226 ruby-1.8.6_p287-r4.ebuild:
1227 Stable on alpha, bug #254307
1228
1229 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1230 ruby-1.8.6_p287-r11.ebuild:
1231 keyword ~x86-fbsd, bug #252315
1232
1233 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1234 ppc stable #254307
1235
1236 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1237 amd64/x86 stable, bug #254307
1238
1239 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1240 stable ppc64, bug 254307
1241
1242 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1243 Stable for HPPA (bug #254307).
1244
1245 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1246 ruby-1.8.6_p287-r11.ebuild:
1247 Marked ~hppa (bug #252315).
1248
1249*ruby-1.8.6_p287-r11 (11 Jan 2009)
1250
1251 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1252 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1253 +ruby-1.8.6_p287-r11.ebuild:
1254 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1255 Fixes #254307.
1256
1257 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1258 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1259
1260 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1261 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1262
1263 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1264 ruby-1.8.6_p287-r10.ebuild:
1265 Add ~sparc keyword, bug #252315
1266
1267*ruby-1.8.6_p287-r10 (23 Dec 2008)
1268
1269 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1270 +ruby-1.8.6_p287-r10.ebuild:
1271 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1272 keywords since eselect-ruby does not yet have these keywords.
1273
1274 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1275 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1276 Revert the ruby-config changes. We can't remove them until we provide an
1277 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1278 for breaking things as mentioned in bug #251833.
1279
1280 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1281 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1282 ruby-1.8.7_p72-r1.ebuild:
1283 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1284 Thanks for the people noticing this in bug #251833.
1285
1286 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1287 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1288 ruby-1.8.7_p72-r1.ebuild:
1289 Drop dependency on ruby-config, which will be removed from the tree. We
1290 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1291 is no need for ruby-config at this moment. For newer versions of Ruby we will
1292 use eselect-ruby, which can be found in the ruby overlay at the moment.
1293
1294 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1295 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1296 Use mirror://ruby in SRC_URI, fixes #237392.
1297
1298 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1299 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1300 -ruby-1.8.7_p72.ebuild:
1301 Remove old versions. Leave one old stable version with cjk support.
1302
1303*ruby-1.8.6_p287-r3 (29 Nov 2008)
1304
1305 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1306 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1307 +ruby-1.8.6_p287-r3.ebuild:
1308 Fix our expansion limit patch according to debian bug report
1309 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1310 make sure people will pick up the fixed version. Thanks to Alex Legler for
1311 mentioning the patch.
1312
1313*ruby-1.8.7_p72-r1 (26 Nov 2008)
1314*ruby-1.8.6_p287-r2 (26 Nov 2008)
1315
1316 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1317 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1318 +ruby-1.8.7_p72-r1.ebuild:
1319 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1320 Thanks to Alex Legler for providing the patch.
1321
1322 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1323 -ruby-1.8.6_p287.ebuild:
1324 Remove versions that will not become stable
1325
1326 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1327 ruby-1.8.6_p287-r1.ebuild:
1328 ppc stable, bug #225465
1329
1330 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1331 ruby-1.8.6_p287-r1.ebuild:
1332 amd64 stable wrt security bug #225465
1333
1334 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1335 alpha/ia64/x86 stable wrt #225465
1336
1337 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1338 ruby-1.8.6_p287-r1.ebuild:
1339 Sparc stable --- Security Bug #225465 --- good since late August.
1340
1341 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1342 Stable on ppc64; bug #225465
1343
1344 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1345 Stable for HPPA (bug #225465).
1346
1347*ruby-1.8.6_p287-r1 (29 Aug 2008)
1348
1349 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1350 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1351 +ruby-1.8.6_p287-r1.ebuild:
1352 Fix REXML security issues, bug #236060.
1353
1354 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1355 Add GLEP 56 USE flag descriptions.
1356
1357*ruby-1.8.7_p72 (15 Aug 2008)
1358
1359 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1360 +ruby-1.8.7_p72.ebuild:
1361 bump 1.8.7 to latest patch release
1362
1363*ruby-1.8.6_p287 (11 Aug 2008)
1364
1365 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1366 Version bump for brown paper bag relelease.
1367
1368 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1369 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1370 Remove broken version in favor of the just-added 1.8.6_p286
1371
1372*ruby-1.8.6_p286 (10 Aug 2008)
1373
1374 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1375 Version bump to latest released version of ruby 1.8.6. This version fixes the
1376 security issues reported in #225465 and #234224. The cjk USE flag has been
1377 dropped since no compatible patches have been released yet.
1378
1379 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1380 ruby-1.8.6_p230.ebuild:
1381 drop cjk from SRC_URI as well
1382
1383 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1384 Drop cjk support since the most recent oniguruma patches no longer apply to
1385 this version, #230111.
1386
1387 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1388 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1389 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1390 Unfortunately the official p230 has a change which causes segmentation faults
1391 for applications like Rails and RSpec, so we are reverting that specific
1392 change.
1393
1394*ruby-1.8.7_p22 (29 Jun 2008)
1395
1396 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1397 +ruby-1.8.7_p22.ebuild:
1398 bump 1.8.7 for security fix
1399
1400 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1401 nevermind, don't bump this yet
1402
1403*ruby-1.8.6_p230 (20 Jun 2008)
1404
1405 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1406 version bump
1407
1408*ruby-1.8.7 (10 Jun 2008)
1409
1410 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1411 +ruby-1.8.7.ebuild:
1412 bump 1.8.7 to final
1413
1414*ruby-1.8.7_pre2 (21 Apr 2008)
1415
1416 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1417 +ruby-1.8.7_pre2.ebuild:
1418 Version Bump
1419
1420*ruby-1.8.7_pre1 (16 Apr 2008)
1421
1422 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1423 Version bump. Drop cjk until a new version of oniguruma appears.
1424
1425 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1426 amd64 stable, bug 212264
1427
1428 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1429 Stable for HPPA (bug #212264).
1430
1431 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1432 ruby-1.8.6_p114.ebuild:
1433 ppc stable, bug #212264
4 1434
5 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild: 1435 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
6 alpha/ia64 stable wrt #212264 1436 alpha/ia64 stable wrt #212264
7 1437
8 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org> 1438 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>

Legend:
Removed from v.1.329  
changed lines
  Added in v.1.667

  ViewVC Help
Powered by ViewVC 1.1.20