/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.330 Revision 1.395
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.330 2008/03/05 20:37:44 dertobi123 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.395 2009/05/07 20:26:10 fauli Exp $
4
5 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
6 ruby-1.8.6_p368.ebuild:
7 stable x86, security bug 268515
8
9 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
10 ruby-1.8.6_p368.ebuild:
11 Stable on alpha, bug #268515
12
13 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
14 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
15
16*ruby-1.8.7_p160 (07 May 2009)
17*ruby-1.8.6_p368 (07 May 2009)
18
19 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
20 +ruby-1.8.7_p160.ebuild:
21 Version bump as per secbug 268515. NB: These are the first ebuilds that
22 no longer use ruby-config.
23
24*ruby-1.9.1-r1 (03 Apr 2009)
25*ruby-1.8.7_p72-r11 (03 Apr 2009)
26*ruby-1.8.6_p287-r13 (03 Apr 2009)
27
28 03 Apr 2009; Alex Legler <a3li@gentoo.org>
29 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
30 +files/ruby18-mkmf-parallel-install.patch,
31 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
32 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
33 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
34 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
35 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
36 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
37 happy.
38
39*ruby-1.9.1 (21 Mar 2009)
40
41 21 Mar 2009; Alex Legler <a3li@gentoo.org>
42 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
43 +ruby-1.9.1.ebuild:
44 Adding Ruby 1.9.1 for preliminary testing
45
46 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
47 ruby-1.8.6_p287-r12.ebuild:
48 Marked ~ppc for bug #252315.
49
50 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
51 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
52 bug 261982.
53
54 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
55 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
56 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
57 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
58 Cleanup
59
60*ruby-1.8.7_p72-r10 (07 Mar 2009)
61
62 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
63 +ruby-1.8.7_p72-r10.ebuild:
64 Add a revision of ruby 1.8.7 using eselect ruby.
65
66 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
67 ~mips keyworded, bug #252315.
68
69 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
70 ruby-1.8.6_p287-r5.ebuild:
71 ppc stable, bug #260006
72
73 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
74 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
75
76 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
77 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
78 Fixing Tk USE flag test, bug 258893.
79
80 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
81 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
82
83 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
84 ruby-1.8.6_p287-r5.ebuild:
85 amd64 stable wrt security bug #260006
86
87 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
88 Stable for HPPA (bug #260006).
89
90 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
91 ruby-1.8.6_p287-r5.ebuild:
92 Stable on alpha, bug #260006
93
94*ruby-1.8.7_p72-r2 (23 Feb 2009)
95*ruby-1.8.6_p287-r12 (23 Feb 2009)
96*ruby-1.8.6_p287-r5 (23 Feb 2009)
97
98 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
99 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
100 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
101 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
102 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
103 now before compilation if Tk useflags don't match) and 230748 (adding
104 --enable-option-checking=no for newer versions of autoconf).
105
106 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
107 arm/ia64/s390/sh/sparc stable wrt #254307
108
109 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
110 ruby-1.8.6_p287-r4.ebuild:
111 Stable on alpha, bug #254307
112
113 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
114 ruby-1.8.6_p287-r11.ebuild:
115 keyword ~x86-fbsd, bug #252315
116
117 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
118 ppc stable #254307
119
120 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
121 amd64/x86 stable, bug #254307
122
123 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
124 stable ppc64, bug 254307
125
126 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
127 Stable for HPPA (bug #254307).
128
129 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
130 ruby-1.8.6_p287-r11.ebuild:
131 Marked ~hppa (bug #252315).
132
133*ruby-1.8.6_p287-r11 (11 Jan 2009)
134
135 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
136 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
137 +ruby-1.8.6_p287-r11.ebuild:
138 Backport conditional definition of missing openssl functions from ruby 1.8.7.
139 Fixes #254307.
140
141 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
142 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
143
144 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
145 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
146
147 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
148 ruby-1.8.6_p287-r10.ebuild:
149 Add ~sparc keyword, bug #252315
150
151*ruby-1.8.6_p287-r10 (23 Dec 2008)
152
153 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
154 +ruby-1.8.6_p287-r10.ebuild:
155 Version bump which switches from ruby-config to eselect-ruby. Dropped most
156 keywords since eselect-ruby does not yet have these keywords.
157
158 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
159 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
160 Revert the ruby-config changes. We can't remove them until we provide an
161 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
162 for breaking things as mentioned in bug #251833.
163
164 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
165 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
166 ruby-1.8.7_p72-r1.ebuild:
167 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
168 Thanks for the people noticing this in bug #251833.
169
170 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
171 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
172 ruby-1.8.7_p72-r1.ebuild:
173 Drop dependency on ruby-config, which will be removed from the tree. We
174 currently only have one major version of ruby in the tree (Ruby 1.8), so there
175 is no need for ruby-config at this moment. For newer versions of Ruby we will
176 use eselect-ruby, which can be found in the ruby overlay at the moment.
177
178 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
179 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
180 Use mirror://ruby in SRC_URI, fixes #237392.
181
182 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
183 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
184 -ruby-1.8.7_p72.ebuild:
185 Remove old versions. Leave one old stable version with cjk support.
186
187*ruby-1.8.6_p287-r3 (29 Nov 2008)
188
189 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
190 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
191 +ruby-1.8.6_p287-r3.ebuild:
192 Fix our expansion limit patch according to debian bug report
193 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
194 make sure people will pick up the fixed version. Thanks to Alex Legler for
195 mentioning the patch.
196
197*ruby-1.8.7_p72-r1 (26 Nov 2008)
198*ruby-1.8.6_p287-r2 (26 Nov 2008)
199
200 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
201 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
202 +ruby-1.8.7_p72-r1.ebuild:
203 Fix problem with shortname constants #247790, already fixed in upstream SVN.
204 Thanks to Alex Legler for providing the patch.
205
206 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
207 -ruby-1.8.6_p287.ebuild:
208 Remove versions that will not become stable
209
210 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
211 ruby-1.8.6_p287-r1.ebuild:
212 ppc stable, bug #225465
213
214 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
215 ruby-1.8.6_p287-r1.ebuild:
216 amd64 stable wrt security bug #225465
217
218 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
219 alpha/ia64/x86 stable wrt #225465
220
221 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
222 ruby-1.8.6_p287-r1.ebuild:
223 Sparc stable --- Security Bug #225465 --- good since late August.
224
225 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
226 Stable on ppc64; bug #225465
227
228 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
229 Stable for HPPA (bug #225465).
230
231*ruby-1.8.6_p287-r1 (29 Aug 2008)
232
233 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
234 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
235 +ruby-1.8.6_p287-r1.ebuild:
236 Fix REXML security issues, bug #236060.
237
238 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
239 Add GLEP 56 USE flag descriptions.
240
241*ruby-1.8.7_p72 (15 Aug 2008)
242
243 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
244 +ruby-1.8.7_p72.ebuild:
245 bump 1.8.7 to latest patch release
246
247*ruby-1.8.6_p287 (11 Aug 2008)
248
249 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
250 Version bump for brown paper bag relelease.
251
252 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
253 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
254 Remove broken version in favor of the just-added 1.8.6_p286
255
256*ruby-1.8.6_p286 (10 Aug 2008)
257
258 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
259 Version bump to latest released version of ruby 1.8.6. This version fixes the
260 security issues reported in #225465 and #234224. The cjk USE flag has been
261 dropped since no compatible patches have been released yet.
262
263 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
264 ruby-1.8.6_p230.ebuild:
265 drop cjk from SRC_URI as well
266
267 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
268 Drop cjk support since the most recent oniguruma patches no longer apply to
269 this version, #230111.
270
271 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
272 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
273 Try to fix the security issues reported in #225465 for ruby 1.8.6.
274 Unfortunately the official p230 has a change which causes segmentation faults
275 for applications like Rails and RSpec, so we are reverting that specific
276 change.
277
278*ruby-1.8.7_p22 (29 Jun 2008)
279
280 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
281 +ruby-1.8.7_p22.ebuild:
282 bump 1.8.7 for security fix
283
284 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
285 nevermind, don't bump this yet
286
287*ruby-1.8.6_p230 (20 Jun 2008)
288
289 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
290 version bump
291
292*ruby-1.8.7 (10 Jun 2008)
293
294 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
295 +ruby-1.8.7.ebuild:
296 bump 1.8.7 to final
297
298*ruby-1.8.7_pre2 (21 Apr 2008)
299
300 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
301 +ruby-1.8.7_pre2.ebuild:
302 Version Bump
303
304*ruby-1.8.7_pre1 (16 Apr 2008)
305
306 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
307 Version bump. Drop cjk until a new version of oniguruma appears.
308
309 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
310 amd64 stable, bug 212264
311
312 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
313 Stable for HPPA (bug #212264).
4 314
5 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org> 315 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
6 ruby-1.8.6_p114.ebuild: 316 ruby-1.8.6_p114.ebuild:
7 ppc stable, bug #212264 317 ppc stable, bug #212264
8 318

Legend:
Removed from v.1.330  
changed lines
  Added in v.1.395

  ViewVC Help
Powered by ViewVC 1.1.20