/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.333 Revision 1.671
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.333 2008/04/16 06:44:24 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.671 2014/11/02 19:22:48 jer Exp $
4
5 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
6 ruby-2.0.0_p594.ebuild:
7 Stable for HPPA (bug #527084).
8
9*ruby-2.1.4 (27 Oct 2014)
10*ruby-2.0.0_p594 (27 Oct 2014)
11*ruby-1.9.3_p550 (27 Oct 2014)
12
13 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
14 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
15 Version bump for security bug 527084. Note that OpenSSL defaults have changed
16 in these versions which may lead to incompatibilities:
17 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
18 -openssl/
19
20 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
21 ruby-2.0.0_p481.ebuild:
22 Stable for sparc, wrt bug #512904
23
24 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
25 ruby-2.0.0_p481.ebuild:
26 Stable for ppc64, wrt bug #512904
27
28 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
29 ruby-2.0.0_p481.ebuild:
30 Stable for ppc, wrt bug #512904
31
32 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
33 ruby-2.0.0_p481.ebuild:
34 Stable for amd64, wrt bug #512904
35
36*ruby-2.1.3 (20 Sep 2014)
37
38 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
39 Version bump:
40 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
41
42*ruby-2.0.0_p576 (20 Sep 2014)
43
44 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
45 Version bump.
46
47 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
48 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
49 Depend on the rubygems virtual with an explicit SLOT now that the specific
50 rubygems versions are listed in virtual/rubygems. This will make the
51 dependencies more explicit and should decrease resolver surprises picking the
52 wrong virtual/rubygems SLOT later on.
53
54 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
55 Cleanup.
56
57 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
58 ruby-2.0.0_p481.ebuild:
59 x86 stable wrt bug #512904
60
61 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
62 Stable on alpha, bug #512904
63
64 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
65 arm stable, bug #512904
66
67 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
68 arm stable, bug #512904
69
70 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
71 ruby-2.0.0_p481.ebuild:
72 ia64 stable wrt bug #512904
73
74 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
75 Stable for HPPA (bug #512904).
76
77 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
78 Stable for HPPA (bug #512904).
79
80 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
81 -ruby-2.1.1-r1.ebuild:
82 Cleanup.
83
84 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
85 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
86 512848.
87
88*ruby-1.9.3_p547 (17 May 2014)
89
90 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
91 Version bump.
92
93*ruby-2.1.2 (10 May 2014)
94*ruby-2.0.0_p481 (10 May 2014)
95
96 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
97 +ruby-2.1.2.ebuild:
98 Version bump.
99
100 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
101 -ruby-2.0.0_p353-r2.ebuild:
102 Cleanup.
103
104 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
105 ruby-2.1.1-r1.ebuild:
106 Remove useless libruby symlinks, bug 503584.
107
108 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
109 -ruby-2.1.1.ebuild:
110 Cleanup.
111
112 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
113 Remove unneeded useflag descriptions from metadata.xml
114
115 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
116 -ruby-1.8.7_p374.ebuild:
117 Remove Ruby 1.8. See bug #434064.
118
119*ruby-2.1.1-r1 (14 Apr 2014)
120
121 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
122 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
123 Thanks to Andrew Savchenko for providing a patch.
124
125 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
126 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
127 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
128 ruby-2.1.1.ebuild:
129 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
130
131*ruby-2.1.1 (06 Mar 2014)
132
133 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
134 Version bump. Update module selection code to fix automagic dependencies.
135 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
136 503106.
137
138*ruby-2.0.0_p451 (05 Mar 2014)
139
140 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
141 Version bump. Update module selection code to fix automagic dependencies.
142 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
143 503106.
144
145*ruby-1.9.3_p545 (26 Feb 2014)
146
147 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
148 Version bump. Drop tk USE flag due to bug 500894.
149
150*ruby-2.0.0_p353-r2 (23 Feb 2014)
151
152 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
153 Backport support for uclibc, fixing bug 484534.
154
155 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
156 Stable for alpha, wrt bug #483254
157
158 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
159 Stable for sparc, wrt bug #483254
160
161 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
162 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
163 Fix slot conflicts, #498970
164
165 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
166 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
167 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
168 bug 497130.
169
170 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
171 -ruby-1.9.3_p448-r1.ebuild:
172 Remove vulnerable versions.
173
174 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
175 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
176 Remove vulnerable versions.
177
178 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
179 arm stable, bug #492282
180
181*ruby-2.0.0_p353-r1 (03 Jan 2014)
182
183 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
184 ruby-2.1.0.ebuild:
185 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
186
187 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
188 arm stable, bug #483254
189
190 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
191 ruby-2.0.0_p353.ebuild:
192 ia64 stable wrt bug #492282
193
194*ruby-2.1.0 (26 Dec 2013)
195
196 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
197 Version bump.
198
199 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
200 ia64 stable wrt bug #483254
201
202 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
203 Stable for sparc, wrt bug #492282
204
205 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
206 Stable for arm, wrt bug #492282
207
208 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
209 Stable for alpha, wrt bug #492282
210
211 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
212 ruby-2.0.0_p353.ebuild:
213 Stable for x86, wrt bug #492282
214
215 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
216 ruby-2.0.0_p353.ebuild:
217 Stable for ppc64, wrt bug #492282
218
219 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
220 ruby-2.0.0_p353.ebuild:
221 Stable for ppc, wrt bug #492282
222
223 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
224 Stable for ppc64, wrt bug #483254
225
226 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
227 Stable for ppc, wrt bug #483254
228
229 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
230 ruby-2.0.0_p353.ebuild:
231 Stable for amd64, wrt bug #492282
232
233 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
234 Stable for HPPA (bug #492282).
235
236 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
237 Stable for HPPA (bug #492282).
238
239*ruby-2.0.0_p353 (22 Nov 2013)
240*ruby-1.9.3_p484 (22 Nov 2013)
241
242 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
243 +ruby-2.0.0_p353.ebuild:
244 Version bumps for security bug 492282.
245
246*ruby-2.0.0_p247-r2 (14 Oct 2013)
247
248 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
249 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
250 2.x. Fixes bug 483466.
251
252 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
253 -ruby-1.9.3_p429.ebuild:
254 Cleanup.
255
256 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
257 Stable for HPPA (bug #483254).
258
259 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
260 Stable for x86, wrt bug #483254
261
262 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
263 Stable for amd64, wrt bug #483254
264
265 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
266 ruby-1.9.3_p448.ebuild:
267 Stable for s390, wrt bug #475074
268
269*ruby-2.0.0_p247-r1 (29 Jul 2013)
270*ruby-1.9.3_p448-r1 (29 Jul 2013)
271*ruby-1.8.7_p374-r1 (29 Jul 2013)
272
273 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
274 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
275 Revision bump to counter breakage introduced in portage 2.1.13 for bug
276 465000. Thanks to thansen for reporting.
277
278 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
279 ruby-1.9.3_p448.ebuild:
280 Stable for sparc, wrt bug #475074
281
282 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
283 ruby-1.9.3_p448.ebuild:
284 Stable for sh, wrt bug #475074
285
286 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
287 ruby-1.9.3_p448.ebuild:
288 Stable for ia64, wrt bug #475074
289
290*ruby-2.0.0_p247 (07 Jul 2013)
291
292 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
293 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
294 ruby20.
295
296 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
297 ruby-1.9.3_p448.ebuild:
298 Stable for alpha, wrt bug #475074
299
300 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
301 ruby-1.9.3_p448.ebuild:
302 Stable for ppc64, wrt bug #475074
303
304 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
305 ruby-1.9.3_p448.ebuild:
306 Stable for HPPA (bug #475074).
307
308 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
309 ruby-1.9.3_p448.ebuild:
310 Stable for ppc, wrt bug #475074
311
312 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
313 ruby-1.9.3_p448.ebuild:
314 Stable for arm, wrt bug #475074
315
316 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
317 ruby-1.9.3_p448.ebuild:
318 Stable for x86, wrt bug #475074
319
320 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
321 ruby-1.9.3_p448.ebuild:
322 Stable for amd64, wrt bug #475074
323
324*ruby-1.9.3_p448 (30 Jun 2013)
325*ruby-1.8.7_p374 (30 Jun 2013)
326
327 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
328 +ruby-1.9.3_p448.ebuild:
329 Version bumps for security bug 475074.
330
331 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
332 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
333 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
334 Cleanup. Remove vulnerable versions.
335
336 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
337 Stable for sh, wrt bug #469984
338
339 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
340 Stable for s390, wrt bug #469984
341
342 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
343 Stable for ppc64, wrt bug #469984
344
345 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
346 Stable for ia64, wrt bug #469984
347
348 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
349 Stable for alpha, wrt bug #469984
350
351 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
352 Stable for sparc, wrt bug #469984
353
354 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
355 Remove non-functional dosym calls, bug 442462.
356
357 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
358 Stable for arm, wrt bug #469984
359
360 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
361 Stable for ppc, wrt bug #469984
362
363 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
364 Stable for x86, wrt bug #469984
365
366 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
367 Stable for amd64, wrt bug #469984
368
369 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
370 Stable for HPPA (bug #469984).
371
372*ruby-1.9.3_p429 (16 May 2013)
373
374 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
375 Version bump for security bug #469984.
376
377 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
378 Stable for s390, wrt bug #437366
379
380 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
381 Stable for sparc, wrt bug #437366
382
383 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
384 Stable for ia64, wrt bug #437366
385
386 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
387 Stable for alpha, wrt bug #437366
388
389 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
390 Stable for ppc64, wrt bug #437366
391
392 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
393 Stable for arm, wrt bug #437366
394
395 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
396 Stable for sh, wrt bug #437366
397
398 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
399 Marking ruby-1.8.7_p371 ppc for bug 437366
400
401 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
402 Stable for HPPA (bug #437366).
403
404 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
405 Stable for x86, wrt bug #437366
406
407 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
408 Stable for amd64, wrt bug #437366
409
410 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
411 Stable for sh, wrt bug #458776
412
413 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
414 Stable for alpha, wrt bug #458776
415
416 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
417 Add patch to fix bug #459074 (parallel build).
418
419 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
420 Stable for arm, wrt bug #458776
421
422 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
423 Stable for s390, wrt bug #458776
424
425 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
426 Stable for sparc, wrt bug #458776
427
428 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
429 Stable for hppa, wrt bug #458776
430
431 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
432 Stable for ia64, wrt bug #458776
433
434 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
435 Stable for x86, wrt bug #458776
436
437 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
438 Stable for amd64, wrt bug #458776
439
440 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
441 Stable for ppc64, wrt bug #458776
442
443 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
444 Stable for ppc, wrt bug #458776
445
446*ruby-1.9.3_p392 (22 Feb 2013)
447
448 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
449 Version bump for security bug 458776.
450
451*ruby-1.9.3_p385 (10 Feb 2013)
452
453 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
454 Version bump. Fixes security bug 442580.
455
456 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
457 keyword ~amd64-fbsd
458
459*ruby-1.8.7_p371 (06 Jan 2013)
460
461 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
462 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
463 Version bump for security bug 437366.
464
465 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
466 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
467 Cleanup.
468
469 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
470 Stable for ppc, wrt bug #427774
471
472 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
473 Stable for HPPA (bug #411507).
474
475 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
476 alpha/ia64/s390/sh/sparc stable wrt #434480
477
478 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
479 ruby-1.9.3_p286.ebuild:
480 Remove HPPA target hack (bug #342819).
481
482 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
483 alpha/ia64/s390/sh/sparc stable wrt #411507
484
485 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
486 Stable for HPPA (bug #434480).
487
488*ruby-1.9.3_p286 (15 Oct 2012)
489
490 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
491 Version bump. Fixes bugs #437264 and #437264.
492
493 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
494 stable arm, bug #434480
495
496 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
497 stable ppc ppc64, bug #434480
498
499 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
500 Stable for x86, wrt bug #434480
501
502 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
503 ruby-1.9.3_p194-r1.ebuild:
504 Update LICENSE, bug 434332.
505
506 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
507 Stable for amd64, wrt bug #434480
508
509 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
510 Stable for amd64, wrt bug #427774
511
512 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
513 arm stable, bug #427774
514
515 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
516 ruby-1.9.3_p194-r1.ebuild:
517 Stable ppc64, bug #411507
518
519 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
520 marked x86 per bug 427774
521
522 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
523 -ruby-1.9.3_p194.ebuild:
524 Cleanup.
525
526 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
527 ppc stable #411507
528
529 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
530 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
531 424611.
532
533*ruby-1.8.7_p370 (07 Jul 2012)
534
535 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
536 Version bump. Fix bug 378567 thanks to slyfox.
537
538 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
539 x86 stable, see bug 411507
540
541 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
542 arm stable, bug #411507
543
544 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
545 Stable for amd64, wrt bug #411507
546
547*ruby-1.9.3_p194-r1 (12 May 2012)
548
549 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
550 +ruby-1.9.3_p194-r1.ebuild:
551 Revision bump to fix mkmf for parallel build/install. Also enable verbose
552 build, so that the log makes sense if it fails.
553
554*ruby-1.9.3_p194 (30 Apr 2012)
555
556 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
557 Version bump.
558
559 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
560 keyword ~amd64-fbsd
561
562*ruby-1.8.7_p358 (20 Apr 2012)
563
564 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
565 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
566 Rails 3.2.
567
568 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
569 Add ~x86-fbsd, #332593
570
571*ruby-1.9.3_p125 (18 Feb 2012)
572
573 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
574 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
575
576 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
577 add ~arm, bug #332593
578
579 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
580 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
581
582 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
583 x86 stable wrt bug #396301
584
585 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
586 Stable for HPPA (bug #396301).
587
588 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
589 Stable for ppc/ppc64; bug #396301
590
591 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
592 Marked ~hppa (bug #332593).
593
594 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
595 Add back ~alpha keyword now that rubygems is keyworded.
596
597 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
598 Stable for AMD64, wrt security bug #396301
599
600*ruby-1.8.7_p357 (28 Dec 2011)
601
602 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
603 Version bump for security bug 396301.
604
605 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
606 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
607
608 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
609 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
610 keyworded, bug 332593.
611
612 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
613 Block older versions of packages that are no longer compatible. Remove
614 ancient blocks on packags long gone from the tree.
615
616 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
617 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
618 Remove old versions.
619
620*ruby-1.9.3_p0 (18 Dec 2011)
621
622 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
623 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
624 suite which need to be diagnosed first.
625
626 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
627 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
628 #332593).
629
630 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
631 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
632 #332593).
633
634 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
635 alpha/ia64/s390/sh/sparc stable wrt #386369
636
637*ruby-1.9.3_rc1 (22 Oct 2011)
638
639 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
640 Version bump.
641
642 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
643 arm stable, bug #386369
644
645 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
646 x86 stable, bug 386369
647
648 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
649 Stable for HPPA (bug #386369).
650
651 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
652 ppc/ppc64 stable wrt #386369
653
654 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
655 Stable on amd64 wrt bug #386369
656
657 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
658 Remove vulnerable version, bug 386369.
659
660*ruby-1.8.7_p352 (30 Aug 2011)
661
662 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
663 +ruby-1.8.7_p352.ebuild:
664 Patchlevel bump for ruby:1.8. Removing old version
665
666*ruby-1.9.2_p290 (30 Aug 2011)
667
668 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
669 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
670 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
671 old patchlevels.
672
673 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
674 ruby-1.8.7_p334-r2.ebuild:
675 ppc/ppc64 stable wrt #378691
676
677*ruby-1.8.7_p334-r2 (22 Jul 2011)
678
679 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
680 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
681 for chasing down upstream and us.
682
683 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
684 Added ~mips, bug 332593
685
686 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
687 ruby-1.8.7_p334-r1.ebuild:
688 ppc64 stable wrt #369141
689
690 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
691 ia64/s390/sh/sparc stable wrt #369141
692
693 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
694 Stable for HPPA (bug #369141).
695
696 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
697 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
698
699 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
700 arm/x86 stable, bug #369141
701
702 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
703 Stable on amd64 wrt bug #369141
704
705 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
706 ruby-1.8.7_p334-r1.ebuild:
707 Stable on alpha, bug #369141
708
709*ruby-1.8.7_p334-r1 (31 May 2011)
710
711 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
712 Revision bump for security bug 369141 (CVE-2011-0188)
713
714*ruby-1.9.2-r1 (16 May 2011)
715
716 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
717 Don't remove racc files since all other ruby targets ship these files
718 themselves as well. Closes bug 363419.
719
720 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
721 ruby-1.8.7_p334.ebuild:
722 Remove old version. Remove obsolete and unused old-style virtual/ruby.
723
724 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
725 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
726
727 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
728 Add append-flags -mieee on sh, bug #357559
729
730 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
731 alpha/arm/ia64/s390/sh stable wrt #355439
732
733 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
734 Marked ~ppc64 wrt #332593
735
736 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
737 ruby-1.8.7_p334.ebuild:
738 x86 stable wrt security bug #355439
739
740 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
741 ruby-1.8.7_p334.ebuild:
742 ppc/ppc64 stable wrt #355439
743
744 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
745 Stable on amd64 wrt bug #355439
746
747 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
748 Stable for HPPA (bug #355439).
749
750*ruby-1.8.7_p334 (19 Feb 2011)
751
752 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
753 Version bump 1.8.7 series, security bug 355439
754
755 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
756 ruby-1.9.2.ebuild:
757 Remove PROVIDE for old-style virtual/ruby per bug 265054.
758
759 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
760 Remove masked ruby 1.8.6 per bug 332597.
761
762 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
763 -ruby-1.9.2_rc2.ebuild:
764 Removing old and vulnerable ebuilds
765
766 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
767 Marking ruby-1.8.7_p302 ppc64 for bug 332957
768
769 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
770 alpha/ia64/s390/sh/sparc stable wrt #332957
771
772*ruby-1.9.2 (24 Aug 2010)
773
774 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
775 metadata.xml:
776 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
777 and x86-fbsd due to a new dependency on rdoc.
778
779 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
780 arm stable, bug #332957
781
782 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
783 ruby-1.8.7_p302.ebuild:
784 x86 stable wrt security bug #332957
785
786 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
787 Stable on amd64 wrt bug #332957
788
789 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
790 Stable for PPC (bug #332957).
791
792 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
793 Stable for HPPA (bug #332957).
794
795*ruby-1.8.7_p302 (21 Aug 2010)
796
797 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
798 +ruby-1.8.7_p302.ebuild:
799 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
800 installation path.
801
802*ruby-1.8.6_p399 (19 Aug 2010)
803
804 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
805 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
806 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
807 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
808 installation path (reported by the x86 team in bug 332597)
809
810*ruby-1.9.2_rc2-r1 (18 Aug 2010)
811
812 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
813 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
814 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
815 the rubygems loading code. Add USE flag for psych.
816
817 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
818 ruby-1.9.2_rc2.ebuild:
819 Remove two keepdir that will try to keep an empty path, closes bug
820 #333163.
821
822 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
823 Marked ~ppc (bug #332593).
824
825 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
826 ruby-1.9.2_rc2.ebuild:
827 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
828
829 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
830 ruby-1.8.7_p299.ebuild:
831 Bump eselect-ruby dependency
832
833 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
834 -ruby-1.9.1_p429.ebuild:
835 Remove ebuild that is not target for unmask anyway.
836
837 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
838 ruby-1.9.2_rc2.ebuild:
839 Try 2 to fix the berkdb 5 issue on 1.9.
840
841 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
842 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
843 ruby-1.9.2_rc2.ebuild:
844 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
845 support for adding new patchsets without bumping the revision for all the
846 old ebuilds as well.
847
848*ruby-1.9.2_rc2 (14 Jul 2010)
849
850 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
851 +ruby-1.9.2_rc2.ebuild:
852 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
853 might cause _further_ build failures as it changed slightly behaviour.
854 You're going to need to rebuild rubygems and then all the packages
855 previously installed after upgrading to this.
856
857 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
858 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
859 -ruby-1.9.1_p376.ebuild:
860 Cleanup old versions.
861
862*ruby-1.9.1_p429 (04 Jul 2010)
863
864 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
865 +ruby-1.9.1_p429.ebuild:
866 Version bump to new 1.9.1 release.
867
868*ruby-1.8.7_p299 (23 Jun 2010)
869
870 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
871 +ruby-1.8.7_p299.ebuild:
872 Version bump.
873
874 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
875 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
876 remove useless comments
877
878 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
879 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
880 ruby-1.9.1_p376.ebuild:
881 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
882 dev.gentoo.org now.
883
884 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
885 ruby-1.9.1_p376.ebuild:
886 Use the correct RUBYLIB.
887
888*ruby-1.8.7_p249-r2 (18 May 2010)
889*ruby-1.8.6_p388-r1 (18 May 2010)
890
891 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
892 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
893 ruby-1.9.1_p376.ebuild, metadata.xml:
894 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
895 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
896 add USE flags for ncurses, readline and libedit, and properly depend on
897 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
898 Emacs versions support ruby-mode themselves and it should be even more
899 updated.
900
901*ruby-1.8.7_p249-r1 (06 May 2010)
902
903 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
904 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
905 309789 by Sune Kloppenborg Jeppesen.
906
907 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
908 ruby-1.8.7_p249.ebuild:
909 Use $PVR instead of $PV in patchset names
910
911 06 May 2010; Alex Legler <a3li@gentoo.org>
912 -files/ruby-1.8.6-memory-leak.diff,
913 -files/ruby18-mkmf-parallel-install.patch,
914 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
915 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
916 Remove old version. Cleanup in files/
917
918*ruby-1.9.1_p376 (01 May 2010)
919
920 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
921 Version bump. Fixes security bugs 296052 and 300468. No longer installs
922 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
923 instead.
924
925 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
926 -ruby-1.8.7_p174-r1.ebuild:
927 Remove vulnerable ebuilds, 300468
928
929 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
930 ruby-1.8.7_p249.ebuild:
931 amd64 stable, security bug 300468
932
933 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
934 ruby-1.8.7_p249.ebuild:
935 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
936
937 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
938 Stable for HPPA (bug #300468).
939
940 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
941 Stable for HPPA (bug #300468).
942
943 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
944 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
945
946 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
947 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
948
949 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
950 ruby-1.8.6_p388.ebuild:
951 stable x86, security bug 300468
952
953 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
954 ruby-1.8.7_p249.ebuild:
955 stable x86, security bug 300468
956
957*ruby-1.8.6_p388 (10 Jan 2010)
958
959 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
960 +ruby-1.8.6_p388.ebuild:
961 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
962 version. The new ebuild also has the fix for bug 168939.
963
964*ruby-1.8.7_p249 (10 Jan 2010)
965
966 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
967 +ruby-1.8.7_p249.ebuild:
968 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
969 version
970
971 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
972 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
973
974*ruby-1.8.7_p248 (25 Dec 2009)
975
976 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
977 Version bump
978
979 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
980 Remove old version.
981
982 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
983 Remove old version.
984
985 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
986 ia64/s390/sh stable wrt #288699
987
988 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
989 stable sparc, bug 288699
990
991 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
992 arm stable, bug #288699
993
994 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
995 amd64/x86 stable, bug #288699
996
997 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
998 ruby-1.8.7_p174-r1.ebuild:
999 Stable on alpha, bug #288699
1000
1001 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1002 ppc stable #288699
1003
1004 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1005 Stable for HPPA (bug #288699).
1006
1007 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1008 Marked ~hppa too.
1009
1010*ruby-1.8.7_p174-r1 (06 Oct 2009)
1011
1012 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1013 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1014 eselect-ruby cleanup feature.
1015
1016*ruby-1.9.1_p243 (09 Sep 2009)
1017
1018 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1019 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1020 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1021 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1022 -files/ruby19-rubygems-proxy.patch,
1023 -files/ruby-1.9.1_p129-parallelmake.patch,
1024 -files/ruby19-mkmf-parallel-install.patch:
1025 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1026 168939. Cleaning up old patches.
1027
1028*ruby-1.8.6_p383 (20 Aug 2009)
1029
1030 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1031 Patchlevel bump.
1032
1033 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1034 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1035 ruby-1.9.1_p129-r1.ebuild:
1036 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1037
1038 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1039 Removing vulnerable ebuild, bug 273213.
1040
1041 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1042 Marking ruby-1.8.6_p369 ppc for bug 273213
1043
1044 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1045 ruby-1.9.1_p129-r1.ebuild:
1046 Prepend our library path instead of overwriting it during src_install.
1047 Thanks to the reporter of bug #274824.
1048
1049*ruby-1.8.7_p174 (18 Jun 2009)
1050
1051 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1052 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1053 Replacing 187_p173 with _p174 because of a regression. Unifying the
1054 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1055 patchsets.
1056
1057 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1058 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1059
1060 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1061 arm/ia64/s390/sh/sparc stable wrt #273213
1062
1063 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1064 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1065 Removing old version, minor cleanup
1066
1067 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1068 -files/ruby-1.8.6-openssl.patch,
1069 -files/ruby-1.8.6-shortname_constants.patch,
1070 -files/ruby-1.8.6_p111-r13657.patch,
1071 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1072 Removing vulnerable old Ruby version and stale patches, bug 274108.
1073
1074 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1075 ruby-1.8.6_p369.ebuild:
1076 Stable on alpha, bug #273213
1077
1078 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1079 Stable for HPPA (bug #273213).
1080
1081 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1082 ruby-1.8.6_p369.ebuild:
1083 stable x86, security bug 273213
1084
1085 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1086 amd64 stable, security bug 273213.
1087
1088*ruby-1.8.7_p173 (10 Jun 2009)
1089*ruby-1.8.6_p369 (10 Jun 2009)
1090
1091 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1092 +ruby-1.8.7_p173.ebuild:
1093 Version bumps for bug #273213.
1094
1095*ruby-1.9.1_p129-r1 (27 May 2009)
1096
1097 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1098 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1099 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1100 +files/ruby-1.9.1_p129-parallelmake.patch:
1101 Revision bump, add patches 1) to make Ruby behave more similarly between
1102 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1103 extensions (undefined symbols in them will cause abort at runtime 3) to
1104 remove a concurrency issue when building the dl extension that could
1105 result in a broken dl.so.
1106
1107 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1108 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1109 Don't block rdoc-2 or later (which may enter Portage one day as it's
1110 needed by some Rakefiles).
1111
1112 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1113 ruby-1.9.1_p129.ebuild:
1114 Add ~x86-fbsd keyword.
1115
1116 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1117 keyword ~sparc-fbsd, bug #252315
1118
1119*ruby-1.9.1_p129 (15 May 2009)
1120
1121 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1122 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1123 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1124 included in every release.
1125
1126 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1127 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1128 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1129 ruby-1.8.7_p160.ebuild:
1130 Removing vulnerable versions (#268515), fixing license (#233747).
1131
1132 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1133 Stable for HPPA (bug #268515).
1134
1135 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1136 Adapting rubygems notice.
1137
1138 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1139 amd64 stable, bug #268515.
1140
1141 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1142 arm/ia64/s390/sh/sparc stable wrt #268515
1143
1144 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1145 ruby-1.8.6_p368.ebuild:
1146 stable x86, security bug 268515
1147
1148 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1149 ruby-1.8.6_p368.ebuild:
1150 Stable on alpha, bug #268515
1151
1152 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1153 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1154
1155*ruby-1.8.7_p160 (07 May 2009)
1156*ruby-1.8.6_p368 (07 May 2009)
1157
1158 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1159 +ruby-1.8.7_p160.ebuild:
1160 Version bump as per secbug 268515. NB: These are the first ebuilds that
1161 no longer use ruby-config.
1162
1163*ruby-1.9.1-r1 (03 Apr 2009)
1164*ruby-1.8.7_p72-r11 (03 Apr 2009)
1165*ruby-1.8.6_p287-r13 (03 Apr 2009)
1166
1167 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1168 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1169 +files/ruby18-mkmf-parallel-install.patch,
1170 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1171 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1172 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1173 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1174 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1175 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1176 happy.
1177
1178*ruby-1.9.1 (21 Mar 2009)
1179
1180 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1181 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1182 +ruby-1.9.1.ebuild:
1183 Adding Ruby 1.9.1 for preliminary testing
1184
1185 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1186 ruby-1.8.6_p287-r12.ebuild:
1187 Marked ~ppc for bug #252315.
1188
1189 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1190 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1191 bug 261982.
1192
1193 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1194 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1195 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1196 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1197 Cleanup
1198
1199*ruby-1.8.7_p72-r10 (07 Mar 2009)
1200
1201 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1202 +ruby-1.8.7_p72-r10.ebuild:
1203 Add a revision of ruby 1.8.7 using eselect ruby.
1204
1205 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1206 ~mips keyworded, bug #252315.
1207
1208 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1209 ruby-1.8.6_p287-r5.ebuild:
1210 ppc stable, bug #260006
1211
1212 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1213 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1214
1215 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1216 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1217 Fixing Tk USE flag test, bug 258893.
1218
1219 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1220 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1221
1222 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1223 ruby-1.8.6_p287-r5.ebuild:
1224 amd64 stable wrt security bug #260006
1225
1226 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1227 Stable for HPPA (bug #260006).
1228
1229 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1230 ruby-1.8.6_p287-r5.ebuild:
1231 Stable on alpha, bug #260006
1232
1233*ruby-1.8.7_p72-r2 (23 Feb 2009)
1234*ruby-1.8.6_p287-r12 (23 Feb 2009)
1235*ruby-1.8.6_p287-r5 (23 Feb 2009)
1236
1237 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1238 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1239 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1240 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1241 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1242 now before compilation if Tk useflags don't match) and 230748 (adding
1243 --enable-option-checking=no for newer versions of autoconf).
1244
1245 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1246 arm/ia64/s390/sh/sparc stable wrt #254307
1247
1248 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1249 ruby-1.8.6_p287-r4.ebuild:
1250 Stable on alpha, bug #254307
1251
1252 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1253 ruby-1.8.6_p287-r11.ebuild:
1254 keyword ~x86-fbsd, bug #252315
1255
1256 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1257 ppc stable #254307
1258
1259 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1260 amd64/x86 stable, bug #254307
1261
1262 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1263 stable ppc64, bug 254307
1264
1265 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1266 Stable for HPPA (bug #254307).
1267
1268 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1269 ruby-1.8.6_p287-r11.ebuild:
1270 Marked ~hppa (bug #252315).
1271
1272*ruby-1.8.6_p287-r11 (11 Jan 2009)
1273
1274 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1275 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1276 +ruby-1.8.6_p287-r11.ebuild:
1277 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1278 Fixes #254307.
1279
1280 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1281 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1282
1283 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1284 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1285
1286 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1287 ruby-1.8.6_p287-r10.ebuild:
1288 Add ~sparc keyword, bug #252315
1289
1290*ruby-1.8.6_p287-r10 (23 Dec 2008)
1291
1292 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1293 +ruby-1.8.6_p287-r10.ebuild:
1294 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1295 keywords since eselect-ruby does not yet have these keywords.
1296
1297 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1298 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1299 Revert the ruby-config changes. We can't remove them until we provide an
1300 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1301 for breaking things as mentioned in bug #251833.
1302
1303 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1304 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1305 ruby-1.8.7_p72-r1.ebuild:
1306 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1307 Thanks for the people noticing this in bug #251833.
1308
1309 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1310 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1311 ruby-1.8.7_p72-r1.ebuild:
1312 Drop dependency on ruby-config, which will be removed from the tree. We
1313 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1314 is no need for ruby-config at this moment. For newer versions of Ruby we will
1315 use eselect-ruby, which can be found in the ruby overlay at the moment.
1316
1317 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1318 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1319 Use mirror://ruby in SRC_URI, fixes #237392.
1320
1321 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1322 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1323 -ruby-1.8.7_p72.ebuild:
1324 Remove old versions. Leave one old stable version with cjk support.
1325
1326*ruby-1.8.6_p287-r3 (29 Nov 2008)
1327
1328 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1329 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1330 +ruby-1.8.6_p287-r3.ebuild:
1331 Fix our expansion limit patch according to debian bug report
1332 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1333 make sure people will pick up the fixed version. Thanks to Alex Legler for
1334 mentioning the patch.
1335
1336*ruby-1.8.7_p72-r1 (26 Nov 2008)
1337*ruby-1.8.6_p287-r2 (26 Nov 2008)
1338
1339 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1340 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1341 +ruby-1.8.7_p72-r1.ebuild:
1342 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1343 Thanks to Alex Legler for providing the patch.
1344
1345 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1346 -ruby-1.8.6_p287.ebuild:
1347 Remove versions that will not become stable
1348
1349 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1350 ruby-1.8.6_p287-r1.ebuild:
1351 ppc stable, bug #225465
1352
1353 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1354 ruby-1.8.6_p287-r1.ebuild:
1355 amd64 stable wrt security bug #225465
1356
1357 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1358 alpha/ia64/x86 stable wrt #225465
1359
1360 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1361 ruby-1.8.6_p287-r1.ebuild:
1362 Sparc stable --- Security Bug #225465 --- good since late August.
1363
1364 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1365 Stable on ppc64; bug #225465
1366
1367 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1368 Stable for HPPA (bug #225465).
1369
1370*ruby-1.8.6_p287-r1 (29 Aug 2008)
1371
1372 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1373 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1374 +ruby-1.8.6_p287-r1.ebuild:
1375 Fix REXML security issues, bug #236060.
1376
1377 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1378 Add GLEP 56 USE flag descriptions.
1379
1380*ruby-1.8.7_p72 (15 Aug 2008)
1381
1382 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1383 +ruby-1.8.7_p72.ebuild:
1384 bump 1.8.7 to latest patch release
1385
1386*ruby-1.8.6_p287 (11 Aug 2008)
1387
1388 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1389 Version bump for brown paper bag relelease.
1390
1391 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1392 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1393 Remove broken version in favor of the just-added 1.8.6_p286
1394
1395*ruby-1.8.6_p286 (10 Aug 2008)
1396
1397 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1398 Version bump to latest released version of ruby 1.8.6. This version fixes the
1399 security issues reported in #225465 and #234224. The cjk USE flag has been
1400 dropped since no compatible patches have been released yet.
1401
1402 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1403 ruby-1.8.6_p230.ebuild:
1404 drop cjk from SRC_URI as well
1405
1406 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1407 Drop cjk support since the most recent oniguruma patches no longer apply to
1408 this version, #230111.
1409
1410 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1411 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1412 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1413 Unfortunately the official p230 has a change which causes segmentation faults
1414 for applications like Rails and RSpec, so we are reverting that specific
1415 change.
1416
1417*ruby-1.8.7_p22 (29 Jun 2008)
1418
1419 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1420 +ruby-1.8.7_p22.ebuild:
1421 bump 1.8.7 for security fix
1422
1423 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1424 nevermind, don't bump this yet
1425
1426*ruby-1.8.6_p230 (20 Jun 2008)
1427
1428 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1429 version bump
1430
1431*ruby-1.8.7 (10 Jun 2008)
1432
1433 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1434 +ruby-1.8.7.ebuild:
1435 bump 1.8.7 to final
1436
1437*ruby-1.8.7_pre2 (21 Apr 2008)
1438
1439 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1440 +ruby-1.8.7_pre2.ebuild:
1441 Version Bump
4 1442
5*ruby-1.8.7_pre1 (16 Apr 2008) 1443*ruby-1.8.7_pre1 (16 Apr 2008)
6 1444
7 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild: 1445 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
8 Version bump. Drop cjk until a new version of oniguruma appears. 1446 Version bump. Drop cjk until a new version of oniguruma appears.

Legend:
Removed from v.1.333  
changed lines
  Added in v.1.671

  ViewVC Help
Powered by ViewVC 1.1.20