/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.333 Revision 1.685
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.333 2008/04/16 06:44:24 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.685 2014/11/26 14:31:57 ago Exp $
4
5 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
6 ruby-2.0.0_p598.ebuild:
7 Stable for x86, wrt bug #529216
8
9 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
10 ruby-2.0.0_p598.ebuild:
11 Stable for amd64, wrt bug #529216
12
13*ruby-2.1.5 (14 Nov 2014)
14*ruby-2.0.0_p598 (14 Nov 2014)
15*ruby-1.9.3_p551 (14 Nov 2014)
16
17 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p551.ebuild,
18 +ruby-2.0.0_p598.ebuild, +ruby-2.1.5.ebuild:
19 Version bumps for security bug 529216.
20
21 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p484.ebuild,
22 -ruby-1.9.3_p547.ebuild, -ruby-2.0.0_p353.ebuild, -ruby-2.0.0_p481.ebuild,
23 -ruby-2.0.0_p576.ebuild, -ruby-2.1.2.ebuild, -ruby-2.1.3.ebuild:
24 Cleanup.
25
26 12 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
27 ruby-2.0.0_p594.ebuild:
28 Stable for alpha, wrt bug #527084
29
30 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
31 ruby-2.0.0_p594.ebuild:
32 Stable for sparc, wrt bug #527084
33
34 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
35 ruby-2.0.0_p594.ebuild:
36 Stable for ia64, wrt bug #527084
37
38*ruby-2.1.4-r1 (10 Nov 2014)
39*ruby-2.0.0_p594-r1 (10 Nov 2014)
40
41 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
42 +ruby-2.1.4-r1.ebuild:
43 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
44 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
45
46 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
47 ruby-2.0.0_p594.ebuild:
48 Stable for ppc64, wrt bug #527084
49
50 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
51 ruby-2.0.0_p594.ebuild:
52 Stable for ppc, wrt bug #527084
53
54 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
55 arm stable, bug #527084
56
57 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
58 arm stable, bug #527084
59
60 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
61 ruby-2.0.0_p594.ebuild:
62 Stable for x86, wrt bug #527084
63
64 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
65 ruby-2.0.0_p594.ebuild:
66 Stable for amd64, wrt bug #527084
67
68 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
69 ruby-2.0.0_p594.ebuild:
70 Stable for HPPA (bug #527084).
71
72*ruby-2.1.4 (27 Oct 2014)
73*ruby-2.0.0_p594 (27 Oct 2014)
74*ruby-1.9.3_p550 (27 Oct 2014)
75
76 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
77 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
78 Version bump for security bug 527084. Note that OpenSSL defaults have changed
79 in these versions which may lead to incompatibilities:
80 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
81 -openssl/
82
83 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
84 ruby-2.0.0_p481.ebuild:
85 Stable for sparc, wrt bug #512904
86
87 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
88 ruby-2.0.0_p481.ebuild:
89 Stable for ppc64, wrt bug #512904
90
91 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
92 ruby-2.0.0_p481.ebuild:
93 Stable for ppc, wrt bug #512904
94
95 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
96 ruby-2.0.0_p481.ebuild:
97 Stable for amd64, wrt bug #512904
98
99*ruby-2.1.3 (20 Sep 2014)
100
101 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
102 Version bump:
103 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
104
105*ruby-2.0.0_p576 (20 Sep 2014)
106
107 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
108 Version bump.
109
110 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
111 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
112 Depend on the rubygems virtual with an explicit SLOT now that the specific
113 rubygems versions are listed in virtual/rubygems. This will make the
114 dependencies more explicit and should decrease resolver surprises picking the
115 wrong virtual/rubygems SLOT later on.
116
117 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
118 Cleanup.
119
120 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
121 ruby-2.0.0_p481.ebuild:
122 x86 stable wrt bug #512904
123
124 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
125 Stable on alpha, bug #512904
126
127 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
128 arm stable, bug #512904
129
130 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
131 arm stable, bug #512904
132
133 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
134 ruby-2.0.0_p481.ebuild:
135 ia64 stable wrt bug #512904
136
137 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
138 Stable for HPPA (bug #512904).
139
140 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
141 Stable for HPPA (bug #512904).
142
143 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
144 -ruby-2.1.1-r1.ebuild:
145 Cleanup.
146
147 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
148 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
149 512848.
150
151*ruby-1.9.3_p547 (17 May 2014)
152
153 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
154 Version bump.
155
156*ruby-2.1.2 (10 May 2014)
157*ruby-2.0.0_p481 (10 May 2014)
158
159 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
160 +ruby-2.1.2.ebuild:
161 Version bump.
162
163 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
164 -ruby-2.0.0_p353-r2.ebuild:
165 Cleanup.
166
167 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
168 ruby-2.1.1-r1.ebuild:
169 Remove useless libruby symlinks, bug 503584.
170
171 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
172 -ruby-2.1.1.ebuild:
173 Cleanup.
174
175 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
176 Remove unneeded useflag descriptions from metadata.xml
177
178 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
179 -ruby-1.8.7_p374.ebuild:
180 Remove Ruby 1.8. See bug #434064.
181
182*ruby-2.1.1-r1 (14 Apr 2014)
183
184 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
185 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
186 Thanks to Andrew Savchenko for providing a patch.
187
188 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
189 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
190 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
191 ruby-2.1.1.ebuild:
192 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
193
194*ruby-2.1.1 (06 Mar 2014)
195
196 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
197 Version bump. Update module selection code to fix automagic dependencies.
198 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
199 503106.
200
201*ruby-2.0.0_p451 (05 Mar 2014)
202
203 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
204 Version bump. Update module selection code to fix automagic dependencies.
205 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
206 503106.
207
208*ruby-1.9.3_p545 (26 Feb 2014)
209
210 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
211 Version bump. Drop tk USE flag due to bug 500894.
212
213*ruby-2.0.0_p353-r2 (23 Feb 2014)
214
215 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
216 Backport support for uclibc, fixing bug 484534.
217
218 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
219 Stable for alpha, wrt bug #483254
220
221 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
222 Stable for sparc, wrt bug #483254
223
224 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
225 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
226 Fix slot conflicts, #498970
227
228 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
229 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
230 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
231 bug 497130.
232
233 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
234 -ruby-1.9.3_p448-r1.ebuild:
235 Remove vulnerable versions.
236
237 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
238 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
239 Remove vulnerable versions.
240
241 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
242 arm stable, bug #492282
243
244*ruby-2.0.0_p353-r1 (03 Jan 2014)
245
246 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
247 ruby-2.1.0.ebuild:
248 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
249
250 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
251 arm stable, bug #483254
252
253 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
254 ruby-2.0.0_p353.ebuild:
255 ia64 stable wrt bug #492282
256
257*ruby-2.1.0 (26 Dec 2013)
258
259 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
260 Version bump.
261
262 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
263 ia64 stable wrt bug #483254
264
265 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
266 Stable for sparc, wrt bug #492282
267
268 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
269 Stable for arm, wrt bug #492282
270
271 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
272 Stable for alpha, wrt bug #492282
273
274 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
275 ruby-2.0.0_p353.ebuild:
276 Stable for x86, wrt bug #492282
277
278 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
279 ruby-2.0.0_p353.ebuild:
280 Stable for ppc64, wrt bug #492282
281
282 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
283 ruby-2.0.0_p353.ebuild:
284 Stable for ppc, wrt bug #492282
285
286 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
287 Stable for ppc64, wrt bug #483254
288
289 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
290 Stable for ppc, wrt bug #483254
291
292 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
293 ruby-2.0.0_p353.ebuild:
294 Stable for amd64, wrt bug #492282
295
296 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
297 Stable for HPPA (bug #492282).
298
299 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
300 Stable for HPPA (bug #492282).
301
302*ruby-2.0.0_p353 (22 Nov 2013)
303*ruby-1.9.3_p484 (22 Nov 2013)
304
305 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
306 +ruby-2.0.0_p353.ebuild:
307 Version bumps for security bug 492282.
308
309*ruby-2.0.0_p247-r2 (14 Oct 2013)
310
311 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
312 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
313 2.x. Fixes bug 483466.
314
315 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
316 -ruby-1.9.3_p429.ebuild:
317 Cleanup.
318
319 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
320 Stable for HPPA (bug #483254).
321
322 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
323 Stable for x86, wrt bug #483254
324
325 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
326 Stable for amd64, wrt bug #483254
327
328 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
329 ruby-1.9.3_p448.ebuild:
330 Stable for s390, wrt bug #475074
331
332*ruby-2.0.0_p247-r1 (29 Jul 2013)
333*ruby-1.9.3_p448-r1 (29 Jul 2013)
334*ruby-1.8.7_p374-r1 (29 Jul 2013)
335
336 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
337 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
338 Revision bump to counter breakage introduced in portage 2.1.13 for bug
339 465000. Thanks to thansen for reporting.
340
341 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
342 ruby-1.9.3_p448.ebuild:
343 Stable for sparc, wrt bug #475074
344
345 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
346 ruby-1.9.3_p448.ebuild:
347 Stable for sh, wrt bug #475074
348
349 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
350 ruby-1.9.3_p448.ebuild:
351 Stable for ia64, wrt bug #475074
352
353*ruby-2.0.0_p247 (07 Jul 2013)
354
355 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
356 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
357 ruby20.
358
359 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
360 ruby-1.9.3_p448.ebuild:
361 Stable for alpha, wrt bug #475074
362
363 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
364 ruby-1.9.3_p448.ebuild:
365 Stable for ppc64, wrt bug #475074
366
367 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
368 ruby-1.9.3_p448.ebuild:
369 Stable for HPPA (bug #475074).
370
371 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
372 ruby-1.9.3_p448.ebuild:
373 Stable for ppc, wrt bug #475074
374
375 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
376 ruby-1.9.3_p448.ebuild:
377 Stable for arm, wrt bug #475074
378
379 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
380 ruby-1.9.3_p448.ebuild:
381 Stable for x86, wrt bug #475074
382
383 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
384 ruby-1.9.3_p448.ebuild:
385 Stable for amd64, wrt bug #475074
386
387*ruby-1.9.3_p448 (30 Jun 2013)
388*ruby-1.8.7_p374 (30 Jun 2013)
389
390 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
391 +ruby-1.9.3_p448.ebuild:
392 Version bumps for security bug 475074.
393
394 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
395 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
396 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
397 Cleanup. Remove vulnerable versions.
398
399 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
400 Stable for sh, wrt bug #469984
401
402 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
403 Stable for s390, wrt bug #469984
404
405 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
406 Stable for ppc64, wrt bug #469984
407
408 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
409 Stable for ia64, wrt bug #469984
410
411 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
412 Stable for alpha, wrt bug #469984
413
414 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
415 Stable for sparc, wrt bug #469984
416
417 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
418 Remove non-functional dosym calls, bug 442462.
419
420 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
421 Stable for arm, wrt bug #469984
422
423 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
424 Stable for ppc, wrt bug #469984
425
426 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
427 Stable for x86, wrt bug #469984
428
429 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
430 Stable for amd64, wrt bug #469984
431
432 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
433 Stable for HPPA (bug #469984).
434
435*ruby-1.9.3_p429 (16 May 2013)
436
437 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
438 Version bump for security bug #469984.
439
440 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
441 Stable for s390, wrt bug #437366
442
443 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
444 Stable for sparc, wrt bug #437366
445
446 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
447 Stable for ia64, wrt bug #437366
448
449 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
450 Stable for alpha, wrt bug #437366
451
452 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
453 Stable for ppc64, wrt bug #437366
454
455 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
456 Stable for arm, wrt bug #437366
457
458 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
459 Stable for sh, wrt bug #437366
460
461 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
462 Marking ruby-1.8.7_p371 ppc for bug 437366
463
464 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
465 Stable for HPPA (bug #437366).
466
467 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
468 Stable for x86, wrt bug #437366
469
470 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
471 Stable for amd64, wrt bug #437366
472
473 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
474 Stable for sh, wrt bug #458776
475
476 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
477 Stable for alpha, wrt bug #458776
478
479 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
480 Add patch to fix bug #459074 (parallel build).
481
482 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
483 Stable for arm, wrt bug #458776
484
485 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
486 Stable for s390, wrt bug #458776
487
488 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
489 Stable for sparc, wrt bug #458776
490
491 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
492 Stable for hppa, wrt bug #458776
493
494 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
495 Stable for ia64, wrt bug #458776
496
497 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
498 Stable for x86, wrt bug #458776
499
500 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
501 Stable for amd64, wrt bug #458776
502
503 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
504 Stable for ppc64, wrt bug #458776
505
506 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
507 Stable for ppc, wrt bug #458776
508
509*ruby-1.9.3_p392 (22 Feb 2013)
510
511 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
512 Version bump for security bug 458776.
513
514*ruby-1.9.3_p385 (10 Feb 2013)
515
516 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
517 Version bump. Fixes security bug 442580.
518
519 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
520 keyword ~amd64-fbsd
521
522*ruby-1.8.7_p371 (06 Jan 2013)
523
524 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
525 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
526 Version bump for security bug 437366.
527
528 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
529 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
530 Cleanup.
531
532 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
533 Stable for ppc, wrt bug #427774
534
535 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
536 Stable for HPPA (bug #411507).
537
538 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
539 alpha/ia64/s390/sh/sparc stable wrt #434480
540
541 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
542 ruby-1.9.3_p286.ebuild:
543 Remove HPPA target hack (bug #342819).
544
545 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
546 alpha/ia64/s390/sh/sparc stable wrt #411507
547
548 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
549 Stable for HPPA (bug #434480).
550
551*ruby-1.9.3_p286 (15 Oct 2012)
552
553 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
554 Version bump. Fixes bugs #437264 and #437264.
555
556 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
557 stable arm, bug #434480
558
559 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
560 stable ppc ppc64, bug #434480
561
562 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
563 Stable for x86, wrt bug #434480
564
565 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
566 ruby-1.9.3_p194-r1.ebuild:
567 Update LICENSE, bug 434332.
568
569 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
570 Stable for amd64, wrt bug #434480
571
572 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
573 Stable for amd64, wrt bug #427774
574
575 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
576 arm stable, bug #427774
577
578 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
579 ruby-1.9.3_p194-r1.ebuild:
580 Stable ppc64, bug #411507
581
582 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
583 marked x86 per bug 427774
584
585 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
586 -ruby-1.9.3_p194.ebuild:
587 Cleanup.
588
589 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
590 ppc stable #411507
591
592 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
593 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
594 424611.
595
596*ruby-1.8.7_p370 (07 Jul 2012)
597
598 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
599 Version bump. Fix bug 378567 thanks to slyfox.
600
601 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
602 x86 stable, see bug 411507
603
604 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
605 arm stable, bug #411507
606
607 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
608 Stable for amd64, wrt bug #411507
609
610*ruby-1.9.3_p194-r1 (12 May 2012)
611
612 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
613 +ruby-1.9.3_p194-r1.ebuild:
614 Revision bump to fix mkmf for parallel build/install. Also enable verbose
615 build, so that the log makes sense if it fails.
616
617*ruby-1.9.3_p194 (30 Apr 2012)
618
619 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
620 Version bump.
621
622 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
623 keyword ~amd64-fbsd
624
625*ruby-1.8.7_p358 (20 Apr 2012)
626
627 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
628 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
629 Rails 3.2.
630
631 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
632 Add ~x86-fbsd, #332593
633
634*ruby-1.9.3_p125 (18 Feb 2012)
635
636 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
637 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
638
639 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
640 add ~arm, bug #332593
641
642 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
643 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
644
645 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
646 x86 stable wrt bug #396301
647
648 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
649 Stable for HPPA (bug #396301).
650
651 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
652 Stable for ppc/ppc64; bug #396301
653
654 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
655 Marked ~hppa (bug #332593).
656
657 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
658 Add back ~alpha keyword now that rubygems is keyworded.
659
660 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
661 Stable for AMD64, wrt security bug #396301
662
663*ruby-1.8.7_p357 (28 Dec 2011)
664
665 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
666 Version bump for security bug 396301.
667
668 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
669 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
670
671 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
672 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
673 keyworded, bug 332593.
674
675 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
676 Block older versions of packages that are no longer compatible. Remove
677 ancient blocks on packags long gone from the tree.
678
679 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
680 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
681 Remove old versions.
682
683*ruby-1.9.3_p0 (18 Dec 2011)
684
685 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
686 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
687 suite which need to be diagnosed first.
688
689 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
690 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
691 #332593).
692
693 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
694 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
695 #332593).
696
697 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
698 alpha/ia64/s390/sh/sparc stable wrt #386369
699
700*ruby-1.9.3_rc1 (22 Oct 2011)
701
702 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
703 Version bump.
704
705 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
706 arm stable, bug #386369
707
708 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
709 x86 stable, bug 386369
710
711 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
712 Stable for HPPA (bug #386369).
713
714 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
715 ppc/ppc64 stable wrt #386369
716
717 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
718 Stable on amd64 wrt bug #386369
719
720 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
721 Remove vulnerable version, bug 386369.
722
723*ruby-1.8.7_p352 (30 Aug 2011)
724
725 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
726 +ruby-1.8.7_p352.ebuild:
727 Patchlevel bump for ruby:1.8. Removing old version
728
729*ruby-1.9.2_p290 (30 Aug 2011)
730
731 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
732 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
733 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
734 old patchlevels.
735
736 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
737 ruby-1.8.7_p334-r2.ebuild:
738 ppc/ppc64 stable wrt #378691
739
740*ruby-1.8.7_p334-r2 (22 Jul 2011)
741
742 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
743 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
744 for chasing down upstream and us.
745
746 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
747 Added ~mips, bug 332593
748
749 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
750 ruby-1.8.7_p334-r1.ebuild:
751 ppc64 stable wrt #369141
752
753 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
754 ia64/s390/sh/sparc stable wrt #369141
755
756 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
757 Stable for HPPA (bug #369141).
758
759 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
760 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
761
762 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
763 arm/x86 stable, bug #369141
764
765 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
766 Stable on amd64 wrt bug #369141
767
768 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
769 ruby-1.8.7_p334-r1.ebuild:
770 Stable on alpha, bug #369141
771
772*ruby-1.8.7_p334-r1 (31 May 2011)
773
774 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
775 Revision bump for security bug 369141 (CVE-2011-0188)
776
777*ruby-1.9.2-r1 (16 May 2011)
778
779 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
780 Don't remove racc files since all other ruby targets ship these files
781 themselves as well. Closes bug 363419.
782
783 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
784 ruby-1.8.7_p334.ebuild:
785 Remove old version. Remove obsolete and unused old-style virtual/ruby.
786
787 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
788 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
789
790 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
791 Add append-flags -mieee on sh, bug #357559
792
793 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
794 alpha/arm/ia64/s390/sh stable wrt #355439
795
796 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
797 Marked ~ppc64 wrt #332593
798
799 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
800 ruby-1.8.7_p334.ebuild:
801 x86 stable wrt security bug #355439
802
803 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
804 ruby-1.8.7_p334.ebuild:
805 ppc/ppc64 stable wrt #355439
806
807 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
808 Stable on amd64 wrt bug #355439
809
810 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
811 Stable for HPPA (bug #355439).
812
813*ruby-1.8.7_p334 (19 Feb 2011)
814
815 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
816 Version bump 1.8.7 series, security bug 355439
817
818 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
819 ruby-1.9.2.ebuild:
820 Remove PROVIDE for old-style virtual/ruby per bug 265054.
821
822 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
823 Remove masked ruby 1.8.6 per bug 332597.
824
825 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
826 -ruby-1.9.2_rc2.ebuild:
827 Removing old and vulnerable ebuilds
828
829 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
830 Marking ruby-1.8.7_p302 ppc64 for bug 332957
831
832 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
833 alpha/ia64/s390/sh/sparc stable wrt #332957
834
835*ruby-1.9.2 (24 Aug 2010)
836
837 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
838 metadata.xml:
839 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
840 and x86-fbsd due to a new dependency on rdoc.
841
842 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
843 arm stable, bug #332957
844
845 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
846 ruby-1.8.7_p302.ebuild:
847 x86 stable wrt security bug #332957
848
849 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
850 Stable on amd64 wrt bug #332957
851
852 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
853 Stable for PPC (bug #332957).
854
855 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
856 Stable for HPPA (bug #332957).
857
858*ruby-1.8.7_p302 (21 Aug 2010)
859
860 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
861 +ruby-1.8.7_p302.ebuild:
862 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
863 installation path.
864
865*ruby-1.8.6_p399 (19 Aug 2010)
866
867 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
868 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
869 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
870 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
871 installation path (reported by the x86 team in bug 332597)
872
873*ruby-1.9.2_rc2-r1 (18 Aug 2010)
874
875 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
876 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
877 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
878 the rubygems loading code. Add USE flag for psych.
879
880 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
881 ruby-1.9.2_rc2.ebuild:
882 Remove two keepdir that will try to keep an empty path, closes bug
883 #333163.
884
885 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
886 Marked ~ppc (bug #332593).
887
888 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
889 ruby-1.9.2_rc2.ebuild:
890 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
891
892 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
893 ruby-1.8.7_p299.ebuild:
894 Bump eselect-ruby dependency
895
896 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
897 -ruby-1.9.1_p429.ebuild:
898 Remove ebuild that is not target for unmask anyway.
899
900 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
901 ruby-1.9.2_rc2.ebuild:
902 Try 2 to fix the berkdb 5 issue on 1.9.
903
904 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
905 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
906 ruby-1.9.2_rc2.ebuild:
907 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
908 support for adding new patchsets without bumping the revision for all the
909 old ebuilds as well.
910
911*ruby-1.9.2_rc2 (14 Jul 2010)
912
913 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
914 +ruby-1.9.2_rc2.ebuild:
915 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
916 might cause _further_ build failures as it changed slightly behaviour.
917 You're going to need to rebuild rubygems and then all the packages
918 previously installed after upgrading to this.
919
920 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
921 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
922 -ruby-1.9.1_p376.ebuild:
923 Cleanup old versions.
924
925*ruby-1.9.1_p429 (04 Jul 2010)
926
927 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
928 +ruby-1.9.1_p429.ebuild:
929 Version bump to new 1.9.1 release.
930
931*ruby-1.8.7_p299 (23 Jun 2010)
932
933 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
934 +ruby-1.8.7_p299.ebuild:
935 Version bump.
936
937 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
938 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
939 remove useless comments
940
941 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
942 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
943 ruby-1.9.1_p376.ebuild:
944 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
945 dev.gentoo.org now.
946
947 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
948 ruby-1.9.1_p376.ebuild:
949 Use the correct RUBYLIB.
950
951*ruby-1.8.7_p249-r2 (18 May 2010)
952*ruby-1.8.6_p388-r1 (18 May 2010)
953
954 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
955 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
956 ruby-1.9.1_p376.ebuild, metadata.xml:
957 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
958 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
959 add USE flags for ncurses, readline and libedit, and properly depend on
960 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
961 Emacs versions support ruby-mode themselves and it should be even more
962 updated.
963
964*ruby-1.8.7_p249-r1 (06 May 2010)
965
966 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
967 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
968 309789 by Sune Kloppenborg Jeppesen.
969
970 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
971 ruby-1.8.7_p249.ebuild:
972 Use $PVR instead of $PV in patchset names
973
974 06 May 2010; Alex Legler <a3li@gentoo.org>
975 -files/ruby-1.8.6-memory-leak.diff,
976 -files/ruby18-mkmf-parallel-install.patch,
977 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
978 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
979 Remove old version. Cleanup in files/
980
981*ruby-1.9.1_p376 (01 May 2010)
982
983 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
984 Version bump. Fixes security bugs 296052 and 300468. No longer installs
985 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
986 instead.
987
988 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
989 -ruby-1.8.7_p174-r1.ebuild:
990 Remove vulnerable ebuilds, 300468
991
992 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
993 ruby-1.8.7_p249.ebuild:
994 amd64 stable, security bug 300468
995
996 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
997 ruby-1.8.7_p249.ebuild:
998 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
999
1000 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
1001 Stable for HPPA (bug #300468).
1002
1003 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
1004 Stable for HPPA (bug #300468).
1005
1006 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
1007 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
1008
1009 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
1010 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
1011
1012 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1013 ruby-1.8.6_p388.ebuild:
1014 stable x86, security bug 300468
1015
1016 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1017 ruby-1.8.7_p249.ebuild:
1018 stable x86, security bug 300468
1019
1020*ruby-1.8.6_p388 (10 Jan 2010)
1021
1022 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
1023 +ruby-1.8.6_p388.ebuild:
1024 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
1025 version. The new ebuild also has the fix for bug 168939.
1026
1027*ruby-1.8.7_p249 (10 Jan 2010)
1028
1029 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1030 +ruby-1.8.7_p249.ebuild:
1031 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1032 version
1033
1034 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1035 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1036
1037*ruby-1.8.7_p248 (25 Dec 2009)
1038
1039 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1040 Version bump
1041
1042 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1043 Remove old version.
1044
1045 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1046 Remove old version.
1047
1048 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1049 ia64/s390/sh stable wrt #288699
1050
1051 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1052 stable sparc, bug 288699
1053
1054 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1055 arm stable, bug #288699
1056
1057 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1058 amd64/x86 stable, bug #288699
1059
1060 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1061 ruby-1.8.7_p174-r1.ebuild:
1062 Stable on alpha, bug #288699
1063
1064 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1065 ppc stable #288699
1066
1067 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1068 Stable for HPPA (bug #288699).
1069
1070 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1071 Marked ~hppa too.
1072
1073*ruby-1.8.7_p174-r1 (06 Oct 2009)
1074
1075 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1076 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1077 eselect-ruby cleanup feature.
1078
1079*ruby-1.9.1_p243 (09 Sep 2009)
1080
1081 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1082 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1083 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1084 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1085 -files/ruby19-rubygems-proxy.patch,
1086 -files/ruby-1.9.1_p129-parallelmake.patch,
1087 -files/ruby19-mkmf-parallel-install.patch:
1088 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1089 168939. Cleaning up old patches.
1090
1091*ruby-1.8.6_p383 (20 Aug 2009)
1092
1093 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1094 Patchlevel bump.
1095
1096 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1097 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1098 ruby-1.9.1_p129-r1.ebuild:
1099 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1100
1101 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1102 Removing vulnerable ebuild, bug 273213.
1103
1104 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1105 Marking ruby-1.8.6_p369 ppc for bug 273213
1106
1107 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1108 ruby-1.9.1_p129-r1.ebuild:
1109 Prepend our library path instead of overwriting it during src_install.
1110 Thanks to the reporter of bug #274824.
1111
1112*ruby-1.8.7_p174 (18 Jun 2009)
1113
1114 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1115 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1116 Replacing 187_p173 with _p174 because of a regression. Unifying the
1117 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1118 patchsets.
1119
1120 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1121 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1122
1123 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1124 arm/ia64/s390/sh/sparc stable wrt #273213
1125
1126 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1127 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1128 Removing old version, minor cleanup
1129
1130 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1131 -files/ruby-1.8.6-openssl.patch,
1132 -files/ruby-1.8.6-shortname_constants.patch,
1133 -files/ruby-1.8.6_p111-r13657.patch,
1134 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1135 Removing vulnerable old Ruby version and stale patches, bug 274108.
1136
1137 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1138 ruby-1.8.6_p369.ebuild:
1139 Stable on alpha, bug #273213
1140
1141 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1142 Stable for HPPA (bug #273213).
1143
1144 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1145 ruby-1.8.6_p369.ebuild:
1146 stable x86, security bug 273213
1147
1148 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1149 amd64 stable, security bug 273213.
1150
1151*ruby-1.8.7_p173 (10 Jun 2009)
1152*ruby-1.8.6_p369 (10 Jun 2009)
1153
1154 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1155 +ruby-1.8.7_p173.ebuild:
1156 Version bumps for bug #273213.
1157
1158*ruby-1.9.1_p129-r1 (27 May 2009)
1159
1160 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1161 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1162 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1163 +files/ruby-1.9.1_p129-parallelmake.patch:
1164 Revision bump, add patches 1) to make Ruby behave more similarly between
1165 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1166 extensions (undefined symbols in them will cause abort at runtime 3) to
1167 remove a concurrency issue when building the dl extension that could
1168 result in a broken dl.so.
1169
1170 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1171 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1172 Don't block rdoc-2 or later (which may enter Portage one day as it's
1173 needed by some Rakefiles).
1174
1175 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1176 ruby-1.9.1_p129.ebuild:
1177 Add ~x86-fbsd keyword.
1178
1179 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1180 keyword ~sparc-fbsd, bug #252315
1181
1182*ruby-1.9.1_p129 (15 May 2009)
1183
1184 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1185 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1186 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1187 included in every release.
1188
1189 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1190 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1191 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1192 ruby-1.8.7_p160.ebuild:
1193 Removing vulnerable versions (#268515), fixing license (#233747).
1194
1195 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1196 Stable for HPPA (bug #268515).
1197
1198 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1199 Adapting rubygems notice.
1200
1201 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1202 amd64 stable, bug #268515.
1203
1204 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1205 arm/ia64/s390/sh/sparc stable wrt #268515
1206
1207 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1208 ruby-1.8.6_p368.ebuild:
1209 stable x86, security bug 268515
1210
1211 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1212 ruby-1.8.6_p368.ebuild:
1213 Stable on alpha, bug #268515
1214
1215 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1216 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1217
1218*ruby-1.8.7_p160 (07 May 2009)
1219*ruby-1.8.6_p368 (07 May 2009)
1220
1221 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1222 +ruby-1.8.7_p160.ebuild:
1223 Version bump as per secbug 268515. NB: These are the first ebuilds that
1224 no longer use ruby-config.
1225
1226*ruby-1.9.1-r1 (03 Apr 2009)
1227*ruby-1.8.7_p72-r11 (03 Apr 2009)
1228*ruby-1.8.6_p287-r13 (03 Apr 2009)
1229
1230 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1231 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1232 +files/ruby18-mkmf-parallel-install.patch,
1233 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1234 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1235 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1236 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1237 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1238 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1239 happy.
1240
1241*ruby-1.9.1 (21 Mar 2009)
1242
1243 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1244 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1245 +ruby-1.9.1.ebuild:
1246 Adding Ruby 1.9.1 for preliminary testing
1247
1248 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1249 ruby-1.8.6_p287-r12.ebuild:
1250 Marked ~ppc for bug #252315.
1251
1252 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1253 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1254 bug 261982.
1255
1256 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1257 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1258 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1259 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1260 Cleanup
1261
1262*ruby-1.8.7_p72-r10 (07 Mar 2009)
1263
1264 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1265 +ruby-1.8.7_p72-r10.ebuild:
1266 Add a revision of ruby 1.8.7 using eselect ruby.
1267
1268 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1269 ~mips keyworded, bug #252315.
1270
1271 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1272 ruby-1.8.6_p287-r5.ebuild:
1273 ppc stable, bug #260006
1274
1275 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1276 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1277
1278 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1279 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1280 Fixing Tk USE flag test, bug 258893.
1281
1282 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1283 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1284
1285 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1286 ruby-1.8.6_p287-r5.ebuild:
1287 amd64 stable wrt security bug #260006
1288
1289 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1290 Stable for HPPA (bug #260006).
1291
1292 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1293 ruby-1.8.6_p287-r5.ebuild:
1294 Stable on alpha, bug #260006
1295
1296*ruby-1.8.7_p72-r2 (23 Feb 2009)
1297*ruby-1.8.6_p287-r12 (23 Feb 2009)
1298*ruby-1.8.6_p287-r5 (23 Feb 2009)
1299
1300 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1301 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1302 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1303 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1304 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1305 now before compilation if Tk useflags don't match) and 230748 (adding
1306 --enable-option-checking=no for newer versions of autoconf).
1307
1308 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1309 arm/ia64/s390/sh/sparc stable wrt #254307
1310
1311 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1312 ruby-1.8.6_p287-r4.ebuild:
1313 Stable on alpha, bug #254307
1314
1315 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1316 ruby-1.8.6_p287-r11.ebuild:
1317 keyword ~x86-fbsd, bug #252315
1318
1319 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1320 ppc stable #254307
1321
1322 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1323 amd64/x86 stable, bug #254307
1324
1325 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1326 stable ppc64, bug 254307
1327
1328 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1329 Stable for HPPA (bug #254307).
1330
1331 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1332 ruby-1.8.6_p287-r11.ebuild:
1333 Marked ~hppa (bug #252315).
1334
1335*ruby-1.8.6_p287-r11 (11 Jan 2009)
1336
1337 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1338 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1339 +ruby-1.8.6_p287-r11.ebuild:
1340 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1341 Fixes #254307.
1342
1343 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1344 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1345
1346 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1347 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1348
1349 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1350 ruby-1.8.6_p287-r10.ebuild:
1351 Add ~sparc keyword, bug #252315
1352
1353*ruby-1.8.6_p287-r10 (23 Dec 2008)
1354
1355 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1356 +ruby-1.8.6_p287-r10.ebuild:
1357 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1358 keywords since eselect-ruby does not yet have these keywords.
1359
1360 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1361 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1362 Revert the ruby-config changes. We can't remove them until we provide an
1363 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1364 for breaking things as mentioned in bug #251833.
1365
1366 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1367 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1368 ruby-1.8.7_p72-r1.ebuild:
1369 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1370 Thanks for the people noticing this in bug #251833.
1371
1372 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1373 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1374 ruby-1.8.7_p72-r1.ebuild:
1375 Drop dependency on ruby-config, which will be removed from the tree. We
1376 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1377 is no need for ruby-config at this moment. For newer versions of Ruby we will
1378 use eselect-ruby, which can be found in the ruby overlay at the moment.
1379
1380 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1381 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1382 Use mirror://ruby in SRC_URI, fixes #237392.
1383
1384 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1385 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1386 -ruby-1.8.7_p72.ebuild:
1387 Remove old versions. Leave one old stable version with cjk support.
1388
1389*ruby-1.8.6_p287-r3 (29 Nov 2008)
1390
1391 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1392 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1393 +ruby-1.8.6_p287-r3.ebuild:
1394 Fix our expansion limit patch according to debian bug report
1395 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1396 make sure people will pick up the fixed version. Thanks to Alex Legler for
1397 mentioning the patch.
1398
1399*ruby-1.8.7_p72-r1 (26 Nov 2008)
1400*ruby-1.8.6_p287-r2 (26 Nov 2008)
1401
1402 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1403 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1404 +ruby-1.8.7_p72-r1.ebuild:
1405 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1406 Thanks to Alex Legler for providing the patch.
1407
1408 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1409 -ruby-1.8.6_p287.ebuild:
1410 Remove versions that will not become stable
1411
1412 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1413 ruby-1.8.6_p287-r1.ebuild:
1414 ppc stable, bug #225465
1415
1416 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1417 ruby-1.8.6_p287-r1.ebuild:
1418 amd64 stable wrt security bug #225465
1419
1420 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1421 alpha/ia64/x86 stable wrt #225465
1422
1423 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1424 ruby-1.8.6_p287-r1.ebuild:
1425 Sparc stable --- Security Bug #225465 --- good since late August.
1426
1427 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1428 Stable on ppc64; bug #225465
1429
1430 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1431 Stable for HPPA (bug #225465).
1432
1433*ruby-1.8.6_p287-r1 (29 Aug 2008)
1434
1435 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1436 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1437 +ruby-1.8.6_p287-r1.ebuild:
1438 Fix REXML security issues, bug #236060.
1439
1440 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1441 Add GLEP 56 USE flag descriptions.
1442
1443*ruby-1.8.7_p72 (15 Aug 2008)
1444
1445 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1446 +ruby-1.8.7_p72.ebuild:
1447 bump 1.8.7 to latest patch release
1448
1449*ruby-1.8.6_p287 (11 Aug 2008)
1450
1451 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1452 Version bump for brown paper bag relelease.
1453
1454 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1455 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1456 Remove broken version in favor of the just-added 1.8.6_p286
1457
1458*ruby-1.8.6_p286 (10 Aug 2008)
1459
1460 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1461 Version bump to latest released version of ruby 1.8.6. This version fixes the
1462 security issues reported in #225465 and #234224. The cjk USE flag has been
1463 dropped since no compatible patches have been released yet.
1464
1465 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1466 ruby-1.8.6_p230.ebuild:
1467 drop cjk from SRC_URI as well
1468
1469 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1470 Drop cjk support since the most recent oniguruma patches no longer apply to
1471 this version, #230111.
1472
1473 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1474 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1475 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1476 Unfortunately the official p230 has a change which causes segmentation faults
1477 for applications like Rails and RSpec, so we are reverting that specific
1478 change.
1479
1480*ruby-1.8.7_p22 (29 Jun 2008)
1481
1482 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1483 +ruby-1.8.7_p22.ebuild:
1484 bump 1.8.7 for security fix
1485
1486 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1487 nevermind, don't bump this yet
1488
1489*ruby-1.8.6_p230 (20 Jun 2008)
1490
1491 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1492 version bump
1493
1494*ruby-1.8.7 (10 Jun 2008)
1495
1496 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1497 +ruby-1.8.7.ebuild:
1498 bump 1.8.7 to final
1499
1500*ruby-1.8.7_pre2 (21 Apr 2008)
1501
1502 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1503 +ruby-1.8.7_pre2.ebuild:
1504 Version Bump
4 1505
5*ruby-1.8.7_pre1 (16 Apr 2008) 1506*ruby-1.8.7_pre1 (16 Apr 2008)
6 1507
7 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild: 1508 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
8 Version bump. Drop cjk until a new version of oniguruma appears. 1509 Version bump. Drop cjk until a new version of oniguruma appears.

Legend:
Removed from v.1.333  
changed lines
  Added in v.1.685

  ViewVC Help
Powered by ViewVC 1.1.20