/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.333 Revision 1.692
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.333 2008/04/16 06:44:24 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.692 2014/12/02 11:57:16 ago Exp $
4
5 02 Dec 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
6 ruby-2.0.0_p598.ebuild:
7 Stable for alpha, wrt bug #529216
8
9 01 Dec 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
10 ruby-2.0.0_p598.ebuild:
11 Stable for sparc, wrt bug #529216
12
13 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p598.ebuild:
14 arm stable, bug #529216
15
16 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p551.ebuild:
17 arm stable, bug #529216
18
19 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
20 ruby-2.0.0_p598.ebuild:
21 Stable for ppc64, wrt bug #529216
22
23 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
24 ruby-2.0.0_p598.ebuild:
25 Stable for ppc, wrt bug #529216
26
27 26 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p551.ebuild,
28 ruby-2.0.0_p598.ebuild:
29 Stable for HPPA (bug #529216).
30
31 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
32 ruby-2.0.0_p598.ebuild:
33 Stable for x86, wrt bug #529216
34
35 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
36 ruby-2.0.0_p598.ebuild:
37 Stable for amd64, wrt bug #529216
38
39*ruby-2.1.5 (14 Nov 2014)
40*ruby-2.0.0_p598 (14 Nov 2014)
41*ruby-1.9.3_p551 (14 Nov 2014)
42
43 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p551.ebuild,
44 +ruby-2.0.0_p598.ebuild, +ruby-2.1.5.ebuild:
45 Version bumps for security bug 529216.
46
47 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p484.ebuild,
48 -ruby-1.9.3_p547.ebuild, -ruby-2.0.0_p353.ebuild, -ruby-2.0.0_p481.ebuild,
49 -ruby-2.0.0_p576.ebuild, -ruby-2.1.2.ebuild, -ruby-2.1.3.ebuild:
50 Cleanup.
51
52 12 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
53 ruby-2.0.0_p594.ebuild:
54 Stable for alpha, wrt bug #527084
55
56 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
57 ruby-2.0.0_p594.ebuild:
58 Stable for sparc, wrt bug #527084
59
60 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
61 ruby-2.0.0_p594.ebuild:
62 Stable for ia64, wrt bug #527084
63
64*ruby-2.1.4-r1 (10 Nov 2014)
65*ruby-2.0.0_p594-r1 (10 Nov 2014)
66
67 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
68 +ruby-2.1.4-r1.ebuild:
69 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
70 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
71
72 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
73 ruby-2.0.0_p594.ebuild:
74 Stable for ppc64, wrt bug #527084
75
76 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
77 ruby-2.0.0_p594.ebuild:
78 Stable for ppc, wrt bug #527084
79
80 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
81 arm stable, bug #527084
82
83 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
84 arm stable, bug #527084
85
86 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
87 ruby-2.0.0_p594.ebuild:
88 Stable for x86, wrt bug #527084
89
90 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
91 ruby-2.0.0_p594.ebuild:
92 Stable for amd64, wrt bug #527084
93
94 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
95 ruby-2.0.0_p594.ebuild:
96 Stable for HPPA (bug #527084).
97
98*ruby-2.1.4 (27 Oct 2014)
99*ruby-2.0.0_p594 (27 Oct 2014)
100*ruby-1.9.3_p550 (27 Oct 2014)
101
102 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
103 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
104 Version bump for security bug 527084. Note that OpenSSL defaults have changed
105 in these versions which may lead to incompatibilities:
106 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
107 -openssl/
108
109 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
110 ruby-2.0.0_p481.ebuild:
111 Stable for sparc, wrt bug #512904
112
113 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
114 ruby-2.0.0_p481.ebuild:
115 Stable for ppc64, wrt bug #512904
116
117 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
118 ruby-2.0.0_p481.ebuild:
119 Stable for ppc, wrt bug #512904
120
121 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
122 ruby-2.0.0_p481.ebuild:
123 Stable for amd64, wrt bug #512904
124
125*ruby-2.1.3 (20 Sep 2014)
126
127 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
128 Version bump:
129 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
130
131*ruby-2.0.0_p576 (20 Sep 2014)
132
133 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
134 Version bump.
135
136 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
137 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
138 Depend on the rubygems virtual with an explicit SLOT now that the specific
139 rubygems versions are listed in virtual/rubygems. This will make the
140 dependencies more explicit and should decrease resolver surprises picking the
141 wrong virtual/rubygems SLOT later on.
142
143 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
144 Cleanup.
145
146 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
147 ruby-2.0.0_p481.ebuild:
148 x86 stable wrt bug #512904
149
150 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
151 Stable on alpha, bug #512904
152
153 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
154 arm stable, bug #512904
155
156 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
157 arm stable, bug #512904
158
159 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
160 ruby-2.0.0_p481.ebuild:
161 ia64 stable wrt bug #512904
162
163 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
164 Stable for HPPA (bug #512904).
165
166 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
167 Stable for HPPA (bug #512904).
168
169 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
170 -ruby-2.1.1-r1.ebuild:
171 Cleanup.
172
173 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
174 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
175 512848.
176
177*ruby-1.9.3_p547 (17 May 2014)
178
179 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
180 Version bump.
181
182*ruby-2.1.2 (10 May 2014)
183*ruby-2.0.0_p481 (10 May 2014)
184
185 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
186 +ruby-2.1.2.ebuild:
187 Version bump.
188
189 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
190 -ruby-2.0.0_p353-r2.ebuild:
191 Cleanup.
192
193 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
194 ruby-2.1.1-r1.ebuild:
195 Remove useless libruby symlinks, bug 503584.
196
197 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
198 -ruby-2.1.1.ebuild:
199 Cleanup.
200
201 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
202 Remove unneeded useflag descriptions from metadata.xml
203
204 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
205 -ruby-1.8.7_p374.ebuild:
206 Remove Ruby 1.8. See bug #434064.
207
208*ruby-2.1.1-r1 (14 Apr 2014)
209
210 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
211 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
212 Thanks to Andrew Savchenko for providing a patch.
213
214 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
215 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
216 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
217 ruby-2.1.1.ebuild:
218 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
219
220*ruby-2.1.1 (06 Mar 2014)
221
222 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
223 Version bump. Update module selection code to fix automagic dependencies.
224 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
225 503106.
226
227*ruby-2.0.0_p451 (05 Mar 2014)
228
229 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
230 Version bump. Update module selection code to fix automagic dependencies.
231 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
232 503106.
233
234*ruby-1.9.3_p545 (26 Feb 2014)
235
236 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
237 Version bump. Drop tk USE flag due to bug 500894.
238
239*ruby-2.0.0_p353-r2 (23 Feb 2014)
240
241 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
242 Backport support for uclibc, fixing bug 484534.
243
244 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
245 Stable for alpha, wrt bug #483254
246
247 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
248 Stable for sparc, wrt bug #483254
249
250 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
251 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
252 Fix slot conflicts, #498970
253
254 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
255 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
256 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
257 bug 497130.
258
259 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
260 -ruby-1.9.3_p448-r1.ebuild:
261 Remove vulnerable versions.
262
263 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
264 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
265 Remove vulnerable versions.
266
267 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
268 arm stable, bug #492282
269
270*ruby-2.0.0_p353-r1 (03 Jan 2014)
271
272 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
273 ruby-2.1.0.ebuild:
274 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
275
276 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
277 arm stable, bug #483254
278
279 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
280 ruby-2.0.0_p353.ebuild:
281 ia64 stable wrt bug #492282
282
283*ruby-2.1.0 (26 Dec 2013)
284
285 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
286 Version bump.
287
288 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
289 ia64 stable wrt bug #483254
290
291 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
292 Stable for sparc, wrt bug #492282
293
294 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
295 Stable for arm, wrt bug #492282
296
297 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
298 Stable for alpha, wrt bug #492282
299
300 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
301 ruby-2.0.0_p353.ebuild:
302 Stable for x86, wrt bug #492282
303
304 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
305 ruby-2.0.0_p353.ebuild:
306 Stable for ppc64, wrt bug #492282
307
308 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
309 ruby-2.0.0_p353.ebuild:
310 Stable for ppc, wrt bug #492282
311
312 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
313 Stable for ppc64, wrt bug #483254
314
315 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
316 Stable for ppc, wrt bug #483254
317
318 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
319 ruby-2.0.0_p353.ebuild:
320 Stable for amd64, wrt bug #492282
321
322 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
323 Stable for HPPA (bug #492282).
324
325 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
326 Stable for HPPA (bug #492282).
327
328*ruby-2.0.0_p353 (22 Nov 2013)
329*ruby-1.9.3_p484 (22 Nov 2013)
330
331 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
332 +ruby-2.0.0_p353.ebuild:
333 Version bumps for security bug 492282.
334
335*ruby-2.0.0_p247-r2 (14 Oct 2013)
336
337 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
338 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
339 2.x. Fixes bug 483466.
340
341 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
342 -ruby-1.9.3_p429.ebuild:
343 Cleanup.
344
345 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
346 Stable for HPPA (bug #483254).
347
348 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
349 Stable for x86, wrt bug #483254
350
351 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
352 Stable for amd64, wrt bug #483254
353
354 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
355 ruby-1.9.3_p448.ebuild:
356 Stable for s390, wrt bug #475074
357
358*ruby-2.0.0_p247-r1 (29 Jul 2013)
359*ruby-1.9.3_p448-r1 (29 Jul 2013)
360*ruby-1.8.7_p374-r1 (29 Jul 2013)
361
362 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
363 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
364 Revision bump to counter breakage introduced in portage 2.1.13 for bug
365 465000. Thanks to thansen for reporting.
366
367 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
368 ruby-1.9.3_p448.ebuild:
369 Stable for sparc, wrt bug #475074
370
371 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
372 ruby-1.9.3_p448.ebuild:
373 Stable for sh, wrt bug #475074
374
375 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
376 ruby-1.9.3_p448.ebuild:
377 Stable for ia64, wrt bug #475074
378
379*ruby-2.0.0_p247 (07 Jul 2013)
380
381 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
382 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
383 ruby20.
384
385 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
386 ruby-1.9.3_p448.ebuild:
387 Stable for alpha, wrt bug #475074
388
389 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
390 ruby-1.9.3_p448.ebuild:
391 Stable for ppc64, wrt bug #475074
392
393 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
394 ruby-1.9.3_p448.ebuild:
395 Stable for HPPA (bug #475074).
396
397 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
398 ruby-1.9.3_p448.ebuild:
399 Stable for ppc, wrt bug #475074
400
401 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
402 ruby-1.9.3_p448.ebuild:
403 Stable for arm, wrt bug #475074
404
405 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
406 ruby-1.9.3_p448.ebuild:
407 Stable for x86, wrt bug #475074
408
409 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
410 ruby-1.9.3_p448.ebuild:
411 Stable for amd64, wrt bug #475074
412
413*ruby-1.9.3_p448 (30 Jun 2013)
414*ruby-1.8.7_p374 (30 Jun 2013)
415
416 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
417 +ruby-1.9.3_p448.ebuild:
418 Version bumps for security bug 475074.
419
420 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
421 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
422 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
423 Cleanup. Remove vulnerable versions.
424
425 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
426 Stable for sh, wrt bug #469984
427
428 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
429 Stable for s390, wrt bug #469984
430
431 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
432 Stable for ppc64, wrt bug #469984
433
434 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
435 Stable for ia64, wrt bug #469984
436
437 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
438 Stable for alpha, wrt bug #469984
439
440 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
441 Stable for sparc, wrt bug #469984
442
443 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
444 Remove non-functional dosym calls, bug 442462.
445
446 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
447 Stable for arm, wrt bug #469984
448
449 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
450 Stable for ppc, wrt bug #469984
451
452 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
453 Stable for x86, wrt bug #469984
454
455 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
456 Stable for amd64, wrt bug #469984
457
458 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
459 Stable for HPPA (bug #469984).
460
461*ruby-1.9.3_p429 (16 May 2013)
462
463 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
464 Version bump for security bug #469984.
465
466 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
467 Stable for s390, wrt bug #437366
468
469 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
470 Stable for sparc, wrt bug #437366
471
472 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
473 Stable for ia64, wrt bug #437366
474
475 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
476 Stable for alpha, wrt bug #437366
477
478 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
479 Stable for ppc64, wrt bug #437366
480
481 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
482 Stable for arm, wrt bug #437366
483
484 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
485 Stable for sh, wrt bug #437366
486
487 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
488 Marking ruby-1.8.7_p371 ppc for bug 437366
489
490 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
491 Stable for HPPA (bug #437366).
492
493 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
494 Stable for x86, wrt bug #437366
495
496 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
497 Stable for amd64, wrt bug #437366
498
499 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
500 Stable for sh, wrt bug #458776
501
502 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
503 Stable for alpha, wrt bug #458776
504
505 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
506 Add patch to fix bug #459074 (parallel build).
507
508 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
509 Stable for arm, wrt bug #458776
510
511 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
512 Stable for s390, wrt bug #458776
513
514 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
515 Stable for sparc, wrt bug #458776
516
517 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
518 Stable for hppa, wrt bug #458776
519
520 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
521 Stable for ia64, wrt bug #458776
522
523 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
524 Stable for x86, wrt bug #458776
525
526 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
527 Stable for amd64, wrt bug #458776
528
529 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
530 Stable for ppc64, wrt bug #458776
531
532 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
533 Stable for ppc, wrt bug #458776
534
535*ruby-1.9.3_p392 (22 Feb 2013)
536
537 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
538 Version bump for security bug 458776.
539
540*ruby-1.9.3_p385 (10 Feb 2013)
541
542 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
543 Version bump. Fixes security bug 442580.
544
545 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
546 keyword ~amd64-fbsd
547
548*ruby-1.8.7_p371 (06 Jan 2013)
549
550 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
551 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
552 Version bump for security bug 437366.
553
554 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
555 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
556 Cleanup.
557
558 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
559 Stable for ppc, wrt bug #427774
560
561 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
562 Stable for HPPA (bug #411507).
563
564 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
565 alpha/ia64/s390/sh/sparc stable wrt #434480
566
567 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
568 ruby-1.9.3_p286.ebuild:
569 Remove HPPA target hack (bug #342819).
570
571 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
572 alpha/ia64/s390/sh/sparc stable wrt #411507
573
574 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
575 Stable for HPPA (bug #434480).
576
577*ruby-1.9.3_p286 (15 Oct 2012)
578
579 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
580 Version bump. Fixes bugs #437264 and #437264.
581
582 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
583 stable arm, bug #434480
584
585 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
586 stable ppc ppc64, bug #434480
587
588 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
589 Stable for x86, wrt bug #434480
590
591 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
592 ruby-1.9.3_p194-r1.ebuild:
593 Update LICENSE, bug 434332.
594
595 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
596 Stable for amd64, wrt bug #434480
597
598 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
599 Stable for amd64, wrt bug #427774
600
601 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
602 arm stable, bug #427774
603
604 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
605 ruby-1.9.3_p194-r1.ebuild:
606 Stable ppc64, bug #411507
607
608 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
609 marked x86 per bug 427774
610
611 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
612 -ruby-1.9.3_p194.ebuild:
613 Cleanup.
614
615 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
616 ppc stable #411507
617
618 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
619 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
620 424611.
621
622*ruby-1.8.7_p370 (07 Jul 2012)
623
624 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
625 Version bump. Fix bug 378567 thanks to slyfox.
626
627 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
628 x86 stable, see bug 411507
629
630 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
631 arm stable, bug #411507
632
633 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
634 Stable for amd64, wrt bug #411507
635
636*ruby-1.9.3_p194-r1 (12 May 2012)
637
638 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
639 +ruby-1.9.3_p194-r1.ebuild:
640 Revision bump to fix mkmf for parallel build/install. Also enable verbose
641 build, so that the log makes sense if it fails.
642
643*ruby-1.9.3_p194 (30 Apr 2012)
644
645 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
646 Version bump.
647
648 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
649 keyword ~amd64-fbsd
650
651*ruby-1.8.7_p358 (20 Apr 2012)
652
653 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
654 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
655 Rails 3.2.
656
657 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
658 Add ~x86-fbsd, #332593
659
660*ruby-1.9.3_p125 (18 Feb 2012)
661
662 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
663 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
664
665 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
666 add ~arm, bug #332593
667
668 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
669 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
670
671 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
672 x86 stable wrt bug #396301
673
674 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
675 Stable for HPPA (bug #396301).
676
677 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
678 Stable for ppc/ppc64; bug #396301
679
680 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
681 Marked ~hppa (bug #332593).
682
683 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
684 Add back ~alpha keyword now that rubygems is keyworded.
685
686 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
687 Stable for AMD64, wrt security bug #396301
688
689*ruby-1.8.7_p357 (28 Dec 2011)
690
691 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
692 Version bump for security bug 396301.
693
694 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
695 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
696
697 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
698 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
699 keyworded, bug 332593.
700
701 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
702 Block older versions of packages that are no longer compatible. Remove
703 ancient blocks on packags long gone from the tree.
704
705 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
706 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
707 Remove old versions.
708
709*ruby-1.9.3_p0 (18 Dec 2011)
710
711 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
712 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
713 suite which need to be diagnosed first.
714
715 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
716 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
717 #332593).
718
719 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
720 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
721 #332593).
722
723 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
724 alpha/ia64/s390/sh/sparc stable wrt #386369
725
726*ruby-1.9.3_rc1 (22 Oct 2011)
727
728 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
729 Version bump.
730
731 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
732 arm stable, bug #386369
733
734 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
735 x86 stable, bug 386369
736
737 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
738 Stable for HPPA (bug #386369).
739
740 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
741 ppc/ppc64 stable wrt #386369
742
743 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
744 Stable on amd64 wrt bug #386369
745
746 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
747 Remove vulnerable version, bug 386369.
748
749*ruby-1.8.7_p352 (30 Aug 2011)
750
751 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
752 +ruby-1.8.7_p352.ebuild:
753 Patchlevel bump for ruby:1.8. Removing old version
754
755*ruby-1.9.2_p290 (30 Aug 2011)
756
757 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
758 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
759 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
760 old patchlevels.
761
762 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
763 ruby-1.8.7_p334-r2.ebuild:
764 ppc/ppc64 stable wrt #378691
765
766*ruby-1.8.7_p334-r2 (22 Jul 2011)
767
768 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
769 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
770 for chasing down upstream and us.
771
772 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
773 Added ~mips, bug 332593
774
775 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
776 ruby-1.8.7_p334-r1.ebuild:
777 ppc64 stable wrt #369141
778
779 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
780 ia64/s390/sh/sparc stable wrt #369141
781
782 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
783 Stable for HPPA (bug #369141).
784
785 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
786 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
787
788 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
789 arm/x86 stable, bug #369141
790
791 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
792 Stable on amd64 wrt bug #369141
793
794 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
795 ruby-1.8.7_p334-r1.ebuild:
796 Stable on alpha, bug #369141
797
798*ruby-1.8.7_p334-r1 (31 May 2011)
799
800 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
801 Revision bump for security bug 369141 (CVE-2011-0188)
802
803*ruby-1.9.2-r1 (16 May 2011)
804
805 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
806 Don't remove racc files since all other ruby targets ship these files
807 themselves as well. Closes bug 363419.
808
809 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
810 ruby-1.8.7_p334.ebuild:
811 Remove old version. Remove obsolete and unused old-style virtual/ruby.
812
813 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
814 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
815
816 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
817 Add append-flags -mieee on sh, bug #357559
818
819 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
820 alpha/arm/ia64/s390/sh stable wrt #355439
821
822 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
823 Marked ~ppc64 wrt #332593
824
825 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
826 ruby-1.8.7_p334.ebuild:
827 x86 stable wrt security bug #355439
828
829 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
830 ruby-1.8.7_p334.ebuild:
831 ppc/ppc64 stable wrt #355439
832
833 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
834 Stable on amd64 wrt bug #355439
835
836 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
837 Stable for HPPA (bug #355439).
838
839*ruby-1.8.7_p334 (19 Feb 2011)
840
841 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
842 Version bump 1.8.7 series, security bug 355439
843
844 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
845 ruby-1.9.2.ebuild:
846 Remove PROVIDE for old-style virtual/ruby per bug 265054.
847
848 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
849 Remove masked ruby 1.8.6 per bug 332597.
850
851 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
852 -ruby-1.9.2_rc2.ebuild:
853 Removing old and vulnerable ebuilds
854
855 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
856 Marking ruby-1.8.7_p302 ppc64 for bug 332957
857
858 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
859 alpha/ia64/s390/sh/sparc stable wrt #332957
860
861*ruby-1.9.2 (24 Aug 2010)
862
863 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
864 metadata.xml:
865 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
866 and x86-fbsd due to a new dependency on rdoc.
867
868 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
869 arm stable, bug #332957
870
871 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
872 ruby-1.8.7_p302.ebuild:
873 x86 stable wrt security bug #332957
874
875 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
876 Stable on amd64 wrt bug #332957
877
878 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
879 Stable for PPC (bug #332957).
880
881 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
882 Stable for HPPA (bug #332957).
883
884*ruby-1.8.7_p302 (21 Aug 2010)
885
886 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
887 +ruby-1.8.7_p302.ebuild:
888 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
889 installation path.
890
891*ruby-1.8.6_p399 (19 Aug 2010)
892
893 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
894 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
895 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
896 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
897 installation path (reported by the x86 team in bug 332597)
898
899*ruby-1.9.2_rc2-r1 (18 Aug 2010)
900
901 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
902 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
903 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
904 the rubygems loading code. Add USE flag for psych.
905
906 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
907 ruby-1.9.2_rc2.ebuild:
908 Remove two keepdir that will try to keep an empty path, closes bug
909 #333163.
910
911 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
912 Marked ~ppc (bug #332593).
913
914 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
915 ruby-1.9.2_rc2.ebuild:
916 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
917
918 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
919 ruby-1.8.7_p299.ebuild:
920 Bump eselect-ruby dependency
921
922 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
923 -ruby-1.9.1_p429.ebuild:
924 Remove ebuild that is not target for unmask anyway.
925
926 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
927 ruby-1.9.2_rc2.ebuild:
928 Try 2 to fix the berkdb 5 issue on 1.9.
929
930 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
931 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
932 ruby-1.9.2_rc2.ebuild:
933 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
934 support for adding new patchsets without bumping the revision for all the
935 old ebuilds as well.
936
937*ruby-1.9.2_rc2 (14 Jul 2010)
938
939 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
940 +ruby-1.9.2_rc2.ebuild:
941 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
942 might cause _further_ build failures as it changed slightly behaviour.
943 You're going to need to rebuild rubygems and then all the packages
944 previously installed after upgrading to this.
945
946 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
947 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
948 -ruby-1.9.1_p376.ebuild:
949 Cleanup old versions.
950
951*ruby-1.9.1_p429 (04 Jul 2010)
952
953 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
954 +ruby-1.9.1_p429.ebuild:
955 Version bump to new 1.9.1 release.
956
957*ruby-1.8.7_p299 (23 Jun 2010)
958
959 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
960 +ruby-1.8.7_p299.ebuild:
961 Version bump.
962
963 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
964 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
965 remove useless comments
966
967 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
968 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
969 ruby-1.9.1_p376.ebuild:
970 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
971 dev.gentoo.org now.
972
973 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
974 ruby-1.9.1_p376.ebuild:
975 Use the correct RUBYLIB.
976
977*ruby-1.8.7_p249-r2 (18 May 2010)
978*ruby-1.8.6_p388-r1 (18 May 2010)
979
980 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
981 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
982 ruby-1.9.1_p376.ebuild, metadata.xml:
983 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
984 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
985 add USE flags for ncurses, readline and libedit, and properly depend on
986 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
987 Emacs versions support ruby-mode themselves and it should be even more
988 updated.
989
990*ruby-1.8.7_p249-r1 (06 May 2010)
991
992 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
993 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
994 309789 by Sune Kloppenborg Jeppesen.
995
996 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
997 ruby-1.8.7_p249.ebuild:
998 Use $PVR instead of $PV in patchset names
999
1000 06 May 2010; Alex Legler <a3li@gentoo.org>
1001 -files/ruby-1.8.6-memory-leak.diff,
1002 -files/ruby18-mkmf-parallel-install.patch,
1003 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
1004 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
1005 Remove old version. Cleanup in files/
1006
1007*ruby-1.9.1_p376 (01 May 2010)
1008
1009 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
1010 Version bump. Fixes security bugs 296052 and 300468. No longer installs
1011 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
1012 instead.
1013
1014 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
1015 -ruby-1.8.7_p174-r1.ebuild:
1016 Remove vulnerable ebuilds, 300468
1017
1018 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
1019 ruby-1.8.7_p249.ebuild:
1020 amd64 stable, security bug 300468
1021
1022 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
1023 ruby-1.8.7_p249.ebuild:
1024 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
1025
1026 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
1027 Stable for HPPA (bug #300468).
1028
1029 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
1030 Stable for HPPA (bug #300468).
1031
1032 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
1033 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
1034
1035 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
1036 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
1037
1038 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1039 ruby-1.8.6_p388.ebuild:
1040 stable x86, security bug 300468
1041
1042 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1043 ruby-1.8.7_p249.ebuild:
1044 stable x86, security bug 300468
1045
1046*ruby-1.8.6_p388 (10 Jan 2010)
1047
1048 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
1049 +ruby-1.8.6_p388.ebuild:
1050 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
1051 version. The new ebuild also has the fix for bug 168939.
1052
1053*ruby-1.8.7_p249 (10 Jan 2010)
1054
1055 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1056 +ruby-1.8.7_p249.ebuild:
1057 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1058 version
1059
1060 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1061 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1062
1063*ruby-1.8.7_p248 (25 Dec 2009)
1064
1065 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1066 Version bump
1067
1068 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1069 Remove old version.
1070
1071 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1072 Remove old version.
1073
1074 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1075 ia64/s390/sh stable wrt #288699
1076
1077 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1078 stable sparc, bug 288699
1079
1080 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1081 arm stable, bug #288699
1082
1083 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1084 amd64/x86 stable, bug #288699
1085
1086 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1087 ruby-1.8.7_p174-r1.ebuild:
1088 Stable on alpha, bug #288699
1089
1090 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1091 ppc stable #288699
1092
1093 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1094 Stable for HPPA (bug #288699).
1095
1096 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1097 Marked ~hppa too.
1098
1099*ruby-1.8.7_p174-r1 (06 Oct 2009)
1100
1101 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1102 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1103 eselect-ruby cleanup feature.
1104
1105*ruby-1.9.1_p243 (09 Sep 2009)
1106
1107 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1108 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1109 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1110 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1111 -files/ruby19-rubygems-proxy.patch,
1112 -files/ruby-1.9.1_p129-parallelmake.patch,
1113 -files/ruby19-mkmf-parallel-install.patch:
1114 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1115 168939. Cleaning up old patches.
1116
1117*ruby-1.8.6_p383 (20 Aug 2009)
1118
1119 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1120 Patchlevel bump.
1121
1122 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1123 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1124 ruby-1.9.1_p129-r1.ebuild:
1125 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1126
1127 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1128 Removing vulnerable ebuild, bug 273213.
1129
1130 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1131 Marking ruby-1.8.6_p369 ppc for bug 273213
1132
1133 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1134 ruby-1.9.1_p129-r1.ebuild:
1135 Prepend our library path instead of overwriting it during src_install.
1136 Thanks to the reporter of bug #274824.
1137
1138*ruby-1.8.7_p174 (18 Jun 2009)
1139
1140 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1141 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1142 Replacing 187_p173 with _p174 because of a regression. Unifying the
1143 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1144 patchsets.
1145
1146 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1147 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1148
1149 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1150 arm/ia64/s390/sh/sparc stable wrt #273213
1151
1152 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1153 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1154 Removing old version, minor cleanup
1155
1156 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1157 -files/ruby-1.8.6-openssl.patch,
1158 -files/ruby-1.8.6-shortname_constants.patch,
1159 -files/ruby-1.8.6_p111-r13657.patch,
1160 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1161 Removing vulnerable old Ruby version and stale patches, bug 274108.
1162
1163 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1164 ruby-1.8.6_p369.ebuild:
1165 Stable on alpha, bug #273213
1166
1167 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1168 Stable for HPPA (bug #273213).
1169
1170 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1171 ruby-1.8.6_p369.ebuild:
1172 stable x86, security bug 273213
1173
1174 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1175 amd64 stable, security bug 273213.
1176
1177*ruby-1.8.7_p173 (10 Jun 2009)
1178*ruby-1.8.6_p369 (10 Jun 2009)
1179
1180 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1181 +ruby-1.8.7_p173.ebuild:
1182 Version bumps for bug #273213.
1183
1184*ruby-1.9.1_p129-r1 (27 May 2009)
1185
1186 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1187 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1188 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1189 +files/ruby-1.9.1_p129-parallelmake.patch:
1190 Revision bump, add patches 1) to make Ruby behave more similarly between
1191 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1192 extensions (undefined symbols in them will cause abort at runtime 3) to
1193 remove a concurrency issue when building the dl extension that could
1194 result in a broken dl.so.
1195
1196 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1197 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1198 Don't block rdoc-2 or later (which may enter Portage one day as it's
1199 needed by some Rakefiles).
1200
1201 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1202 ruby-1.9.1_p129.ebuild:
1203 Add ~x86-fbsd keyword.
1204
1205 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1206 keyword ~sparc-fbsd, bug #252315
1207
1208*ruby-1.9.1_p129 (15 May 2009)
1209
1210 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1211 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1212 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1213 included in every release.
1214
1215 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1216 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1217 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1218 ruby-1.8.7_p160.ebuild:
1219 Removing vulnerable versions (#268515), fixing license (#233747).
1220
1221 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1222 Stable for HPPA (bug #268515).
1223
1224 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1225 Adapting rubygems notice.
1226
1227 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1228 amd64 stable, bug #268515.
1229
1230 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1231 arm/ia64/s390/sh/sparc stable wrt #268515
1232
1233 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1234 ruby-1.8.6_p368.ebuild:
1235 stable x86, security bug 268515
1236
1237 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1238 ruby-1.8.6_p368.ebuild:
1239 Stable on alpha, bug #268515
1240
1241 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1242 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1243
1244*ruby-1.8.7_p160 (07 May 2009)
1245*ruby-1.8.6_p368 (07 May 2009)
1246
1247 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1248 +ruby-1.8.7_p160.ebuild:
1249 Version bump as per secbug 268515. NB: These are the first ebuilds that
1250 no longer use ruby-config.
1251
1252*ruby-1.9.1-r1 (03 Apr 2009)
1253*ruby-1.8.7_p72-r11 (03 Apr 2009)
1254*ruby-1.8.6_p287-r13 (03 Apr 2009)
1255
1256 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1257 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1258 +files/ruby18-mkmf-parallel-install.patch,
1259 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1260 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1261 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1262 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1263 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1264 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1265 happy.
1266
1267*ruby-1.9.1 (21 Mar 2009)
1268
1269 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1270 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1271 +ruby-1.9.1.ebuild:
1272 Adding Ruby 1.9.1 for preliminary testing
1273
1274 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1275 ruby-1.8.6_p287-r12.ebuild:
1276 Marked ~ppc for bug #252315.
1277
1278 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1279 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1280 bug 261982.
1281
1282 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1283 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1284 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1285 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1286 Cleanup
1287
1288*ruby-1.8.7_p72-r10 (07 Mar 2009)
1289
1290 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1291 +ruby-1.8.7_p72-r10.ebuild:
1292 Add a revision of ruby 1.8.7 using eselect ruby.
1293
1294 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1295 ~mips keyworded, bug #252315.
1296
1297 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1298 ruby-1.8.6_p287-r5.ebuild:
1299 ppc stable, bug #260006
1300
1301 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1302 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1303
1304 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1305 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1306 Fixing Tk USE flag test, bug 258893.
1307
1308 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1309 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1310
1311 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1312 ruby-1.8.6_p287-r5.ebuild:
1313 amd64 stable wrt security bug #260006
1314
1315 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1316 Stable for HPPA (bug #260006).
1317
1318 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1319 ruby-1.8.6_p287-r5.ebuild:
1320 Stable on alpha, bug #260006
1321
1322*ruby-1.8.7_p72-r2 (23 Feb 2009)
1323*ruby-1.8.6_p287-r12 (23 Feb 2009)
1324*ruby-1.8.6_p287-r5 (23 Feb 2009)
1325
1326 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1327 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1328 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1329 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1330 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1331 now before compilation if Tk useflags don't match) and 230748 (adding
1332 --enable-option-checking=no for newer versions of autoconf).
1333
1334 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1335 arm/ia64/s390/sh/sparc stable wrt #254307
1336
1337 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1338 ruby-1.8.6_p287-r4.ebuild:
1339 Stable on alpha, bug #254307
1340
1341 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1342 ruby-1.8.6_p287-r11.ebuild:
1343 keyword ~x86-fbsd, bug #252315
1344
1345 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1346 ppc stable #254307
1347
1348 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1349 amd64/x86 stable, bug #254307
1350
1351 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1352 stable ppc64, bug 254307
1353
1354 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1355 Stable for HPPA (bug #254307).
1356
1357 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1358 ruby-1.8.6_p287-r11.ebuild:
1359 Marked ~hppa (bug #252315).
1360
1361*ruby-1.8.6_p287-r11 (11 Jan 2009)
1362
1363 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1364 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1365 +ruby-1.8.6_p287-r11.ebuild:
1366 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1367 Fixes #254307.
1368
1369 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1370 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1371
1372 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1373 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1374
1375 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1376 ruby-1.8.6_p287-r10.ebuild:
1377 Add ~sparc keyword, bug #252315
1378
1379*ruby-1.8.6_p287-r10 (23 Dec 2008)
1380
1381 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1382 +ruby-1.8.6_p287-r10.ebuild:
1383 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1384 keywords since eselect-ruby does not yet have these keywords.
1385
1386 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1387 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1388 Revert the ruby-config changes. We can't remove them until we provide an
1389 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1390 for breaking things as mentioned in bug #251833.
1391
1392 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1393 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1394 ruby-1.8.7_p72-r1.ebuild:
1395 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1396 Thanks for the people noticing this in bug #251833.
1397
1398 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1399 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1400 ruby-1.8.7_p72-r1.ebuild:
1401 Drop dependency on ruby-config, which will be removed from the tree. We
1402 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1403 is no need for ruby-config at this moment. For newer versions of Ruby we will
1404 use eselect-ruby, which can be found in the ruby overlay at the moment.
1405
1406 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1407 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1408 Use mirror://ruby in SRC_URI, fixes #237392.
1409
1410 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1411 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1412 -ruby-1.8.7_p72.ebuild:
1413 Remove old versions. Leave one old stable version with cjk support.
1414
1415*ruby-1.8.6_p287-r3 (29 Nov 2008)
1416
1417 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1418 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1419 +ruby-1.8.6_p287-r3.ebuild:
1420 Fix our expansion limit patch according to debian bug report
1421 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1422 make sure people will pick up the fixed version. Thanks to Alex Legler for
1423 mentioning the patch.
1424
1425*ruby-1.8.7_p72-r1 (26 Nov 2008)
1426*ruby-1.8.6_p287-r2 (26 Nov 2008)
1427
1428 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1429 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1430 +ruby-1.8.7_p72-r1.ebuild:
1431 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1432 Thanks to Alex Legler for providing the patch.
1433
1434 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1435 -ruby-1.8.6_p287.ebuild:
1436 Remove versions that will not become stable
1437
1438 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1439 ruby-1.8.6_p287-r1.ebuild:
1440 ppc stable, bug #225465
1441
1442 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1443 ruby-1.8.6_p287-r1.ebuild:
1444 amd64 stable wrt security bug #225465
1445
1446 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1447 alpha/ia64/x86 stable wrt #225465
1448
1449 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1450 ruby-1.8.6_p287-r1.ebuild:
1451 Sparc stable --- Security Bug #225465 --- good since late August.
1452
1453 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1454 Stable on ppc64; bug #225465
1455
1456 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1457 Stable for HPPA (bug #225465).
1458
1459*ruby-1.8.6_p287-r1 (29 Aug 2008)
1460
1461 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1462 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1463 +ruby-1.8.6_p287-r1.ebuild:
1464 Fix REXML security issues, bug #236060.
1465
1466 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1467 Add GLEP 56 USE flag descriptions.
1468
1469*ruby-1.8.7_p72 (15 Aug 2008)
1470
1471 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1472 +ruby-1.8.7_p72.ebuild:
1473 bump 1.8.7 to latest patch release
1474
1475*ruby-1.8.6_p287 (11 Aug 2008)
1476
1477 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1478 Version bump for brown paper bag relelease.
1479
1480 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1481 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1482 Remove broken version in favor of the just-added 1.8.6_p286
1483
1484*ruby-1.8.6_p286 (10 Aug 2008)
1485
1486 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1487 Version bump to latest released version of ruby 1.8.6. This version fixes the
1488 security issues reported in #225465 and #234224. The cjk USE flag has been
1489 dropped since no compatible patches have been released yet.
1490
1491 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1492 ruby-1.8.6_p230.ebuild:
1493 drop cjk from SRC_URI as well
1494
1495 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1496 Drop cjk support since the most recent oniguruma patches no longer apply to
1497 this version, #230111.
1498
1499 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1500 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1501 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1502 Unfortunately the official p230 has a change which causes segmentation faults
1503 for applications like Rails and RSpec, so we are reverting that specific
1504 change.
1505
1506*ruby-1.8.7_p22 (29 Jun 2008)
1507
1508 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1509 +ruby-1.8.7_p22.ebuild:
1510 bump 1.8.7 for security fix
1511
1512 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1513 nevermind, don't bump this yet
1514
1515*ruby-1.8.6_p230 (20 Jun 2008)
1516
1517 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1518 version bump
1519
1520*ruby-1.8.7 (10 Jun 2008)
1521
1522 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1523 +ruby-1.8.7.ebuild:
1524 bump 1.8.7 to final
1525
1526*ruby-1.8.7_pre2 (21 Apr 2008)
1527
1528 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1529 +ruby-1.8.7_pre2.ebuild:
1530 Version Bump
4 1531
5*ruby-1.8.7_pre1 (16 Apr 2008) 1532*ruby-1.8.7_pre1 (16 Apr 2008)
6 1533
7 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild: 1534 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
8 Version bump. Drop cjk until a new version of oniguruma appears. 1535 Version bump. Drop cjk until a new version of oniguruma appears.

Legend:
Removed from v.1.333  
changed lines
  Added in v.1.692

  ViewVC Help
Powered by ViewVC 1.1.20