/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.480
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.480 2011/02/19 13:52:46 a3li Exp $
4
5*ruby-1.8.7_p334 (19 Feb 2011)
6
7 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
8 Version bump 1.8.7 series, security bug 355439
9
10 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
11 ruby-1.9.2.ebuild:
12 Remove PROVIDE for old-style virtual/ruby per bug 265054.
13
14 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
15 Remove masked ruby 1.8.6 per bug 332597.
16
17 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
18 -ruby-1.9.2_rc2.ebuild:
19 Removing old and vulnerable ebuilds
20
21 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
22 Marking ruby-1.8.7_p302 ppc64 for bug 332957
23
24 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
25 alpha/ia64/s390/sh/sparc stable wrt #332957
26
27*ruby-1.9.2 (24 Aug 2010)
28
29 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
30 metadata.xml:
31 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
32 and x86-fbsd due to a new dependency on rdoc.
33
34 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
35 arm stable, bug #332957
36
37 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
38 ruby-1.8.7_p302.ebuild:
39 x86 stable wrt security bug #332957
40
41 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
42 Stable on amd64 wrt bug #332957
43
44 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
45 Stable for PPC (bug #332957).
46
47 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
48 Stable for HPPA (bug #332957).
49
50*ruby-1.8.7_p302 (21 Aug 2010)
51
52 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
53 +ruby-1.8.7_p302.ebuild:
54 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
55 installation path.
56
57*ruby-1.8.6_p399 (19 Aug 2010)
58
59 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
60 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
61 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
62 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
63 installation path (reported by the x86 team in bug 332597)
64
65*ruby-1.9.2_rc2-r1 (18 Aug 2010)
66
67 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
68 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
69 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
70 the rubygems loading code. Add USE flag for psych.
71
72 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
73 ruby-1.9.2_rc2.ebuild:
74 Remove two keepdir that will try to keep an empty path, closes bug
75 #333163.
76
77 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
78 Marked ~ppc (bug #332593).
79
80 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
81 ruby-1.9.2_rc2.ebuild:
82 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
83
84 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
85 ruby-1.8.7_p299.ebuild:
86 Bump eselect-ruby dependency
87
88 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
89 -ruby-1.9.1_p429.ebuild:
90 Remove ebuild that is not target for unmask anyway.
91
92 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
93 ruby-1.9.2_rc2.ebuild:
94 Try 2 to fix the berkdb 5 issue on 1.9.
95
96 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
97 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
98 ruby-1.9.2_rc2.ebuild:
99 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
100 support for adding new patchsets without bumping the revision for all the
101 old ebuilds as well.
102
103*ruby-1.9.2_rc2 (14 Jul 2010)
104
105 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
106 +ruby-1.9.2_rc2.ebuild:
107 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
108 might cause _further_ build failures as it changed slightly behaviour.
109 You're going to need to rebuild rubygems and then all the packages
110 previously installed after upgrading to this.
111
112 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
113 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
114 -ruby-1.9.1_p376.ebuild:
115 Cleanup old versions.
116
117*ruby-1.9.1_p429 (04 Jul 2010)
118
119 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
120 +ruby-1.9.1_p429.ebuild:
121 Version bump to new 1.9.1 release.
122
123*ruby-1.8.7_p299 (23 Jun 2010)
124
125 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
126 +ruby-1.8.7_p299.ebuild:
127 Version bump.
128
129 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
130 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
131 remove useless comments
132
133 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
134 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
135 ruby-1.9.1_p376.ebuild:
136 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
137 dev.gentoo.org now.
138
139 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
140 ruby-1.9.1_p376.ebuild:
141 Use the correct RUBYLIB.
142
143*ruby-1.8.7_p249-r2 (18 May 2010)
144*ruby-1.8.6_p388-r1 (18 May 2010)
145
146 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
147 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
148 ruby-1.9.1_p376.ebuild, metadata.xml:
149 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
150 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
151 add USE flags for ncurses, readline and libedit, and properly depend on
152 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
153 Emacs versions support ruby-mode themselves and it should be even more
154 updated.
155
156*ruby-1.8.7_p249-r1 (06 May 2010)
157
158 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
159 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
160 309789 by Sune Kloppenborg Jeppesen.
161
162 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
163 ruby-1.8.7_p249.ebuild:
164 Use $PVR instead of $PV in patchset names
165
166 06 May 2010; Alex Legler <a3li@gentoo.org>
167 -files/ruby-1.8.6-memory-leak.diff,
168 -files/ruby18-mkmf-parallel-install.patch,
169 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
170 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
171 Remove old version. Cleanup in files/
172
173*ruby-1.9.1_p376 (01 May 2010)
174
175 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
176 Version bump. Fixes security bugs 296052 and 300468. No longer installs
177 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
178 instead.
179
180 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
181 -ruby-1.8.7_p174-r1.ebuild:
182 Remove vulnerable ebuilds, 300468
183
184 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
185 ruby-1.8.7_p249.ebuild:
186 amd64 stable, security bug 300468
187
188 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
189 ruby-1.8.7_p249.ebuild:
190 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
191
192 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
193 Stable for HPPA (bug #300468).
194
195 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
196 Stable for HPPA (bug #300468).
197
198 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
199 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
200
201 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
202 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
203
204 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
205 ruby-1.8.6_p388.ebuild:
206 stable x86, security bug 300468
207
208 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
209 ruby-1.8.7_p249.ebuild:
210 stable x86, security bug 300468
211
212*ruby-1.8.6_p388 (10 Jan 2010)
213
214 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
215 +ruby-1.8.6_p388.ebuild:
216 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
217 version. The new ebuild also has the fix for bug 168939.
218
219*ruby-1.8.7_p249 (10 Jan 2010)
220
221 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
222 +ruby-1.8.7_p249.ebuild:
223 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
224 version
225
226 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
227 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
228
229*ruby-1.8.7_p248 (25 Dec 2009)
230
231 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
232 Version bump
233
234 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
235 Remove old version.
236
237 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
238 Remove old version.
239
240 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
241 ia64/s390/sh stable wrt #288699
242
243 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
244 stable sparc, bug 288699
245
246 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
247 arm stable, bug #288699
248
249 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
250 amd64/x86 stable, bug #288699
251
252 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
253 ruby-1.8.7_p174-r1.ebuild:
254 Stable on alpha, bug #288699
255
256 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
257 ppc stable #288699
258
259 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
260 Stable for HPPA (bug #288699).
261
262 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
263 Marked ~hppa too.
264
265*ruby-1.8.7_p174-r1 (06 Oct 2009)
266
267 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
268 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
269 eselect-ruby cleanup feature.
270
271*ruby-1.9.1_p243 (09 Sep 2009)
272
273 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
274 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
275 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
276 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
277 -files/ruby19-rubygems-proxy.patch,
278 -files/ruby-1.9.1_p129-parallelmake.patch,
279 -files/ruby19-mkmf-parallel-install.patch:
280 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
281 168939. Cleaning up old patches.
282
283*ruby-1.8.6_p383 (20 Aug 2009)
284
285 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
286 Patchlevel bump.
287
288 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
289 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
290 ruby-1.9.1_p129-r1.ebuild:
291 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
292
293 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
294 Removing vulnerable ebuild, bug 273213.
295
296 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
297 Marking ruby-1.8.6_p369 ppc for bug 273213
298
299 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
300 ruby-1.9.1_p129-r1.ebuild:
301 Prepend our library path instead of overwriting it during src_install.
302 Thanks to the reporter of bug #274824.
303
304*ruby-1.8.7_p174 (18 Jun 2009)
305
306 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
307 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
308 Replacing 187_p173 with _p174 because of a regression. Unifying the
309 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
310 patchsets.
311
312 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
313 Marking ruby-1.8.6_p369 ppc64 for bug 273213
314
315 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
316 arm/ia64/s390/sh/sparc stable wrt #273213
317
318 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
319 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
320 Removing old version, minor cleanup
321
322 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
323 -files/ruby-1.8.6-openssl.patch,
324 -files/ruby-1.8.6-shortname_constants.patch,
325 -files/ruby-1.8.6_p111-r13657.patch,
326 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
327 Removing vulnerable old Ruby version and stale patches, bug 274108.
328
329 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
330 ruby-1.8.6_p369.ebuild:
331 Stable on alpha, bug #273213
332
333 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
334 Stable for HPPA (bug #273213).
335
336 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
337 ruby-1.8.6_p369.ebuild:
338 stable x86, security bug 273213
339
340 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
341 amd64 stable, security bug 273213.
342
343*ruby-1.8.7_p173 (10 Jun 2009)
344*ruby-1.8.6_p369 (10 Jun 2009)
345
346 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
347 +ruby-1.8.7_p173.ebuild:
348 Version bumps for bug #273213.
349
350*ruby-1.9.1_p129-r1 (27 May 2009)
351
352 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
353 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
354 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
355 +files/ruby-1.9.1_p129-parallelmake.patch:
356 Revision bump, add patches 1) to make Ruby behave more similarly between
357 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
358 extensions (undefined symbols in them will cause abort at runtime 3) to
359 remove a concurrency issue when building the dl extension that could
360 result in a broken dl.so.
361
362 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
363 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
364 Don't block rdoc-2 or later (which may enter Portage one day as it's
365 needed by some Rakefiles).
366
367 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
368 ruby-1.9.1_p129.ebuild:
369 Add ~x86-fbsd keyword.
370
371 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
372 keyword ~sparc-fbsd, bug #252315
373
374*ruby-1.9.1_p129 (15 May 2009)
375
376 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
377 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
378 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
379 included in every release.
380
381 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
382 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
383 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
384 ruby-1.8.7_p160.ebuild:
385 Removing vulnerable versions (#268515), fixing license (#233747).
386
387 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
388 Stable for HPPA (bug #268515).
389
390 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
391 Adapting rubygems notice.
392
393 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
394 amd64 stable, bug #268515.
395
396 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
397 arm/ia64/s390/sh/sparc stable wrt #268515
398
399 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
400 ruby-1.8.6_p368.ebuild:
401 stable x86, security bug 268515
402
403 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
404 ruby-1.8.6_p368.ebuild:
405 Stable on alpha, bug #268515
406
407 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
408 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
409
410*ruby-1.8.7_p160 (07 May 2009)
411*ruby-1.8.6_p368 (07 May 2009)
412
413 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
414 +ruby-1.8.7_p160.ebuild:
415 Version bump as per secbug 268515. NB: These are the first ebuilds that
416 no longer use ruby-config.
417
418*ruby-1.9.1-r1 (03 Apr 2009)
419*ruby-1.8.7_p72-r11 (03 Apr 2009)
420*ruby-1.8.6_p287-r13 (03 Apr 2009)
421
422 03 Apr 2009; Alex Legler <a3li@gentoo.org>
423 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
424 +files/ruby18-mkmf-parallel-install.patch,
425 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
426 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
427 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
428 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
429 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
430 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
431 happy.
432
433*ruby-1.9.1 (21 Mar 2009)
434
435 21 Mar 2009; Alex Legler <a3li@gentoo.org>
436 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
437 +ruby-1.9.1.ebuild:
438 Adding Ruby 1.9.1 for preliminary testing
439
440 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
441 ruby-1.8.6_p287-r12.ebuild:
442 Marked ~ppc for bug #252315.
4 443
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 444 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 445 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 446 bug 261982.
8 447

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.480

  ViewVC Help
Powered by ViewVC 1.1.20