/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.407
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.407 2009/06/10 05:45:28 a3li Exp $
4
5 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
6 amd64 stable, security bug 273213.
7
8*ruby-1.8.7_p173 (10 Jun 2009)
9*ruby-1.8.6_p369 (10 Jun 2009)
10
11 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
12 +ruby-1.8.7_p173.ebuild:
13 Version bumps for bug #273213.
14
15*ruby-1.9.1_p129-r1 (27 May 2009)
16
17 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
18 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
19 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
20 +files/ruby-1.9.1_p129-parallelmake.patch:
21 Revision bump, add patches 1) to make Ruby behave more similarly between
22 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
23 extensions (undefined symbols in them will cause abort at runtime 3) to
24 remove a concurrency issue when building the dl extension that could
25 result in a broken dl.so.
26
27 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
28 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
29 Don't block rdoc-2 or later (which may enter Portage one day as it's
30 needed by some Rakefiles).
31
32 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
33 ruby-1.9.1_p129.ebuild:
34 Add ~x86-fbsd keyword.
35
36 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
37 keyword ~sparc-fbsd, bug #252315
38
39*ruby-1.9.1_p129 (15 May 2009)
40
41 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
42 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
43 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
44 included in every release.
45
46 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
47 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
48 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
49 ruby-1.8.7_p160.ebuild:
50 Removing vulnerable versions (#268515), fixing license (#233747).
51
52 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
53 Stable for HPPA (bug #268515).
54
55 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
56 Adapting rubygems notice.
57
58 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
59 amd64 stable, bug #268515.
60
61 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
62 arm/ia64/s390/sh/sparc stable wrt #268515
63
64 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
65 ruby-1.8.6_p368.ebuild:
66 stable x86, security bug 268515
67
68 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
69 ruby-1.8.6_p368.ebuild:
70 Stable on alpha, bug #268515
71
72 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
73 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
74
75*ruby-1.8.7_p160 (07 May 2009)
76*ruby-1.8.6_p368 (07 May 2009)
77
78 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
79 +ruby-1.8.7_p160.ebuild:
80 Version bump as per secbug 268515. NB: These are the first ebuilds that
81 no longer use ruby-config.
82
83*ruby-1.9.1-r1 (03 Apr 2009)
84*ruby-1.8.7_p72-r11 (03 Apr 2009)
85*ruby-1.8.6_p287-r13 (03 Apr 2009)
86
87 03 Apr 2009; Alex Legler <a3li@gentoo.org>
88 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
89 +files/ruby18-mkmf-parallel-install.patch,
90 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
91 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
92 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
93 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
94 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
95 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
96 happy.
97
98*ruby-1.9.1 (21 Mar 2009)
99
100 21 Mar 2009; Alex Legler <a3li@gentoo.org>
101 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
102 +ruby-1.9.1.ebuild:
103 Adding Ruby 1.9.1 for preliminary testing
104
105 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
106 ruby-1.8.6_p287-r12.ebuild:
107 Marked ~ppc for bug #252315.
4 108
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 109 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 110 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 111 bug 261982.
8 112

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.407

  ViewVC Help
Powered by ViewVC 1.1.20