/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.486
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.486 2011/02/26 16:49:24 armin76 Exp $
4
5 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
6 alpha/arm/ia64/s390/sh stable wrt #355439
7
8 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
9 Marked ~ppc64 wrt #332593
10
11 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
12 ruby-1.8.7_p334.ebuild:
13 x86 stable wrt security bug #355439
14
15 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
16 ruby-1.8.7_p334.ebuild:
17 ppc/ppc64 stable wrt #355439
18
19 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
20 Stable on amd64 wrt bug #355439
21
22 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
23 Stable for HPPA (bug #355439).
24
25*ruby-1.8.7_p334 (19 Feb 2011)
26
27 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
28 Version bump 1.8.7 series, security bug 355439
29
30 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
31 ruby-1.9.2.ebuild:
32 Remove PROVIDE for old-style virtual/ruby per bug 265054.
33
34 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
35 Remove masked ruby 1.8.6 per bug 332597.
36
37 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
38 -ruby-1.9.2_rc2.ebuild:
39 Removing old and vulnerable ebuilds
40
41 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
42 Marking ruby-1.8.7_p302 ppc64 for bug 332957
43
44 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
45 alpha/ia64/s390/sh/sparc stable wrt #332957
46
47*ruby-1.9.2 (24 Aug 2010)
48
49 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
50 metadata.xml:
51 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
52 and x86-fbsd due to a new dependency on rdoc.
53
54 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
55 arm stable, bug #332957
56
57 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
58 ruby-1.8.7_p302.ebuild:
59 x86 stable wrt security bug #332957
60
61 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
62 Stable on amd64 wrt bug #332957
63
64 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
65 Stable for PPC (bug #332957).
66
67 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
68 Stable for HPPA (bug #332957).
69
70*ruby-1.8.7_p302 (21 Aug 2010)
71
72 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
73 +ruby-1.8.7_p302.ebuild:
74 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
75 installation path.
76
77*ruby-1.8.6_p399 (19 Aug 2010)
78
79 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
80 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
81 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
82 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
83 installation path (reported by the x86 team in bug 332597)
84
85*ruby-1.9.2_rc2-r1 (18 Aug 2010)
86
87 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
88 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
89 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
90 the rubygems loading code. Add USE flag for psych.
91
92 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
93 ruby-1.9.2_rc2.ebuild:
94 Remove two keepdir that will try to keep an empty path, closes bug
95 #333163.
96
97 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
98 Marked ~ppc (bug #332593).
99
100 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
101 ruby-1.9.2_rc2.ebuild:
102 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
103
104 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
105 ruby-1.8.7_p299.ebuild:
106 Bump eselect-ruby dependency
107
108 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
109 -ruby-1.9.1_p429.ebuild:
110 Remove ebuild that is not target for unmask anyway.
111
112 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
113 ruby-1.9.2_rc2.ebuild:
114 Try 2 to fix the berkdb 5 issue on 1.9.
115
116 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
117 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
118 ruby-1.9.2_rc2.ebuild:
119 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
120 support for adding new patchsets without bumping the revision for all the
121 old ebuilds as well.
122
123*ruby-1.9.2_rc2 (14 Jul 2010)
124
125 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
126 +ruby-1.9.2_rc2.ebuild:
127 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
128 might cause _further_ build failures as it changed slightly behaviour.
129 You're going to need to rebuild rubygems and then all the packages
130 previously installed after upgrading to this.
131
132 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
133 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
134 -ruby-1.9.1_p376.ebuild:
135 Cleanup old versions.
136
137*ruby-1.9.1_p429 (04 Jul 2010)
138
139 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
140 +ruby-1.9.1_p429.ebuild:
141 Version bump to new 1.9.1 release.
142
143*ruby-1.8.7_p299 (23 Jun 2010)
144
145 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
146 +ruby-1.8.7_p299.ebuild:
147 Version bump.
148
149 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
150 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
151 remove useless comments
152
153 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
154 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
155 ruby-1.9.1_p376.ebuild:
156 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
157 dev.gentoo.org now.
158
159 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
160 ruby-1.9.1_p376.ebuild:
161 Use the correct RUBYLIB.
162
163*ruby-1.8.7_p249-r2 (18 May 2010)
164*ruby-1.8.6_p388-r1 (18 May 2010)
165
166 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
167 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
168 ruby-1.9.1_p376.ebuild, metadata.xml:
169 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
170 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
171 add USE flags for ncurses, readline and libedit, and properly depend on
172 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
173 Emacs versions support ruby-mode themselves and it should be even more
174 updated.
175
176*ruby-1.8.7_p249-r1 (06 May 2010)
177
178 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
179 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
180 309789 by Sune Kloppenborg Jeppesen.
181
182 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
183 ruby-1.8.7_p249.ebuild:
184 Use $PVR instead of $PV in patchset names
185
186 06 May 2010; Alex Legler <a3li@gentoo.org>
187 -files/ruby-1.8.6-memory-leak.diff,
188 -files/ruby18-mkmf-parallel-install.patch,
189 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
190 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
191 Remove old version. Cleanup in files/
192
193*ruby-1.9.1_p376 (01 May 2010)
194
195 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
196 Version bump. Fixes security bugs 296052 and 300468. No longer installs
197 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
198 instead.
199
200 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
201 -ruby-1.8.7_p174-r1.ebuild:
202 Remove vulnerable ebuilds, 300468
203
204 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
205 ruby-1.8.7_p249.ebuild:
206 amd64 stable, security bug 300468
207
208 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
209 ruby-1.8.7_p249.ebuild:
210 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
211
212 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
213 Stable for HPPA (bug #300468).
214
215 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
216 Stable for HPPA (bug #300468).
217
218 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
219 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
220
221 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
222 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
223
224 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
225 ruby-1.8.6_p388.ebuild:
226 stable x86, security bug 300468
227
228 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
229 ruby-1.8.7_p249.ebuild:
230 stable x86, security bug 300468
231
232*ruby-1.8.6_p388 (10 Jan 2010)
233
234 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
235 +ruby-1.8.6_p388.ebuild:
236 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
237 version. The new ebuild also has the fix for bug 168939.
238
239*ruby-1.8.7_p249 (10 Jan 2010)
240
241 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
242 +ruby-1.8.7_p249.ebuild:
243 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
244 version
245
246 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
247 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
248
249*ruby-1.8.7_p248 (25 Dec 2009)
250
251 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
252 Version bump
253
254 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
255 Remove old version.
256
257 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
258 Remove old version.
259
260 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
261 ia64/s390/sh stable wrt #288699
262
263 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
264 stable sparc, bug 288699
265
266 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
267 arm stable, bug #288699
268
269 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
270 amd64/x86 stable, bug #288699
271
272 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
273 ruby-1.8.7_p174-r1.ebuild:
274 Stable on alpha, bug #288699
275
276 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
277 ppc stable #288699
278
279 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
280 Stable for HPPA (bug #288699).
281
282 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
283 Marked ~hppa too.
284
285*ruby-1.8.7_p174-r1 (06 Oct 2009)
286
287 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
288 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
289 eselect-ruby cleanup feature.
290
291*ruby-1.9.1_p243 (09 Sep 2009)
292
293 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
294 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
295 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
296 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
297 -files/ruby19-rubygems-proxy.patch,
298 -files/ruby-1.9.1_p129-parallelmake.patch,
299 -files/ruby19-mkmf-parallel-install.patch:
300 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
301 168939. Cleaning up old patches.
302
303*ruby-1.8.6_p383 (20 Aug 2009)
304
305 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
306 Patchlevel bump.
307
308 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
309 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
310 ruby-1.9.1_p129-r1.ebuild:
311 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
312
313 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
314 Removing vulnerable ebuild, bug 273213.
315
316 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
317 Marking ruby-1.8.6_p369 ppc for bug 273213
318
319 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
320 ruby-1.9.1_p129-r1.ebuild:
321 Prepend our library path instead of overwriting it during src_install.
322 Thanks to the reporter of bug #274824.
323
324*ruby-1.8.7_p174 (18 Jun 2009)
325
326 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
327 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
328 Replacing 187_p173 with _p174 because of a regression. Unifying the
329 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
330 patchsets.
331
332 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
333 Marking ruby-1.8.6_p369 ppc64 for bug 273213
334
335 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
336 arm/ia64/s390/sh/sparc stable wrt #273213
337
338 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
339 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
340 Removing old version, minor cleanup
341
342 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
343 -files/ruby-1.8.6-openssl.patch,
344 -files/ruby-1.8.6-shortname_constants.patch,
345 -files/ruby-1.8.6_p111-r13657.patch,
346 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
347 Removing vulnerable old Ruby version and stale patches, bug 274108.
348
349 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
350 ruby-1.8.6_p369.ebuild:
351 Stable on alpha, bug #273213
352
353 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
354 Stable for HPPA (bug #273213).
355
356 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
357 ruby-1.8.6_p369.ebuild:
358 stable x86, security bug 273213
359
360 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
361 amd64 stable, security bug 273213.
362
363*ruby-1.8.7_p173 (10 Jun 2009)
364*ruby-1.8.6_p369 (10 Jun 2009)
365
366 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
367 +ruby-1.8.7_p173.ebuild:
368 Version bumps for bug #273213.
369
370*ruby-1.9.1_p129-r1 (27 May 2009)
371
372 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
373 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
374 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
375 +files/ruby-1.9.1_p129-parallelmake.patch:
376 Revision bump, add patches 1) to make Ruby behave more similarly between
377 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
378 extensions (undefined symbols in them will cause abort at runtime 3) to
379 remove a concurrency issue when building the dl extension that could
380 result in a broken dl.so.
381
382 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
383 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
384 Don't block rdoc-2 or later (which may enter Portage one day as it's
385 needed by some Rakefiles).
386
387 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
388 ruby-1.9.1_p129.ebuild:
389 Add ~x86-fbsd keyword.
390
391 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
392 keyword ~sparc-fbsd, bug #252315
393
394*ruby-1.9.1_p129 (15 May 2009)
395
396 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
397 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
398 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
399 included in every release.
400
401 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
402 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
403 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
404 ruby-1.8.7_p160.ebuild:
405 Removing vulnerable versions (#268515), fixing license (#233747).
406
407 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
408 Stable for HPPA (bug #268515).
409
410 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
411 Adapting rubygems notice.
412
413 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
414 amd64 stable, bug #268515.
415
416 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
417 arm/ia64/s390/sh/sparc stable wrt #268515
418
419 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
420 ruby-1.8.6_p368.ebuild:
421 stable x86, security bug 268515
422
423 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
424 ruby-1.8.6_p368.ebuild:
425 Stable on alpha, bug #268515
426
427 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
428 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
429
430*ruby-1.8.7_p160 (07 May 2009)
431*ruby-1.8.6_p368 (07 May 2009)
432
433 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
434 +ruby-1.8.7_p160.ebuild:
435 Version bump as per secbug 268515. NB: These are the first ebuilds that
436 no longer use ruby-config.
437
438*ruby-1.9.1-r1 (03 Apr 2009)
439*ruby-1.8.7_p72-r11 (03 Apr 2009)
440*ruby-1.8.6_p287-r13 (03 Apr 2009)
441
442 03 Apr 2009; Alex Legler <a3li@gentoo.org>
443 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
444 +files/ruby18-mkmf-parallel-install.patch,
445 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
446 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
447 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
448 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
449 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
450 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
451 happy.
452
453*ruby-1.9.1 (21 Mar 2009)
454
455 21 Mar 2009; Alex Legler <a3li@gentoo.org>
456 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
457 +ruby-1.9.1.ebuild:
458 Adding Ruby 1.9.1 for preliminary testing
459
460 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
461 ruby-1.8.6_p287-r12.ebuild:
462 Marked ~ppc for bug #252315.
4 463
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 464 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 465 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 466 bug 261982.
8 467

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.486

  ViewVC Help
Powered by ViewVC 1.1.20