/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.493
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.493 2011/06/01 09:27:49 klausman Exp $
4
5 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
6 ruby-1.8.7_p334-r1.ebuild:
7 Stable on alpha, bug #369141
8
9*ruby-1.8.7_p334-r1 (31 May 2011)
10
11 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
12 Revision bump for security bug 369141 (CVE-2011-0188)
13
14*ruby-1.9.2-r1 (16 May 2011)
15
16 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
17 Don't remove racc files since all other ruby targets ship these files
18 themselves as well. Closes bug 363419.
19
20 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
21 ruby-1.8.7_p334.ebuild:
22 Remove old version. Remove obsolete and unused old-style virtual/ruby.
23
24 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
25 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
26
27 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
28 Add append-flags -mieee on sh, bug #357559
29
30 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
31 alpha/arm/ia64/s390/sh stable wrt #355439
32
33 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
34 Marked ~ppc64 wrt #332593
35
36 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
37 ruby-1.8.7_p334.ebuild:
38 x86 stable wrt security bug #355439
39
40 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
41 ruby-1.8.7_p334.ebuild:
42 ppc/ppc64 stable wrt #355439
43
44 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
45 Stable on amd64 wrt bug #355439
46
47 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
48 Stable for HPPA (bug #355439).
49
50*ruby-1.8.7_p334 (19 Feb 2011)
51
52 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
53 Version bump 1.8.7 series, security bug 355439
54
55 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
56 ruby-1.9.2.ebuild:
57 Remove PROVIDE for old-style virtual/ruby per bug 265054.
58
59 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
60 Remove masked ruby 1.8.6 per bug 332597.
61
62 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
63 -ruby-1.9.2_rc2.ebuild:
64 Removing old and vulnerable ebuilds
65
66 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
67 Marking ruby-1.8.7_p302 ppc64 for bug 332957
68
69 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
70 alpha/ia64/s390/sh/sparc stable wrt #332957
71
72*ruby-1.9.2 (24 Aug 2010)
73
74 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
75 metadata.xml:
76 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
77 and x86-fbsd due to a new dependency on rdoc.
78
79 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
80 arm stable, bug #332957
81
82 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
83 ruby-1.8.7_p302.ebuild:
84 x86 stable wrt security bug #332957
85
86 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
87 Stable on amd64 wrt bug #332957
88
89 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
90 Stable for PPC (bug #332957).
91
92 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
93 Stable for HPPA (bug #332957).
94
95*ruby-1.8.7_p302 (21 Aug 2010)
96
97 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
98 +ruby-1.8.7_p302.ebuild:
99 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
100 installation path.
101
102*ruby-1.8.6_p399 (19 Aug 2010)
103
104 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
105 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
106 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
107 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
108 installation path (reported by the x86 team in bug 332597)
109
110*ruby-1.9.2_rc2-r1 (18 Aug 2010)
111
112 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
113 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
114 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
115 the rubygems loading code. Add USE flag for psych.
116
117 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
118 ruby-1.9.2_rc2.ebuild:
119 Remove two keepdir that will try to keep an empty path, closes bug
120 #333163.
121
122 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
123 Marked ~ppc (bug #332593).
124
125 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
126 ruby-1.9.2_rc2.ebuild:
127 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
128
129 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
130 ruby-1.8.7_p299.ebuild:
131 Bump eselect-ruby dependency
132
133 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
134 -ruby-1.9.1_p429.ebuild:
135 Remove ebuild that is not target for unmask anyway.
136
137 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
138 ruby-1.9.2_rc2.ebuild:
139 Try 2 to fix the berkdb 5 issue on 1.9.
140
141 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
142 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
143 ruby-1.9.2_rc2.ebuild:
144 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
145 support for adding new patchsets without bumping the revision for all the
146 old ebuilds as well.
147
148*ruby-1.9.2_rc2 (14 Jul 2010)
149
150 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
151 +ruby-1.9.2_rc2.ebuild:
152 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
153 might cause _further_ build failures as it changed slightly behaviour.
154 You're going to need to rebuild rubygems and then all the packages
155 previously installed after upgrading to this.
156
157 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
158 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
159 -ruby-1.9.1_p376.ebuild:
160 Cleanup old versions.
161
162*ruby-1.9.1_p429 (04 Jul 2010)
163
164 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
165 +ruby-1.9.1_p429.ebuild:
166 Version bump to new 1.9.1 release.
167
168*ruby-1.8.7_p299 (23 Jun 2010)
169
170 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
171 +ruby-1.8.7_p299.ebuild:
172 Version bump.
173
174 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
175 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
176 remove useless comments
177
178 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
179 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
180 ruby-1.9.1_p376.ebuild:
181 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
182 dev.gentoo.org now.
183
184 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
185 ruby-1.9.1_p376.ebuild:
186 Use the correct RUBYLIB.
187
188*ruby-1.8.7_p249-r2 (18 May 2010)
189*ruby-1.8.6_p388-r1 (18 May 2010)
190
191 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
192 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
193 ruby-1.9.1_p376.ebuild, metadata.xml:
194 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
195 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
196 add USE flags for ncurses, readline and libedit, and properly depend on
197 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
198 Emacs versions support ruby-mode themselves and it should be even more
199 updated.
200
201*ruby-1.8.7_p249-r1 (06 May 2010)
202
203 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
204 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
205 309789 by Sune Kloppenborg Jeppesen.
206
207 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
208 ruby-1.8.7_p249.ebuild:
209 Use $PVR instead of $PV in patchset names
210
211 06 May 2010; Alex Legler <a3li@gentoo.org>
212 -files/ruby-1.8.6-memory-leak.diff,
213 -files/ruby18-mkmf-parallel-install.patch,
214 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
215 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
216 Remove old version. Cleanup in files/
217
218*ruby-1.9.1_p376 (01 May 2010)
219
220 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
221 Version bump. Fixes security bugs 296052 and 300468. No longer installs
222 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
223 instead.
224
225 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
226 -ruby-1.8.7_p174-r1.ebuild:
227 Remove vulnerable ebuilds, 300468
228
229 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
230 ruby-1.8.7_p249.ebuild:
231 amd64 stable, security bug 300468
232
233 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
234 ruby-1.8.7_p249.ebuild:
235 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
236
237 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
238 Stable for HPPA (bug #300468).
239
240 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
241 Stable for HPPA (bug #300468).
242
243 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
244 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
245
246 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
247 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
248
249 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
250 ruby-1.8.6_p388.ebuild:
251 stable x86, security bug 300468
252
253 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
254 ruby-1.8.7_p249.ebuild:
255 stable x86, security bug 300468
256
257*ruby-1.8.6_p388 (10 Jan 2010)
258
259 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
260 +ruby-1.8.6_p388.ebuild:
261 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
262 version. The new ebuild also has the fix for bug 168939.
263
264*ruby-1.8.7_p249 (10 Jan 2010)
265
266 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
267 +ruby-1.8.7_p249.ebuild:
268 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
269 version
270
271 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
272 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
273
274*ruby-1.8.7_p248 (25 Dec 2009)
275
276 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
277 Version bump
278
279 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
280 Remove old version.
281
282 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
283 Remove old version.
284
285 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
286 ia64/s390/sh stable wrt #288699
287
288 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
289 stable sparc, bug 288699
290
291 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
292 arm stable, bug #288699
293
294 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
295 amd64/x86 stable, bug #288699
296
297 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
298 ruby-1.8.7_p174-r1.ebuild:
299 Stable on alpha, bug #288699
300
301 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
302 ppc stable #288699
303
304 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
305 Stable for HPPA (bug #288699).
306
307 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
308 Marked ~hppa too.
309
310*ruby-1.8.7_p174-r1 (06 Oct 2009)
311
312 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
313 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
314 eselect-ruby cleanup feature.
315
316*ruby-1.9.1_p243 (09 Sep 2009)
317
318 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
319 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
320 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
321 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
322 -files/ruby19-rubygems-proxy.patch,
323 -files/ruby-1.9.1_p129-parallelmake.patch,
324 -files/ruby19-mkmf-parallel-install.patch:
325 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
326 168939. Cleaning up old patches.
327
328*ruby-1.8.6_p383 (20 Aug 2009)
329
330 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
331 Patchlevel bump.
332
333 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
334 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
335 ruby-1.9.1_p129-r1.ebuild:
336 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
337
338 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
339 Removing vulnerable ebuild, bug 273213.
340
341 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
342 Marking ruby-1.8.6_p369 ppc for bug 273213
343
344 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
345 ruby-1.9.1_p129-r1.ebuild:
346 Prepend our library path instead of overwriting it during src_install.
347 Thanks to the reporter of bug #274824.
348
349*ruby-1.8.7_p174 (18 Jun 2009)
350
351 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
352 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
353 Replacing 187_p173 with _p174 because of a regression. Unifying the
354 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
355 patchsets.
356
357 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
358 Marking ruby-1.8.6_p369 ppc64 for bug 273213
359
360 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
361 arm/ia64/s390/sh/sparc stable wrt #273213
362
363 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
364 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
365 Removing old version, minor cleanup
366
367 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
368 -files/ruby-1.8.6-openssl.patch,
369 -files/ruby-1.8.6-shortname_constants.patch,
370 -files/ruby-1.8.6_p111-r13657.patch,
371 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
372 Removing vulnerable old Ruby version and stale patches, bug 274108.
373
374 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
375 ruby-1.8.6_p369.ebuild:
376 Stable on alpha, bug #273213
377
378 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
379 Stable for HPPA (bug #273213).
380
381 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
382 ruby-1.8.6_p369.ebuild:
383 stable x86, security bug 273213
384
385 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
386 amd64 stable, security bug 273213.
387
388*ruby-1.8.7_p173 (10 Jun 2009)
389*ruby-1.8.6_p369 (10 Jun 2009)
390
391 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
392 +ruby-1.8.7_p173.ebuild:
393 Version bumps for bug #273213.
394
395*ruby-1.9.1_p129-r1 (27 May 2009)
396
397 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
398 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
399 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
400 +files/ruby-1.9.1_p129-parallelmake.patch:
401 Revision bump, add patches 1) to make Ruby behave more similarly between
402 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
403 extensions (undefined symbols in them will cause abort at runtime 3) to
404 remove a concurrency issue when building the dl extension that could
405 result in a broken dl.so.
406
407 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
408 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
409 Don't block rdoc-2 or later (which may enter Portage one day as it's
410 needed by some Rakefiles).
411
412 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
413 ruby-1.9.1_p129.ebuild:
414 Add ~x86-fbsd keyword.
415
416 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
417 keyword ~sparc-fbsd, bug #252315
418
419*ruby-1.9.1_p129 (15 May 2009)
420
421 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
422 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
423 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
424 included in every release.
425
426 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
427 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
428 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
429 ruby-1.8.7_p160.ebuild:
430 Removing vulnerable versions (#268515), fixing license (#233747).
431
432 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
433 Stable for HPPA (bug #268515).
434
435 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
436 Adapting rubygems notice.
437
438 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
439 amd64 stable, bug #268515.
440
441 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
442 arm/ia64/s390/sh/sparc stable wrt #268515
443
444 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
445 ruby-1.8.6_p368.ebuild:
446 stable x86, security bug 268515
447
448 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
449 ruby-1.8.6_p368.ebuild:
450 Stable on alpha, bug #268515
451
452 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
453 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
454
455*ruby-1.8.7_p160 (07 May 2009)
456*ruby-1.8.6_p368 (07 May 2009)
457
458 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
459 +ruby-1.8.7_p160.ebuild:
460 Version bump as per secbug 268515. NB: These are the first ebuilds that
461 no longer use ruby-config.
462
463*ruby-1.9.1-r1 (03 Apr 2009)
464*ruby-1.8.7_p72-r11 (03 Apr 2009)
465*ruby-1.8.6_p287-r13 (03 Apr 2009)
466
467 03 Apr 2009; Alex Legler <a3li@gentoo.org>
468 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
469 +files/ruby18-mkmf-parallel-install.patch,
470 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
471 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
472 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
473 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
474 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
475 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
476 happy.
477
478*ruby-1.9.1 (21 Mar 2009)
479
480 21 Mar 2009; Alex Legler <a3li@gentoo.org>
481 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
482 +ruby-1.9.1.ebuild:
483 Adding Ruby 1.9.1 for preliminary testing
484
485 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
486 ruby-1.8.6_p287-r12.ebuild:
487 Marked ~ppc for bug #252315.
4 488
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 489 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 490 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 491 bug 261982.
8 492

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.493

  ViewVC Help
Powered by ViewVC 1.1.20