/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.494
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.494 2011/06/01 15:13:17 hwoarang Exp $
4
5 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
6 Stable on amd64 wrt bug #369141
7
8 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
9 ruby-1.8.7_p334-r1.ebuild:
10 Stable on alpha, bug #369141
11
12*ruby-1.8.7_p334-r1 (31 May 2011)
13
14 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
15 Revision bump for security bug 369141 (CVE-2011-0188)
16
17*ruby-1.9.2-r1 (16 May 2011)
18
19 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
20 Don't remove racc files since all other ruby targets ship these files
21 themselves as well. Closes bug 363419.
22
23 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
24 ruby-1.8.7_p334.ebuild:
25 Remove old version. Remove obsolete and unused old-style virtual/ruby.
26
27 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
28 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
29
30 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
31 Add append-flags -mieee on sh, bug #357559
32
33 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
34 alpha/arm/ia64/s390/sh stable wrt #355439
35
36 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
37 Marked ~ppc64 wrt #332593
38
39 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
40 ruby-1.8.7_p334.ebuild:
41 x86 stable wrt security bug #355439
42
43 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
44 ruby-1.8.7_p334.ebuild:
45 ppc/ppc64 stable wrt #355439
46
47 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
48 Stable on amd64 wrt bug #355439
49
50 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
51 Stable for HPPA (bug #355439).
52
53*ruby-1.8.7_p334 (19 Feb 2011)
54
55 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
56 Version bump 1.8.7 series, security bug 355439
57
58 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
59 ruby-1.9.2.ebuild:
60 Remove PROVIDE for old-style virtual/ruby per bug 265054.
61
62 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
63 Remove masked ruby 1.8.6 per bug 332597.
64
65 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
66 -ruby-1.9.2_rc2.ebuild:
67 Removing old and vulnerable ebuilds
68
69 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
70 Marking ruby-1.8.7_p302 ppc64 for bug 332957
71
72 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
73 alpha/ia64/s390/sh/sparc stable wrt #332957
74
75*ruby-1.9.2 (24 Aug 2010)
76
77 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
78 metadata.xml:
79 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
80 and x86-fbsd due to a new dependency on rdoc.
81
82 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
83 arm stable, bug #332957
84
85 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
86 ruby-1.8.7_p302.ebuild:
87 x86 stable wrt security bug #332957
88
89 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
90 Stable on amd64 wrt bug #332957
91
92 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
93 Stable for PPC (bug #332957).
94
95 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
96 Stable for HPPA (bug #332957).
97
98*ruby-1.8.7_p302 (21 Aug 2010)
99
100 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
101 +ruby-1.8.7_p302.ebuild:
102 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
103 installation path.
104
105*ruby-1.8.6_p399 (19 Aug 2010)
106
107 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
108 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
109 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
110 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
111 installation path (reported by the x86 team in bug 332597)
112
113*ruby-1.9.2_rc2-r1 (18 Aug 2010)
114
115 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
116 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
117 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
118 the rubygems loading code. Add USE flag for psych.
119
120 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
121 ruby-1.9.2_rc2.ebuild:
122 Remove two keepdir that will try to keep an empty path, closes bug
123 #333163.
124
125 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
126 Marked ~ppc (bug #332593).
127
128 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
129 ruby-1.9.2_rc2.ebuild:
130 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
131
132 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
133 ruby-1.8.7_p299.ebuild:
134 Bump eselect-ruby dependency
135
136 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
137 -ruby-1.9.1_p429.ebuild:
138 Remove ebuild that is not target for unmask anyway.
139
140 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
141 ruby-1.9.2_rc2.ebuild:
142 Try 2 to fix the berkdb 5 issue on 1.9.
143
144 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
145 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
146 ruby-1.9.2_rc2.ebuild:
147 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
148 support for adding new patchsets without bumping the revision for all the
149 old ebuilds as well.
150
151*ruby-1.9.2_rc2 (14 Jul 2010)
152
153 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
154 +ruby-1.9.2_rc2.ebuild:
155 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
156 might cause _further_ build failures as it changed slightly behaviour.
157 You're going to need to rebuild rubygems and then all the packages
158 previously installed after upgrading to this.
159
160 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
161 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
162 -ruby-1.9.1_p376.ebuild:
163 Cleanup old versions.
164
165*ruby-1.9.1_p429 (04 Jul 2010)
166
167 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
168 +ruby-1.9.1_p429.ebuild:
169 Version bump to new 1.9.1 release.
170
171*ruby-1.8.7_p299 (23 Jun 2010)
172
173 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
174 +ruby-1.8.7_p299.ebuild:
175 Version bump.
176
177 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
178 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
179 remove useless comments
180
181 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
182 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
183 ruby-1.9.1_p376.ebuild:
184 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
185 dev.gentoo.org now.
186
187 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
188 ruby-1.9.1_p376.ebuild:
189 Use the correct RUBYLIB.
190
191*ruby-1.8.7_p249-r2 (18 May 2010)
192*ruby-1.8.6_p388-r1 (18 May 2010)
193
194 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
195 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
196 ruby-1.9.1_p376.ebuild, metadata.xml:
197 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
198 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
199 add USE flags for ncurses, readline and libedit, and properly depend on
200 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
201 Emacs versions support ruby-mode themselves and it should be even more
202 updated.
203
204*ruby-1.8.7_p249-r1 (06 May 2010)
205
206 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
207 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
208 309789 by Sune Kloppenborg Jeppesen.
209
210 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
211 ruby-1.8.7_p249.ebuild:
212 Use $PVR instead of $PV in patchset names
213
214 06 May 2010; Alex Legler <a3li@gentoo.org>
215 -files/ruby-1.8.6-memory-leak.diff,
216 -files/ruby18-mkmf-parallel-install.patch,
217 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
218 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
219 Remove old version. Cleanup in files/
220
221*ruby-1.9.1_p376 (01 May 2010)
222
223 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
224 Version bump. Fixes security bugs 296052 and 300468. No longer installs
225 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
226 instead.
227
228 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
229 -ruby-1.8.7_p174-r1.ebuild:
230 Remove vulnerable ebuilds, 300468
231
232 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
233 ruby-1.8.7_p249.ebuild:
234 amd64 stable, security bug 300468
235
236 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
237 ruby-1.8.7_p249.ebuild:
238 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
239
240 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
241 Stable for HPPA (bug #300468).
242
243 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
244 Stable for HPPA (bug #300468).
245
246 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
247 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
248
249 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
250 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
251
252 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
253 ruby-1.8.6_p388.ebuild:
254 stable x86, security bug 300468
255
256 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
257 ruby-1.8.7_p249.ebuild:
258 stable x86, security bug 300468
259
260*ruby-1.8.6_p388 (10 Jan 2010)
261
262 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
263 +ruby-1.8.6_p388.ebuild:
264 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
265 version. The new ebuild also has the fix for bug 168939.
266
267*ruby-1.8.7_p249 (10 Jan 2010)
268
269 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
270 +ruby-1.8.7_p249.ebuild:
271 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
272 version
273
274 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
275 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
276
277*ruby-1.8.7_p248 (25 Dec 2009)
278
279 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
280 Version bump
281
282 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
283 Remove old version.
284
285 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
286 Remove old version.
287
288 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
289 ia64/s390/sh stable wrt #288699
290
291 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
292 stable sparc, bug 288699
293
294 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
295 arm stable, bug #288699
296
297 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
298 amd64/x86 stable, bug #288699
299
300 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
301 ruby-1.8.7_p174-r1.ebuild:
302 Stable on alpha, bug #288699
303
304 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
305 ppc stable #288699
306
307 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
308 Stable for HPPA (bug #288699).
309
310 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
311 Marked ~hppa too.
312
313*ruby-1.8.7_p174-r1 (06 Oct 2009)
314
315 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
316 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
317 eselect-ruby cleanup feature.
318
319*ruby-1.9.1_p243 (09 Sep 2009)
320
321 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
322 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
323 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
324 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
325 -files/ruby19-rubygems-proxy.patch,
326 -files/ruby-1.9.1_p129-parallelmake.patch,
327 -files/ruby19-mkmf-parallel-install.patch:
328 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
329 168939. Cleaning up old patches.
330
331*ruby-1.8.6_p383 (20 Aug 2009)
332
333 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
334 Patchlevel bump.
335
336 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
337 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
338 ruby-1.9.1_p129-r1.ebuild:
339 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
340
341 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
342 Removing vulnerable ebuild, bug 273213.
343
344 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
345 Marking ruby-1.8.6_p369 ppc for bug 273213
346
347 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
348 ruby-1.9.1_p129-r1.ebuild:
349 Prepend our library path instead of overwriting it during src_install.
350 Thanks to the reporter of bug #274824.
351
352*ruby-1.8.7_p174 (18 Jun 2009)
353
354 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
355 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
356 Replacing 187_p173 with _p174 because of a regression. Unifying the
357 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
358 patchsets.
359
360 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
361 Marking ruby-1.8.6_p369 ppc64 for bug 273213
362
363 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
364 arm/ia64/s390/sh/sparc stable wrt #273213
365
366 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
367 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
368 Removing old version, minor cleanup
369
370 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
371 -files/ruby-1.8.6-openssl.patch,
372 -files/ruby-1.8.6-shortname_constants.patch,
373 -files/ruby-1.8.6_p111-r13657.patch,
374 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
375 Removing vulnerable old Ruby version and stale patches, bug 274108.
376
377 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
378 ruby-1.8.6_p369.ebuild:
379 Stable on alpha, bug #273213
380
381 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
382 Stable for HPPA (bug #273213).
383
384 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
385 ruby-1.8.6_p369.ebuild:
386 stable x86, security bug 273213
387
388 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
389 amd64 stable, security bug 273213.
390
391*ruby-1.8.7_p173 (10 Jun 2009)
392*ruby-1.8.6_p369 (10 Jun 2009)
393
394 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
395 +ruby-1.8.7_p173.ebuild:
396 Version bumps for bug #273213.
397
398*ruby-1.9.1_p129-r1 (27 May 2009)
399
400 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
401 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
402 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
403 +files/ruby-1.9.1_p129-parallelmake.patch:
404 Revision bump, add patches 1) to make Ruby behave more similarly between
405 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
406 extensions (undefined symbols in them will cause abort at runtime 3) to
407 remove a concurrency issue when building the dl extension that could
408 result in a broken dl.so.
409
410 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
411 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
412 Don't block rdoc-2 or later (which may enter Portage one day as it's
413 needed by some Rakefiles).
414
415 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
416 ruby-1.9.1_p129.ebuild:
417 Add ~x86-fbsd keyword.
418
419 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
420 keyword ~sparc-fbsd, bug #252315
421
422*ruby-1.9.1_p129 (15 May 2009)
423
424 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
425 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
426 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
427 included in every release.
428
429 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
430 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
431 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
432 ruby-1.8.7_p160.ebuild:
433 Removing vulnerable versions (#268515), fixing license (#233747).
434
435 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
436 Stable for HPPA (bug #268515).
437
438 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
439 Adapting rubygems notice.
440
441 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
442 amd64 stable, bug #268515.
443
444 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
445 arm/ia64/s390/sh/sparc stable wrt #268515
446
447 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
448 ruby-1.8.6_p368.ebuild:
449 stable x86, security bug 268515
450
451 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
452 ruby-1.8.6_p368.ebuild:
453 Stable on alpha, bug #268515
454
455 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
456 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
457
458*ruby-1.8.7_p160 (07 May 2009)
459*ruby-1.8.6_p368 (07 May 2009)
460
461 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
462 +ruby-1.8.7_p160.ebuild:
463 Version bump as per secbug 268515. NB: These are the first ebuilds that
464 no longer use ruby-config.
465
466*ruby-1.9.1-r1 (03 Apr 2009)
467*ruby-1.8.7_p72-r11 (03 Apr 2009)
468*ruby-1.8.6_p287-r13 (03 Apr 2009)
469
470 03 Apr 2009; Alex Legler <a3li@gentoo.org>
471 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
472 +files/ruby18-mkmf-parallel-install.patch,
473 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
474 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
475 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
476 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
477 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
478 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
479 happy.
480
481*ruby-1.9.1 (21 Mar 2009)
482
483 21 Mar 2009; Alex Legler <a3li@gentoo.org>
484 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
485 +ruby-1.9.1.ebuild:
486 Adding Ruby 1.9.1 for preliminary testing
487
488 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
489 ruby-1.8.6_p287-r12.ebuild:
490 Marked ~ppc for bug #252315.
4 491
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 492 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 493 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 494 bug 261982.
8 495

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.494

  ViewVC Help
Powered by ViewVC 1.1.20