/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.502
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.502 2011/08/10 18:16:07 xarthisius Exp $
4
5 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
6 ruby-1.8.7_p334-r2.ebuild:
7 ppc/ppc64 stable wrt #378691
8
9*ruby-1.8.7_p334-r2 (22 Jul 2011)
10
11 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
12 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
13 for chasing down upstream and us.
14
15 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
16 Added ~mips, bug 332593
17
18 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
19 ruby-1.8.7_p334-r1.ebuild:
20 ppc64 stable wrt #369141
21
22 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
23 ia64/s390/sh/sparc stable wrt #369141
24
25 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
26 Stable for HPPA (bug #369141).
27
28 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
29 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
30
31 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
32 arm/x86 stable, bug #369141
33
34 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
35 Stable on amd64 wrt bug #369141
36
37 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
38 ruby-1.8.7_p334-r1.ebuild:
39 Stable on alpha, bug #369141
40
41*ruby-1.8.7_p334-r1 (31 May 2011)
42
43 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
44 Revision bump for security bug 369141 (CVE-2011-0188)
45
46*ruby-1.9.2-r1 (16 May 2011)
47
48 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
49 Don't remove racc files since all other ruby targets ship these files
50 themselves as well. Closes bug 363419.
51
52 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
53 ruby-1.8.7_p334.ebuild:
54 Remove old version. Remove obsolete and unused old-style virtual/ruby.
55
56 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
57 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
58
59 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
60 Add append-flags -mieee on sh, bug #357559
61
62 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
63 alpha/arm/ia64/s390/sh stable wrt #355439
64
65 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
66 Marked ~ppc64 wrt #332593
67
68 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
69 ruby-1.8.7_p334.ebuild:
70 x86 stable wrt security bug #355439
71
72 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
73 ruby-1.8.7_p334.ebuild:
74 ppc/ppc64 stable wrt #355439
75
76 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
77 Stable on amd64 wrt bug #355439
78
79 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
80 Stable for HPPA (bug #355439).
81
82*ruby-1.8.7_p334 (19 Feb 2011)
83
84 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
85 Version bump 1.8.7 series, security bug 355439
86
87 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
88 ruby-1.9.2.ebuild:
89 Remove PROVIDE for old-style virtual/ruby per bug 265054.
90
91 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
92 Remove masked ruby 1.8.6 per bug 332597.
93
94 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
95 -ruby-1.9.2_rc2.ebuild:
96 Removing old and vulnerable ebuilds
97
98 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
99 Marking ruby-1.8.7_p302 ppc64 for bug 332957
100
101 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
102 alpha/ia64/s390/sh/sparc stable wrt #332957
103
104*ruby-1.9.2 (24 Aug 2010)
105
106 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
107 metadata.xml:
108 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
109 and x86-fbsd due to a new dependency on rdoc.
110
111 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
112 arm stable, bug #332957
113
114 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
115 ruby-1.8.7_p302.ebuild:
116 x86 stable wrt security bug #332957
117
118 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
119 Stable on amd64 wrt bug #332957
120
121 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
122 Stable for PPC (bug #332957).
123
124 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
125 Stable for HPPA (bug #332957).
126
127*ruby-1.8.7_p302 (21 Aug 2010)
128
129 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
130 +ruby-1.8.7_p302.ebuild:
131 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
132 installation path.
133
134*ruby-1.8.6_p399 (19 Aug 2010)
135
136 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
137 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
138 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
139 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
140 installation path (reported by the x86 team in bug 332597)
141
142*ruby-1.9.2_rc2-r1 (18 Aug 2010)
143
144 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
145 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
146 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
147 the rubygems loading code. Add USE flag for psych.
148
149 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
150 ruby-1.9.2_rc2.ebuild:
151 Remove two keepdir that will try to keep an empty path, closes bug
152 #333163.
153
154 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
155 Marked ~ppc (bug #332593).
156
157 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
158 ruby-1.9.2_rc2.ebuild:
159 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
160
161 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
162 ruby-1.8.7_p299.ebuild:
163 Bump eselect-ruby dependency
164
165 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
166 -ruby-1.9.1_p429.ebuild:
167 Remove ebuild that is not target for unmask anyway.
168
169 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
170 ruby-1.9.2_rc2.ebuild:
171 Try 2 to fix the berkdb 5 issue on 1.9.
172
173 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
174 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
175 ruby-1.9.2_rc2.ebuild:
176 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
177 support for adding new patchsets without bumping the revision for all the
178 old ebuilds as well.
179
180*ruby-1.9.2_rc2 (14 Jul 2010)
181
182 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
183 +ruby-1.9.2_rc2.ebuild:
184 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
185 might cause _further_ build failures as it changed slightly behaviour.
186 You're going to need to rebuild rubygems and then all the packages
187 previously installed after upgrading to this.
188
189 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
190 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
191 -ruby-1.9.1_p376.ebuild:
192 Cleanup old versions.
193
194*ruby-1.9.1_p429 (04 Jul 2010)
195
196 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
197 +ruby-1.9.1_p429.ebuild:
198 Version bump to new 1.9.1 release.
199
200*ruby-1.8.7_p299 (23 Jun 2010)
201
202 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
203 +ruby-1.8.7_p299.ebuild:
204 Version bump.
205
206 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
207 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
208 remove useless comments
209
210 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
211 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
212 ruby-1.9.1_p376.ebuild:
213 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
214 dev.gentoo.org now.
215
216 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
217 ruby-1.9.1_p376.ebuild:
218 Use the correct RUBYLIB.
219
220*ruby-1.8.7_p249-r2 (18 May 2010)
221*ruby-1.8.6_p388-r1 (18 May 2010)
222
223 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
224 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
225 ruby-1.9.1_p376.ebuild, metadata.xml:
226 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
227 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
228 add USE flags for ncurses, readline and libedit, and properly depend on
229 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
230 Emacs versions support ruby-mode themselves and it should be even more
231 updated.
232
233*ruby-1.8.7_p249-r1 (06 May 2010)
234
235 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
236 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
237 309789 by Sune Kloppenborg Jeppesen.
238
239 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
240 ruby-1.8.7_p249.ebuild:
241 Use $PVR instead of $PV in patchset names
242
243 06 May 2010; Alex Legler <a3li@gentoo.org>
244 -files/ruby-1.8.6-memory-leak.diff,
245 -files/ruby18-mkmf-parallel-install.patch,
246 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
247 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
248 Remove old version. Cleanup in files/
249
250*ruby-1.9.1_p376 (01 May 2010)
251
252 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
253 Version bump. Fixes security bugs 296052 and 300468. No longer installs
254 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
255 instead.
256
257 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
258 -ruby-1.8.7_p174-r1.ebuild:
259 Remove vulnerable ebuilds, 300468
260
261 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
262 ruby-1.8.7_p249.ebuild:
263 amd64 stable, security bug 300468
264
265 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
266 ruby-1.8.7_p249.ebuild:
267 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
268
269 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
270 Stable for HPPA (bug #300468).
271
272 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
273 Stable for HPPA (bug #300468).
274
275 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
276 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
277
278 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
279 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
280
281 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
282 ruby-1.8.6_p388.ebuild:
283 stable x86, security bug 300468
284
285 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
286 ruby-1.8.7_p249.ebuild:
287 stable x86, security bug 300468
288
289*ruby-1.8.6_p388 (10 Jan 2010)
290
291 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
292 +ruby-1.8.6_p388.ebuild:
293 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
294 version. The new ebuild also has the fix for bug 168939.
295
296*ruby-1.8.7_p249 (10 Jan 2010)
297
298 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
299 +ruby-1.8.7_p249.ebuild:
300 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
301 version
302
303 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
304 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
305
306*ruby-1.8.7_p248 (25 Dec 2009)
307
308 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
309 Version bump
310
311 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
312 Remove old version.
313
314 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
315 Remove old version.
316
317 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
318 ia64/s390/sh stable wrt #288699
319
320 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
321 stable sparc, bug 288699
322
323 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
324 arm stable, bug #288699
325
326 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
327 amd64/x86 stable, bug #288699
328
329 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
330 ruby-1.8.7_p174-r1.ebuild:
331 Stable on alpha, bug #288699
332
333 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
334 ppc stable #288699
335
336 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
337 Stable for HPPA (bug #288699).
338
339 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
340 Marked ~hppa too.
341
342*ruby-1.8.7_p174-r1 (06 Oct 2009)
343
344 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
345 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
346 eselect-ruby cleanup feature.
347
348*ruby-1.9.1_p243 (09 Sep 2009)
349
350 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
351 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
352 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
353 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
354 -files/ruby19-rubygems-proxy.patch,
355 -files/ruby-1.9.1_p129-parallelmake.patch,
356 -files/ruby19-mkmf-parallel-install.patch:
357 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
358 168939. Cleaning up old patches.
359
360*ruby-1.8.6_p383 (20 Aug 2009)
361
362 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
363 Patchlevel bump.
364
365 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
366 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
367 ruby-1.9.1_p129-r1.ebuild:
368 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
369
370 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
371 Removing vulnerable ebuild, bug 273213.
372
373 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
374 Marking ruby-1.8.6_p369 ppc for bug 273213
375
376 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
377 ruby-1.9.1_p129-r1.ebuild:
378 Prepend our library path instead of overwriting it during src_install.
379 Thanks to the reporter of bug #274824.
380
381*ruby-1.8.7_p174 (18 Jun 2009)
382
383 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
384 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
385 Replacing 187_p173 with _p174 because of a regression. Unifying the
386 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
387 patchsets.
388
389 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
390 Marking ruby-1.8.6_p369 ppc64 for bug 273213
391
392 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
393 arm/ia64/s390/sh/sparc stable wrt #273213
394
395 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
396 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
397 Removing old version, minor cleanup
398
399 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
400 -files/ruby-1.8.6-openssl.patch,
401 -files/ruby-1.8.6-shortname_constants.patch,
402 -files/ruby-1.8.6_p111-r13657.patch,
403 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
404 Removing vulnerable old Ruby version and stale patches, bug 274108.
405
406 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
407 ruby-1.8.6_p369.ebuild:
408 Stable on alpha, bug #273213
409
410 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
411 Stable for HPPA (bug #273213).
412
413 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
414 ruby-1.8.6_p369.ebuild:
415 stable x86, security bug 273213
416
417 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
418 amd64 stable, security bug 273213.
419
420*ruby-1.8.7_p173 (10 Jun 2009)
421*ruby-1.8.6_p369 (10 Jun 2009)
422
423 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
424 +ruby-1.8.7_p173.ebuild:
425 Version bumps for bug #273213.
426
427*ruby-1.9.1_p129-r1 (27 May 2009)
428
429 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
430 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
431 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
432 +files/ruby-1.9.1_p129-parallelmake.patch:
433 Revision bump, add patches 1) to make Ruby behave more similarly between
434 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
435 extensions (undefined symbols in them will cause abort at runtime 3) to
436 remove a concurrency issue when building the dl extension that could
437 result in a broken dl.so.
438
439 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
440 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
441 Don't block rdoc-2 or later (which may enter Portage one day as it's
442 needed by some Rakefiles).
443
444 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
445 ruby-1.9.1_p129.ebuild:
446 Add ~x86-fbsd keyword.
447
448 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
449 keyword ~sparc-fbsd, bug #252315
450
451*ruby-1.9.1_p129 (15 May 2009)
452
453 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
454 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
455 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
456 included in every release.
457
458 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
459 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
460 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
461 ruby-1.8.7_p160.ebuild:
462 Removing vulnerable versions (#268515), fixing license (#233747).
463
464 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
465 Stable for HPPA (bug #268515).
466
467 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
468 Adapting rubygems notice.
469
470 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
471 amd64 stable, bug #268515.
472
473 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
474 arm/ia64/s390/sh/sparc stable wrt #268515
475
476 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
477 ruby-1.8.6_p368.ebuild:
478 stable x86, security bug 268515
479
480 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
481 ruby-1.8.6_p368.ebuild:
482 Stable on alpha, bug #268515
483
484 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
485 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
486
487*ruby-1.8.7_p160 (07 May 2009)
488*ruby-1.8.6_p368 (07 May 2009)
489
490 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
491 +ruby-1.8.7_p160.ebuild:
492 Version bump as per secbug 268515. NB: These are the first ebuilds that
493 no longer use ruby-config.
494
495*ruby-1.9.1-r1 (03 Apr 2009)
496*ruby-1.8.7_p72-r11 (03 Apr 2009)
497*ruby-1.8.6_p287-r13 (03 Apr 2009)
498
499 03 Apr 2009; Alex Legler <a3li@gentoo.org>
500 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
501 +files/ruby18-mkmf-parallel-install.patch,
502 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
503 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
504 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
505 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
506 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
507 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
508 happy.
509
510*ruby-1.9.1 (21 Mar 2009)
511
512 21 Mar 2009; Alex Legler <a3li@gentoo.org>
513 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
514 +ruby-1.9.1.ebuild:
515 Adding Ruby 1.9.1 for preliminary testing
516
517 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
518 ruby-1.8.6_p287-r12.ebuild:
519 Marked ~ppc for bug #252315.
4 520
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 521 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 522 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 523 bug 261982.
8 524

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.502

  ViewVC Help
Powered by ViewVC 1.1.20