/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.507
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.507 2011/10/09 17:43:17 xarthisius Exp $
4
5 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
6 ppc/ppc64 stable wrt #386369
7
8 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
9 Stable on amd64 wrt bug #386369
10
11 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
12 Remove vulnerable version, bug 386369.
13
14*ruby-1.8.7_p352 (30 Aug 2011)
15
16 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
17 +ruby-1.8.7_p352.ebuild:
18 Patchlevel bump for ruby:1.8. Removing old version
19
20*ruby-1.9.2_p290 (30 Aug 2011)
21
22 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
23 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
24 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
25 old patchlevels.
26
27 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
28 ruby-1.8.7_p334-r2.ebuild:
29 ppc/ppc64 stable wrt #378691
30
31*ruby-1.8.7_p334-r2 (22 Jul 2011)
32
33 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
34 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
35 for chasing down upstream and us.
36
37 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
38 Added ~mips, bug 332593
39
40 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
41 ruby-1.8.7_p334-r1.ebuild:
42 ppc64 stable wrt #369141
43
44 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
45 ia64/s390/sh/sparc stable wrt #369141
46
47 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
48 Stable for HPPA (bug #369141).
49
50 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
51 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
52
53 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
54 arm/x86 stable, bug #369141
55
56 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
57 Stable on amd64 wrt bug #369141
58
59 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
60 ruby-1.8.7_p334-r1.ebuild:
61 Stable on alpha, bug #369141
62
63*ruby-1.8.7_p334-r1 (31 May 2011)
64
65 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
66 Revision bump for security bug 369141 (CVE-2011-0188)
67
68*ruby-1.9.2-r1 (16 May 2011)
69
70 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
71 Don't remove racc files since all other ruby targets ship these files
72 themselves as well. Closes bug 363419.
73
74 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
75 ruby-1.8.7_p334.ebuild:
76 Remove old version. Remove obsolete and unused old-style virtual/ruby.
77
78 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
79 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
80
81 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
82 Add append-flags -mieee on sh, bug #357559
83
84 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
85 alpha/arm/ia64/s390/sh stable wrt #355439
86
87 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
88 Marked ~ppc64 wrt #332593
89
90 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
91 ruby-1.8.7_p334.ebuild:
92 x86 stable wrt security bug #355439
93
94 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
95 ruby-1.8.7_p334.ebuild:
96 ppc/ppc64 stable wrt #355439
97
98 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
99 Stable on amd64 wrt bug #355439
100
101 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
102 Stable for HPPA (bug #355439).
103
104*ruby-1.8.7_p334 (19 Feb 2011)
105
106 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
107 Version bump 1.8.7 series, security bug 355439
108
109 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
110 ruby-1.9.2.ebuild:
111 Remove PROVIDE for old-style virtual/ruby per bug 265054.
112
113 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
114 Remove masked ruby 1.8.6 per bug 332597.
115
116 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
117 -ruby-1.9.2_rc2.ebuild:
118 Removing old and vulnerable ebuilds
119
120 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
121 Marking ruby-1.8.7_p302 ppc64 for bug 332957
122
123 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
124 alpha/ia64/s390/sh/sparc stable wrt #332957
125
126*ruby-1.9.2 (24 Aug 2010)
127
128 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
129 metadata.xml:
130 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
131 and x86-fbsd due to a new dependency on rdoc.
132
133 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
134 arm stable, bug #332957
135
136 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
137 ruby-1.8.7_p302.ebuild:
138 x86 stable wrt security bug #332957
139
140 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
141 Stable on amd64 wrt bug #332957
142
143 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
144 Stable for PPC (bug #332957).
145
146 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
147 Stable for HPPA (bug #332957).
148
149*ruby-1.8.7_p302 (21 Aug 2010)
150
151 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
152 +ruby-1.8.7_p302.ebuild:
153 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
154 installation path.
155
156*ruby-1.8.6_p399 (19 Aug 2010)
157
158 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
159 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
160 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
161 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
162 installation path (reported by the x86 team in bug 332597)
163
164*ruby-1.9.2_rc2-r1 (18 Aug 2010)
165
166 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
167 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
168 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
169 the rubygems loading code. Add USE flag for psych.
170
171 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
172 ruby-1.9.2_rc2.ebuild:
173 Remove two keepdir that will try to keep an empty path, closes bug
174 #333163.
175
176 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
177 Marked ~ppc (bug #332593).
178
179 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
180 ruby-1.9.2_rc2.ebuild:
181 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
182
183 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
184 ruby-1.8.7_p299.ebuild:
185 Bump eselect-ruby dependency
186
187 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
188 -ruby-1.9.1_p429.ebuild:
189 Remove ebuild that is not target for unmask anyway.
190
191 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
192 ruby-1.9.2_rc2.ebuild:
193 Try 2 to fix the berkdb 5 issue on 1.9.
194
195 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
196 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
197 ruby-1.9.2_rc2.ebuild:
198 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
199 support for adding new patchsets without bumping the revision for all the
200 old ebuilds as well.
201
202*ruby-1.9.2_rc2 (14 Jul 2010)
203
204 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
205 +ruby-1.9.2_rc2.ebuild:
206 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
207 might cause _further_ build failures as it changed slightly behaviour.
208 You're going to need to rebuild rubygems and then all the packages
209 previously installed after upgrading to this.
210
211 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
212 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
213 -ruby-1.9.1_p376.ebuild:
214 Cleanup old versions.
215
216*ruby-1.9.1_p429 (04 Jul 2010)
217
218 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
219 +ruby-1.9.1_p429.ebuild:
220 Version bump to new 1.9.1 release.
221
222*ruby-1.8.7_p299 (23 Jun 2010)
223
224 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
225 +ruby-1.8.7_p299.ebuild:
226 Version bump.
227
228 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
229 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
230 remove useless comments
231
232 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
233 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
234 ruby-1.9.1_p376.ebuild:
235 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
236 dev.gentoo.org now.
237
238 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
239 ruby-1.9.1_p376.ebuild:
240 Use the correct RUBYLIB.
241
242*ruby-1.8.7_p249-r2 (18 May 2010)
243*ruby-1.8.6_p388-r1 (18 May 2010)
244
245 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
246 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
247 ruby-1.9.1_p376.ebuild, metadata.xml:
248 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
249 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
250 add USE flags for ncurses, readline and libedit, and properly depend on
251 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
252 Emacs versions support ruby-mode themselves and it should be even more
253 updated.
254
255*ruby-1.8.7_p249-r1 (06 May 2010)
256
257 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
258 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
259 309789 by Sune Kloppenborg Jeppesen.
260
261 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
262 ruby-1.8.7_p249.ebuild:
263 Use $PVR instead of $PV in patchset names
264
265 06 May 2010; Alex Legler <a3li@gentoo.org>
266 -files/ruby-1.8.6-memory-leak.diff,
267 -files/ruby18-mkmf-parallel-install.patch,
268 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
269 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
270 Remove old version. Cleanup in files/
271
272*ruby-1.9.1_p376 (01 May 2010)
273
274 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
275 Version bump. Fixes security bugs 296052 and 300468. No longer installs
276 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
277 instead.
278
279 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
280 -ruby-1.8.7_p174-r1.ebuild:
281 Remove vulnerable ebuilds, 300468
282
283 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
284 ruby-1.8.7_p249.ebuild:
285 amd64 stable, security bug 300468
286
287 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
288 ruby-1.8.7_p249.ebuild:
289 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
290
291 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
292 Stable for HPPA (bug #300468).
293
294 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
295 Stable for HPPA (bug #300468).
296
297 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
298 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
299
300 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
301 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
302
303 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
304 ruby-1.8.6_p388.ebuild:
305 stable x86, security bug 300468
306
307 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
308 ruby-1.8.7_p249.ebuild:
309 stable x86, security bug 300468
310
311*ruby-1.8.6_p388 (10 Jan 2010)
312
313 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
314 +ruby-1.8.6_p388.ebuild:
315 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
316 version. The new ebuild also has the fix for bug 168939.
317
318*ruby-1.8.7_p249 (10 Jan 2010)
319
320 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
321 +ruby-1.8.7_p249.ebuild:
322 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
323 version
324
325 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
326 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
327
328*ruby-1.8.7_p248 (25 Dec 2009)
329
330 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
331 Version bump
332
333 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
334 Remove old version.
335
336 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
337 Remove old version.
338
339 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
340 ia64/s390/sh stable wrt #288699
341
342 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
343 stable sparc, bug 288699
344
345 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
346 arm stable, bug #288699
347
348 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
349 amd64/x86 stable, bug #288699
350
351 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
352 ruby-1.8.7_p174-r1.ebuild:
353 Stable on alpha, bug #288699
354
355 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
356 ppc stable #288699
357
358 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
359 Stable for HPPA (bug #288699).
360
361 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
362 Marked ~hppa too.
363
364*ruby-1.8.7_p174-r1 (06 Oct 2009)
365
366 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
367 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
368 eselect-ruby cleanup feature.
369
370*ruby-1.9.1_p243 (09 Sep 2009)
371
372 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
373 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
374 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
375 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
376 -files/ruby19-rubygems-proxy.patch,
377 -files/ruby-1.9.1_p129-parallelmake.patch,
378 -files/ruby19-mkmf-parallel-install.patch:
379 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
380 168939. Cleaning up old patches.
381
382*ruby-1.8.6_p383 (20 Aug 2009)
383
384 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
385 Patchlevel bump.
386
387 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
388 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
389 ruby-1.9.1_p129-r1.ebuild:
390 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
391
392 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
393 Removing vulnerable ebuild, bug 273213.
394
395 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
396 Marking ruby-1.8.6_p369 ppc for bug 273213
397
398 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
399 ruby-1.9.1_p129-r1.ebuild:
400 Prepend our library path instead of overwriting it during src_install.
401 Thanks to the reporter of bug #274824.
402
403*ruby-1.8.7_p174 (18 Jun 2009)
404
405 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
406 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
407 Replacing 187_p173 with _p174 because of a regression. Unifying the
408 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
409 patchsets.
410
411 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
412 Marking ruby-1.8.6_p369 ppc64 for bug 273213
413
414 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
415 arm/ia64/s390/sh/sparc stable wrt #273213
416
417 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
418 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
419 Removing old version, minor cleanup
420
421 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
422 -files/ruby-1.8.6-openssl.patch,
423 -files/ruby-1.8.6-shortname_constants.patch,
424 -files/ruby-1.8.6_p111-r13657.patch,
425 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
426 Removing vulnerable old Ruby version and stale patches, bug 274108.
427
428 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
429 ruby-1.8.6_p369.ebuild:
430 Stable on alpha, bug #273213
431
432 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
433 Stable for HPPA (bug #273213).
434
435 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
436 ruby-1.8.6_p369.ebuild:
437 stable x86, security bug 273213
438
439 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
440 amd64 stable, security bug 273213.
441
442*ruby-1.8.7_p173 (10 Jun 2009)
443*ruby-1.8.6_p369 (10 Jun 2009)
444
445 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
446 +ruby-1.8.7_p173.ebuild:
447 Version bumps for bug #273213.
448
449*ruby-1.9.1_p129-r1 (27 May 2009)
450
451 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
452 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
453 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
454 +files/ruby-1.9.1_p129-parallelmake.patch:
455 Revision bump, add patches 1) to make Ruby behave more similarly between
456 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
457 extensions (undefined symbols in them will cause abort at runtime 3) to
458 remove a concurrency issue when building the dl extension that could
459 result in a broken dl.so.
460
461 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
462 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
463 Don't block rdoc-2 or later (which may enter Portage one day as it's
464 needed by some Rakefiles).
465
466 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
467 ruby-1.9.1_p129.ebuild:
468 Add ~x86-fbsd keyword.
469
470 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
471 keyword ~sparc-fbsd, bug #252315
472
473*ruby-1.9.1_p129 (15 May 2009)
474
475 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
476 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
477 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
478 included in every release.
479
480 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
481 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
482 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
483 ruby-1.8.7_p160.ebuild:
484 Removing vulnerable versions (#268515), fixing license (#233747).
485
486 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
487 Stable for HPPA (bug #268515).
488
489 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
490 Adapting rubygems notice.
491
492 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
493 amd64 stable, bug #268515.
494
495 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
496 arm/ia64/s390/sh/sparc stable wrt #268515
497
498 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
499 ruby-1.8.6_p368.ebuild:
500 stable x86, security bug 268515
501
502 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
503 ruby-1.8.6_p368.ebuild:
504 Stable on alpha, bug #268515
505
506 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
507 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
508
509*ruby-1.8.7_p160 (07 May 2009)
510*ruby-1.8.6_p368 (07 May 2009)
511
512 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
513 +ruby-1.8.7_p160.ebuild:
514 Version bump as per secbug 268515. NB: These are the first ebuilds that
515 no longer use ruby-config.
516
517*ruby-1.9.1-r1 (03 Apr 2009)
518*ruby-1.8.7_p72-r11 (03 Apr 2009)
519*ruby-1.8.6_p287-r13 (03 Apr 2009)
520
521 03 Apr 2009; Alex Legler <a3li@gentoo.org>
522 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
523 +files/ruby18-mkmf-parallel-install.patch,
524 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
525 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
526 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
527 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
528 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
529 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
530 happy.
531
532*ruby-1.9.1 (21 Mar 2009)
533
534 21 Mar 2009; Alex Legler <a3li@gentoo.org>
535 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
536 +ruby-1.9.1.ebuild:
537 Adding Ruby 1.9.1 for preliminary testing
538
539 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
540 ruby-1.8.6_p287-r12.ebuild:
541 Marked ~ppc for bug #252315.
4 542
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 543 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 544 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 545 bug 261982.
8 546

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.507

  ViewVC Help
Powered by ViewVC 1.1.20