/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.509
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.509 2011/10/14 08:27:07 nativemad Exp $
4
5 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
6 x86 stable, bug 386369
7
8 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
9 Stable for HPPA (bug #386369).
10
11 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
12 ppc/ppc64 stable wrt #386369
13
14 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
15 Stable on amd64 wrt bug #386369
16
17 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
18 Remove vulnerable version, bug 386369.
19
20*ruby-1.8.7_p352 (30 Aug 2011)
21
22 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
23 +ruby-1.8.7_p352.ebuild:
24 Patchlevel bump for ruby:1.8. Removing old version
25
26*ruby-1.9.2_p290 (30 Aug 2011)
27
28 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
29 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
30 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
31 old patchlevels.
32
33 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
34 ruby-1.8.7_p334-r2.ebuild:
35 ppc/ppc64 stable wrt #378691
36
37*ruby-1.8.7_p334-r2 (22 Jul 2011)
38
39 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
40 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
41 for chasing down upstream and us.
42
43 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
44 Added ~mips, bug 332593
45
46 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
47 ruby-1.8.7_p334-r1.ebuild:
48 ppc64 stable wrt #369141
49
50 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
51 ia64/s390/sh/sparc stable wrt #369141
52
53 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
54 Stable for HPPA (bug #369141).
55
56 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
57 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
58
59 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
60 arm/x86 stable, bug #369141
61
62 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
63 Stable on amd64 wrt bug #369141
64
65 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
66 ruby-1.8.7_p334-r1.ebuild:
67 Stable on alpha, bug #369141
68
69*ruby-1.8.7_p334-r1 (31 May 2011)
70
71 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
72 Revision bump for security bug 369141 (CVE-2011-0188)
73
74*ruby-1.9.2-r1 (16 May 2011)
75
76 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
77 Don't remove racc files since all other ruby targets ship these files
78 themselves as well. Closes bug 363419.
79
80 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
81 ruby-1.8.7_p334.ebuild:
82 Remove old version. Remove obsolete and unused old-style virtual/ruby.
83
84 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
85 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
86
87 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
88 Add append-flags -mieee on sh, bug #357559
89
90 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
91 alpha/arm/ia64/s390/sh stable wrt #355439
92
93 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
94 Marked ~ppc64 wrt #332593
95
96 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
97 ruby-1.8.7_p334.ebuild:
98 x86 stable wrt security bug #355439
99
100 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
101 ruby-1.8.7_p334.ebuild:
102 ppc/ppc64 stable wrt #355439
103
104 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
105 Stable on amd64 wrt bug #355439
106
107 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
108 Stable for HPPA (bug #355439).
109
110*ruby-1.8.7_p334 (19 Feb 2011)
111
112 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
113 Version bump 1.8.7 series, security bug 355439
114
115 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
116 ruby-1.9.2.ebuild:
117 Remove PROVIDE for old-style virtual/ruby per bug 265054.
118
119 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
120 Remove masked ruby 1.8.6 per bug 332597.
121
122 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
123 -ruby-1.9.2_rc2.ebuild:
124 Removing old and vulnerable ebuilds
125
126 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
127 Marking ruby-1.8.7_p302 ppc64 for bug 332957
128
129 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
130 alpha/ia64/s390/sh/sparc stable wrt #332957
131
132*ruby-1.9.2 (24 Aug 2010)
133
134 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
135 metadata.xml:
136 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
137 and x86-fbsd due to a new dependency on rdoc.
138
139 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
140 arm stable, bug #332957
141
142 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
143 ruby-1.8.7_p302.ebuild:
144 x86 stable wrt security bug #332957
145
146 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
147 Stable on amd64 wrt bug #332957
148
149 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
150 Stable for PPC (bug #332957).
151
152 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
153 Stable for HPPA (bug #332957).
154
155*ruby-1.8.7_p302 (21 Aug 2010)
156
157 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
158 +ruby-1.8.7_p302.ebuild:
159 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
160 installation path.
161
162*ruby-1.8.6_p399 (19 Aug 2010)
163
164 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
165 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
166 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
167 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
168 installation path (reported by the x86 team in bug 332597)
169
170*ruby-1.9.2_rc2-r1 (18 Aug 2010)
171
172 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
173 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
174 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
175 the rubygems loading code. Add USE flag for psych.
176
177 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
178 ruby-1.9.2_rc2.ebuild:
179 Remove two keepdir that will try to keep an empty path, closes bug
180 #333163.
181
182 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
183 Marked ~ppc (bug #332593).
184
185 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
186 ruby-1.9.2_rc2.ebuild:
187 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
188
189 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
190 ruby-1.8.7_p299.ebuild:
191 Bump eselect-ruby dependency
192
193 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
194 -ruby-1.9.1_p429.ebuild:
195 Remove ebuild that is not target for unmask anyway.
196
197 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
198 ruby-1.9.2_rc2.ebuild:
199 Try 2 to fix the berkdb 5 issue on 1.9.
200
201 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
202 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
203 ruby-1.9.2_rc2.ebuild:
204 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
205 support for adding new patchsets without bumping the revision for all the
206 old ebuilds as well.
207
208*ruby-1.9.2_rc2 (14 Jul 2010)
209
210 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
211 +ruby-1.9.2_rc2.ebuild:
212 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
213 might cause _further_ build failures as it changed slightly behaviour.
214 You're going to need to rebuild rubygems and then all the packages
215 previously installed after upgrading to this.
216
217 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
218 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
219 -ruby-1.9.1_p376.ebuild:
220 Cleanup old versions.
221
222*ruby-1.9.1_p429 (04 Jul 2010)
223
224 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
225 +ruby-1.9.1_p429.ebuild:
226 Version bump to new 1.9.1 release.
227
228*ruby-1.8.7_p299 (23 Jun 2010)
229
230 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
231 +ruby-1.8.7_p299.ebuild:
232 Version bump.
233
234 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
235 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
236 remove useless comments
237
238 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
239 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
240 ruby-1.9.1_p376.ebuild:
241 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
242 dev.gentoo.org now.
243
244 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
245 ruby-1.9.1_p376.ebuild:
246 Use the correct RUBYLIB.
247
248*ruby-1.8.7_p249-r2 (18 May 2010)
249*ruby-1.8.6_p388-r1 (18 May 2010)
250
251 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
252 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
253 ruby-1.9.1_p376.ebuild, metadata.xml:
254 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
255 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
256 add USE flags for ncurses, readline and libedit, and properly depend on
257 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
258 Emacs versions support ruby-mode themselves and it should be even more
259 updated.
260
261*ruby-1.8.7_p249-r1 (06 May 2010)
262
263 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
264 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
265 309789 by Sune Kloppenborg Jeppesen.
266
267 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
268 ruby-1.8.7_p249.ebuild:
269 Use $PVR instead of $PV in patchset names
270
271 06 May 2010; Alex Legler <a3li@gentoo.org>
272 -files/ruby-1.8.6-memory-leak.diff,
273 -files/ruby18-mkmf-parallel-install.patch,
274 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
275 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
276 Remove old version. Cleanup in files/
277
278*ruby-1.9.1_p376 (01 May 2010)
279
280 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
281 Version bump. Fixes security bugs 296052 and 300468. No longer installs
282 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
283 instead.
284
285 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
286 -ruby-1.8.7_p174-r1.ebuild:
287 Remove vulnerable ebuilds, 300468
288
289 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
290 ruby-1.8.7_p249.ebuild:
291 amd64 stable, security bug 300468
292
293 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
294 ruby-1.8.7_p249.ebuild:
295 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
296
297 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
298 Stable for HPPA (bug #300468).
299
300 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
301 Stable for HPPA (bug #300468).
302
303 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
304 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
305
306 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
307 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
308
309 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
310 ruby-1.8.6_p388.ebuild:
311 stable x86, security bug 300468
312
313 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
314 ruby-1.8.7_p249.ebuild:
315 stable x86, security bug 300468
316
317*ruby-1.8.6_p388 (10 Jan 2010)
318
319 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
320 +ruby-1.8.6_p388.ebuild:
321 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
322 version. The new ebuild also has the fix for bug 168939.
323
324*ruby-1.8.7_p249 (10 Jan 2010)
325
326 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
327 +ruby-1.8.7_p249.ebuild:
328 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
329 version
330
331 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
332 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
333
334*ruby-1.8.7_p248 (25 Dec 2009)
335
336 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
337 Version bump
338
339 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
340 Remove old version.
341
342 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
343 Remove old version.
344
345 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
346 ia64/s390/sh stable wrt #288699
347
348 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
349 stable sparc, bug 288699
350
351 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
352 arm stable, bug #288699
353
354 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
355 amd64/x86 stable, bug #288699
356
357 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
358 ruby-1.8.7_p174-r1.ebuild:
359 Stable on alpha, bug #288699
360
361 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
362 ppc stable #288699
363
364 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
365 Stable for HPPA (bug #288699).
366
367 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
368 Marked ~hppa too.
369
370*ruby-1.8.7_p174-r1 (06 Oct 2009)
371
372 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
373 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
374 eselect-ruby cleanup feature.
375
376*ruby-1.9.1_p243 (09 Sep 2009)
377
378 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
379 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
380 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
381 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
382 -files/ruby19-rubygems-proxy.patch,
383 -files/ruby-1.9.1_p129-parallelmake.patch,
384 -files/ruby19-mkmf-parallel-install.patch:
385 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
386 168939. Cleaning up old patches.
387
388*ruby-1.8.6_p383 (20 Aug 2009)
389
390 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
391 Patchlevel bump.
392
393 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
394 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
395 ruby-1.9.1_p129-r1.ebuild:
396 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
397
398 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
399 Removing vulnerable ebuild, bug 273213.
400
401 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
402 Marking ruby-1.8.6_p369 ppc for bug 273213
403
404 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
405 ruby-1.9.1_p129-r1.ebuild:
406 Prepend our library path instead of overwriting it during src_install.
407 Thanks to the reporter of bug #274824.
408
409*ruby-1.8.7_p174 (18 Jun 2009)
410
411 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
412 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
413 Replacing 187_p173 with _p174 because of a regression. Unifying the
414 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
415 patchsets.
416
417 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
418 Marking ruby-1.8.6_p369 ppc64 for bug 273213
419
420 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
421 arm/ia64/s390/sh/sparc stable wrt #273213
422
423 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
424 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
425 Removing old version, minor cleanup
426
427 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
428 -files/ruby-1.8.6-openssl.patch,
429 -files/ruby-1.8.6-shortname_constants.patch,
430 -files/ruby-1.8.6_p111-r13657.patch,
431 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
432 Removing vulnerable old Ruby version and stale patches, bug 274108.
433
434 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
435 ruby-1.8.6_p369.ebuild:
436 Stable on alpha, bug #273213
437
438 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
439 Stable for HPPA (bug #273213).
440
441 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
442 ruby-1.8.6_p369.ebuild:
443 stable x86, security bug 273213
444
445 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
446 amd64 stable, security bug 273213.
447
448*ruby-1.8.7_p173 (10 Jun 2009)
449*ruby-1.8.6_p369 (10 Jun 2009)
450
451 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
452 +ruby-1.8.7_p173.ebuild:
453 Version bumps for bug #273213.
454
455*ruby-1.9.1_p129-r1 (27 May 2009)
456
457 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
458 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
459 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
460 +files/ruby-1.9.1_p129-parallelmake.patch:
461 Revision bump, add patches 1) to make Ruby behave more similarly between
462 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
463 extensions (undefined symbols in them will cause abort at runtime 3) to
464 remove a concurrency issue when building the dl extension that could
465 result in a broken dl.so.
466
467 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
468 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
469 Don't block rdoc-2 or later (which may enter Portage one day as it's
470 needed by some Rakefiles).
471
472 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
473 ruby-1.9.1_p129.ebuild:
474 Add ~x86-fbsd keyword.
475
476 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
477 keyword ~sparc-fbsd, bug #252315
478
479*ruby-1.9.1_p129 (15 May 2009)
480
481 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
482 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
483 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
484 included in every release.
485
486 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
487 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
488 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
489 ruby-1.8.7_p160.ebuild:
490 Removing vulnerable versions (#268515), fixing license (#233747).
491
492 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
493 Stable for HPPA (bug #268515).
494
495 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
496 Adapting rubygems notice.
497
498 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
499 amd64 stable, bug #268515.
500
501 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
502 arm/ia64/s390/sh/sparc stable wrt #268515
503
504 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
505 ruby-1.8.6_p368.ebuild:
506 stable x86, security bug 268515
507
508 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
509 ruby-1.8.6_p368.ebuild:
510 Stable on alpha, bug #268515
511
512 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
513 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
514
515*ruby-1.8.7_p160 (07 May 2009)
516*ruby-1.8.6_p368 (07 May 2009)
517
518 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
519 +ruby-1.8.7_p160.ebuild:
520 Version bump as per secbug 268515. NB: These are the first ebuilds that
521 no longer use ruby-config.
522
523*ruby-1.9.1-r1 (03 Apr 2009)
524*ruby-1.8.7_p72-r11 (03 Apr 2009)
525*ruby-1.8.6_p287-r13 (03 Apr 2009)
526
527 03 Apr 2009; Alex Legler <a3li@gentoo.org>
528 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
529 +files/ruby18-mkmf-parallel-install.patch,
530 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
531 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
532 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
533 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
534 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
535 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
536 happy.
537
538*ruby-1.9.1 (21 Mar 2009)
539
540 21 Mar 2009; Alex Legler <a3li@gentoo.org>
541 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
542 +ruby-1.9.1.ebuild:
543 Adding Ruby 1.9.1 for preliminary testing
544
545 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
546 ruby-1.8.6_p287-r12.ebuild:
547 Marked ~ppc for bug #252315.
4 548
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 549 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 550 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 551 bug 261982.
8 552

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.509

  ViewVC Help
Powered by ViewVC 1.1.20