/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.525
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.525 2012/01/04 17:37:30 phajdan.jr Exp $
4
5 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
6 x86 stable wrt bug #396301
7
8 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
9 Stable for HPPA (bug #396301).
10
11 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
12 Stable for ppc/ppc64; bug #396301
13
14 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
15 Marked ~hppa (bug #332593).
16
17 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
18 Add back ~alpha keyword now that rubygems is keyworded.
19
20 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
21 Stable for AMD64, wrt security bug #396301
22
23*ruby-1.8.7_p357 (28 Dec 2011)
24
25 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
26 Version bump for security bug 396301.
27
28 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
29 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
30
31 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
32 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
33 keyworded, bug 332593.
34
35 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
36 Block older versions of packages that are no longer compatible. Remove
37 ancient blocks on packags long gone from the tree.
38
39 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
40 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
41 Remove old versions.
42
43*ruby-1.9.3_p0 (18 Dec 2011)
44
45 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
46 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
47 suite which need to be diagnosed first.
48
49 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
50 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
51 #332593).
52
53 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
54 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
55 #332593).
56
57 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
58 alpha/ia64/s390/sh/sparc stable wrt #386369
59
60*ruby-1.9.3_rc1 (22 Oct 2011)
61
62 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
63 Version bump.
64
65 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
66 arm stable, bug #386369
67
68 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
69 x86 stable, bug 386369
70
71 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
72 Stable for HPPA (bug #386369).
73
74 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
75 ppc/ppc64 stable wrt #386369
76
77 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
78 Stable on amd64 wrt bug #386369
79
80 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
81 Remove vulnerable version, bug 386369.
82
83*ruby-1.8.7_p352 (30 Aug 2011)
84
85 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
86 +ruby-1.8.7_p352.ebuild:
87 Patchlevel bump for ruby:1.8. Removing old version
88
89*ruby-1.9.2_p290 (30 Aug 2011)
90
91 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
92 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
93 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
94 old patchlevels.
95
96 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
97 ruby-1.8.7_p334-r2.ebuild:
98 ppc/ppc64 stable wrt #378691
99
100*ruby-1.8.7_p334-r2 (22 Jul 2011)
101
102 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
103 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
104 for chasing down upstream and us.
105
106 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
107 Added ~mips, bug 332593
108
109 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
110 ruby-1.8.7_p334-r1.ebuild:
111 ppc64 stable wrt #369141
112
113 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
114 ia64/s390/sh/sparc stable wrt #369141
115
116 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
117 Stable for HPPA (bug #369141).
118
119 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
120 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
121
122 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
123 arm/x86 stable, bug #369141
124
125 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
126 Stable on amd64 wrt bug #369141
127
128 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
129 ruby-1.8.7_p334-r1.ebuild:
130 Stable on alpha, bug #369141
131
132*ruby-1.8.7_p334-r1 (31 May 2011)
133
134 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
135 Revision bump for security bug 369141 (CVE-2011-0188)
136
137*ruby-1.9.2-r1 (16 May 2011)
138
139 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
140 Don't remove racc files since all other ruby targets ship these files
141 themselves as well. Closes bug 363419.
142
143 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
144 ruby-1.8.7_p334.ebuild:
145 Remove old version. Remove obsolete and unused old-style virtual/ruby.
146
147 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
148 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
149
150 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
151 Add append-flags -mieee on sh, bug #357559
152
153 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
154 alpha/arm/ia64/s390/sh stable wrt #355439
155
156 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
157 Marked ~ppc64 wrt #332593
158
159 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
160 ruby-1.8.7_p334.ebuild:
161 x86 stable wrt security bug #355439
162
163 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
164 ruby-1.8.7_p334.ebuild:
165 ppc/ppc64 stable wrt #355439
166
167 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
168 Stable on amd64 wrt bug #355439
169
170 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
171 Stable for HPPA (bug #355439).
172
173*ruby-1.8.7_p334 (19 Feb 2011)
174
175 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
176 Version bump 1.8.7 series, security bug 355439
177
178 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
179 ruby-1.9.2.ebuild:
180 Remove PROVIDE for old-style virtual/ruby per bug 265054.
181
182 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
183 Remove masked ruby 1.8.6 per bug 332597.
184
185 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
186 -ruby-1.9.2_rc2.ebuild:
187 Removing old and vulnerable ebuilds
188
189 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
190 Marking ruby-1.8.7_p302 ppc64 for bug 332957
191
192 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
193 alpha/ia64/s390/sh/sparc stable wrt #332957
194
195*ruby-1.9.2 (24 Aug 2010)
196
197 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
198 metadata.xml:
199 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
200 and x86-fbsd due to a new dependency on rdoc.
201
202 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
203 arm stable, bug #332957
204
205 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
206 ruby-1.8.7_p302.ebuild:
207 x86 stable wrt security bug #332957
208
209 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
210 Stable on amd64 wrt bug #332957
211
212 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
213 Stable for PPC (bug #332957).
214
215 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
216 Stable for HPPA (bug #332957).
217
218*ruby-1.8.7_p302 (21 Aug 2010)
219
220 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
221 +ruby-1.8.7_p302.ebuild:
222 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
223 installation path.
224
225*ruby-1.8.6_p399 (19 Aug 2010)
226
227 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
228 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
229 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
230 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
231 installation path (reported by the x86 team in bug 332597)
232
233*ruby-1.9.2_rc2-r1 (18 Aug 2010)
234
235 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
236 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
237 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
238 the rubygems loading code. Add USE flag for psych.
239
240 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
241 ruby-1.9.2_rc2.ebuild:
242 Remove two keepdir that will try to keep an empty path, closes bug
243 #333163.
244
245 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
246 Marked ~ppc (bug #332593).
247
248 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
249 ruby-1.9.2_rc2.ebuild:
250 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
251
252 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
253 ruby-1.8.7_p299.ebuild:
254 Bump eselect-ruby dependency
255
256 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
257 -ruby-1.9.1_p429.ebuild:
258 Remove ebuild that is not target for unmask anyway.
259
260 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
261 ruby-1.9.2_rc2.ebuild:
262 Try 2 to fix the berkdb 5 issue on 1.9.
263
264 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
265 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
266 ruby-1.9.2_rc2.ebuild:
267 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
268 support for adding new patchsets without bumping the revision for all the
269 old ebuilds as well.
270
271*ruby-1.9.2_rc2 (14 Jul 2010)
272
273 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
274 +ruby-1.9.2_rc2.ebuild:
275 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
276 might cause _further_ build failures as it changed slightly behaviour.
277 You're going to need to rebuild rubygems and then all the packages
278 previously installed after upgrading to this.
279
280 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
281 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
282 -ruby-1.9.1_p376.ebuild:
283 Cleanup old versions.
284
285*ruby-1.9.1_p429 (04 Jul 2010)
286
287 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
288 +ruby-1.9.1_p429.ebuild:
289 Version bump to new 1.9.1 release.
290
291*ruby-1.8.7_p299 (23 Jun 2010)
292
293 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
294 +ruby-1.8.7_p299.ebuild:
295 Version bump.
296
297 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
298 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
299 remove useless comments
300
301 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
302 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
303 ruby-1.9.1_p376.ebuild:
304 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
305 dev.gentoo.org now.
306
307 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
308 ruby-1.9.1_p376.ebuild:
309 Use the correct RUBYLIB.
310
311*ruby-1.8.7_p249-r2 (18 May 2010)
312*ruby-1.8.6_p388-r1 (18 May 2010)
313
314 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
315 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
316 ruby-1.9.1_p376.ebuild, metadata.xml:
317 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
318 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
319 add USE flags for ncurses, readline and libedit, and properly depend on
320 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
321 Emacs versions support ruby-mode themselves and it should be even more
322 updated.
323
324*ruby-1.8.7_p249-r1 (06 May 2010)
325
326 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
327 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
328 309789 by Sune Kloppenborg Jeppesen.
329
330 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
331 ruby-1.8.7_p249.ebuild:
332 Use $PVR instead of $PV in patchset names
333
334 06 May 2010; Alex Legler <a3li@gentoo.org>
335 -files/ruby-1.8.6-memory-leak.diff,
336 -files/ruby18-mkmf-parallel-install.patch,
337 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
338 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
339 Remove old version. Cleanup in files/
340
341*ruby-1.9.1_p376 (01 May 2010)
342
343 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
344 Version bump. Fixes security bugs 296052 and 300468. No longer installs
345 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
346 instead.
347
348 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
349 -ruby-1.8.7_p174-r1.ebuild:
350 Remove vulnerable ebuilds, 300468
351
352 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
353 ruby-1.8.7_p249.ebuild:
354 amd64 stable, security bug 300468
355
356 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
357 ruby-1.8.7_p249.ebuild:
358 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
359
360 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
361 Stable for HPPA (bug #300468).
362
363 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
364 Stable for HPPA (bug #300468).
365
366 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
367 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
368
369 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
370 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
371
372 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
373 ruby-1.8.6_p388.ebuild:
374 stable x86, security bug 300468
375
376 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
377 ruby-1.8.7_p249.ebuild:
378 stable x86, security bug 300468
379
380*ruby-1.8.6_p388 (10 Jan 2010)
381
382 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
383 +ruby-1.8.6_p388.ebuild:
384 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
385 version. The new ebuild also has the fix for bug 168939.
386
387*ruby-1.8.7_p249 (10 Jan 2010)
388
389 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
390 +ruby-1.8.7_p249.ebuild:
391 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
392 version
393
394 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
395 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
396
397*ruby-1.8.7_p248 (25 Dec 2009)
398
399 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
400 Version bump
401
402 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
403 Remove old version.
404
405 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
406 Remove old version.
407
408 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
409 ia64/s390/sh stable wrt #288699
410
411 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
412 stable sparc, bug 288699
413
414 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
415 arm stable, bug #288699
416
417 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
418 amd64/x86 stable, bug #288699
419
420 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
421 ruby-1.8.7_p174-r1.ebuild:
422 Stable on alpha, bug #288699
423
424 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
425 ppc stable #288699
426
427 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
428 Stable for HPPA (bug #288699).
429
430 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
431 Marked ~hppa too.
432
433*ruby-1.8.7_p174-r1 (06 Oct 2009)
434
435 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
436 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
437 eselect-ruby cleanup feature.
438
439*ruby-1.9.1_p243 (09 Sep 2009)
440
441 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
442 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
443 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
444 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
445 -files/ruby19-rubygems-proxy.patch,
446 -files/ruby-1.9.1_p129-parallelmake.patch,
447 -files/ruby19-mkmf-parallel-install.patch:
448 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
449 168939. Cleaning up old patches.
450
451*ruby-1.8.6_p383 (20 Aug 2009)
452
453 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
454 Patchlevel bump.
455
456 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
457 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
458 ruby-1.9.1_p129-r1.ebuild:
459 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
460
461 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
462 Removing vulnerable ebuild, bug 273213.
463
464 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
465 Marking ruby-1.8.6_p369 ppc for bug 273213
466
467 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
468 ruby-1.9.1_p129-r1.ebuild:
469 Prepend our library path instead of overwriting it during src_install.
470 Thanks to the reporter of bug #274824.
471
472*ruby-1.8.7_p174 (18 Jun 2009)
473
474 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
475 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
476 Replacing 187_p173 with _p174 because of a regression. Unifying the
477 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
478 patchsets.
479
480 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
481 Marking ruby-1.8.6_p369 ppc64 for bug 273213
482
483 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
484 arm/ia64/s390/sh/sparc stable wrt #273213
485
486 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
487 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
488 Removing old version, minor cleanup
489
490 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
491 -files/ruby-1.8.6-openssl.patch,
492 -files/ruby-1.8.6-shortname_constants.patch,
493 -files/ruby-1.8.6_p111-r13657.patch,
494 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
495 Removing vulnerable old Ruby version and stale patches, bug 274108.
496
497 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
498 ruby-1.8.6_p369.ebuild:
499 Stable on alpha, bug #273213
500
501 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
502 Stable for HPPA (bug #273213).
503
504 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
505 ruby-1.8.6_p369.ebuild:
506 stable x86, security bug 273213
507
508 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
509 amd64 stable, security bug 273213.
510
511*ruby-1.8.7_p173 (10 Jun 2009)
512*ruby-1.8.6_p369 (10 Jun 2009)
513
514 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
515 +ruby-1.8.7_p173.ebuild:
516 Version bumps for bug #273213.
517
518*ruby-1.9.1_p129-r1 (27 May 2009)
519
520 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
521 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
522 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
523 +files/ruby-1.9.1_p129-parallelmake.patch:
524 Revision bump, add patches 1) to make Ruby behave more similarly between
525 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
526 extensions (undefined symbols in them will cause abort at runtime 3) to
527 remove a concurrency issue when building the dl extension that could
528 result in a broken dl.so.
529
530 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
531 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
532 Don't block rdoc-2 or later (which may enter Portage one day as it's
533 needed by some Rakefiles).
534
535 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
536 ruby-1.9.1_p129.ebuild:
537 Add ~x86-fbsd keyword.
538
539 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
540 keyword ~sparc-fbsd, bug #252315
541
542*ruby-1.9.1_p129 (15 May 2009)
543
544 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
545 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
546 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
547 included in every release.
548
549 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
550 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
551 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
552 ruby-1.8.7_p160.ebuild:
553 Removing vulnerable versions (#268515), fixing license (#233747).
554
555 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
556 Stable for HPPA (bug #268515).
557
558 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
559 Adapting rubygems notice.
560
561 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
562 amd64 stable, bug #268515.
563
564 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
565 arm/ia64/s390/sh/sparc stable wrt #268515
566
567 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
568 ruby-1.8.6_p368.ebuild:
569 stable x86, security bug 268515
570
571 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
572 ruby-1.8.6_p368.ebuild:
573 Stable on alpha, bug #268515
574
575 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
576 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
577
578*ruby-1.8.7_p160 (07 May 2009)
579*ruby-1.8.6_p368 (07 May 2009)
580
581 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
582 +ruby-1.8.7_p160.ebuild:
583 Version bump as per secbug 268515. NB: These are the first ebuilds that
584 no longer use ruby-config.
585
586*ruby-1.9.1-r1 (03 Apr 2009)
587*ruby-1.8.7_p72-r11 (03 Apr 2009)
588*ruby-1.8.6_p287-r13 (03 Apr 2009)
589
590 03 Apr 2009; Alex Legler <a3li@gentoo.org>
591 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
592 +files/ruby18-mkmf-parallel-install.patch,
593 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
594 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
595 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
596 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
597 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
598 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
599 happy.
600
601*ruby-1.9.1 (21 Mar 2009)
602
603 21 Mar 2009; Alex Legler <a3li@gentoo.org>
604 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
605 +ruby-1.9.1.ebuild:
606 Adding Ruby 1.9.1 for preliminary testing
607
608 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
609 ruby-1.8.6_p287-r12.ebuild:
610 Marked ~ppc for bug #252315.
4 611
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 612 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 613 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 614 bug 261982.
8 615

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.525

  ViewVC Help
Powered by ViewVC 1.1.20