/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.397 Revision 1.503
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.397 2009/05/08 17:06:43 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.503 2011/08/30 19:35:59 a3li Exp $
4
5*ruby-1.9.2_p290 (30 Aug 2011)
6
7 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
8 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
9 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
10 old patchlevels.
11
12 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
13 ruby-1.8.7_p334-r2.ebuild:
14 ppc/ppc64 stable wrt #378691
15
16*ruby-1.8.7_p334-r2 (22 Jul 2011)
17
18 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
19 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
20 for chasing down upstream and us.
21
22 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
23 Added ~mips, bug 332593
24
25 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
26 ruby-1.8.7_p334-r1.ebuild:
27 ppc64 stable wrt #369141
28
29 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
30 ia64/s390/sh/sparc stable wrt #369141
31
32 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
33 Stable for HPPA (bug #369141).
34
35 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
36 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
37
38 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
39 arm/x86 stable, bug #369141
40
41 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
42 Stable on amd64 wrt bug #369141
43
44 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
45 ruby-1.8.7_p334-r1.ebuild:
46 Stable on alpha, bug #369141
47
48*ruby-1.8.7_p334-r1 (31 May 2011)
49
50 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
51 Revision bump for security bug 369141 (CVE-2011-0188)
52
53*ruby-1.9.2-r1 (16 May 2011)
54
55 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
56 Don't remove racc files since all other ruby targets ship these files
57 themselves as well. Closes bug 363419.
58
59 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
60 ruby-1.8.7_p334.ebuild:
61 Remove old version. Remove obsolete and unused old-style virtual/ruby.
62
63 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
64 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
65
66 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
67 Add append-flags -mieee on sh, bug #357559
68
69 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
70 alpha/arm/ia64/s390/sh stable wrt #355439
71
72 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
73 Marked ~ppc64 wrt #332593
74
75 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
76 ruby-1.8.7_p334.ebuild:
77 x86 stable wrt security bug #355439
78
79 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
80 ruby-1.8.7_p334.ebuild:
81 ppc/ppc64 stable wrt #355439
82
83 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
84 Stable on amd64 wrt bug #355439
85
86 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
87 Stable for HPPA (bug #355439).
88
89*ruby-1.8.7_p334 (19 Feb 2011)
90
91 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
92 Version bump 1.8.7 series, security bug 355439
93
94 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
95 ruby-1.9.2.ebuild:
96 Remove PROVIDE for old-style virtual/ruby per bug 265054.
97
98 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
99 Remove masked ruby 1.8.6 per bug 332597.
100
101 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
102 -ruby-1.9.2_rc2.ebuild:
103 Removing old and vulnerable ebuilds
104
105 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
106 Marking ruby-1.8.7_p302 ppc64 for bug 332957
107
108 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
109 alpha/ia64/s390/sh/sparc stable wrt #332957
110
111*ruby-1.9.2 (24 Aug 2010)
112
113 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
114 metadata.xml:
115 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
116 and x86-fbsd due to a new dependency on rdoc.
117
118 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
119 arm stable, bug #332957
120
121 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
122 ruby-1.8.7_p302.ebuild:
123 x86 stable wrt security bug #332957
124
125 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
126 Stable on amd64 wrt bug #332957
127
128 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
129 Stable for PPC (bug #332957).
130
131 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
132 Stable for HPPA (bug #332957).
133
134*ruby-1.8.7_p302 (21 Aug 2010)
135
136 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
137 +ruby-1.8.7_p302.ebuild:
138 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
139 installation path.
140
141*ruby-1.8.6_p399 (19 Aug 2010)
142
143 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
144 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
145 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
146 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
147 installation path (reported by the x86 team in bug 332597)
148
149*ruby-1.9.2_rc2-r1 (18 Aug 2010)
150
151 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
152 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
153 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
154 the rubygems loading code. Add USE flag for psych.
155
156 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
157 ruby-1.9.2_rc2.ebuild:
158 Remove two keepdir that will try to keep an empty path, closes bug
159 #333163.
160
161 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
162 Marked ~ppc (bug #332593).
163
164 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
165 ruby-1.9.2_rc2.ebuild:
166 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
167
168 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
169 ruby-1.8.7_p299.ebuild:
170 Bump eselect-ruby dependency
171
172 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
173 -ruby-1.9.1_p429.ebuild:
174 Remove ebuild that is not target for unmask anyway.
175
176 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
177 ruby-1.9.2_rc2.ebuild:
178 Try 2 to fix the berkdb 5 issue on 1.9.
179
180 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
181 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
182 ruby-1.9.2_rc2.ebuild:
183 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
184 support for adding new patchsets without bumping the revision for all the
185 old ebuilds as well.
186
187*ruby-1.9.2_rc2 (14 Jul 2010)
188
189 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
190 +ruby-1.9.2_rc2.ebuild:
191 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
192 might cause _further_ build failures as it changed slightly behaviour.
193 You're going to need to rebuild rubygems and then all the packages
194 previously installed after upgrading to this.
195
196 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
197 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
198 -ruby-1.9.1_p376.ebuild:
199 Cleanup old versions.
200
201*ruby-1.9.1_p429 (04 Jul 2010)
202
203 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
204 +ruby-1.9.1_p429.ebuild:
205 Version bump to new 1.9.1 release.
206
207*ruby-1.8.7_p299 (23 Jun 2010)
208
209 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
210 +ruby-1.8.7_p299.ebuild:
211 Version bump.
212
213 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
214 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
215 remove useless comments
216
217 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
218 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
219 ruby-1.9.1_p376.ebuild:
220 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
221 dev.gentoo.org now.
222
223 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
224 ruby-1.9.1_p376.ebuild:
225 Use the correct RUBYLIB.
226
227*ruby-1.8.7_p249-r2 (18 May 2010)
228*ruby-1.8.6_p388-r1 (18 May 2010)
229
230 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
231 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
232 ruby-1.9.1_p376.ebuild, metadata.xml:
233 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
234 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
235 add USE flags for ncurses, readline and libedit, and properly depend on
236 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
237 Emacs versions support ruby-mode themselves and it should be even more
238 updated.
239
240*ruby-1.8.7_p249-r1 (06 May 2010)
241
242 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
243 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
244 309789 by Sune Kloppenborg Jeppesen.
245
246 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
247 ruby-1.8.7_p249.ebuild:
248 Use $PVR instead of $PV in patchset names
249
250 06 May 2010; Alex Legler <a3li@gentoo.org>
251 -files/ruby-1.8.6-memory-leak.diff,
252 -files/ruby18-mkmf-parallel-install.patch,
253 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
254 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
255 Remove old version. Cleanup in files/
256
257*ruby-1.9.1_p376 (01 May 2010)
258
259 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
260 Version bump. Fixes security bugs 296052 and 300468. No longer installs
261 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
262 instead.
263
264 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
265 -ruby-1.8.7_p174-r1.ebuild:
266 Remove vulnerable ebuilds, 300468
267
268 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
269 ruby-1.8.7_p249.ebuild:
270 amd64 stable, security bug 300468
271
272 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
273 ruby-1.8.7_p249.ebuild:
274 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
275
276 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
277 Stable for HPPA (bug #300468).
278
279 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
280 Stable for HPPA (bug #300468).
281
282 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
283 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
284
285 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
286 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
287
288 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
289 ruby-1.8.6_p388.ebuild:
290 stable x86, security bug 300468
291
292 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
293 ruby-1.8.7_p249.ebuild:
294 stable x86, security bug 300468
295
296*ruby-1.8.6_p388 (10 Jan 2010)
297
298 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
299 +ruby-1.8.6_p388.ebuild:
300 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
301 version. The new ebuild also has the fix for bug 168939.
302
303*ruby-1.8.7_p249 (10 Jan 2010)
304
305 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
306 +ruby-1.8.7_p249.ebuild:
307 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
308 version
309
310 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
311 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
312
313*ruby-1.8.7_p248 (25 Dec 2009)
314
315 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
316 Version bump
317
318 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
319 Remove old version.
320
321 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
322 Remove old version.
323
324 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
325 ia64/s390/sh stable wrt #288699
326
327 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
328 stable sparc, bug 288699
329
330 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
331 arm stable, bug #288699
332
333 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
334 amd64/x86 stable, bug #288699
335
336 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
337 ruby-1.8.7_p174-r1.ebuild:
338 Stable on alpha, bug #288699
339
340 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
341 ppc stable #288699
342
343 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
344 Stable for HPPA (bug #288699).
345
346 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
347 Marked ~hppa too.
348
349*ruby-1.8.7_p174-r1 (06 Oct 2009)
350
351 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
352 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
353 eselect-ruby cleanup feature.
354
355*ruby-1.9.1_p243 (09 Sep 2009)
356
357 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
358 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
359 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
360 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
361 -files/ruby19-rubygems-proxy.patch,
362 -files/ruby-1.9.1_p129-parallelmake.patch,
363 -files/ruby19-mkmf-parallel-install.patch:
364 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
365 168939. Cleaning up old patches.
366
367*ruby-1.8.6_p383 (20 Aug 2009)
368
369 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
370 Patchlevel bump.
371
372 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
373 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
374 ruby-1.9.1_p129-r1.ebuild:
375 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
376
377 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
378 Removing vulnerable ebuild, bug 273213.
379
380 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
381 Marking ruby-1.8.6_p369 ppc for bug 273213
382
383 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
384 ruby-1.9.1_p129-r1.ebuild:
385 Prepend our library path instead of overwriting it during src_install.
386 Thanks to the reporter of bug #274824.
387
388*ruby-1.8.7_p174 (18 Jun 2009)
389
390 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
391 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
392 Replacing 187_p173 with _p174 because of a regression. Unifying the
393 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
394 patchsets.
395
396 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
397 Marking ruby-1.8.6_p369 ppc64 for bug 273213
398
399 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
400 arm/ia64/s390/sh/sparc stable wrt #273213
401
402 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
403 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
404 Removing old version, minor cleanup
405
406 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
407 -files/ruby-1.8.6-openssl.patch,
408 -files/ruby-1.8.6-shortname_constants.patch,
409 -files/ruby-1.8.6_p111-r13657.patch,
410 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
411 Removing vulnerable old Ruby version and stale patches, bug 274108.
412
413 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
414 ruby-1.8.6_p369.ebuild:
415 Stable on alpha, bug #273213
416
417 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
418 Stable for HPPA (bug #273213).
419
420 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
421 ruby-1.8.6_p369.ebuild:
422 stable x86, security bug 273213
423
424 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
425 amd64 stable, security bug 273213.
426
427*ruby-1.8.7_p173 (10 Jun 2009)
428*ruby-1.8.6_p369 (10 Jun 2009)
429
430 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
431 +ruby-1.8.7_p173.ebuild:
432 Version bumps for bug #273213.
433
434*ruby-1.9.1_p129-r1 (27 May 2009)
435
436 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
437 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
438 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
439 +files/ruby-1.9.1_p129-parallelmake.patch:
440 Revision bump, add patches 1) to make Ruby behave more similarly between
441 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
442 extensions (undefined symbols in them will cause abort at runtime 3) to
443 remove a concurrency issue when building the dl extension that could
444 result in a broken dl.so.
445
446 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
447 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
448 Don't block rdoc-2 or later (which may enter Portage one day as it's
449 needed by some Rakefiles).
450
451 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
452 ruby-1.9.1_p129.ebuild:
453 Add ~x86-fbsd keyword.
454
455 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
456 keyword ~sparc-fbsd, bug #252315
457
458*ruby-1.9.1_p129 (15 May 2009)
459
460 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
461 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
462 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
463 included in every release.
464
465 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
466 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
467 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
468 ruby-1.8.7_p160.ebuild:
469 Removing vulnerable versions (#268515), fixing license (#233747).
470
471 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
472 Stable for HPPA (bug #268515).
473
474 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
475 Adapting rubygems notice.
4 476
5 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild: 477 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
6 amd64 stable, bug #268515. 478 amd64 stable, bug #268515.
7 479
8 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild: 480 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:

Legend:
Removed from v.1.397  
changed lines
  Added in v.1.503

  ViewVC Help
Powered by ViewVC 1.1.20