/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.397 Revision 1.512
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.397 2009/05/08 17:06:43 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.512 2011/10/22 12:07:43 armin76 Exp $
4
5 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
6 alpha/ia64/s390/sh/sparc stable wrt #386369
7
8*ruby-1.9.3_rc1 (22 Oct 2011)
9
10 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
11 Version bump.
12
13 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
14 arm stable, bug #386369
15
16 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
17 x86 stable, bug 386369
18
19 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
20 Stable for HPPA (bug #386369).
21
22 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
23 ppc/ppc64 stable wrt #386369
24
25 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
26 Stable on amd64 wrt bug #386369
27
28 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
29 Remove vulnerable version, bug 386369.
30
31*ruby-1.8.7_p352 (30 Aug 2011)
32
33 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
34 +ruby-1.8.7_p352.ebuild:
35 Patchlevel bump for ruby:1.8. Removing old version
36
37*ruby-1.9.2_p290 (30 Aug 2011)
38
39 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
40 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
41 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
42 old patchlevels.
43
44 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
45 ruby-1.8.7_p334-r2.ebuild:
46 ppc/ppc64 stable wrt #378691
47
48*ruby-1.8.7_p334-r2 (22 Jul 2011)
49
50 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
51 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
52 for chasing down upstream and us.
53
54 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
55 Added ~mips, bug 332593
56
57 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
58 ruby-1.8.7_p334-r1.ebuild:
59 ppc64 stable wrt #369141
60
61 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
62 ia64/s390/sh/sparc stable wrt #369141
63
64 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
65 Stable for HPPA (bug #369141).
66
67 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
68 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
69
70 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
71 arm/x86 stable, bug #369141
72
73 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
74 Stable on amd64 wrt bug #369141
75
76 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
77 ruby-1.8.7_p334-r1.ebuild:
78 Stable on alpha, bug #369141
79
80*ruby-1.8.7_p334-r1 (31 May 2011)
81
82 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
83 Revision bump for security bug 369141 (CVE-2011-0188)
84
85*ruby-1.9.2-r1 (16 May 2011)
86
87 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
88 Don't remove racc files since all other ruby targets ship these files
89 themselves as well. Closes bug 363419.
90
91 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
92 ruby-1.8.7_p334.ebuild:
93 Remove old version. Remove obsolete and unused old-style virtual/ruby.
94
95 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
96 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
97
98 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
99 Add append-flags -mieee on sh, bug #357559
100
101 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
102 alpha/arm/ia64/s390/sh stable wrt #355439
103
104 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
105 Marked ~ppc64 wrt #332593
106
107 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
108 ruby-1.8.7_p334.ebuild:
109 x86 stable wrt security bug #355439
110
111 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
112 ruby-1.8.7_p334.ebuild:
113 ppc/ppc64 stable wrt #355439
114
115 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
116 Stable on amd64 wrt bug #355439
117
118 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
119 Stable for HPPA (bug #355439).
120
121*ruby-1.8.7_p334 (19 Feb 2011)
122
123 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
124 Version bump 1.8.7 series, security bug 355439
125
126 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
127 ruby-1.9.2.ebuild:
128 Remove PROVIDE for old-style virtual/ruby per bug 265054.
129
130 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
131 Remove masked ruby 1.8.6 per bug 332597.
132
133 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
134 -ruby-1.9.2_rc2.ebuild:
135 Removing old and vulnerable ebuilds
136
137 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
138 Marking ruby-1.8.7_p302 ppc64 for bug 332957
139
140 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
141 alpha/ia64/s390/sh/sparc stable wrt #332957
142
143*ruby-1.9.2 (24 Aug 2010)
144
145 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
146 metadata.xml:
147 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
148 and x86-fbsd due to a new dependency on rdoc.
149
150 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
151 arm stable, bug #332957
152
153 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
154 ruby-1.8.7_p302.ebuild:
155 x86 stable wrt security bug #332957
156
157 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
158 Stable on amd64 wrt bug #332957
159
160 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
161 Stable for PPC (bug #332957).
162
163 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
164 Stable for HPPA (bug #332957).
165
166*ruby-1.8.7_p302 (21 Aug 2010)
167
168 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
169 +ruby-1.8.7_p302.ebuild:
170 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
171 installation path.
172
173*ruby-1.8.6_p399 (19 Aug 2010)
174
175 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
176 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
177 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
178 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
179 installation path (reported by the x86 team in bug 332597)
180
181*ruby-1.9.2_rc2-r1 (18 Aug 2010)
182
183 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
184 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
185 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
186 the rubygems loading code. Add USE flag for psych.
187
188 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
189 ruby-1.9.2_rc2.ebuild:
190 Remove two keepdir that will try to keep an empty path, closes bug
191 #333163.
192
193 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
194 Marked ~ppc (bug #332593).
195
196 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
197 ruby-1.9.2_rc2.ebuild:
198 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
199
200 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
201 ruby-1.8.7_p299.ebuild:
202 Bump eselect-ruby dependency
203
204 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
205 -ruby-1.9.1_p429.ebuild:
206 Remove ebuild that is not target for unmask anyway.
207
208 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
209 ruby-1.9.2_rc2.ebuild:
210 Try 2 to fix the berkdb 5 issue on 1.9.
211
212 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
213 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
214 ruby-1.9.2_rc2.ebuild:
215 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
216 support for adding new patchsets without bumping the revision for all the
217 old ebuilds as well.
218
219*ruby-1.9.2_rc2 (14 Jul 2010)
220
221 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
222 +ruby-1.9.2_rc2.ebuild:
223 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
224 might cause _further_ build failures as it changed slightly behaviour.
225 You're going to need to rebuild rubygems and then all the packages
226 previously installed after upgrading to this.
227
228 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
229 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
230 -ruby-1.9.1_p376.ebuild:
231 Cleanup old versions.
232
233*ruby-1.9.1_p429 (04 Jul 2010)
234
235 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
236 +ruby-1.9.1_p429.ebuild:
237 Version bump to new 1.9.1 release.
238
239*ruby-1.8.7_p299 (23 Jun 2010)
240
241 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
242 +ruby-1.8.7_p299.ebuild:
243 Version bump.
244
245 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
246 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
247 remove useless comments
248
249 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
250 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
251 ruby-1.9.1_p376.ebuild:
252 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
253 dev.gentoo.org now.
254
255 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
256 ruby-1.9.1_p376.ebuild:
257 Use the correct RUBYLIB.
258
259*ruby-1.8.7_p249-r2 (18 May 2010)
260*ruby-1.8.6_p388-r1 (18 May 2010)
261
262 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
263 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
264 ruby-1.9.1_p376.ebuild, metadata.xml:
265 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
266 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
267 add USE flags for ncurses, readline and libedit, and properly depend on
268 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
269 Emacs versions support ruby-mode themselves and it should be even more
270 updated.
271
272*ruby-1.8.7_p249-r1 (06 May 2010)
273
274 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
275 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
276 309789 by Sune Kloppenborg Jeppesen.
277
278 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
279 ruby-1.8.7_p249.ebuild:
280 Use $PVR instead of $PV in patchset names
281
282 06 May 2010; Alex Legler <a3li@gentoo.org>
283 -files/ruby-1.8.6-memory-leak.diff,
284 -files/ruby18-mkmf-parallel-install.patch,
285 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
286 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
287 Remove old version. Cleanup in files/
288
289*ruby-1.9.1_p376 (01 May 2010)
290
291 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
292 Version bump. Fixes security bugs 296052 and 300468. No longer installs
293 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
294 instead.
295
296 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
297 -ruby-1.8.7_p174-r1.ebuild:
298 Remove vulnerable ebuilds, 300468
299
300 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
301 ruby-1.8.7_p249.ebuild:
302 amd64 stable, security bug 300468
303
304 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
305 ruby-1.8.7_p249.ebuild:
306 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
307
308 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
309 Stable for HPPA (bug #300468).
310
311 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
312 Stable for HPPA (bug #300468).
313
314 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
315 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
316
317 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
318 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
319
320 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
321 ruby-1.8.6_p388.ebuild:
322 stable x86, security bug 300468
323
324 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
325 ruby-1.8.7_p249.ebuild:
326 stable x86, security bug 300468
327
328*ruby-1.8.6_p388 (10 Jan 2010)
329
330 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
331 +ruby-1.8.6_p388.ebuild:
332 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
333 version. The new ebuild also has the fix for bug 168939.
334
335*ruby-1.8.7_p249 (10 Jan 2010)
336
337 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
338 +ruby-1.8.7_p249.ebuild:
339 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
340 version
341
342 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
343 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
344
345*ruby-1.8.7_p248 (25 Dec 2009)
346
347 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
348 Version bump
349
350 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
351 Remove old version.
352
353 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
354 Remove old version.
355
356 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
357 ia64/s390/sh stable wrt #288699
358
359 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
360 stable sparc, bug 288699
361
362 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
363 arm stable, bug #288699
364
365 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
366 amd64/x86 stable, bug #288699
367
368 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
369 ruby-1.8.7_p174-r1.ebuild:
370 Stable on alpha, bug #288699
371
372 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
373 ppc stable #288699
374
375 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
376 Stable for HPPA (bug #288699).
377
378 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
379 Marked ~hppa too.
380
381*ruby-1.8.7_p174-r1 (06 Oct 2009)
382
383 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
384 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
385 eselect-ruby cleanup feature.
386
387*ruby-1.9.1_p243 (09 Sep 2009)
388
389 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
390 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
391 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
392 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
393 -files/ruby19-rubygems-proxy.patch,
394 -files/ruby-1.9.1_p129-parallelmake.patch,
395 -files/ruby19-mkmf-parallel-install.patch:
396 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
397 168939. Cleaning up old patches.
398
399*ruby-1.8.6_p383 (20 Aug 2009)
400
401 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
402 Patchlevel bump.
403
404 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
405 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
406 ruby-1.9.1_p129-r1.ebuild:
407 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
408
409 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
410 Removing vulnerable ebuild, bug 273213.
411
412 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
413 Marking ruby-1.8.6_p369 ppc for bug 273213
414
415 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
416 ruby-1.9.1_p129-r1.ebuild:
417 Prepend our library path instead of overwriting it during src_install.
418 Thanks to the reporter of bug #274824.
419
420*ruby-1.8.7_p174 (18 Jun 2009)
421
422 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
423 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
424 Replacing 187_p173 with _p174 because of a regression. Unifying the
425 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
426 patchsets.
427
428 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
429 Marking ruby-1.8.6_p369 ppc64 for bug 273213
430
431 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
432 arm/ia64/s390/sh/sparc stable wrt #273213
433
434 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
435 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
436 Removing old version, minor cleanup
437
438 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
439 -files/ruby-1.8.6-openssl.patch,
440 -files/ruby-1.8.6-shortname_constants.patch,
441 -files/ruby-1.8.6_p111-r13657.patch,
442 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
443 Removing vulnerable old Ruby version and stale patches, bug 274108.
444
445 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
446 ruby-1.8.6_p369.ebuild:
447 Stable on alpha, bug #273213
448
449 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
450 Stable for HPPA (bug #273213).
451
452 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
453 ruby-1.8.6_p369.ebuild:
454 stable x86, security bug 273213
455
456 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
457 amd64 stable, security bug 273213.
458
459*ruby-1.8.7_p173 (10 Jun 2009)
460*ruby-1.8.6_p369 (10 Jun 2009)
461
462 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
463 +ruby-1.8.7_p173.ebuild:
464 Version bumps for bug #273213.
465
466*ruby-1.9.1_p129-r1 (27 May 2009)
467
468 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
469 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
470 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
471 +files/ruby-1.9.1_p129-parallelmake.patch:
472 Revision bump, add patches 1) to make Ruby behave more similarly between
473 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
474 extensions (undefined symbols in them will cause abort at runtime 3) to
475 remove a concurrency issue when building the dl extension that could
476 result in a broken dl.so.
477
478 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
479 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
480 Don't block rdoc-2 or later (which may enter Portage one day as it's
481 needed by some Rakefiles).
482
483 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
484 ruby-1.9.1_p129.ebuild:
485 Add ~x86-fbsd keyword.
486
487 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
488 keyword ~sparc-fbsd, bug #252315
489
490*ruby-1.9.1_p129 (15 May 2009)
491
492 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
493 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
494 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
495 included in every release.
496
497 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
498 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
499 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
500 ruby-1.8.7_p160.ebuild:
501 Removing vulnerable versions (#268515), fixing license (#233747).
502
503 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
504 Stable for HPPA (bug #268515).
505
506 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
507 Adapting rubygems notice.
4 508
5 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild: 509 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
6 amd64 stable, bug #268515. 510 amd64 stable, bug #268515.
7 511
8 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild: 512 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:

Legend:
Removed from v.1.397  
changed lines
  Added in v.1.512

  ViewVC Help
Powered by ViewVC 1.1.20