/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.397 Revision 1.517
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.397 2009/05/08 17:06:43 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.517 2011/12/28 07:57:49 graaff Exp $
4
5 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
6 Block older versions of packages that are no longer compatible. Remove
7 ancient blocks on packags long gone from the tree.
8
9 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
10 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
11 Remove old versions.
12
13*ruby-1.9.3_p0 (18 Dec 2011)
14
15 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
16 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
17 suite which need to be diagnosed first.
18
19 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
20 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
21 #332593).
22
23 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
24 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
25 #332593).
26
27 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
28 alpha/ia64/s390/sh/sparc stable wrt #386369
29
30*ruby-1.9.3_rc1 (22 Oct 2011)
31
32 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
33 Version bump.
34
35 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
36 arm stable, bug #386369
37
38 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
39 x86 stable, bug 386369
40
41 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
42 Stable for HPPA (bug #386369).
43
44 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
45 ppc/ppc64 stable wrt #386369
46
47 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
48 Stable on amd64 wrt bug #386369
49
50 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
51 Remove vulnerable version, bug 386369.
52
53*ruby-1.8.7_p352 (30 Aug 2011)
54
55 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
56 +ruby-1.8.7_p352.ebuild:
57 Patchlevel bump for ruby:1.8. Removing old version
58
59*ruby-1.9.2_p290 (30 Aug 2011)
60
61 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
62 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
63 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
64 old patchlevels.
65
66 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
67 ruby-1.8.7_p334-r2.ebuild:
68 ppc/ppc64 stable wrt #378691
69
70*ruby-1.8.7_p334-r2 (22 Jul 2011)
71
72 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
73 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
74 for chasing down upstream and us.
75
76 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
77 Added ~mips, bug 332593
78
79 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
80 ruby-1.8.7_p334-r1.ebuild:
81 ppc64 stable wrt #369141
82
83 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
84 ia64/s390/sh/sparc stable wrt #369141
85
86 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
87 Stable for HPPA (bug #369141).
88
89 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
90 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
91
92 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
93 arm/x86 stable, bug #369141
94
95 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
96 Stable on amd64 wrt bug #369141
97
98 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
99 ruby-1.8.7_p334-r1.ebuild:
100 Stable on alpha, bug #369141
101
102*ruby-1.8.7_p334-r1 (31 May 2011)
103
104 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
105 Revision bump for security bug 369141 (CVE-2011-0188)
106
107*ruby-1.9.2-r1 (16 May 2011)
108
109 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
110 Don't remove racc files since all other ruby targets ship these files
111 themselves as well. Closes bug 363419.
112
113 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
114 ruby-1.8.7_p334.ebuild:
115 Remove old version. Remove obsolete and unused old-style virtual/ruby.
116
117 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
118 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
119
120 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
121 Add append-flags -mieee on sh, bug #357559
122
123 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
124 alpha/arm/ia64/s390/sh stable wrt #355439
125
126 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
127 Marked ~ppc64 wrt #332593
128
129 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
130 ruby-1.8.7_p334.ebuild:
131 x86 stable wrt security bug #355439
132
133 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
134 ruby-1.8.7_p334.ebuild:
135 ppc/ppc64 stable wrt #355439
136
137 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
138 Stable on amd64 wrt bug #355439
139
140 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
141 Stable for HPPA (bug #355439).
142
143*ruby-1.8.7_p334 (19 Feb 2011)
144
145 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
146 Version bump 1.8.7 series, security bug 355439
147
148 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
149 ruby-1.9.2.ebuild:
150 Remove PROVIDE for old-style virtual/ruby per bug 265054.
151
152 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
153 Remove masked ruby 1.8.6 per bug 332597.
154
155 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
156 -ruby-1.9.2_rc2.ebuild:
157 Removing old and vulnerable ebuilds
158
159 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
160 Marking ruby-1.8.7_p302 ppc64 for bug 332957
161
162 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
163 alpha/ia64/s390/sh/sparc stable wrt #332957
164
165*ruby-1.9.2 (24 Aug 2010)
166
167 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
168 metadata.xml:
169 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
170 and x86-fbsd due to a new dependency on rdoc.
171
172 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
173 arm stable, bug #332957
174
175 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
176 ruby-1.8.7_p302.ebuild:
177 x86 stable wrt security bug #332957
178
179 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
180 Stable on amd64 wrt bug #332957
181
182 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
183 Stable for PPC (bug #332957).
184
185 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
186 Stable for HPPA (bug #332957).
187
188*ruby-1.8.7_p302 (21 Aug 2010)
189
190 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
191 +ruby-1.8.7_p302.ebuild:
192 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
193 installation path.
194
195*ruby-1.8.6_p399 (19 Aug 2010)
196
197 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
198 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
199 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
200 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
201 installation path (reported by the x86 team in bug 332597)
202
203*ruby-1.9.2_rc2-r1 (18 Aug 2010)
204
205 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
206 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
207 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
208 the rubygems loading code. Add USE flag for psych.
209
210 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
211 ruby-1.9.2_rc2.ebuild:
212 Remove two keepdir that will try to keep an empty path, closes bug
213 #333163.
214
215 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
216 Marked ~ppc (bug #332593).
217
218 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
219 ruby-1.9.2_rc2.ebuild:
220 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
221
222 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
223 ruby-1.8.7_p299.ebuild:
224 Bump eselect-ruby dependency
225
226 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
227 -ruby-1.9.1_p429.ebuild:
228 Remove ebuild that is not target for unmask anyway.
229
230 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
231 ruby-1.9.2_rc2.ebuild:
232 Try 2 to fix the berkdb 5 issue on 1.9.
233
234 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
235 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
236 ruby-1.9.2_rc2.ebuild:
237 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
238 support for adding new patchsets without bumping the revision for all the
239 old ebuilds as well.
240
241*ruby-1.9.2_rc2 (14 Jul 2010)
242
243 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
244 +ruby-1.9.2_rc2.ebuild:
245 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
246 might cause _further_ build failures as it changed slightly behaviour.
247 You're going to need to rebuild rubygems and then all the packages
248 previously installed after upgrading to this.
249
250 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
251 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
252 -ruby-1.9.1_p376.ebuild:
253 Cleanup old versions.
254
255*ruby-1.9.1_p429 (04 Jul 2010)
256
257 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
258 +ruby-1.9.1_p429.ebuild:
259 Version bump to new 1.9.1 release.
260
261*ruby-1.8.7_p299 (23 Jun 2010)
262
263 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
264 +ruby-1.8.7_p299.ebuild:
265 Version bump.
266
267 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
268 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
269 remove useless comments
270
271 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
272 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
273 ruby-1.9.1_p376.ebuild:
274 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
275 dev.gentoo.org now.
276
277 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
278 ruby-1.9.1_p376.ebuild:
279 Use the correct RUBYLIB.
280
281*ruby-1.8.7_p249-r2 (18 May 2010)
282*ruby-1.8.6_p388-r1 (18 May 2010)
283
284 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
286 ruby-1.9.1_p376.ebuild, metadata.xml:
287 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
288 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
289 add USE flags for ncurses, readline and libedit, and properly depend on
290 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
291 Emacs versions support ruby-mode themselves and it should be even more
292 updated.
293
294*ruby-1.8.7_p249-r1 (06 May 2010)
295
296 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
297 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
298 309789 by Sune Kloppenborg Jeppesen.
299
300 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
301 ruby-1.8.7_p249.ebuild:
302 Use $PVR instead of $PV in patchset names
303
304 06 May 2010; Alex Legler <a3li@gentoo.org>
305 -files/ruby-1.8.6-memory-leak.diff,
306 -files/ruby18-mkmf-parallel-install.patch,
307 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
308 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
309 Remove old version. Cleanup in files/
310
311*ruby-1.9.1_p376 (01 May 2010)
312
313 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
314 Version bump. Fixes security bugs 296052 and 300468. No longer installs
315 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
316 instead.
317
318 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
319 -ruby-1.8.7_p174-r1.ebuild:
320 Remove vulnerable ebuilds, 300468
321
322 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
323 ruby-1.8.7_p249.ebuild:
324 amd64 stable, security bug 300468
325
326 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
327 ruby-1.8.7_p249.ebuild:
328 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
329
330 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
331 Stable for HPPA (bug #300468).
332
333 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
334 Stable for HPPA (bug #300468).
335
336 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
337 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
338
339 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
340 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
341
342 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
343 ruby-1.8.6_p388.ebuild:
344 stable x86, security bug 300468
345
346 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
347 ruby-1.8.7_p249.ebuild:
348 stable x86, security bug 300468
349
350*ruby-1.8.6_p388 (10 Jan 2010)
351
352 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
353 +ruby-1.8.6_p388.ebuild:
354 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
355 version. The new ebuild also has the fix for bug 168939.
356
357*ruby-1.8.7_p249 (10 Jan 2010)
358
359 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
360 +ruby-1.8.7_p249.ebuild:
361 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
362 version
363
364 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
365 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
366
367*ruby-1.8.7_p248 (25 Dec 2009)
368
369 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
370 Version bump
371
372 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
373 Remove old version.
374
375 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
376 Remove old version.
377
378 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
379 ia64/s390/sh stable wrt #288699
380
381 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
382 stable sparc, bug 288699
383
384 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
385 arm stable, bug #288699
386
387 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
388 amd64/x86 stable, bug #288699
389
390 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
391 ruby-1.8.7_p174-r1.ebuild:
392 Stable on alpha, bug #288699
393
394 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
395 ppc stable #288699
396
397 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
398 Stable for HPPA (bug #288699).
399
400 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
401 Marked ~hppa too.
402
403*ruby-1.8.7_p174-r1 (06 Oct 2009)
404
405 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
406 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
407 eselect-ruby cleanup feature.
408
409*ruby-1.9.1_p243 (09 Sep 2009)
410
411 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
412 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
413 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
414 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
415 -files/ruby19-rubygems-proxy.patch,
416 -files/ruby-1.9.1_p129-parallelmake.patch,
417 -files/ruby19-mkmf-parallel-install.patch:
418 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
419 168939. Cleaning up old patches.
420
421*ruby-1.8.6_p383 (20 Aug 2009)
422
423 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
424 Patchlevel bump.
425
426 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
427 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
428 ruby-1.9.1_p129-r1.ebuild:
429 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
430
431 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
432 Removing vulnerable ebuild, bug 273213.
433
434 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
435 Marking ruby-1.8.6_p369 ppc for bug 273213
436
437 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
438 ruby-1.9.1_p129-r1.ebuild:
439 Prepend our library path instead of overwriting it during src_install.
440 Thanks to the reporter of bug #274824.
441
442*ruby-1.8.7_p174 (18 Jun 2009)
443
444 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
445 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
446 Replacing 187_p173 with _p174 because of a regression. Unifying the
447 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
448 patchsets.
449
450 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
451 Marking ruby-1.8.6_p369 ppc64 for bug 273213
452
453 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
454 arm/ia64/s390/sh/sparc stable wrt #273213
455
456 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
457 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
458 Removing old version, minor cleanup
459
460 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
461 -files/ruby-1.8.6-openssl.patch,
462 -files/ruby-1.8.6-shortname_constants.patch,
463 -files/ruby-1.8.6_p111-r13657.patch,
464 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
465 Removing vulnerable old Ruby version and stale patches, bug 274108.
466
467 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
468 ruby-1.8.6_p369.ebuild:
469 Stable on alpha, bug #273213
470
471 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
472 Stable for HPPA (bug #273213).
473
474 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
475 ruby-1.8.6_p369.ebuild:
476 stable x86, security bug 273213
477
478 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
479 amd64 stable, security bug 273213.
480
481*ruby-1.8.7_p173 (10 Jun 2009)
482*ruby-1.8.6_p369 (10 Jun 2009)
483
484 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
485 +ruby-1.8.7_p173.ebuild:
486 Version bumps for bug #273213.
487
488*ruby-1.9.1_p129-r1 (27 May 2009)
489
490 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
491 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
492 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
493 +files/ruby-1.9.1_p129-parallelmake.patch:
494 Revision bump, add patches 1) to make Ruby behave more similarly between
495 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
496 extensions (undefined symbols in them will cause abort at runtime 3) to
497 remove a concurrency issue when building the dl extension that could
498 result in a broken dl.so.
499
500 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
501 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
502 Don't block rdoc-2 or later (which may enter Portage one day as it's
503 needed by some Rakefiles).
504
505 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
506 ruby-1.9.1_p129.ebuild:
507 Add ~x86-fbsd keyword.
508
509 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
510 keyword ~sparc-fbsd, bug #252315
511
512*ruby-1.9.1_p129 (15 May 2009)
513
514 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
515 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
516 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
517 included in every release.
518
519 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
520 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
521 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
522 ruby-1.8.7_p160.ebuild:
523 Removing vulnerable versions (#268515), fixing license (#233747).
524
525 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
526 Stable for HPPA (bug #268515).
527
528 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
529 Adapting rubygems notice.
4 530
5 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild: 531 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
6 amd64 stable, bug #268515. 532 amd64 stable, bug #268515.
7 533
8 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild: 534 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:

Legend:
Removed from v.1.397  
changed lines
  Added in v.1.517

  ViewVC Help
Powered by ViewVC 1.1.20