/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.430 Revision 1.523
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.430 2009/12/15 19:30:25 armin76 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.523 2011/12/29 20:28:31 halcy0n Exp $
4
5 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
6 Stable for ppc/ppc64; bug #396301
7
8 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
9 Marked ~hppa (bug #332593).
10
11 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
12 Add back ~alpha keyword now that rubygems is keyworded.
13
14 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
15 Stable for AMD64, wrt security bug #396301
16
17*ruby-1.8.7_p357 (28 Dec 2011)
18
19 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
20 Version bump for security bug 396301.
21
22 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
23 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
24
25 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
26 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
27 keyworded, bug 332593.
28
29 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
30 Block older versions of packages that are no longer compatible. Remove
31 ancient blocks on packags long gone from the tree.
32
33 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
34 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
35 Remove old versions.
36
37*ruby-1.9.3_p0 (18 Dec 2011)
38
39 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
40 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
41 suite which need to be diagnosed first.
42
43 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
44 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
45 #332593).
46
47 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
48 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
49 #332593).
50
51 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
52 alpha/ia64/s390/sh/sparc stable wrt #386369
53
54*ruby-1.9.3_rc1 (22 Oct 2011)
55
56 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
57 Version bump.
58
59 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
60 arm stable, bug #386369
61
62 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
63 x86 stable, bug 386369
64
65 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
66 Stable for HPPA (bug #386369).
67
68 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
69 ppc/ppc64 stable wrt #386369
70
71 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
72 Stable on amd64 wrt bug #386369
73
74 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
75 Remove vulnerable version, bug 386369.
76
77*ruby-1.8.7_p352 (30 Aug 2011)
78
79 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
80 +ruby-1.8.7_p352.ebuild:
81 Patchlevel bump for ruby:1.8. Removing old version
82
83*ruby-1.9.2_p290 (30 Aug 2011)
84
85 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
86 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
87 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
88 old patchlevels.
89
90 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
91 ruby-1.8.7_p334-r2.ebuild:
92 ppc/ppc64 stable wrt #378691
93
94*ruby-1.8.7_p334-r2 (22 Jul 2011)
95
96 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
97 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
98 for chasing down upstream and us.
99
100 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
101 Added ~mips, bug 332593
102
103 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
104 ruby-1.8.7_p334-r1.ebuild:
105 ppc64 stable wrt #369141
106
107 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
108 ia64/s390/sh/sparc stable wrt #369141
109
110 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
111 Stable for HPPA (bug #369141).
112
113 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
114 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
115
116 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
117 arm/x86 stable, bug #369141
118
119 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
120 Stable on amd64 wrt bug #369141
121
122 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
123 ruby-1.8.7_p334-r1.ebuild:
124 Stable on alpha, bug #369141
125
126*ruby-1.8.7_p334-r1 (31 May 2011)
127
128 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
129 Revision bump for security bug 369141 (CVE-2011-0188)
130
131*ruby-1.9.2-r1 (16 May 2011)
132
133 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
134 Don't remove racc files since all other ruby targets ship these files
135 themselves as well. Closes bug 363419.
136
137 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
138 ruby-1.8.7_p334.ebuild:
139 Remove old version. Remove obsolete and unused old-style virtual/ruby.
140
141 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
142 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
143
144 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
145 Add append-flags -mieee on sh, bug #357559
146
147 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
148 alpha/arm/ia64/s390/sh stable wrt #355439
149
150 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
151 Marked ~ppc64 wrt #332593
152
153 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
154 ruby-1.8.7_p334.ebuild:
155 x86 stable wrt security bug #355439
156
157 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
158 ruby-1.8.7_p334.ebuild:
159 ppc/ppc64 stable wrt #355439
160
161 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
162 Stable on amd64 wrt bug #355439
163
164 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
165 Stable for HPPA (bug #355439).
166
167*ruby-1.8.7_p334 (19 Feb 2011)
168
169 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
170 Version bump 1.8.7 series, security bug 355439
171
172 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
173 ruby-1.9.2.ebuild:
174 Remove PROVIDE for old-style virtual/ruby per bug 265054.
175
176 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
177 Remove masked ruby 1.8.6 per bug 332597.
178
179 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
180 -ruby-1.9.2_rc2.ebuild:
181 Removing old and vulnerable ebuilds
182
183 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
184 Marking ruby-1.8.7_p302 ppc64 for bug 332957
185
186 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
187 alpha/ia64/s390/sh/sparc stable wrt #332957
188
189*ruby-1.9.2 (24 Aug 2010)
190
191 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
192 metadata.xml:
193 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
194 and x86-fbsd due to a new dependency on rdoc.
195
196 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
197 arm stable, bug #332957
198
199 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
200 ruby-1.8.7_p302.ebuild:
201 x86 stable wrt security bug #332957
202
203 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
204 Stable on amd64 wrt bug #332957
205
206 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
207 Stable for PPC (bug #332957).
208
209 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
210 Stable for HPPA (bug #332957).
211
212*ruby-1.8.7_p302 (21 Aug 2010)
213
214 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
215 +ruby-1.8.7_p302.ebuild:
216 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
217 installation path.
218
219*ruby-1.8.6_p399 (19 Aug 2010)
220
221 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
222 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
223 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
224 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
225 installation path (reported by the x86 team in bug 332597)
226
227*ruby-1.9.2_rc2-r1 (18 Aug 2010)
228
229 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
230 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
231 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
232 the rubygems loading code. Add USE flag for psych.
233
234 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
235 ruby-1.9.2_rc2.ebuild:
236 Remove two keepdir that will try to keep an empty path, closes bug
237 #333163.
238
239 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
240 Marked ~ppc (bug #332593).
241
242 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
243 ruby-1.9.2_rc2.ebuild:
244 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
245
246 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
247 ruby-1.8.7_p299.ebuild:
248 Bump eselect-ruby dependency
249
250 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
251 -ruby-1.9.1_p429.ebuild:
252 Remove ebuild that is not target for unmask anyway.
253
254 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
255 ruby-1.9.2_rc2.ebuild:
256 Try 2 to fix the berkdb 5 issue on 1.9.
257
258 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
259 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
260 ruby-1.9.2_rc2.ebuild:
261 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
262 support for adding new patchsets without bumping the revision for all the
263 old ebuilds as well.
264
265*ruby-1.9.2_rc2 (14 Jul 2010)
266
267 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
268 +ruby-1.9.2_rc2.ebuild:
269 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
270 might cause _further_ build failures as it changed slightly behaviour.
271 You're going to need to rebuild rubygems and then all the packages
272 previously installed after upgrading to this.
273
274 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
275 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
276 -ruby-1.9.1_p376.ebuild:
277 Cleanup old versions.
278
279*ruby-1.9.1_p429 (04 Jul 2010)
280
281 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
282 +ruby-1.9.1_p429.ebuild:
283 Version bump to new 1.9.1 release.
284
285*ruby-1.8.7_p299 (23 Jun 2010)
286
287 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
288 +ruby-1.8.7_p299.ebuild:
289 Version bump.
290
291 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
292 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
293 remove useless comments
294
295 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
296 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
297 ruby-1.9.1_p376.ebuild:
298 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
299 dev.gentoo.org now.
300
301 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
302 ruby-1.9.1_p376.ebuild:
303 Use the correct RUBYLIB.
304
305*ruby-1.8.7_p249-r2 (18 May 2010)
306*ruby-1.8.6_p388-r1 (18 May 2010)
307
308 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
309 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
310 ruby-1.9.1_p376.ebuild, metadata.xml:
311 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
312 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
313 add USE flags for ncurses, readline and libedit, and properly depend on
314 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
315 Emacs versions support ruby-mode themselves and it should be even more
316 updated.
317
318*ruby-1.8.7_p249-r1 (06 May 2010)
319
320 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
321 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
322 309789 by Sune Kloppenborg Jeppesen.
323
324 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
325 ruby-1.8.7_p249.ebuild:
326 Use $PVR instead of $PV in patchset names
327
328 06 May 2010; Alex Legler <a3li@gentoo.org>
329 -files/ruby-1.8.6-memory-leak.diff,
330 -files/ruby18-mkmf-parallel-install.patch,
331 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
332 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
333 Remove old version. Cleanup in files/
334
335*ruby-1.9.1_p376 (01 May 2010)
336
337 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
338 Version bump. Fixes security bugs 296052 and 300468. No longer installs
339 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
340 instead.
341
342 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
343 -ruby-1.8.7_p174-r1.ebuild:
344 Remove vulnerable ebuilds, 300468
345
346 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
347 ruby-1.8.7_p249.ebuild:
348 amd64 stable, security bug 300468
349
350 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
351 ruby-1.8.7_p249.ebuild:
352 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
353
354 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
355 Stable for HPPA (bug #300468).
356
357 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
358 Stable for HPPA (bug #300468).
359
360 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
361 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
362
363 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
364 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
365
366 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
367 ruby-1.8.6_p388.ebuild:
368 stable x86, security bug 300468
369
370 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
371 ruby-1.8.7_p249.ebuild:
372 stable x86, security bug 300468
373
374*ruby-1.8.6_p388 (10 Jan 2010)
375
376 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
377 +ruby-1.8.6_p388.ebuild:
378 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
379 version. The new ebuild also has the fix for bug 168939.
380
381*ruby-1.8.7_p249 (10 Jan 2010)
382
383 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
384 +ruby-1.8.7_p249.ebuild:
385 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
386 version
387
388 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
389 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
390
391*ruby-1.8.7_p248 (25 Dec 2009)
392
393 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
394 Version bump
395
396 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
397 Remove old version.
398
399 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
400 Remove old version.
4 401
5 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild: 402 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
6 ia64/s390/sh stable wrt #288699 403 ia64/s390/sh stable wrt #288699
7 404
8 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild: 405 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:

Legend:
Removed from v.1.430  
changed lines
  Added in v.1.523

  ViewVC Help
Powered by ViewVC 1.1.20