/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.170
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.170 2012/03/02 18:23:33 pesa Exp $
4
5 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
6 Don't enable QtAssistant module because it was removed in qt-4.7 and we
7 already depend on 4.7.2 or later.
8
9 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
10 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
11 Restrict pypy for older versions too.
12
13 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
14 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
15 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
16 version.
17
18 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
19 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
20 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
21 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
22 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
23 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
24
25 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
26 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
27 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
28 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
29 Fixing pypy restricts to actually work
30
31*PyQt4-4.9.1 (12 Feb 2012)
32
33 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
34 version bump
35
36 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
37 builds with qt-opengl-4.8.0[egl], updated dep
38
39 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
40 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
41 Fixes backported from Progress Overlay. Patch by Arfrever.
42
43*PyQt4-4.9 (24 Dec 2011)
44
45 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
46 Version bump
47
48*PyQt4-4.8.6 (11 Nov 2011)
49
50 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
51 Version bump
52
53 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
54 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
55 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
56 python overlay.
57
58*PyQt4-4.8.5 (19 Aug 2011)
59
60 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
61 Version bump
62
63 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
64 ppc/ppc64 stable wrt #374591
65
66 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
67 x86 stable, bug #374591
68
69 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
70 ppc64 stable wrt #354033
71
72 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
73 Stable on amd64 wrt bug #374591
74
75 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
76 Marking PyQt4-4.8.3 ppc stable for bug 354033
77
78 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
79 Stable on amd64 wrt bug #354033
80
81 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
82 x86 stable per bug 354033
83
84*PyQt4-4.8.4 (02 May 2011)
85
86 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
87 +PyQt4-4.8.4.ebuild:
88 Version bump.
89
90 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
91 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
92 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
93 Adapt phonon dependency for package move
94
95 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
96 ppc64 stable wrt #349607
97
98 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
99 ia64/sparc stable wrt #349607
100
101 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
102 Stable on alpha, bug #349607
103
104 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
105 PyQt4-4.8.3.ebuild:
106 Update dependencies (bug #353053).
107
108*PyQt4-4.8.3 (25 Jan 2011)
109
110 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
111 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
112 Version bump.
113
114 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
115 x86 stable wrt bug #349607
116
117 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
118 Marking PyQt4-4.8.1 ppc stable for bug 349607
119
120 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
121 Stable on amd64 wrt bug #349607
122
123 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
124 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
125 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
126
127*PyQt4-4.8.1-r1 (30 Dec 2010)
128
129 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
130 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
131 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
132
133 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
134 PyQt4-4.8.2.ebuild:
135 Fix dependencies (bug #349672).
136
137*PyQt4-4.8.2 (24 Dec 2010)
138
139 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
140 +PyQt4-4.8.2.ebuild:
141 Version bump.
142
143 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
144 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
145 Restrict Jython ABIs.
146
147 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
148 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
149 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
150 -files/configure.py.patch:
151 Delete.
152
153 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
154 old, depends on qt 4.5
155
156 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
157 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
158 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
159 Remove HPPA keywording (bug #239441).
160
161*PyQt4-4.8.1 (30 Oct 2010)
162
163 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
164 +PyQt4-4.8.1.ebuild:
165 Version bump.
166
167 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
168 ia64/sparc stable wrt #315775
169
170*PyQt4-4.8 (23 Oct 2010)
171
172 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
173 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
174 +PyQt4-4.8.ebuild, metadata.xml:
175 Version bump.
176
177*PyQt4-4.7.7-r1 (06 Oct 2010)
178
179 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
180 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
181 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
182
183*PyQt4-4.7.7 (21 Sep 2010)
184
185 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
186 +PyQt4-4.7.7.ebuild:
187 Version bump. Remove old bogus version
188
189 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
190 Stable on alpha, bug #315775
191
192 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
193 Marked ppc stable for bug #315775.
194
195 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
196 PyQt4-4.7.6.ebuild:
197 Update EAPI. Fix dependencies.
198
199*PyQt4-4.7.6 (08 Sep 2010)
200
201 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
202 +PyQt4-4.7.6.ebuild:
203 Version bump. Remove old ebuild
204
205 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
206 PyQt4-4.7.5.ebuild:
207 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
208
209*PyQt4-4.7.5 (01 Sep 2010)
210
211 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
212 +PyQt4-4.7.5.ebuild:
213 Version bump
214
215 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
216 Stable for HPPA (bug #315775).
217
218 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
219 Bump sip dependency to 4.10.3. Fix arm epatch command
220
221*PyQt4-4.7.4 (13 Jul 2010)
222
223 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
224 Version bump
225
226 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
227 ppc64 stable wrt #315775
228
229 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
230 +files/PyQt4-4.7.3-qreal_float_support.patch:
231 Add patch for qreal/float support in ARM wrt bug 322349
232
233 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
234 x86 stable wrt bug 315775
235
236 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
237 Stable on amd64 wrt bug 315775
238
239 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
240 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
241 Fix sip dep in PyQt4 ebuilds
242
243*PyQt4-4.7.3 (17 Apr 2010)
244
245 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
246 Version bump
247
248 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
249 ppc stable #301105
250
251*PyQt4-4.7.2 (18 Mar 2010)
252
253 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
254 +files/PyQt4-4.7.2-configure.py.patch:
255 Version bump. ChangeLog is no longer shipped. Update patch.
256
257 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
258 stable x86, bug 301105
259
260 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
261 amd64 stable wrt #301105
4 262
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 263 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 264 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 265 -files/fix_license_check.patch:
8 Drop old patches 266 Drop old patches

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.170

  ViewVC Help
Powered by ViewVC 1.1.20